Einleitung
In diesem Dokument wird beschrieben, wie Lizenzzuweisungen vom CSSM-Portal bereinigt werden, wenn die tatsächliche Zuweisungsanzahl von vManage nicht übereinstimmt.
Problem
Zwischen der vManage-Instanz und dem Cisco Smart Software Manager (CSSM)-Portal kann es zu einer Lizenzungleichheit kommen. Dies kann sich in einer falschen Anzahl von Lizenzen äußern, da die Lizenzen nach dem Löschen des Geräts nicht freigegeben werden.
Symptome
- Die Lizenzanzahl in vManage und im CSSM-Portal ist unterschiedlich.
- Gelöschte Geräte in vManage geben ihre zugewiesenen Lizenzen nicht in CSSM frei, was zu einem Mangel an verfügbaren Lizenzen führt.
- Doppelte Lizenzberichte in CSSM (alte und neue Berichte zusammenfassend).
- Verdächtige schlagen einige dieser Fehler: Cisco Bug-ID CSCwj27435 oder Cisco Bug-ID CSCwm39910
- Fehlermeldungen in der Admin-Tech-Datei "vManage" var/log/nms/vmanage-server.log ähnlich:
[vmanage-0] [SmartLicensingManager || SmartLicense: Failed to report license usage for tenant default : Exception: {"product_instance_identifier":["The identity for the instance is not valid.Please re-register the instance."]}
Beispiel:
Wie Sie in vManage sehen, sind 298 Geräte und insgesamt 300 Lizenzen lizenziert.

Im Lizenzportal zeigte sich jedoch, dass 598 Lizenzen genutzt werden. Sie meldet eine doppelte Anzahl von Lizenzen, die verwendet wurden (300 + 298 = 598), 300 Lizenzen vor Aufhebung der Zuweisung und 298 Lizenzen nach Aufhebung der Zuweisung.

Ursache
Als Hauptursache wurden veraltete Lizenzeinträge in der vManage-Datenbank und möglicherweise falsche Smart Agent Tenant-Komponenteninformationen ermittelt. Dies verhinderte eine genaue Berichterstellung und Synchronisierung mit dem CSSM-Portal.
Lösung
Um die vManage-Synchronisierung mit dem CSSM-Portal zu reaktivieren, müssen Sie ein TAC-Ticket öffnen, um Unterstützung für die in den BUGs dokumentierte Problemumgehung anzufordern.
Wenn jedoch nur ein Problem mit der Diskrepanz zwischen Nutzung und verfügbaren Lizenzen im CSSM-Portal auftritt, können Sie die aktuellen Lizenzzuweisungen löschen und warten, bis vManage den neuen Bericht generiert.
Kontostand über Cisco Central Portal (CSSM) bereinigen
Für diesen Schritt ist in der Regel die Zusammenarbeit mit dem Cisco Lizenzierungsteam erforderlich, wenn Sie nicht über die erforderlichen Berechtigungen zum Entfernen doppelter oder falscher Berichte verfügen.
- Navigieren Sie im Cisco Software Portal zu Smart Software Manager > Manage Licenses > Wählen Sie Ihr Smart and Virtual Account > Inventory > Licenses (Smart- und virtuelles Konto verwalten > Bestand > Lizenzen), und klicken Sie auf die Lizenz.

- Navigieren Sie zu Produktinstanzen, und klicken Sie auf die Instanz.


- Entfernen Sie dann die Lizenznutzung...

- Nun sehen Sie den Zähler Lizenzen unter Verwendung 0 und alle verfügbaren Lizenzen.
Synchronisieren von Lizenzen in vManage
Starten Sie nach der Bereinigung des Portals eine Lizenz-Synchronisierung von vManage aus.
Warten Sie mindestens 24 Stunden, bis vManage erneut mit dem CSSM-Portal synchronisiert wird.