Einleitung
In diesem Dokument wird beschrieben, wie Sie die Ursache identifizieren und Fehler beheben, während Sie die Terminplanung mit dem Hybrid-Kalender für Cloud-Geräte im Control Hub von Google aktivieren.
Voraussetzungen
Anforderungen
Cisco empfiehlt, dass Sie über Kenntnisse in folgenden Bereichen verfügen:
- Eine WebEx-Organisation.
- WebEx Hybrid-Kalender.
- Google Workspace-Verwaltungskonsole.
Verwendete Komponenten
Die Informationen in diesem Dokument basierend auf folgenden Software- und Hardware-Versionen:
- WebEx Control Hub Build 20240919-84b27c9
- Google Workspace Business Starter oder höher
- Chrome-Browser 129.0.6668.58 (offizieller Build) (arm64)
Die Informationen in diesem Dokument beziehen sich auf Geräte in einer speziell eingerichteten Testumgebung. Alle Geräte, die in diesem Dokument benutzt wurden, begannen mit einer gelöschten (Nichterfüllungs) Konfiguration. Wenn Ihr Netzwerk in Betrieb ist, stellen Sie sicher, dass Sie die möglichen Auswirkungen aller Befehle kennen.
Hintergrund
Die Aktivierung des Hybrid Calendar (Scheduling) mit Google erfordert eine Überprüfung der E-Mail-Adressen durch das CSDM, das Atlas bei der Verwaltung der Geräteregistrierung und -aktivierung unterstützt.
Control Hub-Fehler
Fügen Sie im Control Hub > Management > Workspaces die Option "Scheduling" für einen Workspace hinzu, nachdem Sie auf die Schaltfläche "Validieren" geklickt haben. Die Fehlermeldung "Ein unbekannter Validierungsfehler ist aufgetreten. Wenn dieser Fehler auch nach wiederholten Versuchen auftritt, wenden Sie sich an den Support."
Google-Fehler
Protokolle werden gesammelt
Steuerungs-Hub
Über eine Browser-Registerkarte, vorzugsweise mit Inkognito. Wenn Sie Chrome verwenden, öffnen Sie DevTools > Network; für FireFox Web Developer Tools > Network. Gehen Sie zu admin.webex.com > Management > Workspaces > Planung. Wählen Sie Kalender-Anbieter und fügen Sie E-Mail-Adresse, klicken Sie auf Validieren.
HTTP-Inspektion
Fehlermeldung
{"status":403,"errorMessage":"Email validation failed: null","valid":false}
Validierung
Google APIs-Explorer
Rufen Sie den Google APIs Explorer auf, wählen Sie GET als HTTP-Anforderungsmethode aus, und führen Sie eine Abfrage mit der folgenden URL aus:
https://admin.googleapis.com/admin/directory/v1/customer/{customer}/resources/calendars/{calendarResourceId}
Google-API
Vorsicht: customerId und calendarResourceId sind Pflichtfelder. Weitere Hinweise zum Abrufen finden Sie unter.
Ursache
WebEx Cloud-Geräte müssen über gültige E-Mail-Adressen verfügen, die mit dem Google-Ressourcenformat "@resource.calendar.google.com" übereinstimmen.
Lösung
Von Google Workspace Admin > Verzeichnis > Gebäude und Ressourcen > Ressourcen verwalten bestätigen E-Mail-Feld Ressource.
Google-Ressource
Im Control Hub verwendete E-Mail-Adresse
c_1888af8kmnb1ojo6nu3drhdg01pa@resource.calendar.google.com
E-Mail-Adresse in Google Admin
c_1888af8kmnb1ojo6nu3drhdg01pau@resource.calendar.google.com
Fügen Sie Ressourcen-E-Mails zu Scheduling > Email address hinzu, und klicken Sie auf Validate. Eine 200-API-Antwort bestätigt die Änderung und klickt dann auf Speichern.
200 OK
Arbeitsbereich erfolgreich für Hybrid-Kalender mit Google aktiviert.
Angewandte Konfiguration
Kalender aktiviert
Fehlercodes
400 Ungültige Anforderung |
Ungültiges E-Mail-Format für Ressource |
403 Verboten |
Enthält ungültige Daten |
Zugehörige Informationen