Guest

Cisco IOS Software Releases 12.2 T

OSPF Nonstop Forwarding (NSF) Awareness

Table Of Contents

OSPF Nonstop Forwarding (NSF) Awareness

Contents

Information About OSPF NSF Awareness

Benefits of OSPF NSF Awareness

How to Control OSPF NSF Awareness

Setting the OSPF Resynchronization Timeout Timer

Prerequisites

Disabling OSPF NSF Awareness

Configuration Examples for OSPF NSF Awareness

Setting OSPF Resynchronization Timeout Example

Displaying OSPF Neighbor NSF Information

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

capability lls

ip ospf resync-timeout

show ip ospf neighbor


OSPF Nonstop Forwarding (NSF) Awareness


The OSPF Nonstop Forwarding (NSF) Awareness feature allows customer premises equipment (CPE) routers that are NSF-aware to help NSF-capable routers perform nonstop forwarding of packets.

Feature Specifications for the OSPF NSF Awareness Feature

Feature History
 
Release
Modification

12.2(15)T

This feature was introduced.

Supported Platforms

For information about platforms supported, refer to Cisco Feature Navigator.


Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Information About OSPF NSF Awareness

How to Control OSPF NSF Awareness

Additional References

Command Reference

Information About OSPF NSF Awareness

The following concept describes the OSPF NSF Awareness feature:

Benefits of OSPF NSF Awareness

Benefits of OSPF NSF Awareness

The OSPF Nonstop Forwarding (NSF) Awareness feature allows customer premise equipment (CPE) routers that are NSF-aware to help NSF-capable routers perform nonstop forwarding of packets. The awareness feature is part of the software code; it need not be configured.

The local router is not necessarily performing NSF; its awareness of NSF allows the integrity and accuracy of the RIB and link state database occurring on the neighboring NSF-capable router to be maintained during the switchover process.

How to Control OSPF NSF Awareness

OSPF NSF awareness is a feature that is part of the system's software code and need not be specifically enabled. However, there are a few optional tasks related to OSPF NSF awareness. This section contains the following tasks:

Setting the OSPF Resynchronization Timeout Timer (optional)

Disabling OSPF NSF Awareness (optional)

Displaying OSPF Neighbor NSF Information (optional)

Setting the OSPF Resynchronization Timeout Timer

The user can configure a timer that sets the out-of-band resynchronization timer, which is a optional task described in this section.

Prerequisites

This task presumes that OSPF is already configured before you configure the out-of-band resynchronization timer. It also presumes that the local router is a neighbor to a router that is NSF-capable.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip ospf resync-timeout seconds

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface ethernet 0

Configures the interface type and number.

Step 4 

ip ospf resync-timeout seconds

Example:

Router(config-if)# ip ospf resync-timeout 60

Configures how long the router will wait before taking a neighbor adjacency down if the out-of-band resynchronization has not taken place since the time a restart signal was received from the neighbor.

The default is 40 seconds or the value of the OSPF dead interval, whichever is greater.

Step 5 

end

Example:

Router(config-if)# end

Exits the configuration mode and returns to privileged EXEC mode.

Disabling OSPF NSF Awareness

OSPF NSF awareness is enabled by default. You might want to disable NSF awareness by disabling the use of the Link-Local Signalling (LLS) data block in originated OSPF packets. You might want to disable NSF awareness if the router has no applications using LLS. Disabling NSF awareness is described in this section.

SUMMARY STEPS

1. enable

2. configure terminal

3. router ospf process-id

4. no capability lls

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables higher privilege levels, such as privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router ospf process-id

Router(config)# router ospf 1

Enables OSPF routing and enters router configuration mode.

The process-id argument identifies the OSPF process.

Step 4 

no capability lls

Example:

Router(config-router)# no capability lls

Disables the use of the LLS data block and NSF awareness.

Step 5 

end

Example:

Router(config-router)# end

Exits the configuration mode and returns to privileged EXEC mode.

Configuration Examples for OSPF NSF Awareness

This section provides the following configuration examples:

Setting OSPF Resynchronization Timeout Example

Displaying OSPF Neighbor NSF Information

Setting OSPF Resynchronization Timeout Example

This example configures a 60-second resync timeout for OSPF on Ethernet interface 1:

interface ethernet 0
 ip address 10.93.1.1 255.255.255.0
 ip ospf cost 1
!
interface ethernet 1
 ip address 10.94.1.1 255.255.255.0
 ip ospf resync-timeout 60

Displaying OSPF Neighbor NSF Information

You can issue the show ip ospf neighbor detail command and display a new line of output about an NSF-capable neighbor. The command displays the last successful out-of-band resynchronization with the NSF-capable router.

This document presumes that OSPF is configured and that the local router has a neighbor that is NSF-capable.

The following is sample output from the show ip ospf neighbor detail command. The bold line is the new output about the NSF-capable neighbor, which indicates Link-local Signaling and Out-of-band (oob) link-state database resynchronization was performed hours:minutes:seconds ago. The command displays the last successful out-of-band resynchronization with the NSF-capable router.

Router> show ip ospf neighbor detail
Neighbor 192.168.5.2, interface address 10.225.200.28
    In the area 0 via interface GigabitEthernet1/0/0
    Neighbor priority is 1, State is FULL, 6 state changes
    DR is 10.225.200.28 BDR is 10.225.200.30
    Options is 0x42
    LLS Options is 0x1 (LR), last OOB-Resync 00:03:08 ago
    Dead timer due in 00:00:36
    Neighbor is up for 00:09:46
   Index 1/1, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec

Additional References

For additional information related to NSF and OSPF, see the following sections:

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Related Documents

Related Topic
Document Title

Nonstop forwarding

Cisco Nonstop Forwarding with Stateful Switchover

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s22/nsf120s.htm

Configuring OSPF

Cisco IOS IP Configuration Guide, Release 12.2

OSPF commands

Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To obtain lists of supported MIBs by platform and Cisco IOS release, and to download MIB modules, go to the Cisco MIB website on Cisco.com at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml


To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://tools.cisco.com/ITDIT/MIBS/servlet/index

If Cisco  MIB Locator does not support the MIB information that you need, you can also obtain a list of supported MIBs and download MIBs from the Cisco  MIBs page at the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

To access Cisco MIB Locator, you must have an account on Cisco.com. If you have forgotten or lost your account information, send a blank e-mail to cco-locksmith@cisco.com. An automatic check will verify that your e-mail address is registered with Cisco.com. If the check is successful, account details with a new random password will be e-mailed to you. Qualified users can establish an account on Cisco.com by following the directions found at this URL:

http://www.cisco.com/register

RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, tools, and lots more. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/public/support/tac/home.shtml


Command Reference

This section documents the following new and modified commands. All other commands used with this feature are documented in the Cisco IOS Release 12.2 T command reference publications.

New Commands

capability lls

ip ospf resync-timeout

Modified Command

show ip ospf neighbor

capability lls

To enable the use of the Link-Local Signalling (LLS) data block in originated OSPF packets and reenable OSPF nonstop forwarding (NSF) awareness, use the capability lls command in router configuration mode. To disable LLS and OSPF NSF awareness, use the no form of this command.

capability lls

no capability lls

Syntax Description

This command has no arguments or keywords.

Defaults

LLS is enabled.

Command Modes

Router configuration

Command History

Release
Modification

12.2(15)T

This command was introduced.


Usage Guidelines

You might want to disable NSF awareness by disabling the use of the Link-Local Signalling (LLS) data block in originated OSPF packets. You might want to disable NSF awareness if the router has no applications using LLS.

If NSF is configured and you try to disable LLS, you will receive the error message, "OSPF Non-Stop Forwarding (NSF) must be disabled first."

If LLS is disabled and you try to configure NSF, you will receive the error message, "OSPF Link-Local Signaling (LLS) capability must be enabled first."

Examples

The following example disables LLS support and OSPF NSF awareness:

router ospf 2
 no capability lls

ip ospf resync-timeout

To configure how long the router will wait before taking a neighbor adjacency down if the out-of-band resynchronization (oob-resync) has not taken place since the time a restart signal (OSPF Hello packet with RS-bit set) was received from the neighbor, use the ip ospf resync-timeout command in interface configuration mode. To restore the default value, use the no form of this command.

ip ospf resync-timeout seconds

no ip ospf resync-timeout

Syntax Description

seconds

Number of seconds the router will wait before taking a neighbor adjacency down if the out-of-band resynchronization (oob-resync) has not taken place since the time a restart signal (OSPF Hello packet with RS-bit set) was received from the neighbor. The value is in the range from 1 to 65535 seconds. The default value is 40 seconds or the value set for the OSPF dead interval for the interface, whichever is greater.


Defaults

The default value is 40 seconds or the value set for the interface's OSPF dead interval, whichever is greater.

Command Modes

Interface configuration

Command History

Release
Modification

12.2(15)T

This command was introduced.


Usage Guidelines

When an OSPF nonstop forwarding (NSF) router performs a route processor (RP) switchover, it notifies its neighbors, via a special Hello packet, of such action and requests that each neighbor help resynchronize the Link State Database.

When a neighbor (that is NSF-aware) receives the special Hello packet from the NSF-capable router, it starts a resync timeout timer and waits to synchronize its database with the NSF-capable router. If the NSF-capable router does not initiate the database resynchronization process before the resync-timeout timer expires, the NSF-aware neighbor will take down the adjacency with the NSF-capable router.

By default, the resync-timeout timer is set to 40 seconds or the dead interval of the interface, whichever is greater. (By default, the dead interval is 4 times the hello interval; the hello interval defaults to 10 seconds for Ethernet or 30 seconds for nonbroadcast.) The ip ospf resync-timeout command allows the resync-timeout to be changed and independent of the dead interval or default value.

Examples

This example sets the OSPF resync-timeout interval to 50 seconds: 

interface GigabitEthernet 6/0/0
 ip ospf resync-timeout 50

Related Commands

Command
Description

ip ospf dead-interval

Sets the interval at which hello packets must not be seen before neighbors declare the router down.

ip ospf hello-interval

Sets the interval between hello packets that the software sends on the interface.


show ip ospf neighbor

To display OSPF-neighbor information on a per-interface basis, use the show ip ospf neighbor command in EXEC mode.

show ip ospf neighbor [interface-type interface-number] [neighbor-id] [detail]

Syntax Description

interface-type

(Optional) Interface type.

interface-number

(Optional) Interface number.

neighbor-id

(Optional) Neighbor ID.

detail

(Optional) Displays all neighbors given in detail (lists all neighbors).


Command Modes

EXEC

Command History

Release
Modification

10.0

This command was introduced.


Examples

The following is sample output from the show ip ospf neighbor command showing a single line of summary information for each neighbor:

Router# show ip ospf neighbor

   ID          Pri   State        Dead Time     Address         Interface
10.199.199.137  1    FULL/DR       0:00:31    192.168.80.37      Ethernet0
172.16.48.1     1    FULL/DROTHER  0:00:33    172.16.48.1        Fddi0
172.16.48.200   1    FULL/DROTHER  0:00:33    172.16.48.200      Fddi0
10.199.199.137  5    FULL/DR       0:00:33    172.16.48.189      Fddi0

The following is sample output showing summary information about the neighbor that matches the neighbor ID:

Router# show ip ospf neighbor 10.199.199.137
Neighbor 10.199.199.137, interface address 192.168.80.37
    In the area 0.0.0.0 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 0:00:32
    Link State retransmission due in 0:00:04
 Neighbor 10.199.199.137, interface address 172.16.48.189
    In the area 0.0.0.0 via interface Fddi0
    Neighbor priority is 5, State is FULL
    Options 2
    Dead timer due in 0:00:32
    Link State retransmission due in 0:00:03

If you specify the interface along with the neighbor ID, the system displays the neighbors that match the neighbor ID on the interface, as in the following sample display:

Router# show ip ospf neighbor ethernet 0 10.199.199.137
Neighbor 10.199.199.137, interface address 192.168.80.37
    In the area 0.0.0.0 via interface Ethernet0
    Neighbor priority is 1, State is FULL
    Options 2
    Dead timer due in 0:00:37
    Link State retransmission due in 0:00:04

You can also specify the interface without the neighbor ID to show all neighbors on the specified interface, as in the following sample display:

Router# show ip ospf neighbor fddi 0

   ID          Pri   State        Dead Time     Address         Interface
172.16.48.1     1    FULL/DROTHER  0:00:33    172.16.48.1       Fddi0
172.16.48.200   1    FULL/DROTHER  0:00:32    172.16.48.200     Fddi0
10.199.199.137  5    FULL/DR       0:00:32    172.16.48.189     Fddi0

The following is sample output from the show ip ospf neighbor detail command:

Router# show ip ospf neighbor detail
Neighbor 192.168.5.2, interface address 10.225.200.28
    In the area 0 via interface GigabitEthernet1/0/0
    Neighbor priority is 1, State is FULL, 6 state changes
    DR is 10.225.200.28 BDR is 10.225.200.30
    Options is 0x42
    LLS Options is 0x1 (LR), last OOB-Resync 00:03:08 ago
    Dead timer due in 00:00:36
    Neighbor is up for 00:09:46
   Index 1/1, retransmission queue length 0, number of retransmission 1
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 1, maximum is 1
    Last retransmission scan time is 0 msec, maximum is 0 msec

Table 1 describes the significant fields shown in the displays.

Table 1 show ip ospf neighbor detail Field Descriptions 

Field
Description

Neighbor

Neighbor router ID.

interface address

IP address of the interface.

In the area

Area and interface through which the OSPF neighbor is known.

Neighbor priority

Router priority of the neighbor, neighbor state.

State

OSPF state.

state changes

Number of state changes since the neighbor was created.This value can be reset using the clear ip ospf counters neighbor command.

DR is

Router ID of the designated router for the interface.

BDR is

Router ID of the backup designated router for the interface.

Options

Hello packet options field contents. (E-bit only. Possible values are 0 and 2; 2 indicates area is not a stub; 0 indicates area is a stub.)

LLS Options ..., last OOB-Resync

Link-Local Signalling and out-of-band (OOB) link-state database resynchronization performed hours:minutes:seconds ago (NSF information). The field indicates the last successful out-of-band resynchronization with the NSF-capable router.

Dead timer due in

Expected time before Cisco IOS software will declare the neighbor dead.

Neighbor is up for

Number of hours:minutes:seconds since the neighbor went into two-way state.

Index

Neighbor location in the area-wide and autonomous system-wide retransmission queue.

retransmission queue length

Number of elements in the retransmission queue.

number of retransmission

Number of times update packets have been re-sent during flooding.

First

Memory location of the flooding details.

Next

Memory location of the flooding details.

Last retransmission scan length

Number of link state advertisements (LSAs) in the last retransmission packet.

maximum

Maximum number of LSAs sent in any retransmission packet.

Last retransmission scan time

Time taken to build last retransmission packet.

maximum

Maximum time taken to build any retransmission packet.