Guest

Cisco PGW 2200 Softswitch

MGCP Dial Provisioning Examples

  • Viewing Options

  • PDF (353.6 KB)
  • Feedback
Provisioning Examples for PGW 2200 Softswitch and AS5x00 Gateways

Table Of Contents

Provisioning Examples for PGW 2200 Softswitch and AS5x00 Gateways

MGCP Dial Provisioning Examples

Cisco PGW 2200 Softswitch MGCP Dial Provisioning Examples

NAS Provisioning Examples

Trace of a Successful Call

Additional Provisioning Examples


Provisioning Examples for PGW 2200 Softswitch and AS5x00 Gateways


Updated March 2003

MGCP Dial Provisioning Examples

This section contains the following MGCP dial provisioning examples:

Cisco PGW 2200 MGCP Dial Provisioning Examples

NAS Provisioning Examples

Cisco PGW 2200 Softswitch MGCP Dial Provisioning Examples

To configure the PGW 2200 Softswitch for MGCP dial, create a result set for MGCP Dial on the PGW 2200. A provisioning example is listed below:

numan-add:resultset:custgrpid="pst1",name="DIAL"
numan-add:resulttable:custgrpid="pst1",name="Terminate",resulttype="MGCPDIALPKG",dw1="Dyna
mic",dw2="1",setname="DIAL"

NAS Provisioning Examples


Note Before you begin, set appropriate IP routing for dial in.



Step 1 Configure Authentication for the Dial In users. A provisioning example is listed below:

aaa new-model
aaa authentication login default local
aaa authentication ppp default local
aaa authorization network default local 
aaa session-id common

Step 2 Set up user locally (or configure RADIUS). A provisioning example is listed below:

username mgcusr password 0 cisco

Step 3 Set extsig mgcp on the controller. A provisioning example is listed below:

controller E1 3/4
 extsig mgcp

Step 4 Set loopback interface to use with group-async.

A provisioning example is listed below:

interface Loopback0
ip address 11.1.1.1 255.255.255.224

Step 5 Set group-async

A provisioning example is listed below:

interface Group-Async0
 ip unnumbered Loopback0
 encapsulation ppp
 no ip mroute-cache
 dialer in-band
 dialer idle-timeout 22222
 dialer-group 1

Note Dialer-group specifies the dialer to use.


 async mode dedicated
 peer default ip address pool pool1
 ppp authentication chap pap
 group-range 1/00 2/107


Note Group-range specifies the lines for the modem.


Step 6 Set the dialer interface

A provisioning example is listed below:

interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 222222
 dialer extsig
 dialer-group 1
 peer default ip address pool pool1
 no cdp enable
 ppp authentication chap pap

Step 7 Set the IP address pool

A provisioning example is listed below:

ip local pool pool1 10.52.162.77 10.52.162.79

Step 8 Add a route to the default gateway.

A provisioning example is listed below:

ip route 0.0.0.0 0.0.0.0 10.52.162.65

Step 9 Set the modems

A provisioning example is listed below:

line 1/00 1/107
 no flush-at-activation
 modem InOut
 transport input all
 autoselect during-login
 autoselect ppp
line 2/00 2/107


Trace of a Successful Call

A successful call trace is listed below:

14:24:55.460446  10.52.166.200:2427   10.52.162.83:2427    MGCP...... -> CRCX 1450 s3/ds1-0/1@as5350-1 
MGCP 0.1
                                                                         C: 9A
                                                                         L: 
e:off,nas/cdn:8740,nas/cgn:384970,nas/bt:modem
                                                                         M: nas/data
                                                                         R: 
G/ft(N),G/mt(N),nas/au(N),nas/ax(N),nas/of(N)
                                                                         S:
                                                                         X: 5A9
14:24:55.465492  10.52.162.83:2427    10.52.166.200:2427   MGCP...... -> 200 1450  Alert
                                                                         I: 63DC344C
14:25:01.980289  10.52.166.200:2427   10.10.13.8:2427      MGCP...... -> AUEP 900082880 
s0/ds1-1/1@as5850-1 MGCP 0.1
14:25:21.081753  10.52.162.83:2427    10.52.166.200:2427   MGCP...... -> NTFY 10 
S3/DS1-0/1@as5350-1(10.52.162.83) MGCP 0.1
                                                                         X: 5A9
                                                                         O: NAS/au
14:25:21.100556  10.52.166.200:2427   10.52.162.83:2427    MGCP...... -> 200 10 OK
                                                                         C: 9A
14:25:21.980312  10.52.166.200:2427   10.10.13.8:2427      MGCP...... -> AUEP 900082900 
s0/ds1-1/1@as5850-1 MGCP 0.1
                                                                         F:
14:25:21.980413  10.52.166.200:2427   10.52.162.83:2427    MGCP...... -> AUEP 900082900 
s3/ds1-7/1@as5350-1 MGCP 0.1
                                                                         F:
14:25:21.981550  10.10.13.8:2427      10.52.166.200:2427   MGCP...... -> 200 900082900 Endpoint exists
14:25:21.982021  10.52.162.83:2427    10.52.166.200:2427   MGCP...... -> 200 900082900 Endpoint exists
14:25:31.980314  10.52.166.200:2427   10.10.13.8:2427      MGCP...... -> AUEP 900082910 
s0/ds1-1/1@as5850-1 MGCP 0.1
                                                                         F:
14:25:31.981682  10.10.13.8:2427      10.52.166.200:2427   MGCP...... -> 200 900082910 Endpoint exists
14:25:38.260467  10.52.166.200:2427   10.52.162.83:2427    MGCP...... -> DLCX 1452 s3/ds1-0/1@as5350-1 
MGCP 0.1
                                                                         C: 9A
                                                                         I: 63DC344C
                                                                         R:
                                                                         S:
                                                                         X: 5AB
14:25:38.263207  10.52.162.83:2427    10.52.166.200:2427   MGCP...... -> 200 1452 OK

Additional Provisioning Examples

View the following application notes for additional provisioning examples:

Provisioning Examples for Cisco PGW 2200 Softswitch

Provisioning Examples for Modem and Fax Passthrough