Guest

Cisco PGW 2200 Softswitch

Enhanced Video Support

  • Viewing Options

  • PDF (293.7 KB)
  • Feedback
Cisco PGW 2200 Softswitch Enhanced Video Support Feature Module

Table Of Contents

Cisco PGW 2200 Softswitch Enhanced Video Support Feature Module

Feature Description

Benefits

Prerequisites

Restrictions or Limitations

Related Features and Technology

Related Documents

Supported Standards, MIBs, and RFCs

Provisioning Tasks

Provisioning Video Call Admission Control

Prohibiting Video Calls on H.323 Trunk Groups

Provisioning Audio and Video Capabilities of DBEs

Provisioning Three-Level Codec Lists (Optional)

Provisioning a Level 1 Codec List

Provisioning a Level 2 Codec List

Provisioning a Level 3 Codec List

Provisioning Media Anchoring

Provisioning Examples

Cisco PGW 2200 Softswitch Provisioning Examples

Sample of a Provisioned Cisco 7600 DBE

Sample of a Provisioned Cisco ASR 1000 series DBE

Cisco Unified Communications Manager Configuring Tips

Software Changes for This Feature

Billing Interface

Modified Billing Interfaces

Properties

New Properties

Result Types

New Result Types

Modified Result Types

Troubleshooting the Feature

Obtaining Documentation and Submitting a Service Request

Glossary


Cisco PGW 2200 Softswitch Enhanced Video Support Feature Module


Document Release History

Publication Date
Comments

December 2009

Updated that the valid values for dataword3 of the CODEC result type are 0 and 1.

June 2009

Initial release of document


Feature History

Release
Modification

9.8(1)

The Enhanced Video Support feature is introduced on the Cisco PGW 2200 Softswitch.


This document describes the Enhanced Video Support feature on the Cisco PGW 2200 Softswitch and includes the following sections:

Feature Description

Provisioning Tasks

Provisioning Examples

Software Changes for This Feature

Troubleshooting the Feature

Obtaining Documentation and Submitting a Service Request

Glossary

Feature Description

The Enhanced Video Support feature expands video capabilities on the Cisco PGW 2200 Softswitch.

Before the introduction of this feature, the Cisco PGW 2200 Softswitch handled Session Initiation Protocol (SIP) video calls in a basic way. You couldn't hold or transfer SIP video calls. You did not have control of media streams for SIP video calls.

With this feature, you have more control of the call setup process for SIP video calls compared to the basic SIP calls. Working together with data border elements (DBEs) (Cisco ASR 1000 series DBE or Cisco 7600 DBE), the Cisco PGW 2200 Softswitch handles SIP video calls more comprehensively:

Strong control of audio and video streams—The Cisco PGW 2200 Softswitch anchors audio and video streams on DBEs (such as Cisco ASR 1000 series DBE and Cisco 7600 DBE). The Cisco PGW 2200 Softswitch, coworking with DBEs, provides the following functions for audio and video traffic:

Virtual private network (VPN) discrimination

Topology hiding

Gate control

Media latching for remote network address translation (NAT) traversal

Delayed-offer to early-offer conversion

Flexibility to control video call admissions—This feature enables you to control video call admissions based on trunk group capabilities or number analysis results.

Video codec negotiation and selection—You can customize video codec capabilities at three levels to affect the codec selection process.

Video call hold, call transfer, and conferencing services—This feature allows you to hold or transfer a video call. You can also use video conferencing services on the Cisco PGW 2200 Softswitch. These mid-call services are available when the Cisco PGW 2200 Softswitch coworks with the Cisco Unified Communications Manager (CUCM) and the Cisco Telepresence Solutions (CTS).

Video call fallback to audio calls—If the Cisco PGW 2200 Softswitch cannot handle a video call due to video codec shortages or other reasons, it converts the video call into an audio call.

Figure 1 shows a typical Cisco PGW 2200 Softswitch deployment in the Cisco TelePresence solution.

In this deployment, the CUCM uses SIP trunks to instruct the Cisco PGW 2200 Softswitch to set up video calls. The Cisco PGW 2200 Softswitch selects the trunk groups and the DBEs (Cisco ASR 1000 series DBE or Cisco 7600 DBE) based on their video capabilities. Then it uses the H.248 protocol to control the selected DBEs. Under instructions from the Cisco PGW 2200 Softswitch, the DBEs manage the Real-time Transport Protocol (RTP) streams that carry audio and video media between two Cisco TelePresence sites.

Figure 1 Typical Cisco PGW 2200 Softswitch Deployment in the Cisco TelePresence Solution

Benefits

The Enhanced Video Support feature broadens the scope of the Cisco PGW 2200 Softswitch product and makes way for its inclusion in video-based solutions, for example, the Cisco Telepresence solution.

Prerequisites

The Cisco PGW 2200 Softswitch must be running software Release 9.8(1). Prerequisites for this release can be found in the Release Notes for the Cisco PGW 2200 Softswitch Release 9.8(1) at

http://www.cisco.com/en/US/docs/voice_ip_comm/pgw/9/release/note/rn981.html

Restrictions or Limitations

The Enhanced Video Support feature has the following limitations:

Cisco PGW 2200 Softswitch supports SIP video calls only. H.323-to-SIP, or H.323-to-H.323 video calls are not supported. You must configure the EISUP profile property, VideoAllowed, to 0 for H.323 trunk groups.

Cisco Voice Switch Service Module (VXSM) gateways cannot support video calls. You cannot make video calls using Cisco VXSM gateways in your network.

The Cisco PGW 2200 Softswitch cannot transport SIP INFO messages for media control through the EISUP interfaces between the two Cisco PGW 2200 Softswitches.

Related Features and Technology

The H.248 Protocol-Phase 2 feature is related to this feature.

The H.248 Protocol-Phase 2 feature introduced audio anchoring for IP-to-IP gateway calls. This feature completes the media anchoring by adding video anchoring.


Note The Cisco PGW 2200 Softswitch supports video anchoring on DBEs.


See the H.248 Protocol-Phase 2 feature module at

http://www.cisco.com/en/US/docs/voice_ip_comm/pgw/9/feature/module/9.8_1_/h248-ph2.html

Related Documents

This document contains information that is strictly related to this feature. The documents that contain additional information related to the Cisco PGW 2200 Softswitch are at

http://www.cisco.com/en/US/products/hw/vcallcon/ps2027/tsd_products_support_series_home.html

Supported Standards, MIBs, and RFCs

Standards

The Enhanced Video Support feature supports the following standards:

ITU-T H.248.1 05-2002—Gateway Control Protocol (Version 2)

ITU-T H.248.1 V2 (2002) 03-2004—Corrigendum 1

ITU-T H.248.2 (Annex F) 1/2000—Facsimile, Text Conversation and Call Discrimination Packages

ITU-T H.248.3 (Annex G) 11/2000—User Interface Elements and Action Packages

ITU-T H.248.3 (2000) 03-2004—Corrigendum 1

ITU-T H.248.4 (Annex H) 11/2000—Transport over Stream Control Transmission Protocol (SCTP)

ITU-T H.248.4 (2000) 03-2004—Corrigendum 1

ITU-T H.248.5 (Annex I) 11/2000—Transport over ATM

ITU-T H.248.6 (Annex J) 11/2000—Dynamic Tone Definition Package

ITU-T H.248.7 (Annex K) 11/2000—Generic Announcement Package (determined text)

ITU-T H.248.8 (Annex L) 11/2000—Error codes and service change reason description

ITU-T H.248.8 (2002) 03/2004—Amendment 1

ITU-T H.248.9 (Annex M1) 01/2005—Advanced Media Server Packages

ITU-T H.248.10 (Annex M2) 07/2001—Media Gateway Resource Congestion Handling Package

ITU-T H.248.12 (Annex M4) 07/2001—H.248 Packages for H.323 and H.324 Interworking

ITU-T H.248.12 11/2002—Amendment 1

ITU-T H.248.13 (Annex M5) 03/2002—Quality Alert Ceasing Package

ITU-T H.248.14 (Annex M6) 03/2002—Inactivity Timer Package

ITU-T H.248.15 (Annex M2) 03/2002—SDP H.248 package attribute

ITU-T H.248.16 11/2002—Enhanced Digit Collection Packages and Procedures

ITU-T H.248.16 (2002) 03-2004—Corrigendum 1

ITU-T H.248.17 11/2002—Line Test Packages

ITU-T H.248.17 (2002) 03/2004—Corrigendum 1

ITU-T H.248.18 11/2002—Package for Support of Multiple Profiles

ITU-T H.248.20 11/2002—The use of local and remote descriptors with H.221/H.223 multiplexing

ITU-T H.248.22 07/2003—Shared Risk Group Package

ITU-T H.248.22 (2003) 01/2004—Erratum 1

ITU-T H.248.23 07/2003—Enhanced Alerting packages

ITU-T H.248.23 (2003) 03/2004—Corrigendum 1

ITU-T H.248.24 07/2003—Multi-frequency tone generation and detection packages

ITU-T H.248.25 07/2003—Basic CAS packages

ITU-T H.248.25 (2003) 03/2004—Corrigendum 1

ITU-T H.248.26 07/2003—Enhanced analogue lines packages

ITU-T H.248.26 (2003) 03/2004—Corrigendum 1

ITU-T H.248.26 (2003) 01/2005—Amendment 1

ITU-T H.248.27 07/2003—Supplemental tones packages

ITU-T H.248.28 03/2004—International CAS packages

ITU-T H.248.29 01/2005—International CAS Compelled Register Signaling Packages

ITU-T H.248.30 03/2004—RTCP extended performance metrics packages

ITU-T H.248.31 04/2004—Adaptive jitter buffer package

ITU-T H.248.32 01/2005—Detailed congestion reporting package

ITU-T H.248.33 01-2005—PCM frame spare bit package

ITU-T H.248.37 09-2005—PCM frame spare bit package

ETSI TS 102 333 V1.1.2 07-2004—Gate control protocol

ETSI TS 283 018 V1.1.1 06-2006—Resource and admission control: H.248 profile for controlling by this feature.

You can find these standards at the ITU website.

http://www.itu.int/ITU-T/

Provisioning Tasks

This section describes the provisioning tasks for this feature.

To use this feature, you need to perform four main tasks:

1. Allow video call on ingress and egress SIP trunk groups and prohibit video calls on H.323 trunk groups.

2. Tell the Cisco PGW 2200 Softswitch the video capabilities on the DBEs that are associated with the SIP trunk groups.

3. Customize the three-level codec lists to affect the codec selection process. (This task is optional.)

4. Enable the audio and video anchoring function. (This function anchors audio and video streams on the DBEs.)

Here are the four main tasks:

Provisioning Video Call Admission Control

Provisioning Audio and Video Capabilities of DBEs

Provisioning Three-Level Codec Lists (Optional)

Provisioning Media Anchoring

For complete provisioning samples, see the "Provisioning Examples" section.

Provisioning Video Call Admission Control

There are two levels of video call admission control, dial plan level and trunk group level. By default, at the two levels, the Cisco PGW 2200 Softswitch allows video calls. No provisioning is needed.

Because the Cisco PGW 2200 Softswitch doesn't handle video calls that originate or end on H.323 trunk groups, you must prohibit video calls on H.323 trunk groups.

Prohibiting Video Calls on H.323 Trunk Groups

You set VideoAllowed to 0 in the EISUP profile for the H.323 trunk group to prohibit video calls.

mml> prov-ed:profile:name="EISUPprofile",videoallowed="0"

Provisioning Audio and Video Capabilities of DBEs

DBEs manage video streams for video calls. On the Cisco PGW 2200 Softswitch, you must indicate whether DBEs support video calls.

A gateway pool contain DBEs. To indicate that a DBE supports video calls, you must set the GatewayVideoSupport property to 1 in the profile of the gateway pool that contains the DBE.

mml> prov-add:PROFILE:NAME="GWPoolprofile",type="gwpoolprofile",
gatewayvideosupport="1"

Provisioning Three-Level Codec Lists (Optional)

The Cisco PGW 2200 Softswitch makes the codec selection on three levels.

The Cisco PGW 2200 Softswitch compares the codec lists that are provisioned at Level 1 (sigPath), Level 2 (trunk group) or Level 3 (dial plan). If there is more than one codec list provisioned, the highest level of codec provisioning is used.

You can customize the preferred audio and video codecs that DBEs use on the three levels. Make sure the codecs that you provision on the three levels are supported by the DBEs.


Note The Cisco PGW 2200 Softswitch does not restrict usage of a certain codec. It is DBEs' codec capabilities that determine whether a certain codec is available for a call.


For details on the three-level codec selection, see the CODEC and DTMF Preferential Routing Enhancements feature module at

http://www.cisco.com/en/US/docs/voice_ip_comm/pgw/9/feature/module/9.7_3_/FMdpL3co.html


Note The three-level audio and video codec selections are not available for mid-calls (calls that are answered).



Note The existing DBEs (Cisco ASR 1000 series DBE or Cisco 7600 DBE) do not support video codec transcoding. If the video codec of the incoming SDP mismatches the DBE video codec that is provisioned on the Cisco PGW 2200 Softswitch, the video call might fail. You can check the DBE video codec provisioning on the Cisco PGW 2200 Softswitch. Make sure your DBE video codec provisioning matches the video codec of the incoming SDP.


Provisioning a Level 1 Codec List

You set the properties, GWDefaultAudioCodecString and GWDefaultVideoCodecString, on the H.248 sigPath to specify the default audio and video codec list for DBEs.

mml> prov-ed:sigsvcprop:name="h248-path",gwdefaultvideocodecstring="H264;H263;H261"
mml> prov-ed:sigsvcprop:name="h248-path",gwdefaultaudiocodecstring="G.711u;G.711a"

Provisioning a Level 2 Codec List

You set the properties, GWDefaultVidecoCodecString and GWDefaultVideoCodecString, in a SIP/EISUP profile to specify the default audio and video codec list for DBEs.

mml> prov-ed:profile:name="SIPprofile",GWDefaultVideoCodecString="H263;H261;H264"
mml> prov-ed:profile:name="SIPprofile",GWDefaultAudioCodecString="G.711u;G.711a" 

Provisioning a Dummy Video Codec List

If you do not provision the Level 2 codec list, you can set the DummyVideoCodecString property in a SIP/EISUP profile. The Cisco PGW 2200 Softswitch uses the dummy video codecs in an H.248 add request when neither a remote SDP nor a local codec is provisioned.

mml> prov-ed:profile:name="SIPprofile",DummyVideoCodecString="H263;H261;H264"
mml> prov-ed:profile:name="SIPprofile",DummyAudioCodecString="G.711u;G.711a"

Provisioning a Level 3 Codec List

You provision the result type CODEC to specify the audio and video codec list on Level 3 (dial plan).

mml> prov-add:codecstring:name="videocodec1",codecstring="H263;H261"
mml> prov-add:codecstring:name="audiocodec1",codecstring="G.711u;G.711a"
mml> numan-add:resulttable:custgrpid="T001",resulttype="CODEC",dw1="videocodec1",dw2="1",
dw3="1",setname="ra1",name="res1"
mml> numan-add:resulttable:custgrpid="T001",resulttype="CODEC",dw1="audiocodec1",dw2="1",
dw3="0",setname="ra1",name="res1"

Provisioning Media Anchoring

To enable the media anchoring, you must set the AnchorMedia and AnchorPolicy properties properly. For details on the two properties, see the H.248 Protocol-Phase 2 feature module at

http://www.cisco.com/en/US/docs/voice_ip_comm/pgw/9/feature/module/9.8_1_/h248-ph2.html

In the following example, you set the AnchorMedia property to 3 (always anchor media on the IP trunk group), and the AnchorPolicy property to 1 (enables the use of the gateway pool on an IP trunk group).

prov-ed:profile:name="SIPprofile",anchormedia="3",anchorpolicy="1"

Provisioning Examples

This section provides the following provisioning examples and tips for this feature:

Cisco PGW 2200 Softswitch Provisioning Examples

Sample of a Provisioned Cisco 7600 DBE

Sample of a Provisioned Cisco ASR 1000 series DBE

Cisco Unified Communications Manager Configuring Tips

Additional provisioning examples for the Cisco PGW 2200 Softswitch can be found in the Cisco PGW 2200 Softswitch Release 9.8 Provisioning Guide.

Cisco PGW 2200 Softswitch Provisioning Examples

________________________________________
; Add the Dial Plan 1111
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-stp
prov-sta::srcver="active",dstver="PGW98videosupport",confirm
numan-add:dialplan:custgrpid="1111",overdec="yes"

________________________________________
; Add the DBE
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:extnode:name="asr-1000",desc="asr1000",type="ASR1000",isdnsigtype="N/A",group=0
prov-add:H248PATH:name="h248-udp-asr1000",desc="service to asr1000",extnode="asr-1000"
prov-add:iplnk:name="h248-asr1000",desc="udp to asr1000",svc="h248-udp-asr1000", 
ipaddr="IP_Addr1",port=2944,peeraddr="33.33.36.1",peerport=2944,pri=1
prov-add:sigsvcprop:name="h248-udp-asr1000",GWProtocolVersion="H248 V2"

________________________________________
; Add the Gateway Pool 
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:PROFILE:NAME="dbe-profile",TYPE="gwpoolprofile",gatewayselectionmethod="1",
GatewayVideoSupport="1"
prov-add:GWPOOL:NAME="104",DESC="gsr",PROFILE="dbe-profile"
prov-add:IPGW:poolid="104",gw="asr-1000"

________________________________________
; Add the Ingress SIP Trunk Group
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:sippath:name="sip-path",mdo="IETF_SIP"
prov-add:siplnk:name="sip-lnk",ipaddr="IP_Addr1",svc="sip-path",port=5060,pri=1
prov-add:trnkgrp:name="888",clli="NULL",svc="sip-path",type="SIP_IN",selseq="LIDL",qable="
N"

________________________________________
; Add the SIP Profile for the Ingress SIP Trunk Group
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:profile:type="SIPPROFILE",name="incoming",custgrpid="1111",gatewaypool="104",
insessiontimer="90",mgcdomain="10.0.49.117"
prov-add:trnkgrpprof:name="888",profile="incoming"

________________________________________
; Provision the SIP Profile for the Ingress SIP Trunk Group
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-ed:profile:name="incoming",videoallowed="1",unsolicitednotifymethod="1",
anchormedia="3",anchorpolicy="1"
prov-ed:profile:name="incoming",gwdefaultaudiocodecstring="G.711u;G.711a"
prov-ed:profile:name="incoming",gwdefaultvideocodecstring="H264;H263;H261"
prov-ed:profile:name="incoming",dummyaudiocodecstring="G.711u;G.711a" 
prov-ed:profile:name="incoming",dummyvideocodecstring="H264;H263;H261"

________________________________________
; Add the Egress SIP Trunk Group
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:trnkgrp:name="5134",clli="NULL",svc="sip-path",type="IP_SIP",selseq="NULL",
qable="N"

________________________________________
; Add the SIP Profile for the Egress SIP Trunk Group
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:profile:type="SIPPROFILE",name="out5134",custgrpid="1111",anchormedia="3",
gatewaypool="104",insessiontimer="90",mgcdomain="10.0.49.146"
prov-add:trnkgrpprof:name="5134",profile="out5134"

________________________________________
; Provision the SIP Profile for the Egress SIP Trunk Group
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-ed:profile:name="out5134",videoallowed="1",unsolicitednotifymethod="1"
prov-ed:profile:name="out5134",gwdefaultaudiocodecstring="G.711u;G.711a"
prov-ed:profile:name="out5134",gwdefaultvideocodecstring="H264;H263;H261"
prov-ed:profile:name="out5134",dummyaudiocodecstring="G.711u;G.711a" 
prov-ed:profile:name="out5134",dummyvideocodecstring="H264;H263;H261"

________________________________________
; Add the Route and the Route List
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
prov-add:siprttrnkgrp:name="5134",url="10.0.50.134",version="2.0",cutthrough=3,srvrr=0,ext
support=1,sipproxyport=5060
prov-add:rttrnk:name="rt51348",trnkgrpnum=5134,weightedtg="OFF"
prov-add:rtlist:name="rtlist51348",rtname="rt51348",distrib="OFF"

________________________________________
; Add the Result Set and the Results
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
numan-add:resultset:custgrpid="1111",name="rs51348"
numan-add:resulttable:custgrpid="1111",name="bmodccm5",resulttype="BMODDIG",dw1="1",dw2="3
",setname="rs51348"
numan-add:resulttable:custgrpid="1111",name="rtb51348",setname="rs51348",resulttype="ROUTE
",dw1="rtlist51348"

prov-add:codecstring:name="videocodec1",codecstring="H263;H261"
prov-add:codecstring:name="audiocodec1",codecstring="G.711u;G.711a"
numan-add:resultset:custgrpid="1111",name="rs513381"
numan-add:resulttable:custgrpid="1111",name="rescodecres133",resulttype="VIDEO_ALLOWED",
dw1="1",setname="rs513381"
numan-add:resulttable:custgrpid="1111",name="rstaudiocodec5133",resulttype="CODEC",
dw1="audiocodec1",dw2="0",dw3="0",setname="rs513381"
numan-add:resulttable:custgrpid="1111",name="rstvideocodec5133",resulttype="CODEC",
dw1="videocodec1",dw2="0",dw3="1",setname="rs513381"

________________________________________
; Add B-digit Modification 
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
numan-add:bdigtree:custgrpid="1111",callside="originating",digitstring="64666",setname="rs
51348"
numan-add:bdigtree:custgrpid="1111",callside="originating",digitstring="64670",setname="rs
513381"

prov-cpy

Sample of a Provisioned Cisco 7600 DBE

The following data represents the provisioning of a Cisco 7600 DBE:

login timeout 0
hostname switch
boot system image:c76-sbck9-mzg.3.0.1_AS3_0_01.bin
timeout xlate 2147483

interface vlan 13
  ip address 10.120.10.2 255.255.0.0
  alias 10.120.10.3 255.255.0.0
  no shutdown

ft interface vlan 77
  ip address 77.0.0.4 255.0.0.0
  peer ip address 77.77.0.6 255.0.0.0
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 30
  ft-interface vlan 77
ft group 1
  peer 1
  priority 127
  peer priority 126
  associate-context Admin
  inservice

ip route 0.0.0.0 0.0.0.0 10.120.10.1
ip route 10.74.0.0 255.255.0.0 10.74.56.129
ip route 64.0.0.0 255.255.0.0 10.74.56.129

username admin password 5 $1$faXJEFBj$TJR1Nx7sLPTi5BZ97v08c/  role Admin domain 
default-domain 
username www password 5 $1$UZIiwUk7$QMVYN1JASaycabrHkhGcS/  role Admin domain 
default-domain 

sbc sbc-zhuque
  dbe
    vdbe
      global
        dtmf-duration 200
        congestion-cleared 60
        congestion-threshold 80
        unexpected-source-alerting
        local-port 2944
        control-address h248 ipv4 10.120.10.3
        controller h248 1
          remote-address ipv4 10.0.4.6
          transport udp
        controller h248 2
          remote-address ipv4 10.0.20.7
          transport udp
        h248-profile gatecontrol
        attach-controllers
    media-address ipv4 10.120.10.3
    location-id 1
    media-timeout 30
    overload-time-threshold 100
    deact-mode normal
    activate

Sample of a Provisioned Cisco ASR 1000 series DBE

The following data represents the provisioning of a Cisco ASR 1000 series DBE:

!
no issu config-sync policy bulk prc
upgrade fpd auto
version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname ASR1000-3
!
boot-start-marker
boot-end-marker
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
logging buffered 64000 informational
enable password cisco
!
no aaa new-model
ip subnet-zero
ip tftp source-interface GigabitEthernet0
!
!
!
!
!
multilink bundle-name authenticated
mpls label protocol ldp
!         
!
!
redundancy
 mode none
 no policy config-sync bulk prc reload
!
pseudowire-class pgw
 encapsulation l2tpv3
 protocol none
 ip local interface Loopback0
!
! 
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface SBC3
 ip address 33.33.37.1 255.255.255.0
!
interface FastEthernet0/0/0
 mtu 1530
 ip address 10.0.99.33 255.255.0.0
 negotiation auto
 mpls ip
 no cdp enable
!
interface FastEthernet0/0/1
 ip address 10.128.99.33 255.255.0.0
 negotiation auto
 no cdp enable
!
interface FastEthernet0/0/1.1
 no cdp enable
!
interface FastEthernet0/0/2
 no ip address
 shutdown
 duplex full
 negotiation auto
 no cdp enable
!
interface FastEthernet0/0/3
 no ip address
 shutdown
 negotiation auto
 no cdp enable
!
interface GigabitEthernet0
 ip address 10.74.48.149 255.255.255.224
 speed 1000
 duplex full
 negotiation auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.100.111
ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 10.74.48.129
!
no ip http server
no ip http secure-server
!
logging 10.74.49.109
!
snmp-server community public RO
snmp-server community private RW
snmp-server host 10.74.49.109 public 
!
!
!
sbc pgw-ccb3 dbe
 vdbe global
  h248-inactivity-duration 6000
  local-port 2946
  control-address h248 ipv4 33.33.37.1
  controller h248 1
   remote-address ipv4 10.0.49.146
   remote-port 2946
  attach-controllers
 location-id 1
 media-address ipv4 33.33.37.1
  port-range 16384 20000 voice
  port-range 20001 65535 video
 activate
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password cisco
 login
!
end

Cisco Unified Communications Manager Configuring Tips

This section provides CUCM provisioning tips for video calls. For these tips, you are assumed to be using the CUCM Administration page to provision CUCM.

These tips fall into three categories:

Video part

Uncheck the Media Resource Group List check box under Device > Trunk.

Uncheck the Media Termination Point Required check box under Device > Trunk.

Choose enabled from the Video Capabilities drop-down list for the phone that uses video calls under Device > Phone.

Audio part

If you want the calling party to hear music on hold (MOH) when either party holds the call, configure the media resource group list on both trunks and the phones.

MOH server

Make sure an MOH server appears under Media Resources > Music On Hold Server

Make sure the Run Flag of the MOH server is set to Yes.

Make sure that the status of MOH server is registered with the CUCM under Media Resources > Music On Hold Server. If it is in the registered status, navigate to Cisco Unified Serviceability page. Under Tools > Control Center - Feature Services, click the radio button of the Cisco IP Voice Media Streaming App and click Start at the bottom.

By default, the MOH server is in the default group. All of the phones and trunks configured in the CUCM can use this MOH server. If you assign the MOH server to a media resource group which belongs to a media resource group list, only phones and trunks that are associated with that media resource group list can use the MOH server.

Software Changes for This Feature

The following sections describe software changes related to this feature:

Billing Interface

Properties

Result Types

Billing Interface

This section lists the modified call detail record (CDR) data for this feature. For the other billing interface information of the Cisco PGW 2200 Softswitch, see the Cisco PGW 2200 Softswitch Release 9 Billing Interface Guide.

Modified Billing Interfaces

Initial Codec (Tag: 4207)

This tag identifies the initial codec used for the RTP stream. The initial codec is parsed from the SDP from SIP or MGCP. If the call is a video call, this tag also includes the video codec.

Final Codec (Tag: 4208)

This tag identifies the final codec used for the RTP stream. The final codec is parsed from the SDP from SIP or MGCP. If the call is a video call, this tag also includes the video codec.

The two tags are helpful when you are troubleshooting the codec selection for calls. You can find the initial and the final audio and video codecs for a call in these two tags.

Properties

This section describes new properties for this feature. For more information on other properties for the Cisco PGW 2200 Softswitch, see the Cisco PGW 2200 Softswitch Release 9.8 Provisioning Guide.

New Properties

Table 1 describes the new properties for SIP, EISUP, and gateway pool profiles. You can find the provisioning examples of these properties in the "Provisioning Tasks" section.

Table 1 New Properties in This Feature 

Property
Description

DummyVideoCodecString

You use this property to specify the dummy video codec list. The Cisco PGW 2200 Softswitch uses the dummy video codecs in an H.248 add request when neither a remote SDP nor a local codec is provisioned. H.263, H.264, H.261, and H.263-1998 are all valid codec strings that can be included in the codec list. This property applies for DBEs only.

Valid values: video codec names (1 to 140 characters) separated by semicolons (for example, H.263; H.264; H.261), with the maximum length being 140 characters.

Default value: NULL.

Dynamically reconfigurable: yes.

GatewayVideoSupport

You use this property to control whether a gateway pool supports video traffic.

Valid values: boolean (0 = does not support, 1 = supports).

Default value: 0.

Dynamically reconfigurable: yes.

GWDefaultVideoCodecString

You use this property to specify an ordered series of codec choices for DBEs.

Valid values: video codec names (1 to 140 characters) separated by semicolons (for example, H.263; H.264; H.261), with the maximum length being 140 characters.

Default value: NULL.

Dynamically reconfigurable: yes.

VideoAllowed

You use this property to specify whether the Cisco PGW 2200 Softswitch allows video calls on SIP or EISUP trunk groups.

Valid values: boolean (0 = video calls not allowed, 1 = video calls allowed).

Default value: 1.

Dynamically reconfigurable: yes.


Result Types

This section describes new and modified result types for this feature. For other result type definitions for the Cisco PGW 2200 Softswitch, see the Cisco PGW 2200 Softswitch Release 9.8 Dial Plan Guide.

New Result Types

Table 2 gives the definition for the new result type in this feature.

Table 2 New Result Type Definitions 

Result Number
Result Type
Dataword1
Dataword2
Dataword3
Dataword4
Analysis Points
Result Type Valid For
Intermediate
End Point
A-digit analysis
B-digit analysis
Cause
Pre-analysis

86

VIDEO_ALLOWED

Allows or prohibits video calls

0 (not used)

0 (not used)

0 (not used)

  X

 

 X

 X

 

 X


VIDEO_ALLOWED

The new result type VIDEO_ALLOWED is added for this feature. This result type enables the Cisco PGW 2200 Softswitch to allow or prohibit video calls at the dial plan level.

There are two levels of video call admission control, the dial plan level and the trunk group level. If video calls are allowed at the trunk group level but prohibited at the dial plan level, video calls are prohibited. If video calls are prohibited at the trunk group level but allowed at the dial plan level, video calls are prohibited. For information on call admission control at the trunk group level, see the "Provisioning Video Call Admission Control" section.

This result type provides you the flexibility to include video call admission control in the number analysis. For example, you can prohibit video calls whose B-numbers start with 909.

Dataword1 specifies whether the Cisco PGW 2200 Softswitch allows or prohibits video calls:

0—Prohibits video calls at the dial plan level

1—Allows video calls at the dial plan level


Note If you do not provision the VIDEO_ALLOWED result type, the Cisco PGW 2200 Softswitch allows video calls at the dial plan level by default.


Modified Result Types

Table 3 gives the definition of the modified result type for this feature.

Table 3 Modified Result Type Definitions 

Result Number
Result Type
Dataword1
Dataword2
Dataword3
Dataword4
Analysis Points
Result Type Valid For
Intermediate
End Point
A-digit analysis
B-digit analysis
Cause
Pre-analysis

47

CODEC

CodecStringName

Action

CodecStringType

0 (not used)

  X

 

 X

 X

 X

 X


CODEC

This feature modifies the existing result type CODEC. Dataword3, CodecStringType, is added to indicate whether the codec string type is video or audio.

Dataword3 indicates the type of the codec string that Dataword1 contains:

0—Indicates that the codec string in Dataword1 is an audio codec string.

1—Indicates that the codec string in Dataword1 is a video codec string.

Troubleshooting the Feature

This section describes two troubleshooting procedures for this feature.

The first procedure is used if incoming video calls are rejected.

 
Action
Description

Step 1 

Check the gateway pool profile property, GatewayVideoSupport.

The GatewayVideoSupport property indicates whether or not the DBEs support video calls. Make sure you set the property to 1 (supports).

For property details, see the "Properties" section.

Step 2 

Check the SIP/EISUP profile property, VideoAllowed, for both ingress and egress trunk groups.

The Cisco PGW 2200 Softswitch uses the VideoAllowed property to control the video call admission on a certain SIP or EISUP trunk group. Make sure you set the property to 1 (video calls allowed).

For property details, see the "Properties" section.

Step 3 

Check the result type, VIDEO_ALLOWED, in the dial plan.

The Cisco PGW 2200 Softswitch uses the VIDEO_ALLOWED result type to control the video call admission at the dial plan level. If you provisioned this result type, make sure that you set it to 1 (video allowed). The Cisco PGW 2200 Softswitch allows the video calls at the dial plan level by default if you do not provision this result type in the dial plan.

For property details, see the "Properties" section.

Step 4 

Check the video support configuration on the CUCM.

See the "Cisco Unified Communications Manager Configuring Tips" section.

The second procedure is used if the video call has one-way audio, one-way video, or no voice at all.

 
Action
Description

Step 1 

Check connection between the DBE and the SIP end point (a Cisco TelePresence site or an IP phone).

Use the ping command to test the connection. If the ping action succeeds, the connection between the DBE and the SIP end point is good. If the ping action fails, proceed to Step 2.

Step 2 

Check the IP route configuration.

Check if you have correctly configured IP routes between the DBE and the SIP end point. See the user docs for Cisco ASR 1000 series DBE and Cisco 7600 DBE.

If you still have problems with this feature, get the MDL trace and contact the Cisco TAC.

For more information on operational tasks for the rest of theCisco PGW 2200 Softswitch, see the Cisco PGW 2200 Softswitch Release 9 Operations, Maintenance, and Troubleshooting Guide at

http://www.cisco.com/en/US/docs/voice_ip_comm/pgw/9/maintenance/guide/omtguide.html

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the monthly What's New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports RSS Version 2.0.

Glossary

Table 4 Acronym Expansions 

Acronym
Expansion

CTS

Cisco Telepresence Solutions

CUCM

Cisco Unified Communications Manager (formerly known as Cisco Unified CallManager)

DBE

data border element

NAT

network address translation

MOH

music on hold

PGW

PSTN gateway

RTP

Real-time Transport Protocol

SBE

session border element

SIP

Session Initiation Protocol

SPDM

service policy decision module

VPN

virtual private network

VXSM

Cisco Voice Switch Service Module