Getting Started Guide for Cisco UCS E-Series Servers and the Cisco UCS E-Series Network Compute Engine, Release 2.x
Configuring Access to the Management Firmware
Downloads: This chapterpdf (PDF - 2.23 MB) The complete bookPDF (PDF - 5.78 MB) | The complete bookePub (ePub - 2.12 MB) | Feedback

Configuring Access to the Management Firmware

Contents

Configuring Access to the Management Firmware

This chapter provides an overview of the E-Series Server and NCE interfaces and provides procedures to configure access to the CIMC management firmware when the E-Series Server or NCE is installed in the router. It contains the following sections:

Configuring CIMC Access

If you are a remote user, use the Cisco IOS CLI to configure CIMC access.

If you are a local user, use one of the following methods:

Understanding the Interfaces in an E-Series Server and the Cisco ISR G2

The following figure shows the interfaces in a double-wide E-Series Server and the Cisco ISR G2 host router.

Figure 1. Interfaces in a Double-Wide E-Series Server

 

Interface

Interface Location

Description

1

Router’s PCIe slot/0 Interface

Internal Interface

Also called Console interface. This interface connects the router’s PCIe interface to the E-Series Server. The PCIe interface provides an internal Layer 3 GE link between the router and the E-Series Server. It can be used both for CIMC configuration and for host operating system configuration.

2

Router’s MGF slot/1 VLAN Interface

Internal Interface

Used to access CIMC over a high-speed backplane switch. The MGF VLAN interface provides an internal Layer 2 GE link between the router and the E-Series Server. This interface can be used both for CIMC configuration and for host operating system configuration.

3

Management (Dedicated) Interface

External Interface

Used for CIMC configuration and management.

4

GE3 Interface

External Interface

Used as a primary interface or as a backup interface. This interface can be used both for CIMC configuration and for host operating system configuration.

Note   

The GE3 interface is only available on the double-wide E-Series Servers.

5

GE2 Interface

External Interface

Used as a primary interface or as a backup interface. This interface can be used both for CIMC configuration and for host operating system configuration.

CIMC Access Configuration Options—Cisco ISR G2

Depending on whether you are a remote user or a local user, do one of the following to configure CIMC access.

  • If you are a remote user, use either the external Management (dedicated) interface or one of the following shared LOM interfaces to configure CIMC access:

    • Router’s internal PCIe slot/0 Console interface

    • Router's internal MGF slot/1 VLAN interface

    • E-Series Server’s external GE2 or GE3 interface

  • If you are a local user, use the Cisco IOS CLI or the CIMC Configuration Utility to configure CIMC access.

Configuring CIMC Access Using the E-Series Server's External Management (Dedicated) Interface—Cisco ISR G2

See the following figure and the procedure that follows to configure CIMC access using the E-Series Server's external Management (dedicated) interface.

Figure 2. Configuring CIMC Access Using the E-Series Server's External Management (Dedicated) Interface



Before You Begin

Make sure that you have the following information:

  • IP address of CIMC.

  • Username and password for logging in to the router.

  • Slot and port number of the E-Series Server or NCE.

Procedure
     Command or ActionPurpose
    Step 1Router> enable  

    Enters privileged EXEC mode on the host router. Enter your password if prompted.

     
    Step 2Router# configure terminal  

    Enters global configuration mode on the host router.

     
    Step 3 Router (config)# interface ucse slot/port  

    Enters interface configuration mode for the slot and port where the E-Series Server is installed.

     
    Step 4Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

    Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

    • cimc-ip-address—IP address of CIMC.

    • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

    • cimc-gateway-ip-address—IP address for the default gateway.

     
    Step 5Router (config-if)# imc access-port dedicated  

    Configures CIMC access through the server’s external Management (dedicated) interface. See # 3 in E-Series Server Interfaces.

     
    Step 6Router (config-if)# no shut  

    Causes the interface to be administratively up.

     
    Step 7Router (config-if)# end  

    Exits interface configuration mode.

     

    This example shows how to configure CIMC access using the server’s external IMC dedicated interface:

    Router> enable
    Router> password
    Router# configure terminal
    
    Router(config)# interface ucse 2/0
    Router(config-if)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
    Router(config-if)# imc access-port dedicated 
    Router(config-if)# no shut
    Router(config-if)# end
    
    Configuring CIMC Access Using Shared LOM—Cisco ISR G2

    Use one of the following shared LOM interfaces to configure CIMC access:

    • Router’s internal PCIe slot/0 Console interface

    • Router's internal MGF slot/1 VLAN interface

    • E-Series Server’s external GE2 or GE3 interface

    Configuring CIMC Access Using the Router's Internal PCIe Slot/0 Console Interface—Cisco ISR G2

    See the following figure and the procedure that follows to configure CIMC access using the router's internal PCIe slot/0 Console interface.

    Figure 3. Configuring CIMC Access Using the Router's Internal PCIe Slot/0 Console Interface



    Before You Begin

    Make sure that you have the following information:

    • IP address of CIMC.

    • Username and password for logging in to the router.

    • Slot and port number of the E-Series Server or NCE.

    Procedure
       Command or ActionPurpose
      Step 1Router> enable  

      Enters privileged EXEC mode on the host router. Enter your password if prompted.

       
      Step 2Router# configure terminal  

      Enters global configuration mode on the host router.

       
      Step 3 Router (config)# interface GigabitEthernet0/0  

      Enters interface configuration mode for Gigabit Ethernet 0/0.

       
      Step 4Router (config-if)# ip address ip-address subnet-mask  

      Specifies the IP address and subnet mask of the interface.

       
      Step 5Router (config-if)# no shut  

      Causes the interface to be administratively up.

       
      Step 6Router (config-if)# end  

      Exits interface configuration mode.

       
      Step 7Router# configure terminal  

      Enters global configuration mode on the host router.

       
      Step 8 Router (config)# interface ucse slot/port  

      Enters interface configuration mode for the slot and port where the E-Series Server is installed.

       
      Step 9Router (config-if)# ip unnumbered type number  

      The ip unnumbered command enables IP processing on an interface without assigning an explicit IP address to that interface.

      • type—Type of interface on which the router has an assigned IP address.

      • number—Number of the interface and subinterface on which the router has an assigned IP address.

      Note   

      The unnumbered interface must be unique. It cannot be another unnumbered interface.

      When you use the ip unnumbered command, you must use the ip route command to create a static route.

      Caution   

      The ip unnumbered and ipv6 unnumbered commands create a point-to-point interface between devices. Broadcasting is not supported.

       
      Step 10Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

      Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

      • cimc-ip-address—IP address of CIMC.

      • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

      • cimc-gateway-ip-address—IP address for the default gateway.

       
      Step 11Router (config-if)# imc access-port shared-lom console  

      Configures CIMC access using the router's PCIe slot/0 (console) interface. See # 1 in E-Series Server Interfaces.

       
      Step 12Router (config-if)# no shut  

      Causes the interface to be administratively up.

       
      Step 13Router (config-if)# end  

      Exits interface configuration mode.

       
      Step 14Router# configure terminal  

      Enters global configuration mode on the host router.

       
      Step 15 Router (config)# ip route cimc-ip-address subnet-mask ucse slot/port  

      Creates a static route.

      • cimc-ip-address—IP address of CIMC.

      • slot/port—Slot and port where the E-Series Server is installed.

       
      Step 16Router (config-if)# end  

      Exits interface configuration mode.

       
      Step 17Router# ping cimc-ip-address  

      Verifies connection from the router to CIMC through the router's internal PCIe slot/0 console interface.

       

      This example shows how to configure CIMC access using the server’s internal PCIe slot/0 console interface:

      Router> enable
      Router> password
      Router# configure terminal
      
      Router(config)# interface GigabitEthernet0/0
      Router(config-if)# ip address 10.0.0.1 255.0.0.0
      Router(config-if)# no shut
      Router(config-if)# end
      
      Router# configure terminal
      Router(config)# interface ucse 2/0
      Router(config)# ip unnumbered GigabitEthernet0/0
      Router(config-if)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
      Router(config-if)# imc access-port shared-lom console 
      Router(config-if)# no shut
      Router(config)# end
      
      Router# configure terminal
      Router(config)# ip route 10.0.0.2 255.255.255.255 ucse 2/0
      Router(config)# end
      
      Router# ping 10.0.0.2
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
      
      Configuring CIMC Access Using the Router's Internal MGF Slot/1 VLAN Interface—Cisco ISR G2

      See the following figure and the procedure that follows to configure CIMC access using the router's internal MGF slot/1 VLAN interface.

      Figure 4. Configuring CIMC Access Using the Router's Internal MGF Slot/1 VLAN Interface




      Note


      * For a list of supported Cisco EtherSwitch EHWICs, see Supported Cisco EtherSwitch EHWIC and Cisco EtherSwitch Service Modules.


      Before You Begin

      Make sure that you have the following information:

      • IP address of CIMC.

      • Username and password for logging in to the router.

      • Slot and port number of the E-Series Server or NCE.

      Procedure
         Command or ActionPurpose
        Step 1Router> enable  

        Enters privileged EXEC mode on the host router. Enter your password if prompted.

         
        Step 2Router# show vlan-switch  

        Displays VLANs.

         
        Step 3Router# configure terminal  

        Enters global configuration mode on the host router.

         
        Step 4Router (config)# interface vlan vlan-number  

        Enters VLAN configuration mode for the specified VLAN number.

         
        Step 5Router (config-if)# ip address vlan-ip-address subnet-mask  

        Specifies the IP address for the VLAN.

        • vlan-ip-address—IP address of the VLAN.

        • subnet-mask—Subnet mask to append to the IP address.

         
        Step 6Router (config-if)# end  

        Exits interface configuration mode.

         
        Step 7Router# configure terminal  

        Enters global configuration mode on the host router.

         
        Step 8 Router (config)# interface ucse slot/port  

        Enters interface configuration mode for the slot and port where the E-Series Server is installed.

         
        Step 9Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

        Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

        • cimc-ip-address—IP address of CIMC.

        • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

        • cimc-gateway-ip-address—IP address for the default gateway.

         
        Step 10Router (config-if)# imc access-port shared-lom GE1  

        Configures CIMC access using the router’s internal slot/1 MGF VLAN interface. See # 2 in E-Series Server Interfaces.

         
        Step 11Router (config-if)# no shut  

        Causes the interface to be administratively up.

         
        Step 12Router (config-if)# end  

        Exits interface configuration mode.

         
        Step 13Router# ping cimc-ip-address  

        Verifies connection from the router to CIMC through the router's internal MGF slot/1 VLAN interface.

         

        This example shows how to configure CIMC access using the router's internal MGF slot/1 VLAN interface:

        Router> enable
        Router> password
        Router> show vlan-switch
        VLAN Name                             Status    Ports
        ---- -------------------------------- --------- -------------------------------
        1    default                          active    Gi0/0/0, Gi0/0/1, Gi0/0/2
                                                                    Gi0/0/3, uc2/1
        Router# configure terminal
        Router(config)# interface vlan 1 
        Router(config-if)# ip address 10.0.0.1 255.0.0.0
        Router(config-if)# end
        
        Router# configure terminal
        Router(config)# interface ucse 2/0
        Router(config-if)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1 
        Router(config-if)# imc access-port shared-lom GE1 
        Router(config-if)# no shut
        Router(config-if)# end
        
        Router# ping 10.0.0.2
        Type escape sequence to abort.
        Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
        !!!!!
        Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
        
        Configuring CIMC Access Using the Router's Internal MGF Slot/1 Interface Using a Non-Native VLAN—Cisco ISR G2

        See the following figure and the procedure that follows to configure CIMC access using the router's internal MGF slot/1 interface using a non-native VLAN.

        Figure 5. Configuring CIMC Access Using the Router's Internal MGF Slot/1 Interface Using a Non-Native VLAN




        Note


        * For a list of supported Cisco EtherSwitch EHWICs, see Supported Cisco EtherSwitch EHWIC and Cisco EtherSwitch Service Modules.


        Before You Begin

        Make sure that you have the following information:

        • IP address of CIMC.

        • Username and password for logging in to the router.

        • Slot and port number of the E-Series Server or NCE.

        Procedure
           Command or ActionPurpose
          Step 1Router> enable  

          Enters privileged EXEC mode on the host router. Enter your password if prompted.

           
          Step 2Router# show vlan-switch  

          Displays VLANs.

           
          Step 3Router# configure terminal  

          Enters global configuration mode on the host router.

           
          Step 4Router (config)# vlan vlan-number  

          Configures the specified VLAN.

           
          Step 5Router (config)# end  

          Exits VLAN configuration.

           
          Step 6Router# configure terminal  

          Enters global configuration mode on the host router.

           
          Step 7Router (config)# interface vlan vlan-number  

          Enters VLAN configuration mode for the specified VLAN number.

           
          Step 8Router (config-if)# ip address vlan-ip-address subnet-mask  

          Specifies the IP address for the VLAN.

          • vlan-ip-address—IP address of the VLAN.

          • subnet-mask—Subnet mask to append to the IP address.

           
          Step 9Router (config-if)# end  

          Exits interface configuration mode.

           
          Step 10Router# configure terminal  

          Enters global configuration mode on the host router.

           
          Step 11 Router (config)# interface ucse slot/port  

          Enters interface configuration mode for the slot and port where the E-Series Server is installed.

           
          Step 12Router (config)# imc vlan vlan-id  

          Configures the specified VLAN ID for CIMC.

           
          Step 13Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

          Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

          • cimc-ip-address—IP address of CIMC.

          • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

          • cimc-gateway-ip-address—IP address for the default gateway.

           
          Step 14Router (config-if)# imc access-port shared-lom GE1  

          Configures CIMC access using the router’s internal slot/1 MGF VLAN interface. See # 2 in E-Series Server Interfaces.

           
          Step 15Router (config-if)# no shut  

          Causes the interface to be administratively up.

           
          Step 16Router (config-if)# end  

          Exits interface configuration mode.

           
          Step 17Router# configure terminal  

          Enters global configuration mode on the host router.

           
          Step 18 Router (config)# interface ucse slot/1  

          Enters interface configuration mode for the router’s MGF slot/1 VLAN interface.

           
          Step 19 Router (config-if)# switchport mode trunk  

          Puts the port into permanent trunking mode. The default configuration is access mode.

           
          Step 20Router (config-if)# no shut  

          Causes the interface to be administratively up.

           
          Step 21Router (config-if)# end  

          Exits interface configuration mode.

           
          Step 22Router# ping cimc-ip-address  

          Verifies connection from the router to CIMC through the router's internal MGF slot/1 VLAN interface.

           

          This example shows how to configure CIMC access using the router's internal MGF slot/1 interface using a non-native VLAN:

          Router> enable
          Router> password
          Router> show vlan-switch
          VLAN Name                             Status    Ports
          ---- -------------------------------- --------- -------------------------------
          1    default                          active    Gi0/0/0, Gi0/0/1, Gi0/0/2
                                                                      Gi0/0/3, uc2/1
          
          Router# configure terminal
          Router(config)# vlan 2 
          Router(config)# end
          
          Router# configure terminal
          Router(config)# interface vlan 2 
          Router(config-if)# ip address 10.0.0.1 255.0.0.0
          Router(config-if)# end
          
          Router# configure terminal
          Router(config)# interface ucse 2/0
          Router(config-if)# imc vlan 2
          Router(config-if)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1 
          Router(config-if)# imc access-port shared-lom GE1 
          Router(config-if)# no shut
          Router(config-if)# end
          
          Router# configure terminal
          Router(config)# interface ucse 2/1
          Router(config-if)# switchport mode trunk
          Router(config-if)# no shut
          Router(config-if)# end
          
          Router# ping 10.0.0.2
          Type escape sequence to abort.
          Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
          !!!!!
          Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
          
          Configuring CIMC Access Using the E-Series Server's External GE2 or GE3 Interface—Cisco ISR G2

          See the following figure and the procedure that follows to configure CIMC access using the E-Series Server's external GE2 or GE3 interface.


          Note


          This figure shows how to configure CIMC access using the E-Series Server's external GE2 interface.


          Figure 6. Configuring CIMC Access Using the E-Series Server's External GE2 Interface



          Before You Begin

          Make sure that you have the following information:

          • IP address of CIMC.

          • Username and password for logging in to the router.

          • Slot and port number of the E-Series Server or NCE.

          Procedure
             Command or ActionPurpose
            Step 1Router> enable  

            Enters privileged EXEC mode on the host router. Enter your password if prompted.

             
            Step 2Router# configure terminal  

            Enters global configuration mode on the host router.

             
            Step 3 Router (config)# interface ucse slot/port  

            Enters interface configuration mode for the slot and port where the E-Series Server is installed.

             
            Step 4Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

            Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

            • cimc-ip-address—IP address of CIMC.

            • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

            • cimc-gateway-ip-address—IP address for the default gateway.

             
            Step 5Router (config-if)# imc access-port shared-lom {GE2 | GE3}  

            Configures CIMC access through the E-Series Server's external GE2 or GE3 interface. See # 4 and 5 in E-Series Server Interfaces.

             
            Step 6Router (config-if)# no shut  

            Causes the interface to be administratively up.

             
            Step 7Router (config-if)# end  

            Exits interface configuration mode.

             

            This example shows how to configure CIMC access using the server's external GE2 interface:

            Router> enable
            Router> password
            Router# configure terminal
            
            Router(config)# interface ucse 2/0
            Router(config-if)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
            Router(config-if)# imc access-port shared-lom GE2 
            Router(config-if)# no shut
            Router(config-if)# end
            

            Understanding the Interfaces in an E-Series Server and the Cisco ISR 4000 Series

            The following figure shows the interfaces in a double-wide E-Series Server and the Cisco ISR 4000 series host router.

            Figure 7. Interfaces in a Double-Wide E-Series Server

             

            Interface

            Interface Location

            Description

            1

            Router’s ucse slot/0/0 Interface

            Internal Interface

            Used to access CIMC over a high-speed backplane switch. The MGF interface provides an internal Layer 2 GE link between the router and the E-Series Server. This interface can be used both for CIMC configuration and for host operating system configuration.

            Note   

            This interface is used to access the E-Series Server's internal GE0 interface.

            2

            Router’s ucse slot/0/1 Interface

            Internal Interface

            Used to access CIMC over a high-speed backplane switch. The MGF interface provides an internal Layer 2 GE link between the router and the E-Series Server. This interface can be used both for CIMC configuration and for host operating system configuration.

            Note   

            This interface is used to access the E-Series Server's internal GE1 interface.

            3

            GE0 and GE1 Interfaces

            Internal Interfaces

            E-Series Server's internal NIC interfaces.

            4

            Management (Dedicated) Interface

            External Interface

            Used for CIMC configuration and management.

            5

            GE3 Interface

            External Interface

            Can be used both for CIMC configuration and for host operating system configuration.

            Note   

            The GE3 interface is only available on the double-wide E-Series Servers.

            6

            GE2 Interface

            External Interface

            Can be used both for CIMC configuration and for host operating system configuration.

            CIMC Access Configuration Options—Cisco ISR 4000 Series

            Depending on whether you are a remote user or a local user, do one of the following to configure CIMC access.

            • If you are a remote user, use the Cisco IOS CLI to configure CIMC access by using one of the following interfaces:

              • CIMC Management (dedicated) interface

              • E-Series Server’s internal GE0 and the router's ucse slot/0/0 interface

              • E-Series Server’s internal GE1 interface and the router's ucse slot/0/1 interface

              • E-Series Server’s external GE2 or GE3 interface

            • If you are a local user, use the CIMC Configuration Utility or the Cisco IOS CLI (mentioned above) to configure CIMC access.

            Configuring CIMC Access Using the E-Series Server's External Management (Dedicated) Interface—Cisco ISR 4000 Series

            See the following figure and the procedure that follows to configure CIMC access using the E-Series Server's external Management (dedicated) interface.

            Figure 8. Configuring CIMC Access Using the E-Series Server's External Management (Dedicated) Interface



            Before You Begin

            Make sure that you have the following information:

            • IP address of CIMC.

            • Username and password for logging in to the router.

            • Slot and port number of the E-Series Server or NCE.

            Procedure
               Command or ActionPurpose
              Step 1Router> enable  

              Enters privileged EXEC mode on the host router. Enter your password if prompted.

               
              Step 2Router# configure terminal  

              Enters global configuration mode on the host router.

               
              Step 3 Router (config)# ucse subslot slot/port  

              Enters ucse interface configuration mode for the slot and port where the E-Series Server is installed.

               
              Step 4Router (config-ucse)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

              Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

              • cimc-ip-address—IP address of CIMC.

              • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

              • cimc-gateway-ip-address—IP address for the default gateway.

               
              Step 5Enter one of the following commands:
              • Router (config-ucse)# imc access-port mgmt
              • Router (config-ucse)# imc access-port dedicated
               

              Configures CIMC access through the server’s external Management (dedicated) interface. See # 4 in Understanding the Interfaces in an E-Series Server and the Cisco ISR 4000 Series.

              • Use the imc access-port mgmt command if you installed the Cisco IOS XE Release 3.9S.

              • Use the imc access-port dedicated command if you installed the Cisco IOS XE Release 3.10S and later versions.

               
              Step 6Router (config-ucse)# end  

              Returns to privileged EXEC mode on the host router.

               

              This example shows how to configure CIMC access using the server’s external management interface—Applicable only with Cisco IOS XE Release 3.9S:

              Router> enable
              Router> password
              Router# configure terminal
              
              Router(config)# ucse subslot 1/0
              Router(config-ucse)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
              Router(config-ucse)# imc access-port mgmt 
              Router(config-ucse)# end
              

              This example shows how to configure CIMC access using the server’s external dedicated interface—Applicable with Cisco IOS XE Release 3.10S and later versions:

              Router> enable
              Router> password
              Router# configure terminal
              
              Router(config)# ucse subslot 1/0
              Router(config-ucse)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
              Router(config-ucse)# imc access-port dedicated 
              Router(config-ucse)# end
              
              Configuring CIMC Access Using the E-Series Server's NIC Interfaces—Cisco ISR 4000 Series
              Use one of the following E-Series Server's NIC interfaces to access CIMC:
              • E-Series Server’s internal GE0 and the router's ucse slot/0/0 interface

              • E-Series Server’s internal GE1 interface and the router's ucse slot/0/1 interface

              • E-Series Server’s external GE2 or GE3 interface

              Configuring CIMC Access Using the E-Series Server's Internal GE0 Interface and the Cisco ISR 4000 Series ucse slot/0/0 Interface

              See the following figure and the procedure that follows to configure CIMC access using the E-Series Server's internal GE0 interface and the router's ucse slot/0/0 interface.

              Figure 9. Configuring CIMC Access Using the E-Series Server's Internal GE0 Interface and the Router's ucse slot/0/0 Interface



              Before You Begin

              Make sure that you have the following information:

              • IP address of CIMC.

              • Username and password for logging in to the router.

              • Slot and port number of the E-Series Server or NCE.

              Procedure
                 Command or ActionPurpose
                Step 1Router> enable  

                Enters privileged EXEC mode on the host router. Enter your password if prompted.

                 
                Step 2Router# configure terminal  

                Enters global configuration mode on the host router.

                 
                Step 3 Router (config)# interface GigabitEthernet 0/0/0  

                Enters interface configuration mode for Gigabit Ethernet interface 0/0/0.

                 
                Step 4Router (config-if)# ip address ip-address subnet-mask  

                Specifies the IP address and subnet mask of the interface.

                 
                Step 5Router (config-if)# no shut  

                Causes the interface to be administratively up.

                 
                Step 6Router (config-if)# exit  

                Exits interface configuration mode.

                 
                Step 7 Router (config)# interface ucse slot/0/0  

                Enters ucse interface configuration mode for the slot, port, and subport where the E-Series Server is installed.

                 
                Step 8Router (config-if)# ip unnumbered type number  

                The ip unnumbered command enables IP processing on an interface without assigning an explicit IP address to that interface.

                • type—Type of interface on which the router has an assigned IP address.

                • number—Number of the interface and subinterface on which the router has an assigned IP address.

                Note   

                The unnumbered interface must be unique. It cannot be another unnumbered interface.

                When you use the ip unnumbered command, you must use the ip route command to create a static route.

                Caution   

                The ip unnumbered and ipv6 unnumbered commands create a point-to-point interface between devices. Broadcasting is not supported.

                 
                Step 9Router (config-if)# no shut  

                Causes the interface to be administratively up.

                 
                Step 10Router (config-if)# exit  

                Exits interface configuration mode.

                 
                Step 11 Router (config)# ucse subslot slot/port  

                Enters ucse interface configuration mode for the slot and port where the E-Series Server is installed.

                 
                Step 12Router (config-ucse)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

                Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

                • cimc-ip-address—IP address of CIMC.

                • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

                • cimc-gateway-ip-address—IP address for the default gateway.

                 
                Step 13Enter one of the following commands:
                • Router (config-ucse)# imc access-port ge0
                • Router (config-ucse)# imc access-port shared-lom console
                 

                Configures CIMC access using the E-Series Server's internal GE0 or console interface. See # 3 in Understanding the Interfaces in an E-Series Server and the Cisco ISR 4000 Series.

                • Use the imc access-port ge0 command if you installed the Cisco IOS XE Release 3.9S.

                • Use the imc access-port shared-lom console command if you installed the Cisco IOS XE Release 3.10S and later versions.

                 
                Step 14Router (config-ucse)# exit  

                Exits ucse interface configuration mode.

                 
                Step 15 Router (config)# ip route cimc-ip-address subnet-mask ucse slot/port/subport  

                Creates a static route.

                • cimc-ip-address—IP address of CIMC.

                • slot/port/subport—Slot, port, and subport where the E-Series Server is installed.

                 
                Step 16Router (config)# end  

                Exits configuration mode.

                 
                Step 17Router# ping cimc-ip-address  

                Verifies the connection from the router to CIMC through the ucse slot/0/0 interface.

                 

                This example shows how to configure CIMC access using the E-Series Server's internal GE0 interface and the router's ucse slot/0/0 interface—Applicable only with Cisco IOS XE Release 3.9S:

                Router> enable
                Router> password
                Router# configure terminal
                
                Router(config)# interface GigabitEthernet0/0/0
                Router(config-if)# ip address 10.0.0.1 255.0.0.0
                Router(config-if)# no shut
                Router(config-if)# exit
                
                Router(config)# interface ucse 1/0/0
                Router(config-if)# ip unnumbered GigabitEthernet0/0/0
                Router(config-if)# no shut
                Router(config-if)# exit
                
                Router(config)# ucse subslot 1/0
                Router(config-ucse)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
                Router(config-ucse)# imc access-port ge0 
                Router(config-ucse)# exit
                
                Router(config)# ip route 10.0.0.2 255.255.255.255 ucse 1/0/0
                Router(config)# end
                
                Router# ping 10.0.0.2
                Type escape sequence to abort.
                Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                !!!!!
                Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
                

                This example shows how to configure CIMC access using the E-Series Server's internal console interface and the router's ucse slot/0/0 interface—Applicable with Cisco IOS XE Release 3.10S and later versions:

                Router> enable
                Router> password
                Router# configure terminal
                
                Router(config)# interface GigabitEthernet0/0/0
                Router(config-if)# ip address 10.0.0.1 255.0.0.0
                Router(config-if)# no shut
                Router(config-if)# exit
                
                Router(config)# interface ucse 1/0/0
                Router(config-if)# ip unnumbered GigabitEthernet0/0/0
                Router(config-if)# no shut
                Router(config-if)# exit
                
                Router(config)# ucse subslot 1/0
                Router(config-ucse)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
                Router(config-ucse)# imc access-port shared-lom console 
                Router(config-ucse)# exit
                
                Router(config)# ip route 10.0.0.2 255.255.255.255 ucse 1/0/0
                Router(config)# end
                
                Router# ping 10.0.0.2
                Type escape sequence to abort.
                Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                !!!!!
                Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
                
                Configuring CIMC Access Using the E-Series Server's Internal GE1 Interface and the Cisco ISR 4000 Series ucse slot/0/1 Interface

                See the following figure and the procedure that follows to configure CIMC access using the E-Series Server's internal GE1 interface and the router's ucse slot/0/1 interface.

                Figure 10. Configuring CIMC Access Using the E-Series Server's Internal GE1 Interface and the Router's ucse slot/0/1 Interface



                Before You Begin

                Make sure that you have the following information:

                • IP address of CIMC.

                • Username and password for logging in to the router.

                • Slot and port number of the E-Series Server or NCE.

                Procedure
                   Command or ActionPurpose
                  Step 1Router> enable  

                  Enters privileged EXEC mode on the host router. Enter your password if prompted.

                   
                  Step 2Router# configure terminal  

                  Enters global configuration mode on the host router.

                   
                  Step 3 Router (config)# interface GigabitEthernet 0/0/0  

                  Enters interface configuration mode for Gigabit Ethernet interface 0/0/0.

                   
                  Step 4Router (config-if)# ip address ip-address subnet-mask  

                  Specifies the IP address and subnet mask of the interface.

                   
                  Step 5Router (config-if)# no shut  

                  Causes the interface to be administratively up.

                   
                  Step 6Router (config-if)# exit  

                  Exits interface configuration mode.

                   
                  Step 7 Router (config)# interface ucse slot/0/1  

                  Enters ucse interface configuration mode for the slot, port, and subport where the E-Series Server is installed.

                   
                  Step 8Router (config-if)# ip unnumbered type number  

                  The ip unnumbered command enables IP processing on an interface without assigning an explicit IP address to that interface.

                  • type—Type of interface on which the router has an assigned IP address.

                  • number—Number of the interface and subinterface on which the router has an assigned IP address.

                  Note   

                  The unnumbered interface must be unique. It cannot be another unnumbered interface.

                  When you use the ip unnumbered command, you must use the ip route command to create a static route.

                  Caution   

                  The ip unnumbered and ipv6 unnumbered commands create a point-to-point interface between devices. Broadcasting is not supported.

                   
                  Step 9Router (config-if)# no shut  

                  Causes the interface to be administratively up.

                   
                  Step 10Router (config-if)# exit  

                  Exits interface configuration mode.

                   
                  Step 11 Router (config)# ucse subslot slot/port  

                  Enters ucse interface configuration mode for the slot and port where the E-Series Server is installed.

                   
                  Step 12Router (config-ucse)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

                  Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

                  • cimc-ip-address—IP address of CIMC.

                  • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

                  • cimc-gateway-ip-address—IP address for the default gateway.

                   
                  Step 13Enter one of the following commands:
                  • Router (config-ucse)# imc access-port ge1
                  • Router (config-ucse)# imc access-port shared-lom ge1
                   

                  Configures CIMC access using the E-Series Server's internal GE1 interface. See # 3 in Understanding the Interfaces in an E-Series Server and the Cisco ISR 4000 Series.

                  • Use the imc access-port ge1 command if you installed the Cisco IOS XE Release 3.9S.

                  • Use the imc access-port shared-lom ge1 command if you installed the Cisco IOS XE Release 3.10S and later versions.

                   
                  Step 14Router (config-ucse)# exit  

                  Exits ucse interface configuration mode.

                   
                  Step 15 Router (config)# ip route cimc-ip-address subnet-mask ucse slot/port/subport  

                  Creates a static route.

                  • cimc-ip-address—IP address of CIMC.

                  • slot/port/subport—Slot, port, and subport where the E-Series Server is installed.

                   
                  Step 16Router (config)# end  

                  Exits configuration mode.

                   
                  Step 17Router# ping cimc-ip-address  

                  Verifies the connection from the router to CIMC through the ucse slot/0/1 interface.

                   

                  This example shows how to configure CIMC access using the E-Series Server's internal GE1 interface and the router's ucse slot/0/1 interface—Applicable only with Cisco IOS XE Release 3.9S:

                  Router> enable
                  Router> password
                  Router# configure terminal
                  
                  Router(config)# interface GigabitEthernet0/0/0
                  Router(config-if)# ip address 10.0.0.1 255.0.0.0
                  Router(config-if)# no shut
                  Router(config-if)# exit
                  
                  Router(config)# interface ucse 1/0/1
                  Router(config-if)# ip unnumbered GigabitEthernet0/0/0
                  Router(config-if)# no shut
                  Router(config-if)# exit
                  
                  Router(config)# ucse subslot 1/0
                  Router(config-ucse)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
                  Router(config-ucse)# imc access-port ge1 
                  Router(config-ucse)# exit
                  
                  Router(config)# ip route 10.0.0.2 255.255.255.255 ucse 1/0/1
                  Router(config)# end
                  
                  Router# ping 10.0.0.2
                  Type escape sequence to abort.
                  Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                  !!!!!
                  Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
                  

                  This example shows how to configure CIMC access using the E-Series Server's internal GE1 interface and the router's ucse slot/0/1 interface—Applicable with Cisco IOS XE Release 3.10S and later releases:

                  Router> enable
                  Router> password
                  Router# configure terminal
                  
                  Router(config)# interface GigabitEthernet0/0/0
                  Router(config-if)# ip address 10.0.0.1 255.0.0.0
                  Router(config-if)# no shut
                  Router(config-if)# exit
                  
                  Router(config)# interface ucse 1/0/1
                  Router(config-if)# ip unnumbered GigabitEthernet0/0/0
                  Router(config-if)# no shut
                  Router(config-if)# exit
                  
                  Router(config)# ucse subslot 1/0
                  Router(config-ucse)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
                  Router(config-ucse)# imc access-port shared-lom ge1 
                  Router(config-ucse)# exit
                  
                  Router(config)# ip route 10.0.0.2 255.255.255.255 ucse 1/0/1
                  Router(config)# end
                  
                  Router# ping 10.0.0.2
                  Type escape sequence to abort.
                  Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                  !!!!!
                  Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
                  
                  Configuring CIMC Access Using the E-Series Server's External GE2 or GE3 Interface—Cisco ISR 4000 Series

                  See the following figure and the procedure that follows to configure CIMC access using the E-Series Server's external GE2 or GE3 interface.


                  Note


                  This figure shows how to configure CIMC access using the E-Series Server's external GE2 interface.


                  Figure 11. Configuring CIMC Access Using the E-Series Server's External GE2 Interface



                  Before You Begin

                  Make sure that you have the following information:

                  • IP address of CIMC.

                  • Username and password for logging in to the router.

                  • Slot and port number of the E-Series Server.

                  Procedure
                     Command or ActionPurpose
                    Step 1Router> enable  

                    Enters privileged EXEC mode on the host router. Enter your password if prompted.

                     
                    Step 2Router# configure terminal  

                    Enters global configuration mode on the host router.

                     
                    Step 3 Router (config)# ucse subslot slot/port  

                    Enters ucse interface configuration mode for the slot and port where the E-Series Server is installed.

                     
                    Step 4Router (config-ucse)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

                    Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

                    • cimc-ip-address—IP address of CIMC.

                    • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

                    • cimc-gateway-ip-address—IP address for the default gateway.

                     
                    Step 5Router (config-ucse)# imc access-port {GE2 | GE3} or Router (config-ucse)# imc access-port shared-lom {GE2 | GE3}  

                    Configures CIMC access through the E-Series Server's external GE2 or GE3 interface. See # 5 and 6 in Understanding the Interfaces in an E-Series Server and the Cisco ISR 4000 Series.

                    • Use the imc access-port {GE2 | GE3} command if you installed the Cisco IOS XE Release 3.9S.

                    • Use the imc access-port shared-lom {GE2 | GE3} command if you installed the Cisco IOS XE Release 3.10S and later versions.

                     
                    Step 6Router (config-ucse)# end  

                    Returns to privileged EXEC mode on the host router.

                     

                    This example shows how to configure CIMC access using the server's external GE2 interface—Applicable only with Cisco IOS XE Release 3.9S:

                    Router> enable
                    Router> password
                    Router# configure terminal
                    
                    Router(config)# ucse subslot 1/0
                    Router(config-ucse)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
                    Router(config-ucse)# imc access-port GE2 
                    Router(config-ucse)# no shut
                    Router(config-ucse)# end
                    

                    This example shows how to configure CIMC access using the server's external GE2 interface—Applicable with Cisco IOS XE Release 3.10S and later releases:

                    Router> enable
                    Router> password
                    Router# configure terminal
                    
                    Router(config)# ucse subslot 1/0
                    Router(config-ucse)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
                    Router(config-ucse)# imc access-port shared-lom GE2 
                    Router(config-ucse)# no shut
                    Router(config-ucse)# end
                    

                    Understanding the Interfaces in the EHWIC E-Series NCE and the Cisco ISR G2


                    Note


                    This section is applicable to the EHWIC E-Series NCE. This section is not applicable to the SM E-Series NCE.


                    The following figure shows the interfaces in the EHWIC E-Series NCE and the Cisco ISR G2 host router.

                    Figure 12. Interfaces in the EHWIC E-Series NCE and the Cisco ISR G2 Host Router



                     

                    Interface

                    Interface Location

                    Description

                    1

                    Router’s EHWIC 0/slot/0 Interface

                    Internal Interface

                    Also called Console interface. This interface connects the router’s EHWIC interface to the EHWIC E-Series NCE. The EHWIC interface provides an internal Layer 3 GE link between the router and the EHWIC E-Series NCE. It can be used both for CIMC configuration and for host operating system configuration.

                    2

                    Router’s MGF 0/slot/1 VLAN Interface

                    Internal Interface

                    Used to access CIMC over a high-speed backplane switch. The MGF VLAN interface provides an internal Layer 2 GE link between the router and the EHWIC E-Series NCE. This interface can be used both for CIMC configuration and for host operating system configuration.

                    Note   

                    This interface is not applicable to the Cisco 1921 ISR G2.

                    3

                    GE2 Interface

                    External Interface

                    Used as a primary interface or as a backup interface. This interface can be used both for CIMC configuration and for host operating system configuration.

                    CIMC Access Configuration Options—EHWIC E-Series NCE

                    Do one of the following to configure CIMC access.

                    • Use one of the following shared LOM interfaces to configure CIMC access:

                      • Router’s internal EHWIC 0/slot/0 Console interface

                      • Router's internal MGF 0/slot/1 VLAN interface


                        Note


                        This interface is not applicable to the Cisco ISR 1921.


                      • NCE’s external GE2 interface

                    • Use the Cisco IOS CLI to configure CIMC access.

                    Configuring CIMC Access Using the Router's Internal EHWIC 0/Slot/0 Console Interface—EHWIC E-Series NCE

                    See the following figure and the procedure that follows to configure CIMC access using the router's internal EHWIC 0/slot/0 console interface.

                    Figure 13. Configuring CIMC Access Using the Router's Internal EHWIC 0/Slot/0 Console Interface



                    Before You Begin

                    Make sure that you have the following information:

                    • IP address of CIMC.

                    • Username and password for logging in to the router.

                    • Slot and port number of the E-Series Server or NCE.

                    Procedure
                       Command or ActionPurpose
                      Step 1Router> enable  

                      Enters privileged EXEC mode on the host router. Enter your password if prompted.

                       
                      Step 2Router# configure terminal  

                      Enters global configuration mode on the host router.

                       
                      Step 3 Router (config)# interface GigabitEthernet0/0  

                      Enters interface configuration mode for Gigabit Ethernet 0/0.

                       
                      Step 4Router (config-if)# ip address ip-address subnet-mask  

                      Specifies the IP address and subnet mask of the interface.

                       
                      Step 5Router (config-if)# no shut  

                      Causes the interface to be administratively up.

                       
                      Step 6Router (config-if)# end  

                      Exits interface configuration mode.

                       
                      Step 7Router# configure terminal  

                      Enters global configuration mode on the host router.

                       
                      Step 8 Router (config)# interface ucse 0/slot/port  

                      Enters ucse interface configuration mode for the slot and port where the NCE is installed.

                       
                      Step 9Router (config-if)# ip unnumbered type number  

                      The ip unnumbered command enables IP processing on an interface without assigning an explicit IP address to that interface.

                      • type—Type of interface on which the router has an assigned IP address.

                      • number—Number of the interface and subinterface on which the router has an assigned IP address.

                      Note   

                      The unnumbered interface must be unique. It cannot be another unnumbered interface.

                      When you use the ip unnumbered command, you must use the ip route command to create a static route.

                      Caution   

                      The ip unnumbered and ipv6 unnumbered commands create a point-to-point interface between devices. Broadcasting is not supported.

                       
                      Step 10Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

                      Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

                      • cimc-ip-address—IP address of CIMC.

                      • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

                      • cimc-gateway-ip-address—IP address for the default gateway.

                       
                      Step 11Router (config-if)# imc access-port shared-lom console  

                      Configures CIMC access using the router's EHWIC 0/slot/0 (console) interface. See # 1 in Understanding the Interfaces in the EHWIC E-Series NCE and the Cisco ISR G2.

                       
                      Step 12Router (config-if)# no shut  

                      Causes the interface to be administratively up.

                       
                      Step 13Router (config-if)# end  

                      Exits interface configuration mode.

                       
                      Step 14Router# configure terminal  

                      Enters global configuration mode on the host router.

                       
                      Step 15 Router (config)# ip route cimc-ip-address subnet-mask ucse 0/slot/port  

                      Creates a static route.

                      • cimc-ip-address—IP address of CIMC.

                      • slot/port—Slot and port where the NCE is installed.

                       
                      Step 16Router (config-if)# end  

                      Exits interface configuration mode.

                       
                      Step 17Router# ping cimc-ip-address  

                      Verifies connection from the router to CIMC through the router's internal EHWIC 0/slot/0 console interface.

                       

                      This example shows how to configure CIMC access using the server’s internal EHWIC 0/slot/0 console interface:

                      Router> enable
                      Router> password
                      Router# configure terminal
                      
                      Router(config)# interface GigabitEthernet0/0
                      Router(config-if)# ip address 10.0.0.1 255.0.0.0
                      Router(config-if)# no shut
                      Router(config-if)# end
                      
                      Router# configure terminal
                      Router(config)# interface ucse 0/3/0
                      Router(config)# ip unnumbered GigabitEthernet0/0
                      Router(config-if)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
                      Router(config-if)# imc access-port shared-lom console 
                      Router(config-if)# no shut
                      Router(config)# end
                      
                      Router# configure terminal
                      Router(config)# ip route 10.0.0.2 255.255.255.255 ucse 0/3/0
                      Router(config)# end
                      
                      Router# ping 10.0.0.2
                      Type escape sequence to abort.
                      Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                      !!!!!
                      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
                      
                      Configuring CIMC Access Using the Router's Internal MGF 0/Slot/1 VLAN Interface—EHWIC E-Series NCE
                      Important:

                      This procedure is not applicable to the Cisco 1921 ISR G2.

                      See the following figure and the procedure that follows to configure CIMC access using the router's internal MGF 0/slot/1 VLAN interface.

                      Figure 14. Configuring CIMC Access Using the Router's Internal MGF 0/Slot/1 VLAN Interface






                      Note


                      * For a list of supported Cisco EtherSwitch EHWICs, see Supported Cisco EtherSwitch EHWIC and Cisco EtherSwitch Service Modules.


                      Before You Begin

                      Make sure that you have the following information:

                      • IP address of CIMC.

                      • Username and password for logging in to the router.

                      • Slot and port number of the E-Series Server or NCE.

                      Procedure
                         Command or ActionPurpose
                        Step 1Router> enable  

                        Enters privileged EXEC mode on the host router. Enter your password if prompted.

                         
                        Step 2Router# show vlan-switch  

                        Displays VLANs.

                         
                        Step 3Router# configure terminal  

                        Enters global configuration mode on the host router.

                         
                        Step 4Router (config)# interface vlan vlan-number  

                        Enters interface configuration mode for the specified VLAN number.

                         
                        Step 5Router (config-if)# ip address vlan-ip-address subnet-mask  

                        Specifies the IP address for the VLAN.

                        • vlan-ip-address—IP address of the VLAN.

                        • subnet-mask—Subnet mask to append to the IP address.

                         
                        Step 6Router (config-if)# end  

                        Exits interface configuration mode.

                         
                        Step 7Router# configure terminal  

                        Enters global configuration mode on the host router.

                         
                        Step 8 Router (config)# interface ucse 0/slot/0  

                        Enters ucse interface configuration mode for the slot and port where the NCE is installed.

                         
                        Step 9Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

                        Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

                        • cimc-ip-address—IP address of CIMC.

                        • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

                        • cimc-gateway-ip-address—IP address for the default gateway.

                         
                        Step 10Router (config-if)# imc access-port shared-lom GE1  

                        Configures CIMC access using the router’s internal 0/slot/1 MGF VLAN interface. See # 2 in Understanding the Interfaces in the EHWIC E-Series NCE and the Cisco ISR G2.

                         
                        Step 11Router (config-if)# no shut  

                        Causes the interface to be administratively up.

                         
                        Step 12Router (config-if)# end  

                        Exits interface configuration mode.

                         
                        Step 13Router# configure terminal  

                        Enters global configuration mode on the host router.

                         
                        Step 14 Router (config)# interface ucse 0/slot/1  

                        Enters ucse interface configuration mode for the slot and port where the NCE is installed.

                         
                        Step 15Router (config-if)# no shut  

                        Causes the interface to be administratively up.

                         
                        Step 16Router (config-if)# end  

                        Exits interface configuration mode.

                         
                        Step 17Router# ping cimc-ip-address  

                        Verifies connection from the router to CIMC through the router's internal MGF 0/slot/1 VLAN interface.

                         

                        This example shows how to configure CIMC access using the router's internal MGF 0/slot/1 VLAN interface:

                        Router> enable
                        Router> password
                        Router> show vlan-switch
                        VLAN Name                             Status    Ports
                        ---- -------------------------------- --------- -------------------------------
                        1    default                          active    Gi0/0/0, Gi0/0/1, Gi0/0/2
                                                                                    Gi0/0/3, uc0/3/1
                        Router# configure terminal
                        Router(config)# interface vlan 1 
                        Router(config-if)# ip address 10.0.0.1 255.0.0.0
                        Router(config-if)# end
                        
                        Router# configure terminal
                        Router(config)# interface ucse 0/3/0
                        Router(config-if)# imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1 
                        Router(config-if)# imc access-port shared-lom GE1 
                        Router(config-if)# no shut
                        Router(config-if)# end
                        
                        Router# configure terminal
                        Router(config)# interface ucse 0/3/1
                        Router(config-if)# no shut
                        Router(config-if)# end
                        
                        Router# ping 10.0.0.2
                        Type escape sequence to abort.
                        Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
                        !!!!!
                        Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
                        
                        Configuring CIMC Access Using the EHWIC E-Series NCE's External GE2 Interface
                        Important:

                        If you are using the external GE2 interface on an EHWIC E-Series NCE to configure CIMC access, you might lose connectivity with CIMC during server reboot. This is expected behavior. If you must maintain connectivity with CIMC during a reboot, we recommend that you use one of the other network interfaces to configure CIMC access. See CIMC Access Configuration Options—EHWIC E-Series NCE.

                        If you want to use the external GE2 interface to configure CIMC access, we recommend that you use the spanning-tree portfast command. For details, see the CSCup50049 caveat in the Release Notes for Cisco UCS E-Series Servers and the Cisco UCS E-Series Network Compute Engine at http:/​/​www.cisco.com/​c/​en/​us/​td/​docs/​unified_computing/​ucs/​e/​2-0/​release/​notes/​2_​0_​release_​notes.html.

                        See the following figure and the procedure that follows to configure CIMC access using the EHWIC E-Series NCE's external GE2 interface.


                        Note


                        This figure shows how to configure CIMC access using the EHWIC E-Series NCE's external GE2 interface.


                        Figure 15. Configuring CIMC Access Using the EHWIC E-Series NCE's External GE2 Interface



                        Before You Begin

                        Make sure that you have the following information:

                        • IP address of CIMC.

                        • Username and password for logging in to the router.

                        • Slot and port number of the E-Series Server or NCE.

                        Procedure
                           Command or ActionPurpose
                          Step 1Router> enable  

                          Enters privileged EXEC mode on the host router. Enter your password if prompted.

                           
                          Step 2Router# configure terminal  

                          Enters global configuration mode on the host router.

                           
                          Step 3 Router (config)# interface ucse 0/slot/port  

                          Enters ucse interface configuration mode for the slot and port where the NCE is installed.

                           
                          Step 4Router (config-if)# imc ip address cimc-ip-address subnet-mask default-gateway cimc-gateway-ip-address  

                          Specifies the IP address of CIMC and the IP address of the default gateway that CIMC must use.

                          • cimc-ip-address—IP address of CIMC.

                          • subnet-mask—Subnet mask used to append to the IP address; must be in the same subnet as the host router.

                          • cimc-gateway-ip-address—IP address for the default gateway.

                           
                          Step 5Router (config-if)# imc access-port shared-lom GE2  

                          Configures CIMC access through the EHWIC E-Series NCE's external GE2 interface. See # 3 in Understanding the Interfaces in the EHWIC E-Series NCE and the Cisco ISR G2.

                           
                          Step 6Router (config-if)# no shut  

                          Causes the interface to be administratively up.

                           
                          Step 7Router (config-if)# end  

                          Exits interface configuration mode.

                           

                          This example shows how to configure CIMC access using the EHWIC E-Series NCE external GE2 interface:

                          Router> enable
                          Router> password
                          Router# configure terminal
                          
                          Router(config)# interface ucse 0/3/0
                          Router(config-if)# imc ip address 10.0.0.1 255.0.0.0 default-gateway 10.0.0.2 
                          Router(config-if)# imc access-port shared-lom GE2 
                          Router(config-if)# no shut
                          Router(config-if)# end
                          

                          Configuring CIMC Access Using the CIMC Configuration Utility


                          Note


                          This procedure is applicable to E-Series Servers and the SM E-Series NCE. This procedure is not applicable to the EHWIC E-Series NCE.


                          If you are a local user, you can use either the Cisco IOS CLI or the CIMC Configuration Utility to configure CIMC access. To configure CIMC access using the Cisco IOS CLI, see Configuring CIMC Access Using the Cisco IOS CLI.


                          Note


                          When you use the CIMC Configuration Utility to configure CIMC access, the configuration is not reflected as a Cisco IOS configuration. In other words, if you execute the show running-config command from the Cisco IOS CLI, the changes that you made using the CIMC Configuration Utility are not reflected.


                          Procedure
                            Step 1   Power on the router.
                            Step 2   Connect a keyboard and monitor to the front panel of the E-Series Server.
                            Step 3   Press the Power button to boot the E-Series Server. During bootup, watch for the prompt to press F8.
                            Step 4   When you see the prompt, press F8.

                            The CIMC Configuration Utility appears.

                            Figure 16. CIMC Configuration Utility



                            Step 5   Use the CIMC configuration Utility to set the NIC mode and NIC redundancy, and to choose whether to enable DHCP or set static network settings.
                            1. From the NIC mode area, choose a port to access CIMC. Options are:
                              • Dedicated—The 10/100 IMC port is used to access CIMC.

                              • Shared LOM (default)—The four 1Gb Ethernet ports are used to access the CIMC. This is the factory default setting.

                            2. From the NIC redundancy area, choose the NIC redundancy. Options are:
                              • None—The Ethernet ports operate independently and do not fail over if there is a problem.

                              • Active-standby—If an active Ethernet port fails, the traffic falls over to a standby port. This is the factory default setting.

                            3. From the IPV4 (Basic) area, do one of the following:
                              • DHCP Enabled—Select this option to enable DHCP for dynamic network settings. Before you enable DHCP, your DHCP server must be preconfigured with the range of MAC addresses for this server. The MAC address is printed on a label on the rear of the server. This server has a range of six MAC addresses assigned to CIMC. The MAC address printed on the label is the beginning of the range of six contiguous MAC addresses.

                              • CIMC IP—IP address of CIMC.

                                Subnet Mask—Enter the subnet mask to append to the CIMC IP address; must be in the same subnet as the host router.

                                Gateway—IP address of the default gateway router.

                            4. (Optional) From the VLAN (Advanced) area, configure VLAN settings.
                            5. Press F5 to refresh the page and have the new settings appear.

                              The page refresh takes approximately 45 seconds.

                            6. Press F10 to save your settings and reboot the server.

                              If you chose to enable DHCP, the dynamically assigned IP and MAC addresses are displayed on the console screen during bootup.

                            Step 6   Using the ports that you selected for the NIC Mode settings in Step 5, substep a, connect Ethernet cables from your LAN to the E-Series Server.
                            Step 7   In your web browser, enter the IP address that you configured to access CIMC. The CIMC IP address is based upon the settings that you configured in Step 5, substep c (either a static IP address or the IP address assigned by your DHCP server).

                            The default username to log in to CIMC is admin, and the default password is password.

                            Step 8   Use the CIMC GUI or CIMC CLI to manage and monitor the server.

                            See the GUI Configuration Guide for Cisco UCS E-Series Servers and the Cisco UCS E-Series Network Compute Engine or the CLI Configuration Guide for Cisco UCS E-Series Servers and the Cisco UCS E-Series Network Compute Engine.


                            Defining Network Static Settings Using a Script File

                            Use this procedure to define static network settings for multiple servers by automating the configuration process with a script file.
                            Procedure
                              Step 1   Use a text editor to create a file named network.cfg.
                              Step 2   Create the contents of network.cfg in the following format by using only the tags that you want to set:
                              dhcp-enabled:
                              v4-addr:
                              v4-netmask:
                              v4-gateway:
                              vlan-enabled:
                              vlan-id:
                              vlan-priority:
                              password: 
                              mode:
                              redundancy:
                              
                              
                              For example, to disable DHCP, set the IP address, subnet mask, gateway, and user password, use the following sample values:
                              dhcp-enabled: 0
                              v4-addr: 10.193.70.102
                              v4-netmask: 255.255.255.0
                              v4-gateway: 10.193.70.1
                              password: nonpasswd
                              mode:
                              redundancy:
                              
                              
                              Step 3   Use a text editor to create a file named startup.nsh with the following contents:
                              fs0:
                              cimcconfig
                              
                              
                              Step 4   Copy your network.cfg file and your startup.nsh file to a USB thumb drive.
                              Step 5   Insert the USB thumb drive into a USB port on the server.
                              Step 6   Press and release the Power button to boot the server.
                              Step 7   Observe the booting process and press F6 when prompted to enter the BIOS Boot Manager.
                              Step 8   Select EFI as the boot device and then press Enter.

                              The server power-cycles and launches the configuration utility, which runs the startup.nsh file. Any errors are displayed on the screen and on an errors.txt file.

                              Step 9   Remove the USB thumb drive, alter the network.cfg file with your next IP address, and then insert the USB thumb drive into the next server that you want to configure.
                              Step 10   After the server has been assigned an IP address, you can use that address to access the service processor's GUI or CLI management system.

                              What to Do Next

                              Do one of the following as appropriate:

                              • If you purchased an E-Series Server or NCE Option 1 (E-Series Server or NCE without a preinstalled operating system or hypervisor), log in to the CIMC GUI or the CIMC CLI to access CIMC. See Accessing the Management Firmware.

                              • If you purchased an E-Series Server or NCE Option 2 (E-Series Server or NCE with a preinstalled Microsoft Windows Server) or Option 3 (E-Series Server or NCE with a preinstalled VMware vSphere Hypervisor), configure an internal connection between the router and the E-Series Server or NCE. Do one of the following:
                                • If you do not want the traffic to your application or operating system to flow through the router, use the server’s host operating system to configure the E-Series Server’s or NCE's external interface.

                                • If you want the traffic to your application or operating system to flow through the router, use the Cisco IOS CLI to configure an internal connection between the router and the E-Series Server or NCE. See Configuring a Connection Between the Router and the E-Series Server or NCE.