Getting Started Guide for Cisco UCS E-Series Servers, Release 2.x
Configuration Differences
Downloads: This chapterpdf (PDF - 1.26MB) The complete bookPDF (PDF - 5.75MB) | The complete bookePub (ePub - 2.02MB) | Feedback

Configuration Differences

This chapter includes the following sections:

Router Configuration Differences Between the Cisco SRE-V and the E-Series Server—ISR G2

The examples in the following table provide the key differences between the Cisco SRE-V and the E-Series Server configuration.

Table 1  Differences in Router Configuration Between the Cisco SRE-V and the E-Series Server—ISR G2

Cisco SRE-V Configuration

Cisco E-Series Server Configuration

interface GigabitEthernet0/0
ip address 10.0.0.1 255.0.0.0

interface sm 1/0
ip unnumbered GigabitEthernet0/0
service-module ip address 10.0.0.2 255.0.0.0
service-module ip default-gateway 10.0.0.1


interface SM1/1
 switchport mode trunk

ip route 10.0.0.2 255.255.255.255 sm1/0
interface GigabitEthernet0/0
ip address 10.0.0.1 255.0.0.0

interface ucse 1/0
ip unnumbered GigabitEthernet0/0
imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
imc access-port shared-lom console


interface ucse1/1
 switchport mode trunk

ip route 10.0.0.2 255.255.255.255 ucse1/0

Note the following differences:

  • In the E-Series Server, the sm slot/port command is replaced by the ucse slot/port command.
  • In the E-Series Server, the service-module keyword is replaced by the imc keyword.
  • In the E-Series Server, the default gateway command resides in the same command line as the imc ip address command.
  • Since the E-Series Server has different external interfaces, you must specify the access port using the imc access-port command.
  • In the E-Series Server, you can either use the dedicated interface or one of the shared local area network on motherboard (shared LOM) interfaces to configure CIMC access. See Configuring CIMC Access. In the above example, the imc access-port shared-lom console command uses the console interface for CIMC access, where:
    • imc access-port—is the physical Ethernet connection to the E-Series Server.
    • shared-lom—is shared LOM.
    • console—is the router interface.

The command to session into the server has also changed:

  • Cisco SRE-V uses the service-module sm slot/0 session command to session into the server.
  • E-Series Server uses the ucse slot session {imc | host} command to session into the server.

Router Configuration Differences Between the ISR G2 and the Cisco ISR 4451-X

The examples in the following table provide the key differences between the ISR G2 configuration and the Cisco ISR 4451-X configuration.

Table 2  Differences in Router Configuration Between the ISR G2 and the Cisco ISR 4451-X

Cisco ISR G2 Configuration

Cisco ISR 4451-X Configuration

interface GigabitEthernet0/0
 ip address 10.0.0.1 255.0.0.0

interface ucse 1/0
 ip unnumbered GigabitEthernet0/0
 imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
 imc access-port shared-lom console


interface ucse1/1
 switchport mode trunk

ip route 10.0.0.2 255.255.255.255 ucse1/0
interface GigabitEthernet 0/0/0
 ip address 10.0.0.1 255.0.0.0

ucse subslot 1/0
 imc access-port ge0
 imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1 

interface ucse1/0/0
 ip unnumbered GigabitEthernet0/0/0
 no negotiation auto
 switchport mode trunk

ip route 10.0.0.2 255.255.255.255 ucse1/0/0

Note the following differences:

  • In the Cisco ISR 4451-X, the interface ucse slot/port command is replaced by the ucse subslot slot/port and the interface ucse slot/port/subport commands.
  • In the Cisco ISR 4451-X (with Cisco IOS XE Release 3.9S), the imc access-port shared-lom command is replaced by the imc access-port command.
  • In the ISR G2, you can use either the dedicated interface or one of the shared local area network on motherboard (shared LOM) interfaces to configure CIMC access. In the Cisco ISR 4451-X, you can use either the management interface or one of the NIC interfaces to configure CIMC access. See Configuring CIMC Access. In the above example, the command configures CIMC access using the E-Series Server's internal GE0 NIC interface, where:
    • imc access-port—CIMC access port configuration.
    • ge0E-Series Server's internal GE0 NIC interface.

The command to session into the server has also changed:

  • In the ISR G2, you use the ucse slot session {imc | host} command to session into the server.
  • In the Cisco ISR 4451-X, you use the hw-module subslot slot/0 session {imc | server} command to session into the server.

VMware vSphere Hypervisor Configuration Differences

In the Cisco SRE-V, the IP address of the VMware vSphere Hypervisor™ host is the same as the IP address of the service module. For example, in the Cisco SRE-V, service-module ip address 10.0.0.2 (see table) is also assigned to the VMware vSphere Hypervisor™ host.

Table 3  Differences in Router Configuration Between the Cisco SRE-V and the E-Series Server—ISR G2

Cisco SRE-V Configuration

Cisco E-Series Server Configuration

interface GigabitEthernet0/0
ip address 10.0.0.1 255.0.0.0

interface sm 1/0
ip unnumbered GigabitEthernet0/0
service-module ip address 10.0.0.2 255.0.0.0
service-module ip default-gateway 10.0.0.1


interface SM1/1
 switchport mode trunk

ip route 10.0.0.2 255.255.255.255 sm1/0
interface GigabitEthernet0/0
ip address 10.0.0.1 255.0.0.0

interface ucse 1/0
ip unnumbered GigabitEthernet0/0
imc ip address 10.0.0.2 255.0.0.0 default-gateway 10.0.0.1
imc access-port shared-lom console


interface ucse1/1
 switchport mode trunk

ip route 10.0.0.2 255.255.255.255 ucse1/0

However, with the E-Series Server, the IMC IP address, which is also 10.0.0.2 (see the example above), is reserved for CIMC access. You enter this IP address (10.0.0.2) on your web browser to access the CIMC GUI.

In the E-Series Server, either the VMware vSphere Hypervisor™ assigns an IP address to the host using DHCP, or you can choose to assign a static IP address to the VMware vSphere Hypervisor™ host. See Assigning a Static IP Address to the VMware vSphere Hypervisor.