Cisco Nexus 7000 Series NX-OS Fundamentals Configuration Guide, Release 4.0
Basic Device Management
Downloads: This chapterpdf (PDF - 187.0KB) The complete bookPDF (PDF - 3.29MB) | Feedback

Basic Device Management

Table Of Contents

Basic Device Management

Information About Basic Device Management

mgmt0 Interface

Device Hostname

Message-of-the-Day Banner

Device Clock

Time Zone and Summer Time (Daylight Savings Time)

User Sessions

Virtualization Support

Licensing Requirements for Basic Device Management

Configuring the mgmt0 Interface

Changing the Device Hostname

Configuring the MOTD Banner

Configuring the Time Zone

Configuring Summer Time (Daylight Saving Time)

Manually Setting the Device Clock

Managing Users

Displaying Information about the Users Sessions

Sending a Message to Users

Example of Basic Device Management

Verifying Basic Device Settings

Default Settings

Additional References

Related Documents


Basic Device Management


This chapter describes how to perform basic management tasks on the Cisco NX-OS device.

This chapter includes the following sections:

Information About Basic Device Management

Configuring the mgmt0 Interface

Changing the Device Hostname

Configuring the MOTD Banner

Configuring the Time Zone

Configuring Summer Time (Daylight Saving Time)

Manually Setting the Device Clock

Managing Users

Example of Basic Device Management

Verifying Basic Device Settings

Default Settings

Additional References

Information About Basic Device Management

This section include the following topics:

mgmt0 Interface

Device Hostname

Message-of-the-Day Banner

Device Clock

Time Zone and Summer Time (Daylight Savings Time)

User Sessions

Virtualization Support

mgmt0 Interface

The mgmt0 interface on Cisco NX-OS devices provides out-of-band management, which enables you to manage the device by its IPv4 or IPv6 address. The mgmt0 interface uses 10/100/1000 Ethernet.

For detailed information on configuring interfaces, see the Cisco Nexus 7000 Series NX-OS Interfaces Configuration Guide, Release 4.0 and the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 4.0.

Device Hostname

You can change the device hostname displayed in the command prompt from the default (switch) to another character string. When you give the device a unique hostname, you can easily identify the device from the command-line interface (CLI) prompt.

Message-of-the-Day Banner

The message-of-the-day (MOTD) banner displays before the user login prompt on the device. This message can contain any information that you want to display for users of the device.

Device Clock

If you do not synchronize your device with a valid outside timing mechanism, such as an NTP clock source, you can manually set the clock time when your device boots. For information about NTP, see the Cisco Nexus 7000 Series NX-OS System Management Configuration Guide, Release 4.0.

Time Zone and Summer Time (Daylight Savings Time)

You can configure the time zone and summer time (daylight savings time) setting for your device. These values offset the clock time from Coordinated Universal Time (UTC). UTC is International Atomic Time (TAI) with leap seconds added periodically to compensate for the Earth's slowing rotation. UTC was formerly called Greenwich Mean Time (GMT).

User Sessions

You can display the active user session on your device. You can also send messages to the user sessions. For more information about managing user sessions and accounts, see the Cisco Nexus 7000 Series NX-OS Security Configuration Guide, Release 4.0.

Virtualization Support

Basic device management is local to the virtual device context (VDC). The mgmt0 interface exists in the management virtual routing and forwarding instance (VRF) and is accessible from any VDC. You can configure a unique IP address for the mgmt0 interface in each VDC.

For more information on VDCs, see the Cisco Nexus 7000 Series NX-OS Virtual Device Context Configuration Guide, Release 4.0. For more information on VRFs, see the Cisco Nexus 7000 Series NX-OS Unicast Routing Configuration Guide, Release 4.0.

Licensing Requirements for Basic Device Management

The following table shows the licensing requirements for this feature:

Product
License Requirement

NX-OS

Basic device management requires no license. Any feature not included in a license package is bundled with the Cisco NX-OS system images and is provided at no extra charge to you. For a complete explanation of the NX-OS licensing scheme, see the Cisco NX-OS Licensing Guide.


Configuring the mgmt0 Interface

You can configure the mgmt0 interface on your Cisco NX-OS device.

BEFORE YOU BEGIN

Ensure that the management Ethernet (MGMT ETH) port on the active supervisor module is connected the network (see the hardware installation guide for your device).

For the default VDC, log in to the console port.

For non-default VDCs, log in to the default VDC and use the switchto vdc command.

SUMMARY STEPS

1. configure terminal

2. interface mgmt0

3. ip address ipv4-address[/length]

ipv6 address ipv6-address[/length]

4. no shutdown

5. exit

6. vrf context management

7. ip route ipv4-prefix[/length] ipv4-nexthop-address

ipv6 route ipv6-prefix[/length] ipv6-nexthop-address

8. exit

9. show interface mgmt0

10. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal


Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

interface mgmt0


Example:

switch(config)# interface mgmt0

switch(config-if)#

Specifies the mgmt0 interface and enters interface configuration mode.

Step 3 

ip address ipv4-address[/length]


Example:

switch(config-if)# ip address 172.20.1.1/23

Configures the IPv4 address.

ipv6 address ipv6-address[/length]


Example:

switch(config-if)# ipv6 address 2001:0DB8:c18:1::3/64

Configures the IPv6 address.

Step 4 

no shutdown


Example:

switch(config-if)# no shutdown

Enables the interface.

Step 5 

exit


Example:

switch(config-if)# exit

switch(config)#

Exits interface configuration mode.

Step 6 

vrf context management


Example:

switch(config)# vrf context management

switch(config-vrf)#

Specifies the management VRF and enters VRF configuration mode.

Step 7 

ip route ipv4-prefix[/length] ipv4-nexthop-address


Example:

switch(config-vrf)# ip route 0.0.0.0/0 172.20.20.1

Configures the IPv4 address of the next hop.

ipv6 route ipv6-prefix[/length] ipv6-nexthop-address


Example:

switch(config-vrf)# ipv6 route 2001:0DB8::/16 2001:0DB8:c18:1::2

Configures the IPv6 address of the next hop.

Step 8 

exit


Example:

switch(config-vrf)# exit

switch(config)#

Exits interface configuration mode.

Step 9 

show interface mgmt0


Example:

switch(config)# show interface mgmt0

(Optional) Displays the mgmt0 interface configuration and status.

Step 10 

copy running-config startup-config


Example:

switch(config)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Changing the Device Hostname

You can change the device hostname displayed in the command prompt from the default (switch) to another character string.

SUMMARY STEPS

1. configure terminal

2. hostname name

switchname name

3. exit

4. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal


Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

hostname name


Example:

switch(config)# hostname Engineering2

Engineering2(config)#

Changes the device hostname. The default is switch.

switchname name


Example:

switch# switchname Engineering2

Engineering2(config)#

Changes the device hostname. The default is switch.

Step 3 

exit


Example:

Engineering2(config)# exit

Engineering2#

Exits global configuration mode.

Step 4 

copy running-config startup-config


Example:

Engineering2# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuring the MOTD Banner

You can configure the MOTD to display before the login prompt on the terminal when a user logs in.The MOTD banner has the following characteristics:

Maximum of 80 characters per line

Maximum of 40 lines

SUMMARY STEPS

1. configure terminal

2. banner motd delimiting-character message delimiting-character

3. exit

4. show banner motd

5. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal


Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

banner motd delimiting-character message delimiting-character


Example: 
switch(config)# banner motd #Welcome to 
the Switch#
switch(config)# 

Configures the MOTD banner. Do not use the delimiting-character in the message text.

Note Do not use " and % as a delimiting character.

Step 3 

exit


Example:

switch(config)# exit

switch#

Exits global configuration mode.

Step 4 

show banner motd


Example:

switch# show banner motd

(Optional) Displays the configured MOTD banner.

Step 5 

copy running-config startup-config


Example:

switch# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuring the Time Zone

You can configure the time zone to offset the device clock time from UTC.

SUMMARY STEPS

1. configure terminal

2. clock timezone zone-name offset-hours offset-minutes

3. exit

4. show clock

5. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal


Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

clock timezone zone-name offset-hours offset-minutes


Example: 
switch(config)# clock timezone EST -5 0

Configures the time zone. The zone-name argument is a 3-character string for the time zone acronym (for example, PST or EST). The offset-hours argument is the offset from the UTC and the range is from -23 to 23 hours. The range for the offset-minutes argument is from 0 to 59 minutes.

Step 3 

exit


Example:

switch(config)# exit

switch#

Exits global configuration mode.

Step 4 

show banner clock


Example:

switch# show clock

(Optional) Displays the time and time zone.

Step 5 

copy running-config startup-config


Example:

switch# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuring Summer Time (Daylight Saving Time)

You can configure when summer time, or daylight saving time, is in effect for the device and the offset in minutes.

SUMMARY STEPS

1. configure terminal

2. clock summer-time zone-name start-week start-day start-month start-time end-week end-day end-month end-time offset-minutes

3. exit

4. show clock detail

5. copy running-config startup-config

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal


Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2 

clock summer-time zone-name start-week start-day start-month start-time end-week end-day end-month end-time offset-minutes


Example: 
switch(config)# clock summer-time PDT 1 
Sunday March 02:00 1 Sunday November 
02:00 60

Configures summer time or daylight saving time.

The zone-name argument is a three characters string for the time zone acronym (for example, PST and EST).

The values for the start-day and end-day arguments are Monday, Tuesday, Wednesday, Thursday, Friday, Saturday, and Sunday.

The values for start-month and end-month arguments are January, February, March, April, May, June, July, August, September, October, November, and December.

The value for the start-time and end-time arguments are in the format hh:mm.

The range for the offset-minutes argument is from 0 to 1440 minutes.

Step 3 

exit


Example:

switch(config)# exit

switch#

Exits global configuration mode.

Step 4 

show clock detail


Example:

switch(config)# show clock detail

(Optional) Displays the configured MOTD banner.

Step 5 

copy running-config startup-config


Example:

switch# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Manually Setting the Device Clock

You can set the clock manually if your device cannot access a remote time source.

BEFORE YOU BEGIN

Configure the time zone (see the "Configuring the Time Zone" section).

SUMMARY STEPS

1. clock time day month year

2. show clock

DETAILED STEPS

 
Command
Purpose

Step 1 

clock set time day month year


Example:

switch# clock set 15:00:00 30 May 2008

Fri May 30 15:14:00 PDT 2008

Configures the device clock.

The format for the time argument is hh:mm:ss.

The range for the day argument is from 1 to 31.

The values for the month argument are January, February, March, April, May, June, July, August, September, October, November, and December.

The range for the year argument is from 2000 to 2030.

Step 2 

show clock


Example: 
switch(config)# show clock

(Optional) Displays the current clock value.

Managing Users

This section includes the following topics:

Displaying Information about the Users Sessions

Sending a Message to Users

Displaying Information about the Users Sessions

You can display information about the user session on the device.

SUMMARY STEPS

1. show users

DETAILED STEPS

 
Command
Purpose

Step 1 

show users


Example:

switch# show users

Displays the user sessions.

For detailed information about the fields in the output from this command, see the Cisco Nexus 7000 Series NX-OS Fundamentals Command Reference, Release 4.0.

Sending a Message to Users

You can send a message to active users currently using the device CLI.

SUMMARY STEPS

1. show users

2. send [session line] message-text

DETAILED STEPS

 
Command
Purpose

Step 1 

show users


Example:

switch# show users

(Optional) Displays the active user sessions.

Step 2 

send [session line] message-text


Example:

switch# send Reloading the device is 10 minutes!

Sends a message to all active users or to a specific user. The message can be up to 80 alphanumeric characters and is case sensitive.

Example of Basic Device Management

This example shows how to configure the mgmt0 interface using IPv4 addressing:

interface mgmt0
  ip address 172.10.10.10/24
vrf context management
  ip route 0.0.0.0/0 172.10.10.1 

Verifying Basic Device Settings

To verify the basic device settings, perform one of the following tasks:

Command
Purpose

show banner motd

Displays the banner MOTD.

show clock

Displays clock and timezone settings.

show clock detail

Displays the summer time settings.


Default Settings

Table 5-1 lists the default settings for basic device parameters.

Table 5-1 Default Basic Device Parameters

Parameters
Default

MOTD banner text

User Access Verification

Clock time zone

UTC


Additional References

For additional information related to basic device management, see the following sections:

Related Documents

Related Documents

Related Topic
Document Title

Licensing

Cisco Nexus 7000 Series NX-OS Licensing Guide, Release 4.0

Command reference

Cisco Nexus 7000 Series NX-OS Fundamentals Command Reference, Release 4.0