Cisco Nexus 1000V System Management Configuration Guide, Release 4.2(1)SV1(4a)
Managing Server Connections
Downloads: This chapterpdf (PDF - 185.0KB) The complete bookPDF (PDF - 4.4MB) | Feedback

Table of Contents

Managing Server Connections

Information About Server Connections

Guidelines and Limitations

Connecting to the vCenter Server

Disconnecting From the vCenter Server

Removing the DVS from the vCenter Server

Removing the DVS from the vCenter Server When the VSM Is Not Connected

Configuring the DVS Admin User or DVS Admin Group

Removing the DVS from the vCenter Server With the DVS Admin Account

Configuring Host Mapping

Information about Host Mapping

Removing Host Mapping from a Module

Mapping to a New Host

Viewing Host Mapping

Verifying Connections

Verifying the Domain

Verifying the Configuration

Verifying Module Information

Feature History for Server Connections

Information About Server Connections

In order to connect to vCenter Server or an ESX server, you must first define the connection in the Cisco Nexus 1000V including the following:

  • A connection name
  • The protocol used
  • The server IP address
  • The server DNS name
  • The datacenter name

All communication with vCenter Server is secured by the TLS protocol.

Guidelines and Limitations

Server connections have the following configuration guidelines and limitations:

  • A single VSM can only connect to one vCenter server at a time. A single VSM cannot connect to multiple vCenter servers at once.

Connecting to the vCenter Server

Use this procedure to configure a connection and then connect to vCenter server or an ESX server.

BEFORE YOU BEGIN

  • You are logged in to the CLI in EXEC mode.
  • You know the datacenter name.
  • The vCenter Server management station is installed and running.
  • You know the vCenter Server IP address or hostname.
  • The ESX servers are installed and running.
  • The management port is configured.
  • The vCenter Server is reachable from the Cisco Nexus 1000V.
  • The Cisco Nexus 1000V appliance is installed.
  • If you are configuring a connection using a hostname, DNS is already configured.
  • You have already registered an extension with the vCenter Server. The extension includes the extension key and public certificate for the VSM. vCenter Server uses these to verify the authenticity of the request it receives from the VSM. For instructions about adding and registering an extension, see the Cisco Nexus 1000V Software Installation Guide, Release 4.2(1)SV1(4a) .

SUMMARY STEPS

1. config t

2. svs connection name

3. protocol vmware-vim

4. remote {ip address address A.B.C.D | hostname name}

5. vmware dvs datacenter-name name

6. connect

DETAILED STEPS

Command
Description

Step 1

config t

 

Example:

n1000v# config t

n1000v(config)#

Places you into global configuration mode.

Step 2

svs connection name

 

Example:

n1000v (config#) svs connection VC

n1000v(config-svs-conn#)

Places you into connection configuration mode for adding this connection between Cisco Nexus 1000V and either a particular ESX server or the vCenter Server. By using a name, information for multiple connections can be stored in the configuration.

Step 3

protocol vmware-vim [http]

 

Example:

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#)

Specifies that this connection uses the VIM protocol. This command is stored locally.

  • http: Specifies that the VIM protocol runs over HTTP. The default is to use HTTP over SSL (HTTPS).

Step 4

Do one of the following:

  • If you are configuring an IP address, go to Step 5.
  • If you are configuring a hostname, go to Step 6.

Step 5

remote ip address ipaddress

 

Example:

n1000v(config-svs-conn#) remote ip address 192.168.0.1

n1000v(config-svs-conn#)

 

Go to Step 7.

Specifies the IP address of the ESX server or vCenter Server for this connection. This command is stored locally.

Step 6

remote hostname hostname

 

Example:

n1000v(config-svs-conn#) remote hostname vcMain

n1000v(config-svs-conn#)

Specifies the DNS name of the ESX server or vCenter Server for this connection. This command is stored locally.

Note DNS is already configured.

Step 7

vmware dvs datacenter-name [folder/] name

 

Example:

n1000v(config-svs-conn#) vmware dvs datacenter-name Hamilton-DC

n1000v(config-svs-conn#)

Identifies the datacenter name in the vCenter Server where Cisco Nexus 1000V is to be created as a distributed virtual switch (DVS). You can use this command before or after connecting. The datacenter name is stored locally.

Note The Nexus 1000V folder name should be same in the vCenter Server and in the VSM. If the Nexus 1000V folder is renamed in the vCenter Server, it must also be renamed in the VSM.

Step 8

connect

 

Example:

n1000v(config-svs-conn#) connect

 

Initiates the connection. If the username and password have not been configured for this connection, the user is prompted for a username and password.

The default is no connect. There can be only one active connection at a time. If a previously-defined connection is up, an error message displays and the command is rejected until the user closes the previous connection by entering no connect.

Examples

n1000v# config t

n1000v (config)# svs connection VC

n1000v(config-svs-conn#) protocol vmware-vim

n1000v(config-svs-conn#) remote ip address 192.168.0.1

n1000v(config-svs-conn#) vmware dvs datacenter-name Hamilton-DC

n1000v(config-svs-conn#) connect
 
 
n1000v# show svs connections
connection VC:
ip address: 192.168.0.1
protocol: vmware-vim https
certificate: default
datacenter name: Hamilton-DC
DVS uuid: ac 36 07 50 42 88 e9 ab-03 fe 4f dd d1 30 cc 5c
config status: Enabled
operational status: Connected
n1000v#

Disconnecting From the vCenter Server

Use this procedure to disconnect from the vCenter Server, for example, after correcting a vCenter Server configuration.

BEFORE YOU BEGIN

  • You are logged in to the Cisco Nexus 1000V in EXEC mode.
  • You have configured an Cisco Nexus 1000V connection using the Connecting to the vCenter Server.
  • The Cisco Nexus 1000V is connected to vCenter Server/ESX.

DETAILED STEPS

 

Command
Description

Step 1

config t

 

Example:

n1000v# config t

n1000v(config)#

Places you into global configuration mode.

Step 2

svs connection name

 

Example:

n1000v (config#) svs connection vcWest

n1000v(config-svs-conn)#

Places you into a global configuration submode for the connection to vCenter Server.

Step 3

no connect

 

Example:

n1000v(config-svs-conn)# no connect
n1000v(config-svs-conn)#

Closes the connection.

Removing the DVS from the vCenter Server

Use this procedure to remove the DVS from the vCenter Server.


Note If do you not have connectivity to the VSM, see the “Removing the DVS from the vCenter Server When the VSM Is Not Connected” section.


BEFORE YOU BEGIN

  • You are logged in to the CLI in EXEC mode.
  • You have configured a connection using the Connecting to the vCenter Server.
  • The Cisco Nexus 1000V is connected to vCenter Server/ESX.
  • The Server Administrator has already removed from the VI client all of the hosts connected to Cisco Nexus 1000V. For more information, see the VMware documentation.

DETAILED STEPS

 

Command
Description

Step 1

config t

 

Example:

n1000v# config t

n1000v(config)#

Places you into global configuration mode.

Step 2

svs connection name

 

Example:

n1000v(config#) svs connection vcWest

n1000v(config-svs-conn)#

Places you into a global configuration submode for the connection to vCenter Server.

Step 3

no vmware dvs

 

Example:

n1000v(config-svs-conn)# no vmware dvs

n1000v(config-svs-conn)#

Removes the DVS associated with the specified connection from the vCenter Server.

Removing the DVS from the vCenter Server When the VSM Is Not Connected

Use this procedure to remove the DVS from the vCenter Server when the VSM does not have connectivity to the vCenter Server.

Configuring the ability to delete the DVS when the VSM is not connected to the vCenter Server is a two-step process:

1. Configure the admin user or group. See the Configuring the DVS Admin User or DVS Admin Group.

2. Remove the DVS from the vCenter Server. See the Removing the DVS from the vCenter Server With the DVS Admin Account.

BEFORE YOU BEGIN

  • You are logged in to the CLI in EXEC mode.
  • You have logged in the vCenter Server.
  • The admin user or group account has been configured on the vCenter Server.

Configuring the DVS Admin User or DVS Admin Group

Use this procedure to configure a DVS admin user or DVS admin group.

BEFORE YOU BEGIN

  • Ensure that the System Administrator has created an admin user or admin group on the vCenter Server to manage and delete the DVS. This user should not be given any other permissions like deploying VMs or hosts, etc. The admin user name configured on the VSM should be the same as the user name on the vCenter Server.

Summary Steps

1. config t

2. show svs connections

3. svs connection name

4. admin {user username | group groupname }

5. show svs connections

Detailed Steps


Step 1 Determine the name of the DVS.

switch# show svs connections
 
connection VC:
ipaddress: 10.104.63.16
remote port: 80
protocol: VMware-vim https
certificate: default
datacenter name: N1K-DC
admin:
DVS uuid: a2 …
config status: Enabled
operational status: Connected
sync status: Complete
version: VMware vCenter Server 4.1.0 build 258902
 

Step 2 Configure the admin user in the vCenter Server.

switch# config t
switch(config)# svs connection VC
switch(config-svs-conn) # admin user NAuser
switch(config-svs-conn) #

Note You can also configure an admin group by entering the admin group groupname command.


Step 3 Verify that the admin user has been created.

switch# show svs connections
 
connection VC:
ipaddress: 10.104.63.16
remote port: 80
protocol: VMware-vim https
certificate: default
datacenter name: N1K-DC
admin: NAuser(user)
DVS uuid: a2 …
config status: Enabled
operational status: Connected
sync status: Complete
version: VMware vCenter Server 4.1.0 build 258902


 

Removing the DVS from the vCenter Server With the DVS Admin Account

Use this procedure to remove the DVS from the vCenter Server.


Step 1 Log in to the vCenter Server through the VMware vSphere Client with the DVS admin account that was configured in Configuring the DVS Admin User or DVS Admin Group.

Step 2 In the vSphere Client left pane, choose the data center.

Step 3 Click Hosts and Clusters > Networking .

Step 4 Right-click the DVS and choose Remove .


 

Configuring Host Mapping

This section includes the following topics:

Information about Host Mapping

When a VSM detects a new VEM, it automatically assigns a free module number to the VEM and then maintains the mapping between the module number and UUID of a host server. This mapping is used to assign the same module number to a given host server.

Removing Host Mapping from a Module

Use this procedure to remove the mapping of a module to a host server.

BEFORE YOU BEGIN

  • You are logged in to the CLI in EXEC mode.
  • You have already removed the host from the Cisco Nexus 1000V DVS on vCenter.

SUMMARY STEPS

1. config t

2. no vem module-number

3. show module vem mapping

4. copy running-config startup-config

DETAILED STEPS

 

Command
Description

Step 1

config t

 

Example:

n1000v# config t

n1000v(config)#

Places you into CLI Global Configuration mode.

Step 2

no vem module-number

 

Example:

n1000v(config)# no vem 4

n1000v(config)# no vem 3

cannot modify slot 3: host module is inserted

n1000v((config)#

Removes the specified module from software.

Note If the module is still present in the slot, the command is rejected, as shown in this example.

Step 3

show module vem mapping

 

Example:

n1000v(config)# show module vem mapping

(Optional) Displays the mapping of modules to host servers.

Step 4

copy running-config startup-config

 

Example:

n1000v(config-vem-slot)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

Example

This example shows the VEM mapping.

n1000v(config)# show module vem mapping

Mod Status UUID License Status

--- ----------- ------------------------------------ --------------

3 powered-up 93312881-309e-11db-afa1-0015170f51a8 licensed

n1000v(config)#

 

Mapping to a New Host

Use this procedure to map a module number to a different host server UUID.

BEFORE YOU BEGIN


Note If you do not first remove the existing host server mapping, the new host server is assigned a different module number.


SUMMARY STEPS

1. config t

2. vem module number

3. host vmware id server-bios-uuid

4. show module vem mapping

5. copy running-config startup-config

DETAILED STEPS

 

Command
Description

Step 1

config t

 

Example:

n1000v# config t

n1000v(config)#

Places you into CLI Global Configuration mode.

Step 2

vem module number

 

Example:

n1000v(config)# vem 3

n1000v((config-vem-slot)#

Places you into CLI VEM Slot Configuration mode.

Step 3

host vmware id server-bios-uuid

 

Example:

n1000v(config-vem-slot)# host vmware id 6dd6c3e3-7379-11db-abcd-000bab086eb6

n1000v(config-vem-slot)#

Assigns a different host server UUID to the specified module.

Step 4

show module vem mapping

 

Example:

n1000v(config-vem-slot)# show module vem mapping

(Optional) Displays the mapping of modules to host servers.

Step 5

copy running-config startup-config

 

Example:

n1000v(config-vem-slot)# copy running-config startup-config

(Optional) Saves the running configuration persistently through reboots and restarts by copying it to the startup configuration.

Example

This example shows the VEM mapping.

n1000v(config-vem-slot)# show module vem mapping

Mod Status UUID License Status

--- ----------- ------------------------------------ --------------

3 powered-up 93312881-309e-11db-afa1-0015170f51a8 licensed

4 absent 6dd6c3e3-7379-11db-abcd-000bab086eb6 licensed

 

n1000v(config-vem-slot)#

Viewing Host Mapping

Use this procedure in EXEC mode to view the mapping of modules to host servers.

Summary Steps

1. show module vem mapping

Detailed Steps


Step 1 Display the mapping on modules to host servers by entering the following command:

n1000v(config)# show module vem mapping

Mod Status UUID License Status

--- ----------- ------------------------------------ --------------

3 powered-up 93312881-309e-11db-afa1-0015170f51a8 licensed

n1000v(config)#


 

Verifying Connections

Use this procedure to view and verify connections.

BEFORE YOU BEGIN

  • You are logged in to the CLI in any command mode.
  • You have configured the connection using the Connecting to the vCenter Server.
  • The Cisco Nexus 1000V is connected to vCenter Server/ESX.

Summary Steps

Detailed Steps

 

Command
Description

Step 1

show svs connections [name]

 

Example:

n1000v# show svs connections vc
Connection vc:
IP address: 172.28.15.206
Protocol: vmware-vim https
vmware dvs datacenter-name: HamiltonDC
ConfigStatus: Enabled
OperStatus: Connected
n1000v#

Displays the current connections to the Cisco Nexus 1000V.

Note Network connectivity issues may shut down your connection to the vCenter Server. When network connectivity is restored, the Cisco Nexus 1000V will not automatically restore the connection. In this case, you must restore the connection manually using the following command sequence,

no connect
connect

 

Verifying the Domain

Use this procedure to view and verify the configured domain.

BEFORE YOU BEGIN

  • You are logged in to the CLI in any command mode.
  • You have configured a domain using the Creating a Domain.

DETAILED STEPS

 

Command
Description

Step 1

show svs domain

 

Example:

n1000v# show svs domain
SVS domain config:
Domain id: 98
Control vlan: 70
Packet vlan: 71
Sync state: -
 
n1000v#

Display the domain configured on the Cisco Nexus 1000V.

Verifying the Configuration

Use this procedure to display and verify the running configuration.

BEFORE YOU BEGIN

  • You are logged in to the CLI in any command mode.
  • You have configured Cisco Nexus 1000V connections using the Connecting to the vCenter Server.
  • The Cisco Nexus 1000V is connected to vCenter Server/ESX.

DETAILED STEPS

 

Command
Description

Step 1

show running-config

Display the current configuration.

If the Cisco Nexus 1000V is not connected to a vCenter Server or ESX server, the output is limited to connection-related information.

Example:

n1000v(config-acl)# show running-config
version 4.0(4)SV1(1)
feature port-security
username adminbackup password 5 $1$Oip/C5Ci$oOdx7oJSlBCFpNRmQK4na. role network-operator
username admin password 5 $1$N1mX5tLD$daXpuxlAPcIHoz53PBhy6/ role network-admin
telnet server enable
ssh key rsa 1024 force
kernel core target 0.0.0.0
kernel core limit 1
system default switchport
ip access-list my66
10 permit ip 1.1.1.1/32 1.1.1.2/32
snmp-server user admin network-admin auth md5 0x90f3798f3e894496a11ec42ce2efec9c priv 0x90f3798f3e894496a11ec42ce2efec9c localizedkey
snmp-server enable traps entity fru
snmp-server enable traps license
vrf context management
ip route 0.0.0.0/0 172.28.15.1
switchname srini-cp
vlan 40-43,45-48
vdc srini-cp id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource monitor-session minimum 0 maximum 32
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 192
limit-resource u4route-mem minimum 32 maximum 256
limit-resource u6route-mem minimum 16 maximum 256
 
interface Ethernet6/2
inherit port-profile uplinkportprofile1
 
interface Ethernet6/3
inherit port-profile uplinkportprofile2
 
interface Ethernet6/4
inherit port-profile uplinportprofile3
 
interface Ethernet7/2
inherit port-profile uplinkportprofile1
 
interface mgmt0
ip address 172.28.15.163/24
 
interface Vethernet1
inherit port-profile vm100
 
interface Vethernet2
inherit port-profile vm100
 
interface Vethernet3
inherit port-profile vm100
 
interface Vethernet4
inherit port-profile vm100
 
interface Vethernet5
 
interface Vethernet6
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-1
boot system bootflash:/isan.bin sup-1
boot kickstart bootflash:/svs-kickstart-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/svs-mzg.4.0.1a.S1.0.82.bin sup-2
boot system bootflash:/isan.bin sup-2
ip route 0.0.0.0/0 172.28.15.1
port-profile uplinkportprofile1
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 1,40-43
no shutdown
system vlan 1,40-43
state enabled
port-profile vm100
vmware port-group
switchport mode access
switchport access vlan 43
ip port access-group my100 out
ip port access-group my66 in
no shutdown
state enabled
port-profile uplinkportprofile2
capability uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 45-46
no shutdown
state enabled
port-profile uplinportprofile3
capability uplink
vmware port-group
switchport trunk allowed vlan 47-48
state enabled
port-profile uplinkportprofile3
no shutdown
svs-domain
domain id 163
control vlan 41
packet vlan 42
svs connection VCR5
protocol vmware-vim
remote ip address 172.28.30.83
vmware dvs datacenter-name cisco-DC
connect
n1000v(config-acl)#

Verifying Module Information

Use this procedure to display and verify module information, including a view of the DVS from Cisco Nexus 1000V.

BEFORE YOU BEGIN

  • You are logged in to the CLI in any command mode.
  • You have configured the Cisco Nexus 1000V connection using the Connecting to the vCenter Server.
  • The Cisco Nexus 1000V is connected to vCenter Server/ESX.
  • The Server Administrator has already added the host running Cisco Nexus 1000V to the DVS in vCenter Server.

SUMMARY STEPS

1. show module

2. show server-info

3. show interface brief

4. show interface virtual

DETAILED STEPS

 

Command
Description

Step 1

show module

 
Example:
n1000v# show module

Displays module information.

Step 2

show server_info

 
Example:
n1000v# show server_info

Displays server information.

Step 3

show interface brief

 
Example:
n1000v# show interface brief

Displays interface information, including the uplinks to vCenter Server.

Step 4

show interface virtual

 
Example:
n1000v# show interface virtual

Displays virtual interface information.

 

Example
n1000v# show module
Mod Ports Module-Type Model Status
--- ----- -------------------------------- ------------------ ------------
1 1 Virtual Supervisor Module Nexus1000V active *
2 48 Virtual Ethernet Module ok
3 48 Virtual Ethernet Module ok
 
Mod Sw Hw World-Wide-Name(s) (WWN)
--- -------------- ------ --------------------------------------------------
1 4.0(0)S1(0.82) 0.0 --
2 NA 0.0 --
3 NA 0.0 --
 
Mod MAC-Address(es) Serial-Num
--- -------------------------------------- ----------
1 00-19-07-6c-5a-a8 to 00-19-07-6c-62-a8 NA
2 02-00-0c-00-02-00 to 02-00-0c-00-02-80 NA
3 02-00-0c-00-03-00 to 02-00-0c-00-03-80 NA
 
Mod Server-IP Server-UUID Server-Name
--- --------------- ------------------------------------ --------------------
1 172.18.217.180 esx-1
2 172.18.117.44 487701ee-6e87-c9e8-fb62-001a64d20a20 esx-2
3 172.18.217.3 4876efdd-b563-9873-8b39-001a64644a24 esx-3
 
* this terminal session
 
 
Example
n1000v# show server_info
 
Mod Status UUID
--- ----------- ----
2 powered-up 34303734-3239-5347-4838-323130344654
3 absent 371e5916-8505-3833-a02b-74a4122fc476
4 powered-up 4880a7a7-7b51-dd96-5561-001e4f3a22f9
5 absent 48840e85-e6f9-e298-85fc-001e4f3a2326
6 powered-up eb084ba6-3b35-3031-a6fe-255506d10cd0
n1000v#
 
 
Example
n1000v# show interface brief
 
--------------------------------------------------------------------------------
Port VRF Status IP Address Speed MTU
--------------------------------------------------------------------------------
mgmt0 -- up 172.28.15.211 1000 1500
 
--------------------------------------------------------------------------------
Ethernet VLAN Type Mode Status Reason Speed Port
Interface Ch #
--------------------------------------------------------------------------------
Eth2/2 1 eth trunk up none a-1000(D) --
 
--------------------------------------------------------------------------------
Interface VLAN Type Mode Status Reason MTU
--------------------------------------------------------------------------------
 
 
Example
n1000v# show interface virtual
 
--------------------------------------------------------------------------------
Port Adapter Owner Mod Host
--------------------------------------------------------------------------------
Veth49 R-VM-1 2 mcs-srvr35
 

Feature History for Server Connections

This section provides the server connections feature release history.

 

Feature Name
Releases
Feature Information

DVS Deletion

4.2(1)SV1(4a)

This feature was added.

Server Connections

4.0(4)SV1(1)

This feature was introduced.