Cisco IAD2430 Series Integrated Access Devices Software Configuration Guide
Chapter 4: Configuring Voice over IP
Downloads: This chapterpdf (PDF - 188.0KB) The complete bookPDF (PDF - 3.34MB) | Feedback

Configuring Voice over IP

Table Of Contents

Configuring Voice over IP

Prerequisites

Configuring the Voice Interface

VoIP Configuration Examples

FXS-to-FXS Connection

Configuration for IAD-1

Configuration for Router RLB-w

Configuration for Router R12-e

Configuration for IAD-2

Linking PBX Users with Digital E&M Trunk Lines over T1/E1 CAS

IAD SJ Configuration

IAD SLC Configuration

PSTN Gateway Access Using an FXO Connection

IAD SJ Configuration

IAD SLC Configuration

PSTN Gateway Access Using an FXO Connection in PLAR Mode

IAD SJ Configuration

IAD SLC Configuration


Configuring Voice over IP


This chapter explains how to configure voice interfaces and ports, which convert telephone voice signals for transmission over an IP network.

This chapter presents the following major topics:

Prerequisites

Configuring the Voice Interface

VoIP Configuration Examples

VoIP enables your Cisco IAD to carry live voice traffic (for example, telephone calls and faxes) over an IP network. VoIP offers the following benefits:

Toll bypass

Remote PBX presence over WANs

Unified voice and data trunking

Plain old telephone service (POTS)-Internet telephony gateways

For more information on understanding and configuring VoIP, see the Configuring Voice over IP document.

Prerequisites

Before you can configure your Cisco integrated access device (IAD) to use VoIP, you must first do the following:

Establish a working IP network.


Note For information applicable to the Cisco IAD2400 series, see "Voice over IP for the
Cisco 3600 Series Overview," and references therein, at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios113ed/113t/113t_1/voip/
voipover.htm

See also Configuring Voice over IP for the Cisco 3600 Series at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/voice_c/vcprt1/
vcvoip.htm


Implement a dial plan, including the following tasks:

Complete your company's dial plan. That is, decide what patterns of dialed numbers will access what telephony endpoints.

Establish a working telephony network based on your company's dial plan.

Integrate your dial plan and telephony network into your existing IP network topology.


Note To support FXO signaling, you must install a VIC2-4FXO interface card. For information on connecting voice interface cards (VICs), see "Connecting Voice Network Modules" at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis2600/hw_inst/nm_inst/
nm-doc/conntvoi.htm


Configuring the Voice Interface

Whenever you install a new interface or want to change the configuration of an existing interface, you must configure the interface. If you replace a module that was already configured, the Cisco IAD recognizes it and brings up the interface in the existing configuration.


Note The Cisco IAD2435 router is a fixed-configuration router and does not support interface cards.



Note The Cisco IAD2435 IAD does not support loss plan or idle voltage features available on other Cisco IAD2430 series IADs.


Before you configure an interface, have the following information available:

Protocols you plan to route on the new interface

IP addresses, subnet masks, network numbers, zones, or other information related to the routing protocol


Timesaver Obtain this information from your system administrator or network plan before you begin configuring your Cisco IAD.


To configure a voice interface, you must use configuration mode (manual configuration). In this mode, you can enter Cisco IOS commands through the command-line interface (CLI).

Before you begin, disconnect all WAN cables from the Cisco IAD to prevent it from running the AutoInstall process. The Cisco IAD tries to run AutoInstall whenever you power it on if there is a WAN connection on both ends and the Cisco IAD does not have a valid configuration file stored in NVRAM (for instance, when you add a new interface). It can take several minutes for the Cisco IAD to determine that AutoInstall is not connected to a remote TCP/IP host.

To configure the voice interface configuration mode, follow these steps:


Step 1 Connect a console to the Cisco IAD. If you need instructions for connecting a console, see the installation chapter of your Cisco IAD installation and configuration guide.

Step 2 Power on the Cisco IAD. If the current configuration is no longer valid, after about one minute you see the following prompt:

Would you like to enter the initial dialog? [yes/no]: 

Answer no. You now enter the normal operating mode of the Cisco IAD.


Note If the current configuration is valid, you enter the normal operating mode automatically.


Step 3 After a few seconds, you see the user EXEC prompt (Router>). Type enable and the password to enter enable mode:

Router> enable
Password: <password>

The prompt changes to the privileged EXEC (enable) prompt (Router#):

Router#

Step 4 Enter the configure terminal command to enter global configuration mode:

Router# configure terminal
Router(config)#

The Cisco IAD enters global configuration mode, indicated by the Router(config)# prompt.

Step 5 If you have not configured the Cisco IAD before, or you want to change the configuration, use Cisco IOS commands to configure global parameters, passwords, network management, and routing protocols. In this example, IP routing is enabled:

Router(config)# ip routing

For complete information about global configuration commands, see the Cisco IOS configuration guides and command references.

Step 6 If you have not already done so, configure the network module or WAN interface card that you plan to use for IP traffic. For instructions, see your Cisco IAD hardware installation and software configuration guides or the configuration note for the network module or WAN interface card.

Step 7 To configure another interface, enter the exit command to return to the Router(config)# prompt.

Step 8 To configure the Cisco IAD for voice traffic, see the VoIP references in the "Prerequisites" section.

Step 9 To exit configuration mode and return to the enable prompt, when you finish configuring interfaces, press Ctrl-Z. To see the current operating configuration, including any changes you just made, enter the show running-config command:

Router# show running-config

To see the configuration currently stored in NVRAM, enter the show startup-config command at the enable prompt:

Router# show startup-config

Step 10 The results of the show running-config and show startup-config commands differ if you have made changes to the configuration but have not yet written them to NVRAM. To write your changes to NVRAM and make them permanent, enter the copy running-config startup-config command at the enable prompt:

Router# copy running-config startup-config
Building configuration. . .
[OK]
Router# 

The Cisco IAD is now configured to boot in the new configuration.


VoIP Configuration Examples

The actual VoIP configuration procedure you complete depends on the topology of your voice network. The following configuration examples give you a starting point. Of course, you need to customize these configuration examples for your own network topology.

Configuration procedures and examples are supplied for the following scenarios:

FXS-to-FXS Connection

Linking PBX Users with Digital E&M Trunk Lines over T1/E1 CAS

PSTN Gateway Access Using an FXO Connection

PSTN Gateway Access Using an FXO Connection in PLAR Mode

FXS-to-FXS Connection

The following example shows how to configure VoIP for simple FXS-to-FXS connections over channelized T1/E1s. In this example, a very small company, consisting of two offices, has decided to integrate VoIP into its existing IP network. One basic telephony device is connected to IAD-1; therefore, IAD-1 has been configured for one POTS peer and one VoIP peer. Routers RLB-w and R12-e establish the WAN connection between the two offices. Because one POTS telephony device is connected to IAD-2, that Cisco IAD has also been configured for only one POTS peer and one VoIP peer.

Figure 4-1 illustrates the topology of this FXS-to-FXS connection example.

Figure 4-1 Channelized T1/E1 FXS-to-FXS Connection

Configuration for IAD-1

hostname iad-1
! Create voip dial-peer 10
dial-peer voice 10 voip
! Define its associated telephone number and IP address
 destination-pattern +4152222222
 session target ipv4:10.0.0.1
! Create pots dial-peer 1
dial-peer voice 1 pots
! Define its associated telephone number and voice port
 destination-pattern +4081111111
 port 2/0
!Configure serial interface 0/0
interface Serial0/0
 ip address 10.0.0.1 255.0.0.0
 no ip mroute-cache
! Configure RTP header compression
 ip rtp header-compression
 ip rtp compression-connections 25
 fair-queue 64 256 36
router igrp 888
network 10.0.0.0

Configuration for Router RLB-w

hostname rlb-w
! Configure serial interface 1/0
interface Serial1/0
 ip address 10.0.0.2 255.0.0.0
! Configure RTP header compression
 ip rtp header-compression
 ip rtp compression-connections 25
 fair-queue 64 256 3
! Configure serial interface 1/3
interface Serial1/3
 ip address 20.0.0.1 255.0.0.0
! Configure RTP header compression
 ip rtp header-compression
 ip rtp compression-connections 25
 fair-queue 64 256 3
! Configure IGRP
router igrp 888
network 10.0.0.0
network 20.0.0.0

Configuration for Router R12-e

hostname r12-e
! Configure serial interface 1/0
interface Serial1/0
 ip address 40.0.0.2 25.0.0.0
! Configure RTP header compression
 ip rtp header-compression
 ip rtp compression-connections 25
 fair-queue 64 256 3
! Configure serial interface 1/3
interface Serial1/3
 ip address 20.0.0.2 255.0.0.0
! Configure RTP header compression
 ip rtp header-compression
 ip rtp compression-connections 25
 fair-queue 64 256 3
 clockrate 128000
! Configure IGRP
router igrp 888
network 20.0.0.0
network 40.0.0.0

Configuration for IAD-2

hostname iad-2
! Create pots dial-peer 2
dial-peer voice 2 pots
! Define its associated telephone number and voice-port
 destination-pattern +4152222222
 port 2/0
! Create voip dial-peer 20
dial-peer voice 20 voip
!Define its associated telephone number and IP address
 destination-pattern +4081111111
 session target ipv4:40.0.0.1
! Configure channel group on T1/E1
controller T1 1/0
 channel-group 0 timeslots 1-24
! Configure serial interface 1/0:0
interface Serial1/0:0
 ip address 40.0.0.1 255.0.0.0
 no ip mroute-cache
! Configure RTP header compression
 ip rtp header-compression
 ip rtp compression-connections 25
 fair-queue 64 256 3
 clockrate 64000
! Configure IGRP
router igrp 888
network 40.0.0.0

Linking PBX Users with Digital E&M Trunk Lines over T1/E1 CAS

The following example shows how to configure VoIP to link PBX users with digital E&M trunk lines over T1/E1 Channel-associated signalling (CAS). (See the "Configuring DS0 Groups for CAS" section on page 3-15.)

In this example, a company wants to connect two offices: one in San Jose, California, and the other in Salt Lake City, Utah. Each office has an internal telephone network using a PBX connected to the voice network by an E&M interface. Both offices are using E&M Port Type II, with four-wire operation and ImmediateStart signaling. Each E&M interface connects to the router by means of two voice interface connections. Users in San Jose dial "8-569" and then the extension number to reach a destination at the Salt Lake City office. Users in Salt Lake City dial "4-527" and then the extension number to reach a destination in the San Jose office.

Figure 4-2 shows the topology of this connection example.

Figure 4-2 Linking PBX Users with Digital E&M Trunk Lines over T1/E1 CAS


Note This example assumes that the company already has established a working IP connection between its two remote offices.


IAD SJ Configuration

hostname sanjose
!Configure digital voice-ports
controller T1 1/0
 ds0-group 1 timeslots 1-24 type e&m-immediate-start
!Configure pots dial-peer 1
dial-peer voice 1 pots
 destination-pattern +527....
 port 1/1:0
!Configure voip dial-peer 2
dial-peer voice 3 voip
 destination-pattern +569....
 session target ipv4:172.16.65.182
!Configure the fastethernet interface
interface fe 0/0
 ip address 172.16.1.123
 no shutdown

IAD SLC Configuration

hostname saltlake
!Configure digital voice-ports
controller T1 1/0
 ds0-group 1 timeslots 1-24 type e&m-immediate-start
!Configure pots dial-peer 1
dial-peer voice 1 pots
 destination-pattern +569....
 port 1/1:0
!Configure voip dial-peer 2
dial-peer voice 3 voip
 destination-pattern +527....
 session target ipv4:172.16.65.123
!Configure the fastethernet interface
interface fe 0/0
 ip address 172.16.1.182
 no shutdown


Note PBXs should be configured to pass all dual tone multifrequency (DTMF) signals to the Cisco IAD. We recommend that you do not configure "store-and-forward" tone.



Note If you change the gain or the telephony port, make sure that the telephony port still accepts DTMF signals.


PSTN Gateway Access Using an FXO Connection

The following example shows how to configure VoIP to link users with the PSTN gateway using a Foreign Exchange Office (FXO) connection.

In this example, users connected to Router SJ in San Jose, California, can reach PSTN users in Salt Lake City, Utah, using Router SLC. Router SLC in Salt Lake City is connected directly to the PSTN through an FXO interface.

Figure 4-3 shows the topology of this connection example.

Figure 4-3 PSTN Gateway Access Using FXO Connection Example


Note This example assumes that the company already has established a working IP connection between its two remote offices.


IAD SJ Configuration

! Configure pots dial-peer 1
dial-peer voice 1 pots
 destination-pattern +14081111111
 port 2/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
 destination-pattern +9...........
 session target ipv4:172.16.65.182
! Configure the serial interface
interface serial 0/0
 clock rate 2000000
 ip address 172.16.1.123
 no shutdown

IAD SLC Configuration

! Configure pots dial-peer 1
dial-peer voice 1 pots
 destination-pattern +9...........
 port 2/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
 destination-pattern +14081111111
 session target ipv4:172.16.1.123
! Configure serial interface
interface serial 0/0
 ip address 172.16.65.182
 no shutdown

PSTN Gateway Access Using an FXO Connection in PLAR Mode

The following example shows how to configure VoIP to link users with the PSTN gateway using an Foreign Exchange Office (FXO) connection in private line, automated ringdown (PLAR) mode.

In this example, PSTN users in Salt Lake City, Utah, can dial a local number and establish a private line connection in a remote location. As in the previous example (that is, a PSTN gateway using an FXO connection) Router SLC in Salt Lake City is connected directly to the PSTN through an FXO interface.

Figure 4-4 shows the topology of this connection example.

Figure 4-4 PSTN Gateway Access Using FXO Connection (PLAR Mode)


Note This example assumes that the company already has established a working IP connection between its two remote offices.


IAD SJ Configuration

! Configure pots dial-peer 1
dial-peer voice 1 pots
 destination-pattern +14081111111
 port 2/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
 destination-pattern +9...........
 session target ipv4:172.16.65.182
! Configure the serial interface
interface serial 0/0
 clock rate 2000000
 ip address 172.16.1.123
 no shutdown

IAD SLC Configuration

! Configure pots dial-peer 1
dial-peer voice 1 pots
 destination-pattern +9...........
 port 2/0
! Configure voip dial-peer 2
dial-peer voice 2 voip
 destination-pattern +14081111111
 session target ipv4:172.16.1.123
! Configure the voice port
voice port 2/0
connection plar 14081111111
! Configure the serial interface
interface serial 0/0
 ip address 172.16.65.182
 no shutdown