Cisco IAD2430 Series Integrated Access Devices Software Configuration Guide
Appendix A: Cisco 2430 Series Configuration Examples
Downloads: This chapterpdf (PDF - 151.0KB) The complete bookPDF (PDF - 3.34MB) | Feedback

Cisco IAD2430 Series Configuration Examples

Table Of Contents

Cisco IAD2430 Series Configuration Examples

Sample Configuration: Cisco IAD2435-8FXS

Sample Configuration: Cisco 2430-24FXS

Sample Configuration: Cisco 2431-1T1/E1 with WIC-2T

Sample Configuration: Cisco 2432-24FXS with VIC2-4FXO
and QoS


Cisco IAD2430 Series Configuration Examples


This appendix presents the following sample configurations for the Cisco 2430 series IADs:

Sample Configuration: Cisco IAD2435-8FXS

Sample Configuration: Cisco 2430-24FXS

Sample Configuration: Cisco 2431-1T1/E1 with WIC-2T

Sample Configuration: Cisco 2432-24FXS with VIC2-4FXO and QoS

Sample Configuration: Cisco IAD2435-8FXS

Current configuration : 1089 bytes
!
version 12.4(1)T
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2435-8FXS
!
logging queue-limit 100
!
ip subnet-zero
!
!
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
mta receive maximum-recipients 0
!
!
controller T1 1/0
framing sf
 linecode ami
 channel-group 0 timeslots 1-24
!
!
!
interface FastEthernet0/0
 ip address 1.3.21.53 255.255.0.0
 no ip mroute-cache
 duplex auto
 speed auto
 fair-queue
!
interface Serial1/0:0
 ip address 10.1.1.1 255.255.0.0
 encapsulation ppp
!
ip http server
ip classless
!
!
!
call rsvp-sync
!
voice-port 2/0
!
voice-port 2/1
!
voice-port 2/2
!
voice-port 2/3
!
voice-port 2/4
!
voice-port 2/5
!
voice-port 2/6
!
voice-port 2/7
!
mgcp
mgcp call-agent 1.3.37.1 service-type mgcp version 1.0
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 application mgcpapp
 port 2/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 2/1
!
!
line con 0
 exec-timeout 0 0
 speed 115200
line aux 0
line vty 0 4
 login
!
!
end

Sample Configuration: Cisco 2430-24FXS

Current configuration : 2612 bytes
!
version 12.4(1)T
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname swell-China
!
ip subnet-zero
!
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
mta receive maximum-recipients 0
!
!
interface FastEthernet0/0
 ip address 1.3.21.55 255.255.0.0
 ip nat inside
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.2.111.1 255.255.0.0
 duplex auto
 speed auto
!
ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 1.2.0.1
!
!
call rsvp-sync
!
voice-port 2/0
 disc_pi_off
 input gain 10
 output attenuation 10
 playout-delay minimum low
 cptone HK
 timing digit 53
 description cflow1
 music-threshold -50
 bearer-cap Speech
 station-id name ashoowin
 station-id number 1000
 caller-id enable
 ren 3
 disconnect-ack
!
voice-port 2/1
 disc_pi_off
 input gain 10
 output attenuation 10
 playout-delay minimum low
 cptone HK
 timing digit 53
 description cflow1
 music-threshold -50
 bearer-cap Speech
 station-id name ashwin
 station-id number 1000
 caller-id enable
 ren 3
 disconnect-ack
!
voice-port 2/2
 cptone HK
!
voice-port 2/3
 cptone HK
!
voice-port 2/4
 cptone HK
!
voice-port 2/5
 cptone HK
!
voice-port 2/6
 cptone HK
!
voice-port 2/7
 cptone HK
!
voice-port 2/8
 cptone HK
!
voice-port 2/9
 cptone HK
!
voice-port 2/10
 cptone HK
!
voice-port 2/11
!
voice-port 2/12
!
voice-port 2/13
!
voice-port 2/14
!
voice-port 2/15
!
voice-port 2/16
!
voice-port 2/17
!
voice-port 2/18
!
voice-port 2/19
!
voice-port 2/20
!
voice-port 2/21
!
voice-port 2/22
!
voice-port 2/23
!
mgcp profile default
!
dial-peer cor custom
!
!
dial-peer voice 1 pots
 destination-pattern 1000
 port 2/0
!
dial-peer voice 2 pots
 destination-pattern 2000
 port 2/1
!
dial-peer voice 3 pots
 destination-pattern 1002
 port 2/2 
!
dial-peer voice 4 pots
 destination-pattern 1003
 port 2/3
!
dial-peer voice 5 pots
 destination-pattern 1004
 port 2/4
!
dial-peer voice 6 pots
 destination-pattern 1005
 port 2/5
!
dial-peer voice 10 voip
 destination-pattern 2...
 session target ipv4:1.2.125.57
 codec g711ulaw
!
dial-peer voice 7 pots
 destination-pattern 1006
 port 2/6
!
dial-peer voice 8 pots
 destination-pattern 1007
 port 2/7
!
dial-peer voice 9 pots
 destination-pattern 1008
 port 2/8
!
dial-peer voice 11 pots
 destination-pattern 1009
 port 2/9
!
dial-peer voice 12 pots
 destination-pattern 1010
 port 2/10
!
line con 0
 exec-timeout 0 0
 speed 115200
line aux 0
line vty 0 4
 login    
!
end

Sample Configuration: Cisco 2431-1T1/E1 with WIC-2T

Current configuration : 1755 bytes
!
version 12.4(1)T
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2431-2T1/E1-1
!
logging queue-limit 100
logging buffered 10000000 debugging
no logging console
!
network-clock-select 1 T1 1/0
ip subnet-zero
!
!
!
backhaul-session-manager
  set vsc1_set client nft
  group vsc1_grp set vsc1_set
isdn switch-type primary-ni
!
!
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
mta receive maximum-recipients 0
!
!
controller T1 1/0
shutdown
 framing sf
 linecode ami
 channel-group 0 timeslots 1-24
!
controller T1 1/1
mode cas
 framing esf
 linecode b8zs
 ds0-group 1 timeslots 1-24 type e&m-wink-start
!
!
!
interface Multilink1
 ip address 10.1.1.1 255.255.0.0
 ppp multilink
 multilink-group 1
!
interface FastEthernet0/0
 ip address 1.3.21.56 255.255.0.0
 duplex auto
 speed auto
 ip rsvp bandwidth 1 1
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clockrate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 encapsulation ppp
 shutdown
 clockrate 2000000
 ppp multilink
 multilink-group 1
!
interface Serial1/0:0
 no ip address
 encapsulation ppp
 no logging event link-status
 ppp multilink
 multilink-group 1
!
ip http server
ip classless
ip route 223.255.254.254 255.255.255.255 FastEthernet0/0
!
!
access-list 101 permit ip host 10.1.1.1 host 10.1.1.2
no cdp run
!
!
call rsvp-sync
!
voice-port 1/1:1
!
mgcp
mgcp call-agent 1.3.37.1 service-type sgcp version 1.5
mgcp quarantine mode process loop
mgcp timer receive-rtcp 2
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 voip
 destination-pattern 408....
 session target ipv4:1.3.21.54
!
dial-peer voice 2 pots
 application mgcpapp
 incoming called-number 408....
 port 1/1:1
!
!
line con 0
 exec-timeout 0 0
 speed 115200
line aux 0
line vty 0 4
 login
!
end

Sample Configuration: Cisco 2432-24FXS with VIC2-4FXO
and QoS

Current configuration : 3807 bytes
!
version 12.4(1)T
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2432-24-2T1/E1-2
!
logging queue-limit 100
logging buffered 5000 debugging
no logging console
!
ip subnet-zero
!
!
ip cef
no ip domain lookup
!
!
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
mta receive maximum-recipients 0
!
!
controller T1 1/0
shutdown
 framing sf
 clock source internal
 linecode ami
 channel-group 1 timeslots 1-12 speed 64
!
controller T1 1/1
framing esf
 clock source internal
 linecode b8zs
 channel-group 1 timeslots 1-12 speed 64
!
 class-map match-all control
  match ip dscp af31 
 class-map match-all voice
  match ip dscp ef 
!
!
 policy-map CORP-POLICY
  class voice
   priority percent 45
  class control
   bandwidth percent 10
  class class-default
   fair-queue
!
!
!
interface Multilink1
 ip address 12.12.0.1 255.255.0.0
 service-policy output CORP-POLICY
 ip tcp header-compression iphc-format
 load-interval 30
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format
 ip rtp compression-connections 1000
!
interface FastEthernet0/0
 ip address 1.3.21.57 255.255.0.0
 load-interval 30
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0:1
 bandwidth 768
 no ip address
 encapsulation ppp
 load-interval 30
 ppp multilink
 multilink-group 1
!
interface Serial1/1:1
 bandwidth 768
 no ip address
 encapsulation ppp
 load-interval 30
 ppp multilink
 multilink-group 1
!
ip http server
ip classless
ip route 1.3.0.0 255.255.255.0 FastEthernet0/0
ip route 10.2.0.0 255.255.0.0 Multilink1
ip route 10.2.0.0 255.255.0.0 12.12.0.2
!
!
!         
call threshold global cpu-5sec low 80 high 90 treatment
call threshold global cpu-avg low 80 high 90 treatment
call threshold global total-mem low 80 high 90 treatment
call threshold global io-mem low 80 high 90 treatment
call threshold global proc-mem low 80 high 90 treatment
call threshold global total-calls low 10 high 12 treatment
call rsvp-sync
!
voice-port 0/0
 battery-reversal answer
!
voice-port 0/1
 battery-reversal answer
!
voice-port 0/2
 battery-reversal answer
!
voice-port 0/3
 battery-reversal answer
!
voice-port 2/0
!
voice-port 2/1
!
voice-port 2/2
!
voice-port 2/3
!
voice-port 2/4
!
voice-port 2/5
!
voice-port 2/6
!
voice-port 2/7
!
voice-port 2/8
!
voice-port 2/9
!
voice-port 2/10
!
voice-port 2/11
!
voice-port 2/12
!         
voice-port 2/13
!
voice-port 2/14
!
voice-port 2/15
!
voice-port 2/16
!
voice-port 2/17
!
voice-port 2/18
!
voice-port 2/19
!
voice-port 2/20
!
voice-port 2/21
!
voice-port 2/22
!
voice-port 2/23
!
mgcp      
mgcp call-agent 1.3.37.1 service-type mgcp version 1.0
mgcp src-cac
no mgcp piggyback message
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 voip
 incoming called-number 4088...
 destination-pattern 4089...
 session target ipv4:12.12.0.2
 codec g711ulaw
 no vad
!
dial-peer voice 2 pots
 destination-pattern 4088001
 port 2/0
!
dial-peer voice 3 pots
 destination-pattern 4088002
 port 2/1
!
dial-peer voice 4 pots
 destination-pattern 4088003
 port 2/2
!
dial-peer voice 5 pots
 destination-pattern 4088004
 port 2/3
!
dial-peer voice 6 pots
 destination-pattern 4088005
 port 2/4
!
dial-peer voice 7 pots
 destination-pattern 4088006
 port 2/5
!
dial-peer voice 8 pots
 destination-pattern 4088007
 port 2/6
!
dial-peer voice 9 pots
 destination-pattern 4088008
 port 2/7
!
dial-peer voice 10 pots
 destination-pattern 4088009
 port 2/8
!
dial-peer voice 11 pots
 destination-pattern 4088010
 port 2/9
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 115200
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
!
!
end