3G High-Speed WAN Interface Card Solution Deployment Guide
Basic Configurations
Downloads: This chapterpdf (PDF - 368.0KB) The complete bookPDF (PDF - 2.75MB) | Feedback

Basic Configurations

Table Of Contents

Basic Configurations

Contents

GSM-Based Wireless Networks

Deployment Using Network/Port Address Translation (NAT/PAT)

Debugging and Troubleshooting

CDMA-Based Wireless Networks

Deployment Using Network/Port Address Translation (NAT/PAT)

Debugging and Troubleshooting


Basic Configurations


First Published: May 6, 2010
Last Updated: November 28, 2012, OL-22739-03

This chapter describes basic configurations for GSM- and CDMA-based wireless networks.

Contents

GSM-Based Wireless Networks

CDMA-Based Wireless Networks

GSM-Based Wireless Networks

This chapter describes the most common deployment scenarios with detailed configurations and comments for each.

Deployment Using Network/Port Address Translation (NAT/PAT)

This simple deployment example uses NAT/PAT, as shown in Figure 4-1, that focuses on a wireless specific configuration. For more information on NAT, see

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6640/product_data_sheet0900aecd8064c999.html.

Figure 4-1 Simple Deployment Using NAT/PAT for GSM Wireless Networks

Example 4-1 IOS Configuration for Deployment Using NAT/PAT

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

hostname ROUTER
!
ip cef
!
ip dhcp excluded-address 10.1.0.254
!
ip dhcp pool gsm105
   network 10.1.0.0 255.255.0.0
   default-router 10.1.0.254 
   dns-server 66.102.163.231 66.102.163.232
! 
!	Defines the DHCP pool for network 10.1.0.0/16, for hosts connected on VLAN 101, and
!	Fast Ethernet ports 0/1/0 thru 0/1/3. 
!
ip domain name yourdomain.com
!
chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT"
! 
!	Defines dialer string 'gsm'. 'atdt*98*1#' command causes the cellular modem to
!	dial out using profile 1 (profiles are created using 'cellular x/x/x gsm profile
!	create ...' command). In response, the IOS expects the 'CONNECT' string from the modem
!	upon successful dial out. In this case, IOS waits 30 seconds as timeout, in case of
!	no/unexpected response. Note that the expected 'CONNECT' response from the modem is
!	case sensitive. 
!
!	For 3G routers with Cisco IOS Release 15.3(1)T, the chat-script configuration, 
!	including the dialer in-band, dialer string, and script dialer (shown later), will be 
!	auto-generated based on the modem type plugged in. These configuration changes are 
!	supported only on 3G HWIC SKUs. The auto-generated configuration can be overwritten if 
!	needed.
!
 
   
!        
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 shutdown
!
interface FastEthernet0/1/0
 switchport access vlan 101
!
interface FastEthernet0/1/1
 switchport access vlan 101
!
interface FastEthernet0/1/2
 switchport access vlan 101
!
interface FastEthernet0/1/3
 switchport access vlan 101
!
!	DHCP client hosts connected to the above Fast Ethernet ports.
! 
interface Cellular0/0/0
 ip address negotiated
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 0
 dialer string cingular
 dialer-group 1
 async mode interactive
 ppp chap hostname SP-provided-user-name@sp-domain
 ppp chap password 0 SP-provided-password
 ppp ipcp dns request
!
!	It is highly recommended that the IP address is always configured as ip address
!	negotiated, even when a fixed (persistent) IP address is required. Cellular interface
!	is spoofed as 'up'/'up' (status/protocol states), regardless of whether the PPP is
!	established or not. If this interface is configured with a specific IP address
!	(instead of 'ip address negotiated'), and if the PPP is not yet established, the
!	routing table will interpret it as a valid route available via the cellular interface.
!	By assigning a negotiated IP address, this problem is avoided. This is particularly
!	important when using the cellular as a backup interface.
!
!	ip nat outside uses the IP address assigned to the cellular interface, as the
!	source IP address of IP packets going through the cellular interface, and sourced from
!	hosts on VLAN 101.
!
!	dialer in-band configures the interface to support dial on demand routing, and
!	additionally specifies that a chat script will be used for dialing out. In this case
!	it uses the chat script 'gsm', as defined earlier. 
!
!	It is recommended that dialer idle-timeout is set to '0', to avoid disconnection of
!	PPP in the event of no traffic for a specified time, defined by this command. 'dialer
!	idle-timeout 0' sets this timer to indefinite timeout period.
!
!	dialer group and dialer-list are associated commands that allow the specification of
!	'interesting' traffic which will trigger the cellular modem dial out to occur, in
!	order to set up the PPP connection, if it is not yet established.
!
!	The user-name (hostname) and password for the PPP are provided by your service
!	provider (SP). Note that the user-name and password are locally authenticated between
!	the IOS and the cellular modem (which resides in the 3G HWIC), as far as the PPP is
!	concerned. The PPP terminates between the IOS and the modem. These same parameters
!	(i.e. the user-name and password) need to be also configured on the cellular modem).
!	The modem uses these parameters over the air, for the purposes of authenticating the
!	user with the network, using PDP context activation message, in order to set up a data
!	connection (known as PDP context) with the cellular network.
!
!	ppp ipcp dns-request is an optional command, which allows DNS IP address(es) to be
!	obtained from the cellular network, if required, via the PPP procedures.
!   
interface Vlan1
 no ip address
!
interface Vlan101
 ip address 10.1.0.254 255.255.0.0
ip nat inside
!
!	Defines interface VLAN 101. This VLAN is used by the associated hosts (on the Fast
!	Ethernet ports). It provides NAT/PAT functionality using the ip nat inside command.
!
 ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
!	Defines the default route to be via the cellular interface - in this case all IP
!	packets are routed through the cellular interface.
! 
!
ip nat inside source list 2 interface Cellular0/0/0 overload
!
!	Specifies the source of traffic that should be NAT/PATed is via the cellular
!	interface. In this case, it is performing PAT, by using the 'overload' parameter. The
!	source list 2 is associated with the access-list 2 (defined below), which 
!	specifies the traffic source of interest (from 10.1.0.0/16 network, in this case).
!  
!
access-list 1 permit any
!
access-list 2 permit 10.1.0.0 0.0.255.255
!
dialer-list 1 protocol ip list 1
!
!	The dialer-list 1 command is associated with dialer-group 1 command specified under
!	the cellular interface. 
!
!	The access-list 1 command is associated with dialer-list 1 protocol ip list 1 command. 
!
!	These commands specify the traffic of interest that will trigger the dial out to occur
!	through the cellular modem, and establish the PPP, if not already established.
!
no cdp run
!
!
control-plane
!
line con 0
 exec-timeout 0 0
 exec prompt timestamp
 stopbits 1
line aux 0
 stopbits 1
line 0/0/0
 exec-timeout 0 0
 script dialer gsm
 login
 modem InOut
 no exec
 transport input all
 transport output all
 rxspeed 236800
 txspeed 118000
!
!	It is necessary to specify the script dialer command under the corresponding line for
!	the cellular interface. In this case the cellular interface is 0/0/0, and hence the
!	line is also essentially 0/0/0. 
!
!	rxspeed and txspeed cannot be configured. 
!
!	modem InOut allows incoming and outgoing calls, although incoming call is not
!	currently supported by the network.
!
!	transport input all and transport output all may be used for the purposes of
!	reverse telneting to the cellular modem.
!
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end

Debugging and Troubleshooting

The following debugging methods are useful for debugging common problems:

PPP

PPP detailed event

PPP protocol negotiation

Chat Script

Chat scripts activity debugging

You can ping a destination IP address that is expected to respond and is part of the interesting traffic to see if you have connectivity.

Example 4-2 Debug Output for Normal Operation

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

The following debug output is typical for a successful call establishment:

 
   
Router# ping ip 209.131.36.158 source 10.1.0.254 
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.1.0.254 
 
   
*Jun 21 00:45:43.679: CHAT0/0/0: Attempting async line dialer script
*Jun 21 00:45:43.679: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
*Jun 21 00:45:43.679: CHAT0/0/0: process started
*Jun 21 00:45:43.683: CHAT0/0/0: Asserting DTR
*Jun 21 00:45:43.683: CHAT0/0/0: Chat script gsm started
*Jun 21 00:45:43.683: CHAT0/0/0: Sending string: atdt*98*1#
*Jun 21 00:45:43.683: CHAT0/0/0: Expecting string: CONNECT
*Jun 21 00:45:43.727: CHAT0/0/0: Completed match for expect: CONNECT
*Jun 21 00:45:43.727: CHAT0/0/0: Chat script gsm finished, status = Success.
 
   
*Jun 21 00:45:45.931: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
!
!	Upon detecting 'interesting' traffic, the IOS has successfully communicated with the
!	cellular modem and has commanded it to dial out.
! 
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Using dialer call direction
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Treating connection as a callout
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Session handle[3C00021F] Session id[180]
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Phase is ESTABLISHING, Active Open
*Jun 21 00:45:45.931: Ce0/0/0 PPP: No remote authentication for call-out
!
!	Preparing to start the PPP - LCP (Link Control Protocol) phase.
! 
*Jun 21 00:45:45.931: Ce0/0/0 LCP: O CONFREQ [Closed] id 189 len 20
*Jun 21 00:45:45.931: Ce0/0/0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jun 21 00:45:45.931: Ce0/0/0 LCP:    MagicNumber 0x3F7E2331 (0x05063F7E2331)
*Jun 21 00:45:45.931: Ce0/0/0 LCP:    PFC (0x0702)
*Jun 21 00:45:45.931: Ce0/0/0 LCP:    ACFC (0x0802)
!
!	Outgoing CONFREQ sent out from Cisco IOS to the cellular modem.
! 
*Jun 21 00:45:45.935: Ce0/0/0 LCP: I CONFREQ [REQsent] id 63 len 25
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    ACCM 0x00000000 (0x020600000000)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    AuthProto CHAP (0x0305C22305)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    MagicNumber 0xB9F4D928 (0x0506B9F4D928)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    PFC (0x0702)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    ACFC (0x0802)
!
!	Incoming CONFREQ received by IOS from the cellular modem.
! 
*Jun 21 00:45:45.935: Ce0/0/0 LCP: O CONFACK [REQsent] id 63 len 25
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    ACCM 0x00000000 (0x020600000000)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    AuthProto CHAP (0x0305C22305)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    MagicNumber 0xB9F4D928 (0x0506B9F4D928)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    PFC (0x0702)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    ACFC (0x0802)
!
!	Outgoing CONFACK sent out from the IOS to the cellular modem.
! 
*Jun 21 00:45:45.935: Ce0/0/0 LCP: I CONFACK [ACKsent] id 189 len 20
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    MagicNumber 0x3F7E2331 (0x05063F7E2331)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    PFC (0x0702)
*Jun 21 00:45:45.935: Ce0/0/0 LCP:    ACFC (0x0802)
!
!	Incoming CONACK received by IOS from the cellular modem.
! 
*Jun 21 00:45:45.935: Ce0/0/0 LCP: State is Open
!
!	LCP phase completed successfully and is now OPEN.
! 
*Jun 21 00:45:45.939: Ce0/0/0 PPP: Phase is AUTHENTICATING, by the peer.
!
!	Beginning the authentication phase.
! 
*Jun 21 00:45:45.939: Ce0/0/0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: Using hostname from interface CHAP
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: Using password from interface CHAP
 
   
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: O RESPONSE id 1 len 40 from 
SP-provided-user-name@wwan.ccs
 
   
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: I SUCCESS id 1 len 4
!
!	CHAP (Challenge Handshake Authentication Protocol) phase completed successfully and
!	is now OPEN.
!
!	This CHAP authentication has only occurred between the IOS and the cellular
!	modem on the 3G-HWIC, and not yet with the network. It is important to remember that
!	the PPP does not terminate on the network; it terminates locally on the modem.
!
!	The cellular network (GGSN) has not yet authenticated the user. The cellular modem
!	then uses 'Activate PDP context' message, over the air, for the purposes of obtaining
!	an IP address from the network and also for authenticating itself to the network. 
!	The network in turn responds with 'Activate PDP context Accept' message, 
!	authenticating the user and returning the IP address. The 'Activate PDP context' 
!	message contains the CHAP credentials configured under the cellular interface. 
! 
*Jun 21 00:45:45.943: Ce0/0/0 PPP: Phase is FORWARDING, Attempting Forward
*Jun 21 00:45:45.947: Ce0/0/0 PPP: Phase is ESTABLISHING, Finish LCP
*Jun 21 00:45:45.947: Ce0/0/0 PPP: Phase is UP
!
!	Starting NCP (Network Control Protocol)/IPCP (IP Control Protocol) phase. 
!	 
*Jun 21 00:45:45.947: Ce0/0/0 IPCP: O CONFREQ [Closed] id 1 len 22
*Jun 21 00:45:45.947: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:45.947: Ce0/0/0 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
*Jun 21 00:45:45.947: Ce0/0/0 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
!
!	IPCP CONFREQ (Configure-Request) sent by Cisco IOS to the modem, requesting host IP
!	address and the DNS addresses.
! 
*Jun 21 00:45:45.947: Ce0/0/0 PPP: Process pending ncp packets
 
   
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 1 len 16
*Jun 21 00:45:46.955: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:46.955: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	IPCP CONFNAK (Received configuration option is recognizable and acceptable, but some
!	values are not acceptable) sent by the modem to Cisco IOS, in return to the above
!	CONFREQ. 
!
!	The modem has not yet been authenticated by the cellular network. The modem is waiting
!	for the 'Activate PDP context Accept' message from the cellular network. The modem is
!	merely returning a response to IOS, containing primary and secondary DNS addresses
!	(these addresses are arbitrary, since the real addresses are provided by the network).
!	For obvious reasons, it does not return any host IP Address to the IOS.  
! 
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 2 len 22
*Jun 21 00:45:46.955: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:46.955: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:46.955: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	A new IPCP CONFREQ sent by the IOS to modem, requesting the missing host IP address in
!	the CONFNAK from the modem.
!
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 2 len 16
*Jun 21 00:45:47.959: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:47.959: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	Modem responds with IPCP CONFNAK, still excluding the requested host IP address.
!
!	The reason for this exclusion is that the modem is still waiting for the 'Activate PDP
!	context Accept' message from the network which would contain these requested
!	parameters.
!
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 3 len 22
*Jun 21 00:45:47.959: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:47.963: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.!.13 (0x81060A0B0C0D)
*Jun 21 00:45:47.963: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	IOS continues sending IPCP CONREQ to the modem.
!
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 3 len 16
*Jun 21 00:45:48.967: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:48.967: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	Modem responds with IPCP CONFNAK, still once again excluding the requested host 
!	IP Address.
!
!	The modem is still waiting for the 'Activate PDP context Accept' message from the
!	network.
!
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 4 len 22
*Jun 21 00:45:48.967: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:48.967: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:48.967: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	IOS continues sending IPCP CONREQ to the modem.
!
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: I CONFREQ [REQsent] id 108 len 4
 
   
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: O CONFACK [REQsent] id 108 len 4
 
   
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: I CONFNAK [ACKsent] id 4 len 22
*Jun 21 00:45:49.263: Ce0/0/0 IPCP:    Address 166.138.186.120 (0x0306A68ABA78)
*Jun 21 00:45:49.263: Ce0/0/0 IPCP:    PrimaryDNS 66.102.163.231 (0x81064266A3E7)
*Jun 21 00:45:49.263: Ce0/0/0 IPCP:    SecondaryDNS 66.102.163.232 (0x83064266A3E8)
!
!	Finally, the modem receives the 'Activate PDP context Accept' message from the
!	cellular network, which successfully authenticates the modem/IOS, and also provides
!	the host IP address and the DNS addresses as received from the network.
!
!	IPCP CONFNAK sent by the modem to IOS, containing these valid addresses received from
!	the network.
! 
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: O CONFREQ [ACKsent] id 5 len 22
*Jun 21 00:45:49.267: Ce0/0/0 IPCP:    Address 166.138.186.120 (0x0306A68ABA78)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP:    PrimaryDNS 66.102.163.231 (0x81064266A3E7)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP:    SecondaryDNS 66.102.163.232 (0x83064266A3E8)
!
!	IPCP CONFREQ sent by the IOS to the modem, requesting the suggested host IP address
!	and the DNS addresses.
! 
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: I CONFACK [ACKsent] id 5 len 22
*Jun 21 00:45:49.267: Ce0/0/0 IPCP:    Address 166.138.186.120 (0x0306A68ABA78)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP:    PrimaryDNS 66.102.163.231 (0x81064266A3E7)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP:    SecondaryDNS 66.102.163.232 (0x83064266A3E8)
!
!	IPCP CONFACK (if all options in the CONFREQ message are recognizable and all values
!	are acceptable, then the router transmits a CONFACK message) sent by the modem to
!	Cisco IOS, accepting the requested host IP address and the DNS addresses.
! 
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: State is Open
!
!	IPCP Phase is now successful and is OPEN.
!
*Jun 21 00:45:49.291: Ce0/0/0 IPCP: Install negotiated IP interface address 
166.138.186.120
!
!	IP address assigned to the cellular interface and installed in the routing table.
! 

Example 4-3 Cellular Interface Information for Normal Operation

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

The output below shows the typical state of the show cellular x/x/x all command after a successful call set up.

 
   
Router# sh cellular 0/0/0 all
!
!	Some of the normally displayed information is excluded, for readability purposes, so
!	as to highlight the important information.
!
Profile Information
====================
Profile 1 = ACTIVE
--------
PDP Type = IPv4
PDP address = 166.138.186.120
Access Point Name (APN) = wwan.ccs
Authentication = CHAP
Username: SP-provided-user-name@wwan.ccs, Password: SP-provided-password
 
   
Data Connection Information
===========================
Data Transmitted = 276 bytes, Received = 200 bytes
Profile 1, Packet Session Status = ACTIVE
        IP address = 166.138.186.120
!
!	Cellular interface is actively connected to the cellular network, with PPP
!	established and IP address assigned, using Profile 1.
! 
Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = UMTS/WCDMA (Attached)
Packet Session Status = Active
Current Roaming Status = Roaming
Network Selection Mode = Automatic
Country = USA, Network = gsm
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 380
Location Area Code (LAC) = 56997
Routing Area Code (RAC) = 253
Cell ID = 5933
Primary Scrambling Code = 196
PLMN Selection = Automatic
Registered PLMN = gsm , Abbreviated = 
Service Provider = 
!
!	Shows information about the type of service (Radio Access Technology) and other
!	cellular information.
! 
Radio Information
=================
Current Band = WCDMA 1900, Channel Number = 9721
Current RSSI(RSCP) = -77 dBm
!
!	Shows the Received Signal Strength Indication (an important parameter that determines
!	the radio reception level) and the type of service and radio band being used.
! 
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
!
!	Shows the normal status of the SIM card
! 

Example 4-4 Debug Output for Failure to Connect and Obtain IP Address for the Cellular Interface and Possible Reasons

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

The following debug output is typical for a failure at the IPCP phase or a failure to obtain the IP address:

 
   
Router# ping 209.131.36.158 source 10.1.0.254
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.1.0.254 
 
   
*Jun 21 22:47:51.467: CHAT0/0/0: Attempting async line dialer script
*Jun 21 22:47:51.471: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
*Jun 21 22:47:51.471: CHAT0/0/0: process started
*Jun 21 22:47:51.471: CHAT0/0/0: Asserting DTR
*Jun 21 22:47:51.471: CHAT0/0/0: Chat script gsm started
*Jun 21 22:47:51.471: CHAT0/0/0: Sending string: atdt*98*1#
*Jun 21 22:47:51.471: CHAT0/0/0: Expecting string: CONNECT
*Jun 21 22:47:51.515: CHAT0/0/0: Completed match for expect: CONNECT
*Jun 21 22:47:51.515: CHAT0/0/0: Chat script gsm finished, status = Success.
*Jun 21 22:47:53.719: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
 
   
*Jun 21 22:47:53.727: Ce0/0/0 LCP: State is Open
 
   
*Jun 21 22:47:53.735: Ce0/0/0 CHAP: I SUCCESS id 1 len 4
!
!	IPCP started after CHAT; LCP and CHAP are successful.
!
*Jun 21 22:47:53.735: Ce0/0/0 IPCP: O CONFREQ [Closed] id 1 len 22
*Jun 21 22:47:53.735: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:53.735: Ce0/0/0 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
*Jun 21 22:47:53.735: Ce0/0/0 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
*Jun 21 22:47:53.735: Ce0/0/0 PPP: Process pending ncp packets
 
   
 
   
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 1 len 16
*Jun 21 22:47:54.739: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:54.739: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 2 len 22
*Jun 21 22:47:54.739: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:54.739: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:54.739: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:55.743: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 2 len 16
*Jun 21 22:47:55.747: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:55.747: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 3 len 22
*Jun 21 22:47:55.747: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:55.747: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:55.747: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 3 len 16
*Jun 21 22:47:56.751: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:56.751: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 4 len 22
*Jun 21 22:47:56.751: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:56.751: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:56.751: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 4 len 16
*Jun 21 22:47:57.755: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:57.755: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 5 len 22
*Jun 21 22:47:57.755: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:57.755: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:57.755: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 5 len 16
*Jun 21 22:47:58.759: Ce0/0/0 IPCP:   .PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:58.759: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 6 len 22
*Jun 21 22:47:58.759: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:58.759: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:58.759: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:59.799: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 6 len 16
*Jun 21 22:47:59.803: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:59.803: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 7 len 22
*Jun 21 22:47:59.803: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:59.803: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:59.803: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:00.807: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 7 len 16
*Jun 21 22:48:00.811: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:00.811: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 8 len 22
*Jun 21 22:48:00.811: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:48:00.811: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:00.811: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 8 len 16
*Jun 21 22:48:01.815: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:01.815: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 9 len 22
*Jun 21 22:48:01.815: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:48:01.815: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:01.815: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 9 len 16
*Jun 21 22:48:02.819: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:02.819: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 10 len 22
*Jun 21 22:48:02.819: Ce0/0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 21 22:48:02.819: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:02.819: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
   
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 10 len 16
*Jun 21 22:48:03.823: Ce0/0/0 IPCP:    PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:03.823: Ce0/0/0 IPCP:    SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
!	Modem is not able to successfully establish the PDP context with the cellular network,
!	and therefore unable to get the host IP address and any other requested parameters
!	as requested by the PPP.
!
!	The reason for this could be one of the following:
!		- Poor radio reception
!		- Antenna could be disconnected
!		- Authentication failure with the radio network, possibly due to incorrect/invalid
!		or mis-configured user-name/password and APN (Access Point Name)
!
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: Failed to negotiate with peer
!
!	IPCP Failed, possibly due to one of the reasons above.
!
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: State is Closed

Example 4-5 Details of Cellular Interface When Failed to Obtain IP Address

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

Router# sh cellular 0/0/0 all
!
!	Some of the normally displayed information is excluded for readability purposes, so as
!	to highlight the important information.
!
Profile Information
====================
Profile 1 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = wwan.ccs
Authentication = CHAP
Username: SP-provided-user-name@wwan.ccs, Password: SP-provided-password
!
!	Ensure that the user-name, password, and APN are as provided by your service provider.
!	Also, ensure that they are correctly configured, both under the cellular interface, as
!	well as on the modem (using the 'cellular 0/0/0 gsm profile create ...' command).
!
Data Connection Information
===========================
Data Transmitted = 14428 bytes, Received = 13852 bytes
Profile 1, Packet Session Status = INACTIVE
        Inactivity Reason = Unknown
 
   
Network Information
===================
Current Service Status = No service, Service Error = None
Current Service = Combined
Packet Service = None
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = USA, Network = Cinglr
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 380
Location Area Code (LAC) = 56997
Routing Area Code (RAC) = 255
Cell ID = 0
Primary Scrambling Code = 0
PLMN Selection = Automatic
!
!	This indicates a potential radio level connectivity problem. The modem is not able to
!	communicate with the cellular network - possibly due to very low signal level.
!
Radio Information
=================
Current Band = None, Channel Number = 0
Current RSSI = -110 dBm
!
!	This indicates that the Received Signal Strength Indication (RSSI) is very low 
!	(-110 dBm). This is possibly due to antenna disconnection or due to poor radio
!	reception levels.
!
 
   
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3

Example 4-6 Debug Output for Failure to Dial Out and Possible Reasons

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

Router# ping ip 209.131.36.158 source 10.1.0.254 
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.5.0.254 
 
   
*Jun 22 21:50:30.187: CHAT0/0/0: Attempting async line dialer script
*Jun 22 21:50:30.187: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
*Jun 22 21:50:30.187: CHAT0/0/0: process started
*Jun 22 21:50:30.187: CHAT0/0/0: Asserting DTR
*Jun 22 21:50:30.187: CHAT0/0/0: Chat script gsm started
*Jun 22 21:50:30.187: CHAT0/0/0: Sending string: atdt*69*1# 20 
*Jun 22 21:50:30.187: CHAT0/0/0: Expecting string: CONNECT"...
*Jun 22 21:50:35.187: CHAT0/0/0: Timeout expecting: CONNECT"
*Jun 22 21:50:35.187: CHAT0/0/0: Chat script gsm finished, status = Connection timed out; 
remote host not responding
Success rate is 0 percent (0/5)
!
!	Modem is not responding to the dial out command.
!
!	Denotes a problem with the 'chat-script ...' command - possibly incorrectly specified
!	dialer string
!
!	A similar problem may be encountered: 
!		- If the expected string ('CONNECT') has typo or that it is not specified as 
!		uppercase.
!		-If the chat-script command is missing in the configuration
!		-If the 'script dialer ...' command is missing on the corresponding line x/x/x
!

CDMA-Based Wireless Networks

Deployment Using Network/Port Address Translation (NAT/PAT)

Figure 4-2 shows deployment using NAT/PAT. It focuses on a wireless specific configuration. You should familiarize yourself with the 3G wireless specific configuration before reviewing this example for a better understanding. For more information on NAT, see http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6640/product_data_sheet0900aecd8064c999.html.

Figure 4-2 Simple Deployment Using NAT/PAT for CDMA Wireless Networks

Example 4-7 IOS Configuration for Deployment Using NAT/PAT

hostname ROUTER
!
ip cef
!
ip dhcp excluded-address 10.3.0.254
!         
ip dhcp pool cdmapool
   network 10.3.0.0 255.255.0.0
   dns-server 68.28.58.11 
   default-router 10.3.0.254
!
!	Defines DHCP pool for network 10.3.0.0/16, for hosts connected on VLAN 103, Fast
!	Ethernet ports 0/2/0 thru 0/2/3. 
! 
chat-script cdma2 "" "atdt#777" TIMEOUT 30 "CONNECT"
chat-script cdma1 "" "atdt#777" TIMEOUT 30 "CONNECT"
!
!	Defines dialer strings 'cdma2' and 'cdma1' for a cdma2 wireless network and cdma1's
!	network, respectively. You need to choose one of these chat-script commands, depending
!	on which of these two is your service provider. The 'atdt#777' or 'atdt#777' command
!	causes the cellular modem to dial out. In response, the IOS expects the 'CONNECT'
!	string from the modem upon successful dial out. In this case, IOS waits 30 seconds as
!	timeout, in case of no/unexpected response. Note that the expected 'CONNECT' response
!	from the modem is case sensitive. 
!
!	For 3G routers with Cisco IOS Release 15.3(1)T, the chat-script configuration, 
!	including the dialer in-band, dialer string, and script dialer (shown later), will be 
!	auto-generated based on the modem type plugged in. These configuration changes are 
!	supported only on 3G HWIC SKUs. The auto-generated configuration can be overwritten if 
!	needed.
!
username cisco privilege 15 secret 5 $1$c/5O$W4sr3BFW3AhIB9BRXjy84/
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
 ip virtual-reassembly
 shutdown
!
interface GigabitEthernet0/1
 no ip address
shutdown
!
interface FastEthernet0/2/0
 switchport access vlan 103
!
interface FastEthernet0/2/1
 switchport access vlan 103
!
interface FastEthernet0/2/2
 switchport access vlan 103
!
interface FastEthernet0/2/3
 switchport access vlan 103
!
!	DHCP client hosts connected to the above Fast Ethernet ports.
!
!
interface Cellular0/1/0
 ip address negotiated
 ip nat outside
 no ip virtual-reassembly
 encapsulation ppp
 dialer in-band
 dialer idle-timeout 0
 dialer string cdma1
 async mode interactive
dialer-group 1
 ppp ipcp dns request
!
!	It is highly recommended that the IP address is always configured as ip address
!	negotiated, even when a fixed (persistent) IP address is required. Cellular interface
!	is spoofed as 'up'/'up' (status/protocol states), regardless of whether the PPP is
!	established or not. If this interface is configured with a specific IP address
!	(instead of 'ip address negotiated') and if the PPP is not yet established, the
!	routing table will interpret a valid route available via the cellular interface. By
!	assigning a negotiated IP address, this problem is avoided. This is particularly
!	important when using the cellular as a backup interface.
!
!	ip nat outside uses the IP address assigned to the cellular interface as the source
!	IP address of IP packets going through the cellular interface and sourced from hosts
!	on VLAN 103.
!
!	dialer in-band configures the interface to support dial on demand routing, and
!	additionally specifies that a chat script will be used for dialing out. In this case
!	it uses the chat script 'cdma1', as defined earlier. 
!
!	It is recommended that dialer idle-timeout is set to '0', to avoid disconnection of
!	PPP in the event of no traffic for a specified time, defined by this command. 'dialer
!	idle-timeout 0' sets this timer to indefinite timeout period.
!
!	dialer group and dialer-list are associated commands that allow the specification of
!	'interesting' traffic which will trigger the cellular modem dial out to occur, in
!	order to set up the PPP connection, if it is not yet established.
!
!	ppp ipcp dns-request is an optional command which allows DNS IP address(es) to be
!	obtained from the cellular network, if required, via the PPP procedures.
!   
 
   
interface Vlan1
 no ip address
!
interface Vlan103
 ip address 10.3.0.254 255.255.0.0
 ip nat inside
 ip virtual-reassembly
!
!	Defines interface VLAN 103. This VLAN is used by the associated hosts (on the Fast
!	Ethernet ports). It provides NAT/PAT functionality using the ip nat inside command.
!
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0 
!
!	Defines the default route via the cellular interface - in this case, all IP packets 
!	are routed through the cellular interface.
! 
ip nat inside source list 2 interface Cellular0/1/0 overload
!
!	Specifies the source of traffic that should be NAT/PATed, via the cellular interface.
!	In this case, it is performing PAT by using the 'overload' parameter. The source
!	list 2 is associated with the access-list 2 (defined below), which specifies the
!	traffic source of interest (from 10.3.0.0/16 network, in this case).
!  
access-list 1 permit any
access-list 2 permit 10.3.0.0 0.0.255.255
dialer-list 1 protocol ip list 1
no cdp run
!
!	dialer-list 1 command is associated with dialer-group 1 command specified under the
!	cellular interface. 
!
!	access-list 1 command is associated with dialer-list 1 protocol ip list 1 command. 
!
!	These commands specify the traffic of interest that will trigger the dial out to occur
!	through the cellular modem, and establish the PPP, if not already established.
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line aux 0
line 0/1/0
 exec-timeout 0 0
 script dialer cdma1
 login
 modem InOut
 no exec
 transport input all
 transport output all
 speed 144000
!
!	It is necessary to specify the script dialer command under the corresponding line
!	for the cellular interface. In this case the cellular interface is 0/1/0, and hence
!	the line is also essentially 0/1/0. 
!
!	speed can not be configured. 
!
!	modem InOut allows incoming/outgoing calls, although incoming call is not currently
!	supported by the network.
!
!	transport input all and transport output all may be used for the purposes of
!	reverse telneting to the cellular modem.
!
 
   
line vty 0 4
 privilege level 15
 no login
 transport input telnet
line vty 5 15
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
webvpn cef
!
end

Debugging and Troubleshooting

The following debugging methods are useful for debugging common problems:

PPP

PPP detailed event

PPP protocol errors

PPP protocol negotiation

Chat Script

Chat scripts activity debugging

Ping a destination IP address that is expected to respond and is part of the interesting traffic to see if you have connectivity.

Example 4-8 Debug Output for Normal Operation

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

The following debug information is typical for a successful call establishment:

Router# ping ip 209.131.36.158 source 10.3.0.254
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.3.0.254 
 
   
*Jun 29 15:40:51.248: CHAT0/1/0: Attempting async line dialer script
*Jun 29 15:40:51.248: CHAT0/1/0: Dialing using Modem script: cdma1 & System script: none
*Jun 29 15:40:51.248: CHAT0/1/0: process started
*Jun 29 15:40:51.248: CHAT0/1/0: Asserting DTR
*Jun 29 15:40:51.248: CHAT0/1/0: Chat script cdma1 started
*Jun 29 15:40:51.248: CHAT0/1/0: Sending string: atdt#777
*Jun 29 15:40:51.252: CHAT0/1/0: Expecting string: CONNECT..
*Jun 29 15:40:55.728: CHAT0/1/0: Completed match for expect: CONNECT
*Jun 29 15:40:55.728: CHAT0/1/0: Chat script cdma1 finished, status = Success
*Jun 29 15:40:55.896: TTY0/1/0: no timer type 1 to destroy
*Jun 29 15:40:55.896: TTY0/1/0: no timer type 0 to destroy
*Jun 29 15:40:55.896: TTY0/1/0: no timer type 2 to destroy.
 
   
*Jun 29 15:40:57.896: %LINK-3-UPDOWN: Interface Cellular0/1/0, changed state to up
!
!	Upon detecting 'interesting' traffic, the IOS has successfully communicated with the
!	cellular modem and has commanded it to dial out.
!
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Using dialer call direction
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Treating connection as a callout
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Session handle[57000CC5] Session id[89]
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Phase is ESTABLISHING, Active Open
*Jun 29 15:40:57.896: Ce0/1/0 PPP: No remote authentication for call-out
!
!	Preparing to start the PPP - LCP phase.
!
*Jun 29 15:40:57.896: Ce0/1/0 LCP: O CONFREQ [Closed] id 125 len 20
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    MagicNumber 0x89803B5B (0x050689803B5B)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    PFC (0x0702)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    ACFC (0x0802)
!
!	Outgoing LCP CONFREQ from IOS to the modem
!	
*Jun 29 15:40:57.896: Ce0/1/0 LCP: I CONFREQ [REQsent] id 136 len 20
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    ACCM 0x00000000 (0x020600000000)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    MagicNumber 0xE7985207 (0x0506E7985207)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    PFC (0x0702)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    ACFC (0x0802)
!
!	Incoming LCP CONFREQ from modem to Cisco IOS
!
*Jun 29 15:40:57.896: Ce0/1/0 LCP: O CONFACK [REQsent] id 136 len 20
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    ACCM 0x00000000 (0x020600000000)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    MagicNumber 0xE7985207 (0x0506E7985207)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    PFC (0x0702)
*Jun 29 15:40:57.896: Ce0/1/0 LCP:    ACFC (0x0802)
!
!	Outgoing LCP CONFACK from IOS to modem, acknowledging the CONFREQ from the modem.
!
*Jun 29 15:40:57.900: Ce0/1/0 LCP: I CONFACK [ACKsent] id 125 len 20
*Jun 29 15:40:57.900: Ce0/1/0 LCP:    ACCM 0x000A0000 (0x0206000A0000)
*Jun 29 15:40:57.900: Ce0/1/0 LCP:    MagicNumber 0x89803B5B (0x050689803B5B)
*Jun 29 15:40:57.900: Ce0/1/0 LCP:    PFC (0x0702)
*Jun 29 15:40:57.900: Ce0/1/0 LCP:    ACFC (0x0802)
!
!	Incoming LCP CONFACK from modem to IOS, acknowledging the CONFREQ from the modem.
!
*Jun 29 15:40:57.900: Ce0/1/0 LCP: State is Open
 
   
*Jun 29 15:40:57.900: Ce0/1/0 PPP: Phase is FORWARDING, Attempting Forward
*Jun 29 15.!
Success rate is 20 percent (1/5), round-trip min/avg/max = 612/612/612 ms
 
   
2851-b1-cdma1#:40:57.900: Ce0/1/0 PPP: Phase is ESTABLISHING, Finish LCP
 
   
*Jun 29 15:40:57.900: Ce0/1/0 PPP: Phase is UP
!
!	At this point, the LCP is established. Note that the next phase is IPCP, and as far as 
!	Cisco IOS is concerned, and NOT CHAP or PAP. 
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: O CONFREQ [Closed] id 1 len 22
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    Address 0.0.0.0 (0x030600000000)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
*Jun 29 15:40:57.900: Ce0/1/0 PPP: Process pending ncp packets
!
!	Outgoing IPCP CONFREQ from IOS to modem/network proposing the IP address for the host
!	(cellular interface) and the DNS IP addresses. Note that the IP address for the host
!	is set to 0.0.0.0 (dynamically assigned IP address), even if a persistent IP address
!	is required from the network.
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: I CONFREQ [REQsent] id 65 len 10
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    Address 68.28.57.69 (0x0306441C3945)
!
!	Incoming IPCP CONFREQ from modem/network proposing its own address as received from
!	the network.
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: O CONFACK [REQsent] id 65 len 10
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    Address 68.28.57.69 (0x0306441C3945)
!
!	Outgoing IPCP CONFACK from IOS to modem/network accepting the network's address.
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: I CONFNAK [ACKsent] id 1 len 22
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    Address 70.12.221.250 (0x0306460CDDFA)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    PrimaryDNS 68.28.58.11 (0x8106441C3A0B)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    SecondaryDNS 68.28.50.11 (0x8306441C320B)
!
!	Incoming IPCP CONFNAK from modem/network, in response to the earlier CONFREQ from
!	Cisco IOS.
!	
!	CONFNAK proposes the IP address for the host (cellular interface) and the DNS
!	addresses as received from the network as part of the Mobile IP procedure, which
!	occurred between the modem and the network.
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: O CONFREQ [ACKsent] id 2 len 22
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    Address 70.12.221.250 (0x0306460CDDFA)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    PrimaryDNS 68.28.58.11 (0x8106441C3A0B)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP:    SecondaryDNS 68.28.50.11 (0x8306441C320B)
!
!	Outgoing IPCP CONFREQ from IOS, in response to the above CONFNAK from the
!	modem/network.
!
!	CONFREQ proposes the same IP address for the host (cellular interface) and the DNS
!	addresses, as contained in the CONFNAK received earlier.
!
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: I CONFACK [ACKsent] id 2 len 22
*Jun 29 15:40:57.904: Ce0/1/0 IPCP:    Address 70.12.221.250 (0x0306460CDDFA)
*Jun 29 15:40:57.904: Ce0/1/0 IPCP:    PrimaryDNS 68.28.58.11 (0x8106441C3A0B)
*Jun 29 15:40:57.904: Ce0/1/0 IPCP:    SecondaryDNS 68.28.50.11 (0x8306441C320B)
!
!	Incoming IPCP CONFACK from modem/network acknowledging these addresses as acceptable
!	to the modem/network.
!
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: State is Open
!
!	IPCP phase is UP.
!
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: Install negotiated IP interface address 70.12.221.250
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: Install route to 68.28.57.69
*Jun 29 15:40:57.908: Ce0/1/0 IPCP: Add link info for cef entry 68.28.57.69
!
!	IP address assigned to the cellular interface and installed in the routing table. 
! 
 
   
*Jun 29 15:40:58.896: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/1/0, 
changed state to up

Example 4-9 Cellular Interface Information for Normal Operation

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

The following output shows the typical state of the show cellular x/x/x all command after a successful call set up:

Router# sh cellular 0/1/0 all
!
!	Some of the normally displayed information is excluded for readability purposes, so
!	as to highlight the important information,.
!
2851-b1-cdma1#sh cellular 0/1/0 all
Hardware Information
====================
Modem Firmware Version = p2005800
Modem Firmware built = 02-09-07
Hardware Version = 1.0
Electronic Serial Number (ESN) = 0x6032691E
Preferred Roaming List (PRL) Version = 60607
Current Modem Temperature = 35 degrees Celsius
 
   
Profile Information
====================
Electronic Serial Number (ESN) = 0x6032691E
Modem activated = YES
!
!	Modem on the HWIC has been activated.
!
Account Information:
======================
Activation Date: Not available
Phone Number (MDN) : 9134390870
Mobile Station Identifier (MSID) : 9132214671
 
   
Data Profile Info:
=====================
Number of data profiles configured : 2
Current active data profile : 1
 
   
Data Profile 0 Information
==================================
NAI (Network Access Identifier) = 6032691E@hcm.cdma1pcs.com
MN-HA SS = Set
MN-HA SPI = 1234
MN-AAA SS = Set
MN-AAA SPI = 1234
Reverse Tunneling Preference = Set
Home Address = 0.0.0.0
Primary Home Agent Address = 68.28.15.12
Secondary Home Agent Address = 68.28.31.12
!
!	Displays information loaded from the network in modem's NVRAM for data profile 0,
!	which is not used by the user but by the modem for management purposes.
!
!	It displays the NAI.
!	
!	MN-HA and MN-AAA shared secret values are not displayed.
!	
!	Primary and Secondary Home Agent addresses, used for management purposes, are
!	displayed.
!
 
   
Data Profile 1 Information (Active)
==================================
NAI (Network Access Identifier) = productmarketing393@cdma1pcs.com
MN-HA SS = Set
MN-HA SPI = 1234
MN-AAA SS = Set
MN-AAA SPI = 1234
Reverse Tunneling Preference = Set
Home Address = 0.0.0.0
Primary Home Agent Address = 68.28.81.76
Secondary Home Agent Address = 68.28.89.76
!
!	Displays information loaded from the network in modem's NVRAM for data profile 1,
!	which is used by the user.
!
!	It displays the NAI.
!
!	MN-HA and MN-AAA shared secret values are not displayed.
!
!	Primary and Secondary Home Agent addresses, used for Mobile IP purposes, are
!	displayed.
!
Data Connection Information
===========================
Phone number of outgoing call = #777
HDR AT State = Inactive, HDR Session State = Open
HDR Session Info:
    UATI (Hex) = 0084:0AC0:0000:0000:000A:05DC:A812:00A9
    Color Code = 32, RATI = 0x266DF468
    Session duration = 480 msecs, Session start = 4365427257 msecs
    Session end = 4365428118 msecs, Authentication Status = Authenticated
HDR DRC Value = 14, DRC Cover = 1, RRI = 9.6 kbps
Current Transmitted = 8777 bytes, Received = 8036 bytes
Total Transmitted = 31520 KB, Received = 312411 KB
Current Call Status = CONNECTED Privacy Mode = OFF, Service Option = 33
Current Call Duration = 261 secs
Total Call Duration = 7938948 seconds
Current Call State = AT Packet Call 
Last Call Disconnect Reason = Client ended call
Last Connection Error = None
HDR DDTM (Data Dedicated Transmission Mode) Preference = Off
Mobile IP Error Code (RFC-2002) = 0 (Registration accepted)
!
!	Displays data connection related information.
!
 
   
Network Information
===================
Current Service = 1xRTT only
Current Roaming Status(1xRTT) = HOME, (HDR) = HOME
Current Idle Digital Mode = CDMA
Current System Identifier (SID) = 4183
Current Network Identifier (NID) = 87
Current Call Setup Mode = Mobile IP only
Serving Base Station Longitude = -121 deg -55 min -8 sec
Serving Base Station Latitude = 37 deg 25 min 22 sec
Current System Time = Fri Jun 29 12:10:54 2007
 
   
Radio Information
=================
1xRTT related info
------------------
Current RSSI = -93 dBm, ECIO = -9 dBm
Current Channel Number = 50
Current Channel State = Acquired
Current Band Class = Band Class 1
 
   
HDR (1xEVDO) related info
-------------------------
Current RSSI = -125 dBm, ECIO = -2 dBm
Current Channel Number = 25
Current Band Class = Band Class 1
Sector ID (Hex) = 0084:0AC0:0000:0000:000A:05DC:A801:1202
Subnet Mask = 104, Color Code = 32, PN Offset = 240
Rx gain control(Main) = Unavailable, Diversity = Unavailable
Tx total power = -5 dBm, Tx gain adjust = -256 dBm
Carrier-to-interference (C/I) ratio = 12
 
   
Modem Security Information
==========================
Modem PIN Security UNLOCKED
Power-up lock DISABLED
Router#

Example 4-10 Debug for Failure to Connect and Obtain IP Address for the Cellular Interface and Possible Reasons

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

Router# ping ip 209.131.36.158 source 10.3.0.254
 
   
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.3.0.254 
 
   
*Jun 29 20:37:19.043: CHAT0/1/0: Attempting async line dialer script
*Jun 29 20:37:19.043: CHAT0/1/0: Dialing using Modem script: cdma1 & System script: none
*Jun 29 20:37:19.043: CHAT0/1/0: process started
*Jun 29 20:37:19.043: CHAT0/1/0: Asserting DTR
*Jun 29 20:37:19.043: CHAT0/1/0: Chat script cdma1 started
*Jun 29 20:37:19.043: CHAT0/1/0: Sending string: atdt#777
*Jun 29 20:37:19.043: CHAT0/1/0: Expecting string: CONNECT.....
Success rate is 0 percent (0/5)
*Jun 29 20:40:19.043: CHAT0/1/0: Timeout expecting: CONNECT
*Jun 29 20:40:19.043: CHAT0/1/0: Chat script cdma1 finished, status = Connection timed 
out; remote host not responding
*Jun 29 20:40:19.043: TTY0/1/0: Line reset by "Async dialer"
*Jun 29 20:40:19.043: TTY0/1/0: Modem: (unknown)->HANGUP
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 0 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 1 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 3 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 4 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 10 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 2 to destroy
2851-b1-cdma1#
!
!	Modem is not responding to the dial out command. 
!	
!	The reason for this could be one of the following:
!		- Antenna may be disconnected
!		- Very poor signal reception
!		- Problem with the 'chat-script ...' command, possibly incorrectly specified dialer 
!		string
!	
!	A similar problem may be encountered: 
!		- If the expected string ('CONNECT') has typo or that it is not specified as 
!		uppercase.
!		- If the chat-script command is missing in the configuration
!		- If the 'script dialer ...' command is missing on the corresponding line x/x/x
!

Example 4-11 Details of Cellular Interface When Failed to Connect and Obtain IP Address

The blue italicized text throughout this configuration is used to indicate comments and will not be seen when a normal console output is viewed. The bold text is used to indicate important commands to refer back to in case of an error. When debugging, ensure that all the commands in bold are the same in your console output.

The bold text is used to call out the basic cellular configuration, the crypto IPsec configuration, the IP SLA backup configuration, and the mobile IP configuration. The comments below each of the commands associated with each of these configurations are called out throughout the example for ease of reference when debugging.

Router# sh cellular 0/1/0 all
!
!	Some of the normally displayed information is excluded for readability purposes, so
!	as to highlight the important information.
!
 
   
Network Information
===================
Current Service = No Service
Current Roaming Status(1xRTT) = HOME, (HDR) = HOME
Current Idle Digital Mode = CDMA
Current System Identifier (SID) = 4183
Current Network Identifier (NID) = 87
Current Call Setup Mode = Mobile IP only
Serving Base Station Longitude = -121 deg -55 min -8 sec
Serving Base Station Latitude = 37 deg 25 min 22 sec
Current System Time = Fri Jun 29 13:26:48 2007
 
   
Radio Information
=================
1xRTT related info
------------------
Current RSSI = -125 dBm, ECIO = -2 dBm
Current Channel Number = 950
Current Channel State = Scanning
Current Band Class = Band Class 0
 
   
HDR (1xEVDO) related info
-------------------------
Current RSSI = -125 dBm, ECIO = -2 dBm
Current Channel Number = 25
Current Band Class = Band Class 1
Sector ID (Hex) = 0084:0AC0:0000:0000:000A:05DC:A801:1202
Subnet Mask = 104, Color Code = 32, PN Offset = 240
Rx gain control(Main) = Unavailable, Diversity = Unavailable
Tx total power = -5 dBm, Tx gain adjust = -256 dBm
Carrier-to-interference (C/I) ratio = 12
 
   
Modem Security Information
==========================
Modem PIN Security UNLOCKED
Power-up lock DISABLED
!
!	Some of the normally displayed information is excluded for readability purposes, so
!	as to highlight the important information.
!