OSM Configuration Note, 12.2SX
Configuring Destination Sensitive Services on the Optical Services Modules
Downloads: This chapterpdf (PDF - 354.0KB) The complete bookPDF (PDF - 9.55MB) | Feedback

Configuring Destination Sensitive Services on the Optical Services Modules

Table Of Contents

Configuring Destination Sensitive Services on the Optical Services Modules

Understanding Destination Sensitive Services

Configuring Destination Sensitive Services

Configuring Ingress DSS

Configuring Ingress DSB


Configuring Destination Sensitive Services on the Optical Services Modules


This chapter describes how to configure Destination Sensitive Services (DSS) on the Optical Services Modules (OSMs).

This chapter consists of these sections:

Understanding Destination Sensitive Services

Configuring Destination Sensitive Services

Understanding Destination Sensitive Services

DSS allows traffic accounting and traffic shaping to known autonomous system numbers in order to engineer and plan network circuit peering and transit agreements. DSS is supported on ingress WAN ports on the following OSMs:

OC-3 POS:

OSM-4OC3-POS-SI

OSM-8OC3-POS-SI, SL

OSM-16OC3-POS-SI, SL

OSM-4OC3-POS-SI+

OSM-8OC3-POS-SI+, SL+

OSM-16OC3-POS-SI+, SL+

OC-12 POS:

OSM-2OC12-POS-MM, SI, SL

OSM-4OC12-POS-MM, SI, SL

OSM-2OC12-POS-MM+, SI+, SL+

OSM-4OC12-POS-MM+, SI+, SL+

OC-48 POS:

OSM-1OC48-POS-SS, SI, SL

OSM-1OC48-POS-SS+, SI+, SL+

Channelized:

OSM-1CHOC48/T3-SS

OSM-1CHOC12/T3-SI

OSM-1CHOC12/T1-SI

OSM-12CT3/T1

OC-48 POS/DPT:

OSM-2OC48/1DPT-SS, SI, SL

Gigabit Ethernet

OSM-4GE-WAN-GBIC

OSM-2+4GE-WAN+

DSS supports two separate services:

Destination Sensitive Billing (DSB)

DSB allows accounting based on destination traffic indexes and provides a means of classifying customer traffic according to the route that the traffic travels. Trans-Pacific, Trans-Atlantic, satellite, domestic, and other provider traffic can be identified and accounted for on a destination network basis when the customer traffic is on a unique software interface. DSB provides packet and byte counters, which represent counts for IP packets per destination network. DSB is implemented using route-maps to classify the traffic into one of seven possible indexes, which represent a traffic classification.

Destination Sensitive Traffic Shaping (DSTS)

DSTS performs inbound traffic shaping based on the destination traffic index configuration.

See the "Configuring Destination Sensitive Services" section for configuration information.


Note Although the CLI allows it, DSB and DSTS should not be applied to the same interface.


Configuring Destination Sensitive Services

When you configure ingress DSS and DSB on a WAN interface, the traffic coming in over the WAN interface is classified and accounted for.

These sections describe how to configure ingress DSS and DSB:

Configuring Ingress DSS

Configuring Ingress DSB

Configuring Ingress DSS

To configure ingress DSS on your OSM, perform this task:

 
Command
Purpose

Step 1 

Router(config)# route-map map-tag [permit | deny] [sequence-number]

Defines the conditions for redistributing routes from one routing protocol into another.

Step 2 

Router(config-route-map)# match community-list community-list-number

Matches a BGP community.

Step 3 

Router(config-route-map)# set traffic-index 1-8

Creates the BGP traffic index.

Step 4 

Router(config)# router bgp autonomous-system

Configures BGP routing.

Step 5 

Router(config-router)# table-map route-map-name

Modifies metric and tag values when the IP routing table is updated with BGP learned routes.

Step 6 

Router(config)# ip bgp-community new-format

Displays BGP communities in the format AA:NN (autonomous system-community number/2-byte number).

Step 7 

Router(config)# ip community-list 40 100:120

Creates a community list for BGP and controls access to it.

Step 8 

Router(config-pmap)# class-map [match-all | match-any]

Creates a class map to be used for matching packets to a class you define and specifies the criteria to match on.

Step 9 

Router(config-pmap-c)# match bgp-index bgp-index

Identifies a specific BGP index to match on.

Step 10 

Router(config)# policy-map policy_map

Creates or modifies a policy map that can be attached to one or more interfaces to specify a service policy.

Step 11 

Router(config-pmap)# class class-name

Defines the classes you want the service policy to contain.

Step 12 

Router(config-pmap-c)# shape [average | peak] mean-rate [[burst-size] [excess-burst-size]]

Shapes traffic to the indicated bit rate.

Step 13 

Router(config)# interface

Specifies the WAN interface to which the policy map will be applied.

Step 14 

Router(config-if)# service-policy input policy-map

Attaches the specified policy map to the input interface.

To configure ingress DSS, perform this task:


Step 1 Classify the BGP routes by creating BGP traffic indexes:

Router(config)# route-map dss-map1 permit 1
Router(config-route-map)# match community 40
Router(config-route-map)#s et traffic-index 1
Router(config-route-map)# exit
Router(config)# route-map dss-map3
Router(config-route-map)# match community 50
Router(config-route-map)# set traffic-index 3
Router(config-route-map)# exit
Router(config)# route-map dss-map7
Router(config-route-map)# match community 60
Router(config-route-map)# set traffic-index 7
Router(config-route-map)# exit
 
   

Step 2 Enable BGP routing for the autonomous system and apply the route-maps:

Router(config)# router bgp 100
Router(config-router)# table-map dss-map1
Router(config)# ip bgp-community new-format
Router(config)# ip community-list 10 100:120
Router(config-router)# exit
 
   

Step 3 Map the BGP index to the traffic index classes:

Router(config)# class-map dss1
Router(config-cmap)# match bgp-index 1
Router(config-cmap)# exit
Router(config)# class-map dss3
Router(config-cmap)# match bgp-index 3
Router(config-cmap)# exit
Router(config)# class-map dss7
Router(config-cmap)# match bgp-index 7
Router(config-cmap)# exit
 
   

Step 4 Configure the policy-maps and traffic shaping parameters:

Router(config)# policy-map dss-policy
Router(config-pmap)# class dss1
Router(config-pmap-c)#s hape average 64000
Router(config-pmap-c)# exit
Router(config-pmap)# class dss3
Router(config-pmap-c)# shape average 1024000
Router(config-pmap-c)# exit
Router(config-pmap)# class dss7
Router(config-pmap-c)# shape average 384000
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# 
 
   

Step 5 Apply the policy configuration to the appropriate WAN interface:

Router(config)# interface ge-wan 4/1
Router(config-if)# service-policy input dss-policy
Router(config-if)# exit
Router(config)
 
   

Step 6 Display DSS configuration information:

Router# show ip cef 8.1.1.0
8.1.1.0/24, version 340, cached adjacency 19.1.1.3
0 packets, 0 bytes, Precedence critical (5), traffic_index 1
  via 19.1.1.3, 0 dependencies, recursive
    next hop 19.1.1.3, Vlan19 via 19.1.1.3/32
    valid cached adjacency
 
   
Router# show ip bgp 8.1.1.0
BGP routing table entry for 8.1.1.0/24, version 14
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  12
    19.1.1.3 from 19.1.1.3 (19.1.1.3)
      Origin IGP, metric 0, localpref 100, valid, external, best
      Community: 100:120
 
   
Router# show class-map dss1
 Class Map match-all dss1 (id 8)
   Match bgp-index 1
 
   
Router# show policy-map interface ge-wan 4/1
 
   
 GigabitEthernet4/1
 
   
  service-policy input: dss-policy
 
   
    class-map: dss1 (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      match: bgp-index 1
      queue size 0, queue limit 2
      packets input 0, packet drops 0
<ouput truncated>
 
   
Router(config)#
 
   

Configuring Ingress DSB

To configure ingress DSB on your OSM, display the BGP policy accounting configuration, and clear the ingress DSB counters, perform this task:


Step 1 Enable ingress DSB on the port:

Router(config)# interface GE-WAN6/2
Router(config-if)# ingress-dsb
 
   

Step 2 Enable BGP policy accounting on the interface:

Router(config-if)# bgp-policy accounting
Router(config-if)# end
 
   

Step 3 Display the BGP policy accounting configuration on the input interface:

Router# show cef interface GE-WAN6/2 policy
GE_WAN6/2 is up (if_number 18)
  Corresponding hwidb fast_if_number 18
  Corresponding hwidb firstsw->if_number 18
BGP based Policy accounting is enabled
 Index         Packets           Bytes
     1         5259200       315552000
     2         5259300       315558000
     3         5259300       315558000
     4         5258900       315534000
     5         5258916       315534960
     6         5259000       315540000
     7         5259100       315546000
     8               0               0
Router#
 
   

Step 4 Clear all ingress DSB counters:

Router# clear cef interface policy-statistics
 
   

Step 5 Clear the ingress DSB counter for a specific interface:

Router# clear cef interface GE-WAN6/2 policy-statistics