OSM Configuration Note, 12.2SX
Configuring the Channelized OC-12/T3 SONET/SDH Optical Services Modules
Downloads: This chapterpdf (PDF - 514.0KB) The complete bookPDF (PDF - 9.55MB) | Feedback

Configuring the Channelized OC-12/T3 SONET/SDH Optical Services Modules

Table Of Contents

Configuring the Channelized OC-12/T3 SONET/SDH Optical Services Modules

Understanding the Channelized OSMs

Supported Multiplexing and Mappings

Supported Features on the Channelized OC-12/T3 OSMs

SONET Compliance

SONET Errors, Alarms, and Performance Monitoring

SONET Synchronization

WAN Protocols

Network Management

DS-3 Support

DSU Mode

Quality of Service Protocols

Configuring the Channelized Modules

Configuring the SONET Controller

Configuring the POS Interface

Configuring the DS-3 Serial Interface

Configuring Interfaces Using SDH Framing with AU-3 Mapping

Configuring Interfaces under SDH Framing with AU-4 Mapping

Configuring Automatic Protection Switching

Configuring the Working Interface

Configuring the Protect Interface

Configuring Frame Relay and Frame Relay Traffic Shaping

Frame Relay Limitations and Restrictions

Frame Relay Traffic Shaping Configuration Example

Configuration Examples

Configuring Channelized POS

Configuring Channelized DS-3

Configuring Basic APS

Multiple APS Interface Configuration


Configuring the Channelized OC-12/T3 SONET/SDH Optical Services Modules


This chapter describes how to configure the channelized 1-port OC-12 (OSM-1CHOC12/T3-SI) SONET/SDH Optical Services Modules (OSMs).

The chapter consists of these sections:

Understanding the Channelized OSMs

Configuring the Channelized Modules

Understanding the Channelized OSMs

These sections describe the SONET/SDH mappings and multiplex hierachy and the features supported on the channelized OSMs:

Supported Multiplexing and Mappings

Supported Features on the Channelized OC-12/T3 OSMs

Configuring the Channelized Modules

Supported Multiplexing and Mappings

The OSM-1CHOC12/STM-4 T3-SI module supports channelized configurations down to OC-3, DS-3, and DS-3 subrate.

Figure 5-1 shows the SONET multiplexing hierarchy supported by the 1-port ChOC-12/STM-4 OSMs.

Figure 5-2 shows the SDH multiplexing hierarchy supported by the 1-ChOC-12/STM-4 OSMs.

Figure 5-1 Supported SONET Multiplexing Hierarchy on the 1-port ChOC-12 OSMs

Figure 5-2 Supported SDH Multiplexing Hierarchy on the 1-port ChOC-12 OSMs

Supported Features on the Channelized OC-12/T3 OSMs

The OSM-1CHOC12/T3-SI support the following standard Cisco IOS SONET/SDH features:

SONET Compliance

SONET Errors, Alarms, and Performance Monitoring

SONET Synchronization

WAN Protocols

Network Management

DS-3 Support

DSU Mode

Quality of Service Protocols

SONET Compliance

The OSM-1CHOC12/T3-SI supports 1+1 SONET Automatic Protection Switching (APS).

SONET Errors, Alarms, and Performance Monitoring

This section lists the supported SONET errors, alarms, and perfomance monitoring features:

Signal Failure Bit Error Rate (SF-ber)

Signal Degrade Bit Error Rate (SD-ber)

Signal Label Payload Construction (C2)

Path Trace Byte (J1)

Loss of Signal (LOS)

Loss of Frame (LOF)

Error Counts for B1

Threshold Crossing Alarms (TCA) for B1

Line Alarm Indication Signal (LAIS)

Line Remote Defection Indication (LRDI)

Line Remote Error Indication (LREI)

Error Counts for B2

Threshold Crossing Alarms (TCA) for B2

Path Alarm Indication Signal (PAIS)

Path Remote Defect Indication (PRDI)

Path Remote Error Indication (PREI)

Error Counts for B3

Threshold Crossing Alarms (TCA) for B3

Loss of Pointer (LOP)

Path Unequipped (PUNEQ)

Path Label Mismatch (PPLM)

New Pointer Events (NEWPTR)

Positive Stuffing Event (PSE)

Negative Stuffing Event (NSE)

SONET Synchronization

This section lists the supported SONET synchronization features:

Local timing (internal timing for inter-router connections over dark fiber or WDM equipment):

+/- 4.6 ppm clock accuracy over full operating temperature

Loop timing (loop timing for connecting to SONET/SDH equipment)

WAN Protocols

This section lists the supported WAN protocols:

Multiprotocol Label Switching (MPLS) and MPLS/VPN

See Chapter 11 "Configuring Multiprotocol Label Switching on the Optical Services Modules" for information configuring MPLS/VPN on the channelized OSMs.

Point-to-Point Protocol (PPP) IETF RFC 1661

HDLC (IETF RFC 1662)

PPP over SONET with 1+x43 Self-Synchronous Payload Scrambling

Frame Relay

Configure the channelized interfaces for Frame Relay as described in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.1 under "Configuring Frame Relay" and in the Cisco IOS Wide-Area Networking Command Reference, Release 12.1 at these URLs:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

Configure traffic shaping for Frame Relay as described in the Cisco IOS Quality of Service Solutions Configuration Guide under "Configuring Distributed Traffic Shaping" at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm.

Cisco Protection Group Protocol over UDP/IP (Port 172) for APS and MSP

Configure the serial interface encapsulation as described in the Cisco IOS Interface Configuration Guide under "Configuring Serial Interfaces" and in the Cisco IOS Interface Command Reference publication at these URLs:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_r/index.htm

Network Management

This section lists the supported network management features:

Local Loopback

Network Loopback

NetFlow Data Export

Performance Statistics for Timed Intervals (RFC 1595)

DS-3 Support

This section lists the supported DS-3 features:

Framing control, C-bit or M23

Local (internal) clocking mode

Loopback modes

Bit error rate test (BERT) diagnostics for each DS-3 channel

Receive and transmit alarm processing

Performance and error counters

Far-End Alarm and Control (FEAC) support

DSU Mode

This section lists the supported DSU modes:

Digital Link

Verilink

Adtran

Larscom

Kentrox

Quality of Service Protocols

For information on configuring QoS on the channelized OSMs, see Chapter 9 "Configuring QoS on the Optical Services Modules."

The following QoS features are supported on the channelized OSMs:

PFC2 QoS on the LAN and WAN ports.

Differentiated Services Control Point (DSCP)

IP Precedence classification

Configure class-based marking as described in the Class-Based Marking Feature Module at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/cbpmark2.htm

Classification and priority marking based on the following:

Ethertype

IP Source Address (SA)

IP Destintation Address (DA)

TCP port number

UDP port number

IP SA + TCP/UDP port number + IP DA + TCP/UDP port number

Class-based weighted fair queuing (CBWFQ) on the WAN ports.

Low latency queuing (LLQ) on the WAN ports.

Hierarchical traffic shaping for Frame Relay, HDLC, and PPP encapsulations.

For general information on classification, marking, and queuing in Cisco IOS, refer to the "Classificiation" chapter of the Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.1 at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_c/index.htm

For information about platform-independent Cisco IOS QoS commands, refer to the Cisco IOS Quality of Service Solutions Command Reference, Release 12.1 at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/qos_r/index.htm

Configuring the Channelized Modules

These sections describe how to configure the channelized modules:

Configuring the SONET Controller

Configuring the POS Interface

Configuring the DS-3 Serial Interface

Configuring Interfaces Using SDH Framing with AU-3 Mapping

Configuring Interfaces under SDH Framing with AU-4 Mapping

Configuring Automatic Protection Switching

Configuring Frame Relay and Frame Relay Traffic Shaping

Configuration Examples

Configuring the SONET Controller

To configure the SONET controller, perform this task:

 
Command
Purpose

Step 1 

Router# configure terminal

Enters configuration mode and specifies that the console terminal is the source of the configuration subcommands.

Step 2 

Router(config)# controller sonet slot/port

Selects a port and enters controller configuration mode.

Step 3 

Router(config-controller)# [no] framing {sonet | sdh}

Configures the framing mode of the ChOC-12 to SONET or SDH.

SDH is the ITU standards equivalent of SONET.

SONET is the default.

Step 4 

Router(config-controller)#

sts-1 {sts-1 number} serial {T3 | E3}

sts-1 {start sts-1 number} - {end sts-1 number} pos

au-3 {au-3 number} serial {T3 | E3}

au-3 {start au-3 number} - {end au-3 number} pos

au-4 {start-au4-number} vc-3 {vc3-number} serial [t3|e3]

au-4 {start-au4-number} - {end-au4-number} pos

Provisions the channels for the interface. Select the channel provisioning command option appropriate to your needs.

Step 5 

Router(config-controller)# clock source {internal [primary | secondary]| line [primary | secondary]}

Configures the clock source used by the SONET controller.

internal—The clocking source is obtained from the port adapter line.

line—The clocking source is obtained from the network.

primary—Provides the first priority clock for internal circuitry.

secondary—Provides the second clock for internal circuitry when the primary clock fails. The network clocking source is the default.

Step 6 

Router(config-controller)# [no] loopback {internal line}

Enables or disables loopback mode on a SONET controller.

internal—Data is looped from the transmit path to the receive path allowing diagnostics to send data to itself without relying on any external connections.

line—Data is looped from the external port to the transmit port and back out the external port.

No loopback enabled is the default.

Step 7 

Router(config-controller)# alarm-report {all | b1-tca | b2-tca | b3-tca | lais | lrdi | pplm | ptim | sd-ber | sf-ber | slof | slos}

(Optional) Enables alarm reporting.

Step 8 

Router(config-controller)# threshold {b1-tca value | b2-tca value| b3-tca value| sd-ber value| sf-ber value}

(Optional) Sets BER threshold values.

Step 9 

Router(config-controller)# [no] description string

(Optional) Specifies up to 80 characters of text describing the SONET controller. No description is the default.

Configuring the POS Interface

After you verify the controller configuration, you can configure the POS interface. The configuration below is basic, and you may need to specify additional interface parameters depending on your network requirements.

To configure the POS interface, perform this task:

 
Command
Purpose

Step 1 

Router# configure terminal

Enters configuration mode and specifies that the console terminal is the source of the configuration subcommands.

Step 2 

Router(config)# interface POS slot/port:channel#

Specifies the serial port and channel to configure.

Step 3 

Router(config-if)# encapsulation hdlc | ppp

Specifies the encapsulation type.

Step 4 

Router(config-if)# pos flag j1 expect message rxpathmessagetext | length [16|64] | message txpathmessagetext

(Optional) Specifies a path message for a channelized interface.

Step 5 

Router(config-if)# ip address ip-address mask [secondary]

Assigns an IP address and subnet mask to the interface.

Step 6 

Router(config-if)# no shutdown

Enables the interface.

Configuring the DS-3 Serial Interface

After you verify the controller configuration, you can configure the associated DS-3 channel and serial interfaces on the controller.


Note When connecting a T3 interface to a VeriLink DSU the minimum supported bandwidth for the T3 interface is 6316 Kbps and the bandwidth should be in multiples of 6316 Kbps up to 44210.


To configure the DS-3 interfaces, perform this task:

 
Command
Purpose

Step 1 

Router# configure terminal

Enters configuration mode and specifies that the console terminal is the source of the configuration subcommands.

Step 2 

Router(config)# interface serial slot/port:channel#

Specifies the serial port and channel to configure.

Step 3 

Router(config-if)# framing {c-bit | m23}

Specifies the framing.

Step 4 

Router(config-if)# [no] dsu mode {0-4}

Specifies the DSU mode:

0-Digital-Link

1-Kentrox

2-Larscom

3-Adtran

4-Verilink

Step 5 

Router(config-if)# [no] dsu remote [accept | fullrate]

Specifies if the local (near-end) interface will accept incoming requests from the remote (far-end) interface, or if the local interface will request that the remote interface set its bandwidth to fullrate.

Step 6 

Router(config-if)# [no] dsu bandwidth Kilobits/sec

Sets the DSU subrate bandwidth.

Step 7 

Router(config-if)# [no] scramble

Enables payload scrambling.

Step 8 

Router(config-if)# [no] loopback {local | network remote}

Sets the loopback mode.

Step 9 

Router(config-if)# [no] bert pattern [2^15 | 2^20 ] interval [1-1440]

(Optional) Configures bit-error-rate (BER) testing.

Step 10 

Router(config-if)# alarm-report {all | b3-tca | pais | pplm | plop | prdi | ptim | ptiu | puneq}

(Optional) Enables reporting of path alarms.

Step 11 

Router(config-if)# overhead {c2 byte value | j1 {expect message message-string | length 16-64 |

message message-string}

Specifies SONET path header byte value.

Step 12 

Router(config-if)# ip address ip-address mask [secondary]

Assigns an IP address and subnet mask to the interface.

Step 13 

Router(config-if)# [no] keepalive

Turns on and off keepalive messages.

Step 14 

Router(config-if)# no shutdown

Enables the interface.

This is an example of an unchannelized DS-3 interface configuration:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller t3 3/0
Router (config-controller)#no channelized
Router (config-controller)# exit
Router (config)# interface serial 1/0
Router (config-if)# dsu bandwidth 16000
Router (config-if)# encapsulation frame-relay
Router (config-if)# ip address 10.10.10.10.255.255.255.255
Router (config-if)# no shutdown
Router (config-if)# exit
Router(config)#

Configuring Interfaces Using SDH Framing with AU-3 Mapping

This section describes how to enable an interface under SDH framing with AU-3 mapping and specify IP routing on the OSM-1CHOC12/T3-SI channelized modules. To configure interfaces using SDH framing with AU-3 mapping, peform this task:

 
Command
Purpose

Step 1 

Router# configure terminal

Enters configuration mode and specifies that the console terminal is the source of the configuration subcommands.

Step 2 

Router(config)# controller sonet slot/port

Selects the controller.

Step 3 

Router(config-controller)# framing sdh

Specifies the framing.

Step 4 

Router(config-controller)# aug mapping au-3

Specifies the AUG mapping.

Step 5 

Router(config-controller)# au-3 au-3 number serial {T3 
| E3}

Provisions the AU-3 channels.

Step 6 

Router(config-controller)# exit

Exits controller configuration mode.

Step 7 

Router(config)# interface serial slot/port:au-3 number

Selects the interface.

Step 8 

Router(config-if)# ip address ip-address mask [secondary]

Assigns an IP address and subnet mask to the interface.

Step 9 

Router(config-if)# [no] shutdown

Enables the interface.

In this example, a port is configured as 12 E3 interfaces.


Note When you connect an E3 interface to a Digital Link DL3100E E3 access multiplexer DSU, you must use the "clear channel" mode on the Digital Link DSU. When you connect an E3 interface to a Cisco 12000 Series 12-Port packet over E3 line card, you must configure dsu mode kentrox on the Cisco 12000 Series 12-Port packet over E3 line card. When you connect an E3 interface to a Cisco C7500 or a Cisco C7200 E3 port adaptor (PA), you must configure dsu mode 1 on the E3 interface on the E3 PA



Step 1 .Enter the configure terminal EXEC command to enter global configuration mode as follows:

router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.  

Step 2 Provisision the E3 channels:

router(config)# controller sonet 4/1
router(config-controller)# framing sdh
router(config-controller)# overhead s1s0 2
router(config-controller)# aug mapping au-3
router(config-controller)# au-3 1 serial e3
router(config-controller)# au-3 2 serial e3
router(config-controller)# au-3 3 serial e3
router(config-controller)# au-3 4 serial e3
router(config-controller)# au-3 5 serial e3
router(config-controller)# au-3 6 serial e3
router(config-controller)# au-3 7 serial e3
router(config-controller)# au-3 8 serial e3
router(config-controller)# au-3 9 serial e3
router(config-controller)# au-3 10 serial e3
router(config-controller)# au-3 11 serial e3
router(config-controller)# au-3 12 serial e3
 
   

Step 3 Configure the E3 interfaces:

Router(config)# interface serial 5/2:1
Router(config-if)# ip address 10.2.1.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:2
Router(config-if)# ip address 10.2.2.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:3
Router(config-if)# ip address 10.2.3.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:4
Router(config-if)# ip address 10.2.4.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:5
Router(config-if)# ip address 10.2.5.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:6
Router(config-if)# ip address 10.2.6.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:7
Router(config-if)# ip address 10.2.7.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:8
Router(config-if)# ip address 10.2.8.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:9
Router(config-if)# ip address 10.2.9.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:10
Router(config-if)# ip address 10.2.10.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:11
Router(config-if)# ip address 10.2.11.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# interface serial 5/2:12
Router(config-if)# ip address 10.2.12.1 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# exit
 
   

Step 4 Write the new configuration to nonvolatile random-access memory (NVRAM) by using the copy running-config startup-config command:

router# copy running-config startup-config
[OK]
router#

Configuring Interfaces under SDH Framing with AU-4 Mapping

This section describes how to enable an interface under SDH framing with AU-4 mapping and specify IP routing on the OSM-1CHOC12/T3-SI channelized modules. In this example, a port is configured as 12 E3 interfaces.

 
Command
Purpose

Step 1 

Router# configure terminal

Enters configuration mode and specifies that the console terminal is the source of the configuration subcommands.

Step 2 

Router(config)# controller sonet slot/port

Selects the controller.

Step 3 

Router(config-controller)# framing sdh

Specifies the framing.

Step 4 

Router(config-controller)# aug mapping au-4

Specifies the AUG mapping.

Step 5 

Router(config-controller)#  
au-4 start-au4-number vc-3 VC3-number serial [t3|e3]

au-4 start-au4-number - end-au4-number pos

 
        

Provisions the channels and defines the interface number.

Step 6 

Router(config-controller)# exit

Exits controller configuration mode.

Step 7 

Router(config)# interface serial slot/port. au-4:au-3

Selects the interface.

Step 8 

Router(config-if)# ip address ip-address mask [secondary]

Assigns an IP address and subnet mask to the interface.

Step 9 

Router(config-if)# [no] shutdown

Enables the interface.

In this example, AU-4 mapping is used to configure one STM-4 POS interaface, two STM-1 interfaces, and two DS-3 serial interfaces. The DS-3 interface names are constructed from slot/port. au-4:au-3. The VC-3 number, ranging 1 through 3, is the TUG-3 (or VC3) number inside the selected AU-4.

The STM-4 interface name is constructed from the first AU-4 number.


Step 1 Enter the configure terminal EXEC command to enter global configuration mode as follows:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z. 
 
   

Step 2 Provision the channels:

Router(config)# controller sonet 5/1
Router(config-controller)# framing sdh
Router(config-controller)# aug mapping au-4
Router(config-controller)# au-4 1-4 pos
Router(config-controller)# au-4 5 pos 
Router(config-controller)# au-4 6 vc-3 1 serial t3
Router(config-controller)# au-4 6 vc-3 2 serial t3
Router(config-controller)# au-4 7 pos 
Router(config-controller)# end
 
   

Step 3 Configure the interfaces:

Router(config)# interface pos 5/1:1
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.10 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface pos 5/1:5
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.11 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface serial 5/1.6:1
Router(config_if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 30000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.10.10.12. 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface serial 5/1.6:2
Router(config_if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 45000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.10.10.12. 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
Router(config)# interface pos 5/1:7
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.13 255.255.255.0
Router(config-if)# no shutdown
Router(config-if)# end
 
   

Step 4 Write the new configuration to nonvolatile random-access memory (NVRAM) by using the copy running-config startup-config command:

Router# copy running-config startup-config
[OK]
Router#

Configuring Automatic Protection Switching

Automatic protection switching (APS) allows switchover of packet-over-SONET (POS) circuits and is often required when connecting SONET equipment to telecommunications equipment. When APS is configured, a protect POS interface is brought into the SONET network from the intervening SONET equipment and the protect POS interface becomes the working POS interface on the circuit.


Note Note that on the OSM-1CHOC12/T3-SI, APS is configured at the SONET controller level rather than at the interface level.


The protect interface is configured with the IP address of the router that has the working interface. The APS Protect Group Protocol provides communication between the process controlling the working interface and the process controlling the protect interface. When you use the APS Protect Group Protocol, POS interfaces can be switched in the event of a router failure, degradation or loss of channel signal, or manual intervention.

Two SONET connections are required to support APS. In a telecommuncations environment, the SONET circuits must be provisioned as APS. You must also provision the operation, mode, and revert options. If the SONET connections are homed on two separate routers (the normal configuration), an out-of-band (OOB) communications channel between the two routers needs to be set up for APS communication.

When configuring APS, we recommend you configure the working interface first, along with the IP address of the interface being used as the APS OOB communications path.


Note To prevent the protected interface from becoming the active circuit and disabling the working circuit when it is discovered, configure the working interface before configuring the protected interface.


For more information on APS, refer to the Cisco IOS Interface Configuration Guide, Release 12.1 at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/inter_c/index.htm

Configuring the Working Interface

To configure the working interface, perform this task:

 
Command
Purpose

Step 1 

Router(config)# controller sonet slot/port

Enters SONET controller-configuration mode from the config prompt.

Step 2 

Router(config-controller)# aps working circuit-number

Configures this interface as a working interface.

Step 3 

Router(config-controller)# end

Exits configuration mode.

Step 4 

Router# show aps

Router# show aps controller

Displays information about the controllers so that you can verify the configuration.


Note If a router has two or more protect interfaces, the aps group command for each interface must precede the corresponding aps protect command.


Configuring the Protect Interface

To configure the protect interface, perform this task beginning in global configuration mode:

 
Command
Purpose

Step 1 

Router(config)# controller sonet slot/port

Enters SONET controller-configuration mode from the config prompt.

Step 2 

Router(config-controller)# aps protect circuit-number ip-address

Configures this interface as a protect interface. Specifies the IP address of the router that contains the working interface.

Step 3 

Router(config-controller)# end

Exits configuration mode.

Step 4 

Router# show aps

Router# show aps controller

Displays information about the controllers so that you can verify the configuration.

Configuring Frame Relay and Frame Relay Traffic Shaping

This section describes Frame Relay configurations, platform-specific commands, and limitations:

Frame Relay Limitations and Restrictions

Frame Relay Traffic Shaping Configuration Example

Configure the channelized interfaces for Frame Relay as described in the Cisco IOS Wide-Area Networking Configuration Guide, Release 12.1 under "Configuring Frame Relay" and in the Cisco IOS Wide-Area Networking Command Reference, Release 12.1 at:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_c/wcdfrely.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/wan_r/wrdfrely.htm

Configure traffic shaping for Frame Relay as described in the Cisco IOS Quality of Service

Solutions Configuration Guide under "Configuring Distributed Traffic Shaping" at this URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt4/qcfdts.htm.

Frame Relay Limitations and Restrictions

The following limitations and restrictions apply to Frame Relay:

Frame Relay is not supported on SVCs.

IP addresses cannot be assigned to main interfaces configured for Frame Relay.

Frame Relay is supported only on point-to-point connections.

Frame Relay switching functionality is not supported. The frame-relay switching configuration is available only to configure the frame-relay intf-type dce option.

Frame Relay fragmentation and compression is not supported.

FECN and BECN statistics per DLCI are not supported.

Only FIFO queuing is supported.

DLCI is configurable on subinterfaces only and cannot be configured on the main interface.

The maximum supported number of configured DLCIs per chassis is 4,000.

Only class-based traffic shaping is supported. The following commands are not supported:

Router(config-pmap-c)# shape [average | peak] mean-rate [[burst-size] [excess-burst-size]]

Router (config-pmap-c)# priority {kbps | percent percent} [bytes]

Router (config-pmap-c)# fair-queue number-of-queues

Router(config-map-class)# frame-relay adaptive-shaping [becn | foresight]1

Router(config-map-class)# frame-relay cir {in | out} bps

Router(config-map-class)# frame-relay {bc | be} {in | out} bits

Router(config-map-class)# frame-relay traffic-rate average [peak]

Router(config-map-class)# frame-relay priority-group list-number

Router(config-map-class)# frame-relay fragment fragment_size

Router(config-if)# frame-relay payload-compress packet-by-packet

Router(config-if)# frame-relay de-group group-number dlci

Router# show traffic-shape queue

Frame Relay Traffic Shaping Configuration Example

 
Command
Purpose

Step 1 

Router(config-pmap)# class-map [match-all | match-any]

Creates a class map to be used for matching packets to a class you define and specifies the criteria to match on. Match criteria for classes can be based on IP DSCP or IP precedence.

Step 2 

Router(config-pmap)# match

Identifies a match criterion.

Step 3 

Router(config)# policy-map policy_map

Creates or modifies a policy map that can be attached to one or more interfaces to specify a service policy.

Step 4 

Router(config-pmap)# class class-name

Defines the classes you want the service policy to contain.

Step 5 

Router(config-pmap-c)#shape average mean-rate [burst-size]

Shapes traffic to the indicated bit rate.

Step 6 

Router(config)# map-class frame-relay 
map-class-name

Specifies a map class to define quality of service (QoS) values.

Step 7 

Router(config-map-class)# no frame-relay adaptive-shaping

Disables backward notification.

Step 8 

Router(config-map-class)# service-policy input policy-map

Attaches the specified policy map to the input interface.

Step 9 

Router(config-map-class)# service-policy output policy-map

Attaches the specified policy map to the output interface.

Step 10 

Router(config)#interface interface

Specifies the interface to which the policy map will be applied.

Step 11 

Router(config-subif)# ip address ip_address mask

Assigns an IP address to the subinterface.

Step 12 

Router(config-subif)# no cdp enable

Disables CDP.

Step 13 

Router(config-subif)# frame-relay interface-dlci dlci

Assigns a data link connection identifier (DLCI) to a specified Frame Relay subinterface.

Step 14 

Router(config-fr-dlci)# class class-name

Specifies the name a predefined map-class which was defined with the map-class frame-relay command.

We recommend that you explicitly disable CDP on the subinterfaces. Should CDP be required on the subinterfaces, the input-queue depth may need to be adjusted. To accommodate the number of incoming CDP packets, configure the input-queue depth on the main interface to be slightly larger than the number of subinterfaces on which you have enabled CDP. The default input-queue depth is 75 and it can be adjusted with the hold-queue interface command as follows:

Router(config-if)#hold-queue 300 in
 
   

In the following example, traffic leaving subinterface 6/1:1.1 or 6/1:1.2 is shaped to 1 Mbps:

Router(config)# class-map class-p2p-all
Router(config-cmap)# match any
Router(config-cmap)# exit
Router(config)# policy-map dts-p2p-all-action
Router(config-pmap)# class class-p2p-all
Router(config-pmap-c)# shape average 1000000
Router(config-pmap-c)# exit
Router(config)# interface Serial6/1:1.1 point-to-point
Router(config-subif)# service-policy output dts-p2p-all-action
Router(config-subif)# exit
Router(config)# interface serial6/1:1.2 point-to-point
Router(config-subif)# service-policy output dts-p2p-all-action
 
   

The following example shows a per-DLCI traffic configuration:

Router(config)# class-map match-all fr-classmap

Router(config-cmap)# match any

Router(config-cmap)# exit
Router(config)# policy-map fr-pmap
Router(config-pmap)# class fr-classmap
Router(config-pmap-c)# shape average 8000000 32000 32000
Router(config-pmap-c)# exit
Router(config)# interface Serial6/1:1.1 point-to-point
Router(config-subif)# ip address 72.0.0.1 255.255.0.0
Router(config-subif)# mls qos trust dscp
Router(config-subif)# frame-relay interface-dlci 18 
Router(config-fr-dlci)# class fr-shaping
Router(config-fr-dlci)# exit
Router(config)# map-class frame-relay fr-shaping
Router(config-map-class)# no frame-relay adaptive-shaping
Router(config-map-class)# service-policy input fr-pmap
Router(config-map-class)# service-policy output fr-pmap

Configuration Examples

This following configurations are shown in this section:

Configuring Channelized POS

Configuring Channelized DS-3

Configuring Basic APS

Multiple APS Interface Configuration

Configuring Channelized POS

This example shows how to configure channelized POS. The sts-1 number is the logical STS-1 path inside the OC-12 frame and ranges from 1-12. For an OC-3 channel, the STS-1 numbers cannot cross the OC-3 boundary. For example, sts-1 1-6 would be an illegal configuration.

Perform the appropriate configurations for each POS interface after you have configured for channelized POS:


Step 1 Configure the SONET controller:

Router(config)# controller sonet 2/1
 
   

Step 2 Provision the channels:

Router(config-controller)# sts-1 1-3 pos
Router(config-controller)# sts-1 13-15 pos
Router(config-controller)# sts-1 16-18 pos
Router(config-controller)# exit
 
   

Step 3 Configure the POS interface:

Router(config)# interface pos 2/1:13
Router(config-if)# encapsulation ppp
Router(config-if)# ip address 10.10.10.10 255.255.255.0
Router(config-if)# end
 
   

Configuring Channelized DS-3

This example show how to configure channelized DS-3:


Step 1 Configure the SONET controller:

Router(config)# controller sonet 2/1
 
   

Step 2 Provision the channels:

Router(config-controller)# sts-1 4 serial t3
Router(config-controller)# exit
 
   

Step 3 Configure the serial interface:

Router(config)# interface serial 2/1:4
Router(config-if)# framing c-bit
Router(config-if)# dsu mode 0
Router(config-if)# dsu remote accept
Router(config-if)# dsu bandwidth 30000
Router(config-if)# scramble
Router(config-if)# loopback remote
Router(config-if)# ip address 10.1.1.1. 255.255.255.0
Router(config-if)# end
 
   

Configuring Basic APS

The following example shows the configuration of APS on router A and router B (see Figure 5-3). In this example, router A is configured with the working interface, and router B is configured with the protect interface. If the working interface on router A becomes unavailable, the connection will automatically switch over to the protect interface on router B. The working and protect interfaces are configured at the controller level.

Figure 5-3 Basic APS Configuration


Step 1 On router A, which contains the working interface, use the following configuration:

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config)# controller sonet 7/1
Router(config-controller)# aps working 1
Router(config-controller)# end
Router#
 
   

Step 2 On router B, which contains the protect interface, use the following configuration:

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config-controller)# controller sonet 3/1
Router(config-controller)# aps protect 1 7.7.7.7
Router(config-controller)# end
Router#
 
   

Multiple APS Interface Configuration

To configure more than one protect/working interface, use the aps group command. The following example in Figure 5-4 shows the configuration of grouping more than one working/protect interface. In this example, router A is configured with a working interface and a protect interface, and router B is configured with a working interface and a protect interface. If the working interface 2/0 on router A becomes unavailable, the connection will switch over to the protect interface 3/0 on router B because they are both in APS group 10. Similarly, if the working interface 2/0 on router B becomes unavailable, the connection will switch over to the protect interface 3/0 on router A because they are both in APS group 20.

Figure 5-4 Multiple Working and Protect Interfaces Configuration


Note Configure the working interface before configuring the protect interface to avoid the protect interface from becoming the active circuit and disabling the working circuit when it is discovered.



Step 1 On router A, which contains the working interface for group 10 and the protect interface for group 20, use the following configuration:

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.6 255.255.255.0
Router(config-if)# exit
Router(config)# controller sonet 7/1
Router(config-controller)# aps group 10
Router(config-controller)# aps working 1
Router(config-controller)# exit
Router(config)# contoller sonet 3/0
Router(config-controller)# aps group 20
Router(config-controller)# aps protect 1 7.7.7.7
Router(config-controller)# end
Router#
 
   

Step 2 On router B, which contains the protect interface for group 10 and the working interface for group 20, use the following configuration:

Router# configure terminal
Router(config)# interface ethernet 0/0
Router(config-if)# ip address 7.7.7.7 255.255.255.0
Router(config-if)# exit
Router(config)# controller sonet 2/0
Router(config-controller)# aps group 20
Router(config-controller)# aps working 1
Router(config-controller)# exit
Router(config)# controller sonet 3/0
Router(config-controller)# aps group 10
Router(config-controller)# aps protect 1 7.7.7.6
Router(config-controllers)# end
Router#