Cisco 10000 Series Router Software Configuration Guide
Configuring L2VPN Interworking
Downloads: This chapterpdf (PDF - 901.0KB) The complete bookPDF (PDF - 16.03MB) | Feedback

Configuring L2VPN Interworking

Table Of Contents

Configuring L2VPN Interworking

Bridged Interworking

Ethernet to VLAN—Bridged Interworking

Configuring L2VPN Interworking

Verifying the Configuration

Configuration Examples of Ethernet to VLAN—Bridged

Ethernet to VLAN over LS—Bridged: Example

Ethernet to VLAN over AToM—Bridged: Example

Routed Interworking

Restrictions for Routed Interworking

Ethernet/VLAN to ATM AAL5 Interworking

Prerequisites of Ethernet/VLAN to ATM AAL5 Interworking

Restrictions of Ethernet/VLAN to ATM AAL5 Interworking

ATM AAL5 to Ethernet Local Switching—Bridged Interworking

ATM AAL5 to VLAN 802.1Q Local Switching—Bridged Interworking

ATM AAL5 to Ethernet Port AToM—Bridged Interworking

ATM AAL5 to Ethernet VLAN 802.1Q AToM—Bridged Interworking

ATM to Ethernet—Routed Interworking

Configuration Tasks and Examples

Local Switching

AToM

Ethernet/VLAN to Frame Relay Interworking

Prerequisites of Ethernet/VLAN to Frame Relay Interworking

Restrictions for Ethernet/VLAN to Frame Relay Interworking

FR DLCI to Ethernet Local Switching—Bridged Interworking

FR DLCI to VLAN 802.1Q Local Switching—Bridged Interworking

FR DLCI to Ethernet Port AToM—Bridged Interworking

FR DLCI to Ethernet VLAN 802.1Q AToM—Bridged Interworking

Frame Relay to Ethernet—Routed Interworking

Configuration Tasks and Examples

Local Switching

AToM

ATM to Frame Relay—Routed Interworking

Configuration Tasks and Examples

Local Switching

AToM

Verifying L2VPN Interworking


Configuring L2VPN Interworking


Interworking is a transforming function that is required to interconnect two heterogeneous attachment circuits (ACs). Several types of interworking functions exist. The function that is used would depend on the type of ACs being used, the type of data being carried, and the level of functionality required. The two main L2VPN interworking functions supported in Cisco IOS Software are bridged and routed interworking.

Layer 2 transport over MPLS and IP already exists for like-to-like attachment circuits, such as Ethernet-to-Ethernet or PPP-to-PPP. L2VPN Interworking builds on this functionality by allowing disparate attachment circuits to be connected. An interworking function facilitates the translation between different Layer 2 encapsulations. In earlier releases, the Cisco 10000 series router supported only bridged interworking, which is also known as Ethernet interworking.

This chapter describes the following L2VPN interworking features:

Bridged Interworking

Routed Interworking

Bridged Interworking

Bridged interworking is used when Layer 2 (L2) packets are considered without regard for Layer 3 contents. No routing participation by the Internet Service Provider (ISP) exists. In Cisco IOS Release 12.2(33)SB, the Ethernet (port) over MPLS pseudowire is supported for bridged interworking. Therefore, this type of interworking function is also called Ethernet Interworking.

In bridged interworking, Ethernet frames that are extracted from the attachment circuit (AC) are sent over the MPLS pseudowire. In the case of 802.1 Q AC, the VLAN tag is removed. The pseudowire functions in the Ethernet (VC type 0x0005) like-to-like mode. The interworking function at the Native Service Processor (NSP) performs the required adaptation based on AC technology. Non-Ethernet frames are dropped.

The following bridged interworking features are explained in the chapter:

Ethernet to VLAN—Bridged Interworking

Ethernet/VLAN to ATM AAL5 Interworking

Ethernet/VLAN to Frame Relay Interworking

Verifying L2VPN Interworking

Ethernet to VLAN—Bridged Interworking

In Ethernet Interworking, also called bridged interworking, Ethernet frames are bridged across the pseudowire. The customer edge (CE) routers can bridge Ethernet, or can route using a bridged encapsulation model, such as Bridge Virtual Interface (BVI) or Routed Bridged Encapsulation (RBE). The provider edge (PE) routers operate in the Ethernet like-to-like mode.

The Ethernet to VLAN (Bridged) feature is described in the following topics:

Configuring L2VPN Interworking

Verifying the Configuration

Configuration Examples of Ethernet to VLAN—Bridged

Configuring L2VPN Interworking

To enable L2VPN Interworking, you must add the interworking command to the list of commands that comprise of the pseudowire. The interworking command cause ACs to be terminated locally.

SUMMARY STEPS

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation mpls

5. interworking ethernet

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode. if prompted, enter your password.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

pseudowire-class name

Example:

Router(config)# pseudowire-class class1

Establishes a pseudowire class with a name that you specify. Enters pseudowire class configuration mode.

Step 4 

encapsulation mpls

Example:

Router(config-pw)# encapsulation mpls

Specifies the tunneling encapsulation.

Step 5 

interworking {ethernet|ip}

Example:

Router(config-pw)# interworking ethernet

Specifies the type of pseudowire and the type of traffic that can flow across it.

Verifying the Configuration

You can verify the AToM configuration by using the show mpls l2transport vc detail command. In the following example, the interworking type appears in bold.

PE1
PE2

Router# show mpls l2transport vc detail

Local interface: Fa1/1/0 up, line protocol up, Ethernet up

Destination address: 10.9.9.9, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 17, next hop 10.1.1.3

Output interface: Fa4/0/0, imposed label stack {17 20}

Create time: 01:43:50, last status change time: 01:43:33

Signaling protocol: LDP, peer 10.9.9.9:0 up

MPLS VC labels: local 16, remote 20

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 15, send 4184

byte totals: receive 1830, send 309248

packet drops: receive 0, send 0

Router# show mpls l2transport vc detail

Local interface: Fa2/0.3 up, line protocol up, Eth VLAN 10 up

MPLS VC type is Ethernet, interworking type is Ethernet

Destination address: 10.8.8.8, VC ID: 123, VC status: up

Preferred path: not configured

Default path: active

Tunnel label: 16, next hop 10.1.1.3

Output interface: Fa6/0, imposed label stack {16 16}

Create time: 00:00:26, last status change time: 00:00:06

Signaling protocol: LDP, peer 10.8.8.8:0 up

MPLS VC labels: local 20, remote 16

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 5, send 0

byte totals: receive 340, send 0

packet drops: receive 0, send 0


Configuration Examples of Ethernet to VLAN—Bridged

This section contains examples of Ethernet to VLAN for both local switching (LS) and AToM:

Ethernet to VLAN over LS—Bridged: Example

Ethernet to VLAN over AToM—Bridged: Example

Ethernet to VLAN over LS—Bridged: Example

PE
config t
interface atm 2/0/0
	pvc 0/200 l2transport
	encapsulation aal5snap
interface gigabitethernet 5/1/0
	no ip address
connect ETH-VLAN gigabitethernet 5/0/0 gigabitethernet 5/1/0.3 
interworking ethernet
 
        

Ethernet to VLAN over AToM—Bridged: Example

PE1
PE2

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom

 encapsulation mpls

!

interface Loopback0

 ip address 10.9.9.9 255.255.255.255

!

interface FastEthernet0/0

 no ip address

!

interface FastEthernet1/0

xconnect 10.9.9.9 123 pw-class atom

ip cef

!

mpls label protocol ldp

mpls ldp router-id Loopback0 force

!

pseudowire-class atom-eth-iw

encapsulation mpls

interworking ethernet

!

interface Loopback0

ip address 10.8.8.8 255.255.255.255

!

interface FastEthernet1/0.1

encapsulation dot1q 100

xconnect 10.9.9.9 123 pw-class atom-eth-iw


Routed Interworking

Routed interworking is used to carry Layer 3 packets. Each protocol type has a different routed interworking function. The most common routed interworking function is support for Internet Protocol (IP). Therefore, this type of interworking function is also called IP Interworking, and a new type of pseudowire, IP over MPLS, is used.

In routed interworking, IP packets that are extracted from the attachment circuits are sent over the pseudowire. The pseudowire works in the IP Layer 2 transport (VC type 0x000B) like-to-like mode. The interworking function at NSP performs the required adaptation based on the attachment circuit technology. Non-IPv4 packets are dropped.

In routed interworking, the following considerations are to be kept in mind:

Address resolution packets (ARP), inverse ARP, and IPCP are punted to routing protocol. Therefore, NSP at the PE router must provide the following functionality for address resolution:

Ethernet—PE device acts as a proxy-ARP server to all ARP requests from the CE router. The PE router responds with MAC address of its local interface.

ATM and FR point-to-point—By default, inverse ARP does not run in the point-to-point FR or ATM subinterfaces. The IP Address and subnet mask define the connected prefix therefore, configuration is not required in the CE devices.

Interworking using pseudowire at L2 requires that the MTUs in both attachment circuits match, for the pseudowire to come up. The default MTU in one AC requires to be changed, so that it matches with other AC. Table 21-1 lists the range of MTUs that can be configured on the Cisco 10000 series router for different ACs.

Table 21-1 Range Of MTUs For Different ACs

AC type
Range of MTUs supported

ATM

64-17940

Gig

1500-4470

POS

64-9102

FE

64-9192

Frame Relay

64-7673


The CEs with Ethernet attachment VCs running OSPF must be configured with the ospfIfType option so that the OSPF protocol treats the underlying physical broadcast link as a P2P link.

Restrictions for Routed Interworking

Routed interworking has the following restrictions:

Maximum numbers of AC supported are 16K.

Fragmentation is not supported.

Multipoint FR and ATM interface ACs are not supported.

Both bridged and routed interworking do not support QinQ interworking.

QoS classification on IP tos, dscp and other IP header fields is not supported.

Security ACL, LI and other features based on IP header fields parsing is not supported.

The following routed interworking features are explained in the chapter:

Ethernet/VLAN to ATM AAL5 Interworking

Ethernet/VLAN to Frame Relay Interworking

ATM to Frame Relay—Routed Interworking

Verifying L2VPN Interworking

Ethernet/VLAN to ATM AAL5 Interworking

The Ethernet/VLAN to ATM AAL5 Interworking feature is described in the following topics:

Prerequisites of Ethernet/VLAN to ATM AAL5 Interworking

Restrictions of Ethernet/VLAN to ATM AAL5 Interworking

ATM AAL5 to Ethernet Local Switching—Bridged Interworking

ATM AAL5 to VLAN 802.1Q Local Switching—Bridged Interworking

ATM AAL5 to Ethernet Port AToM—Bridged Interworking

ATM AAL5 to Ethernet VLAN 802.1Q AToM—Bridged Interworking

ATM to Ethernet—Routed Interworking

Configuration Tasks and Examples

Prerequisites of Ethernet/VLAN to ATM AAL5 Interworking

Before you configure Ethernet/VLAN to ATM AAL5 Interworking on a network, you must enable Cisco Express Forwarding.

Restrictions of Ethernet/VLAN to ATM AAL5 Interworking

In Cisco IOS Release 12.2(33)SB, the Ethernet/VLAN to ATM AAL5 local switching has the following restrictions:

The following translations are only supported and other translations are dropped:

Ethernet without LAN FCS (AAAA030080C200070000)

Spanning tree (AAAA030080C2000E)

ATM encapsulation type supported for bridged interworking is aal5snap. However, ATM encapsulation types supported for routed interworking are aal5snap and mux.

The existing QoS functionality for ATM is supported, including setting the ATM CLP bit.

Only ATM AAL5 virtual circuit (VC) mode is supported. ATM VP and port mode are not supported.

The non-AAL5 traffic is punted, for example, OAM cells. The end-to-end F5 loopback cells are looped back onto the PE router.

If the Ethernet frame arriving from Ethernet CE includes a 802.1Q header (VLAN header), due to the type of endpoint attachment (Ethernet port mode), the VLAN header stays in the frame and it is forwarded to the ATM CE, as shown in Figure 21-1.

Figure 21-1 Protocol Stack for ATM AAL5 to Ethernet Local Switching Bridged Interworking—With VLAN Header

In Cisco IOS Release 12.2(33)SB, the Ethernet/VLAN to ATM AAL5 AToM has the following restrictions:

The following translations are only supported and other translations are dropped:

Ethernet without LAN FCS (AAAA030080C200070000)

Spanning tree (AAAA030080C2000E)

ATM encapsulation type supported for bridged interworking is aal5snap. However, ATM encapsulation types supported for routed interworking are aal5snap and mux.

The existing QoS functionality for ATM is supported, including setting the ATM CLP bit.

Only ATM AAL5 VC mode is supported. ATM VP and port mode are not supported.

SVCs are not supported.

Individual AAL5 ATM cells are assembled into frames before being sent across the pseudowire.

Non-AAL5 traffic, (such as OAM cells) is punted to be processed at RP level. A VC that has been configured with OAM cell emulation on the ATM PE router (using the oam-ac emulation-enable CLI command) can send end-to-end F5 loopback cells at configured intervals toward the CE router.

When the pseudowire is down, an F5 end-to-end segment AIS/RDI (Alarm indication signal/Remote defect indication) is sent from the PE router to the CE router.

If the Ethernet frame arriving from Ethernet CE includes a 802.1Q header (VLAN header), due to the type of endpoint attachment (Ethernet port mode), the VLAN header stays in the frame across the pseudowire (Figure 21-2).

Figure 21-2 Protocol Stack for ATM to Ethernet AToM Bridged Interworking—With VLAN Header

ATM AAL5 to Ethernet Local Switching—Bridged Interworking

This interworking type provides interoperability between Ethernet attachment VC and ATM attachment VC connected to the same PE router. For this interworking type, Bridged encapsulation is used, corresponding to the Bridged Interworking mechanism.

In Ethernet to ATM direction, the PE router forwards the Layer 2 packet without any change to the egress interface, encapsulating the Layer 2 packet over AAL5 using Bridged encapsulation.

In ATM to Ethernet direction, the ATM header and bridged encapsulation get discarded and the Layer 2 packet is sent out with Ethernet encapsulation.

Figure 21-3 shows the protocol stack for ATM to Ethernet local switching -bridged interworking. The ATM side has an encapsulation type as aal5snap.

Figure 21-3 Protocol Stack for ATM AAL5 to Ethernet Local Switching Bridged Interworking

ATM AAL5 to VLAN 802.1Q Local Switching—Bridged Interworking

This interworking type provides interoperability between ATM attachment VC and Ethernet VLAN attachment VC connected to the same PE router. As in the ATM to Ethernet case, Bridged encapsulation is used, corresponding to Bridged (Ethernet) Interworking mechanism.

In case of Ethernet VLAN attachment, the VLAN ID is a service delimiter, so the VLAN header is not included in the frame to and from the ATM CE.

In the VLAN to ATM direction, the PE router discards the VLAN header from the Layer 2 packet. The PE router sends the frame to the ATM egress interface after encapsulating the L2 packet over AAL5 using Bridged encapsulation.

In the ATM to VLAN direction, the ATM header and bridged encapsulation are discarded and the L2 packet is sent out with a VLAN header inserted following the destination/source MAC addresses.

The protocol stack for ATM to VLAN local switching is shown in Figure 21-3. The ATM side has an encapsulation type of aal5snap.

ATM AAL5 to Ethernet Port AToM—Bridged Interworking

This interworking type provides interoperability between ATM attachment VC and Ethernet attachment VC connected to different PE routers. Bridged encapsulation is used, corresponding to the Bridged (Ethernet) Interworking mechanism.

The interworking function is performed at the PE connected to the ATM attachment VC based on Multiprotocol Encapsulation over ATM Adaptation Layer 5 (Figure 21-4).

Figure 21-4 Network Topology for ATM to Ethernet AToM Bridged Interworking

The advantage of this architecture is that the Ethernet PE (connected to the Ethernet segment) operates similarly to Ethernet like-to-like services.

On the PE with Interworking function, in the direction from the ATM segment to MPLS cloud, the bridged encapsulation (ATM/SNAP header) is discarded and the Ethernet frame is encapsulated with the labels required to go through the pseudowire using the VC type 5 (Ethernet) (Figure 21-5).

In the opposite direction, after the label disposition from the MPLS cloud, Ethernet frames are encapsulated over AAL5 using bridged encapsulation.

Figure 21-5 shows the protocol stack for ATM to Ethernet AToM Bridged Interworking. The ATM side has an encapsulation type of aal5snap.

Figure 21-5 Protocol Stack for ATM to Ethernet AToM Bridged Interworking—Without VLAN Header

ATM AAL5 to Ethernet VLAN 802.1Q AToM—Bridged Interworking

This interworking type provides interoperability between ATM attachment VC and Ethernet VLAN attachment VC connected to different PE routers. Bridged encapsulation is used, corresponding to the Bridged (Ethernet) Interworking mechanism.

The interworking function is performed in the same way as for the ATM to Ethernet Port case, implemented on the PE connected to the ATM attachment VC. The implementation is based on Multiprotocol Encapsulation over ATM Adaptation Layer 5 (see Figure 21-4).

For the PE connected to the Ethernet side, one major difference exists due the existence of the VLAN header in the incoming packet. The PE discards the VLAN header of the incoming frames from the VLAN CE, and the PE inserts a VLAN header into the Ethernet frames traveling from the MPLS cloud. The frames sent on the pseudowire (with VC type 5) are Ethernet frames without the VLAN header.

Encapsulation over ATM Adaptation Layer 5, as shown in Figure 21-6.

Figure 21-6 Protocol Stack for ATM to VLAN AToM Bridged Interworking

ATM to Ethernet—Routed Interworking

To perform routed interworking, both the ATM PE and Ethernet PE routers must be configured. Figure 21-7 shows the routed interworking between ATM to Ethernet. The IP encapsulation over the pseudowire is performed on the ATM packets arriving from the ATM CE router.

The address resolution is done at the ATM PE router; it is required when the ATM CE router does an inverse ARP. It is not required when the ATM CE router is configured using P2P subinterfaces or static maps.

When packets arrive from the Ethernet CE router, the Ethernet PE router removes the L2 frame tag, and then forwards the IP packet to the egress PE router, using IPoMPLS encapsulation over the pseudowire. The Ethernet PE router makes the forwarding decision based on the L2 circuit ID, the VLAN ID, or port ID, of the incoming L2 frame. At the ATM PE router, after label disposition, the IP packets are encapsulated over the AAL5 using routed encapsulation based on RFC 2684.

The address resolution at the Ethernet PE router can be done when the Ethernet CE router configures the static ARP, or by the proxy ARP on the Ethernet PE. If the proxy ARP is used, the IP address of the remote CE can be learned dynamically. Routing protocols need to be configured to operate in the P2P mode on the Ethernet CE.

Figure 21-7 Protocol Stack for ATM to Ethernet—Routed Interworking

Configuration Tasks and Examples

This section describes configuration tasks for and provides examples of two L2VPN technology solutions:

Local Switching

AToM

Local Switching

Figure 21-8 shows different LS configurations.

Figure 21-8 Local Switching Model for CLI Commands

This section explains the following LS configurations and their examples:

ATM AAL5 to Ethernet Port

ATM AAL5 to Ethernet VLAN 802.1Q

ATM AAL5 to Ethernet Port

You can configure the ATM AAL5 to Ethernet Port feature on a PE router using the following steps:

1. config t

2. interface atm slot/subslot/port

3. pvc vpi/vci l2transport

4. encapsulation aal5snap

5. interface [ fastethernet | gigabitethernet ] slot/subslot/port

6. no ip address

7. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port atm slot/subslot/port vpi/vci interworking ethernet|ip


Note The order of the interfaces in the connect command is not important.



Note For configuring routed interworking on the ATM AAL5 to Ethernet Port feature, enter all commands except the no ip address command.


The following example shows how you can configure the ATM AAL5 to Ethernet Port feature on a PE router using routed interworking:

config t
interface atm 2/0/0
 pvc 0/200 l2transport
 encapsulation aal5snap
interface gigabitethernet 5/1/0
connect atm-enet gigabitethernet 5/1/0 atm 2/0/0 0/200 interworking ip	

ATM AAL5 to Ethernet VLAN 802.1Q

You can configure the ATM AAL5 to Ethernet VLAN 802.1Q feature on a PE router using the following steps:

1. config t

2. interface atm slot/subslot/port

3. pvc vpi/vci l2transport

4. encapsulation aal5snap

5. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

6. encapsulation dot1q VLAN-ID

7. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface atm slot/subslot/port vpi/vci interworking ethernet|ip


Note The order of the interfaces in the connect command is not important.


The following example shows how to configure the ATM AAL5 to Ethernet VLAN 802.1Q feature on a PE router using bridged interworking:

config t
interface atm 2/0/0
	pvc 0/200 l2transport
	encapsulation aal5snap
interface gigabitethernet 5/1/0.3
	encapsulation dot1q 2
connect atm-vlan gigabitethernet 5/1/0.3 atm 2/0/0 0/200 interworking ethernet

AToM

Figure 21-9 illustrates different AToM configurations.

Figure 21-9 AToM Model for CLI Commands

This section explains the following AToM configurations and their examples:

ATM AAL5 to Ethernet Port

Configuring ATM AAL5 to Ethernet VLAN 802.1Q

ATM AAL5 to Ethernet Port

You can configure the ATM AAL5 to Ethernet Port feature on a PE1 router using the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet|ip

8. interface atm slot/subslot/port

9. pvc vpi/vci l2transport

10. encapsulation aal5snap

11. xconnect remote-ip-address vc-id pw-class name

You can configure the ATM AAL5 to Ethernet Port feature on a PE2 router using the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ip

8. interface [ fastethernet | gigabitethernet ] slot/subslot/port

9. xconnect remote-ip-address vc-id pw-class name


Note When configuring bridged interworking, the PE2 configuration does not include the interworking ethernet command because it is treated as like-to-like, and also because the attachment circuit is already an Ethernet port. However, when configuring routed interworking, the interworking ip command is required.


The following example shows how to configure the ATM AAL5 to Ethernet Port feature on a PE1 router, using routed interworking:

config t
mpls label protocol ldp
interface Loopback100
 ip address 10.0.0.100 255.255.255.255
pseudowire-class atm-eth
 encapsulation mpls
 interworking ip
interface atm 2/0/0
 pvc 0/200 l2transport
 encapsulation aal5
 xconnect 10.0.0.200 140 pw-class atm-eth
 
   

The following example shows how to configure the ATM AAL5 to Ethernet Port feature on a PE2 router, using routed interworking:

config t
mpls label protocol ldp
interface Loopback200
 ip address 10.0.0.200 255.255.255.255
pseudowire-class atm-eth
 encapsulation mpls
 interworking ip
interface gigabitethernet 5/1/0
 xconnect 10.0.0.100 140 pw-class atm-eth
 
   

Configuring ATM AAL5 to Ethernet VLAN 802.1Q

You can configure the ATM AAL5 to Ethernet VLAN 802.1Q feature on a PE1 router using the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet|ip

8. interface atm slot/subslot/port

9. pvc vpi/vci l2transport

10. encapsulation aal5snap

11. xconnect remote-ip-address vc-id pw-class name

You can configure the ATM AAL5 to Ethernet VLAN 802.1Q feature on a PE2 router using the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet|ip

8. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

9. encapsulation dot1q VLAN-ID

10. xconnect remote-ip-address vci pw-class name


Note In the case of ATM AAl5 to VLAN, the PE2 configuration includes the interworking command for both bridged and routed interworking.


The following example shows how to configure the ATM AAL5 to Ethernet VLAN 802.1Q feature on a PE1 router using bridged interworking:

config t
mpls label protocol ldp
interface Loopback100
 ip address 10.0.0.100 255.255.255.255
pseudowire-class atm-vlan
 encapsulation mpls
 interworking ethernet
interface atm 2/0/0
 pvc 0/200 l2transport
 encapsulation aal5snap
 xconnect 10.0.0.200 140 pw-class atm-vlan
 
   

The following example shows how to configure the ATM AAL5 to Ethernet VLAN 802.1Q feature on a PE2 router using bridged interworking:

config t
mpls label protocol ldp
interface Loopback200
 ip address 10.0.0.200 255.255.255.255
pseudowire-class atm-vlan
 encapsulation mpls
 interworking ethernet
interface gigabitethernet 5/1/0.3
 encapsulation dot1q 1525
 xconnect 10.0.0.100 140 pw-class atm-vlan

Note To verify the L2VPN interworking status and check the statistics, refer to the "Verifying L2VPN Interworking" section.


Ethernet/VLAN to Frame Relay Interworking

The Ethernet VLAN to Frame Relay (FR) Interworking feature is described in the following topics:

Prerequisites of Ethernet/VLAN to Frame Relay Interworking

Restrictions for Ethernet/VLAN to Frame Relay Interworking

FR DLCI to Ethernet Local Switching—Bridged Interworking

FR DLCI to VLAN 802.1Q Local Switching—Bridged Interworking

FR DLCI to Ethernet Port AToM—Bridged Interworking

FR DLCI to Ethernet VLAN 802.1Q AToM—Bridged Interworking

Frame Relay to Ethernet—Routed Interworking

Configuration Tasks and Examples

Prerequisites of Ethernet/VLAN to Frame Relay Interworking

Before you configure Ethernet/VLAN to Frame Relay Interworking on a network, you must enable Cisco Express Forwarding.

Restrictions for Ethernet/VLAN to Frame Relay Interworking

In Cisco IOS Release 12.2(33)SB, the Ethernet/VLAN to Frame Relay LS has the following restrictions:

The following translations are only supported and other translations are dropped:

Ethernet without LAN FCS (0300800080C20007 or 6558)

Spanning tree (0300800080C2000E or 4242)

The PVC status signaling works the same way as in the like-to-like case. The PE router reports the PVC status to the CE router based on the availability of the other CE router.

Only FR DLCI mode is supported. FR port mode is not supported.

If the Ethernet frame includes a 802.1Q header (VLAN header), due to the type of endpoint attachment (Ethernet port mode), the VLAN header stays in the frame and it is forwarded to the FR CE (Figure 21-10).

Figure 21-10 Protocol Stack for FR to Ethernet Local Switching Bridged Interworking—With VLAN Header

In Cisco IOS Release 12.2(33)SB, the Ethernet/VLAN to Frame Relay AToM has the following restrictions:

The following translations are only supported and other translations are dropped:

Ethernet without LAN FCS (0300800080C20007)

Spanning tree (0300800080C2000E)

The PE router automatically supports translation of both Cisco and IETF FR encapsulation types coming from the CE, but translates only to IETF when sending to the CE router. This is not a problem for the Cisco CE router, because it can manage IETF encapsulation upon receipt even if it is configured to send a Cisco encapsulation.

The PVC status signaling works the same way as in the like-to-like case. The PE router reports the PVC status to the CE router based upon the availability of the pseudowire.

The attachment circuit maximum transmission unit (MTU) must match when connected over MPLS.

Only FR DLCI mode is supported. FR port mode is not supported.

If the Ethernet frame includes a 802.1Q header (VLAN header), due to the type of endpoint attachment (Ethernet port mode), the VLAN header stays in the frame across the pseudowire (Figure 21-11).

FR encapsulation types supported for routed interworking are Cisco and IETF for incoming traffic. However, IETF is also supported for outgoing traffic traveling to the CE only.

Figure 21-11 Protocol Stack for FR to Ethernet AToM Bridged Interworking—With VLAN Header

FR DLCI to Ethernet Local Switching—Bridged Interworking

This interworking type provides interoperability between Frame Relay attachment VC and Ethernet attachment VC connected to the same PE router. For this interworking type, Bridged encapsulation is used, corresponding to Bridged (Ethernet) Interworking mechanism.

In the Ethernet to FR direction, the PE router forwards the Layer 2 packet without any change to the egress interface, encapsulating the L2 packet over FR using Bridged encapsulation.

In the FR to Ethernet direction, the FR header and bridged encapsulation are discarded and the L2 packet is sent out with Ethernet encapsulation.

Figure 21-12 shows the protocol stack for FR to Ethernet local switching (bridged interworking).

Figure 21-12 Protocol Stack for FR to Ethernet Local Switching Bridged Interworking

The PE router automatically supports translation of both Cisco and IETF FR encapsulation types traveling from the CE, but translates only to IETF when sending to the CE router. This is not a problem for the Cisco CE router, because it can manage IETF encapsulation on receipt even if it is configured to send a Cisco encapsulation.

FR DLCI to VLAN 802.1Q Local Switching—Bridged Interworking

This interworking type provides interoperability between Frame Relay Attachment VC and Ethernet VLAN Attachment VC connected to the same PE router. For this interworking type the Bridged Encapsulation is used, corresponding to Bridged (Ethernet) Interworking mechanism.

In the case of an Ethernet VLAN attachment, the VLAN ID is a service delimiter, so the VLAN header is not included in the frame to or from the FR CE.

In the VLAN to FR direction, the PE router discards the VLAN header from the Layer 2 packet. The PE router sends the frame to the FR egress interface after encapsulating the L2 packet over FR using Bridged encapsulation.

In the FR to VLAN direction, the FR header and bridged encapsulation are discarded and the L2 packet is sent out with a VLAN header inserted, followed by the destination/source MAC addresses.

The protocol stack for FR to Ethernet local switching (bridged interworking) is shown in Figure 21-12.

FR DLCI to Ethernet Port AToM—Bridged Interworking

This interworking type provides interoperability between FR attachment VC and Ethernet attachment VC connected to different PE routers. Bridged encapsulation is used, corresponding to the Bridged (Ethernet) Interworking mechanism.

For an FR to Ethernet Port case, the interworking function is performed at the PE connected to the FR attachment VC based on multiprotocol interconnect over Frame Relay (Figure 21-13). The Interworking is implemented similar to an ATM-to-Ethernet case.

Figure 21-13 Network Topology for FR to Ethernet AToM Bridged Interworking

The advantage of this architecture is that the Ethernet PE (connected to the Ethernet segment) operates similarly to Ethernet like-to-like services: a pseudowire label is assigned to the Ethernet port and then the remote Label Distribution Protocol (LDP) session distributes the labels to its peer PE. Ethernet frames are carried through the MPLS network using Ethernet over MPLS (EoMPLS).

On the PE with Interworking function, in the direction from the FR segment to MPLS cloud, the bridged encapsulation (FR/SNAP header) is discarded and the Ethernet frame is encapsulated with the labels required to go through the pseudowire using the VC type 5 (Ethernet) (Figure 21-14).

In the opposite direction, after the label disposition from the MPLS cloud, Ethernet frames are encapsulated over FR using bridged encapsulation.

The Figure 21-14 shows the protocol stack for FR to Ethernet Bridged Interworking.

Figure 21-14 Protocol Stack for FR to Ethernet AToM Bridged Interworking—Without VLAN Header

FR DLCI to Ethernet VLAN 802.1Q AToM—Bridged Interworking

This interworking type provides interoperability between FR attachment VC and Ethernet VLAN Attachment VC connected to different PE routers. The bridged encapsulation is used, corresponding to the Bridged (Ethernet) Interworking mechanism.

The interworking function is performed in the same way as for FR to Ethernet port case, implemented on the PE connected to the FR attachment VC, based upon a multiprotocol interconnect over Frame Relay (see Figure 21-14).

As in the ATM to VLAN case, one difference exists on Ethernet side due the existence of the VLAN header in the incoming packet. The PE on the VLAN side discards the VLAN header of the incoming frames from the VLAN CE, and the PE inserts a VLAN header into the Ethernet frames traveling from the MPLS cloud. The frames sent on the pseudowire (with VC type 5) are Ethernet frames without the VLAN header.

The Figure 21-15 shows the protocol stack for FR to VLAN AToM Bridged Interworking.

Figure 21-15 Protocol Stack for FR to VLAN AToM Bridged Interworking

Frame Relay to Ethernet—Routed Interworking

To perform routed interworking, both the FR PE and Ethernet PE routers must be configured. When FR packets arrive from the FR CE router, the FR PE router removes the frame relay header. The FR PE router forwards the IP packet to the egress PE router using IPoMPLS encapsulation over the pseudowire. At the Ethernet PE router, after label disposition, the IP packets are encapsulated with an MAC rewrite.

The address resolution is done at the FR PE router and is required when the FR CE router does an inverse ARP. It is not required when the the FR CE router is configured using P2P subinterfaces or static maps.

For packets arriving from the Ethernet CE router, the Ethernet PE router removes the L2 framing. The Ethernet PE router forwards the IP packet to the egress PE router, using IPoMPLS encapsulation over the pseudowire. The Ethernet PE router makes the forwarding decision based on the L2 circuit ID (VLAN ID or port ID) of the incoming L2 frame. At the FR PE router, after label disposition, the IP packets are encapsulated over FR, using routed encapsulation based on RFC 2427.

The address resolution is also done at the Ethernet PE router by configuring static ARP on the Ethernet CE router, or by implementing proxy ARP on the Ethernet PE router. If a proxy ARP is used, the IP address of the remote CE router can be learned dynamically, or can be statically configured in the PE router. Routing protocols need to be configured to operate in a point-to-point mode on the Ethernet CE router.

Packets that arrive either from the FR CE or the Ethernet CE router with unsupported translations are dropped.

Figure 21-16 shows an example of the protocol stacks at the PEs when IPv4 PDUs are exchanged using routed interworking. Other than IPv4, the Prot_Type field is used while carrying L3 packets.

Figure 21-16 Protocol Stacks for FR to Ethernet Routed Interworking

Configuration Tasks and Examples

This section describes configuration tasks for and examples of two L2VPN technology solutions

Local Switching

AToM

Local Switching

Figure 21-8 shows LS configurations. The following LS configurations and examples are described:

FR DLCI to Ethernet Port

FR DLCI to Ethernet VLAN 802.1Q

FR DLCI to Ethernet Port

You can configure the FR DLCI to Ethernet port feature on a router using the following steps:

1. config t

2. frame-relay switching

3. interface serial slot/subslot/port[:channel | .channel]

4. encapsulation frame-relay

5. frame-relay intf-type dce

6. frame-relay interface-dlci DLCI switched

7. interface [ fastethernet | gigabitethernet ] slot/subslot/port

8. no ip address

9. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port serial slot/subslot/port[:channel | .channel] interworking ethernet|ip


Note The order of the interfaces in the connect command is not important.



Note For configuring routed interworking on the FR DLCI to Ethernet Port feature, enter all commands except the no ip address command.


The following example shows how you can configure the FR DLCI to Ethernet Port feature on a router, using routed interworking:

config t
frame-relay switching
interface serial 2/0/0:1
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay interface-dlci 100 switched
interface gigabitethernet 5/1/0
connect fr-enet gigabitethernet 5/1/0 serial 2/0/0:1 100 interworking ip
 
   

FR DLCI to Ethernet VLAN 802.1Q

You can configure the FR DLCI to Ethernet VLAN 802.1Q feature on a router using the following steps:

1. config t

2. frame-relay switching

3. interface serial slot/subslot/port[:channel | .channel]

4. encapsulation frame-relay

5. frame-relay intf-type dce

6. frame-relay interface-dlci DLCI switched

7. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

8. encapsulation dot1q VLAN-ID

9. connect connection-name [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface serial slot/subslot/port[:channel | .channel] interworking ethernet|ip


Note The order of the interfaces in the connect command is not important.


The following example shows how you can configure the FR DLCI to Ethernet VLAN 802.1Q feature on a router using bridged interworking:

config t
frame-relay switching
interface serial 2/0/0:1
	encapsulation frame-relay
	frame-relay intf-type dce
	frame-relay interface-dlci 100 switched
interface gigabitethernet 5/1/0.3
	encapsulation dot1q 2
connect fr-vlan gigabitethernet 5/1/0.3 serial 2/0/0:1 100 interworking ethernet

AToM

Figure 21-9 illustrates different AToM configurations. This section explains the following AToM configurations and provides examples:

FR DLCI to Ethernet Port

FR DLCI to Ethernet VLAN 802.1Q

FR DLCI to Ethernet Port

You can configure the FR DLCI to Ethernet port feature on a PE1 router using the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback name

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet|ip

8. frame-relay switching

9. interface serial slot/subslot/port[:channel | .channel]

10. encapsulation frame-relay

11. frame-relay interface-dlci DLCI switched

12. connect mpls serial slot/subslot/port[:channel | .channel] DLCI l2transport

13. xconnect remote-ip-address vc-id pw-class name

You can configure the FR DLCI to Ethernet port feature on a PE2 router using the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ip

8. interface [ fastethernet | gigabitethernet ] slot/subslot/port

9. xconnect remote-ip-address vc-id pw-class name


Note When configuring bridged interworking, the PE2 configuration does not include the interworking ethernet command because it is treated as like-to-like, and also because the attachment circuit is already an Ethernet port. However, when configuring routed interworking, the PE2 configuration does include the interworking ip command.


The following example shows how to configure the FR DLCI to Ethernet port feature on a PE1 router, using routed interworking:

config t
mpls label protocol ldp
interface Loopback100
 ip address 10.0.0.100 255.255.255.255
pseudowire-class fr-eth
 encapsulation mpls
 interworking ip
frame-relay switching
interface serial 2/0/0:1
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay interface-dlci 567 switched
connect mpls serial 2/0/0:1 567 l2transport
 xconnect 10.0.0.200 150 pw-class fr-eth
 
   

The following example shows how to configure the FR DLCI to an Ethernet port feature on a PE2 router, using routed interworking:

config t
mpls label protocol ldp
interface Loopback200
 ip address 10.0.0.200 255.255.255.255
pseudowire-class fr-eth
 encapsulation mpls
 interworking ip
interface gigabitethernet 5/1/0
 xconnect 10.0.0.100 150 pw-class fr-eth
 
   

FR DLCI to Ethernet VLAN 802.1Q

To configure the FR DLCI to Ethernet VLAN 802.1Q feature on a PE1 router, use the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet|ip

8. frame-relay switching

9. interface serial slot/subslot/port[:channel | .channel]

10. encapsulation frame-relay

11. frame-relay intf-type dce

12. frame-relay interface-dlci DLCI switched

13. connect mpls serial slot/subslot/port[:channel | .channel] DLCI l2transport

14. xconnect remote-ip-address vc-id pw-class name

To configure the FR DLCI to Ethernet VLAN 802.1Q feature on a PE2 router, use the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ethernet|ip

8. interface [ fastethernet | gigabitethernet ] slot/subslot/port.subinterface

9. encapsulation dot1q VLAN-ID

10. xconnect remote-ip-address vc-id pw-class name


Note In the case of an FR DLCI to VLAN, the PE2 configuration includes the interworking command for both bridged and routed interworking.


The following example shows how to configure the FR DLCI to Ethernet VLAN 802.1Q feature on a PE1 router using bridged interworking:

config t
mpls label protocol ldp
interface Loopback100
 ip address 10.0.0.100 255.255.255.255
pseudowire-class fr-vlan
 encapsulation mpls
 interworking ethernet
frame-relay switching
interface serial 2/0/0:1
 encapsulation frame-relay
 frame-relay intf-type dce
connect mpls serial 2/0/0:1 567 l2transport
 xconnect 10.0.0.200 150 pw-class fr-vlan
 
   

The following example shows how to configure the FR DLCI to Ethernet VLAN 802.1Q feature on a PE2 router using bridged interworking:

config t
mpls label protocol ldp
interface Loopback200
 ip address 10.0.0.200 255.255.255.255
pseudowire-class fr-vlan
 encapsulation mpls
 interworking ethernet
interface gigabitethernet 5/1/0.3
 encapsulation dot1q 1525
 xconnect 10.0.0.100 150 pw-class fr-vlan

Note To verify the L2VPN interworking status and check the statistics, refer to the "Verifying L2VPN Interworking" section.


ATM to Frame RelayRouted Interworking

To perform routed interworking, the ATM and FR PE router must be configured. Routing protocols must also be configured to operate in the P2P mode. ATM packets arriving from the ATM CE router are translated into IP encapsulation over the pseudowire.

When packets arrive from the FR CE router, the FR PE router removes the L2 framing, and forwards the IP packet to the egress PE router, using IPoMPLS encapsulation over the pseudowire. The FR PE router makes the forwarding decision based on the L2 circuit ID (DLCI number) of the incoming L2 frame. The FR CE router can use static map of IP address to DLCI number.

At the ATM PE router, after label disposition, the IP packets are encapsulated over the AAL5, using routed encapsulation.

Address resolution is done at the ATM PE router, if the ATM CE router is doing inverse ARP. It is not required if the ATM CE router is configured using P2P subinterfaces or static maps.

Packets arriving from either ATM CE or FR CE routers with unsupported translations are dropped.

Figure 21-17 demonstrates ATM to FR routed interworking.

Figure 21-17 ATM to Frame Relay Routed Interworking

Configuration Tasks and Examples

This section describes configuration tasks for and examples of two L2VPN technology solutions

Local Switching

AToM

Local Switching

Figure 21-8 shows LS configurations. This section explains LS configuration of the ATM AAL5 to FR DLCI feature and provides examples.

ATM AAL5 to FR DLCI

To configure the ATM AAL5 to FR DLCI feature on a router, use the following steps:

1. config t

2. interface atm slot/subslot/port

3. pvc vpi/vci l2transport

4. encapsulation aal5snap

5. interface serial slot/subslot/port[:channel | .channel]

6. encapsulation frame-relay

7. frame-relay interface-dlci DLCI switched

8. connect connection-name atm slot/subslot/port vpi/vci serial slot/subslot/port[:channel | .channel] interworking ip

The following example shows how to configure the ATM AAL5 to FR DLCI feature on a router:

config t
interface atm 2/0/0
 pvc 0/200 l2transport
 encapsulation aal5snap
frame-relay switching
interface serial 2/0/0:1
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay interface-dlci 100 switched
connect atm-dlci atm 2/0/0 0/200 serial 2/0/0:1 100 interworking ip

AToM

Figure 21-9 illustrates different AToM configurations. This section explains the FR DLCI to ATM AAL5 configurations and provides examples:

FR DLCI to ATM AAL5

To configure the FR DLCI to ATM AAL5 feature on a PE1 router, use the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ip

8. interface atm slot/subslot/port

9. pvc vpi/vci l2transport

10. encapsulation aal5snap

11. xconnect remote-ip-address vc-id pw-class name

To configure the FR DLCI to ATM AAL5 feature on a PE2 router, use the following steps:

1. config t

2. mpls label protocol ldp

3. interface Loopback<name>

4. ip address local-ip-address local-mask

5. pseudowire-class name

6. encapsulation mpls

7. interworking ip

8. frame-relay switching

9. interface serial slot/subslot/port[:channel | .channel]

10. encapsulation frame-relay

11. frame-relay intf-type dce

12. frame-relay interface-dlci DLCI switched

13. connect mpls serial slot/subslot/port[:channel | .channel] DLCI l2transport

14. xconnect remote-ip-address vc-id pw-class name

The following example shows how to configure the FR DLCI to ATM AAL5 feature on a PE1 router:

config t
mpls label protocol ldp
interface Loopback100
 ip address 10.0.0.100 255.255.255.255
pseudowire-class atm-fr
 encapsulation mpls
 interworking ip
interface atm 2/0/0
 pvc 0/200 l2transport
 encapsulation aal5
 xconnect 10.0.0.200 140 pw-class atm-fr

The following example shows how to configure the FR DLCI to ATM AAL5 feature on a PE2 router:

config t
mpls label protocol ldp
interface Loopback100
 ip address 10.0.0.200 255.255.255.255
pseudowire-class atm-fr
 encapsulation mpls
 interworking ip
frame-relay switching
interface serial 2/0/0:1
 encapsulation frame-relay
 frame-relay intf-type dce
 frame-relay interface-dlci 567 switched
connect mpls serial 2/0/0:1 567 l2transport
 xconnect 10.0.0.100 150 pw-class atm-fr

Verifying L2VPN Interworking

To verify the L2VPN status - local switching, use the following commands:

show connection [all | name | id | elements | port ]

show pxf cpu atom [circuits | interface | vcci]

To view the L2VPN statistics - local switching, use the following command:

show pxf cpu statistics atom

To verify the L2VPN status - AToM, use the following commands:

show connection [all | name | id | elements | port ]

show xconnect [ all | interface | peer ]

show mpls l2transport [binding | checkpoint | hw-capability | summary | vc ]

show mpls infrastructure lfd pseudowire vcid

show pxf cpu atom [circuits | interface | vcci]

To verify the L2VPN statistics - AToM, use the following commands:

show pxf cpu statistics atom

show pxf cpu subblocks