Cisco ONS 15454 DWDM Reference Manual, Release 9.1
Appendix C, Pseudo Command Line Reference
Downloads: This chapterpdf (PDF - 633.0KB) The complete bookPDF (PDF - 24.57MB) | Feedback

Pseudo Command Line Interface Reference

Table Of Contents

Pseudo Command Line Interface Reference

C.1  Understanding PCLI

C.1.1  PCLI Security

C.2  PCLI Command Modes

C.2.1  Common Commands

C.2.2  User EXEC Mode

C.2.3  Privileged EXEC Mode

C.2.4  Global Configuration Mode

C.2.5  VLAN Configuration Mode

C.2.6  Interface Configuration Mode

C.2.7  Service Instance Configuration Mode

C.2.8  Policy Map Configuration Mode

C.2.9  VLAN Profile Config Mode

enable shelf/slot

configure terminal

show modules

show vlans

show interfaces

show policy-maps

show policy-map name

show policy-map type port

show controllers type port

show vlan profiles

show vlan profiles name

show ethernet service instance name

show users

reload

show history

show startup-config

show ip igmp snooping groups vlan vlanid

mac-address-table learning vlan vlanid

[no] mac-address-table learning interface type port

[no] vlan vlan-id

interface gigabitethernet port

interface tengigabitethernet port

policy-map name

[no] mvr

mvr vlan

mvr group ip address count

name vlan name

protected

ip igmp snooping

ip igmp snooping immediate-leave

ip igmp snooping report-suppression

description description

shutdown

mtu bytes

speed auto|1000, 10000

flowcontrol on|off

switchport mode trunk

switchport mode dot1q-tunnel

service-policy input name

service-policy output name

service instance ethernet name

l2protocol-tunnel

[no] switchport port-security mac-address mac-address

ip igmp snooping mrouter

encapsulation default

encapsulation dot1q first cvlan last cvlan

encapsulation untagged

bridge-domain svlan

police cir percent % bc bytes be bytes

set cos number

wrr-queue cos-map queue-id cos1 ... cosn

wrr-queue queue-id weight 1-16 bandwidth percent %


Pseudo Command Line Interface Reference


This chapter describes Pseudo-IOS command line interface (PCLI) for GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE cards.


Note Unless otherwise specified, "ONS 15454" refers to both ANSI and ETSI shelf assemblies.


C.1  Understanding PCLI

PCLI provides an IOS-like command line interface for GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE cards in Layer 2 (L2) mode. PCLI employs the Cisco IOS Modular QoS CLI (MQC).

PCLI is a text interface from where you can operate, provision and retrieve GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE card information. PCLI runs on the Timing, Communications, and Control (TCC) of the node controller, to access card level information. PCLI acts as a Corba client and provides the same provisioning mechanisms as CTC or TL1. PCLI can be accessed via CTC by selecting Tools > Open Pseudo IOS Connection menu option or right-click on the node in the Network View and select Open Pseudo IOS Connection. To access the PCLI text interface use Telnet, or SSH to open a shell session to connect to a GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE card and input IOS-like commands.

To access PCLI from Windows XP, enter the following command at the Windows command prompt:

telnet <node name> <port number>
 
   

To access PCLI from Solaris 8, enter the following command:

ssh -p <Port Number> <Node Name>
telnet <Node Name> <Port Number>
 
   

The PCLI shell supports the 454 multi-shelf architecture. Multi-shelf supports 16 shelves with each shelf containing 17 slots. The GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE cards can be inserted in any Input/Output (IO) slot or shelf. PCLI also provides a command to virtually connect to a specified shelf/slot. However, connection to a non-Xponder slot or to an Xponder slot that is not in L2 mode is not supported. PCLI supports a maximum of 16 concurrent login sessions per node controller. A session can be cancelled by logging out of the PCLI session or when the idle timer times out.


Note PCLI adheres to the idle user timeout period security policy set via CTC or TL1.



Note For information on viewing security policies, refer the task, "DLP-G189 Change Security Policy for Multiple Nodes" in the Cisco ONS 15454 DWDM Procedure Guide.


If a PCLI session on a node using a given port number is open, the port number used by the PCLI session cannot be changed. When connecting in a Non-Secure state to a node and a port, use the configured port number for non-secured mode only, and when connecting via a Secure state to a node and a port, use the configured port number for Secure mode.

C.1.1  PCLI Security

PCLI supports configurable secure or unsecure access with a configurable port number per access mechanism. Use CTC to view or modify these settings. The default access state is "Non-secure" and the default port number is "65000".

PCLI supports an unsecured connection via Telnet and a secure connection via Secure Shell (SSH) by using existing system authentication, authorization and accounting (AAA) mechanisms. Login with user/password that is configured at the Network Element (NE). Use CTC or TL1 to manage user accounts.


Note If you have logged in to a PCLI connection in an Non-Secure state and change the connection via CTC to a Secure one (or vice versa), the Non-Secure state in PCLI (or Secure, as the case may be) is closed once the CTC configuration is completed.


For information on setting the access states (Non-secure or Secure), refer Cisco ONS 15454 DWDM Procedure Guide.

C.2  PCLI Command Modes

The PCLI supports eight different command modes. Each command mode can be accessed by specifying a command. The prompt changes to reflect the new command mode that you are in. Consequently, the set of valid commands changes to reflect the sub-commands that are allowed within that mode.

The following section shows supported PCLI commands for each command mode.

C.2.1  Common Commands

The following commands are common across all command modes.

?—Enter a question mark (?) at the system prompt to display a list of commands available in each command mode.

!— Enter an exclamation symbol (!) at the system prompt to add comments.

exit—Enter exit at the system prompt to exit from the mode you are currently in.

C.2.2  User EXEC Mode

Prompt: (>)

After a successful login, the system goes to User Executive (EXEC) command mode. Most PCLI commands in the User EXEC mode do not change system operation. The User EXEC mode allows you to work on multiple GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE cards during a single session while restricting the view at any given time to a single card in a specific shelf and slot. This mode displays system wide parameters that span all cards in the node.

The following commands are supported in the User EXEC mode:

enable shelf/slot

show modules

show users

C.2.3  Privileged EXEC Mode

Prompt: (#)

In general, the Privileged EXEC commands allow you to connect to remote devices, perform basic tests, and lists system information. Most CLI commands in Privileged EXEC mode do not change or modify provisioning and system operation. The most common EXEC commands are show commands and are used to display configuration or operational data, and do not have capability to modify provisioning.

To enter privileged EXEC mode, use the enable shelf/slot command.

The following commands are part of Privileged EXEC mode:

configure terminal

reload

show startup-config

show users

show ip igmp snooping groups vlan vlanid

show interfaces

show ethernet service instance name

show vlan profiles

show vlans

show modules

show controllers type port

show history

show policy-maps

show policy-map name

show policy-map type port

C.2.4  Global Configuration Mode

Prompt: Node Name# (Config)

Enter global configuration mode from privileged EXEC mode. Global configuration commands generally apply to the whole system rather than just one protocol or interface. You can enter other configuration sub modes listed in this section from global configuration mode.

To enter global configuration mode, use the configure terminal command.


Note The node name can be configured by using CTC. Select Node view > General > General > Node Name


The following commands are part of global configuration mode:

mac-address-table learning vlan vlanid

[no] mac-address-table learning interface type port

[no] vlan vlan-id

interface gigabitethernet port

interface tengigabitethernet port

policy-map name

[no] mvr

mvr vlan

mvr group ip address count

C.2.5  VLAN Configuration Mode

Prompt: (config-vlan)

Enter VLAN configuration mode from global configuration mode. You can configure parameters for an individual VLAN.

To enter VLAN configuration mode, use the vlan <vlanid> command.

The following commands are part of VLAN configuration mode:

name vlan name

protected

ip igmp snooping

ip igmp snooping immediate-leave

ip igmp snooping report-suppression

C.2.6  Interface Configuration Mode

Prompt: (config-if)

Enter interface configuration mode from global configuration mode. In this mode and other interface sub modes, a wide variety of capabilities are supported. You can configure provisioning on a specific module interface, i.e. port.

To enter interface configuration mode, use the interface gigabitethernet port or interface tengigabitethernet port command.

The following commands are part of interface configuration mode:

description description

shutdown

mtu bytes

speed auto|1000, 10000

flowcontrol on|off

switchport mode trunk

switchport mode dot1q-tunnel

service-policy input name

service-policy output name

service instance ethernet name

l2protocol-tunnel

[no] switchport port-security mac-address mac-address

ip igmp snooping mrouter

C.2.7  Service Instance Configuration Mode

Prompt: (config-if-srv)

Service instance configuration mode is a sub mode of the interface configuration mode and can be used to define service instances, i.e. Ethernet Flow Points (EFPs). EFPs are specific to a particular interface. Multiple EFPs can be strung together to make an Ethernet Virtual Circuit (EVC).

The encapsulation commands can be used in any combination to implement flexible EFPs. However, the dot1q and untagged commands must be used for selective mode translations, and the default command must be used for transparent mode translations. The following restrictions apply to encapsulation commands:

Selective and transparent mode apply to a whole port and are mutually exclusive.

Encapsulation default is for transparent translations. Only one transparent service instance is allowed per port.

Encapsulation untagged is for selective translation with no cvlan tag. If the operation is DOUBLE_ADD (rewrite ingress tag push dot1q <multipurpose vlan> second-dot1q <svlan>), only one service instance is allowed per port.

To enter service instance configuration mode, use the service instance ethernet name command.

The following commands are part of service instance configuration mode:

encapsulation default

encapsulation dot1q first cvlan last cvlan

encapsulation untagged

service-policy input name

bridge-domain svlan


Note The encapsulation and rewrite commands are work together. These commands take effect only if the following sequence is followed:

1. Enter the encapsulation command.

2. Enter the rewrite command.



Note A service instance cannot be edited once user exits the service instance configuration mode. To make changes to any of these parameters, delete the service instance and recreate it.


C.2.8  Policy Map Configuration Mode

Prompt: (config-pmap)

Enter policy map configuration mode from global configuration mode by using the policy-map command to create a policy map or modify an existing policy map. This mode is part of the quality-of-service (QoS) feature.

To attach a QoS policy to a specific interface, you must enter interface configuration mode from global configuration mode by identifying the interface and then using the service-policy command to attach an existing policy. QoS policy map provisioning can be accessed across multiple GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE cards.

To enter policy map configuration mode, enter the policy-map name command from the global config mode.

The following commands are part of policy map configuration mode:

police cir percent % bc bytes be bytes

set cos number

wrr-queue cos-map queue-id cos1 ... cosn

wrr-queue queue-id weight 1-16 bandwidth percent %

C.2.9  VLAN Profile Config Mode

Prompt: (config-profile)

VLAN profile configuration mode can be used to provision the parameters for a VLAN profile. A VLAN profile can later be applied to multiple VLANs. VLAN profile provisioning can be accessed across multiple GE cards.

To enter VLAN profile configuration mode, use the vlan profile name command from the global config mode.

The following commands are part of VLAN profile configuration mode:

police cir percent % bc bytes be bytes

enable shelf/slot

To enter privileged EXEC mode, use the enable command in user EXEC mode.

enable shelf/slot

Syntax Description

shelf/slot

Shelf and slot number.


Command Modes

User EXEC

Usage Guidelines

Use this command to enter privileged configuration mode. Entering privileged EXEC mode enables the use of privileged commands. Note the prompt for user EXEC mode is the greater than symbol (>), and the prompt for privileged EXEC mode is the hash symbol (#).

Examples

MSTP-176> enable 2/12
MSTP-176#
 
   

configure terminal

To enter global configuration mode, use the configure terminal command in privileged EXEC mode.

configure terminal

Syntax Description

This command has no arguments or keywords.

Command Modes

Privileged EXEC

Usage Guidelines

Use this command to enter global configuration mode.

After you enter the configure terminal command, the system prompt changes from <node-name># to <node-name>(config)#, indicating that the card is now in global configuration mode. To leave global configuration mode and return to privileged EXEC mode, type exit.

Examples

MSTP-176# configure terminal
MSTP-176(config)#
 
   

show modules

To display summary information (shelf/slot/port, equipment type, service state) of the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE card, use the show modules command in User EXEC and privileged EXEC mode.

show modules

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values.

Command Modes

User EXEC and Privileged EXEC

Examples

The following is sample output of the show modules command:

MSTP-176# show modules
Shelf/Slot/Port        EquipType               ServiceState
    1/NA/NA               BIC_UNKNOWN               IS-NR
    1/1 /NA           XP_GE_LINE_CARD               IS-NR
    1/1 /1                 PPM_1_PORT     OOS-AU,AINS&UEQ
    1/1 /2                 PPM_1_PORT     OOS-AU,AINS&UEQ
    1/1 /8                 PPM_1_PORT     OOS-AU,AINS&UEQ
    1/1 /9                 PPM_1_PORT     OOS-AU,AINS&UEQ
    1/1 /11                PPM_1_PORT               IS-NR
    1/1 /15                PPM_1_PORT               IS-NR
    1/1 /16                PPM_1_PORT     OOS-AU,AINS&UEQ
MSTP-176#

show vlans

To display VLAN information, use the show vlans command in privileged EXEC mode.

show vlans

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values

Command Modes

Privileged EXEC

Examples

The following is sample output of the show vlans command which shows the status of 1+1 protection, MAC address learning, IGMP snooping, immediate leave, and report suppression on the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE card for a given VLAN.

MSTP-176# show vlans
									IGMP
VLAN Name 	Prot MAC Learn   Enable Immed Suppress
2 			F    F            F     F     T
50 			F    F            F     F     F
100 			F    F            T     F     T
101 			F    F            F     F     T
MSTP-176#

show interfaces

To display port level parameters and statistics of interfaces configured on the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE, use the show interfaces command in privileged EXEC mode.

show interfaces

Syntax Description

This command has no arguments or keywords.

Defaults

Privileged EXEC

Examples

The following is sample output of the show interfaces command. The output in the example depends on the type and number of interfaces in the card. For this reason only a part of the output is shown.

MSTP-176# show interfaces
Port 22 (Trunk),  Port name: 
Admin State: ADMIN_IS, Service State: IS_NR
Reach: LR, Wavelength: WV_1310, AIS Action: NONE
Flow Control: DISABLED, Duplex Mode: FULL, Speed: SPEED_10G, MTU: 9700
NI Mode: NNI, MAC Learning: DISABLED, IGMP Static Router Port: DISABLED
Ingress CoS: 0, Ethertype Inner/Outer: 8100/8100, Egress QoS: DISABLED
Committed Info Rate: 100, Burst Size Committed/Excess: BCKT_4K/BCKT_4K
ifInOctets: 196928,  rxTotalPkts: 2896, ifInUcastPkts: 0
ifInMulticastPkts: 2896, ifInBroadcastPkts: 0
ifInDiscards: 0, ifOutOctets: 448072424, txTotalPkts: 132911365
ifOutMulticastPkts: 132911359, ifOutBroadcastPkts: 0
ifOutDiscards: 0, ifOutErrors: 0
dot3StatsAlignmentErrors: 0, dot3StatsFCSErrors: 0
dot3StatsFrameTooLong: 0, dot3StatsControlInUnknownOpCodes: 0
dot3StatsInPauseFrames: 0, dot3StatsOutPauseFrames: 0
etherStatsUndersizePkts: 0, etherStatsFragments: 0
etherStatsPkts: 132914261, etherStatsPkts64Octets: 0
65-127 Octets: 132914247, 128-255 Octets: 0
256-511 Octets: 0, 512-1023 Octets: 0
1024-1518 Octets: 0, 1519-1522: 0
etherStatsBroadcastPkts: 0, etherStatsMulticastPkts: 132914255
etherStatsOversizePkts: 0, etherStatsJabbers: 0
etherStatsOctets: 448269352, etherStatsCRCAlignErrors: 0
etherStatsOctets: 448269352, etherStatsCRCAlignErrors: 0
ifHCInOctets: 196928, ifHCInUcastPkts: 0
ifHCInMulticastPkts: 2896, ifHCInBroadcastPkts: 0
ifHCOutOctets: 448072424, ifHCOutMulticastPkts: 132911359
ifHCOutBroadcastPkts: 0, etherStatsHighCapacityPkts: 132914261
etherStatsHighCapacityOctets: 448269352
etherStatsHighCapacityPkts64Octets: 0
etherStatsHighCapacityPkts65to127Octets: 132914247
etherStatsHighCapacityPkts128to255Octets: 0
etherStatsHighCapacityPkts256to511Octets: 0
etherStatsHighCapacityPkts512to1023Octets: 0
etherStatsHighCapacityPkts1024to1518Octets: 0
cisRxReports: 2854, cisRxLeaves: 2
cisTxReports: 0, cisTxLeaves: 2
cisTxGeneralQueries: 2251, cisTxGroupSpecificQueries: 6
cisRxGeneralQueries: 35, RxGroupSpecificQueries 5
cisRxValidPackets: 2896, cisRxInvalidPackets: 0
MSTP-176#

show policy-maps

To display all policy maps in the node, use the show policy-maps command.

Syntax Description

This command has no arguments or keywords.

Defaults

Privileged EXEC

Examples

The following example displays all the policy maps on the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE cards:

MSTP-176# show policy-map
Policy Name: port1
Policy Type: SERVICE INSTANCE
CoS: 2
 
Policy Name: cos3
Policy Type: INGRESS
Ingress CoS: 3   Committed Info Rate: 80   Committed Burst Size: 1
Excess Burst Size: 2 Excess Info Rate: 100
MSTP-176# 

show policy-map name

To display the information of an unnamed class, use the show policy-map command in privileged EXEC mode.

show policy-map name

Syntax Description

name

(Optional) The name of the service policy map whose complete configuration is to be displayed. The name can be a maximum of 31 characters.


Defaults

Existing policy map configurations are displayed.

Command Modes

Privileged EXEC

Examples

The show policy-map command displays the configuration of a service policy map that was created using the policy-map name command.

 
   

The following example displays the contents of policy map "pmapegress" on the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE card:

MSTP-176# show policy-maps pmapegress
Policy Name: pmapegress
Policy Type: EGRESS
CoS: 0     Queue: 0   Bandwidth: 15   Weight: 1
CoS: 1     Queue: 1   Bandwidth: 100   Weight: 1
CoS: 2     Queue: 2   Bandwidth: 100   Weight: 1
CoS: 3     Queue: 3   Bandwidth: 100   Weight: 1
CoS: 4     Queue: 4   Bandwidth: 100   Weight: 1
CoS: 5     Queue: 5   Bandwidth: 100   Weight: 1
CoS: 6     Queue: 6   Bandwidth: 100   Weight: 1
CoS: 7     Queue: 7   Bandwidth: 100   Weight: 1
MSTP-176# 

show policy-map type port

To display all the policy maps configured on the port, use the show policy-map type port in privileged EXEC mode.

show policy-map type port

Syntax Description

type port

Interface type and port number.


Command Default

This command has no default behavior or values.

Command Modes

Privileged EXEC

Usage Guidelines

The show policy-map type port command displays the configuration of classes on the specified interface.

Examples

This section provides sample output of a typical show policy-map type port command. The output in the example depends on the type, number of interfaces and options enabled on the card. For this reason only a part of the output is shown and may vary.

MSTP-176# show policy-map int g 1
Policy Name: ingress
Policy Type: INGRESS
Ingress CoS: 3   Committed Info Rate: 50   Committed Burst Size: 4K
Excess Burst Size: 4K
 
Policy Name: new
Policy Type: EGRESS
CoS: 0     Queue: 0   Bandwidth: 100   Weight: 1
CoS: 1     Queue: 1   Bandwidth: 90   Weight: 2
CoS: 2     Queue: 0   Bandwidth: 100   Weight: 1
CoS: 3     Queue: 3   Bandwidth: 100   Weight: 1
CoS: 4     Queue: 4   Bandwidth: 100   Weight: 1
CoS: 5     Queue: 5   Bandwidth: 100   Weight: 1
CoS: 6     Queue: 6   Bandwidth: 100   Weight: 1
CoS: 7     Queue: 7   Bandwidth: 100   Weight: 1
MSTP-176#

show controllers type port

To display information about Small Form-factor Pluggable (SFP) installed, use the show controllers type port command in privileged EXEC mode.

show controllers type port

Syntax Description

type port

Interface type and port number.


Defaults

No defaults

Command Modes

Privileged EXEC

Examples

This section provides sample output of a typical show controllers type port command.

MSTP-176# show controllers g 2
Port 22 SFP is Present
Equipment Type                   : 1GE/1FC/2FC-1310nm
HW Part Number                   : 10-2273-01
HW Revision                      : A
Serial Number                    : FNS1032J435
CLEI Code                        : WMOTB17AAA
Product ID                       : ONS-SE-G2F-LX
Version ID                       : V01
 
   

MSTP-176#

show vlan profiles

To display the parameters of all configured VLANs or one VLAN (if the VLAN ID or name is specified), use the show vlan profiles command in privileged EXEC mode.


Note A vlan profile is a named set of vlan attributes. A profile can be associated to a VLAN ID on an interface. A profile can be attached to multiple vlan/interface pairs.


show vlan profiles

Command Modes

Privileged EXEC

Examples

The following example shows the output of the show vlan profiles command:

MSTP-176# show vlan profiles
Name 				CIR BC    PIR BE    LinkIntegrity
a_profile				100 4     100 4           F
d_profile				200 4     100 4           T
e_profile				300 4     100 4           F
v_profile				400 4     100 4           T
 
   
MSTP-176#

show vlan profiles name

To display the parameters of all configured VLANs or one VLAN (if the VLAN ID or name is specified), use the show vlan profiles name command in privileged EXEC mode.

Syntax Description

name

Displays information about a single VLAN identified by VLAN name.



Note A vlan profile is a named set of vlan attributes. A profile can be associated to a VLAN ID on an interface. A profile can be attached to multiple vlan/interface pairs.


Command Modes

Privileged EXEC

Examples

The following example shows the output of the show vlan profiles name command:

MSTP-176# show vlan profiles a_profile
Name 				CIR BC    PIR BE    LinkIntegrity
a_profile				100 4     100 4           F
 
   

show ethernet service instance name

To display information about ethernet customer service instances, use the show ethernet service instance name command in privileged EXEC mode.

show ethernet service instance name

Syntax Description

name

Displays service instance information of the specified service instance.


Command Modes

Privileged EXEC

Usage Guidelines

This command is useful for system monitoring and troubleshooting.

Examples

The following is an example of output from the show ethernet service instance command:

MSTP-176# show ethernet service instance 
Identifier Interface               CE-Vlans
222        FastEthernet0/1       untagged,1-4093
10         FastEthernet0/2
222        FastEthernet0/2       200
333        FastEthernet0/2       default
10         FastEthernet0/3       300
11         FastEthernet0/3
10         FastEthernet0/4       300
10         FastEthernet0/6       untagged,1-4093
10         FastEthernet0/7       untagged,1-4093
10         FastEthernet0/8       untagged,1-4093
10         FastEthernet0/9       untagged
20         FastEthernet0/9
222        FastEthernet0/11      300-350,900-999
333        FastEthernet0/11      100-200,1000,1999-4093
222        FastEthernet0/12      20
333        FastEthernet0/12      10
10         FastEthernet0/13      10
20         FastEthernet0/13      20
30         FastEthernet0/13      30
200        FastEthernet0/13      222
200        FastEthernet0/14      200,222
300        FastEthernet0/14      333
555        FastEthernet0/14      555

show users

To display information about the active users on the node, use the show users command in user EXEC or privileged EXEC mode.

show users

Syntax Description

This command has no arguments or keywords.

Command Modes

User EXEC or Privileged EXEC

Usage Guidelines

This command displays user name, security level, aaplications users are using and login time of all users on the node.

Examples

The following is a sample output of the show users command:

MSTP-176# show users
User1, SUPERUSER, PCLI, loginTime:05.13.2000  10:08:29
User2, SUPERUSER, EMS, loginTime:05.13.2000  10:05:27
User3, SUPERUSER, EMS, loginTime:05.13.2000  09:39:35
User4, SUPERUSER, EMS, loginTime:05.13.2000  07:35:18
MSTP-176#

reload

To reset a card, use the reload command in privileged EXEC mode.

reload

Syntax Description

This command has no arguments or keywords.

Command Modes

Privileged EXEC

Usage Guidelines

This command resets the card that is currently used.

Examples

The following is a sample output of the reload command:

MSTP-176> reload
Warning! Resetting this card may impact traffic.
Please confirm (yes/no): n
Command cancelled.
 
   
MSTP-176>

show history

To list the commands you have entered in the current session (in all modes), use the show history command.

show history

Syntax Description

This command has no arguments or keywords.

Command Modes

All modes

Usage Guidelines

The show history command provides a record of commands you have entered. The history buffer records 100 commands.

The show history command can be used with the help of certain keys as shown in Table C-1.

Table C-1 History Keys

Card
Port Description

Ctrl-P or Up Arrow11

Recalls commands in the history buffer in a backward sequence, beginning with the most recent command. Repeat the key sequence to recall successively older commands.

Ctrl-N or Down Arrow1

Returns to more recent commands in the history buffer after recalling commands with Ctrl-P or the Up Arrow. Repeat the key sequence to recall successively more recent commands.

1 The arrow keys function only with ANSI-compatible terminals.


Examples

The following is a sample output from the show history command, which lists the commands the user has entered in privileged EXEC mode for this session:

MSTP-176# show history
help
show users
show history
MSTP-176#
 
   

show startup-config

To display the current configuration of the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE card, use the show startup-config command in privileged EXEC mode. The start-up config and the running-config are the same.

show startup-config

Syntax Description

This command has no arguments or keywords.

Command Modes

Privileged EXEC

Command Default

No defaults

Examples

The following partial sample output displays the configuration file named startup-config:

MSTP-176# show startup-config
 
   
interface tengigabitethernet 22
speed 10000
mtu 9700
flowcontrol off
switchport mode trunk
switchport dot1q ethertype 8100
switchport dot1q ethertype inner 8100
no ip igmp snooping mrouter
switchport port-security mac-address blocked
no l2protocol-tunnel
link integrity action none
service instance ethernet 
no shutdown
 
   
vlan profile a
no link integrity
police cir percent 100 pir percent 100 bc 4 be 4
 
   
no mac-address-table learning interface gigabitethernet 11
no mac-address-table learning interface gigabitethernet 13
no mac-address-table learning interface tengigabitethernet 21
no mac-address-table learning interface tengigabitethernet 22
end
MSTP-176#

show ip igmp snooping groups vlan vlanid

To display the multicast groups that were learned through Internet Group Management Protocol (IGMP) on a given SVLAN/MVLAN, use the show ip igmp groups vlan vlanid in privileged EXEC mode.

show ip igmp groups vlan vlanid

Syntax Description

vlanid

VLAN ID range is 1 to 4093.


Command Modes

Privileged EXEC

Command Default

No defaults.

Examples

The following partial sample output displays the multicast groups for VLAN 10:

MSTP-176# show ip igmp sn gr vlan 128
MCAST IP ADDR                   VLAN    Ports
224.1.1.1                       128     ETHER(99)/SH-1/SL-13/PRT-2
224.1.1.2                       128     ETHER(99)/SH-1/SL-13/PRT-2
224.1.1.3                       128     ETHER(99)/SH-1/SL-13/PRT-2
 
   
MSTP-176#
 
   

mac-address-table learning vlan vlanid

Use the mac-address-table learning vlan global configuration command to enable MAC address learning on a VLAN. Use the no form of this command to disable MAC address learning on a VLAN to control which VLANs can learn MAC addresses.

mac-address-table learning vlan vlanid

no mac-address-table learning vlan <vlanid>

Syntax Description

vlanid

VLAN ID range is 1 to 4093.


Command Modes

Global configuration

Command Default

By default, MAC address learning is disabled on all VLANs.

Usage Guidelines

Customers in a service provider network can tunnel a large number of MAC addresses through the network and fill the available MAC address table space. When you control MAC address learning on a VLAN, you can manage the available MAC address table space by controlling which VLANs, and therefore which ports, can learn MAC addresses.

Examples

An example to enable MAC address learning on VLAN 10 is shown:

MSTP-176# mac-address-table learning vlan 10
MSTP-176#
 
   

[no] mac-address-table learning interface type port

Use the mac-address-table learning interface type port global configuration command to specify interface based learning of MAC addresses.

Syntax Description

type/port

Interface type, and the port number.


Command Modes

Global configuration

Command Default

None

Usage Guidelines

None

Examples

This example shows how to enable MAC-address learning on an interface:

MSTP-176# mac-address-table learning interface gig 1
MSTP-176#
 
   

[no] vlan vlan-id

To add a VLAN and enter config-VLAN submode, use the vlan command. Use the no form of this command to delete the VLAN.

vlan vlan-id

Syntax Description

vlan-id

VLAN ID.


Command Modes

Global configuration

Command Default

None

Usage Guidelines

None

Examples

This example shows how to add a new VLAN and to enter config-VLAN submode:

MSTP-176# (config)# vlan 2
MSTP-176# (config-vlan)#
 
   

interface gigabitethernet port

To enter gigabit ethernet (GigE) interface configuration, use the interface gigabitethernet command in the appropriate configuration mode.

interface gigabitethernet port

Syntax Description

port

Enter port number 1-20.


Command Modes

Global configuration

Command Default

Usage Guidelines

Examples

This example shows how to enter Gigabit Ethernet interface on port 2:

MSTP-176(config)# interface gigabitethernet 2
MSTP-176(config-if)# 
 
   

interface tengigabitethernet port

To enter ten gigabit ethernet (10 GigE) interface configuration, use the interface tengigabitethernet command in the appropriate configuration mode.

interface tengigabitethernet port

Syntax Description

port

Enter port number 21-22.


Command Modes

Global configuration

Command Default

Usage Guidelines

Examples

This example shows how to enter 10GigE interface on port 21:

MSTP-176(config)# interface tengigabitethernet 21
MSTP-176(config-if)# 

policy-map name

To configure the Quality of Service (QoS) policy map, use the policy-map command. Use the no form of this command to delete a policy map.

policy-map name

[no] policy-map name

Syntax Description

name

Policy map name.


Command Modes

Global configuration

Command Default

None

Usage Guidelines

None

Examples

This example shows how to create a QoS policy for ingress traffic on an interface command:

MSTP-176(config)# policy map pmap
MSTP-176(config-pmap)# police cir percent 60 pir percent 80 bc 4 be 16
MSTP-176(config-pmap)# set cos 8
MSTP-176(config-pmap)# service-policy input servpol1
MSTP-176# end

[no] mvr

Use the mvr global configuration command to enable the multicast VLAN registration (MVR) feature on the GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE. Use the [no] mvr form of this command to disable MVR and its options.

mvr group ip-address vlan vlan-id

[no] mvr group ip-address vlan vlan-id

Command Modes

Global Configuration

Command Default

MVR is disabled by default.

Usage Guidelines

A maximum of 256 MVR multicast groups can be configured on the GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE. MVR can be enabled only after the multi-group address and VLAN are configured.

Examples

This example shows how to configure 228.1.23.4 as an IP multicast address:

MSTP-176(config)# mvr group 228.1.23.4
 
   

This example shows how to set VLAN 2 as the multicast VLAN:

MSTP-176(config)# mvr vlan 2 
 
   

This example shows how to enable MVR:

MSTP-176(config)# mvr
 
   

This example shows how to disable MVR:

MSTP-176(config)# no mvr
 
   

mvr vlan

To specify the VLAN (SVLAN) to act as a multicast VLAN, use the mvr vlan command. All ports must belong to this VLAN.

mvr vlan svlan

Syntax Description

svlan

SVLAN ID.


Command Modes

Global Configuration

Command Default

By default MVR is disabled on a SVLAN.

Usage Guidelines

None

Examples

This example shows how to set a VLAN to act as the multicast VLAN:

MSTP-176(config)# mvr vlan 22

mvr group ip address count

To configure an IP multicast address on the GE_XP, 10GE_XP, GE_XPE, or 10GE_XPE card, use the count parameter to configure a contiguous series of MVR group addresses. Any multicast data sent to this address is sent to all source ports on the switch and all receiver ports that have elected to receive data on that multicast address. Each multicast address would correspond to one television channel.

mvr group ip address count

Syntax Description

count

The range for count is 1 to 256.


Command Modes

Global Configuration

Command Default

By default MVR is disabled on a SVLAN.

Examples

This example shows how to configure two contiguous MVR address groups.

MSTP-176(config)# mvr group 228.1.23.4 2
 
   

name vlan name

To configure the VLAN, use the name <vlan name> command.

name vlan name

Syntax Description

name

Specify the name of the VLAN.


Command Modes

VLAN interface configuration

Command Default

By default, no name is assigned to a VLAN.

Usage Guidelines

Names with blank spaces can be provided by enclosing the name within double quotes.

Examples

The following example shows how to set the VLAN name:

MSTP-176(config-vlan)# name MYVLAN
 
   

protected

To enables or disable Fast Automatic Protection Switching (FAPS) on the specified SVLAN, use the protected command.

protected

[no] protected

Syntax Description

This command has no arguments or keywords.

Command Modes

VLAN interface configuration

Command Default

By default, FAPS is disabled on all SVLANs.

Examples

The following example shows how to configure the card for protection:

MSTP-176(config-vlan)# protected
 
   

ip igmp snooping

To enable IGMP snooping, use the ip igmp snooping command. Use the no form of this command to disable IGMP snooping.

ip igmp snooping

no ip igmp snooping

Syntax Description

This command has no arguments or keywords.

Command Default

By default, IGMP snooping is disabled on all SVLANs.

Command Modes

VLAN interface configuration

Usage Guidelines

Before you can enable IGMP snooping configure the VLAN interface for multicast routing.

Examples

This example shows how to enable IGMP snooping:

MSTP-176(config-vlan)# ip igmp snooping
MSTP-176(config-vlan)# 
 
   

ip igmp snooping immediate-leave

To enable IGMPv2 snooping immediate-leave processing on all existing VLAN interfaces, use the ip igmp snooping immediate-leave command. Use the no form of this command to disable immediate-leave processing.

ip igmp snooping immediate-leave

no ip igmp snooping immediate-leave

Syntax Description

This command has no arguments or keywords.

Defaults

By default, IGMP snooping immediate leave is disabled on all SVLANs.

Command Modes

VLAN interface configuration

Usage Guidelines

The immediate-leave feature is supported only with IGMP version 2.

Examples

This example shows how to enable IGMP immediate-leave processing:

MSTP-176(config-vlan)# ip igmp snooping immediate-leave
MSTP-176(config-vlan)# 
 
   

ip igmp snooping report-suppression

To enable report suppression, use the ip igmp snooping report-suppression command. Use the no form of this command to disable report suppression and forward the reports to the multicast devices.

ip igmp snooping report-suppression

no igmp snooping report-suppression

Syntax Description

This command has no arguments or keywords.

Defaults

By default, IGMP snooping report-suppression is disabled on all SVLANs.

Command Modes

VLAN interface configuration

Examples

This example shows how to enable report suppression:

MSTP-176(config-vlan)# ip igmp snooping report-suppression
MSTP-176(config-vlan)# 
 
   

This example shows how to disable report suppression:

MSTP-176(config-vlan)# )# no ip igmp snooping report-suppression
MSTP-176(config-vlan)# 

description description

To specify the port name, use the description command in interface configuration mode.

description

Syntax Description

description

Port name can be a maximum of 32 characters


Command Modes

Interface configuration

Usage Guidelines

To view the ports on an interface, use the show interfaces command in privilege mode.

Examples

This example shows how to specify a port name:

MSTP-176(config-if)# description 5p
 
   

The following partial sample output displays the port name that was set:

MSTP-176# show interface
 
   
Port 2 (Client),  Port name: 5p
Admin State: ADMIN_OOS_DSBLD, Service State: OOS_MA_DSBLD
Reach: REACH_UNKNOWN, Wavelength: WV_UNKNOWN, AIS Action: NONE
Flow Control: DISABLED, Duplex Mode: FULL, Speed: SPEED_AUTO, MTU: 9700
NI Mode: UNI, MAC Learning: DISABLED, IGMP Static Router Port: DISABLED
Ingress CoS: 0, Ethertype Inner/Outer: 8100/8100, Egress QoS: DISABLED
Committed Info Rate: 100, Burst Size Committed/Excess: BCKT_4K/BCKT_4K
Failed to get PM counters for this port
 
   
MSTP-176# 

shutdown

To disable a port use the shutdown command. Use the no shutdown command to enable the port. This command can be executed only by administrators.

shutdown

no shutdown

Syntax Description

This command has no arguments or keywords.

Command Modes

Interface configuration

Examples

This example shows how to shutdown traffic on vlan 2:

MSTP-176(config-if)# shutdown vlan 2
 
   

mtu bytes

To set the maximum frame size that will be accepted by the port, use the mtu command.

To enable jumbo frames on an interface by adjusting the maximum transmission unit (MTU), use the mtu command.

mtu <bytes>

Syntax Description

bytes

Byte size; Valid values are 64-9700.


Defaults

By default, jumbo frames are disabled. The default mtu value is 9700

Command Modes

Interface configuration

Usage Guidelines

Login as an administrator and make sure that the port is down administratively to make this setting.

Examples

This example shows how to specify an MTU of 1800 bytes:

MSTP (config)# interface GigabitEthernet 2
MSTP (config-if)# mtu 1800
 
   
 
   

speed auto|1000, 10000

To enable auto negotiation or to set the speed manually, use the speed command in interface configuration mode.

Syntax Description

auto

Enables Fast Ethernet auto negotiation. The interface automatically operates at 1000 Mbps or 10000 Mbps depending on environmental factors, such as the type of media and transmission speeds for the peer cards, hubs, and switches used in the network configuration. Auto negotiation is the default.


Command Modes

Interface configuration

Usage Guidelines

The speed of client and trunk ports of GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE can be set accordingly:

Table C-2 Setting speed values

Card
Ports
Speed

GE_XP and GE_XPE

Client ports 1 to 20

auto

1000 Mbps

GE_XP and GE_XPE

Trunk ports 21 and 22

10000

10 GE-XP and 10 GE_XPE

Trunk ports 1 to 4

10000


Examples

The following example specifies 1000 Mbps operation:

MSTP-176(config-if)# speed 1000
 
   

flowcontrol on|off

To set a gigabit ethernet interface to send or receive pause frames, use the flowcontrol ON or OFF command.

flowcontrol on|off

Syntax Description

on

Enables a port to receive and process pause frames from remote ports or send pause frames to remote ports.

off

Prevents a port from receiving and processing pause frames from remote ports or from sending pause frames to remote ports.


Defaults

By default, Gigabit Ethernet and 10 Gigabit Ethernet interface ports are set to off.

Command Modes

Interface configuration

Usage Guidelines

Pause frames are special packets that signal a source to stop sending frames for a specific period of time because the buffers are full.

Examples

This example shows how to enable a port to pause frames:

MSTP-176(config-if)# flowcontrol receive on
MSTP-176(config-if)# 
 
   

switchport mode trunk

To set a port as UNI/NNI, use the switchport mode trunk command.

switchport mode trunk

Defaults

By default, all client ports are dot1q-tunnel and all trunk ports are trunk.

Command Modes

Interface configuration

Usage Guidelines

The port has to be administratively down to make these settings

Examples

This example shows how to configure a port for trunk mode:

MSTP(config-if)# switchport mode trunk
 
   

To verify your settings enter the show interfaces privileged EXEC command.

switchport mode dot1q-tunnel

These commands set a port as UNI/NNI, use the switchport mode trunk command.

switchport mode dot1q-tunnel

Syntax Description

This command has no arguments or keywords.

Defaults

By default, all client ports are dot1q-tunnel and all trunk ports are trunk

Command Modes

Interface configuration

Usage Guidelines

Use the switchport mode trunk command to cause the interface to become a trunk.

Examples

This example shows how to configure a port as an IEEE 802.1Q tunnel port:

MSTP-176(config-if)# switchport mode dot1q-tunnel 
 
   

To verify your settings enter the show interfaces privileged EXEC command.

service-policy input name

To set the ingress and egress QoS parameters on the port by mapping relevant policies to the port, use the service-policy input command.

service-policy input name

[no] service-policy input name

Syntax Description

name

Name of a service policy map to be attached.


Defaults

No policy maps are attached.

Command Modes

Interface configuration

Usage Guidelines

The port must be administratively down for configuring.

Examples

This example shows how to attach a policy map to an interface:

MSTP-176(config-if)# service-policy input pmap1
MSTP-176(config-if)#
 
   

service-policy output name

To set the ingress and egress QoS parameters on the port by mapping relevant policies to the port, use the service-policy output name command in interface configuration command.

service-policy output name

[no] service-policy output name

Syntax Description

name

Name of a service policy map to be attached.


Defaults

No policy map is attached.

Command Modes

Interface configuration

Examples

This example shows how to attach a policy map to an output interface:

MSTP-176(config-if)# service-policy output policy9
MSTP-176(config-if)#
 
   
 
   

service instance ethernet name

To create a service instance on an interface, use the service instance ethernet name command.

service instance ethernet name

Syntax Description

name

Name of a service instance. Maximum characters are 32


Command Modes

Interface configuration

Examples

This example shows how to create a service instance:

MSTP-176(config-if)# service instance Ethernet servether1
MSTP-176(config-if)#
 
   

l2protocol-tunnel

To enable protocol tunneling on an interface, use the l2protocol-tunnel command.

l2protocol-tunnel

Syntax Description

This command has no arguments or keywords.

Defaults

No Layer 2 protocol packets are tunneled.

Command Modes

Interface configuration

Examples

This example shows how to enable protocol tunneling:

MSTP-176(config-if)# l2protocol-tunnel
MSTP-176(config-if)#

[no] switchport port-security mac-address mac-address

To configure a secure MAC address for an interface, use the switchport port-security mac-address command.

switchport port-security mac-address mac-address

[no] switchport port-security mac-address mac-address

Syntax Description

mac-address

MAC address of the port. The format is 00:00:00:00:00:00


Defaults

MAC address is not secured on the port.

Command Modes

Interface configuration

Examples

This example shows how to configure a MAC address as secure on the interface:

MSTP-176(config-if)# switchport port-security mac-address ff:ee:00:12:30:04
 
   
 
   

ip igmp snooping mrouter

To configure a Layer 2 port as a multicast router port, use the ip igmp snooping mrouter command. Use the no form of this command to remove the configuration.

ip igmp snooping mroute

Command Modes

Interface configuration

Usage Guidelines

Takes effect on SVLANS associated with the port where IGMP is enabled.

Examples

This example shows how to specify the next-hop interface to the multicast router:

MSTP-176(config-if)# ip igmp snooping mrouter interface gigabitethernet 5
MSTP-176(config-if)#
 
   

encapsulation default

To set the encapsulation method used by the interface, use the encapsulation default command in service interface configuration mode.

encapsulation default

Syntax Description

This command has no arguments or keywords.

Command Modes

Service instance configuration

Usage Guidelines

Execute the rew ing tag push dot1 <svlan> command to set the port in transparent mode.

Examples

MSTP-176(config-if-srv)# encapsulation default

encapsulation dot1q first cvlan last cvlan

To enable IEEE 802.1Q encapsulation of traffic on a specified subinterface in a virtual LAN (VLAN), use the encapsulation dot1q first cvlan last cvlan> command in service interface configuration mode or subinterface configuration mode

encapsulation dot1q first cvlan last cvlan>

Syntax Description

<first cvlan> <last cvlan>

Comma must be entered to separate each customer VLAN (CVLAN) ID range from the next range.


This command has no arguments or keywords.

Defaults

By default, IEEE 802.1Q encapsulation is disabled.

Command Modes

Service instance configuration

Usage Guidelines

IEEE 802.1Q encapsulation is configurable on interface GiGe and 10Gige interfaces. IEEE 802.1Q is a standard protocol for interconnecting cards and for defining VLAN topologies.

Examples

MSTP-176(config-if-srv)# encapsulation dot1q 1000 1002

encapsulation untagged

Defines the matching criteria to be used in order to map untagged Ethernet frames ingress on an interface to the appropriate service instance.

encapsulation untagged

Syntax Description

This command has no arguments or keywords.

Command Modes

Service instance configuration

Examples

MSTP-176(config-if-srv)# encapsulation untagged

bridge-domain svlan

To enable RFC 1490 Frame Relay bridging to map a bridged VLAN to the GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE card, use the bridge-domain command in service interface configuration mode.

bridge-domain svlan

Syntax Description

svlan

SVLAN ID to be used in the bridging configuration. The valid range is from 1 to 4093.


Defaults

Bridging is disabled.

Command Modes

Service instance configuration

Examples

The following example shows the GE_XP, 10GE_XP, GE_XPE, and 10GE_XPE being configured for IEEE 802.1Q VLAN bridging using a VLAN ID of 99:

MSTP-176(config-if-srv)# bridge-domain 99
 
   

police cir percent % bc bytes be bytes

To configure traffic policing based on a percentage of bandwidth available on an interface, use the police command in policy-map configuration mode.

police cir percent % bc bytes be bytes

Syntax Description

cir

Committed information rate. Indicates that the cir will be used for policing traffic.

percent

Specifies that percent of bandwidth will be used for calculating the cir.

%

Specifies the bandwidth percentage. Valid range is a number from 1 to 100.

bc

Conform burst (bc) size used by the first token bucket for policing traffic.

be

Peak burst (be) size used by the second token bucket for policing traffic.


Defaults

By default, traffic policing is disabled.

Command Modes

Policy-map configuration and VLAN profile configuration.

Examples

The following example configures traffic policing using a cir and a pir based on a percentage of bandwidth. In this example, a cir of 20 percent and a pir of 40 percent have been specified. Additionally, an optional bc value and be value (300 ms and 400 ms, respectively) have been specified.

MSTP(config-pmap)# police cir percent 20 bc 300 ms be 400 ms
 
   
 
   

set cos number

To set the Layer 2 class of service (CoS) value of an outgoing packet, use the set cos command in policy-map class configuration mode.

set cos number

Syntax Description

number

Specify the CoS value to be applied to the 802.1Q SVLAN tag. Values 0 through 7 specify constant values for the CoS. Values 8 and 9 mean:

8 = TRUST. This value indicates that the CVLAN CoS value must be trusted, i.e. copied into the SVLAN CoS field.

9 = CVLAN. This value indicates that the SVLAN CoS field is set based on the value of the CVLAN ID. This mapping is provided by an EVC service instance. A service instance on an interface can be defined to match frames with one or more CVLANs. That service instance can also have a policy applied that specifies a CoS. The result is a mapping from CVLAN to CoS on an interface.


Defaults

By default, no CoS value is set for the outgoing packet.

Command Modes

Policy-map configuration.

Usage Guidelines

Enter upto 9 CoS values.

Examples

In the following example, the policy map called "cos-set" is created to assign different CoS values for different types of traffic.

MSTP(config)# policy-map cos-set 
MSTP(config-pmap-c)# set cos 1 
 
   

wrr-queue cos-map queue-id cos1 ... cosn

To map CoS values to drop thresholds for a queue, use the wrr-queue cos-map command.

wrr-queue cos-map queue-id cos1 ... cosn

Syntax Description

queue-id

Queue number; the valid value is 1.

cos1 ... cosn

CoS value; valid values are from 0 to 9.


Command Modes

Policy-map configuration.

Examples

This example shows how to map the CoS values 0 and 1 to standard transmit queue 1

MSTP(config-pmap)# wrr-queue cos-map 1 1 0 
MSTP(config-pmap)# 
 
   

wrr-queue queue-id weight 1-16 bandwidth percent %

To allocate bandwidth between standard transmit queue 1 (low priority) and standard transmit queue 2 (high priority), use the wrr-queue bandwidth command.

wrr-queue <queue-id> weight <1-16> bandwidth percent <%>

Syntax Description

weight <1-16)

WRR weights; valid values are 1 to 15


Command Modes

Policy-map configuration.

Examples

This example shows how to allocate a three-to-one bandwidth ratio:

MSTP(config-pmap)# wrr-queue weight 2 bandwidth 3