Cisco Voice Services Provisioning Tool User Guide, Release 2.7(3)
Getting Started with Cisco VSPT
Downloads: This chapterpdf (PDF - 144.0KB) The complete bookPDF (PDF - 946.0KB) | Feedback

Getting Started with Cisco VSPT

Table Of Contents

Getting Started with Cisco VSPT

Starting Cisco VSPT

Using Cisco VSPT

Menus

File Menu

View Menu

Tools Menu

Help Menu

Configuration Editor Views

Defining Users and Permissions

Exiting the Cisco VSPT


Getting Started with Cisco VSPT


Revised: March 17, 2010, OL-8907-06

This chapter provides directions for starting and using the Cisco VSPT. It contains the following sections:

Starting Cisco VSPT

Using Cisco VSPT

Defining Users and Permissions

Exiting the Cisco VSPT

Starting Cisco VSPT

To start the Cisco VSPT, use this procedure.


Note If you encounter any font problems in Cisco VSPT, start the VNC server using -fb /user/openwin/lib/X11/fonts/misc/ as the command arguments.



Step 1 Do one of the following to start Cisco VSPT:

Start Cisco VSPT standalone.

Log in to the Cisco VSPT server or access it from a machine with X window capability.

In a terminal window, change to the default directory:

>cd /opt/CSCOvsp27 


Note Navigate to the appropriate directory if you installed the Cisco VSPT in a different location.


Enter the following command to start the Cisco VSPT:

>./vspt 

Start Cisco VSPT from Cisco Media Gateway Controller Node Manager (CMNM).

Before starting Cisco MNM, log in as root.

Right-click the Cisco PGW 2200 Softswitch host object in the Map Viewer and choose Tools > Voice Service Provisioning Tool (VSPT).


Note If you start the Cisco VSPT from Cisco MNM, the correct Cisco VSPT version is automatically launched to match the selected Cisco PGW 2200 Softswitch. You must have that version of Cisco VSPT installed before you launch it on the Cisco PGW 2200 Softswitch host object from Cisco MNM.


The login screen shown in Figure 3-1 appears.

Figure 3-1 Login Screen

Step 2 Enter your user name and password and click OK.

The default user name is admin, and the password is also admin.


Note Cisco VSPT checks the license and provides the expiry date for that license after you provide the login information.


The Welcome screen is displayed briefly during the login process, and the Main VSPT window appears (see Figure 3-2).

Figure 3-2 Main Cisco VSPT Window


Using Cisco VSPT

This section describes the Cisco VSPT menus and Configuration Editor views and gives instructions for using the tool functions.

Menus

The Cisco VSPT menu bar contains these menus:

File

View

Tools

Help

These menus are described in the following sections.

File Menu

Table 3-1 describes File menu options.

Table 3-1 File Menu Options 

Menu Option
Description

New

Begin a new configuration session.

Open

Open an existing configuration.

Import

Import an existing configuration from a Cisco PGW 2200 Softswitch, or import trunk group, trunk, routing, or dial plan files into the Cisco VSPT.

Export

Export configuration files from the Cisco VSPT to a specified directory.

Save

Save the current configuration using one of the following options:

As Working—Use to save a new configuration, either a configuration imported from the Cisco PGW 2200 Softswitch or a configuration created in Cisco VSPT. Use also to save modifications to an existing configuration, overwriting the last version.

The configuration is saved in the /var/opt/CSCOvsp27/data/mgc/mistral directory.

As Snapshot—Use to save modifications to an existing configuration under a new name in the ARCHIVE directory. The snapshot configuration is saved in /var/opt/CSCOvsp27/data/mgc/mistral/configname/ARCHIVE.

As New Config—Use to save a modified configuration under a new name, leaving the original unchanged.

Exit

Stop any open provisioning sessions and close the Cisco VSPT.


View Menu

Table 3-2 describes View menu options.

Table 3-2 View Menu Options 

Menu Option
Description

MML

Show generated MML for the current configuration.

Trunk Group File

Show generated trunk group file for the current configuration.

Trunk File

Show generated trunk file for the current configuration.


Tools Menu

Table 3-3 describes Tools menu options.

Table 3-3 Tools Menu Options 

Menu Option
Description

Integrity Check

Check your configuration for inconsistencies and missing information.

Deploy

Move the configuration to one or more target hosts.

Remote Shell

Open a Telnet or SSH session.

MGC Viewer

View, activate, remove, and synchronize configurations on the Cisco PGW 2200 Softswitch.

BAMS Config

View and configure a Cisco Billing and Measurements Server (BAMS). See the Cisco Billing and Measurements Server User's Guide for your release of Cisco BAMS for information about its configuration.

State Operation

View and configure the state of Cisco PGW 2200 Softswitch components.

Advanced Number Editor

View and configure screening numbers, ported number table, and the number termination table. See the Cisco MGC Software Release 9 Dial Plan Guide for information about using the Cisco VSPT Advanced Number Editor.

Audit

Audit bearer trunk information that moves between the Cisco PGW 2200 Softswitch and the Cisco BAMS.

Backup and Restore

Create, modify, or delete scheduled backups or restores on the Cisco PGW 2200 Softswitch Host, Catalyst 2900XL, Catalyst 5500, Catalyst 6509, Cisco ITP-L 2600, Cisco BAMS P3, and Cisco HSI server components.

Administrators

Change Password

Change your own password.

User Admin

Add, modify, or delete users.


Help Menu

Table 3-4 describes Help menu options.

Table 3-4 Help Menu Commands

Menu Option
Description

VSPT User Guide

View a local version of the Cisco VSPT User Guide.

About VSPT

View information about the current version of Cisco VSPT, including the software release number.


Configuration Editor Views

You create, view, and modify configurations using the Cisco VSPT Configuration Editor, which has three different views.

To select a view, click one of the radio buttons at the top of the Configuration Editor window:

MGC Config—Cisco PGW 2200 Softswitch Configuration view. Use to add components and provision component properties.

Traffic—Traffic view. Use to create customer-specific files, including trunk groups, trunks, and routing.

Number Analysis—Number Analysis view. Use to provision dial plans.

In each view, the left pane displays selectable components in an Explorer-type tree view.

The right pane displays data entry fields for the selected component.

Click a component to select it. To see all of the subcomponents for the component you select, click the icon next to the component name to expand the component list.

For instructions on using the Cisco VSPT to provision components, component properties, trunk groups, trunks, and routing, see the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.

For instructions on using the Cisco VSPT to provision a dial plan, see the Cisco Media Gateway Controller Software Release 9 Dial Plan Guide.

Defining Users and Permissions

After you install the Cisco VSPT, you define users and their respective permissions using the following procedure:


Step 1 Log in to the server as root.

Step 2 Start Cisco VSPT, either by first starting Cisco MGC Node Manager and then starting Cisco VSPT, or by starting the Cisco VSPT standalone.

Step 3 Click Tools > User Admin.

The User Administration screen in Figure 3-3 appears.

Figure 3-3 Cisco VSPT User Administration

Step 4 To add a user, do the following:

a. Enter a user name and password.

b. From the Permission dropdown list, select the desired permission level, Admin, User, or Viewer.


Note Admin—Can create, modify, and delete users. This type of user has full read and write access to all of the configurations on the Cisco BAMS and the Cisco PGW 2200 Softswitch.
User—Cannot create, modify, or delete users. This type of user has full read and write access to all of the configurations on the Cisco BAMS and the Cisco PGW 2200 Softswitch.
Viewer—Cannot create, modify, or delete users. This type of user has the read-only access to the Cisco PGW 2200 Softswitch configurations saved on the Cisco VSPT but has no access to the Cisco BAMS configurations saved on the Cisco VSPT. A viewer cannot access the configurations on the remote Cisco BAMS or the Cisco PGW 2200 Softswitch.


c. Click Add.

To modify a user, select the user name, change the password or permission level, and click Modify.

To delete a user, select the user name, and click Delete.


Exiting the Cisco VSPT

You can exit the Cisco VSPT by choosing File > Exit or by clicking the X button in the upper right of the main window.