Supplementary Services Features for FXS Ports on Cisco IOS Voice Gateways Configuration Guide, Cisco IOS Release 15.1M&T
Configuring AMWI and VMWI
Downloads: This chapterpdf (PDF - 174.0KB) The complete bookPDF (PDF - 6.06MB) | Feedback

Configuring AMWI and VMWI

Table Of Contents

Configuring AMWI and VMWI

Contents

Prerequisites for Configurable AMWI and VMWI

Information About Configurable AMWI and VMWI

Feature Summary

Configurable AMWI and VMWI

How to Configure AMWI and VMWI

Configuration Examples for Configurable AMWI and VMWI

Example: Configuring AMWI and VMWI

Example: How to Check the Current MWI Configuration

Additional References

Related Documents

Technical Assistance

Feature Information for Configurable AMWI and VMWI


Configuring AMWI and VMWI


First Published: November 19, 2010

This module describes the configurable audible message waiting indication/visible message waiting indication (AMWI/VMWI) feature for Skinny Client Control Protocol (SCCP)-controlled Analog Ports. This feature provides users with the option to enable one message waiting indication (MWI): audible, visible, or both.

This feature is supported for analog endpoints that are connected to Foreign Exchange Station (FXS) ports or a Cisco VG224 Analog Phone Gateway and controlled by a Cisco call-control system, such as a Cisco Unified Communications Manager (Cisco Unified CM) or a Cisco Unified Communications Manager Express (Cisco Unified CME).

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for Configurable AMWI and VMWI" section.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Configurable AMWI and VMWI

Information About Configurable AMWI and VMWI

How to Configure AMWI and VMWI

Configuration Examples for Configurable AMWI and VMWI

Additional References

Feature Information for Configurable AMWI and VMWI

Prerequisites for Configurable AMWI and VMWI

Cisco IOS Gateway

Cisco IOS Release 15.1(3)T or a later version.

The Cisco voice gateway is set up and configured for operation. For information, see the appropriate Cisco configuration documentation.

SCCP and the SCCP telephony control (STC) application are enabled on the Cisco voice gateway. For configuration information, see "Configuring FXS Ports for Basic Calls".

SCCP supplementary features are enabled on the Cisco voice gateway. See "Configuring Supplementary Features".

Information About Configurable AMWI and VMWI

To enable SCCP supplementary features on analog phones connected to FXS ports on a Cisco voice gateway, you should understand the following concepts:

Feature Summary

Configurable AMWI and VMWI

Feature Summary

Table 16 contains information about SCCP-based Configurable AMWI and VMWI on Cisco Voice Gateways.

Table 16 Configurable AMWI and VMWI

Feature
How Phone User Accesses Feature
Configuration on Call-Control System
Configurable AMWI and VMWI

Allows users to configure AMWI only, VMWI only, or both.

When a voicemail is available, the user goes offhook to hear a special AMWI tone or goes onhook to see an MWI light (when the phone is equipped with one).

No configuration tasks required on your Cisco call-control system.


Configurable AMWI and VMWI

MWI is used to remind you that there is a voicemail message waiting. When a voicemail is available, the phone receives AMWI, which plays a special AMWI tone when you go offhook. A VMWI, which turns on an MWI light, is also activated whenthe phone is equipped with one. No configuration tasks are required to enable MWI feature for analog phones because it plays both AMWI and VMWI by default. However, you can configure your phone to have VMWI or AMWI only.

When configuring MWI, you need to make sure that there are no existing voicemail messages. Configuring MWI while the phone still has voicemail messages is not supported by this feature. You need to clear all voicemail messages and make sure VMWI/AMWI is not active before configuring the MWI setting.

The two types of VMWI, the frequency-shift keying message and DC voltage, are both supported by this feature.

How to Configure AMWI and VMWI


Note This document does not contain details about configuring Cisco Unified Communications Manager or Cisco Unified CME. See the documentation for these products for installation and configuration instructions.


To enable any of the MWI options, perform the following steps:

SUMMARY STEPS

1. enable

2. configure terminal

3. stcapp supplementary-services

4. port port-number

5. mwi {audible | visible | both}

6. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

stcapp supplementary-services

Example:
Router(config)# stcapp supplementary-services

Enters supplementary-service configuration mode.

Step 4 

port port-number

Example:
Router(config-stcapp-suppl-serv)#port 2/2

Specifies analog FXS voice port on which STCAPP supplementary-service features are to be supported.

· port-number—Voice port number. Range is 2/0 to 2/23.

Step 5 

mwi {audible | visible | both}

Example:

Router(config-stcapp-suppl-serv-port)#mwi audible


Enables mwi as audible only (AMWI), visible only (VMWI), or both (default configuration).

audible—AMWI is enabled.

visible—VMWI is enabled.

both—Default configuration. Both AMWI and VMWI are enabled.

Note The current configuration is that MWI (AMWI/VMWI) is automatically turned on when the port is configured in SCCP, MWI cannot be turned off in SCCP.

Step 6 

end

Example:
Router(config-stcapp-suppl-serv-port)#end

Exits configuration mode and returns to privileged EXEC mode.

Configuration Examples for Configurable AMWI and VMWI

This section provides the following configuration examples:

Example: Configuring AMWI and VMWI

Example: How to Check the Current MWI Configuration

Example: Configuring AMWI and VMWI

The following example shows how to configure AMWI and VMWI on specific analog FXS voice ports on which STCAPP supplementary-service features are supported:

Router# show running-config
Building configuration...

Current configuration : 5518 bytes
!
! Last configuration change at 17:02:32 PST Sun Feb 28 1993
!
version 15.1
no service pad
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
logging buffered 20000000
!
no aaa new-model
clock timezone PST -7 0
ip source-route
ip cef
no ipv6 cef
!
stcapp ccm-group 20
stcapp
!
!
stcapp supplementary-services
 port 2/1
  fallback-dn 3001
 port 2/2
  fallback-dn 3102
  mwi visible
 port 2/3
  fallback-dn 3203
  mwi audible
!
!
voice-card 0
!
archive
 log config
  hidekeys
!
!         
!
!
!
!
interface FastEthernet0/0
 ip address 1.5.42.80 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.4.197.150 255.255.255.0
 ip access-group 3 in
 duplex auto
 speed auto
!
ip default-gateway 1.5.0.1
!
ip forward-protocol nd
ip http server
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
!
control-plane
!
!
voice-port 2/0
!
voice-port 2/1
 timeouts ringing infinity
 station-id number 3001
 caller-id enable
!
voice-port 2/2
 vmwi dc-voltage
 timeouts ringing infinity
 station-id number 3102
 caller-id enable
!
voice-port 2/3
 timeouts ringing infinity
 station-id number 3203
 caller-id enable
!
voice-port 2/4
!
voice-port 2/5
!
voice-port 2/6
!
voice-port 2/7
!         
voice-port 2/8
!
voice-port 2/9
!
voice-port 2/10
!
voice-port 2/11
!
voice-port 2/12
!
voice-port 2/13
!
voice-port 2/14
!
voice-port 2/15
!
voice-port 2/16
!
voice-port 2/17
!
voice-port 2/18
!
voice-port 2/19
!
voice-port 2/20
!
voice-port 2/21
!
voice-port 2/22
!
voice-port 2/23
!
!
mgcp fax t38 ecm
!         
sccp local FastEthernet0/0
sccp ccm 1.5.42.40 identifier 40 version 6.0 
sccp
!
!
sccp ccm group 20
 associate ccm 40 priority 1
!
dial-peer voice 21 pots
 service stcapp
 port 2/1
!
dial-peer voice 22 pots
 service stcapp
 port 2/2
!
dial-peer voice 23 pots
 service stcapp
 port 2/3
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 login
 transport input all
!
exception data-corruption buffer truncate
end

Router#

Example: How to Check the Current MWI Configuration

Users can use the show command to check the current MWI configuration.

Router# show stcapp device voice-port 2/2
Port Identifier:  2/2
Device Type:      ALG 
Device Id:        1
Device Name:      AN0C863949F6402
Device Security Mode : None
Modem Capability: None
Device State:     IS
Diagnostic:       None
Directory Number: 3102
Dial Peer(s):     12 
Dialtone after remote onhook feature: activated
Busytone after remote onhook feature: not activated
Last Event:       STCAPP_DC_EV_DEVICE_SET_LAMP_PROCESS_DC_VMWI
Line State:       IDLE
Line Mode:        CALL_BASIC
Hook State:       ONHOOK
mwi:              DISABLE
vmwi:             OFF
mwi config:       Visible
Privacy:          Not configured
PLAR:             DISABLE
Callback State:   DISABLED
CWT Repetition Interval: 0 second(s) (no repetition)
Number of CCBs:   0
Global call info:
    Total CCB count      = 0
    Total call leg count = 0

Router#

Additional References

The following sections provide references related to SCCP analog phone support for FXS ports on the Cisco voice gateway.

Related Documents

Related Topic
Document Title

Cisco Unified Communications Manager

Cisco Unified Communications Manager

Cisco Unified Communications Manager Express

Cisco Unified Communications Manager Express

Cisco IOS debugging

Cisco IOS Debug Command Reference

Cisco IOS voice commands

Cisco IOS Voice Command Reference

Cisco IOS voice configuration

Cisco IOS Voice Configuration Library

Cisco voice gateway

Cisco VG200 Series Gateway

Cisco 1800 Series Integrated Services Routers

Cisco 2800 Series Integrated Services Routers

Cisco 3800 Series Integrated Services Routers

Cisco Unified 500 Series

Conferencing and transcoding resources

"Configuring Enhanced Conferencing and Transcoding for Voice Gateway Routers" chapter in the Cisco Unified CallManager and Cisco IOS Interoperability Guide.

Cisco CallManager and IOS Gateway DSP Farm Configuration Example


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature Information for Configurable AMWI and VMWI

Table 17 lists the features in this module and provides links to specific configuration information. Only features that were introduced or modified in Cisco IOS Release 15.1(3)T or a later release appear in the table.

For information on a feature in this technology that is not documented here, see the "Supplementary Services Features Roadmap" section on page 13.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 17 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 17 Feature Information for Configurable AMWI and VMWI

Feature Name
Releases
Feature Information

Configurable AMWI and VMWI

15.1(3)T

Allows users to configure AMWI only, VMWI only, or both.

MWI is used to remind the user that there is a voicemail message waiting. When a voicemail is available, the phone receives an AMWI that plays a special AMWI tone when the user goes offhook or a VMWI that turns on an MWI light (when the phone is equipped with one) when the user goes onhook.

The following sections provide information about this feature:

Information About Configurable AMWI and VMWI

How to Configure AMWI and VMWI

The following commands were introduced or modified: mwi (supplementary-service).