RADIUS Attributes Configuration Guide Cisco IOS Release 15 M and T
RADIUS Attribute 82: Tunnel Assignment ID
Downloads: This chapterpdf (PDF - 136.0KB) | Feedback

RADIUS Attribute 82: Tunnel Assignment ID

Table Of Contents

RADIUS Attribute 82: Tunnel Assignment ID

Finding Feature Information

Contents

Prerequisites for RADIUS Attribute 82: Tunnel Assignment ID

Restrictions for RADIUS Attribute 82: Tunnel Assignment ID

Information About RADIUS Attribute 82: Tunnel Assignment ID

How to Verify if RADIUS Attribute 82 is Being Used by the LAC

Configuration Examples for RADIUS Attribute 82: Tunnel Assignment ID

LAC Configuration: Example

LNS Configuration: Example

RADIUS Configuration: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for RADIUS Attribute 82: Tunnel Assignment ID


RADIUS Attribute 82: Tunnel Assignment ID


First Published: October 15, 2001
Last Updated: September 8, 2009

The RADIUS Attribute 82: Tunnel Assignment ID feature allows the Layer 2 Transport Protocol access concentrator (LAC) to group users from different per-user or domain RADIUS profiles into the same active tunnel. Previously, Cisco IOS software assigned a separate virtual private dialup network (VPDN) tunnel for each per-user or domain RADIUS profile, even if tunnels with identical endpoints already existed.

This feature improves LAC and L2TP network server (LNS) performance by reducing memory usage, because fewer tunnel data structures must be maintained. This feature allows the LAC and LNS to handle a higher volume of users without negatively impacting router performance.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the "Feature Information for RADIUS Attribute 82: Tunnel Assignment ID" section.

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp. An account on Cisco.com is not required.

Contents

Prerequisites for RADIUS Attribute 82: Tunnel Assignment ID

Restrictions for RADIUS Attribute 82: Tunnel Assignment ID

Information About RADIUS Attribute 82: Tunnel Assignment ID

How to Verify if RADIUS Attribute 82 is Being Used by the LAC

Configuration Examples for RADIUS Attribute 82: Tunnel Assignment ID

Additional References

Feature Information for RADIUS Attribute 82: Tunnel Assignment ID

Prerequisites for RADIUS Attribute 82: Tunnel Assignment ID

You must be using a Cisco platform that supports VPDN to use this feature.

Restrictions for RADIUS Attribute 82: Tunnel Assignment ID

This feature is designed only for VPDN dial-in applications. It does not support VPDN dial-out.

Information About RADIUS Attribute 82: Tunnel Assignment ID

The RADIUS Attribute 82: Tunnel Assignment ID feature defines a new avpair, Tunnel-Assignment-ID, which allows the LAC to group users from different RADIUS profiles into the same tunnel if the chosen endpoint, tunnel type, and Tunnel-Assignment-ID are identical.

How to Verify if RADIUS Attribute 82 is Being Used by the LAC

There are no configuration steps for the RADIUS Attribute 82: Tunnel Assignment ID feature. This task verifies the RADIUS attribute 82 used by the LAC during tunnel authorization.

SUMMARY STEPS

1. enable

2. configure terminal

3. debug radius

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

Router# debug radius

Example:

Router# debug radius

Displays information associated with RADIUS. The output of this command shows whether attribute 82 is being sent in access requests.

Configuration Examples for RADIUS Attribute 82: Tunnel Assignment ID

This section provides the following configuration examples:

LAC Configuration: Example

LNS Configuration: Example

RADIUS Configuration: Example

LAC Configuration: Example

The following example configures VPDN on the LAC:

hostname lac
aaa new-model
aaa authentication ppp default group radius
aaa authorization network default group radius

vpdn enable
 vpdn authen-before-forward

interface Serial2/0:23
 no ip address
 encapsulation ppp
 dialer-group 1
 isdn switch-type primary-5ess
 no fair-queue

dialer-list 1 protocol ip permit

radius-server host lac-radiusd auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key rad123

LNS Configuration: Example

The following example configures VPDN on the LNS:

hostname lns
aaa new-model
aaa authentication ppp default group radius
aaa authorization network default group radius

vpdn enable

vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1

interface Loopback0
 ip address 10.1.1.3 255.255.255.0

interface Virtual-Template1
 ip unnumbered Loopback0
 no keepalive
 peer default ip address pool mypool
 ppp authentication chap

ip local pool mypool 10.1.1.10 10.1.1.50

radius-server host lns-radiusd  auth-port 1645 acct-port 1646
radius-server retransmit 3
radius-server key cisco

RADIUS Configuration: Example

The following examples configure the RADIUS server to group sessions in a tunnel:

Per-User Configuration

user@router.com Password = "cisco" Service-Type = Outbound,
       Tunnel-Type = :1:L2TP,
       Tunnel-Server-Endpoint = :1:"10.14.10.54",
       Tunnel-Assignment-Id = :1:"router"

client@router.com Password = "cisco" Service-Type = Outbound,
       Tunnel-Type = :1:L2TP,
       Tunnel-Server-Endpoint = :1:"10.14.10.54",
       Tunnel-Assignment-Id = :1:"router"

Domain Configuration

eng.router.com Password = "cisco" Service-Type = Outbound,
        Tunnel-Type = :1:L2TP,
        Tunnel-Server-Endpoint = :1:"10.14.10.54",
        Tunnel-Assignment-Id = :1:"router"

sales.router.com Password = "cisco" Service-Type = Outbound,
        Tunnel-Type = :1:L2TP,
        Tunnel-Server-Endpoint = :1:"10.14.10.54",
        Tunnel-Assignment-Id = :1:"router"

Additional References

The following sections provide references related to the RADIUS Attribute 82: Tunnel Assignment ID feature.

Related Documents

Related Topic
Document Title

Dial Technologies

Cisco IOS Dial Technologies Configuration Guide, Release 12.4T

Wide Area Networks

Cisco IOS Wide-Area Networking Configuration Guide, Release 12.4T


Standards

Standard
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

http://www.cisco.com/techsupport


Feature Information for RADIUS Attribute 82: Tunnel Assignment ID

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for RADIUS Attribute 82: Tunnel Assignment ID 

Feature Name
Releases
Feature Information

RADIUS Attribute 82: Tunnel Assignment ID

12.2(4)T
12.2(4)T3
12.2(11)T
12.2(27)SB

In 12.2(4)T, this feature was introduced.

In 12.2(4)T3, support for the Cisco 7500 series routers was added.

This feature was integrated into Cisco IOS Release 12.2(11)T and support was added for the Cisco 1760, Cisco AS5300, Cisco AS5350, Cisco AS5400, Cisco AS5800 and Cisco AS5850 platforms.

This feature was integrated into Cisco IOS Release 12.2(27)SB.