Guest

Cisco IOS Software Releases 12.2 SB

Link Aggregation Control Protocol (LACP) (802.3ad) for Gigabit Interfaces

  • Viewing Options

  • PDF (485.2 KB)
  • Feedback
Link Aggregation Control Protocol (LACP) (802.3ad) for Gigabit Interfaces

Table Of Contents

Link Aggregation Control Protocol (LACP) (802.3ad) for Gigabit Interfaces

Contents

Prerequisites for LACP (802.3ad) for Gigabit Interfaces

Restrictions for LACP (802.3ad) for Gigabit Interfaces

Information About LACP (802.3ad) for Gigabit Interfaces

LACP (802.3ad) for Gigabit Interfaces Feature Overview

Features Supported on Gigabit EtherChannel Bundles

LACP (802.3ad) for Gigabit Interfaces Configuration Overview

Understanding LACP (802.3ad) for Gigabit Interfaces Load Balancing

Understanding LACP (802.3ad) for Gigabit Interfaces Configuration

LACP (802.3ad) for Gigabit Interfaces Configuration Guidelines

How to Configure LACP (802.3ad) for Gigabit Interfaces

Configuring LACP (802.3ad) for Gigabit Interfaces

Examples

Configuring the LACP System ID and Port Priority

Examples

Removing a Channel Group from a Port

Examples

Displaying Gigabit EtherChannel Information

Configuration Examples for LACP (802.3ad) for Gigabit Interfaces

Configuring LACP (802.3ad) for Gigabit Interfaces: Example

Displaying Port Channel Interface Information: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

lacp max-bundle

Feature Information for LACP (802.3ad) for Gigabit Interfaces


Link Aggregation Control Protocol (LACP) (802.3ad) for Gigabit Interfaces


First Published: November, 2006
Revised: March, 2007

This document describes how to configure Gigabit Ethernet port channels using LACP. This allows you to bundle multiple Gigabit Ethernet links into a single logical interface on a Cisco 10000 series router.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for LACP (802.3ad) for Gigabit Interfaces" section.

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for LACP (802.3ad) for Gigabit Interfaces

Restrictions for LACP (802.3ad) for Gigabit Interfaces

Information About LACP (802.3ad) for Gigabit Interfaces

How to Configure LACP (802.3ad) for Gigabit Interfaces

Configuration Examples for LACP (802.3ad) for Gigabit Interfaces

Additional References

Command Reference

Feature Information for LACP (802.3ad) for Gigabit Interfaces

Prerequisites for LACP (802.3ad) for Gigabit Interfaces

This feature requires a Performance Routing Engine 2 (PRE2) or PRE3.

Restrictions for LACP (802.3ad) for Gigabit Interfaces

This feature has the following restrictions on the Cisco 10000 series router in IOS Release12.2(31)SB2:

Maximum of 4 bundled ports per Gigabit Ethernet port channel

Maximum of 64 Gigabit Ethernet port channels in a chassis

MPLS traffic engineering is not supported on port channel interfaces

There is no 802.1q and QinQ subinterface support on Gigabit Ethernet port channels

QoS is supported on individual bundled ports and not on Gigabit Ethernet port channels

Information About LACP (802.3ad) for Gigabit Interfaces

These sections describe the LACP (802.3ad) for Gigabit Interfaces feature:

LACP (802.3ad) for Gigabit Interfaces Feature Overview

Features Supported on Gigabit EtherChannel Bundles

LACP (802.3ad) for Gigabit Interfaces Configuration Overview

Understanding LACP (802.3ad) for Gigabit Interfaces Load Balancing

Understanding LACP (802.3ad) for Gigabit Interfaces Configuration

LACP (802.3ad) for Gigabit Interfaces Configuration Guidelines

LACP (802.3ad) for Gigabit Interfaces Feature Overview

The LACP (802.3ad) for Gigabit Interfaces feature bundles individual Gigabit Ethernet links into a single logical link that provides the aggregate bandwidth of up to 4 physical links. A Cisco 10000 series router supports a maximum of 4 Gigabit Ethernet bundled ports per port channel and a maximum of 64 Gigabit Ethernet port channels per chassis.

All LAN ports on a port channel must be the same speed and must all be configured as either Layer 2 or Layer 3 LAN ports. If a segment within a port channel fails, traffic previously carried over the failed link switches to the remaining segments within the port channel. Inbound broadcast and multicast packets on one segment in a port channel are blocked from returning on any other segment of the port channel.


Note The network device to which a Cisco 10000 series router is connected may impose its own limits on the number of bundled ports per port channel.


Features Supported on Gigabit EtherChannel Bundles

Table 1 lists the features that are supported on Gigabit EtherChannel bundles on a PRE2 and PRE3.

Table 1 Gigabit EtherChannel Bundle Features

Cisco IOS Release
Feature
Bundle Interface

12.2(31)SB2

IP switching

Supported

 

IPv4: unicast and multicast

Supported

 

L2TP, GRE, IPinIP, AToM tunnels

Supported

 

All Ethernet routing protocols

Supported

 

Access control lists (ACLs) per bundle

Supported

 

Interface statistics

Supported

 

High availability beyond Route Processor Redundancy Plus (RPR+)

Not Supported

 

IPv6: unicast and multicast

Not Supported

 

Intelligent Service Gateway (ISG) IP sessions

Not Supported

 

MPLS (6PE)

Not Supported

 

Policy Based Routing (PBR)

Not Supported

 

PPPoX (PPPoEoE, PPPoEoQinQ, PPPoVLAN)

Not Supported

 

VLANs

Not Supported

 

Multicast VPN

Not Supported

 

VPN VRF

Not Supported


LACP (802.3ad) for Gigabit Interfaces Configuration Overview

LACP is part of the IEEE specification 802.3ad that allows you to bundle several physical ports to form a single logical channel. When you change the number of active bundled ports on a port channel, traffic patterns will reflect the rebalanced state of the port channel.

Understanding LACP (802.3ad) for Gigabit Interfaces Load Balancing

A Gigabit Ethernet port channel balances the traffic load across the links by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel. Bundled ports equally inherit the logical MAC addresses on the port channel interface.

Understanding LACP (802.3ad) for Gigabit Interfaces Configuration

LACP supports the automatic creation of Gigabit Ethernet port channels by exchanging LACP packets between ports. It learns the capabilities of port groups dynamically and informs the other ports. Once LACP identifies correctly matched Ethernet links, it facilitates grouping the links into a Gigabit Ethernet port channel.

LACP packets are exchanged between ports in these modes:

Active—Places a port into an active negotiating state, in which the port initiates negotiations with remote ports by sending LACP packets.

Passive—Places a port into a passive negotiating state, in which the port responds to LACP packets it receives but does not initiate LACP negotiation. In this mode, the port channel group attaches the interface to the bundle.

Both modes allow LACP to negotiate between ports to determine if they can form a port channel based on criteria such as port speed and trunking state. Table 2 describes the significant LACP parameters.

Table 2 LACP Parameter Descriptions

Parameter
Description

LACP system priority

A LACP system priority is configured on each router running LACP. The system priority can be configured automatically or through the CLI. LACP uses the system priority with the router MAC address to form the system ID and also during negotiation with other systems.

The LACP system ID is the combination of the LACP system priority value and the MAC address of the router.

LACP port priority

A LACP port priority is configured on each port using LACP. The port priority can be configured automatically or through the CLI. LACP uses the port priority with the port number to form the port identifier. The port priority determines which ports should be put in standby mode when there is a hardware limitation that prevents all compatible ports from aggregating.

LACP administrative key

LACP automatically configures an administrative key value equal to the channel group identification number on each port configured to use LACP. The administrative key defines the ability of a port to aggregate with other ports. A port's ability to aggregate with other ports is determined by these factors:

Port physical characteristics, such as data rate, duplex capability, and point-to-point or shared medium

Configuration restrictions that you establish

LACP maximum number of bundled ports

You can restrict the maximum number of bundled ports allowed in the port channel using the lacp max-bundle command in interface configuration mode.


When LACP is configured on ports, it tries to configure the maximum number of compatible ports in a port channel, up to the maximum allowed by the hardware (four ports). If LACP cannot aggregate all the ports that are compatible (for example, the remote system might have more restrictive hardware limitations), then all the ports that cannot be actively included in the channel are put in hot standby state and are used only if one of the channeled ports fails.


Note In prior Cisco IOS releases, the Cisco-proprietary Port Aggregation Control Protocol (PAgP) was used to configure port channels. LACP and PAgP do not interoperate with each other. Ports configured to use PAgP cannot form port channels on ports configured to use LACP. Ports configured to use LACP cannot form port channels on ports configured to use PAgP.


LACP (802.3ad) for Gigabit Interfaces Configuration Guidelines

When port channel interfaces are configured improperly with LACP, they are disabled automatically to avoid network loops and other problems. To avoid configuration problems, observe these guidelines and restrictions:

Every port added to a port channel must be configured identically. No individual differences in configuration are allowed.

Bundled ports can be configured on different line cards in a chassis.

Maximum Transmission Unit (MTU) must be configured only on port channel interfaces and this MTU is propagated to the bundled ports.

Quality of Service (QoS) and Committed Access Rate (CAR) are applied at the port level. Access control lists (ACLs) are applied on port channels.

MAC configuration is only allowed on port channels.

MPLS IP should be enabled on bundled ports using the mpls ip command.

You should apply Unicast Reverse Path Forwarding (uRPF) on the port channel interface using the ip verify unicast reverse-path command in interface configuration mode.

The Cisco Discovery Protocol (CDP) should be enabled on the port channel interface using the cdp enable command in interface configuration mode.

Enable all LAN ports in a port channel. If you shut down a LAN port in a port channel, it is treated as a link failure and its traffic is transferred to one of the remaining ports in the port channel.

To create a port channel interface, use the interface port-channel command in global configuration command.

When a Gigabit Ethernet interface has an IP address assigned, you must disable that IP address before adding the interface to the port channel. To disable an existing IP address, use the no ip address command in interface configuration mode.

The hold queue in command is only valid on port channel interfaces. The hold queue out command is only valid on bundled ports.

How to Configure LACP (802.3ad) for Gigabit Interfaces

This section includes these procedures:

Configuring LACP (802.3ad) for Gigabit Interfaces

Configuring the LACP System ID and Port Priority

Removing a Channel Group from a Port

Displaying Gigabit EtherChannel Information

Configuring LACP (802.3ad) for Gigabit Interfaces

Perform this task to create a port channel with two bundled ports. You can configure a maximum of four bundled ports per port channel.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface port-channel number

4. ip address ip_address mask

5. interface type slot/subslot/port

6. no ip address

7. channel-group number mode {active | passive}

8. exit

9. interface type slot/subslot/port

10. no ip address

11. channel-group number mode {active | passive}

12. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface port-channel number

Example:

Router(config)# interface port-channel 1

Specifies the port channel interface. Enters interface configuration mode.

number—Valid range is from 1 to 64.

Step 4 

ip address ip_address mask

Example:

Router(config-if)# ip address 10.1.1.1 255.255.255.0

Assigns an IP address and subnet mask to the port channel interface.

Step 5 

interface type slot/subslot/port

Example:

Router(config-if)# interface g2/0/0

Specifies the port to bundle.

Step 6 

no ip address

Example:

Router(config-if)# no ip address

Disables the IP address on the port channel interface.

Step 7 

channel-group number mode {active | passive}

Example:

Router(config-if)# channel-group 1 mode active

Assigns the interface to a port channel group and sets the LACP mode.

number—Valid range is 1 to 64.

active—Places a port into an active negotiating state, in which the port initiates negotiations with other ports by sending LACP packets.

passive—Places a port into a passive negotiating state, in which the port responds to LACP packets it receives but does not initiate LACP negotiation. In this mode, the channel-group attaches the interface to the bundle.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 9 

interface type slot/subslot/port

Example:

Router(config)# interface g4/0/0

Specifies the next port to bundle. Enters interface configuration mode.

Step 10 

no ip address

Example:

Router(config-if)# no ip address

Disables the IP address on the port channel interface.

Step 11 

channel-group number mode {active | passive}

Example:

Router(config-if)# channel-group 1 mode active

Assigns the interface to the previously configured port channel group.

number—Valid range is 1 to 64.

active—Places a port into an active negotiating state, in which the port initiates negotiations with other ports by sending LACP packets.

passive—Places a port into a passive negotiating state, in which the port responds to LACP packets it receives but does not initiate LACP negotiation. In this mode, the channel-group attaches the interface to the bundle.

Step 12 

end

Example:

Router(config-if)# end

Exits interface configuration mode.

Examples

Router> enable 
Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config-if)# interface g2/0/0 
Router(config-if)# no ip address
Router(config-if)# channel-group 1 mode active 
Router(config-if)# exit
Router(config)# interface g4/0/0 
Router(config-if)# no ip address
Router(config-if)# channel-group 1 mode active 
Router(config-if)# end 

Configuring the LACP System ID and Port Priority

Perform this task to manually configure the LACP parameters.

SUMMARY STEPS

1. enable

2. configure terminal

3. lacp system-priority value

4. interface type slot/subslot/port

5. lacp port-priority value

6. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

lacp system-priority value

Example:

Router(config)# lacp system-priority 23456

Specifies the priority of the system for LACP. The higher the number, the lower the priority.

value—Valid range is from 1 to 65535. The default is 32768.

Step 4 

interface type slot/subslot/port

Example:

Router(config)# interface g0/1/1

Specifies the bundled port on which to set the LACP port priority. Enters interface configuration mode.

Step 5 

lacp port-priority value

Example:

Router(config-if)# lacp port-priority 500

Specifies the priority for the physical interface.

value—Valid range is from 1 to 65535. The higher the number, the lower the priority.

Step 6 

end

Example:

Router(config-if)# end

Exits interface configuration mode.

Examples

Router> enable 
Router# configure terminal
Router(config)# lacp system-priority 23456
Router(config)# interface g4/0/0
Router(config-if)# lacp port-priority 500
Router(config-if)# end

Removing a Channel Group from a Port

Perform this task to remove a Gigabit Ethernet port channel group from a physical port.

SUMMARY STEPS

1. enable

2. configure terminal

3. no interface port-channel number

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

no interface port-channel number

Example:

Router(config-if)# no interface port-channel 1

Removes the specified port channel group from a physical port.

number—Valid range is from 1 to 16.

Step 4 

end

Example:

Router(config-if)# end

Exits interface configuration mode.

Examples

Router> enable 
Router# configure terminal
Router(config)# no interface port-channel 1
Router(config)# end 

Displaying Gigabit EtherChannel Information

To display Gigabit Ethernet port channel information, use the show interfaces port-channel command in user or privileged EXEC mode. The following example shows information about port channels configured on ports 0/2 and 0/3. The default MTU is set to 1500 bytes.

Router# show interfaces port-channel 1
Port-channel1 is up, line protocol is up  
Hardware is GEChannel, address is 0013.19b3.7748 (bia 0000.0000.0000) 
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,  
reliability 255/255, txload 1/255, rxload 1/255 
Encapsulation ARPA, loopback not set 
Keepalive set (10 sec) 
ARP type: ARPA, ARP Timeout 04:00:00 
No. of active members in this channel: 2  
Member 0 : GigabitEthernet3/0/0 , Full-duplex, 1000Mb/s Member 1 : GigabitEthernet7/1/0 , 
Full-duplex, 1000Mb/s 
Last input 00:00:05, output never, output hang never 
Last clearing of "show interface" counters 00:04:40 
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
Interface Port-channel1 queueing strategy: PXF First-In-First-Out 
Output queue 0/8192, 0 drops; input queue 0/75, 0 drops 
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 0 bits/sec, 0 packets/sec 
0 packets input, 0 bytes, 0 no buffer 
Received 0 broadcasts (0 IP multicasts) 
0 runts, 0 giants, 0 throttles 
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 
0 watchdog, 0 multicast, 0 pause input 
3 packets output, 180 bytes, 0 underruns 
0 output errors, 0 collisions, 0 interface resets 
0 babbles, 0 late collision, 0 deferred 
0 lost carrier, 0 no carrier, 0 PAUSE output 
0 output buffer failures, 0 output buffers swapped out

Table 3 describes the significant fields shown in the display.

Table 3 show interfaces port-channel Field Descriptions 

Field
Description

Port-channel1 is up, line protocol is up

Indicates the bundle interface is currently active and can transmit and receive or it has been taken down by an administrator.

Hardware is

Hardware type (Gigabit EtherChannel).

address is

Address being used by the interface.

MTU

Maximum transmission unit of the interface.

BW

Bandwidth of the interface, in kilobits per second.

DLY

Delay of the interface, in microseconds.

reliability

Reliability of the interface as a fraction of 255 (255/255 is 100 percent reliability), calculated as an exponential average over 5 minutes.

tx load
rxload

Transmit and receive load on the interface as a fraction of 255 (255/255 is completely saturated), calculated as an exponential average over 5 minutes. The calculation uses the value from the bandwidth interface configuration command.

Encapsulation

Encapsulation type assigned to the interface.

loopback

Indicates if loopbacks are set.

keepalive

Indicates if keepalives are set.

ARP type

ARP type on the interface.

ARP Timeout

Number of hours, minutes, and seconds an ARP cache entry stays in the cache.

No. of active members in this channel

Number of bundled ports (members) currently active and part of the port channel group.

Member #: Gigabit Ethernet: #/#

Number of the bundled port and associated Gigabit Ethernet port channel interface.

Last input

Number of hours, minutes, and seconds since the last packet was successfully received by an interface and processed locally on the router. Useful for knowing when a dead interface failed. This counter is updated only when packets are process-switched, not when packets are fast-switched.

output

Number of hours, minutes, and seconds (or never) since the last packet was successfully transmitted by an interface. This counter is updated only when packets are process-switched, not when packets are fast-switched.

output hang

Number of hours, minutes, and seconds (or never) since the interface was last reset because of a transmission that took too long. When the number of hours in any of the "last" fields exceeds 24 hours, the number of days and hours is printed. If that field overflows, asterisks are printed.

last clearing

Time at which the counters that measure cumulative statistics (such as number of bytes transmitted and received) shown in this report were last reset to zero. Variables that might affect routing (for example, load and reliability) are not cleared when the counters are cleared.

*** indicates the elapsed time is too large to be displayed.

0:00:00 indicates the counters were cleared more than 231 ms and less than 232 ms ago.

Input queue

Number of packets in the input queue and the maximum size of the queue.

Queueing strategy

First-in, first-out queueing strategy (other queueing strategies you might see are priority-list, custom-list, and weighted fair).

Output queue

Number of packets in the output queue and the maximum size of the queue.

5 minute input rate
5 minute output rate

Average number of bits and packets received or transmitted per second in the last 5 minutes.

packets input

Total number of error-free packets received by the system.

bytes (input)

Total number of bytes, including data and MAC encapsulation, in the error-free packets received by the system.

no buffer

Number of received packets discarded because there was no buffer space in the main system. Broadcast storms on Ethernets and bursts of noise on serial lines are often responsible for no input buffer events.

broadcasts

Total number of broadcast or multicast packets received by the interface.

runts

Number of packets that are discarded because they are smaller than the minimum packet size of the medium.

giants

Number of packets that are discarded because they exceed the maximum packet size of the medium.

input errors

Total number of no buffer, runts, giants, CRCs, frame, overrun, ignored, and abort counts. Other input-related errors can also increment the count, so that this sum might not balance with the other counts.

CRC

Cyclic redundancy check generated by the originating LAN station or far-end device does not match the checksum calculated from the data received. On a LAN, this usually indicates noise or transmission problems on the LAN interface or the LAN bus itself. A high number of CRCs is usually the result of collisions or a station transmitting bad data. On a serial link, CRCs usually indicate noise, gain hits or other transmission problems on the data link.

frame

Number of packets received incorrectly having a CRC error and a noninteger number of octets. On a serial line, this is usually the result of noise or other transmission problems.

overrun

Number of times the serial receiver hardware was unable to hand received data to a hardware buffer because the input rate exceeded the receiver's ability to handle the data.

ignored

Number of received packets ignored by the interface because the interface hardware ran low on internal buffers. These buffers are different than the system buffers mentioned previously in the buffer description. Broadcast storms and bursts of noise can cause the ignored count to be incremented.

watchdog

Number of times the watchdog receive timer expired.

multicast

Number of multicast packets received.

packets output

Total number of messages transmitted by the system.

bytes (output)

Total number of bytes, including data and MAC encapsulation, transmitted by the system.

underruns

Number of times that the far-end transmitter has been running faster than the near-end router's receiver can handle.

output errors

Sum of all errors that prevented the final transmission of datagrams out of the interface being examined. Note that this might not balance with the sum of the enumerated output errors, as some datagrams can have more than one error, and others can have errors that do not fall into any of the specifically tabulated categories.

collisions

Number of messages retransmitted because of an Ethernet collision. A packet that collides is counted only once in output packets.

interface resets

Number of times an interface has been completely reset. This can happen if packets queued for transmission were not sent within a certain interval. If the system notices that the carrier detect line of an interface is up but the line protocol is down, the system periodically resets the interface in an effort to restart that interface. Interface resets can also occur when an unrecoverable interface processor error occurred, or when an interface is looped back or shut down.

babbles

The transmit jabber timer expired.

late collision

Number of late collisions. Late collision happens when a collision occurs after transmitting the preamble. The most common cause of late collisions is that your Ethernet cable segments are too long for the speed at which you are transmitting.

deferred

Deferred indicates that the chip had to defer while ready to transmit a frame because the carrier was asserted.

lost carrier

Number of times the carrier was lost during transmission.

no carrier

Number of times the carrier was not present during the transmission.

PAUSE output

Not supported.

output buffer failures

Number of times that a packet was not output from the output hold queue because of a shortage of shared memory.

output buffers swapped out

Number of packets stored in main memory when the output queue is full; swapping buffers to main memory prevents packets from being dropped when output is congested. The number is high when traffic is bursty.


Configuration Examples for LACP (802.3ad) for Gigabit Interfaces

This section provides the following configuration examples:

Configuring LACP (802.3ad) for Gigabit Interfaces: Example

Displaying Port Channel Interface Information: Example

Configuring LACP (802.3ad) for Gigabit Interfaces: Example

The following example shows how to configure Gigabit Ethernet ports 2/0 and 4/0 into port channel 1 with LACP parameters.

Router> enable 
Router# configure terminal
Router(config)# lacp system-priority 65535
Router(config)# interface port-channel 1
Router(config-if)# lacp max-bundle 2
Router(config-if)# ip address 10.1.1.1 255.255.255.0
Router(config)# interface g2/0/0
Router(config-if)# no ip address 
Router(config-if)# lacp port-priority 100
Router(config-if)# channel-group 1 mode passive 
Router(config-if)# exit 
Router(config)# interface g4/0/0 
Router(config-if)# no ip address 
Router(config-if)# lacp port-priority 200
Router(config-if)# channel-group 1 mode passive
Router(config-if)# end 

Displaying Port Channel Interface Information: Example

The following example shows how to display the configuration of port channel interface 1.

Router# show interface port-channel 1
Port-channel1 is up, line protocol is up  
Hardware is GEChannel, address is 0013.19b3.7748 (bia 0000.0000.0000) 
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,  
reliability 255/255, txload 1/255, rxload 1/255 
Encapsulation ARPA, loopback not set 
Keepalive set (10 sec) 
ARP type: ARPA, ARP Timeout 04:00:00 
No. of active members in this channel: 2  
Member 0 : GigabitEthernet3/0/0 , Full-duplex, 1000Mb/s Member 1 : GigabitEthernet7/1/0 , 
Full-duplex, 1000Mb/s 
Last input 00:00:05, output never, output hang never 
Last clearing of "show interface" counters 00:04:40 
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
Interface Port-channel1 queueing strategy: PXF First-In-First-Out 
Output queue 0/8192, 0 drops; input queue 0/75, 0 drops 
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 0 bits/sec, 0 packets/sec 
0 packets input, 0 bytes, 0 no buffer 
Received 0 broadcasts (0 IP multicasts) 
0 runts, 0 giants, 0 throttles 
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 
0 watchdog, 0 multicast, 0 pause input 
3 packets output, 180 bytes, 0 underruns 
0 output errors, 0 collisions, 0 interface resets 
0 babbles, 0 late collision, 0 deferred 
0 lost carrier, 0 no carrier, 0 PAUSE output 
0 output buffer failures, 0 output buffers swapped out

Additional References

The following sections provide references related to the LACP (802.3ad) for Gigabit Interfaces feature.

Related Documents

Related Topic
Document Title

Configuring Cisco 10000 series router line cards

Cisco 10000 Series Router Line Card Configuration Guide

Provisioning QoS

Cisco 10000 Series Router Quality of Service Configuration Guide


Standards

Standard
Title

IEEE 802.3ad

Link Aggregation


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Technical Support & Documentation website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

http://www.cisco.com/techsupport


Command Reference

This section documents modified commands only.

Modified Commands in Cisco IOS Release 12.2(31)SB2

lacp max-bundle

lacp max-bundle

To define the maximum number of bundled Link Aggregation Control Protocol (LACP) ports allowed in a port channel, use the lacp max-bundle command in interface configuration mode. To return to the default settings, use the no form of this command.

lacp max-bundle max-bundles

no lacp max-bundle

Syntax Description

max-bundles

Maximum number of bundled ports allowed in the port channel. Valid values are from 1 to 8.

Note On the Cisco 10000 series router, the valid values are from 1 to 4.


Defaults

The default settings are as follows:

Maximum of eight bundled ports per port channel.

Maximum of eight bundled ports and eight hot-standby ports per port channel; this setting applies if the port channel on both sides of the LACP bundle are configured the same.

Cisco 10000 Series Router

Maximum of four bundled ports per port channel.

Command Modes

Interface configuration

Command History

Release
Modification

12.2(18)SXD

Support for this command was introduced on the Supervisor Engine 720.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(31)SB2

This command was introduced on the Cisco 10000 series router and integrated into Cisco IOS Release 12.2(31)SB2.


Usage Guidelines

Cisco 10000 Series Router

Maximum of four bundled ports per port channel.

This command requires a Performance Routing Engine 2 (PRE2) or PRE3.

Examples

This example shows how to set the maximum number of ports to bundle in a port channel:

Router(config-if)# lacp max-bundle 4
Router(config-if)# 

Related Commands

Command
Description

lacp port-priority

Specifies the priority of the physical interface for LACP.

lacp system-priority

Specifies the priority of the system for LACP.

show lacp

Displays LACP information.


Feature Information for LACP (802.3ad) for Gigabit Interfaces

Table 4 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.


Note Table 4 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 4 Feature Information for LACP (802.3ad) for Gigabit Interfaces

Feature Name
Releases
Feature Information

LACP (802.3ad) for Gigabit Interfaces

12.2(31)SB2

This feature was introduced and implemented on the Cisco 10000 series router for the PRE2 and PRE3.