Guest

Cisco IOS Software Releases 12.2 SB

BGP Support for Dual AS Configuration for Network AS Migrations

  • Viewing Options

  • PDF (268.9 KB)
  • Feedback
BGP Support for Dual AS Configuration for Network AS Migrations

Table Of Contents

BGP Support for Dual AS Configuration for Network AS Migrations

Contents

Prerequisites for BGP Support for Dual AS Configuration for Network AS Migrations

Restrictions for BGP Support for Dual AS Configuration for Network AS Migrations

Information About BGP Support for Dual AS Configuration for Network AS Migrations

How to Configure Autonomous System Migration

Configuring Dual-AS Peering for Network Migration

Confederations, Individual Peering Sessions and Peer Groupings are Supported

Ingress Filtering can be Applied to Minimize the Possibility of Routing Loop Creation

Restrictions

Verifying Autonomous System Number Configuration

Configuration Examples for Autonomous-System Migration

Dual-AS Configuration: Example

Dual-AS Confederation Configuration: Example

Replace-AS Configuration: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Command Reference

neighbor local-as


BGP Support for Dual AS Configuration for Network AS Migrations


The BGP Support for Dual AS Configuration for Network AS Migrations feature extends the functionality of the BGP Local-AS feature by providing additional autonomous-system path customization configuration options. The configuration of this feature is transparent to customer peering sessions, allowing the provider to merge two autonomous-systems without interrupting customer peering arrangements. Customer peering sessions can later be updated during a maintenance window or during other scheduled downtime.

Release
Modification

12.0(27)S

This feature was introduced.

12.2(25)S

This feature was integrated into Cisco IOS Release 12.2(25)S.

12.3(11)T

This feature was integrated into Cisco IOS Release 12.3(11)T.

12.2(27)SBC

This feature was integrated into Cisco IOS Release 12.2(27)SBC.


Feature History for BGP Support for Dual AS Configuration for Network AS Migrations

Finding Support Information for Platforms and Cisco IOS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS software image support. Access Cisco Feature Navigator at http://www.cisco.com/go/fn. You must have an account on Cisco.com. If you do not have an account or have forgotten your username or password, click Cancel at the login dialog box and follow the instructions that appear.

Contents

Prerequisites for BGP Support for Dual AS Configuration for Network AS Migrations

Restrictions for BGP Support for Dual AS Configuration for Network AS Migrations

Information About BGP Support for Dual AS Configuration for Network AS Migrations

How to Configure Autonomous System Migration

Configuration Examples for Autonomous-System Migration

Additional References

Command Reference

Prerequisites for BGP Support for Dual AS Configuration for Network AS Migrations

This document assumes that BGP is configured and eBGP peering sessions have been established.

Restrictions for BGP Support for Dual AS Configuration for Network AS Migrations

BGP prepends the autonomous system number from each BGP network that a route traverses to maintain network reachability information and to prevent routing loops. This feature should be configured only for autonomous-system migration, and should be deconfigured after the transition has been completed. This procedure should be attempted only by an experienced network operator, as routing loops can be created with improper configuration.

This feature can be configured for only true eBGP peering sessions. This feature cannot be configured for two peers in different subautonomous systems of a confederation.

This feature can be configured for individual peering sessions and configurations applied through peer-groups and peer templates. If this command is applied to a group of peers, the peers cannot be individually customized.

Information About BGP Support for Dual AS Configuration for Network AS Migrations

Autonomous-system migration can be necessary when a telecommunications or Internet service provider purchases another network. It is desirable for the provider to be able integrate the second autonomous system without disrupting existing customer peering arrangements. The amount of configuration required in the customer networks can make this a cumbersome task that is difficult to complete without disrupting service.

The BGP Support for Dual AS Configuration for Network AS Migrations feature allows you to merge a secondary autonomous system under a primary autonomous system, without disrupting customer peering sessions. The configuration of this feature is transparent to customer networks. This feature allows a router to appear, to external peers, as a member of secondary autonomous system during the autonomous-system migration. This feature allows the network operator to merge the autonomous systems and then later migrate customers to new configurations during normal service windows without disrupting existing peering arrangements.

How to Configure Autonomous System Migration

This section contains the following procedures:

Configuring Dual-AS Peering for Network Migration

Verifying Autonomous System Number Configuration

Configuring Dual-AS Peering for Network Migration

The neighbor local-as command is used to customize the AS_PATH attribute by adding and removing autonomous system numbers for routes received from eBGP neighbors. This feature allows a router to appear to external peers as a member of another autonomous system for the purpose of autonomous system number migration. This feature simplifies this process of changing the autonomous-system number in a BGP network by allowing the network operator to merge a secondary autonomous system into a primary autonomous system and then later update the customer configurations during normal service windows without disrupting existing peering arrangements.

Confederations, Individual Peering Sessions and Peer Groupings are Supported

This feature supports confederations, individual peering sessions and configurations applied through peer-groups and peer templates. If this feature is applied to a group peers, the individual peers cannot be customized.

Ingress Filtering can be Applied to Minimize the Possibility of Routing Loop Creation

Autonomous-system path customization increases the possibility that routing loops can be created if misconfigured. The larger the number of customer peerings, the greater the risk. You can minimize this possibility by applying policies on the ingress interfaces to block the autonomous-system number that is in transition or routes that have no local-as configuration.


Caution BGP prepends the autonomous system number from each BGP network that a route traverses to maintain network reachability information and to prevent routing loops. This feature should be configured only for autonomous-system migration, and should be deconfigured after the transition has been completed. This procedure should be attempted only by an experienced network operator, as routing loops can be created with improper configuration.

Restrictions

This feature can be configured for only true eBGP peering sessions. This feature cannot be configured for two peers in different subautonomous systems of a confederation.

This feature can be configured for individual peering sessions and configurations applied through peer-groups and peer templates. If this command is applied to a group of peers, the peers cannot be individually customized.

SUMMARY STEPS

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor ip-address remote-as as-number

5. neighbor ip-address local-as [as-number [no-prepend [replace-as [dual-as]]]

6. neighbor ip-address remove-private-as

7. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router bgp as-number

Example:

Router(config)# router bgp 100

Enters router configuration mode, and creates a BGP routing process.

Step 4 

neighbor ip-address remote-as as-number

Example:

Router(config-router)# neighbor 10.0.0.1 remote-as 200

Establishes a peering session with a BGP neighbor.

Step 5 

neighbor ip-address local-as [as-number [no-prepend [replace-as [dual-as]]]]

Example:

Router(config-router)# neighbor 10.0.0.1 local-as 300 no-prepend replace-as dual-as

Customizes the AS_PATH attribute for routes received from an eBGP neighbor.

The replace-as keyword is used to prepend only the local autonomous-system number (as configured with the ip-address argument) to the AS_PATH attribute. The autonomous-system number from the local BGP routing process is not prepended.

The dual-as keyword is used to configure the eBGP neighbor to establish a peering session using the real autonomous-system number (from the local BGP routing process) or by using the autonomous-system number configured with the ip-address argument (local-as).

The example configures the peering session with the 10.0.0.1 neighbor to accept the real autonomous system number and the local-as number.

Step 6 

neighbor ip-address remove-private-as

Example:

Router(config-router)# neighbor 10.0.0.1 remove-private-as

(Optional) Removes private autonomous-system numbers from outbound routing updates.

This command can be used with the replace-as functionality to remove the private autonomous-system number and replace it with an external autonomous system number.

Private autonomous-system numbers (64512 to 65535) are automatically removed from the AS_PATH attribute when this command is configured.

Step 7 

end

Example:

Router(config-router)# end

Exits router configuration mode, and enters privileged EXEC mode.

Verifying Autonomous System Number Configuration

The show ip bgp and show ip bgp neighbors EXEC commands can be used to verify autonomous system number for entries in the routing table and the status of this feature.

SUMMARY STEPS

1. enable

2. show ip bgp [network] [network-mask] [longer-prefixes] [prefix-list prefix-list-name | route-map route-map-name] [shorter prefixes mask-length]

3. show ip bgp neighbors [neighbor-address] [received-routes | routes | advertised-routes | paths regexp | dampened-routes | received prefix-filter]]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

show ip bgp [network] [network-mask] [longer-prefixes] [prefix-list prefix-list-name | route-map route-map-name] [shorter prefixes mask-length]

Example:

Router# show ip bgp

Displays entries in the BGP routing table.

The output can be used to verify if the real autonomous system number or local-as number is configured.

Step 3 

show ip bgp neighbors [neighbor-address] [received-routes | routes | advertised-routes | paths regexp | dampened-routes | received prefix-filter]]

Example:

Router(config)# show ip bgp neighbors

Displays information about TCP and BGP connections to neighbors.

The output will display local AS, no-prepend, replace-as, and dual-as with the corresponding autonomous system number when these options are configured.

Configuration Examples for Autonomous-System Migration

The following examples show how to configure and verify this feature:

Dual-AS Configuration: Example

Dual-AS Confederation Configuration: Example

Replace-AS Configuration: Example

Dual-AS Configuration: Example

The following examples shows how this feature is used to merge two autonomous systems without interrupting peering arrangements with the customer network. The neighbor local-as command is configured to allow Router1 to maintain peering sessions through autonomous-system 100 and autonomous-system 200. Router2 is a customer router that runs a BGP routing process in autonomous system 300 and is configured to peer with autonomous-system 200:

Autonomous System 100 (provider network):

Router1(config)# interface Serial3/0 
Router1(config-int)# ip address 10.3.3.11 255.255.255.0 
Router1(config-int)# ! 
Router1(config)# router bgp 100 
Router1(config-router)# no synchronization 
Router1(config-router)# bgp router-id 100.0.0.11 
Router1(config-router)# neighbor 10.3.3.33 remote-as 300 
Router1(config-router)# neighbor 10.3.3.33 local-as 200 no-prepend replace-as dual-as 

Autonomous System 200 (provider network):

Router1(config)# interface Serial3/0 
Router1(config-int)# ip address 10.3.3.11 255.255.255.0 
Router1(config-int)# ! 
Router1(config)# router bgp 200 
Router1(config-router)# bgp router-id 100.0.0.11 
Router1(config-router)# neighbor 10.3.3.33 remote-as 300 

Autonomous System 300 (customer network):

Router2(config)# interface Serial3/0 
Router2(config-int)# ip address 10.3.3.33 255.255.255.0 
Router2(config-int)# ! 
Router2(config)# router bgp 300 
Router2(config-router)# bgp router-id 100.0.0.3 
Router2(config-router)# neighbor 10.3.3.11 remote-as 200 

After the transition is complete, the configuration on router 3 can be updated to peer with autonomous-system 100 during a normal maintenance window or during other scheduled downtime.

Router2(config-router)# neighbor 10.3.3.11 remote-as 100 

Dual-AS Confederation Configuration: Example

The following example can be used in place of the Router 1 configuration in the previous example. The only difference between these configurations is that Router 1 is configured to be part of a confederation.

Router1(config)# interface Serial3/0 
Router1(config-int)# ip address 10.3.3.11 255.255.255.0 
Router1(config-int)# ! 
Router1(config)# router bgp 65534 
Router1(config-router)# no synchronization 
Router1(config-router)# bgp confederation identifier 100 
Router1(config-router)# bgp router-id 100.0.0.11 
Router1(config-router)# neighbor 10.3.3.33 remote-as 300 
Router1(config-router)# neighbor 10.3.3.33 local-as 200 no-prepend replace-as dual-as 

Replace-AS Configuration: Example

The following example strips private autonomous-system 64512 from outbound routing updates for the 10.3.3.33 neighbor and replaces it with autonomous-system 300:

Router(config)# router bgp 64512 
Router(config-router)# neighbor 10.3.3.33 local-as 300 no-prepend replace-as 

Additional References

The following sections provide references related to the BGP Support for Dual AS Configuration for Network AS Migrations feature.

Related Documents

Related Topic
Document Title

BGP commands

Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols, Release 12.3T

BGP configuration tasks

Cisco IOS IP Configuration Guide, Release 12.3T

BGP Hide Local-Autonomous System feature

BGP Hide Local-Autonomous System

BGP Local-AS feature

Configuring the BGP Local-AS Feature, Release 12.3T


Standards

Standards
Title

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


MIBs

MIBs
MIBs Link

No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.


RFCs

RFCs
Title

No new or modified RFCs are supported by this feature, and support for existing standards has not been modified by this feature.


Technical Assistance

Description
Link

Technical Assistance Center (TAC) home page, containing 30,000 pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

TAC Home Page:

http://www.cisco.com/public/support/tac/home.shtml

BGP Support Page:

http://www.cisco.com/cgi-bin/Support/browse/psp_view.pl?p=Internetworking:BGP


Command Reference

This section documents one modified command.

neighbor local-as

neighbor local-as

To customize the AS_PATH attribute for routes received from an external Border Gateway Protocol (eBGP) neighbor, use the neighbor local-as command in address family or router configuration mode. To disable AS_PATH attribute customization, use the no form of this command.

neighbor ip-address local-as as-number [no-prepend [replace-as [dual-as]]]

no neighbor ip-address local-as as-number

Syntax Description

ip-address

Specifies the IP address of the eBGP neighbor.

as-number

Specifies an autonomous-system number to prepend to the AS_PATH attribute. The range of values for this argument is any valid autonomous system number from 1 to 65535.

Note With this argument, you cannot specify the autonomous system number from the local BGP routing process or from the network of the remote peer.

no-prepend

(Optional) Does not prepend the local autonomous system number to any routes received from the eBGP neighbor.

replace-as

(Optional) Prepends only the local autonomous-system number to the AS_PATH attribute. The autonomous system number from the local BGP routing process is not prepended.

dual-as

(Optional) Configures the eBGP neighbor to establish a peering session using the real autonomous system number (from the local BGP routing process) or by using the autonomous-system number configured with the ip-address argument (local-as).


Defaults

The autonomous system number from the local BGP routing process is prepended to all external routes by default, unless the no-prepend and/or replace-as keywords are configured.

Command Modes

Address-family configuration
Router configuration

Command History

Release
Modification

12.0(5)S

This command was introduced.

12.0(5)T

CLI support for address family configuration mode was added.

12.0(18)S
12.2(8)T
12.2(14)S

The no-prepend keyword was added.

12.0(27)S
12.2(25)S
12.3(11)T

The replace-as and dual-as keywords were added.

12.2(27)SBC

This command was integrated into Cisco IOS Release 12.2(27)SBC.


Usage Guidelines

The neighbor local-as command is used to customize the AS_PATH attribute by adding and removing autonomous system numbers for routes received from eBGP neighbors. The configuration of this command allows a router to appear to external peers as a member of another autonomous system for the purpose of autonomous system number migration. This feature simplifies the process of changing the autonomous system number in a BGP network by allowing the network operator to migrate customers to new configurations during normal service windows without disrupting existing peering arrangements.


Caution BGP prepends the autonomous system number from each BGP network that a route traverses to maintain network reachability information and to prevent routing loops. This command should be configured only for autonomous system migration, and should be deconfigured after the transition has been completed. This procedure should be attempted only by an experienced network operator. Routing loops can be created through improper configuration.

This command can be used for only true eBGP peering sessions. This command does not work for two peers in different subautonomous systems of a confederation.

This command supports individual peering sessions and configurations applied through peer groups and peer templates. If this command is applied to a group of peers, the individual peers cannot be customized.

Examples

Local-AS Configuration Example

The following example establishes peering between router 1 and router 2 through autonomous system 300, using the local-as feature:

Router 1 (Local Router)

router bgp 100
 address-family ipv4 unicast 
  neighbor 172.16.1.1 remote-as 200
  neighbor 172.16.1.1 local-as 300

Router 2 (Remote Router)

router bgp 200
 address-family ipv4 unicast 
  neighbor 10.0.0.1 remote-as 300

No Prepend Configuration Example

The following example configures BGP to not prepend autonomous system 500 to routes received from the 192.168.1.1 neighbor:

router bgp 400
address-family ipv4 multicast
 network 192.168.0.0
 neighbor 192.168.1.1 local-as 500 no-prepend 

Replace-AS Configuration Example

The following example strips private autonomous system 64512 from outbound routing updates for the 172.20.1.1 neighbor and replaces it with autonomous system 600:

router bgp 64512 
address-family ipv4 unicast 
 neighbor 172.20.1.1 local-as 600 no-prepend replace-as 
 neighbor 172.20.1.1 remove-private-as 

Dual-AS Configuration Example

The following examples show the configurations for two provider networks and one customer network. Router 1 belongs to autonomous system 100, and Router 2 belongs to autonomous system 200. Autonomous system 200 is being merged into autonomous system 100. This transition needs to occur without interrupting service to Router 3 in autonomous system 300 (customer network). The neighbor local-as command is configured on router 1 to allow Router 3 to maintain peering with autonomous system 200 during this transition. After the transition is complete, the configuration on Router 3 can be updated to peer with autonomous system 100 during a normal maintenance window or during other scheduled downtime.

Router 1 Configuration (Local Provider Network)

interface Serial3/0
 ip address 10.3.3.11 255.255.255.0
!
router bgp 100
 no synchronization
 bgp router-id 100.0.0.11
 neighbor 10.3.3.33 remote-as 300
 neighbor 10.3.3.33 local-as 200 no-prepend replace-as dual-as

Router 2 Configuration (Remote Provider Network)

interface Serial3/0
 ip address 10.3.3.11 255.255.255.0
 !
router bgp 200 
 bgp router-id 100.0.0.11
 neighbor 10.3.3.33 remote-as 300

Router 3 Configuration (Remote Customer Network)

interface Serial3/0
 ip address 10.3.3.33 255.255.255.0
 !
router bgp 300
 bgp router-id 100.0.0.3
 neighbor 10.3.3.11 remote-as 200 

To complete the migration after the two autonomous systems have merged, the peering session is updated on Router 3:

neighbor 10.3.3.11 remote-as 100

Related Commands

Command
Description

neighbor remove-private-as

Removes private autonomous system numbers from outbound routing updates.

show ip bgp

Displays entries in the BGP routing table.

show ip bgp neighbors

Displays information about BGP neighbors.