Guest

Cisco IOS Software Releases 12.2 SX

Bidirectional Forwarding Detection

  • Viewing Options

  • PDF (467.9 KB)
  • Feedback
Bidirectional Forwarding Detection

Table Of Contents

Bidirectional Forwarding Detection

Contents

Prerequisites for Bidirectional Forwarding Detection

Restrictions for Bidirectional Forwarding Detection

Information About Bidirectional Forwarding Detection

BFD Operation

BFD Detection of Failures

BFD Version Interoperability

BFD Support on Cisco 12000 Routers

Benefits of Using BFD for Failure Detection

How to Configure Bidirectional Forwarding Detection

Configuring BFD Session Parameters on the Interface

Configuring BFD Support for Routing Protocols

Configuring BFD Support for BGP

Configuring BFD Support for EIGRP

Configuring BFD Support for IS-IS

Configuring BFD Support for OSPF

Configuring BFD Support for HSRP

Configuring BFD Echo Mode

Configuring the BFD Slow Timer

Disabling BFD Echo Mode Without Asymmetry

Monitoring and Troubleshooting BFD

Monitoring and Troubleshooting BFD for Cisco 7600 Series Routers

Monitoring and Troubleshooting BFD for Cisco 12000 Series Routers

Monitoring and Troubleshooting BFD for Cisco 10720 Internet Routers

Configuration Examples for Bidirectional Forwarding Detection

Configuring BFD in an EIGRP Network with Echo Mode Enabled by Default: Example

Configuring BFD in an OSPF Network: Example

Configuring BFD in a BGP Network: Example

Configuring BFD in an IS-IS Network: Example

Configuring BFD in an HSRP Network: Example

Additional References

Related Documents

Standards

MIBs

RFCs

Technical Assistance

Feature Information for Bidirectional Forwarding Detection

Glossary


Bidirectional Forwarding Detection


This document describes how to enable the Bidirectional Forwarding Detection (BFD) protocol. BFD is a detection protocol designed to provide fast forwarding path failure detection times for all media types, encapsulations, topologies, and routing protocols. In addition to fast forwarding path failure detection, BFD provides a consistent failure detection method for network administrators. Because the network administrator can use BFD to detect forwarding path failures at a uniform rate, rather than the variable rates for different routing protocol hello mechanisms, network profiling and planning will be easier, and reconvergence time will be consistent and predictable.

Finding Feature Information in This Module

Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for Bidirectional Forwarding Detection" section.

Finding Support Information for Platforms and Cisco IOS and Catalyst OS Software Images

Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.

Contents

Prerequisites for Bidirectional Forwarding Detection

Restrictions for Bidirectional Forwarding Detection

Information About Bidirectional Forwarding Detection

How to Configure Bidirectional Forwarding Detection

Configuration Examples for Bidirectional Forwarding Detection

Additional References

Feature Information for Bidirectional Forwarding Detection

Glossary

Prerequisites for Bidirectional Forwarding Detection

Cisco Express Forwarding (CEF) and IP routing must be enabled on all participating routers.

You must enable Cisco Parallel eXpress Forwarding (PXF) on the Cisco 10720 Internet router in order for BFD to operate properly. PXF is enabled by default and is generally not turned off.

One of the IP routing protocols supported by BFD must be configured on the routers before BFD is deployed. You should implement fast convergence for the routing protocol that you are using. See the IP routing documentation for your version of Cisco IOS software for information on configuring fast convergence. See the "Restrictions for Bidirectional Forwarding Detection" section for more information on BFD routing protocol support in Cisco IOS software.

Restrictions for Bidirectional Forwarding Detection

For the current Cisco implementation of BFD for Cisco IOS Releases 12.2(18)SXE, 12.0(31)S, 12.4(4)T, 12.0(32)S, 12.2(33)SRA, and 12.2(33)SRB, only asynchronous mode is supported. In asynchronous mode, either BFD peer can initiate a BFD session.

For the current Cisco implementation of BFD for Cisco IOS Releases 12.2(18)SXE, 12.0(31)S, 12.4(4)T, 12.0(32)S, 12.2(33)SRA, and 12.2(33)SRB, BFD is supported only for IPv4 networks.

For Cisco IOS Release 12.2(33)SRB, the Cisco implementation of BFD supports only the following routing protocols: BGP, EIGRP, IS-IS, and OSPF.

For Cisco IOS Release 12.2(33)SRA, the Cisco implementation of BFD supports only the following routing protocols: BGP, IS-IS, and OSPF.

For Cisco IOS Release 12.4(4)T, the Cisco implementation of BFD supports only the following routing protocols: Border Gateway Protocol (BGP), Enhanced Interior Gateway Routing Protocol (EIGRP), Intermediate System-to-Intermediate System (IS-IS), and Open Shortest Path First (OSPF).

For Cisco IOS Release 12.4(11)T, the Cisco implementation of BFD introduced support for the Hot Standby Router Protocol (HSRP). BFD support is not available for all platforms and interfaces. In Cisco IOS Release 12.4(11)T, this feature was introduced on Cisco 7200 series, Cisco 7600 series, and Cisco 12000 series routers.

For Cisco IOS Releases 12.0(31)S and 12.0(32)S, the Cisco implementation of BFD supports only the following routing protocols: BGP, IS-IS, and OSPF.

For Cisco IOS Release 12.2(18)SXE, the Cisco implementation of BFD supports only the following routing protocols: EIGRP, IS-IS, and OSPF

For Cisco IOS Release 12.2(18)SXH, the Cisco implementation of BFD supports the following routing protocols: BGP, EIGRP, IS-IS, and OSPF.

BFD works only for directly connected neighbors. BFD neighbors must be no more than one IP hop away. Multihop configurations are not supported.

BFD support is not available for all platforms and interfaces. To confirm BFD support for a specific platform or interface and obtain the most accurate platform and hardware restrictions, see the Cisco IOS software release notes for your software version.

For the following Cisco IOS Releases, BFD on PortChannel is not a supported configuration: 12.2 SXH, 12.2 SXF, 12.2 SRC, and 12.2 SRB.

On the Cisco 10720 Internet router, BFD is supported only on Fast Ethernet, Gigabit Ethernet, and RPR-IEEE interfaces. BFD is not supported on Spatial Reuse Protocol (SRP) and Packet-over-SONET (POS) interfaces.

When you configure the BFD session parameters on a Cisco 10720 interface using the bfd command (in interface configuration mode), the minimum configurable time period supported for the milliseconds argument in both the interval milliseconds and min_rx milliseconds parameters is 50 milliseconds.

A maximum of 100 BFD sessions are supported on the Cisco 10720 Internet router. When BFD tries to set up a connection between routing protocols and establish a 101th session between a Cisco 10720 Internet router and adjacent routers, the following error message is displayed:

00:01:24: %OSPF-5-ADJCHG: Process 100, Nbr 10.0.0.0 on RPR-IEEE1/1 from LOADING to 
FULL, Loading Done 
00:01:24: %BFD-5-SESSIONLIMIT: Attempt to exceed session limit of 100 neighbors. 

The Cisco 10720 Internet router does not support the following BFD features:

Demand mode

Echo packets

BFD over IP Version 6

On the Cisco 12000 series router, asymmetrical routing between peer devices may cause a BFD control packet to be received on a line card other than the line card that initiated the session. In this special case, the BFD session between the routing peers will not be established.

A maximum 100 sessions per line card are supported for the distributed Cisco 12000 series Internet router. The minimum hello interval is 50 ms with up to three Max retries for a BFD control packet to be received from a remote system before a session with a neighbor is declared down.


Note For the most accurate platform and hardware restrictions, see the Cisco IOS software release notes for your software version.


Information About Bidirectional Forwarding Detection

Before you configure BFD, you should become familiar with the information in the following sections:

BFD Operation

Benefits of Using BFD for Failure Detection

BFD Operation

BFD provides a low-overhead, short-duration method of detecting failures in the forwarding path between two adjacent routers, including the interfaces, data links, and forwarding planes. BFD is a detection protocol that you enable at the interface and routing protocol levels. Cisco supports the BFD asynchronous mode, which depends on the sending of BFD control packets between two systems to activate and maintain BFD neighbor sessions between routers. Therefore, in order for a BFD session to be created, you must configure BFD on both systems (or BFD peers). Once BFD has been enabled on the interfaces and at the router level for the appropriate routing protocols, a BFD session is created, BFD timers are negotiated, and the BFD peers will begin to send BFD control packets to each other at the negotiated interval.

BFD provides fast BFD peer failure detection times independently of all media types, encapsulations, topologies, and routing protocols BGP, EIGRP, IS-IS, and OSPF. By sending rapid failure detection notices to the routing protocols in the local router to initiate the routing table recalculation process, BFD contributes to greatly reduced overall network convergence time. Figure 1 shows a simple network with two routers running OSPF and BFD. When OSPF discovers a neighbor (1) it sends a request to the local BFD process to initiate a BFD neighbor session with the OSPF neighbor router (2). The BFD neighbor session with the OSPF neighbor router is established (3).

Figure 1 Establishing a BFD Neighbor Relationship

Figure 2 shows what happens when a failure occurs in the network (1). The BFD neighbor session with the OSPF neighbor router is torn down (2). BFD notifies the local OSPF process that the BFD neighbor is no longer reachable (3). The local OSPF process tears down the OSPF neighbor relationship (4). If an alternative path is available the routers will immediately start converging on it.

Figure 2 Tearing Down an OSPF Neighbor Relationship

BFD Detection of Failures

Once a BFD session has been established and timer negations are complete, BFD peers send BFD control packets that act in the same manner as an IGP hello protocol to detect liveliness, except at a more accelerated rate. The following information should be noted:

BFD is a forwarding path failure detection protocol. BFD detects a failure, but the routing protocol must take action to bypass a failed peer.

Typically, BFD can be used at any protocol layer. However, the Cisco implementation of BFD for Cisco IOS Releases 12.2(18)SXE, 12.0(31)S, and 12.4(4)T supports only Layer 3 clients, in particular, the BGP, EIGRP, IS-IS, and OSPF routing protocols.

Cisco devices will use one BFD session for multiple client protocols in the Cisco implementation of BFD for Cisco IOS Releases 12.2(18)SXE, 12.0(31)S, and 12.4(4)T. For example, if a network is running OSPF and EIGRP across the same link to the same peer, only one BFD session will be established, and BFD will share session information with both routing protocols.

BFD Version Interoperability

Cisco IOS Release 12.4(9)T supports BFD Version 1 as well as BFD Version 0. All BFD sessions come up as Version 1 by default and will be interoperable with Version 0. The system automatically performs BFD version detection, and BFD sessions between neighbors will run in the highest common BFD version between neighbors. For example, of one BFD neighbor is running BFD Version 0 and the other BFD neighbor is running Version 1, the session will run BFD Version 0. The output from the show bfd neighbors [details] command will verify which BFD version a BFD neighbor is running.

See the "Configuring BFD in an EIGRP Network with Echo Mode Enabled by Default: Example" section for an example of BFD version detection.

BFD Support on Cisco 12000 Routers

The Cisco 12000 series routers support distributed BFD to take advantage of its distributed Route Processor (RP) and line card (LC) architecture. The BFD tasks will be divided and assigned to the BFD process on RP and LC as described in the following sections:

BFD Process on the RP

BFD Process on the LC

BFD Process on the RP

Client Interaction

The BFD process on the RP will handle the interaction with clients, which create and delete BFD sessions.

Session Management for BFD Process on the RP

The BFD RP process will primarily own all BFD sessions on the router. It will pass the session creation and deletion requests to the BFD processes on all LCs. BFD LC sessions will have no knowledge of sessions being added or deleted by the clients. Only the BFD RP process will send session addition and deletion commands to the BFD LC process.

Session Database Management

The BFD RP process will maintain a database of all the BFD sessions on the router. This database will contain only the minimum required information.

Process EXEC Commands

The BFD RP process services the BFD show commands.

BFD Process on the LC

Session Management for BFD Process on the LC

The BFD LC process manages sessions, adds and deletes commands from the BFD RP process, and creates and deletes new sessions based on the commands. In the event of transmit failure, receive failure, or session down detection, the LC BFD instance will immediately notify the BFD RP process. It will also update transmit and receive counters. The BFD session is maintained completely on the LC. BFD control packets are received and processed, as well as sent, from the LC itself.

Database Management

The BFD LC process maintains a database of all the BFD sessions hosted on the LC.

Receive and Transmit

The BFD LC process is responsible for transmitting and receiving BFD packets for the sessions on the LC.

Benefits of Using BFD for Failure Detection

When you deploy any feature, it is important to consider all the alternatives and be aware of any trade-offs being made.

The closest alternative to BFD in conventional EIGRP, IS-IS, and OSPF deployments is the use of modified failure detection mechanisms for EIGRP, IS-IS, and OSPF routing protocols.

If you set EIGRP hello and hold timers to their absolute minimums, the failure detection rate for EIGRP falls to within a one- to two-second range.

If you use fast hellos for either IS-IS or OSPF, these Interior Gateway Protocol (IGP) protocols reduce their failure detection mechanisms to a minimum of one second.

There are several advantages to implementing BFD over reduced timer mechanisms for routing protocols:

Although reducing the EIGRP, IS-IS, and OSPF timers can result in minimum detection timer of one to two seconds, BFD can provide failure detection in less than one second.

Because BFD is not tied to any particular routing protocol, it can be used as a generic and consistent failure detection mechanism for EIGRP, IS-IS, and OSPF.

Because some parts of BFD can be distributed to the data plane, it can be less CPU-intensive than the reduced EIGRP, IS-IS, and OSPF timers, which exist wholly at the control plane.

How to Configure Bidirectional Forwarding Detection

You start a BFD process by configuring BFD on the interface. When the BFD process is started, no entries are created in the adjacency database, in other words, no BFD control packets are sent or received. BFD echo mode, which is supported in BFD Version 1 for Cisco IOS 12.4(9)T, is enabled by default. BFD echo packets are sent and received in addition to BFD control packets. The adjacency creation takes places once you have configured BFD support for the applicable routing protocols. This section contains the following procedures:

Configuring BFD Session Parameters on the Interface (required)

Configuring BFD Support for Routing Protocols (required)

Configuring BFD Echo Mode (optional)

Monitoring and Troubleshooting BFD (optional)

Configuring BFD Session Parameters on the Interface

The steps in this procedure show how to configure BFD on the interface by setting the baseline BFD session parameters on an interface. Repeat the steps in this procedure for each interface over which you want to run BFD sessions to BFD neighbors.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number

Example:

Router(config)# interface FastEthernet 6/0

Enters interface configuration mode.

Step 4 

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

Example:

Router(config-if)# bfd interval 50 min_rx 50 multiplier 5

Enables BFD on the interface.

Step 5 

end

Example:

Router(config-if)# end

Exits interface configuration mode.

Configuring BFD Support for Routing Protocols

You can enable BFD support for routing protocols at the router level to enable BFD support globally for all interfaces or you can configure BFD on a per-interface basis at the interface level.

For Cisco IOS Release 12.2(18)SXE, you must configure BFD support for one or more of the following routing protocols: EIGRP, IS-IS, and OSPF.

For Cisco IOS Releases 12.2(33)SRA, you must configure BFD support for one or more of the following routing protocols: EIGRP, IS-IS, and OSPF.

For Cisco IOS Releases 12.2(33)SRB, you must configure BFD support for one or more of the following routing protocols: BGP, EIGRP, IS-IS, and OSPF.

For Cisco IOS Releases 12.0(31)S and 12.4(4)T, you must configure BFD support for one or more of the following routing protocols: BGP, IS-IS, and OSPF.

For Cisco IOS Release 12.0(32)S, for the Cisco 10720 platform, you must configure BFD for one or more of the following routing protocols: BGP, IS-IS, and OSPF.

For Cisco IOS Release 12.4(11)T, BFD support for HSRP was introduced.

This section describes the following procedures:

Configuring BFD Support for BGP (optional)

Configuring BFD Support for EIGRP (optional)

Configuring BFD Support for IS-IS (optional)

Configuring BFD Support for OSPF (optional)

Configuring BFD Support for HSRP (optional)

Configuring BFD Support for BGP

This section describes the procedure for configuring BFD support for BGP, so that BGP is a registered protocol with BFD and will receive forwarding path detection failure messages from BFD.

Prerequisites

BGP must be running on all participating routers.

The baseline parameters for BFD sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured. See the "Configuring BFD Session Parameters on the Interface" section for more information.

SUMMARY STEPS

1. enable

2. configure terminal

3. router bgp as-tag

4. neighbor ip-address fall-over bfd

5. end

6. show bfd neighbors [details]

7. show ip bgp neighbor

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router bgp as-tag
Example:

Router(config)# router bgp tag1

Specifies a BGP process and enters router configuration mode.

Step 4 

neighbor ip-address fall-over bfd

Example:

Router(config-router)# neighbor 172.16.10.2 fall-over bfd

Enables BFD support for fallover.

Step 5 

end

Example:

Router(config-router)# end

Returns the router to privileged EXEC mode.

Step 6 

show bfd neighbors [details]

Example:

Router# show bfd neighbors detail

Verifies that the BFD neighbor is active and displays the routing protocols that BFD has registered.

Note In order to display the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 7 

show ip bgp neighbor

Example:

Router# show ip bgp neighbor

Displays information about BGP and TCP connections to neighbors.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and troubleshooting BFD. If you want to configure BFD support for another routing protocol, see the following sections:

Configuring BFD Support for EIGRP

Configuring BFD Support for IS-IS

Configuring BFD Support for OSPF

Configuring BFD Support for HSRP

Configuring BFD Support for EIGRP

This section describes the procedure for configuring BFD support for EIGRP, so that EIGRP is a registered protocol with BFD and will receive forwarding path detection failure messages from BFD. There are two methods for enabling BFD support for EIGRP:

You can enable BFD for all of the interfaces for which EIGRP is routing by using the bfd all-interfaces command in router configuration mode.

You can enable BFD for a subset of the interfaces for which EIGRP is routing by using the bfd interface type number command in router configuration mode.

Prerequisites

EIGRP must be running on all participating routers.

The baseline parameters for BFD sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured. See the "Configuring BFD Session Parameters on the Interface" section for more information.

Restrictions

BFD for EIGRP is not supported on the Cisco 12000 series routers for Cisco IOS Releases 12.0(31)S, 12.0(32)S, 12.4(4)T, and 12.2(33)SRA.

SUMMARY STEPS

1. enable

2. configure terminal

3. router eigrp as-number

4. log-adjacency-changes [detail]

5. bfd all-interfaces
or
bfd interface type number

6. end

7. show bfd neighbors [details]

8. show ip eigrp interfaces [type number] [as-number] [detail]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router eigrp as-number

Example:

Router(config)# router eigrp 123

Configures the EIGRP routing process and enters router configuration mode.

Step 4 

log-adjacency-changes [detail]

Example:

Router(config-router)# log-adjacency-changes

Configures the router to send a system logging (syslog) message when an EIGRP neighbor goes up or down.

Entering the log-adjacency-changes command allows you to see the "BFD node down" syslog message whenever a neighbor is down due to receiving a BFD failure detection notification.

Step 5 

bfd all-interfaces


or


bfd interface
type number

Example:

Router(config-router)# bfd all-interfaces


or

Example:

Router(config-router)# bfd interface FastEthernet 6/0

Enables BFD globally on all interfaces associated with the EIGRP routing process.

or

Enables BFD on a per-interface basis for one or more interfaces associated with the EIGRP routing process.

Step 6 

end

Example:

Router(config-router) end

Returns the router to privileged EXEC mode.

Step 7 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

Verifies that the BFD neighbor is active and displays the routing protocols that BFD has registered.

Note In order to see the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 8 

show ip eigrp interfaces [type number] [as-number] [detail]

Example:

Router# show ip eigrp interfaces detail

Displays the interfaces for which BFD support for EIGRP has been enabled.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and troubleshooting BFD. If you want to configure BFD support for another routing protocol, see the following sections:

Configuring BFD Support for BGP

Configuring BFD Support for IS-IS

Configuring BFD Support for OSPF

Configuring BFD Support for HSRP

Configuring BFD Support for IS-IS

This section describes the procedures for configuring BFD support for IS-IS, so that IS-IS is a registered protocol with BFD and will receive forwarding path detection failure messages from BFD. There are two methods for enabling BFD support for IS-IS:

You can enable BFD for all of the interfaces for which IS-IS is routing by using the bfd all-interfaces command in router configuration mode. You can then disable BFD for one or more of those interfaces using the isis bfd disable command in interface configuration mode.

You can enable BFD for a subset of the interfaces for which IS-IS is routing by using the isis bfd command in interface configuration mode.

To configure BFD support for IS-IS, perform the steps in one of the following sections:

Configuring BFD Support for IS-IS for All Interfaces

Configuring BFD Support for IS-IS for One or More Interfaces

Prerequisites

IS-IS must be running on all participating routers.

The baseline parameters for BFD sessions on the interfaces that you want to run BFD sessions to BFD neighbors over must be configured. See the "Configuring BFD Session Parameters on the Interface" section for more information.

Configuring BFD Support for IS-IS for All Interfaces

To configure BFD on all IS-IS interfaces, perform the steps in this section.

SUMMARY STEPS

1. enable

2. configure terminal

3. router isis area-tag

4. bfd all-interfaces

5. exit

6. interface type number

7. isis bfd [disable]

8. end

9. show bfd neighbors [details]

10. show clns interface

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router isis area-tag
Example:

Router(config)# router isis tag1

Specifies an IS-IS process and enters router configuration mode.

Step 4 

bfd all-interfaces

Example:

Router(config-router)# bfd all-interfaces

Enables BFD globally on all interfaces associated with the IS-IS routing process.

Step 5 

exit

Example:

Router(config-router)# exit

(Optional) Returns the router to global configuration mode. Enter this command only if you want to follow Step 6 and Step 7 to disable BFD for one or more interfaces.

Step 6 

interface type number
Example:

Router(config)# interface fastethernet 6/0

(Optional) Enters interface configuration mode.

Step 7 

isis bfd [disable]

Example:

Router(config-if)# isis bfd

Enables or disables BFD on a per-interface basis for one or more interfaces associated with the IS-IS routing process.

Note You should use the disable keyword only if you enabled BFD on all of the interfaces that IS-IS is associated with using the bfd all-interfaces command in router configuration mode.

Step 8 

end

Example:

Router(config-if)# end

Returns the router to privileged EXEC mode.

Step 9 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

Displays information that can be used to verify if the BFD neighbor is active and displays the routing protocols that BFD has registered.

Note In order to display the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 10 

show clns interface

Example:

Router# show clns interface

Displays information that can be used to verify if BFD for IS-IS has been enabled for a specific IS-IS interface that is associated.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and troubleshooting BFD. If you want to configure only for a specific subset of interfaces, perform the tasks in the "Configuring BFD Support for IS-IS for One or More Interfaces" section.

Configuring BFD Support for IS-IS for One or More Interfaces

To configure BFD for only one or more IS-IS interfaces, perform the steps in this section.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. isis bfd [disable]

5. end

6. show bfd neighbors [details]

7. show clns interface

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number
Example:

Router(config)# interface fastethernet 6/0

Enters interface configuration mode.

Step 4 

isis bfd [disable]

Example:

Router(config-if)# isis bfd

Enables or disables BFD on a per-interface basis for one or more interfaces associated with the IS-IS routing process.

Note You should use the disable keyword only if you enabled BFD on all of the interfaces that IS-IS is associated with using the bfd all-interfaces command in router configuration mode.

Step 5 

end

Example:

Router(config-if)# end

Returns the router to privileged EXEC mode.

Step 6 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

Displays information that can help verify if the BFD neighbor is active and displays the routing protocols that BFD has registered.

Note In order to display the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 7 

show clns interface

Example:

Router# show clns interface

Displays information that can help verify if BFD for IS-IS has been enabled for a specific IS-IS interface that is associated.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and maintaining BFD. If you want to configure BFD support for another routing protocol, see one of the following sections:

Configuring BFD Support for BGP

Configuring BFD Support for EIGRP

Configuring BFD Support for OSPF

Configuring BFD Support for HSRP

Configuring BFD Support for OSPF

This section describes the procedures for configuring BFD support for OSPF, so that OSPF is a registered protocol with BFD and will receive forwarding path detection failure messages from BFD. You can either configure BFD support for OSPF globally on all interfaces or configure it selectively on one or more interfaces.

There are two methods for enabling BFD support for OSPF:

You can enable BFD for all of the interfaces for which OSPF is routing by using the bfd all-interfaces command in router configuration mode. You can disable BFD support on individual interfaces using the ip ospf bfd [disable] command in interface configuration mode.

You can enable BFD for a subset of the interfaces for which OSPF is routing by using the ip ospf bfd command in interface configuration mode.

See the following sections for tasks for configuring BFD support for OSPF:

Configuring BFD Support for OSPF for All Interfaces (optional)

Configuring BFD Support for OSPF for One or More Interfaces (optional)

Configuring BFD Support for OSPF for All Interfaces

To configure BFD for all OSPF interfaces, perform the steps in this section.

If you do not want to configure BFD on all OSPF interfaces and would rather configure BFD support specifically for one or more interfaces, see the "Configuring BFD Support for OSPF for One or More Interfaces" section.

Prerequisites

OSPF must be running on all participating routers.

The baseline parameters for BFD sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured. See the "Configuring BFD Session Parameters on the Interface" section for more information.

SUMMARY STEPS

1. enable

2. configure terminal

3. router ospf process-id

4. bfd all-interfaces

5. exit

6. interface name number

7. ip ospf bfd [disable]

8. end

9. show bfd neighbors [details]

10. show ip ospf

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

router ospf process-id
Example:

Router(config)# router ospf 4

Specifies an OSPF process and enters router configuration mode.

Step 4 

bfd all-interfaces

Example:

Router(config-router)# bfd all-interfaces

Enables BFD globally on all interfaces associated with the OSPF routing process.

Step 5 

exit

Example:

Router(config-router)# exit

(Optional) Returns the router to global configuration mode. Enter this command only if you want to perform Step 7 to disable BFD for one or more interfaces.

Step 6 

interface type number

Example:

Router(config)# interface fastethernet 6/0

(Optional) Enters interface configuration mode. Enter this command only if you want to perform Step 7 to disable BFD for one or more interfaces.

Step 7 

ip ospf bfd [disable]

Example:

Router(config-if)# ip ospf bfd disable

(Optional) Disables BFD on a per-interface basis for one or more interfaces associated with the OSPF routing process.

Note You should use the disable keyword only if you enabled BFD on all of the interfaces that OSPF is associated with using the bfd all-interfaces command in router configuration mode.

Step 8 

end

Example:

Router(config-if)# end

Returns the router to privileged EXEC mode.

Step 9 

show bfd neighbors [details]

Example:

Router# show bfd neighbors detail

Displays information that can help verify if the BFD neighbor is active and displays the routing protocols that BFD has registered.

Note In order to display the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 10 

show ip ospf

Example:

Router# show ip ospf

Displays information that can help verify if BFD for OSPF has been enabled.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and troubleshooting BFD. If you want to configure BFD support for another routing protocol, see the following sections:

Configuring BFD Support for BGP

Configuring BFD Support for EIGRP

Configuring BFD Support for IS-IS

Configuring BFD Support for HSRP

Configuring BFD Support for OSPF for One or More Interfaces

To configure BFD on one or more OSPF interfaces, perform the steps in this section.

Prerequisites

OSPF must be running on all participating routers.

The baseline parameters for BFD sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured. See the "Configuring BFD Session Parameters on the Interface" section for more information.

SUMMARY STEPS

1. enable

2. configure terminal

3. interface type number

4. ip ospf bfd [disable]

5. end

6. show bfd neighbors [details]

7. show ip ospf

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

interface type number
Example:

Router(config)# interface fastethernet 6/0

Enters interface configuration mode.

Step 4 

ip ospf bfd [disable]

Example:

Router(config-if)# ip ospf bfd

Enables or disables BFD on a per-interface basis for one or more interfaces associated with the OSPF routing process.

Note You should use the disable keyword only if you enabled BFD on all of the interfaces that OSPF is associated with using the bfd all-interfaces command in router configuration mode.

Step 5 

end

Example:

Router(config-if)# end

Returns the router to privileged EXEC mode.

Step 6 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

Displays information that can help verify if the BFD neighbor is active and displays the routing protocols that BFD has registered.

Note In order to display the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 7 

show ip ospf

Example:

Router# show ip ospf

Displays information that can help verify if BFD support for OSPF has been enabled.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and troubleshooting BFD. If you want to configure BFD support for another routing protocol, see the following sections:

Configuring BFD Support for BGP

Configuring BFD Support for EIGRP

Configuring BFD Support for IS-IS

Configuring BFD Support for HSRP

Configuring BFD Support for HSRP

Perform this task to enable BFD support for Hot Standby Router Protocol (HSRP.) Repeat the steps in this procedure for each interface over which you want to run BFD sessions to HSRP peers.

HSRP supports BFD by default. If HSRP support for BFD has been manually disabled, you can reenable it at the router level to enable BFD support globally for all interfaces or on a per-interface basis at the interface level.

Prerequisites

HSRP must be running on all participating routers.

Cisco Express Forwarding (CEF) must be enabled.

SUMMARY STEPS

1. enable

2. configure terminal

3. ip cef [distributed]

4. interface type number

5. ip address ip-address mask

6. standby [group-number] ip [ip-address [secondary]]

7. standby bfd

8. exit

9. standby bfd all-interfaces

10. exit

11. show standby [neighbors]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

ip cef [distributed]

Example:

Router(config)# ip cef

Enables CEF or distributed CEF.

Step 4 

interface type number

Example:

Router(config)# interface FastEthernet 6/0

Enters interface configuration mode.

Step 5 

ip address ip-address mask

Example:

Router(config-if)# ip address 10.0.0.11 255.255.255.0

Configures an IP address for the interface.

Step 6 

standby [group-number] ip [ip-address [secondary]]

Example:

Router(config-if)# standby 1 ip 10.0.0.11

Activates HSRP.

Step 7 

standby bfd

Example:

Router(config-if)# standby bfd

(Optional) Enables HSRP support for BFD on the interface.

Step 8 

exit

Example:

Router(config-if)# exit

Exits interface configuration mode.

Step 9 

standby bfd all-interfaces
Example:

Router(config)# standby bfd all-interfaces

(Optional) Enables HSRP support for BFD on all interfaces.

Step 10 

exit

Example:

Router(config)# exit

Exits global configuration mode.

Step 11 

show standby neighbors

Example:

Router# show standby neighbors

(Optional) Displays information about HSRP support for BFD.

What to Do Next

See the "Monitoring and Troubleshooting BFD" section for more information on monitoring and troubleshooting BFD. If you want to configure BFD support for another routing protocol, see the following sections:

Configuring BFD Support for BGP

Configuring BFD Support for EIGRP

Configuring BFD Support for IS-IS

Configuring BFD Support for OSPF

Configuring BFD Echo Mode

BFD echo mode is enabled by default, but you can disable it such that it can run independently in each direction. Before you configure echo mode you should be familiar with the following concepts:

BFD Echo Mode

Prerequisites

Restrictions

BFD Echo Mode

Benefits of Running BFD Echo Mode

BFD echo mode works with asynchronous BFD. Echo packets are sent by the forwarding engine and forwarded back along the same path in order to perform detection—the BFD session at the other end does not participate in the actual forwarding of the echo packets. The echo function and the forwarding engine are responsible for the detection process, therefore the number of BFD control packets that are sent out between two BFD neighbors is reduced. And since the forwarding engine is testing the forwarding path on the remote (neighbor) system without involving the remote system, there is an opportunity to improve the interpacket delay variance, thereby achieving quicker failure detection times than when using BFD Version 0 with BFD control packets for the BFD session.

Echo Mode Without Asymmetry

Echo mode is described as without asymmetry when it is running on both sides (both BFD neighbors are running echo mode).

Prerequisites

BFD must be running on all participating routers.

Before using BFD echo mode, you must disable the sending of Internet Control Message Protocol (ICMP) redirect messages by entering the no ip redirects command, in order to avoid high CPU utilization.

The baseline parameters for BFD sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured. See the "Configuring BFD Session Parameters on the Interface" section for more information.

Restrictions

BFD echo mode which is supported in BFD Version 1, is available only in Cisco IOS Releases 12.4(9)T and 12.2(33)SRA.

This section contains the following configuration tasks for BFD echo mode:

Configuring the BFD Slow Timer

Disabling BFD Echo Mode Without Asymmetry

Configuring the BFD Slow Timer

The steps in this procedure show how to change the value of the BFD slow timer. Repeat the steps in this procedure for each BFD router.

SUMMARY STEPS

1. enable

2. configure terminal

3. bfd slow-timer milliseconds

4. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

bfd slow-timer milliseconds

Example:

Router(config)# bfd slow-timer 12000

Configures the BFD slow timer.

Step 4 

end

Example:

Router(config)# end

Exits interface configuration mode.

Disabling BFD Echo Mode Without Asymmetry

The steps in this procedure show how to disable BFD echo mode without asymmetry —no echo packets will be sent by the router, and the router will not forward BFD echo packets that are received from any neighbor routers.

Repeat the steps in this procedure for each BFD router.

SUMMARY STEPS

1. enable

2. configure terminal

3. [no] bfd echo

4. bfd echo

5. end

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 3 

[no] bfd echo

Example:

Router(config)# no bfd echo

Disables BFD echo mode.

Step 4 

end

Example:

Router(config)# end

Exits global configuration mode.

Monitoring and Troubleshooting BFD

This section describes how to retrieve BFD information for maintenance and troubleshooting. The commands in these tasks can be entered as needed, in any order desired.

For more information about BFD session initiation and failure, refer to the "BFD Operation" section.

This section contains information for monitoring and troubleshooting BFD for the following Cisco platforms:

Monitoring and Troubleshooting BFD for Cisco 7600 Series Routers

Monitoring and Troubleshooting BFD for Cisco 12000 Series Routers

Monitoring and Troubleshooting BFD for Cisco 10720 Internet Routers

Monitoring and Troubleshooting BFD for Cisco 7600 Series Routers

To monitor or troubleshoot BFD on Cisco 7600 series routers, perform one or more of the steps in this section.

SUMMARY STEPS

1. enable

2. show bfd neighbors [details]

3. debug bfd [packet | event]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

Displays the BFD adjacency database.

The details keyword shows all BFD protocol parameters and timers per neighbor.

Note In order to see the full output of the show bfd neighbors details command on a a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card. The registered protocols are not shown in the output of the show bfd neighbors details command when it is entered on a line card.

Step 3 

debug bfd [packet | event]

Example:

Router# debug bfd packet

Displays debugging information about BFD packets.

Monitoring and Troubleshooting BFD for Cisco 12000 Series Routers

To monitor or troubleshoot BFD on Cisco 12000 series routers, perform one or more of the steps in this section.

SUMMARY STEPS

1. enable

2. attach slot-number

3. show bfd neighbors [details]

4. show monitor event-trace bfd [all]

5. debug bfd event

6. debug bfd packet

7. debug bfd ipc-error

8. debug bfd ipc-event

9. debug bfd oir-error

10. debug bfd oir-event

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

attach slot-number

Example:

Router# attach 6

Connects you to a specific line card for the purpose of executing monitoring and maintenance commands on the specified line card. Slot numbers range from 0 to 11 for the Cisco 12012 and from 0 to 7 for the Cisco 12008.

If the slot number is omitted, you are prompted for the slot number.

Note In order to display the full output of the show bfd neighbors details command on a Cisco 12000 series router, you must enter the command on the line card. Enter the attach slot-number command to establish a CLI session with a line card.

Step 3 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

Displays the BFD adjacency database.

The details keyword shows all BFD protocol parameters and timers per neighbor.

Note The registered protocols are not shown in the output of the show bfd neighbors details when it is entered on a line card.

Step 4 

show monitor event-trace bfd [all]

Example:

Router# show monitor event-trace bfd all

Displays logged messages for important events in "recent past" on BFD activities that occur on the line cards. This is a rolling buffer based log, so "distant past" events would be lost. Depending on traffic and frequency of events, these events could be seen over a variable time window.

Step 5 

debug bfd event

Example:

Router# debug bfd event

Displays debugging information about BFD state transitions.

Step 6 

debug bfd packet

Example:

Router# debug bfd packet

Displays debugging information about BFD control packets.

Step 7 

debug bfd ipc-error

Example:

Router# debug bfd ipc-error

Displays debugging information with IPC errors on the RP and LC.

Step 8 

debug bfd ipc-event

Example:

Router# debug bfd ipc-event

Displays debugging information with IPC events on the RP and LC.

Step 9 

debug bfd oir-error

Example:

Router# debug bfd oir-error

Displays debugging information with OIR errors on the RP and LC.

Step 10 

debug bfd oir-event

Example:

Router# debug bfd oir-event

Displays debugging information with OIR events on the RP and LC.

Monitoring and Troubleshooting BFD for Cisco 10720 Internet Routers

To monitor or troubleshoot BFD on Cisco 10720 Internet routers, perform one or more of the steps in this section.

SUMMARY STEPS

1. enable

2. show bfd neighbors [details]

3. debug bfd event

4. debug bfd packet

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables privileged EXEC mode.

Enter your password if prompted.

Step 2 

show bfd neighbors [details]

Example:

Router# show bfd neighbors details

(Optional) Displays the BFD adjacency database.

The details keyword will show all BFD protocol parameters and timers per neighbor.

Note The registered protocols are not shown in the output of the show bfd neighbors details when it is entered on a line card.

Step 3 

debug bfd event

Example:

Router# debug bfd event

Displays debugging information about BFD state transitions.

Step 4 

debug bfd packet

Example:

Router# debug bfd packet

Displays debugging information about BFD control packets.

Configuration Examples for Bidirectional Forwarding Detection

This section provides the following configuration examples:

Configuring BFD in an EIGRP Network with Echo Mode Enabled by Default: Example

Configuring BFD in an OSPF Network: Example

Configuring BFD in a BGP Network: Example

Configuring BFD in an IS-IS Network: Example

Configuring BFD in an HSRP Network: Example

Configuring BFD in an EIGRP Network with Echo Mode Enabled by Default: Example

12.4(9)T Example

In the following example, the EIGRP network contains RouterA, RouterB, and RouterC. Fast Ethernet interface 0/1 on RouterA is connected to the same network as FastEthernet interface 0/1 on Router B. Fast Ethernet interface 0/1 on RouterB is connected to the same network as Fast Ethernet interface 0/1 on RouterC.

RouterA and RouterB are running BFD Version 1 which supports echo mode, and RouterC is running BFD Version 0, which does not support echo mode. The BFD sessions between RouterC and its BFD neighbors are said to be running echo mode with asymmetry because echo mode will run on the forwarding path for RouteA and RouterB, and their echo packets will return along the same path to for BFD sessions and failure detections, while their BFD neighbor RouterC runs BFD Version 0 and uses BFD controls packets for BFD sessions and failure detections.

Figure 3 EIGRP Network with Three BFD Neighbors Running V1 or V0

Figure 3 shows a large EIGRP network with several routers, three of which are BFD neighbors that are running EIGRP as their routing protocol.

The example, starting in global configuration mode, shows the configuration of BFD.

Configuration for RouterA

interface FastEthernet0/0
 no shutdown 
 ip address 10.4.9.14 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3 
 no shutdown
 duplex auto
 speed auto
!
router eigrp 11
 network 172.16.0.0
 bfd all-interfaces
 auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 171.16.1.129 255.255.255.255 10.4.9.1
!
no ip http server
!
logging alarm informational
!
control-plane
!
line con 0
 exec-timeout 30 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

Configuration for RouterB

!
interface FastEthernet0/0
 no shutdown
 ip address 10.4.9.34 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
 no shtdown
 duplex auto
 speed auto

!
router eigrp 11
 network 172.16.0.0
 bfd all-interfaces
 auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 171.16.1.129 255.255.255.255 10.4.9.1
!
no ip http server
!
logging alarm informational
!
control-plane
!
line con 0
 exec-timeout 30 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

Configuration for RouterC

!
!
interface FastEthernet0/0
 no shutdown
 ip address 10.4.9.34 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
 no shutdown
 duplex auto
 speed auto

!
router eigrp 11
 network 172.16.0.0
 bfd all-interfaces
 auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 171.16.1.129 255.255.255.255 10.4.9.1
!
no ip http server
!
logging alarm informational
!
control-plane
!
line con 0
 exec-timeout 30 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end

The output from the show bfd neighbors details command from RouterA verifies that BFD sessions have been created among all three routers and that EIGRP is registered for BFD support. The first group of output shows that RouterC with the IP address 172.16.1.3 runs BFD Version 0 and therefore does not use the echo mode. The second group of output shows that RouterB with the IP address 172.16.1.2 does run BFD Version 1, and the 50 millisecond BFD interval parameter had been adopted. The relevant command output is shown in bold in the output.

RouterA

RouterA# show bfd neighbors details

OurAddr       NeighAddr      LD/RD  RH/RS    Holdown(mult)  State     Int
172.16.1.1    172.16.1.3     5/3    1(RH)    150 (3 )       Up   Fa0/1       
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holdown (hits): 150(0), Hello (hits): 50(1364284)
Rx Count: 1351813, Rx Interval (ms) min/max/avg: 28/64/49 last: 4 ms ago
Tx Count: 1364289, Tx Interval (ms) min/max/avg: 40/68/49 last: 32 ms ago
Registered protocols: EIGRP
Uptime: 18:42:45
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 3          - Your Discr.: 5
             Min tx interval: 50000    - Min rx interval: 50000
             Min Echo interval: 0

OurAddr       NeighAddr     LD/RD  RH/RS   Holdown(mult)  State     Int
172.16.1.1    172.16.1.2     6/1    Up        0    (3 )   Up        Fa0/1       
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(317)
Rx Count: 305, Rx Interval (ms) min/max/avg: 1/1016/887 last: 448 ms ago
Tx Count: 319, Tx Interval (ms) min/max/avg: 1/1008/880 last: 532 ms ago
Registered protocols: EIGRP
Uptime: 00:04:30
Last packet: Version: 1            - Diagnostic: 0
             State bit: Up         - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 1          - Your Discr.: 6
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 50000

The output from the show bfd neighbors details command on Router B verifies that BFD sessions have been created and that EIGRP is registered for BFD support. As previously noted, RouterA runs BFD Version 1, therefore echo mode is running, and RouterC runs BFD Version 0, so echo mode does not run. The relevant command output is shown in bold in the output.

Router B

RouterB# show bfd neighbors details 

OurAddr       NeighAddr     LD/RD  RH/RS   Holdown(mult)  State     Int
172.16.1.2    172.16.1.1     1/6    Up        0    (3 )   Up        Fa0/1       
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(337)
Rx Count: 341, Rx Interval (ms) min/max/avg: 1/1008/882 last: 364 ms ago
Tx Count: 339, Tx Interval (ms) min/max/avg: 1/1016/886 last: 632 ms ago
Registered protocols: EIGRP
Uptime: 00:05:00
Last packet: Version: 1            - Diagnostic: 0
             State bit: Up         - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 6          - Your Discr.: 1
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 50000

OurAddr       NeighAddr     LD/RD  RH/RS   Holdown(mult)  State     Int
172.16.1.2    172.16.1.3     3/6    1(RH)     118  (3 )   Up        Fa0/1       
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holdown (hits): 150(0), Hello (hits): 50(5735)
Rx Count: 5731, Rx Interval (ms) min/max/avg: 32/72/49 last: 32 ms ago
Tx Count: 5740, Tx Interval (ms) min/max/avg: 40/64/50 last: 44 ms ago
Registered protocols: EIGRP
Uptime: 00:04:45
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 6          - Your Discr.: 3
             Min tx interval: 50000    - Min rx interval: 50000
             Min Echo interval: 0

Figure 4

Fast Ethernet interface 0/1 Failure

Figure 4 shows a that Fast Ethernet interface 0/1 on RouterB has failed. Without this neighbor, there is no way to reach the network beyond RouterB.

When Fast Ethernet interface 0/1 on RouterB fails, BFD will no longer detect Router B as a BFD neighbor for RouterA or for RouterC. In this example, Fast Ethernet interface 0/1 has been administratively shut down on RouterB.

The following output from the show bfd neighbors command on RouterA now shows only one BFD neighbor for RouterA in the EIGRP network. The relevant command output is shown in bold in the output.

RouterA# show bfd neighbors

OurAddr       NeighAddr     LD/RD  RH/RS   Holdown(mult)  State     Int
172.16.1.1    172.16.1.3     5/3    1(RH)     134  (3 )   Up        Fa0/1       

The following output from the show bfd neighbors command on RouterC also now shows only one BFD neighbor for RouterC in the EIGRP network. The relevant command output is shown in bold in the output.

RouterC# show bfd neighbors


OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.1.3    172.16.1.1     3/5  1   114  (3 )      Up        Fa0/1          

Configuring BFD in an OSPF Network: Example

12.0(31)S

In the following example, the simple OSPF network consists of Router A and Router B. Fast Ethernet interface 0/1 on Router A is connected to the same network as Fast Ethernet interface 6/0 in Router B. The example, starting in global configuration mode, shows the configuration of BFD. For both Routers A and B, BFD is configured globally for all interfaces associated with the OSPF process.

Configuration for Router A

!
interface FastEthernet 0/1
 ip address 172.16.10.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 3/0.1
ip address 172.17.0.1 255.255.255.0
!
router ospf 123
 log-adjacency-changes detail
 network 172.16.0.0 0.0.0.255 area 0
 network 172.17.0.0 0.0.0.255 area 0
 bfd all-interfaces

Configuration for Router B

!
interface FastEthernet 6/0
 ip address 172.16.10.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 6/1
 ip address 172.18.0.1 255.255.255.0
!
router ospf 123
 log-adjacency-changes detail
 network 172.16.0.0 0.0.255.255 area 0
 network 172.18.0.0 0.0.255.255 area 0
 bfd all-interfaces


The output from the show bfd neighbors details command verifies that a BFD session has been created and that OSPF is registered for BFD support. The relevant command output is shown in bold in the output.

Router A

RouterA# show bfd neighbors details

OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.10.1   172.16.10.2    1/2  1   532  (3 )      Up        Fa0/1          
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(22), Hello (hits): 200(84453)
Rx Count: 49824, Rx Interval (ms) min/max/avg: 208/440/332 last: 68 ms ago
Tx Count: 84488, Tx Interval (ms) min/max/avg: 152/248/196 last: 192 ms ago

Registered protocols: OSPF

Uptime: 02:18:49
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 2          - Your Discr.: 1
             Min tx interval: 50000    - Min rx interval: 1000
             Min Echo interval: 0

The output from the show bfd neighbors details command from the line card on Router B verifies that a BFD session has been created:


Note Router B is a Cisco 12000 series router. The show bfd neighbors details command must be run on the line cards. The show bfd neighbors details command will not display the registered protocols when it is entered on a line card.


Router B

RouterB# attach 6 

Entering Console for 8 Port Fast Ethernet in Slot: 6
Type "exit" to end this session

Press RETURN to get started!

LC-Slot6> show bfd neighbors details

Cleanup timer hits: 0

OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.10.2   172.16.10.1    8/1  1   1000 (5 )      Up        Fa6/0          
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 5         - Length: 24
             My Discr.: 1          - Your Discr.: 8
             Min tx interval: 200000    - Min rx interval: 200000
             Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
 IPC Tx Failure Count: 0
 IPC Rx Failure Count: 0
 Total Adjs Found: 1

The output of the show ip ospf command verifies that BFD has been enabled for OSPF. The relevant command output is shown in bold in the output.

Router A


RouterA# show ip ospf

 Routing Process "ospf 123" with ID 172.16.10.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x000000
 Number of opaque AS LSA 0. Checksum Sum 0x000000
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0

 BFD is enabled

    Area BACKBONE(0)
        Number of interfaces in this area is 2 (1 loopback)
        Area has no authentication
        SPF algorithm last executed 00:00:08.828 ago
        SPF algorithm executed 9 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x028417
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Router B


RouterB# show ip ospf

 Routing Process "ospf 123" with ID 172.18.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Supports Link-local Signaling (LLS)
 Supports area transit capability
 Initial SPF schedule delay 5000 msecs
 Minimum hold time between two consecutive SPFs 10000 msecs
 Maximum wait time between two consecutive SPFs 10000 msecs
 Incremental-SPF disabled
 Minimum LSA interval 5 secs
 Minimum LSA arrival 1000 msecs
 LSA group pacing timer 240 secs
 Interface flood pacing timer 33 msecs
 Retransmission pacing timer 66 msecs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0

 BFD is enabled

    Area BACKBONE(0)
        Number of interfaces in this area is 2 (1 loopback)
        Area has no authentication
        SPF algorithm last executed 02:07:30.932 ago
        SPF algorithm executed 7 times
        Area ranges are
        Number of LSA 3. Checksum Sum 0x28417 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

The output of the show ip ospf interface command verifies that BFD has been enabled for OSPF on the interfaces connecting Router A and Router B. The relevant command output is shown in bold in the output.

Router A

RouterA# show ip ospf interface fastethernet 0/1

show ip ospf interface fastethernet 0/1 
FastEthernet0/1 is up, line protocol is up 
  Internet Address 172.16.10.1/24, Area 0 
  Process ID 123, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1, BFD enabled
  Designated Router (ID) 172.18.0.1, Interface address 172.16.10.2
  Backup Designated router (ID) 172.16.10.1, Interface address 172.16.10.1
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:03
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 172.18.0.1  (Designated Router)
  Suppress hello for 0 neighbor(s)

Router B

RouterB# show ip ospf interface fastethernet 6/1

FastEthernet6/1 is up, line protocol is up 
  Internet Address 172.18.0.1/24, Area 0 
  Process ID 123, Router ID 172.18.0.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1, BFD enabled
  Designated Router (ID) 172.18.0.1, Interface address 172.18.0.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:01
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 0
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 0, Adjacent neighbor count is 0 
  Suppress hello for 0 neighbor(s)

Configuring BFD in a BGP Network: Example

12.0(31)S

In the following example, the simple BGP network consists of Router A and Router B. Fast Ethernet interface 0/1 on Router A is connected to the same network as Fast Ethernet interface 6/0 in Router B. The example, starting in global configuration mode, shows the configuration of BFD.

Configuration for Router A

!
interface FastEthernet 0/1
 ip address 172.16.10.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 3/0.1
ip address 172.17.0.1 255.255.255.0
!
!
router bgp 40000
 bgp log-neighbor-changes
 neighbor 172.16.10.2 remote-as 45000
 neighbor 172.16.10.2 fall-over bfd
 !
 address-family ipv4
 neighbor 172.16.10.2 activate
 no auto-summary
 no synchronization
 network 172.18.0.0 mask 255.255.255.0
 exit-address-family
!

Configuration for Router B

!
interface FastEthernet 6/0
 ip address 172.16.10.2 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 6/1
 ip address 172.18.0.1 255.255.255.0
!
router bgp 45000
 bgp log-neighbor-changes
 neighbor 172.16.10.1 remote-as 40000
 neighbor 172.16.10.1 fall-over bfd
 !
 address-family ipv4
 neighbor 172.16.10.1 activate
 no auto-summary
 no synchronization
 network 172.17.0.0 mask 255.255.255.0
 exit-address-family
!

The output from the show bfd neighbors details command from Router A verifies that a BFD session has been created and that BGP is registered for BFD support. The relevant command output is shown in bold in the output.

Router A

RouterA# show bfd neighbors details 

OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.10.1   172.16.10.2    1/8  1   332  (3 )      Up        Fa0/1          
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(0), Hello (hits): 200(15491)
Rx Count: 9160, Rx Interval (ms) min/max/avg: 200/440/332 last: 268 ms ago
Tx Count: 15494, Tx Interval (ms) min/max/avg: 152/248/197 last: 32 ms ago
Registered protocols: BGP
Uptime: 00:50:45
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 8          - Your Discr.: 1
             Min tx interval: 50000    - Min rx interval: 1000
             Min Echo interval: 0

The output from the show bfd neighbors details command from the line card on Router B verifies that a BFD session has been created:


Note Router B is a Cisco 12000 series router. The show bfd neighbors details command must be run on the line cards. The show bfd neighbors details command will not display the registered protocols when it is entered on a line card.


Router B

RouterB# attach 6 

Entering Console for 8 Port Fast Ethernet in Slot: 6
Type "exit" to end this session

Press RETURN to get started!

LC-Slot6> show bfd neighbors details

Cleanup timer hits: 0

OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.10.2   172.16.10.1    8/1  1   1000 (5 )      Up        Fa6/0          
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 5         - Length: 24
             My Discr.: 1          - Your Discr.: 8
             Min tx interval: 200000    - Min rx interval: 200000
             Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
 IPC Tx Failure Count: 0
 IPC Rx Failure Count: 0
 Total Adjs Found: 1

The output of the show ip bgp neighbors command verifies that BFD has been enabled for the BGP neighbors:

Router A

RouterA# show ip bgp neighbors

BGP neighbor is 172.16.10.2,  remote AS 45000, external link
 Using BFD to detect fast fallover
.
.
.

Router B

RouterB# show ip bgp neighbors

BGP neighbor is 172.16.10.1,  remote AS 40000, external link
 Using BFD to detect fast fallover
.
.
.

Configuring BFD in an IS-IS Network: Example

12.0(31)S

In the following example, the simple IS-IS network consists of Router A and Router B. Fast Ethernet interface 0/1 on Router A is connected to the same network as Fast Ethernet interface 6/0 for Router B. The example, starting in global configuration mode, shows the configuration of BFD.

Configuration for Router A

!
interface FastEthernet 0/1
 ip address 172.16.10.1 255.255.255.0
ip router isis 
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 3/0.1
ip address 172.17.0.1 255.255.255.0
ip router isis 
!
router isis 
 net 49.0001.1720.1600.1001.00
 bfd all-interfaces
!

Configuration for Router B

!
interface FastEthernet 6/0
 ip address 172.16.10.2 255.255.255.0
ip router isis 
 bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 6/1
 ip address 172.18.0.1 255.255.255.0
ip router isis 
!
router isis 
 net 49.0000.0000.0002.00
 bfd all-interfaces
!

The output from the show bfd neighbors details command from Router A verifies that a BFD session has been created and that IS-IS is registered for BFD support:

Router A

RouterA# show bfd neighbors details 

OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.10.1   172.16.10.2    1/8  1   536  (3 )      Up        Fa0/1          
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(0), Hello (hits): 200(23543)
Rx Count: 13877, Rx Interval (ms) min/max/avg: 200/448/335 last: 64 ms ago
Tx Count: 23546, Tx Interval (ms) min/max/avg: 152/248/196 last: 32 ms ago
Registered protocols: ISIS 
Uptime: 01:17:09
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 8          - Your Discr.: 1
             Min tx interval: 50000    - Min rx interval: 1000
             Min Echo interval: 0

The output from the show bfd neighbors details command from the line card on Router B verifies that a BFD session has been created:


Note Router B is a Cisco 12000 series router. The show bfd neighbors details command must be run on the line cards. The show bfd neighbors details command will not display the registered protocols when it is entered on a line card.


Router B

RouterB# attach 6 

Entering Console for 8 Port Fast Ethernet in Slot: 6
Type "exit" to end this session

Press RETURN to get started!

LC-Slot6> show bfd neighbors details

Cleanup timer hits: 0

OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
172.16.10.2   172.16.10.1    8/1  1   1000 (5 )      Up        Fa6/0          
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0            - Diagnostic: 0
             I Hear You bit: 1     - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 5         - Length: 24
             My Discr.: 1          - Your Discr.: 8
             Min tx interval: 200000    - Min rx interval: 200000
             Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
 IPC Tx Failure Count: 0
 IPC Rx Failure Count: 0
 Total Adjs Found: 1

Configuring BFD in an HSRP Network: Example

In the following example, the HSRP network consists of Router A and Router B. Fast Ethernet interface 2/0 on Router A is connected to the same network as Fast Ethernet interface 2/0 on Router B. The example, starting in global configuration mode, shows the configuration of BFD.


Note In the following example, the standby bfd and the standby bfd all-interfaces commands are not displayed. HSRP support for BFD peering is enabled by default when BFD is configured on the router or interface using the bfd interval command. The standby bfd and standby bfd all-interfaces commands are needed only if BFD has been manually disabled on a router or interface.


Router A

ip cef
interface FastEthernet2/0
 no shutdown
 ip address 10.0.0.2 255.0.0.0
 ip router-cache cef
 bfd interval 200 min_rx 200 multiplier 3
 standby 1 ip 10.0.0.11
 standby 1 preempt
 standby 1 priority 110
 
 standby 2 ip 10.0.0.12
 standby 2 preempt
 standby 2 priority 110

Router B

interface FastEthernet2/0
 ip address 10.1.0.22 255.255.0.0
 no shutdown
 bfd interval 200 min_rx 200 multiplier 3
 standby 1 ip 10.0.0.11
 standby 1 preempt
 standby 1 priority 90

 standby 2 ip 10.0.0.12
 standby 2 preempt
 standby 2 priority 80

The output from the show standby neighbors command verifies that a BFD session has been created:

RouterA# show standby neighbors

HSRP neighbors on FastEthernet2/0
  10.1.0.22
    No active groups
    Standby groups: 1
    BFD enabled !

RouterB# show standby neighbors

HSRP neighbors on FastEthernet2/0
  10.0.0.2
    Active groups: 1
    No standby groups
    BFD enabled !

Additional References

The following sections provide references related to the BFD feature.

Related Documents

Related Topic
Document Title

Configuring and monitoring BGP

"BGP" module of the Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4

Configuring and monitoring EIGRP

"EIGRP" module of the Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4

Configuring and monitoring IS-IS

"Configuring Integrated IS-IS" module of the Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4

Configuring and monitoring OSPF

"OSPF" module of the Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4

Configuring and monitoring HSRP

"Configuring HSRP" module of the Cisco IOS IP Application Services Configuration Guide, Release 12.4T

BFD commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

"IP Routing Protocol-Independent Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.4T

"IP Routing Protocol-Independent Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR

"IP Routing Protocol-Independent Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SX

BGP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

"BGP Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.4T

"BGP Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR

"BGP Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SX

EIGRP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

"EIGRP Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.4T

"EIGRP Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR

"EIGRP Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SX

IS-IS commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

"Integrated IS-IS Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.4T

"Integrated IS-IS Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR

"Integrated IS-IS Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SX

OSPF commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

"OSPF Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.4T

"OSPF Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR

"OSPF Commands" chapter of the Cisco IOS IP Routing Protocols Command Reference, Release 12.2SX


Standards

Standard
Title

IETF Draft

Bidirectional Forwarding Detection, January 2006

(http://www.ietf.org/internet-drafts/draft-ietf-bfd-base-03.txt)

IETF Draft

BFD for IPv4 and IPv6 (Single Hop), March 2005

(http://www.ietf.org/internet-drafts/draft-ietf-bfd-v4v6-1hop-02.txt)


MIBs

MIB
MIBs Link

No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

http://www.cisco.com/go/mibs


RFCs

RFC
Title

No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.


Technical Assistance

Description
Link

The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. Access to most tools on the Cisco Support website requires a Cisco.com user ID and password. If you have a valid service contract but do not have a user ID or password, you can register on Cisco.com.

http://www.cisco.com/techsupport


Feature Information for Bidirectional Forwarding Detection

Table 1 lists the release history for this feature.

Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.

Cisco IOS software images are specific to a Cisco IOS software release, a feature set, and a platform. Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.


Note Table 1 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.


Table 1 Feature Information for Bidirectional Forwarding Detection 

Feature Name
Releases
Feature Information

Bidirectional Forwarding Detection

12.2(18)SXE

This document describes how to enable the Bidirectional Forwarding Detection (BFD) protocol. BFD is a detection protocol designed to provide fast forwarding path failure detection times for all media types, encapsulations, topologies, and routing protocols. In addition to fast forwarding path failure detection, BFD provides a consistent failure detection method for network administrators. Because the network administrator can use BFD to detect forwarding path failures at a uniform rate, rather than the variable rates for different routing protocol hello mechanisms, network profiling and planning will be easier, and reconvergence time will be consistent and predictable.

 

12.0(31)S

In Release 12.0(31)S, support was added for the Cisco 12000 series Internet router.

 

12.0(32)S

In Release 12.0(32)S, support was added for the Cisco 10720 Internet router and IP Services Engine (Engine 3) and Engine 5 shared port adapters (SPAs) and SPA interface processors (SIPs) on the Cisco 12000 series Internet router.

 

12.4(9)T
12.2(33)SRB

In Release 12.4(9)T, support for Version 1 BFD and support for BFD Echo Mode was added.

BFD echo mode works with asynchronous BFD. Echo packets are sent by the forwarding engine and forwarded back along the same path in order to perform detection—the BFD session at the other end does not participate in the actual forwarding of the echo packets. The echo function and the forwarding engine are responsible for the detection process, therefore the number of BFD control packets that are sent out between two BFD neighbors is reduced. And since the forwarding engine is testing the forwarding path on the remote (neighbor) system without involving the remote system, there is an opportunity to improve the interpacket delay variance, thereby achieving quicker failure detection times than when using BFD Version 0 with BFD control packets for the BFD session.

 

12.4(11)T

In Release 12.4(11)T, support for HSRP was added.

 

12.2(33)SRB

In Release 12.2(33)SRB, BFD standard implementation, Version 1, and echo mode is supported on the Cisco 7600 router.

 

12.4(15)T

In Release 12.4(15)T, BFD is supported on the Integrated Services Router (ISR) family of Cisco routers, for example, the Cisco 3800 ISR series routers.

 

12.2(33)SXH

In Release 12.2(33)SXH, BFD standard implementation is supported on the Cisco 6500 router.
BFD standard implementation is supported for ION and Multi-Topology Routing (MTR).


Glossary

BFD—Bidirectional Forwarding Detection. A detection protocol designed to provide fast failure detection times for all media types, encapsulations, topologies, and routing protocols.