Cisco IOS Multitopology Routing Command Reference
A through R
Downloads: This chapterpdf (PDF - 1.65MB) The complete bookPDF (PDF - 2.9MB) | The complete bookePub (ePub - 261.0KB) | Feedback

A through R

Contents

A through R

address-family ipv4 (BGP)

To enter address family or router scope address family configuration mode to configure a routing session using standard IP Version 4 (IPv4) address prefixes, use the address-family ipv4 command in router configuration or router scope configuration mode. To exit address family configuration mode and remove the IPv4 address family configuration from the running configuration, use the no form of this command.

Syntax Available Under Router Configuration Mode

address-family ipv4 [mdt | tunnel | {multicast | unicast} [vrf vrf-name] | vrf vrf-name]

no address-family ipv4 [mdt | tunnel | {multicast | unicast} [vrf vrf-name] | vrf vrf-name]

Syntax Available Under Router Scope Configuration Mode

address-family ipv4 [mdt | multicast | unicast]

no address-family ipv4 [mdt | multicast | unicast]

Syntax Description

mdt

(Optional) Specifies an IPv4 multicast distribution tree (MDT) address family session.

tunnel

(Optional) Specifies an IPv4 routing session for multipoint tunneling.

multicast

(Optional) Specifies IPv4 multicast address prefixes.

unicast

(Optional) Specifies IPv4 unicast address prefixes. This is the default.

vrf vrf-name

(Optional) Specifies the name of the VPN routing and forwarding (VRF) instance to associate with subsequent IPv4 address family configuration mode commands.

Command Default

IPv4 address prefixes are not enabled.

Command Modes

Router configuration (config-router)

Router scope configuration (config-router-scope)

Command History

Release

Modification

12.0(5)T

This command was introduced. This command replaced the match nlri and set nlri commands.

12.0(28)S

This command was modified. The tunnel keyword was added.

12.0(29)S

This command was modified. The mdt keyword was added.

12.0(30)S

This command was modified. Support for the Cisco 12000 series Internet router was added.

12.2(33)SRA

This command was integrated into Cisco IOS Release 12.2(33)SRA.

12.2(31)SB2

This command was integrated into Cisco IOS Release 12.2(31)SB2.

12.2(33)SRB

This command was modified. Support for router scope configuration mode was added. The tunnel keyword was deprecated.

12.2(33)SXH

This command was integrated into Cisco IOS Release 12.2(33)SXH.

12.2(33)SB

This command was integrated into Cisco IOS Release 12.2(33)SB.

Cisco IOS XE Release 2.1

This command was introduced on Cisco ASR 1000 Series Aggregation Services Routers.

12.4(20)T

This command was modified. The mdt keyword was added. The tunnel keyword was deprecated.

Cisco IOS XE Release 3.6S

This command was modified. VRF-based multicast support was added.

15.2(4)S

This command was implemented on the Cisco 7200 series router.

15.1(2)SNG

This command was implemented on the Cisco ASR 901 Series Aggregation Services Routers.

Usage Guidelines

The address-family ipv4 command replaces the match nlri and set nlri commands. The address-family ipv4 command places the device in address family configuration mode (prompt: config-router-af), from which you can configure routing sessions that use standard IPv4 address prefixes. To leave address family configuration mode and return to router configuration mode, type exit.


Note


Routing information for address family IPv4 is advertised by default for each Border Gateway Protocol (BGP) routing session configured with the neighbor remote-as command unless you enter the no bgp default ipv4-unicast command before configuring the neighbor remote-as command.


The tunnel keyword is used to enable the tunnel subaddress family identifier (SAFI) under the IPv4 address family identifier. This SAFI is used to advertise the tunnel endpoints and the SAFI-specific attributes (which contain the tunnel type and tunnel capabilities). Redistribution of tunnel endpoints into the BGP IPv4 tunnel SAFI table occurs automatically when the tunnel address family is configured. However, peers need to be activated under the tunnel address family before the sessions can exchange tunnel information.

The mdt keyword is used to enable the MDT SAFI under the IPv4 address family identifier. This SAFI is used to advertise tunnel endpoints for inter-AS multicast VPN peering sessions.

If you specify the address-family ipv4 multicast command, you will then specify the network network-number [mask network-mask] command. The network command advertises (injects) the specified network number and mask into the multicast BGP database. This route must exist in the forwarding table installed by an Interior Gateway Protocol (IGP) (that is, by EIGRP, OSPF, RIP, IGRP, static, or IS-IS), but not BGP.

In Cisco IOS Release 12.2(33)SRB and later releases, the ability to use address family configuration under the router scope configuration mode was introduced. The scope hierarchy can be defined for BGP routing sessions and is required to support Multitopology Routing (MTR). To enter the router scope configuration mode, use the scope command, which can apply globally or for a specific VRF. When using the scope for a specific VRF, only the unicast keyword is available.

Examples

The following example places the device in address family configuration mode for the IPv4 address family:

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4
Device(config-router-af)#

The following example places the device in address family configuration mode and specifies only multicast address prefixes for the IPv4 address family:

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4 multicast
Device(config-router-af)#

The following example places the device in address family configuration mode and specifies unicast address prefixes for the IPv4 address family:

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4 unicast
Device(config-router-af)#

The following example places the device in address family configuration mode and specifies cisco as the name of the VRF instance to associate with subsequent IPv4 address family configuration mode commands:

Device(config)# router bgp 50000
Device(config-router)# address-family ipv4 vrf cisco
Device(config-router-af)#

Note


Use this form of the command, which specifies a VRF, only to configure routing exchanges between provider edge (PE) and customer edge (CE) devices.


The following example places the device in tunnel address family configuration mode:

Device(config)# router bgp 100
Device(config-router)# address-family ipv4 tunnel
Device(config-router-af)#

The following example shows how to configure a device to support an IPv4 MDT address-family session:

Device(config)# router bgp 45000
Device(config-router)# address-family ipv4 mdt
Device(config-router-af)#

The following example shows how to configure the IPv4 address family under router scope configuration mode. In this example, the scope hierarchy is enabled globally. The device enters router scope address family configuration mode, and only multicast address prefixes for the IPv4 address family are specified:

Device(config)# router bgp 50000
Device(config-router)# scope global
Device(config-router-scope)# address-family ipv4 multicast
Device(config-router-scope-af)#

Related Commands

Command

Description

address-family ipv6

Places the device in address family configuration mode for configuring routing sessions, such as BGP, that use standard IPv6 address prefixes.

address-family vpn4

Places the device in address family configuration mode for configuring routing sessions such as BGP, RIP, or static routing sessions that use standard VPN Version 4 address prefixes.

bgp default ipv4-unicast

Enables the IPv4 unicast address family on all neighbors.

neighbor activate

Enables the exchange of information with a BGP neighboring device.

neighbor remote-as

Adds an entry to the BGP or multiprotocol BGP neighbor table.

scope

Defines the scope for a BGP routing session and enters router scope configuration mode.

address-family ipv4 (EIGRP MTR)

To enter router address family configuration mode to configure the Enhanced Interior Gateway Routing Protocol (EIGRP) for Multitopology Routing (MTR), use the address-family ipv4 command in router configuration mode. To remove the address family from the EIGRP configuration, use the no form of this command.

address-family ipv4 [ unicast | multicast | vrf vrf-name ] autonomous-system as-number

no address-family ipv4 [ unicast | multicast | vrf vrf-name ] autonomous-system as-number

Syntax Description

unicast

(Optional) Specifies the unicast subaddress family.

multicast

(Optional) Specifies the multicast subaddress family.

vrf vrf-name

(Optional) Specifies the name of the VRF.

autonomous-system as-number

Specifies the autonomous system number.

Command Default

This command is disabled by default.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The address-family ipv4 command is used to enter router address family or subaddress family configuration mode to configure the exchange of address-family and subaddress-family prefixes.


Note


If Enhanced Routing and Forwarding is not available, then the multicast keyword is also not available.


Examples

The following example shows how to configure an IPv4 address family to associate with the MTR topology named VIDEO:

Device(config)# router eigrp mtr
Device(config-router)# address-family ipv4 autonomous-system 5
Device(config-router-af)# topology VIDEO tid 100

address-family ipv4 (IS-IS)

To enter router address family configuration mode under Intermediate System-to-Intermediate System (IS-IS) router configuration mode, use the address-family ipv4 command in router configuration mode. To remove the address family or subaddress family configuration from the router configuration, use the no form of this command.

address-family ipv4 [ multicast | unicast ]

no address-family ipv4 [ multicast | unicast ]

Syntax Description

multicast

(Optional) Specifies multicast subaddress family prefixes.

unicast

(Optional) Specifies unicast subaddress family prefixes.

Command Default

Unicast subaddress family configuration mode is entered if no optional keywords are entered.

Command Modes

Router configuration (config-router)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

The address-family ipv4 command is used to enter router address family or subaddress family configuration mode to configure the exchange of address-family and subaddress-family prefixes.

Examples

The following example show how to configure IS-IS to exchange IPv4 unicast prefixes in unicast subaddress family configuration mode:

Device(config)# router isis 1 
Device(config-router)# address-family ipv4 unicast 
Device(config-router-af)# end 

address-family ipv4 (OSPF)

To enter router address family configuration mode under Open Shortest Path First (OSPF) router configuration mode, use the address-family ipv4 command in router configuration mode. To remove the address family or subaddress family configuration from the router configuration, use the no form of this command.

address-family ipv4 [ multicast | unicast ]

no address-family ipv4 [ multicast | unicast ]

Syntax Description

multicast

(Optional) Specifies multicast subaddress family prefixes.

unicast

(Optional) Specifies unicast subaddress family prefixes.

Command Default

Unicast router subaddress family configuration mode is entered if no optional keywords are entered.

Command Modes

Router configuration

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Usage Guidelines

The address-family ipv4 command is used to enter router address family or router subaddress family configuration mode to configure the exchange of address-family and subaddress-family prefixes.

Examples

The following example show how to configure OSPF to exchange IPv4 unicast prefixes in unicast subaddress family configuration mode:

Device(config)# router ospf 1 
Device(config-router)# address-family ipv4 unicast 
Device(config-router-af)# end 

Related Commands

Command

Description

area capability default-exclusion

Configures an OSPF process to allow interfaces to be excluded from the base topology.

ip ospf cost (MTR)

Configures the OSPF interface cost under a topology instance.

ip ospf topology disable

Prevents an OSPF process from advertising the interface as part of the topology.

topology (OSPF)

Configures an OSPF process to route IP traffic under the specified topology instance.

all-interfaces

To configure a topology instance to use all interfaces on a device, use the all-interfaces command in address family topology configuration mode. To remove all interfaces from the topology instance configuration, use the no form of this command.

all-interfaces

no all-interfaces

Syntax Description

This command has no arguments or keywords.

Command Default

This command is disabled by default. No interfaces are included in class-specific topologies unless explicitly configured.

The configuration applied with this command does not override the configuration applied at the interface level with the topology interface configuration command.

Command Modes

Address family topology configuration (config-af-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The all-interfaces command is used to include or exclude all interfaces on the device from a global topology configuration.

Examples

The following example shows how to configure all local interfaces on the device to be used by the VOICE topology:

Device(config)# global-address-family ipv4 
Device(config-af)# topology VOICE 
Device(config-af-topology)# all-interfaces 
Device(config-af-topology)# end 

Related Commands

Command

Description

maximum routes (MTR)

Sets the maximum number of routes that a topology instance will accept and install into the RIB.

shutdown

Temporarily disables a topology instance without removing the topology configuration.

topology (global)

Configures a topology instance.

area capability default-exclusion

To configure an Open Shortest Path First (OSPF) process to allow interfaces to be excluded from the base topology, use the area capability default-exclusion command in router configuration mode. To return the OSPF process to default operation, use the no form of this command.

area area-id capability default-exclusion

no area area-id capability default-exclusion

Syntax Description

area-id

Area ID number. This argument can be entered in the IP address format or as a number. The range is 0 to 4294967295.

Command Default

The base topology cannot be excluded from an interface.

Command Modes

Router configuration

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Examples

The following example shows how to configure OSPF to allow interfaces to be excluded from the base topology:

Device(config)# router ospf 1 
Device(config-router)# area 10 default-cost 100 
Device(config-router)# area 10 capability default-exclusion 
Device(config-router)# end 

Related Commands

Command

Description

address-family ipv4 (OSPF)

Configures address family and subaddress family IP prefix exchange.

ip ospf cost (MTR)

Configures the OSPF interface cost under a topology instance.

ip ospf topology disable

Prevents an OSPF process from advertising the interface as part of the topology.

priority (OSPF)

Sets the priority that an OSPF process assigns to a topology instance for SPF calculations.

topology (OSPF)

Configures an OSPF process to route IP traffic under the specified topology instance.

bgp tid

To configure a Border Gateway Protocol (BGP) routing session to accept routes with a specified Multitopology Routing (MTR) topology ID, use the bgp tid command in router scope address family topology configuration mode. To disassociate the topology ID from the BGP process, use the no form of this command.

bgp tid number

no bgp tid

Syntax Description

number

Topology ID number. The range is 1 to 255.

Command Default

No ID is associated with an MTR topology instance.

Command Modes

Router scope address family topology configuration

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

The bgp tid command is used to associate an ID with an MTR topology instance. Each topology must be configured with a unique topology ID. The topology ID is used to identify and group routes for each topology in BGP updates.

Examples

The following example shows how to configure a topology ID of 100 under the VOICE topology instance:

Device(config)# router bgp 50000 
Device(config-router)# scope global 
Device(config-router-scope)# address-family ipv4 
Device(config-router-scope-af)# topology VOICE 
Device(config-router-scope-af-topo)# bgp tid 100 
Device(config-router-scope-af-topo)# end 

Related Commands

Command

Description

clear ip bgp topology

Resets BGP neighbor session information under a topology instance.

neighbor translate-topology

Configures BGP to translate or move routes from a topology on another device to a topology on the local device.

scope

Defines the scope for a BGP routing session and enters router scope configuration mode.

show ip bgp

Displays entries in the BGP routing table.

topology (BGP)

Configures a BGP routing session to route IP traffic for a specified topology instance.

clear ip bgp topology

To reset Border Gateway Protocol (BGP) neighbor session information for a topology instance, use the clear ip bgp topology command in privileged EXEC mode.

clear ip bgp [ vrf vrf-name ] topology { * | topology-name } { as-number | dampening [ network-address [network-mask] ] | flap-statistics [ network-address [network-mask] ] | peer-group peer-group-name | table-map | update-group [ number | ip-address ] } [ in [prefix-filter] | out | soft [ in [prefix-filter] | out ] ]

Syntax Description

vrf

(Optional) Specifies an instance of a routing table.

vrf-name

(Optional) Name of the Virtual Private Network (VPN) routing and forwarding (VRF) table to use for storing data.

*

Clears session and peering information for all topology instances.

topology-name

Name of a topology instance.

autonomous-system-number

Autonomous system to clear.

dampening

Specifies that dampening statistic counters will be cleared.

network-address [network-mask]

(Optional) Network address and network mask to clear dampening or flap-statistic counters.

flap-statistics

Specifies that session flap statistic counters will be cleared.

peer-group peer-group-name

Clears peer group information for the specified peer group name.

table-map

Clears table-map configuration information.

update-group

Clears update group session information for the specified group number or IP address.

number

(Optional) Update group number.

ip-address

(Optional) IP address of peer for which update group session information is to be cleared.

in

(Optional) Initiates inbound reconfiguration. If neither the in keyword nor out keyword is specified, both inbound and outbound sessions are reset.

prefix-filter

(Optional) Clears the inbound prefix filter.

soft

(Optional) Initiates a soft reset. Does not tear down the session.

out

(Optional) Initiates outbound reconfiguration. If neither the in keyword nor out keyword is specified, both inbound and outbound sessions are reset.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

15.1(2)T

This command was modified. The vrf vrf-name keyword and argument were added.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

The clear ip bgp topology command clears BGP session information under the specified topology or for all topologies. This command can be used to initiate a hard reset or soft reconfiguration. A hard reset tears down and rebuilds the specified peering sessions and rebuilds the BGP routing tables. A soft reconfiguration uses stored prefix information to reconfigure and activate BGP routing tables without tearing down existing peering sessions. Soft reconfiguration uses stored update information, at the cost of additional memory for storing the updates, to allow you to apply new BGP policy without disrupting the network. Soft reconfiguration can be configured for inbound or outbound sessions.

Generating Updates from Stored Information

To generate new inbound updates from stored update information (rather than dynamically) without resetting the BGP session, you must preconfigure the local BGP device using the neighbor soft-reconfiguration inbound command. This preconfiguration causes the software to store all received updates without modification regardless of whether an update is accepted by the inbound policy. Storing updates is memory intensive and should be avoided if possible.

Outbound BGP soft configuration has no memory overhead and does not require any preconfiguration. You can trigger an outbound reconfiguration on the other side of the BGP session to make the new inbound policy take effect.

Use this command whenever any of the following changes occur:

  • Additions or changes to the BGP-related access lists
  • Changes to BGP-related weights
  • Changes to BGP-related distribution lists
  • Changes to BGP-related route maps

Dynamic Inbound Soft Reset

The route refresh capability, as defined in RFC 2918, allows the local device to reset inbound routing tables dynamically by exchanging route refresh requests to supporting peers. The route refresh capability does not store update information locally for non-disruptive policy changes. It instead relies on dynamic exchange with supporting peers. Route refresh is advertised through BGP capability negotiation. All BGP devices must support the route refresh capability.

To determine if a BGP device supports this capability, use the show ip bgp neighbors command. The following message is displayed in the output when the device supports the route refresh capability:

Received route refresh capability from peer.

If all BGP devices support the route refresh capability, use the clear ip bgp topology command with the in keyword. You need not use the soft keyword, because soft reset is automatically assumed when the route refresh capability is supported.


Note


After configuring a soft reset (inbound or outbound), it is normal for the BGP routing process to hold memory. The amount of memory that is held depends on the size of routing tables and the percentage of memory chunks that are utilized. Partially used memory chunks will be used or released before more memory is allocated from the global device memory pool.


Examples

The following example shows how to configure soft reconfiguration for the inbound sessions with neighbors in the autonomous system 45000. The outbound sessions are unaffected.

Device# clear ip bgp topology VOICE 45000 soft in

Related Commands

Command

Description

bgp tid

Configures BGP to accept routes with a specified topology ID.

import topology

Configures BGP to import or move routes from one topology to another on the same device.

neighbor soft-reconfiguration

Configures the Cisco IOS software to start storing updates.

neighbor translate-topology

Configures BGP to translate or move routes from a topology on another device to a topology on the local device.

scope

Defines the scope for a BGP routing session and enters router scope configuration mode.

show ip bgp neighbors

Displays information about BGP and TCP connections to neighbors.

show ip bgp neighbors topology

Displays entries in the BGP routing tables for a topology instance.

topology (BGP)

Configures a process to route IP traffic under the specified topology instance.

clear ip eigrp topology


Note


Effective with Cisco IOS Release 12.2(33)SRE, clear ip eigrp topology command is not available in Cisco IOS software.


To clear an Enhanced Interior Gateway Routing Protocol (EIGRP) process for a topology instance, use the clear ip eigrp topology command in privileged EXEC mode.

clear ip eigrp [as-number] topology [topology-name] topo-entry [entry-mask]

Syntax Description

as-number

(Optional) The autonomous system number to clear.

topology-name

(Optional) The name of the topology instance.

topo-entry

The topology table entry. The topo-entry argument is entered as an IP address.

entry-mask

(Optional) The topology table entry mask. The entry-mask argument is entered as a wild-card mask.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was removed.

Usage Guidelines

The clear ip eigrp topology command can be used to reset EIGRP process and session information for a specific topology.

Examples

The following example resets the EIGRP process under the VOICE topology and clears the topology table entry 10.32.40.2:

Device# clear ip eigrp topology VOICE 10.32.40.2

Related Commands

Command

Description

clear ip eigrp topology eigrp next-hop-self

Configures EIGRP to advertise itself as the next hop.

eigrp shutdown

Disables an EIGRP process under a topology interface configuration.

eigrp split-horizon

Configures split horizon under a topology interface configuration.

eigrp summary-address

Configures an EIGRP summary address under a topology configuration.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance.

topology (interface)

Configures an MTR topology instance on an interface.

clear ip interface

To reset interface-level statistics, use the clear ip interface command in privileged EXEC mode.

clear ip interface type number [ topology { name | all | base } ] [stats]

Syntax Description

type

Interface type.

number

Interface number.

topology

(Optional) Specifies topology statistics.

name

(Optional) Statistics related to a particular topology.

all

(Optional) Statistics for all topologies. This keyword can be used as the name argument.

base

(Optional) Clears base topology statistics.

stats

(Optional) Clears IP traffic statistics without topology awareness, that is, an aggregate of all topologies is cleared.

Command Default

If no topology is specified, only interface level aggregate statistics are reset.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

Use the clear ip interface command to reset interface-level statistics. If a topology name is specified, only the statistics for that topology are cleared. If all topologies need to be reset, use the all keyword as the topology name.

Examples

The following example shows how to clear statistics for all topologies:

Device# clear ip interface FastEthernet 1/10 topology all 

clear ip route multicast

To clear multicast routes from the routing table, use the clear ip route multicast command in privileged EXEC mode.

clear ip route multicast { vrf vrf-name | * | destination [mask] | dhcp ip-address }

Syntax Description

vrf vrf-name

Specifies a VPN routing and forwarding (VRF) instance.

*

Deletes all routes.

destination

Address of the destination network.

mask

(Optional) Mask of the destination network.

dhcp

Specifies a route added by a DHCP server or relay agent.

ip-address

Destination host route to delete.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

15.0(1)M

This command was integrated into Cisco IOS Release 15.0(1)M.

15.0(1)SY

This command was integrated into Cisco IOS Release 15.0(1)SY.

Usage Guidelines

The clear ip route multicast command is used to clear specific multicast entries from the routing table or all multicast entries (by entering the * character).

Examples

The following example shows how to clear all multicast routes from the routing table:

Device# clear ip route multicast * 

Related Commands

clear ip route topology

Clears entries from the routing table of a topology.

ip route topology

Configures static routing under a topology instance.

clear ip route topology

To clear entries from the routing table of a topology, use the clear ip route topology command in privileged EXEC mode.

clear ip route topology topology-name { * | destination [mask] | dhcp ip-address }

Syntax Description

topology-name

Name of the topology.

*

Specifies all routes.

destination

Address of the destination network.

mask

(Optional) Mask of the destination network.

dhcp

Specifies routes added by a DHCP relay agent.

ip-address

IP address of the DHCP relay agent.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The clear ip route topology command is used to clear entries from the routing table for the specified topology instance or all topology instances (by entering the * character).

Examples

The following example shows how to clear all routes from the routing table of the VOICE topology:

Device# clear ip route topology VOICE * 

Related Commands

ip route topology

Configures static routing under a topology instance.

ping (MTR)

Diagnoses basic network connectivity through a topology instance.

show ip protocols topology

Displays the configuration and state of active routing protocol processes under a topology instance.

show ip route topology

Displays the current state of a topology routing table.

show topology

Displays status and configuration information for topologies configured with MTR.

clear ip traffic (MTR)

To clear IP traffic statistics, use the clear ip traffic command in privileged EXEC mode.

clear ip traffic [ topology { name | all | base } ]

Syntax Description

topology

(Optional) Clears IP traffic statistics related to a particular topology.

name

(Optional) Topology name.

all

(Optional) Clears statistics for all topologies.

base

(Optional) Clears base topology statistics.

Command Default

If no topology name is specified, global statistics are cleared.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

Use the clear ip traffic command to clear IP traffic statistics. If no topology name is specified, global statistics are cleared. If a topology name is specified, only the statistics for that topology are cleared. If all topologies need to be reset, use the all keyword as the topology name.

Examples

The following example shows how to clear all topology statistics:

Device# clear ip traffic topology all

Related Commands

Command

Description

show ip traffic (MTR)

Displays statistics about IP traffic.

debug topology

To enable debugging for topology related events, use the debug topology command in privileged EXEC mode. To disable debugging output, use the no form of this command.

debug topology { accounting | all | cache | db | event | ha | interface | locking | sb | state | topoid | vrf }

no debug topology { accounting | all | cache | db | event | ha | interface | locking | sb | state | topoid | vrf }

Syntax Description

accounting

Enables debugging for topology accounting.

all

Enables debugging for all topology routing events.

cache

Enables debugging for topology ID cache activity.

db

Enables debugging for topology DB events.

event

Enables debugging for topology notification events.

ha

Enables debugging for topology High Availability (HA) events.

interface

Enables debugging for topology interface association.

locking

Enables debugging for topology client locking activity.

sb

Enables debugging for topology sub-block.

state

Enables debugging for topology state change events.

topoid

Enables debugging for topology ID management events.

vrf

Enables debugging for topology VRF association.

Command Default

Debugging output for topology related events is disabled.

Command Modes

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Examples

The following example shows how to enable debugging for topology HA events:

Device# debug topology ha

Related Commands

Command

Description

show topology

Displays status and configuration information for topologies configured with MTR.

eigrp delay

To configure the delay value that Enhanced Interior Gateway Routing Protocol (EIGRP) uses for interface metric calculation, use the eigrp delay command in interface topology configuration mode. To return the delay value to the default, use the no form of this command.

eigrp as-number delay value

no eigrp as-number delay value

Syntax Description

as-number

Specifies the autonomous system number of the EIGRP process.

value

Specifies the delay value, in tens of microseconds. The range is 1 to 4294967295.

Command Default

Delay values are inherited from the global interface configuration.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The eigrp delay command is used to set the interface delay value used by the EIGRP process for routing calculation.

Examples

The following example shows how to set the EIGRP delay calculation on Ethernet interface 0/0 to 100 milliseconds:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast VOICE 
Device(config-if-topology)# eigrp 1 delay 100000 
Device(config-if-topology)# end 

Related Commands

Command

Description

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance.

topology (interface)

Configures an MTR topology instance on an interface.

eigrp next-hop-self

To configure an Enhanced Interior Gateway Routing Protocol (EIGRP) process to advertise itself as the next hop when advertising routes under a topology instance, use the eigrp next-hop-self command in interface topology configuration mode. To configure EIGRP to advertise the source of the route as the next hop, use the no form of this command.

eigrp as-number next-hop-self

no eigrp as-number next-hop-self

Syntax Description

as-number

Autonomous system number of the EIGRP process.

Command Default

This command is enabled by default.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The eigrp next-hop-self command is used to configure EIGRP next hop resolution. By default, EIGRP sets the next-hop to itself for routes it advertises, even if the route is advertised through the interface, from which it was learned. Entering the no form of this command configures EIGRP to advertise the IP address of the route source as the next hop.

Examples

The following example shows how to configure EIGRP process 1 to advertise the source of a route as the next hop under the topology VOICE:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast VOICE 
Device(config-if-topology)# no eigrp 1 next-hop-self 
Device(config-if-topology)# end 

Related Commands

Command

Description

clear ip eigrp topology

Resets EIGRP process information for a topology.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance.

topology (interface)

Configures an MTR topology instance on an interface.

eigrp shutdown

To disable an Enhanced Interior Gateway Routing Protocol (EIGRP) process under a topology interface configuration, use the eigrp shutdown command in interface topology configuration mode. To restart the EIGRP process under a topology interface configuration, use the no form of this command.

eigrp as-number shutdown

no eigrp as-number shutdown

Syntax Description

as-number

Autonomous system number of the EIGRP process.

Command Default

The EIGRP process is in the no shutdown state.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The eigrp shutdown command is used to disable an EIGRP process under an interface topology configuration without removing the EIGRP or topology configuration from the device.

Examples

The following example shows how to place the EIGRP process in a shutdown state:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast RED 
Device(config-if-topology)# eigrp 1 delay 2000 
Device(config-if-topology)# eigrp 1 split-horizon 
Device(config-if-topology)# eigrp 1 shutdown 
Device(config-if-topology)# end 

Related Commands

Command

Description

clear ip eigrp

Resets EIGRP process and neighbor session information.

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance.

topology (interface)

Configures an MTR topology instance on an interface.

eigrp split-horizon

To configure Enhanced Interior Gateway Routing Protocol (EIGRP) to use split horizon under a topology interface configuration, use the eigrp split-horizon command in interface topology configuration mode. To disable split horizon on the topology interface, use the no form of this command.

eigrp as-number split-horizon

no eigrp as-number split-horizon

Syntax Description

as-number

Autonomous system number of the EIGRP process.

Command Default

This command is enabled by default.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The eigrp split-horizon command is used to enable or disable split horizon under the topology interface configuration.

Examples

The following example shows how to disable split horizon:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast VOICE 
Device(config-if-topology)# no eigrp 1 split-horizon 
Device(config-if-topology)# end 

Related Commands

Command

Description

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance.

topology (interface)

Configures an MTR topology instance on an interface.

eigrp summary-address

To configure an Enhanced Interior Gateway Routing Protocol (EIGRP) summary address under a topology interface configuration, use the eigrp summary-address command in interface topology configuration mode. To remove the summary address from the topology interface configuration, use the no form of this command.

eigrp as-number summary-address ip-address wildcard-mask [distance]

no eigrp as-number summary-address ip-address wildcard-mask [distance]

Syntax Description

as-number

Autonomous system number of the EIGRP process.

ip-address wildcard-mask

Summary address to be created. The mask is entered in the form of a wildcard mask.

distance

(Optional) Administrative distance to routes summarized by this command. The range is 1 to 255.

Command Default

No summary addresses are predefined.

The default administrative distance metric for EIGRP is 90.

The default administrative distance for an EIGRP summary is 5.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The eigrp summary-address command is used to configure a summary address on an interface for a topology instance. EIGRP summary routes are given an administrative distance value of 5 to allow the summary to be advertised without being installed in the routing table.

Examples

The following example shows how to create a summary of the 10.100.1.0/24 network and apply an administrative distance of 65 to routes summarized by this statement:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast RED 
Device(config-if-topology)# eigrp 1 summary-address 10.100.1.0 0.0.0.255 65 
Device(config-if-topology)# end 

Related Commands

Command

Description

topology (EIGRP)

Configures an EIGRP process to route IP traffic under the specified topology instance.

topology (interface)

Configures an MTR topology instance on an interface.

exit-global-af

To exit global address family configuration mode and enter global configuration mode, use the exit-global-af command in global address family configuration mode.

exit-global-af

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values.

Command Modes

Global address family configuration (config-af)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The exit-global-af command is used to exit global address family configuration mode without removing global topology configuration.

Examples

The following example shows how to exit from global address family configuration mode:

Device(config-af)# exit-global-af 
Device(config)#

Related Commands

Command

Description

global-address-family ipv4

Enters enter address family topology configuration mode to configure MTR.

service-policy type class-routing

Attaches the service policy to the policy map for MTR traffic classification and to enable MTR.

exit-if-topology

To exit interface topology configuration mode, use the exit-if-topology command in interface topology configuration mode.

exit-if-topology

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Examples

The following example, starting in global configuration mode, shows how to exit interface topology configuration mode:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast RED 
Device(config-if-topology)# exit-if-topology 
Device(config-if-topology)# end 

Related Commands

Command

Description

topology (interface)

Configures an MTR topology instance on an interface.

exit-topo

To exit address family topology configuration mode and enter global address family configuration mode, use the exit-topo command in address family topology configuration mode.

exit-topo

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values.

Command Modes

Address family topology configuration (config-af)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The exit-topo command is used to exit from address family topology configuration mode.

Examples

The following example shows how to exit address family topology configuration mode and enter global address family configuration mode:

Device(config-af-topology)# exit-topo 
Device(config-af)# 

Related Commands

Command

Description

all-interfaces

Configures a topology instance to use all interfaces on a device.

forward-base

Configures the forwarding mode under a topology instance.

maximum routes (MTR)

Sets the maximum number of routes that a topology instance will accept and install into the RIB.

shutdown

Temporarily disables a topology instance without removing the topology configuration.

topology (global)

Configures a topology instance.

forward-base

To configure the forwarding mode under a topology instance, use the forward-base command in address family topology configuration mode. To return to strict forwarding mode, use the no form of this command.

forward-base

no forward-base

Syntax Description

This command has no arguments or keywords.

Command Default

Strict forwarding mode

Command Modes

Address family topology configuration (config-af-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The forward-base command is used in incremental deployment.

The forward-base command is used to configure the forwarding rule, under which traffic is forwarded for a topology. MTR supports both full and incremental deployment configurations. For full deployment, MTR supports a strict forwarding mode (default) longest-match lookup in only the forwarding table of the corresponding class-specific topology. If no route is found, the packet is dropped. For incremental deployment, MTR supports a longest-match lookup first in the forwarding table for the corresponding class-specific topology, and subsequently, in the base topology if no class-specific entry is found. If a route is not found in the base topology, the packet is then dropped.

Examples

The following example shows how to configure strict forwarding mode under the VOICE topology:

Device(config)# global-address-family ipv4 
Device(config-af)# topology VOICE 
Device(config-af-topology)# no forward-base 
Device(config-af-topology)# end 

Related Commands

Command

Description

all-interfaces

Configures a topology instance to use all interfaces on a device.

exit-topo

Exits routing topology configuration mode, and enters global address family topology configuration mode.

maximum routes (MTR)

Sets the maximum number of routes that a topology instance will accept and install into the RIB.

shutdown

Temporarily disables a topology instance without removing the topology configuration.

topology (global)

Configures a topology instance.

global-address-family ipv4

To enter global address family configuration mode to configure Multitopology Routing (MTR), use the global-address-family ipv4 command in global configuration mode. To disable and remove all topology configuration from the device configuration, use the no form of this command.

global-address-family ipv4 [ multicast | unicast ]

no global-address-family ipv4 [ multicast | unicast ]

Cisco IOS Release 15.2(3)T and later releases

global-address-family ipv4 multicast

no global-address-family ipv4 multicast

Syntax Description

multicast

(Optional) Enters multicast subaddress family configuration mode.

In Cisco IOS Release 15.2(3)T and later releases, the multicast keyword is required.

unicast

(Optional) Enters unicast subaddress family configuration mode. This is the default.

Command Default

Unicast global address family configuration mode is the default when no optional keywords are entered.

Command Modes

Global configuration (config)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

15.2(3)T

This command was modifed. In Cisco IOS Release 15.2(3)T, the multicast keyword is no longer optional and the unicast keyword is not supported.

Usage Guidelines

The global-address-family ipv4 command is used to enter global address family configuration mode to configure MTR. Global topology configurations are entered in this configuration mode. Independent routing and forwarding tables are maintained for each topology, allowing you to configure separate forwarding rules on a per-topology basis. Cisco Express Forwarding (CEF) and IP routing must be enabled before MTR can be configured. The topology (global) command is entered to configure the base or a class-specific topology.

To completely remove all topologies from the device configuration, use the no global-address-family ipv4 command in global configuration mode. To disable a topology without removing it from the configuration of the device, use the shutdown command in address family topology configuration mode. If the no ip routing global configuration command is used, all topology configuration is retained, but topologies will be operationally disabled.

Examples

The following example creates a topology instance named VOICE. The device is configured to use all interfaces for the VOICE topology.

Device(config)# global-address-family ipv4 
Device(config-af)# topology VOICE 
Device(config-af-topology)# all-interfaces 
Device(config-af-topology)# end 

The following example shows how to create a topology instance named VIDEO and places this topology in a shutdown state:

Device(config)# global-address-family ipv4 
Device(config-af)# topology VIDEO 
Device(config-af-topology)# shutdown 
Device(config-af-topology)# end 

Related Commands

Command

Description

exit-global-af

Exits global address family configuration and enters global configuration mode.

shutdown

Temporarily disables a topology instance without removing the topology configuration.

topology (global)

Configures a topology instance.

import topology

To configure Border Gateway Protocol (BGP) to import routes from one Multitopology Routing (MTR) topology to another on the same device, use the import topology command in router scope address family topology configuration mode. To disable the import configuration, use the no form of this command.

import topology { topology-name | base } [ route-map map-name ]

no import topology { topology-name | base } [ route-map map-name ]

Syntax Description

topology-name

Name of topology instance.

base

Imports routes from the base topology.

route-map map-name

(Optional) Specifies a route map to filter imported routes.

Command Default

No routes are imported from other topologies.

Command Modes

Router scope address family topology configuration

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

The import topology command is used to configure BGP to import routes from one topology to another when multiple topologies are configured on the same device. The name of the class-specific topology or the base topology is specified when entering this command. Best-path calculations are run on the imported routes before they are installed into the topology routing information base (RIB). If a duplicate route is imported, BGP will select and install only one instance of the route per standard BGP best-path calculation behavior. This command also includes a route-map keyword to allow you to filter routes that are moved between class-specific topologies.

Examples

The following example configures BGP to import routes from a topology instance named VIDEO into the local topology instance. Imported routes are filtered through the route map named 10NET, which permits routes from the 10.0.0.0 network.

Device(config)# ip prefix-list 10 permit 10.0.0.0/8 
Device(config)# route-map 10NET 
Device(config-route-map)# match ip address prefix-list 10 
Device(config-route-map)# exit 
Device(config)# router bgp 50000 
Device(config-router)# scope global
Device(config-router-scope)# address-family ipv4 
Device(config-router-scope-af)# topology VOICE 
Device(config-router-scope-af-topo)# import topology VIDEO route-map 10NET 
Device(config-router-scope-af-topo)# end 

Related Commands

Command

Description

bgp tid

Configures BGP to accept routes with a specified topology ID.

clear ip bgp topology

Resets BGP neighbor session information under a topology instance.

neighbor translate-topology

Configures BGP to translate or move routes from a topology on another device to a topology on the local device.

scope

Defines the scope for a BGP routing session and enters router scope configuration mode.

topology (BGP)

Configures a process to route IP traffic under the specified topology instance.

ip multicast rpf multitopology

To enable Multitopology Routing (MTR) support for IP multicast routing, use the ip multicast rpf multitopology command in global configuration mode. To disable MTR support for IP multicast routing, use the no form of this command.

ip multicast rpf multitopology

no ip multicast rpf multitopology

Syntax Description

This command has no arguments or keywords.

Command Default

No default behavior or values

Command Modes

Global configuration (config)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

15.0(1)M

This command was integrated into Cisco IOS Release 15.0(1)M.

15.0(1)SY

This command was integrated into Cisco IOS Release 15.0(1)SY.

Examples

The following example shows how to enable MTR support for IP multicast routing:

Device(config)# ip multicast-routing
Device(config)# ip multicast rpf multitopology

ip ospf cost (MTR)

To configure the Open Shortest Path First (OSPF) interface cost under a topology instance, use the ip ospf cost command in interface topology configuration mode. To remove the interface cost configuration, use the no form of this command.

ip ospf cost value

no ip ospf cost

Syntax Description

value

Cost for the interface. The range is 1 to 65535.

Command Default

The cost configured in interface configuration is inherited.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Examples

The following example configures the interface cost to be 1000:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast DATA 
Device(config-if-topology)# ip ospf cost 1000 
Device(config-if-topology)# end 

ip ospf topology disable

To prevent an Open Shortest Path First (OSPF) process from advertising the interface as part of the topology, use the ip ospf topology disable command in interface topology configuration mode. To enable the OSPF process to advertise the interface as a part of the topology, use the no form of this command.

ip ospf topology disable

no ip ospf topology disable

Syntax Description

This command has no arguments or keywords.

Command Default

The OSPF process advertises the interface as a part of the topology.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Usage Guidelines

The ip ospf topology disable command is used to prevent an OSPF process from advertising the interface as a part of the topology, without removing the OSPF or topology configuration from the interface.

Examples

The following example disables OSPF routing under the topology instance named VOICE on Ethernet interface 0/0:

Device(config)# interface Ethernet 0/0 
Device(config-if)# topology ipv4 unicast VOICE 
Device(config-if-topology)# ip ospf topology disable 
Device(config-if-topology)# end 

Related Commands

Command

Description

area capability default-exclusion

Configures an OSPF process to allow interfaces to be excluded from the MTR base topology.

ip route topology

To configure static routing under a topology instance, use the ip route topology command in global configuration mode. To remove the static route, use the no form of this command.

ip route topology topology-name destination-address destination-mask { forwarding-address | interface [forwarding-address] } [dhcp] [distance] [multicast] [ name name ] [permanent] [ tag value ] [ track number ]

no ip route topology topology-name { * | destination-address destination-mask { forwarding-address | interface [forwarding-address] } } [dhcp] [distance] [multicast] [ name name ] [permanent] [ tag value ] [ track number ]

Syntax Description

topology-name

Name of the topology instance.

destination-address

IP address of the destination.

destination-mask

IP address mask of the destination.

forwarding-address

IP forwarding address (next hop) to the destination network.

interface

Interface type and interface number.

dhcp

(Optional) Enables a Dynamic Host Configuration Protocol (DHCP) server to assign a static route to a default gateway (option 3).

  • Specify the dhcp keyword for each routing protocol.

distance

(Optional) An administrative distance metric for the route.

multicast

(Optional) Configures the route as a multicast static route.

name name

(Optional) Applies a name to the specified route.

permanent

(Optional) Specifies that the route will not be removed, even if the interface is shut down.

tag value

(Optional) Tag value that can be used as a “match” value for controlling redistribution via route maps.

track number

(Optional) Installs the static route based on the conditions set for the tracked object. The argument specifies an object number, which can be a number from 1 to 500.

*

Specifies all static routes. This keyword can be entered only with the no form of this command.

Command Default

No static route is configured.

Command Modes

Global configuration (config)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The ip route topology command is used to configure static routing under a topology instance. The global topology name is entered when the static route is created in global configuration mode.

Examples

The following example configures a static route to the 10.0.0.0 network through Ethernet interface 0/0:

Device(config)# ip route topology VOICE 10.0.0.0 255.0.0.0 Ethernet 0/0 

Related Commands

Command

Description

clear ip route topology

Clears entries from the routing table of a topology.

ping (MTR)

Diagnoses basic network connectivity through a topology instance.

show ip protocols topology

Displays the configuration and state of active routing protocol processes under a topology instance.

show ip route topology

Displays the current state of a topology routing table.

show topology

Displays status and configuration information for topologies configured with MTR.

ip topology-accounting

To enable topology accounting for all IPv4 unicast topologies in the VPN Routing/Forwarding (VRF) associated with a particular interface, use the ip topology-accounting command in interface configuration mode. To disable topology accounting, use the no form of this command.

ip topology-accounting

no ip topology-accounting

Syntax Description

This command has no arguments or keywords.

Command Default

No topology accounting statistics are collected.

Command Modes

Interface configuration (config-if)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

This command enables topology accounting for all IPv4 unicast topologies in the VRF associated with a particular interface regardless of whether those topologies are enabled on the interface or not. In Cisco IOS release 12.2(33)SRB, this topology accounting is only supported for the default VRF.

Examples

The following example shows how to enable topology accounting on FastEthernet interface 1/10:

Device(config)# interface FastEthernet 1/10
Device(config-if)# ip topology-accounting

Related Commands

Command

Description

topology-accounting

Enables topology accounting on all of the interfaces in the global address family.

isis topology disable

To prevent an Intermediate System-to-Intermediate System (IS-IS) process from advertising the interface as part of the topology, use the isis topology disable command in interface topology configuration mode. To enable the IS-IS process to advertise the interface as a part of the topology, use the no form of this command.

isis topology disable

no isis topology disable

Syntax Description

This command has no arguments or keywords.

Command Default

The IS-IS process advertises the interface as a part of the topology.

Command Modes

Interface topology configuration (config-if-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

The isis topology disable command is used to prevent an IS-IS process from advertising the interface as a part of the topology without removing the IS-IS or topology configuration from the interface.

Examples

The following example disables IS-IS routing under the topology instance named VOICE on Ethernet interface 0/0:

Device(config)# interface Ethernet 0/0
Device(config-if)# topology ipv4 unicast VOICE 
Device(config-if-topology)# isis topology disable 
Device(config-if-topology)# end 

Related Commands

Command

Description

address-family (IS-IS)

Configures the exchange of address family and subaddress family prefixes.

topology (interface)

Configures an MTR topology instance on an interface.

topology (IS-IS)

Configures an IS-IS process to route IP traffic under the specified topology instance.

maximum routes (MTR)

To set the maximum number of routes that a topology instance will accept and install into the routing information base (RIB), use the maximum routes command in address family topology configuration mode. To remove the route limit for the topology instance, use the no form of this command.

maximum routes number [ threshold [ reinstall threshold ] | warning-only ]

no maximum routes number [ threshold [ reinstall threshold ] | warning-only ]

Syntax Description

number

Maximum number of routes. The range is 1 to 4294967295.

threshold

(Optional) Threshold percentage, at which warning messages are generated. The range is 1 to 100.

reinstall threshold

(Optional) Configures the threshold percentage, at which routes are reinstalled into the routing table. The range is 1 to 100.

warning-only

(Optional) Configures the device to only display a warning when the maximum route limit has been reached or exceeded.

Command Default

No default behavior or values.

Command Modes

Address family topology configuration (config-af-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The maximum routes command is used to set a limit for the number of routes that will be accepted for a topology instance and installed into the RIB. This command can be configured to set the absolute maximum limit, to generate warning messages when the specified percentage of the limit has been reached, and to configure the percentage (low-water mark), at which routes are reinstalled into the RIB after the maximum limit has been reached.

Examples

The following example shows how to configure the device to accept a maximum of 10000 routes for the VOICE topology and to generate warning messages when 80 percent of the maximum limit has been reached. This example also configures the device to accept routes after the limit has been exceeded but then receded to 40 percent of the maximum number.

Device(config)# global-address-family ipv4
Device(config-af)# topology VOICE
Device(config-af-topology)# maximum routes 10000 80 reinstall 40
Device(config-af-topology)# end
 

Related Commands

Command

Description

all-interfaces

Configures a topology instance to use all interfaces on a device.

exit-topo

Exits routing topology configuration mode, and enters global address family topology configuration mode.

forward-base

Configures the forwarding mode under a topology instance.

shutdown

Temporarily disables a topology instance without removing the topology configuration.

topology (global)

Configures a topology instance.

neighbor translate-topology

To configure the Border Gateway Protocol (BGP) to translate or move routes from a topology on another device to a topology on the local device, use the neighbor translate-topology command in router scope address family topology configuration mode. To disable the topology translation configuration, use the no form of this command.

neighbor ip-address translate-topology number

no neighbor ip-address translate-topology number

Syntax Description

ip-address

IP address of the neighbor.

number

Topology ID of the neighbor. The range is 1 to 4095.

Command Default

No routes are translated from a topology on another device.

Command Modes

Router scope address family topology configuration (config-router-scope-af-topo))

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

The neighbor translate-topology command is used to translate or move routes from a Multitopology Routing (MTR) class-specific topology on a neighbor device to the local topology under which the BGP session is configured. The topology ID identifies the class-specific topology of the neighbor. The routes in the class-specific topology of the neighbor are moved into a local class-specific topology RIB. BGP performs best-path calculation on imported routes and installs these routes into the local class-specific RIB. If a duplicate route is translated, BGP will select and install only one instance of the route per standard BGP best-path calculation behavior.

Examples

The following example shows how to configure BGP to translate the topology with the 255 ID from the 192.168.3.1 neighbor:

Device(config)# router bgp 50000
Device(config-router)# scope global
Device(config-router-scope)# bgp default ipv4-unicast
Device(config-router-scope)# neighbor 192.168.3.1 remote-as 45000
Device(config-router-scope)# address-family ipv4 unicast
Device(config-router-scope-af)# topology VOICE 
Device(config-router-scope-af-topo)# bgp tid 100 
Device(config-router-scope-af-topo)# neighbor 192.168.3.1 activate
Device(config-router-scope-af-topo)# neighbor 192.168.3.1 translate-topology 255
Device(config-router-scope-af-topo)# end 

Related Commands

Command

Description

bgp tid

Configures BGP to accept routes with a specified topology ID.

clear ip bgp topology

Resets BGP neighbor session information under a topology instance.

import topology

Configures BGP to import or move routes from one topology to another on the same device.

scope

Defines the scope for a BGP routing session and enters router scope configuration mode.

topology (BGP)

Configures a process to route IP traffic under the specified topology instance.

neighbor transport

To enable a TCP transport session option for a Border Gateway Protocol (BGP) session, use the neighbor transport command in router or address family configuration mode. To disable a TCP transport session option for a BGP session, use the no form of this command.

neighbor { ip-address | peer-group-name } transport { connection-mode { active | passive } | path-mtu-discovery [disable] | multi-session | single-session }

no neighbor { ip-address | peer-group-name } transport { connection-mode | path-mtu-discovery | multi-session | single-session }

Syntax Description

ip-address

IP address of the BGP neighbor.

peer-group-name

Name of a BGP peer group.

connection-mode

Specifies the type of connection (active or passive).

active

Specifies an active connection.

passive

Specifies a passive connection.

path-mtu-discovery

Enables TCP transport path maximum transmission unit (MTU) discovery. TCP path MTU discovery is enabled by default.

multi-session

Enables a separate TCP transport session for each address family.

single-session

Enables all address families to use a single TCP transport session.

disable

Disables TCP path MTU discovery.

Command Default

If this command is not configured, TCP path MTU discovery is enabled by default, but no other TCP transport session options are enabled.

Command Modes

Router configuration (config-router)

Address family configuration (config-router-af)

Command History

Release

Modification

12.4

This command was introduced.

12.2(33)SRA

This command was modified. The path-mtu-discovery keyword was added.

12.2(33)SRB

This command was modified. The multi-session, single-session, and disable keywords were added.

12.2SX

This command is supported in the Cisco IOS Release 12.2SX train. Support in a specific 12.2SX release of this train depends on your feature set, platform, and platform hardware.

12.4(20)T

This command was modified. The path-mtu-discovery keyword was added.

Cisco IOS XE Release 2.5

This command was integrated into Cisco IOS XE Release 2.5.

Usage Guidelines

This command is used to specify various transport options. An active or passive transport connection can be specified for a BGP session. TCP transport path MTU discovery can be enabled to allow a BGP session to take advantage of larger MTU links. Use the show ip bgp neighbors command to determine whether TCP path MTU discovery is enabled.

In Cisco IOS Release 12.2(33)SRB and later releases, options can be specified for the transport of address family traffic using a single TCP session or to enable a separate TCP session for each address family. Multiple TCP sessions are used to support Multitopology Routing (MTR), and the single session option is available for backwards compatibility for non-MTR configurations and for scalability purposes.

In Cisco IOS Release 12.2(33)SRB and later releases, the ability to disable TCP path MTU discovery, for a single neighbor or for an inheriting peer or peer group, was added. If you use the disable keyword to disable discovery, discovery is also disabled on any peer or peer group that inherits the template in which you disabled discovery.

Examples:

The following example shows how to configure the TCP transport connection to be active for a single internal BGP (iBGP) neighbor:

router bgp 45000
 neighbor 172.16.1.2 remote-as 45000
 neighbor 172.16.1.2 activate
 neighbor 172.16.1.2 transport connection-mode active
 end

The following example shows how to configure the TCP transport connection to be passive for a single external BGP (eBGP) neighbor:

router bgp 45000
 neighbor 192.168.1.2 remote-as 40000
 neighbor 192.168.1.2 activate
 neighbor 192.168.1.2 transport connection-mode passive
 end

The following example shows how to disable TCP path MTU discovery for a single BGP neighbor:

router bgp 45000
 neighbor 172.16.1.2 remote-as 45000
 neighbor 172.16.1.2 activate
 no neighbor 172.16.1.2 transport path-mtu-discovery
 end

The following example shows how to reenable TCP path MTU discovery for a single BGP neighbor, if TCP path MTU discovery is disabled:

router bgp 45000
 neighbor 172.16.1.2 remote-as 45000
 neighbor 172.16.1.2 activate
 neighbor 172.16.1.2 transport path-mtu-discovery
 end

The following example shows how to enable a separate TCP session for each address family for an MTR topology configuration:

router bgp 45000
 scope global
  neighbor 172.16.1.2 remote-as 45000
  neighbor 172.16.1.2 transport multi-session
  address-family ipv4
   topology VIDEO 
   bgp tid 100
   neighbor 172.16.1.2 activate
   end

The following example shows how to disable TCP path MTU discovery and verify that it is disabled:

router bgp 100
 bgp log-neighbor-changes
 timers bgp 0 0
 redistribute static
 neighbor 10.4.4.4 remote-as 100
 neighbor 10.4.4.4 update-source Loopback 0
!end
Device# show ip bgp neighbors 10.4.4.4 | include path
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0
  Transport(tcp) path-mtu-discovery is enabled 
Option Flags: nagle, path mtu capable
Device#
Device# configure terminal
Device(config)# router bgp 100
Device(config-router)# neighbors 10.4.4.4 transport path-mtu-discovery disable 
Device(config-router)# end
Device# show ip bgp neighbor 10.4.4.4 | include path
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0
  Transport(tcp) path-mtu-discovery is disabled 

Related Commands

Command

Description

bgp tid

Configures BGP to accept routes with a specified topology ID.

bgp transport

Enables transport session parameters globally for all BGP neighbor sessions.

scope

Defines the scope for a BGP routing session and enters router scope configuration mode.

show ip bgp neighbors

Displays information about BGP and TCP connections to neighbors.

topology (BGP)

Configures a process to route IP traffic under the specified topology instance.

ping (MTR)

To ping a destination within a specific topology for Multitopology Routing (MTR), use the ping command in user EXEC or privileged EXEC mode.

ping [ vrf vrf-name | topology topology-name ] protocol [target-address] [source-address]

Syntax Description

vrf vrf-name

(Optional) Specifies the name of a VPN routing and forwarding (VRF) instance.

topology topology-name

(Optional) Specifies the name of a topology.

protocol

Supported protocol. The default is IP. If a protocol is not specified at the command line, it will be required in the ping system dialog.

target-address

(Optional) Target IP address or hostname of the system to ping. If a target IP address or a hostname is not specified at the command line, it will be required in the ping system dialog.

source-address

(Optional) Source address initiating the ping. If a source address is not specified at the command line, it will be required in the ping system dialog.

Command Default

No default behavior or values.

Command Modes

User EXEC (>)

Privileged EXEC (#)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The ping (MTR) command is used to send an echo request to a topology instance. The functionality of this command is similar to the standard ping command used in Cisco software. Ping output can help you evaluate path-to-host reliability, delays over the path, and whether the host can be reached or is functioning.

The topology topology-name keyword and argument and the DiffServ Code Point (DSCP) option in the extended ping system dialog are displayed only if there is a topology configured on the device.

If you enter the ping command without any other syntax (ping<cr>), an interactive system dialog prompts you for the additional syntax appropriate to the protocol you specify (see the “Examples” section).

Examples

After you enter the ping command in privileged EXEC mode, the system prompts you for a protocol. The default protocol is IP.

If you enter a hostname or address on the same line as the ping command, the default action is taken as appropriate for the protocol type of that name or address.

The following example is sample dialog from the ping command using default values. The specific dialog varies somewhat from protocol to protocol.

Device# ping
Protocol [ip]:
Target IP address: 192.168.7.27
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:y
Source address of interface: 10.0.20.1
DSCP Value [0]: 
! The Type of Service (TOS) is displayed below only if the DSCP value is 0.
Type of Service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose [none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.7.27, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 1/2/4 ms 

The table below describes the significant fields shown in the display.

Table 1  ping Field Descriptions for IP

Field

Description

Protocol [ip]:

Prompts for a supported protocol. Default is IP.

Target IP address:

Prompts for the IP address or hostname of the destination node you plan to ping. If you have specified a supported protocol other than IP, enter an appropriate address for that protocol here. Default: none.

Repeat count [5]:

Number of ping packets that will be sent to the destination address. Default: 5.

Datagram size [100]:

Size of the ping packet (in bytes). Default: 100 bytes.

Timeout in seconds [2]:

Timeout interval. Default: 2 (seconds).

Extended commands [n]:

Specifies whether a series of additional commands appears.

DSCP Value [10]:

DiffServ Code Point. Six bits in the ToS. These are the bits used to mark the packet.

Sweep range of sizes [n]:

Allows you to vary the sizes of the echo packets being sent. This capability is useful for determining the minimum sizes of the maximum transmission units (MTUs) configured on the nodes along the path to the destination address. Packet fragmentation contributing to performance problems can then be reduced.

!!!!!

Each exclamation point (!) indicates receipt of a reply. A period (.) indicates that the network server timed out while waiting for a reply. Other characters may appear in the ping output display, depending on the protocol type.

Success rate is 100 percent

Percentage of packets successfully echoed back to the device. Anything less than 80 percent is usually considered problematic.

round-trip min/avg/max = 1/2/4 ms

Round-trip travel time intervals for the protocol echo packets, including minimum/average/maximum (in milliseconds).

Related Commands

Command

Description

clear ip route topology

Clears entries from the routing table of a topology.

ip route topology

Configures static routing under a topology instance.

show ip protocols topology

Displays the configuration and state of active routing protocol processes under a topology instance.

show ip route topology

Displays the current state of a topology routing table.

show topology

Displays status and configuration information for topologies configured with MTR.

policy-map type class-routing ipv4 unicast

To create or modify a policy map for Multitopology Routing (MTR) and enter policy map configuration mode, use the policy-map type class-routing ipv4 unicast command in global configuration mode. To delete the policy map, use the no form of this command.

policy-map type class-routing ipv4 unicast policy-map-name

no policy-map type class-routing ipv4 unicast policy-map-name

Syntax Description

policy-map-name

Name of the MTR policy map.

Command Default

An MTR policy map name is not created.

Command Modes

Global configuration (config)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The policy map name created by the policy-map type class-routing ipv4 unicast command is referenced by the service-policy type class-routing command to enable MTR.

Examples

In the following example, an MTR policy map named BLUE is created that will be attached to the service policy to enable MTR:

Device(config)# policy-map type class-routing ipv4 unicast BLUE 
Device(config-pmap)# class DATA 
Device(config-pmap-c)# select-topology VOICE 
Device(config-pmap-c)# exit
Device(config-pmap)# exit
Device(config)# global-address-family ipv4 
Device(config-af)# service-policy type class-routing BLUE
Device(config-af)# end 

Related Commands

Command

Description

service-policy type class-routing

Attaches the service policy to the policy map for MTR traffic classification and enables MTR.

priority (OSPF)

To set the priority that an Open Shortest Path First (OSPF) process assigns to a topology instance for shortest path first (SPF) calculations, use the priority command in router address family topology configuration mode. To return the priority to the default value, use the no form of this command.

priority number

no priority

Syntax Description

number

Priority number for a topology instance. The range is 0 to 127. The default is 64.

Command Default

The default priority number is 64.

Command Modes

Router address family topology configuration (config-router-af-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

Usage Guidelines

The priority command is used to set the OSPF processing order for topology instances when an SPF calculation is scheduled and ready to run for multiple topologies. The topology with the highest priority number is processed first. The default priority value is 64.

Examples

The following example assigns the VOICE topology instance the highest possible priority for SPF calculations:

Device(config)# router ospf 1
Device(config-router)# address-family ipv4 
Device(config-router-af)# topology VOICE tid 10
Device(config-router-af-topology)# priority 127
Device(config-router-af-topology)# end
 

Related Commands

Command

Description

address-family (OSPF)

Configures address family and subaddress family IP prefix exchange.

topology (OSPF)

Configures an OSPF process to route IP traffic under the specified topology instance.

router eigrp (MTR)

To configure the Enhanced Interior Gateway Routing Protocol (EIGRP) process for Multitopology Routing (MTR) and enter router configuration mode, use the router eigrp command in global configuration mode. To shut down an EIGRP routing process, use the no form of this command.

router eigrp block-name

no router eigrp block-name

Syntax Description

block-name

Routing configuration block name.

Command Default

This command is disabled by default.

Command Modes

Global configuration (config)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

Usage Guidelines

The router eigrp block-name command allows access to MTR topology commands in router address family configuration mode. The topology commands are blocked if using the legacy router eigrp as-number command. You can use the router eigrp block-name command if MTR is not configured, but the topology defaults to the base topology.

Examples

The following example shows how to configure EIGRP for MTR and how to configure an IPv4 address family to associate with the MTR service topology named VIDEO:

Device(config)# router eigrp mtr
Device(config-router)# address-family ipv4 autonomous-system 5
Device(config-router-af)# topology VIDEO tid 100

Related Commands

Command

Description

router eigrp

Configures the EIGRP process.

route-replicate

To enable the replication of routes from one topology to another, use the route-replicate command in address family topology configuration mode. To disable route replication, use the no form of this command.

route-replicate from { multicast | unicast } [ topology { base | name } ] protocol [ route-map map-tag | vrf name

no route-replicate from { multicast | unicast } [ topology { base | name } ] protocol [ route-map map-tag | vrf name

Syntax Description

from

Specifies from which topology route replication is enabled.

multicast

Specifies a multicast subaddress family identifier (SAFI).

unicast

Specifies a unicast SAFI.

topology

(Optional) Specifies the source topology.

base

Specifies the base topology.

name

Topology instance name.

protocol

The owning protocol that is the source of the route. Valid keywords include:

  • all—Specifies all routes.
  • bgp—Specifies Border Gateway Protocol. An autonomous system number must be specified with this keyword. The range is 1 to 65535.
  • eigrp—Specifies Enhanced Interior Gateway Routing Protocol. An autonomous system number or a routing configuration block name must be specified with this keyword. The range is 1 to 65535; the block name can be up to 32 characters in length.
  • isis—Specifies ISO Intermediate System-to-Intermediate System (IS-IS). An optional ISO area routing tag or the route-map keyword can be used.
  • mobile—Specifies mobile routes. The optional route-map keyword can be used.
  • odr—Specifies on-demand stub routes. The optional route-map keyword can be used.
  • ospf—Specifies Open Shortest Path First (OSPF). A process ID must be specified with this keyword. The range is 1 to 65535. The optional route-map keyword or vrfname keyword and argument can be used.
  • rip—Specifies Routing Information Protocol. The optional route-map map-tag keyword and argument can be used.
  • static—Specifies static routes. The optional route-map map-tag keyword and argument can be used.

route-map map-tag

(Optional) Specifies a route map filter.

vrf name

(Optional) Specifies a VPN routing and forwarding (VRF) instance name.

Command Default

Route replication is disabled.

Command Modes

Address family topology configuration (config-af-topology)

Command History

Release

Modification

12.2(33)SRB

This command was introduced.

12.2(33)SRE

This command was integrated into Cisco IOS Release 12.2(33)SRE.

15.2(1)S

This command was modified. The behavior of the command changed, and the software does not allow you to replicate routes from a multicast RIB to a unicast RIB. For more information, see the "Usage Guidelines."

Usage Guidelines

Use this command to replicate routes from one topology to another. Route replication supports legacy multicast behavior and may be used to support scenarios in which not all protocols support multiple topologies.

In Cisco IOS Release 15.2(1)S, you cannot replicate routes from a multicast RIB to a unicast RIB. However, you can replicate routes from a multicast RIB to a multicast RIB or replicate routes from a unicast RIB to a multicast RIB.

For the multicast and unicast keywords, the address family identifier (AFI) is the same as the AFI of the destination table.

If the forwarding mode of the destination topology is set to incremental mode (forward-base), the route replication configuration commands are rejected.

If the mobile, odr, rip, or static keyword is used for the protocol argument, the optional vrf name keyword and argument cannot be used.

Examples

The following example shows how to configure the multicast topology to replicate OSPF routes from the VOICE topology. The routes are filtered through the map1 route map before they are installed in the multicast routing table.

Device(config)# ip multicast-routing
Device(config)# ip multicast rpf multitopology
Device(config)# global-address-family ipv4 multicast
Device(config-af)# topology base
Device(config-af-topology)# route-replicate from unicast topology VOICE ospf 3 route-map map1