IP Mobility: PMIPv6 Configuration Guide, Cisco IOS XE Release 3S
PMIP: Multipath Support on MAG and LMA
Downloads: This chapterpdf (PDF - 1.41MB) The complete bookPDF (PDF - 2.52MB) | Feedback

PMIP: Multipath Support on MAG and LMA

Contents

PMIP: Multipath Support on MAG and LMA

The PMIP: Multipath Support on MAG and LMA feature enables the Mobile Access Gateway (MAG) to register multiple transport end-points with the Local Mobility Anchor (LMA), allowing the MAG and LMA to establish multiple tunnels and apply path selection on a flow basis.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for PMIP: Multipath Support for MAG and LMA

You must configure UDP as the tunnel encapsulation mode on Mobile Access Gateway (MAG) and the Local Mobility Anchor (LMA).

Information About PMIP: Multipath Support for MAG and LMA

Local Mobility Anchor

Local Mobility Anchor (LMA) is the home agent for a mobile node (MN) in a Proxy Mobile IPv6 (PMIPv6) domain. It is the topological anchor point for MN home network prefixes and manages the binding state of an MN. An LMA has the functional capabilities of a home agent as defined in the Mobile IPv6 base specification (RFC 3775) along with the capabilities required for supporting the PMIPv6 protocol.


Note


Use an dynamic mag learning command to enable an LMA to accept Proxy Mobile IPv6 (PMIPv6) signaling messages from any Mobile Access Gateway (MAG) that is not locally configured.


Mobile Access Gateways

A Mobile Access Gateway (MAG) performs mobility-related signaling on behalf of the mobile nodes (MN) attached to its access links. MAG is the access router for the MN; that is, the MAG is the first-hop router in the localized mobility management infrastructure.

A MAG performs the following functions:

  • Obtains an IP address from a Local Mobility Anchor (LMA) and assigns it to an MN
  • Retains the IP address of an MN when the MN roams across MAGs
  • Tunnels traffic from an MN to LMA

Mobile Node

A mobile node (MN) is an IP host whose mobility is managed by the network. An MN can be an IPv4-only node, an IPv6-only node, or a dual-stack node, which is a node with IPv4 and IPv6 protocol stacks. An MN is not required to participate in any IP mobility-related signaling for achieving mobility for an IP address or a prefix that is obtained in the Proxy Mobile IPv6 (PMIPv6) domain.

Multipath Support

At any given time, many network paths exists between the Local Mobility Anchor (LMA) and Mobile Access Gateway (MAG). The PMIP: Multipath Support on MAG and LMA feature enables the MAG to select any one of the paths on priority basis or select all the existing network paths simultaneously to create tunnels to reach the LMA. All the paths have the same priority when multiple paths are selected.

Mobile Map

Mobile map configuration facilitates application-based routing. More than one mobile map can be configured under the Proxy Mobile IPv6 (PMIPv6) domain, however, at a given point of time, only one mobile map is active at the Mobile Access Gateway (MAG) and the Local Mobility Anchor (LMA). The mobile map and its entries are configured or modified when no bindings are available.

Logical Mobile Node

Logical mobile node (LMN) is a logical entity that represents a mobile node (MN) that is hosted on one of the interfaces of the Mobile Access Gateway (MAG) device. The LMN has a Network Access Indicator (NAI) similar to a regular MN. One or more networks can be associated with each LMN through the interfaces designated as mobile network interfaces. An LMN on mobile network receives an IP address from a DHCP server that runs on the MAG, unlike a mobile node whose address is assigned by the Local Mobility Anchor (LMA).

MAG to MAG Traffic Blocking on the PMIPv6 LMA

To prevent communication between PMIPv6 clients such as, mobile nodes (MNs), or entire mobile networks, that are connected to the same Local Mobility Anchor (LMA), the inter-MAG tunnel traffic is blocked by applying access control list (ACL) on the PMIPv6 tunnels. To enable the blockage of inter-MAG tunnel traffic, the prefixes of all the PMIPv6 addresses mentioned in the address pool configured on the LMA, must be entered in the ACL.

How to Configure PMIP: Multipath Support for MAG and LMA

Configuring PMIP: Multipath Support for MAG and LMA

Configuring UDP Encapsulation for a PMIPv6 Domain

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    ipv6 mobile pmipv6-domain domain-name

    4.    encap udptunnel

    5.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 ipv6 mobile pmipv6-domain domain-name


    Example:
    Device(config)# ipv6 mobile pmipv6-domain dn1
     

    Creates a PMIPv6 domain and enters PMIPv6 domain configuration mode.

     
    Step 4 encap udptunnel


    Example:
    Device(config-ipv6-pmipv6-domain)# encap udptunnel
     

    Configures the tunnel encapsulation mode type between the Mobile Access Gateway (MAG) and the Local Mobility Anchor (LMA).

     
    Step 5 end


    Example:
    Device(onfig-ipv6-pmipv6-domain)# end
     

    Exits PMIPv6 domain configuration mode and enters privileged EXEC mode.

     

    Configuring Roaming Interface

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    ipv6 mobile pmipv6-mag mag-id domain domain-name

      4.    addressdynamic

      5.    roaming interface type number

      6.    exit


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 ipv6 mobile pmipv6-mag mag-id domain domain-name


      Example:
      Device(config)# ipv6 mobile pmipv6-mag mag1 domain dn1
       

      Enables MAG service on a device, configures the PMIPv6 domain for the MAG, and enters MAG configuration mode.

       
      Step 4 addressdynamic


      Example:
      Device(config-ipv6-pmipv6-mag)# address dynamic
       

      Configures dynamic address for the MAG and enters MAG dynamic address configuration mode.

       
      Step 5 roaming interface type number


      Example:
      Device(config-ipv6-pmipv6-mag-addr-dyn)# roaming interface Ethernet 0/0 
       

      Specifies an interface as a roaming interface for the MAG.

       
      Step 6 exit


      Example:
      Device(config-ipv6-pmipv6-mag-addr-dyn)# exit
       

      Enters MAG dynamic address configuration mode and returns to privileged EXEC mode.

       

      Configuring Multipath under LMA and MAG Configurations

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    ipv6 mobile pmipv6-lma lma-id domain domain-name

        4.    multipath

        5.    exit

        6.    ipv6 mobile pmipv6-mag mag1 domain dn1

        7.    multipath

        8.    exit


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Device> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Device# configure terminal
         

        Enters global configuration mode.

         
        Step 3 ipv6 mobile pmipv6-lma lma-id domain domain-name


        Example:
        Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
         

        Enables LMA service on the device, configures the PMIPv6 domain for the Local Mobility Anchor (LMA), and enters LMA configuration mode.

         
        Step 4 multipath


        Example:
        Device(config-ipv6-pmipv6-lma)# multipath
         

        Enables multipath support on the LMA.

         
        Step 5 exit


        Example:
        Device(config-ipv6-pmipv6-lma)# exit
         

        Exits LMA configuration mode and enters global configuration mode.

         
        Step 6 ipv6 mobile pmipv6-mag mag1 domain dn1


        Example:
        Device(config)# ipv6 mobile pmipv6-mag mag1 domain dn1
         

        Enables the MAG service on a device, configures the PMIPv6 domain for the MAG, and enters MAG configuration mode.

         
        Step 7 multipath


        Example:
        Device(config-ipv6-pmipv6-mag)# multipath
         

        Enables multipath support on the MAG.

         
        Step 8 exit


        Example:
        Device(config-ipv6-pmipv6-mag)# exit
         

        Exits MAG configuration mode and enters global configuration mode.

         

        Configuring Mobile Map Support on LMA

        Configuring Access Lists in LMA

        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    ip access-list extended access-list-name

          4.    permit protocol any any

          5.    exit

          6.    ip access-list extended access-list-name

          7.    permit protocol any any

          8.    exit

          9.    ip access-list extended access-list-name

          10.    permit protocol any any

          11.    exit

          12.    ip access-list extended access-list-name

          13.    permit ip any destination-address destination-wildcard

          14.    end


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 ip access-list extended access-list-name


          Example:
          Router(config)# ip access-list extended tcp
           

          Configures an extended named ACL specific to TCP.

           
          Step 4 permit protocol any any


          Example:
          Router(config-ext-nacl)# permit tcp any any 
           

          Sets conditions in named IP lists that permit packets.

           
          Step 5 exit


          Example:
          Router(config-ext-nacl)# exit
           

          Exits extended-ACL configuration mode and returns to global configuration mode.

           
          Step 6 ip access-list extended access-list-name


          Example:
          Router(config)# ip access-list extended icmp
           

          Configures an extended named ACL specific to Internet Control Message Protocol (ICMP).

           
          Step 7 permit protocol any any


          Example:
          Router(config-ext-nacl)# permit icmp any any 
           

          Sets conditions in named IP lists that permit packets.

           
          Step 8 exit


          Example:
          Router(config-ext-nacl)# exit
           

          Exits extended-ACL configuration mode and returns to global configuration mode.

           
          Step 9 ip access-list extended access-list-name


          Example:
          Router(config)# ip access-list extended udp
           

          Configures an extended named ACL specific to UDP.

           
          Step 10 permit protocol any any


          Example:
          Router(config-ext-nacl)# permit udp any any
           

          Sets conditions in named IP lists that permit packets.

           
          Step 11 exit


          Example:
          Router(config-ext-nacl)# exit
           

          Exits extended-ACL configuration mode and returns to global configuration mode.

           
          Step 12 ip access-list extended access-list-name


          Example:
          Router(config)# ip access-list extended LB010ACL
           

          Configures an extended named ACL

           
          Step 13 permit ip any destination-address destination-wildcard


          Example:
          Router(config-ext-nacl)# permit ip any 10.255.224.0 0.0.0.255
           

          Sets conditions in named IP lists that permit packets.

           
          Step 14 end


          Example:
          Router(config-ext-nacl)# end
           

          Exits extended-ACL configuration mode and returns to privileged EXEC mode.

           

          Configuring Mobile Maps under the PMIPv6 domain

          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    ipv6 mobile pmipv6-domain domain-name terminal

            4.    mobile-map map-name sequence-number

            5.    match access-list acl-list-name

            6.    set link-type {link-name1} [link-name2] [link-name2] null

            7.    exit

            8.    mobile-map map-name seuence-number

            9.    match access-list acl-list-name

            10.    set link-type { link-name1 } null

            11.    end


          DETAILED STEPS
             Command or ActionPurpose
            Step 1 enable


            Example:
            Device> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.
             
            Step 2 configure terminal


            Example:
            Device# configure terminal
             

            Enters global configuration mode.

             
            Step 3 ipv6 mobile pmipv6-domain domain-name terminal


            Example:
            Device(config)# ipv6 mobile pmipv6-domain dn1
             

            Creates a PMIP domain and enters PMIPv6 domain configuration mode.

             
            Step 4 mobile-map map-name sequence-number


            Example:
            Device(config-ipv6-pmipv6-domain)# mobile-map mobilemap1 10
             

            Configures a mobile map for the PMIPv6 domain and enters mobile-map configuration mode.

             
            Step 5 match access-list acl-list-name


            Example:
            Device(config-ipv6-pmipv6-domain-mobile-map)# match access-list LB010ACL
             

            Specifies an access list (ACL) name.

             
            Step 6 set link-type {link-name1} [link-name2] [link-name2] null


            Example:
            Device(config-ipv6-pmipv6-domain-mobile-map)# set link-type lte_intf 3g_intf wifi_intf null
             

            Specifies the link type for a match clause.

             
            Step 7 exit


            Example:
            Device(config-ipv6-pmipv6-domain-mobile-map)# exit
             

            Exits mobile-map configuration mode and enters global configuration mode.

             
            Step 8 mobile-map map-name seuence-number


            Example:
            Device(config-ipv6-pmipv6-domain)# mobile-map mobilemap1 20
             

            Configures a mobile map for a PMIPv6 domain and enters mobile-map configuration mode.

             
            Step 9 match access-list acl-list-name


            Example:
            Device(config-ipv6-pmipv6-domain-mobile-map)# match access-list icmp
             

            Specifies an access list (ACL) name.

             
            Step 10 set link-type { link-name1 } null


            Example:
            Device(config-ipv6-pmipv6-domain-mobile-map)# set link-type 3g_intf_lte_intf null
             

            Specifies the link type for a match clause.

             
            Step 11 end


            Example:
            Device(config-ipv6-pmipv6-domain-mobile-map)# end
             

            Exits mobile-map configuration mode and enters privileged EXEC mode.

             

            Configuring a Mobile Map under LMA Configuration and Applying it on an Interface

            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    ipv6 mobile pmipv6-lma lma-id domain domain-name

              4.    mobile-map map-name

              5.    interface type number

              6.    end


            DETAILED STEPS
               Command or ActionPurpose
              Step 1 enable


              Example:
              Device> enable
               

              Enables privileged EXEC mode.

              • Enter your password if prompted.
               
              Step 2 configure terminal


              Example:
              Device# configure terminal
               

              Enters global configuration mode.

               
              Step 3 ipv6 mobile pmipv6-lma lma-id domain domain-name


              Example:
              Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
               

              Enables the LMA service on the device, configures the PMIP domain for the LMA, and enters LMA configuration mode.

               
              Step 4 mobile-map map-name


              Example:
              Device(config-ipv6-pmipv6-lma)# mobile-map mobilemap1
               

              Configures a mobile map for the PMIPv6 domain and enters mobile-map configuration mode.

              Note   

              If you modify one or more access-list entries, for the modified access list to be applied, you must unconfigure the mobile map from the LMA configuration and reconfigure it.

               
              Step 5 interface type number


              Example:
              Device(config-ipv6-pmipv6-lma)# interface gigabitethernet 0/0/0
               

              Enables an interface for the mobile map.

               
              Step 6 end


              Example:
              Device(config-ipv6-pmipv6-lma)# end
               

              Exits mobile-map configuration mode and enters privileged EXEC mode.

               

              Configuring the MTU to be Applied on the PMIPv6 Tunnel

              SUMMARY STEPS

                1.    enable

                2.    configure terminal

                3.    ipv6 mobile pmipv6-lma lma-id domain domain-name

                4.    tunnel mtu 1360

                5.    end


              DETAILED STEPS
                 Command or ActionPurpose
                Step 1 enable


                Example:
                Device> enable
                 

                Enables privileged EXEC mode.

                • Enter your password if prompted.
                 
                Step 2 configure terminal


                Example:
                Device# configure terminal
                 

                Enters global configuration mode.

                 
                Step 3 ipv6 mobile pmipv6-lma lma-id domain domain-name


                Example:
                Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
                 

                Enables the LMA service on the device, configures the PMIP domain for the LMA, and enters LMA configuration mode.

                 
                Step 4 tunnel mtu 1360


                Example:
                Device(config-ipv6-pmipv6-lma)# tunnel mtu 1360
                 

                Configures a maximum transmission unit (MTU) on a PMIPv6 tunnel.

                 
                Step 5 end


                Example:
                Device(config-ipv6-pmipv6-lma)# end
                 

                Exits LMA configuration mode and enters privileged EXEC mode.

                 

                Applying an ACL on the PMIPv6 Tunnel

                SUMMARY STEPS

                  1.    enable

                  2.    configure terminal

                  3.    ip access-list extended access-list-name

                  4.    deny protocol host addr any

                  5.    permit protocol any any

                  6.    exit

                  7.    ipv6 mobile pmipv6-mag mag-id domain domain-name

                  8.    tunnel acl acl-list-name

                  9.    end


                DETAILED STEPS
                   Command or ActionPurpose
                  Step 1 enable


                  Example:
                  Device> enable
                   

                  Enables privileged EXEC mode.

                  • Enter your password if prompted.
                   
                  Step 2 configure terminal


                  Example:
                  Device# configure terminal
                   

                  Enters global configuration mode.

                   
                  Step 3 ip access-list extended access-list-name


                  Example:
                  Device(config)# ip access-list extended acl1
                   

                  Defines an IP access list by name and enters the extended access-list configuration mode.

                   
                  Step 4 deny protocol host addr any


                  Example:
                  Device(config-ext-nacl)# deny ip host 10.2.2.2 any
                   

                  Sets conditions in a named IP access list that will deny packets.

                   
                  Step 5 permit protocol any any


                  Example:
                  Device(config-ext-nacl)# permit ip any any
                   

                  Sets conditions to allow a packet to pass a named IP access list.

                   
                  Step 6 exit


                  Example:
                  Device(config-ext-nacl)# exit
                   

                  Exits the extended access-list configuration mode and returns to the global configuration mode.

                   
                  Step 7 ipv6 mobile pmipv6-mag mag-id domain domain-name


                  Example:
                  Device(config)# ipv6 mobile pmipv6-mag mag1 domain dn1 
                   

                  Enables the MAG service on the device, configures the PMIP domain for the LMA, and enters MAG configuration mode.

                   
                  Step 8 tunnel acl acl-list-name


                  Example:
                  Device(config-ipv6-pmipv6-lma)# tunnel acl acl1
                   

                  Specifies an ACL to be applied on the PMIPv6 tunnel in an LMA.

                   
                  Step 9 end


                  Example:
                  Device(config-ipv6-pmipv6-lma)# end
                   

                  Exits LMA configuration mode and enters privileged EXEC mode.

                   

                  Configuring Multiple Mobile Network IPv4 or IPv6 Address Pools for a Network Under LMA Configuration

                  SUMMARY STEPS

                    1.    enable

                    2.    configure terminal

                    3.    ipv6 mobile pmipv6-lma lma-id domain domain-name

                    4.    network name

                    5.    Depending on whether you are configuring IPv4 or IPv6 address pools, perform one of the following tasks:

                    • mobile-network pool address pool-prefix pool-prefix network-prefix network-prefix
                    • mobile-network v6pool address pool-prefix pool-prefix network-prefix network-prefix

                    6.    Depending on whether you are configuring IPv4 or IPv6 address pools, perform one of the following tasks:

                    • mobile-network pool address pool-prefix pool-prefix network-prefix network-prefix
                    • mobile-network v6pool address pool-prefix pool-prefix network-prefix network-prefix

                    7.    end


                  DETAILED STEPS
                     Command or ActionPurpose
                    Step 1 enable


                    Example:
                    Device> enable
                     

                    Enables privileged EXEC mode.

                    • Enter your password if prompted.
                     
                    Step 2 configure terminal


                    Example:
                    Device# configure terminal
                     

                    Enters global configuration mode.

                     
                    Step 3 ipv6 mobile pmipv6-lma lma-id domain domain-name


                    Example:
                    Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
                     

                    Enables the LMA service on the device, configures the PMIP domain for the LMA, and enters LMA configuration mode.

                     
                    Step 4 network name


                    Example:
                    Device(config-ipv6-pmipv6-lma)# network name
                     

                    Specifies mobile address pools, from which a mobile network prefix is allocated to a logical mobile node (LMN) and enters LMA-network configuration mode.

                     
                    Step 5Depending on whether you are configuring IPv4 or IPv6 address pools, perform one of the following tasks:
                    • mobile-network pool address pool-prefix pool-prefix network-prefix network-prefix
                    • mobile-network v6pool address pool-prefix pool-prefix network-prefix network-prefix


                    Example:
                    Device(config)# mobile-network pool 10.20.2.1 pool-prefix 24 network-prefix 30


                    Example:
                    Device(config)# mobile-network pool 2001:DB8:: pool-prefix 48  pool-prefix 48 network-prefix 30
                     

                    Associates a network, to which an IPv4 or IPv6 pool can be configured, with a Local Mobility Anchor (LMA).

                     
                    Step 6Depending on whether you are configuring IPv4 or IPv6 address pools, perform one of the following tasks:
                    • mobile-network pool address pool-prefix pool-prefix network-prefix network-prefix
                    • mobile-network v6pool address pool-prefix pool-prefix network-prefix network-prefix


                    Example:
                    Device(config)# mobile-network pool 10.20.2.2 pool-prefix 24 network-prefix 30


                    Example:
                    Device(config)# mobile-network pool 2001:DB8:0:1::1 pool-prefix 64 pool-prefix 48 network-prefix 30
                     

                    Associates a network, to which an IPv4 or IPv6 pool can be configured, with a Local Mobility Anchor (LMA).

                     
                    Step 7 end


                    Example:
                    Device(config-ipv6-pmipv6lma-network)# end
                     

                    Exits LMA-network configuration mode and enters privileged EXEC mode.

                     

                    Configuring Heartbeat under LMA Configuration

                    SUMMARY STEPS

                      1.    enable

                      2.    configure terminal

                      3.    ipv6 mobile pmipv6-lma lma-id domain domain-name

                      4.    heartbeat [interval interval retries retries [label label] natreboot]]

                      5.    end


                    DETAILED STEPS
                       Command or ActionPurpose
                      Step 1 enable


                      Example:
                      Device> enable
                       

                      Enables privileged EXEC mode.

                      • Enter your password if prompted.
                       
                      Step 2 configure terminal


                      Example:
                      Device# configure terminal
                       

                      Enters global configuration mode.

                       
                      Step 3 ipv6 mobile pmipv6-lma lma-id domain domain-name


                      Example:
                      Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
                       

                      Enables the LMA service on the device, configures the PMIP domain for the LMA, and enters LMA configuration mode.

                       
                      Step 4 heartbeat [interval interval retries retries [label label] natreboot]]


                      Example:
                      Device(config-ipv6-pmipv6-lma)# heartbeat interval 300 retries 2 label label1 natreboot
                       

                      Configures heartbeat detection between MAG and LMA.

                       
                      Step 5 end


                      Example:
                      Device(config-ipv6-pmipv6-lma)# end
                       

                      Exits LMA configuration mode and enters privileged EXEC mode.

                       

                      Configuration Examples for PMIPv6 Multipath Support for MAG and LMA

                      Example: Configuring Multipath on LMA

                      Example: Configuring UDP Encapsulation under PMIPv6 Domain

                      Device> enable
                      Device# configuration terminal
                      Device(config) ipv6 mobile pmipv6-domain D1
                      Device(config-ipv6-pmipv6-domain)# encap udptunnel
                      Device(config-ipv6-pmipv6-domain)# end
                      

                      Example: Configuring Roaming Interface

                      Device> enable
                      Device# configuration terminal
                      Device(config) ipv6 mobile pmipv6-ma mag1 domain D1
                      Device(config-ipv6-pmipv6-mag) address dynamic
                      Device(config-ipv6-pmipv6-mag-addr-dyn)# roaming interface Ethernet 0/0 
                      Device(config-ipv6-pmipv6-mag-addr-dyn)# exit
                      

                      Example: Configuring PMIP: Multipath Support on LMA

                      Device> enable
                      Device# configuration terminal
                      Device(config) ipv6 mobile pmipv6-lma LMA1 domain D1
                      Device(config-ipv6-pmipv6-lma)# multipath
                      Device(config-ipv6-pmipv6-lma)# end
                      

                      Example: Configuring Mobile Map on an LMA

                      Example: Configuring Access List on an LMA

                      Device> enable
                      Device# configuration terminal
                      Device(config)# ip access-list extended tcp 
                      Device(config-ext-nacl)# permit tcp any any 
                      Device(config-ext-nacl)# exit
                      Device(config)# ip access-list extended icmp
                      Device(config-ext-nacl)# permit icmp any any
                      Device(config-ext-nacl)# exit
                      Device(config)# ip access-list extended udp
                      Device(config-ext-nacl)# permit udp any any 
                      Device(config-ext-nacl)# exit
                      Device(config)# ip access-list extended LB010ACL
                      Device(config-ext-nacl)# permit ip any 10.255.224.0 0.0.0.255
                      Device(config-ext-nacl)# end

                      Example: Applying an ACL on the PMIPv6 Tunnel

                      Device> enable
                      Device# configure terminal
                      Device(config)# ip access-list extended acl1
                      Device(config-ext-nacl)# deny ip host 10.2.2.2 any
                      Device(config)# permit ip any any
                      Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1 
                      Device(config-ipv6-pmipv6-lma)# tunnel acl acl1
                      Device(config-ipv6-pmipv6-lma)# end

                      Example: Configuring mobile maps under the PMIPv6 domain

                      Device> enable
                      Device# configure terminal
                      Device(config)#  ipv6 mobile pmipv6-domain dn1
                      Device(config-ipv6-pmipv6-domain)# mobile-map mobilemap1 10
                      Device(config-ipv6-pmipv6-domain-mobile-map)# match access-list LB010ACL
                      Device(config-ipv6-pmipv6-domain-mobile-map)# set link-type lte_intf_3g_intf null
                      Device(config-ipv6-pmipv6-domain-mobile-map)# exit 
                      Device(config-ipv6-pmipv6-domain)# mobile-map mobilemap1 20
                      Device(config-ipv6-pmipv6-domain-mobile-map)# match access-list icmp
                      Device(config-ipv6-pmipv6-domain-mobile-map)# set link-type lte_intf 3g_intf wifi_intf null
                      Device(config-ipv6-pmipv6-domain-mobile-map)# end
                      

                      Example: Configuring a Mobile Map Under LMA Configuration and Applying it on an Interface

                      Device> enable 
                      Device# configure terminal
                      Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1 
                      Device(config-ipv6-pmipv6-domain)# mobile-map mobilemap1 10
                      Device(config-ipv6-pmipv6-domain-mobile-map)# interface gigabitethernet 0/0/0
                      Device(config-ipv6-pmipv6-domain-mobile-map)# end

                      Example: Configuring the MTU to be Applied on the PMIPv6 Tunnel

                       
                      Device> enable
                      Device# configure terminal
                      Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
                      Device(config-ipv6-pmipv6-lma)# tunnel mtu 1360
                      Device(config-ipv6-pmipv6-lma)# end

                      Example: Configuring Multiple Mobile Network Pools for a Network Under LMA Configuration

                      Device> enable
                      Device# configure terminal
                      Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1 
                      Device(config-ipv6-pmipv6-lma)# network name
                      Device(config-ipv6-pmipv6lma-network)# mobile-network pool 10.20.2.1 pool-prefix 24 network-prefix 30 
                      Device(config-ipv6-pmipv6lma-network)# mobile-network pool 10.20.3.1 pool-prefix 24 network-prefix 30
                      Device(config-ipv6-pmipv6lma-network)# end

                      Example: Configuring Heartbeat under LMA Configuration

                      Device> enable
                      Device# configure terminal
                      Device(config)# ipv6 mobile pmipv6-lma lma1 domain dn1
                      Device(config-ipv6-pmipv6-lma)# heartbeat interval 300 retries 2 label label1 natreboot
                      Device(config-ipv6-pmipv6-lma)# end

                      Additional References

                      Related Documents

                      Related Topic

                      Document Title

                      Cisco IOS commands

                      Master Command List, All Releases

                      IP mobility commands

                      IP Mobility Command Reference

                      Standards and RFCs

                      Standard/RFC

                      Title

                      RFC 3775

                      Mobility Support in IPv6

                      RFC 5213

                      Proxy Mobile IPv6

                      RFC 5844

                      IPv4 Support for Proxy Mobile IPv6

                      RFC 5845

                      Generic Routing Encapsulation (GRE) Key Option for Proxy Mobile IPv6

                      RFC 5846

                      Binding Revocation for IPv6 Mobility

                      MIBs

                      MIB

                      MIBs Link

                      None

                      To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

                      http:/​/​www.cisco.com/​go/​mibs

                      Technical Assistance

                      Description

                      Link

                      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

                      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

                      Feature Information for PMIP: Multipath Support on MAG and LMA

                      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

                      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

                      Table 1 Feature Information for PMIP: Multipath Support on MAG and LMA

                      Feature Name

                      Releases

                      Feature Information

                      PMIP: Multipath Support on MAG and LMA

                      Cisco IOS XE Release 3.10S

                      The PMIP: Multipath Support on MAG and LMA feature enables the Mobility Access Gateway (MAG) to register multiple transport end-points with the Local Mobility Anchor (LMA), allowing the MAG and LMA to establish multiple tunnels and apply path selection on a flow basis.

                      The following commands were introduced or modified: encap (proxy mobile IPv6), heartbeat , interface (proxy mobile IPv6) , match access-list (PMIPv6), mobile-map (PMIPv6 domain), mobile-map (LMA) , mobile-network PMIPv6), multipath, set link-type, and tunnel mtu .

                      MAG to MAG Traffic Blocking on the PMIPv6 LMA

                      Cisco IOS XE Release 3.12S

                      The MAG to MAG Traffic Blocking on the PMIPv6 LMA feature is an enhancement that enables prevention of communication between PMIPv6 clients connected to the same LMA. The inter-MAG tunnel traffic is blocked by applying ACLs on the PMIPv6 tunnels.

                      The following commands were introduced or modified:

                      tunnel acl and mobile-network