LAN Switching Configuration Guide, Cisco IOS XE Release 3S
EtherChannel Flow-Based Limited 1 1 Redundancy
Downloads: This chapterpdf (PDF - 1.32MB) The complete bookPDF (PDF - 4.74MB) | The complete bookePub (ePub - 1.24MB) | Feedback

EtherChannel Flow-Based Limited 1 1 Redundancy

EtherChannel Flow-Based Limited 1 1 Redundancy

EtherChannel flow-based limited 1:1 redundancy provides MAC, or layer 2, traffic protection to avoid higher layer protocols from reacting to single link failures and re-converging. To use EtherChannel flow-based limited 1:1 redundancy, you configure an EtherChannel with two ports (one active and one standby). If the active link goes down, the EtherChannel stays up and the system performs fast switchover to the hot-standby link. Depending on how you have the priorities set, when the failed link becomes operational again, the EtherChannel performs another fast switchover to revert to the original active link. if all port-priorities are the same, it will not revert, but remain on the current active link.

With 1:1 redundancy configured, only one link is active at any given time so all flows are directed over the active link.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About EtherChannel Flow-Based Limited 1 1 Redundancy

EtherChannel Flow-Based Limited 1 1 Redundancy

EtherChannel flow-based limited 1:1 redundancy provides an EtherChannel configuration with one active link and fast switchover to a hot standby link. To use EtherChannel flow-based limited 1:1 redundancy, you configure a Link Aggregation Control Protocol (LACP) EtherChannel with two ports (one active and one standby). If the active link goes down, the EtherChannel stays up and the system performs fast switchover to the hot standby link. Depending on how the priorities of the links are set, when the failed link becomes operational again, the EtherChannel performs another fast switchover to revert to the original active link, or to the link with the higher priority.

For EtherChannel flow-based limited 1:1 redundancy to work correctly (especially the fast switchover capability) the feature must be enabled at both ends of the link.

How to Configure EtherChannel Flow-Based Limited 1 1 Redundancy

Configuring EtherChannel Flow-Based Limited 1 1 Redundancy with Fast-Switchover

To configure an LACP EtherChannel with two ports (one active and one standby), perform the following steps. This feature must be enabled at both ends of the link.

You can control which link is the primary active link by setting the port priority on the links used for the redundancy. To configure a primary link and enable the EtherChannel to revert to the original link, one link must have a higher port priority than the other and the LACP max-bundle must be set to 1. This configuration results in link 1 being active and link 2 being in hot standby state.

To prevent the switchover to revert, you can assign both links the same priority.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface port-channel channel -number

    4.    lacp fast-switchover

    5.    lacp max-bundle 1

    6.    exit

    7.    interface tengigabitethernet slot / port / number

    8.    channel-group 1 mode mode

    9.    lacp port-priority priority

    10.    exit

    11.    interface tengigabitethernet slot / port / number

    12.    channel-group 1 mode mode

    13.    lacp port-priority priority

    14.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface port-channel channel -number


    Example:
    Router(config)# interface port-channel 1
     

    Selects an LACP port channel interface.

     
    Step 4 lacp fast-switchover


    Example:
    Router(config-if)# lacp fast-switchover
     

    Enables the fast switchover feature for this EtherChannel.

     
    Step 5 lacp max-bundle 1


    Example:
    Router(config-if)# lacp max-bundle 1
     

    Sets the maximum number of active member ports to 1.

     
    Step 6 exit


    Example:
    Router(config-if)# exit 
     

    Exits interface configuration mode and returns to global configuration mode.

     
    Step 7 interface tengigabitethernet slot / port / number


    Example:
    Router(config)# interface tengigabitethernet 0/0/0
     

    Selects the first interface to add to the port channel.

     
    Step 8 channel-group 1 mode mode


    Example:
    Router(config-if)# channel-group 1 mode active
     

    Adds the member link to the port-channel and actively participates in LACP negotiation.

     
    Step 9 lacp port-priority priority


    Example:
    Router(config-if)# lacp port-priority 32768
     

    Sets the priority on the port-channel. This priority is set to the default value.

     
    Step 10 exit


    Example:
    Router(config-if)# exit 
     

    Exits interface configuration mode and returns to global configuration mode.

     
    Step 11 interface tengigabitethernet slot / port / number


    Example:
    Router(config)# interface tengigabitethernet 1/0/0
     

    Selects the interface to add to the port channel.

     
    Step 12 channel-group 1 mode mode


    Example:
    Router(config-if)# channel-group 1 mode active
     

    Adds the member link to the port-channel and actively participates in LACP negotiation.

     
    Step 13 lacp port-priority priority


    Example:
    Router(config-if)# lacp port-priority 32767
     

    Sets the port priority higher than the other link by using a value lower than the default value of 32768. This forces this link to be the active link whenever it is capable of carrying traffic.

     
    Step 14 end


    Example:
    Router(config-if)# end
     

    Exits interface configuration mode.

     

    Setting the Switchover Rate with Carrier Delay

    Optionally, you can control the speed of the switchover between the active and standby links by setting the carrier delay on each link. The carrier-delay command controls how long it takes for Cisco IOS to propagate the information about the links status to other modules.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface tengigabitethernet slot / port / number

      4.    carrier-delay msec msec

      5.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.

       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface tengigabitethernet slot / port / number


      Example:
      Router(config)# interface tengigabitethernet 0/1/0
       

      Enters interface configuration mode and opens the configuration for the specified interface.

       
      Step 4 carrier-delay msec msec


      Example:
      Router(config-if)# carrier-delay msec 11
       

      Sets how long it takes to propagate the link status to other modules.

       
      Step 5 end


      Example:
      Router(config-if)# end
       

      Exits interface configuration mode.

       

      Verifying EtherChannel Flow-Based Limited 1 1 Redundancy

      Use these show commands to verify the configuration and to display information about the port channel.

      SUMMARY STEPS

        1.    enable

        2.    show running-config interface type slot / port / number

        3.    show interfaces port-channel channel-number etherchannel

        4.    show etherchannel channel-number port-channel

        5.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.

         
        Step 2 show running-config interface type slot / port / number


        Example:
        Router# show running-config interface tengigabitethernet 0/0/0
         

        Verifies the configuration.

        • type --gigabitethernet or tengigabitethernet.

         
        Step 3 show interfaces port-channel channel-number etherchannel


        Example:
        Router# show interfaces port-channel 1 etherchannel
         

        Displays the bucket distribution currently in use.

         
        Step 4 show etherchannel channel-number port-channel


        Example:
        Router# show etherchannel 1 port-channel
         

        Displays the port channel fast-switchover feature capability.

         
        Step 5 end


        Example:
        Router# end
         

        Exits privileged EXEC mode.

         

        Configuration Examples for EtherChannel Flow-Based Limited1 1 Redundancy

        EtherChannel 1 1 Active Standby Example

        This example shows how to configure a port channel for 1:1 link redundancy for equal priority ports so there is no preference which port is active.

        Router# enable
        Router# configure terminal
        Router(config)# interface port-channel 2
        Router(config-if)# ip address 10.1.1.1 255.255.0.0
        Router(config-if)# negotiation auto
        Router(config-if)# lacp max-bundle 1
        Router(config-if)# lacp fast-switchover
        Router(config)# interface Tengigabitethernet0/1/0
        Router(config-if)# channel-group 2 mode active
        Router(config-if)# negotiation auto
        Router(config)# interface Tengigabitethernet 2/1/0
        Router(config-if)# channel-group 2 mode active
        Router(config-if)# negotiation auto
        Router(config)# interface GigabitEthernet0/1/6
        Router(config-if)# negotiation auto
        Router(config-if)# channel-group 19 mode active
        Router(config)# interface GigabitEthernet0/1/7
        Router(config-if)# negotiation auto
        Router(config-if)# channel-group 19 mode active
        Router(config-if)# interface Port-channel19
        Router(config-if)# ip address 10.19.1.1 255.255.255.0
        Router(config-if)# no negotiation auto
        Router(config-if)# lacp fast-switchover
        Router(config-if)# lacp max-bundle 1
        Router(config-if)# end
        

        Notice in the show command display the priorities are the same value.

        Router# show lacp internal 
        Flags: S - Device is requesting Slow LACPDUs 
        	F - Device is requesting Fast LACPDUs
        	A - Device is in Active mode P - Device is in Passive mode 
        Channel group 19
        LACP port Admin Oper Port Port
        Port Flags State Priority Key Key Number State
        Gi0/1/6 SA bndl 32768 0x13 0x13 0x47 0x3D 
        Gi0/1/7 FA hot-sby 32768 0x13 0x13 0x48 0x7 

        Setting Priority for 1 1 Redundancy Using LACP Example

        This example shows how to configure an LACP EtherChannel with 1:1 redundancy. GigabitEthernet 0/1/7 is the active link, because it is configured with a lower number which give it a higher port priority.

        Router# configure terminal
        Router(config)# interface GigabitEthernet0/1/6
        Router(config-if)# lacp port-priority 32767
        Router(config-if)# exit
        Router(config)# interface GigabitEthernet0/1/7
        Router(config-if)# lacp fast-switchover
        Router(config-if)# lacp max-bundle 1
        Router(config-if)# negotiation auto
        Router(config-if)# channel-group 19 mode active
        

        In this show display, notice that the bundled link is set at a higher priority. This will ensure that the bundled link is used as the first active link in the standby configuration.

        Router# show lacp internal
         
        Flags: S - Device is requesting Slow LACPDUs 
        	F - Device is requesting Fast LACPDUs
        	A - Device is in Active mode P - Device is in Passive mode 
        Channel group 19
        LACP port Admin Oper Port Port
        Port Flags State Priority Key Key Number State
        Gi0/1/6 FA hot-sby 32768 0x13 0x13 0x47 0x7 
        Gi0/1/7 SA bndl 32767 0x13 0x13 0x48 0x3D

        Additional References

        The following sections provide references related to the EtherChannel Flow-based Limited1:1 Redundancy feature.

        Related Documents

        Related Topic

        Document Title

        Cisco IOS commands

        Cisco IOS Master Commands List, All Releases

        LAN Switching commands

        Cisco IOS LAN Switching Command Reference

        Standards

        Standard

        Title

        No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

        --

        MIBs

        MIB

        MIBs Link

        No new or modified MIBs are supported by this feature, and support for existing MIBs has not been modified by this feature.

        To locate and download MIBs for selected platforms, Cisco IOS XE software releases, and feature sets, use Cisco MIB Locator found at the following URL:

        http:/​/​www.cisco.com/​go/​mibs

        RFCs

        RFC

        Title

        No new or modified RFCs are supported by this feature, and support for existing standards has not been modified by this feature.

        --

        Technical Assistance

        Description

        Link

        The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

        To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

        Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        Feature Information for EtherChannel Flow-based Limited 1 1 Redundancy

        The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

        Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

        Table 1 Feature Information for EtherChannel Flow-based Limited 1:1 Redundancy

        Feature Name

        Releases

        Feature Information

        EtherChannel Flow-Based Limited 1:1 Redundancy

        Cisco IOS XE Release 2.4

        EtherChannel flow-based limited 1:1 redundancy provides MAC, or layer 2, traffic protection to avoid higher layer protocols from reacting to single link failures and re-converging. To use EtherChannel flow-based limited 1:1 redundancy, you configure an EtherChannel with two ports (one active and one standby). If the active link goes down, the EtherChannel stays up and the system performs fast switchover to the hot-standby link. Depending on how you have the priorities set, when the failed link becomes operational again, the EtherChannel performs another fast switchover to revert to the original active link. if all port-priorities are the same, it will not revert, but remain on the current active link.

        No commands were modified or created to support this feature.