IP Routing: LISP Configuration Guide, Cisco IOS XE Release 3S
LISP Support for Disjoint RLOC Domains
Downloads: This chapterpdf (PDF - 1.46MB) The complete bookPDF (PDF - 5.63MB) | The complete bookePub (ePub - 1.61MB) | Feedback

LISP Support for Disjoint RLOC Domains

LISP Support for Disjoint RLOC Domains

The Locator/ID Separation Protocol (LISP) implements a “level of indirection” that enables a new IP routing architecture. LISP separates IP addresses into two namespaces: Endpoint Identifiers (EIDs), which are assigned to end-hosts, and Routing Locators (RLOCs), which are assigned to devices that make up the global routing system.

The LISP Support for Disjoint RLOC Domains feature enables LISP-to-LISP communication between LISP sites that are connected to different RLOC spaces but have no connectivity to each other. One example of disjointed RLOC space is that of between the IPv4 Internet and IPv6 Internet. When one LISP site has IPv4-only RLOC connectivity and the second site has IPv6-only RLOC connectivity, these sites can still communicate via LISP using the LISP Support for Disjoint RLOC Domains feature.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for LISP Support for Disjoint RLOC Domains

Map servers and re-encapsulating tunnel routers (RTRs) must have connectivity to all locator spaces that are being joined.

Restrictions for LISP Support for Disjoint RLOC Domains

Map servers and re-encapsulating tunnel routers (RTRs) cannot join more than eight locator scopes.

Information About LISP Support for Disjoint RLOC Domains

LISP Support for Disjoint RLOC Domains Overview

The fundamental principal of any network is that routing and reachability must exist between all devices that make up the total network system. There are many network systems, public and private, for which internetwork connectivity is not directly available. A few examples include:

  • IPv4 Internet and IPv6 Internet.
  • An IPv4 Multiprotocol Label Switching (MPLS) VPN from service provider A and an IPv4 MPLS VPN from service provider B.
  • An IPv4 MPLS VPN from service provider A and IPv4 Internet.

When some sites within a network connect to one routing domain and other sites connect to another routing domain, a gateway function must be provided to facilitate connectivity between these disjointed routing domains. In traditional routing architectures, providing connectivity between disjointed routing domains can be quite complex.

The inherent property of Locator/ID Separation Protocol (LISP), which separates IP addresses into two namespaces, endpoint identifiers (EIDs) and routing locators (RLOCs), also gives it the ability to connect disjointed RLOC domains. The LISP Support for Disjoint RLOC Domains feature provides simplified configuration mechanisms that enable this capability. The key components are new control plane configuration options on the LISP map server, and a functionality called re-encapsulating tunnel router (RTR), which provides data plane connectivity between disjointed locator spaces.

LISP Map Server

The key concept in the LISP Support for Disjoint RLOC Domains feature is the recognition that the LISP Mapping System has full knowledge of all LISP sites. When a LISP site registers with a map server, the registration message not only provides information about the EID space that the site is authoritative for, but it also provides information about its own RLOCs.

The LISP Support for Disjoint RLOC Domains feature provides new configuration options to define within the map server the routing locator scopes that LISP sites can connect to. Once defined, the map server automatically determines whether individual sites have common or disjoint locator connectivity between themselves. The map server then uses this knowledge when handling Map-Request messages to determine how to inform LISP sites to communicate with each other. Map-Request messages contain both source and destination EID information. When a map server receives a Map-Request message, it compares the RLOCs associated with the source EID and destination EID contained with the Map-Request message against the configured locator scopes.

  • If the ingress tunnel router (ITR) (source EID) and egress tunnel router (ETR) (destination EID) share at least one RLOC in a common locator scope, the map server forwards the Map-Request message to the ETR as normal. In this case, the ETR is capable of generating a Map-Reply message that is sent back to the ITR since it has reachability across (at least one) common locator space.
  • If the ITR (source EID) and ETR (destination EID) do not share at least one RLOC in a common locator scope, the map server sends a proxy Map-Reply message to the ITR that includes a list of RTRs that are capable of connecting the disjointed locator space between the ITR and ETR.
  • If the RLOCs associated with the ITR (source EID) and ETR (destination EID) do not match any configured locator scopes, the map server forwards the Map-Request message to the ETR as normal. In this case, the RLOCs are assumed to be reachable via routing, even though they are not defined in any locator scope configuration.

LISP data plane packets flow directly between sites when the sites share locator space. An RTR is used to connect LISP data plane packets when locator spaces between the sites are disjointed.

LISP RTR

A re-encapsulating tunnel router (RTR) provides data plane communications support for LISP-to-LISP traffic between LISP sites that do not share common locator space. Functionally, an RTR takes in LISP encapsulated packets from an ITR in one locator scope, decapsulates them, does a map-cache lookup, and then re-encapsulates them to an ETR in another locator scope. The following are important considerations for an RTR:

  • The RTR itself must have RLOCs in all locator scopes that are being joined.
  • An RTR sends Map-Request messages to populate its own map cache. As a Map-Request message contains an ITR RLOC field that is populated with one or more entries corresponding to the locators of the device sending the Map-Request message, the RTR in this case, the locator set configuration is also required on the RTR to define its locators. This enables the map server to correctly receive Map-Requests from the RTR to assess locator scope connectivity.
  • An RTR performs functions similar to a proxy ingress tunnel router (PITR) and proxy egress tunnel router (PETR), therefore these features must be enabled on the RTR.
Figure 1. LISP - Disjoint RLOC Domains Topology



Referring to Figure 1, the tasks below illustrate the configuration steps required to provide Locator/ID Separation Protocol (LISP) Disjoint Routing Locator (RLOC) support for cross address-family (IPv4/IPv6) connectivity.
  • Ingress/Egress tunnel router (xTR) represents the LISP Site router. In Figure 1, xTR4 only has RLOC connectivity to the IPv4 Internet, and xTR6 only has RLOC connectivity to the IPv6 Internet.
  • Map server map resolver (MSMR) represents the MSMR supporting the LISP control plane.
  • Re-encapsulating tunnel router (RTR) represents the LISP data plane device that joins locator scopes.

How to configure LISP Support for Disjoint RLOC Domains

Configuring xTR

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address ip-address mask

    5.    ipv6 address ipv6-address/ipv6-prefix

    6.    interface type number

    7.    ip address ip-address mask

    8.    router lisp

    9.    locator-set locator-set-name

    10.    ipv4-address priority priority-locator weight locator-weight

    11.    ipv6-address priority priority-locator weight locator-weight

    12.    exit

    13.    eid-table default instance-id id

    14.    database-mapping dynamic-eid-prefix/prefix-length locator-set name

    15.    database-mapping dynamic-eid-prefix/prefix-length locator-set name

    16.    exit

    17.    ipv4 itr map-resolver map-resolver-address

    18.    ipv4 itr

    19.    ipv4 etr map-server map-server-address key authentication-key

    20.    ipv4 etr

    21.    ipv6 itr map-resolver map-resolver-address

    22.    ipv6 itr

    23.    ipv6 etr map-server map-server-address key authentication-key

    24.    ipv6 etr

    25.    exit

    26.    ip route prefix mask ip-address

    27.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     
    Enables privileged EXEC mode.
    • Enter your password if prompted.
     
    Step 2configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3interface type number


    Example:
    Device(config)# interface loopback0
     

    Specifies the interface type and number and enters interface configuration mode.

     
    Step 4ip address ip-address mask


    Example:
    Device(config-if)# ip address 10.10.10.4 255.255.255.0
     

    Configures an IPv4 address for the interface.

     
    Step 5ipv6 address ipv6-address/ipv6-prefix


    Example:
    Device(config-if)# ipv6 address 2001:DB8:0:ABCD::1/64
     

    Configures an IPv6 address for the interface.

     
    Step 6interface type number


    Example:
    Device(config)# interface ethernet0/0
     

    Specifies the interface type and number and enters interface configuration mode.

     
    Step 7ip address ip-address mask


    Example:
    Device(config-if)# ip address 10.0.4.1 255.255.255.252
     

    Configures an IPv4 address for the interface.

     
    Step 8router lisp


    Example:
    Device(config-if)# router lisp
     

    Enters LISP configuration mode.

     
    Step 9locator-set locator-set-name


    Example:
    Device(config-router-lisp)# locator-set R4
     

    Specifies a locator set and enters LISP locator set configuration mode.

     
    Step 10ipv4-address priority priority-locator weight locator-weight


    Example:
    Device(config-router-lisp-locator-set)# 10.0.4.1 priority 1 weight 1
     

    Configures the LISP locator set. The LISP locator set is the set of addresses the first-hop router uses when communicating with the gateway xTR. You can configure each IPv4 locator address by creating a locator entry with assigned priority and weight.

     
    Step 11ipv6-address priority priority-locator weight locator-weight


    Example:
    Device(config-router-lisp-locator-set)# 2001:DB8:4::2 priority 1 weight 1
     

    Configures the LISP locator set. The LISP locator set is the set of addresses the first-hop router uses when communicating with the gateway xTR. You can configure each IPv6 locator address by creating a locator entry with assigned priority and weight.

     
    Step 12exit


    Example:
    Device(config-router-lisp-locator-set)# exit
     

    Exits LISP locator set configuration mode and returns to LISP configuration mode.

     
    Step 13eid-table default instance-id id


    Example:
    Device(config-router-lisp)# eid-table default instance-id 0
     

    Configures an association between the default (global) routing table and a LISP instance ID, and enters EID table configuration mode.

     
    Step 14database-mapping dynamic-eid-prefix/prefix-length locator-set name


    Example:
    Device(config-router-lisp-eid-table)# database-mapping 10.10.10.0/24 locator-set R4
     

    Configures an IPv4/IPv6 mapping relationship and an associated traffic policy (as defined in the locator set) for this LISP site.

     
    Step 15database-mapping dynamic-eid-prefix/prefix-length locator-set name


    Example:
    Device(config-router-lisp-eid-table)# database-mapping 2001:DB8::/48 locator-set R4
     

    Configures an IPv4/IPv6 mapping relationship and an associated traffic policy (as defined in the locator set) for this LISP site.

     
    Step 16exit


    Example:
    Device(config-router-lisp-eid-table)# exit
     

    Exits EID table configuration mode and returns to LISP configuration mode.

     
    Step 17ipv4 itr map-resolver map-resolver-address


    Example:
    Device(config-router-lisp)# ipv4 itr map-resolver 10.0.2.1
     

    Configures a locator address for the LISP map resolver to which this device will send Map-Request messages for IPv4 endpoint identifier-to-routing locator (EID-to-RLOC) mapping resolutions.

    • The locator address of the map resolver may be an IPv4 or IPv6 address.
    Note    You can configure up to eight map resolvers if multiple map resolvers are available.
     
    Step 18ipv4 itr


    Example:
    Device(config-router-lisp)# ipv4 itr
     

    Enables LISP ingress tunnel router (ITR) functionality for an IPv4 address family.

     
    Step 19ipv4 etr map-server map-server-address key authentication-key


    Example:
    Device(config-router-lisp)# ipv4 etr map-server 10.0.2.1 key R4KEY
     

    Configures the IPv4 locator address of the LISP map server to be used by the egress tunnel router (ETR) when registering itself for IPv4 endpoint identifiers (EIDs).

     
    Step 20ipv4 etr


    Example:
    Device(config-router-lisp)# ipv4 etr
     

    Enables LISP ETR functionality for an IPv4 address family.

     
    Step 21ipv6 itr map-resolver map-resolver-address


    Example:
    Device(config-router-lisp)# ipv6 itr map-resolver 10.0.2.1
     

    Configures a locator address for the LISP map resolver to which this router will send Map-Request messages for IPv6 EID-to-RLOC mapping resolutions.

    • The locator address of the map resolver may be an IPv4 or IPv6 address.
    Note    You can configure up to eight map resolvers if multiple map resolvers are available.
     
    Step 22ipv6 itr


    Example:
    Device(config-router-lisp)# ipv6 itr
     

    Enables LISP ITR functionality for an IPv6 address family.

     
    Step 23ipv6 etr map-server map-server-address key authentication-key


    Example:
    Device(config-router-lisp)# ipv6 etr map-server 10.0.2.1 key R4KEY
     

    Configures the IPv6 locator address for the LISP map server to be used by the ETR when registering for IPv6 EIDs.

     
    Step 24ipv6 etr


    Example:
    Device(config-router-lisp)# ipv6 etr
     

    Enables LISP ETR functionality for an IPv6 address family.

     
    Step 25exit


    Example:
    Device(config-router-lisp)# exit
     

    Exits LISP configuration mode and returns to global configuration mode.

     
    Step 26ip route prefix mask ip-address


    Example:
    Device(config)# ip route 0.0.0.0 0.0.0.0 10.0.4.2
     

    Establishes static routes to the next hop destination.

     
    Step 27end


    Example:
    Device(config)# end
     

    Returns to privileged EXEC mode.

     

    Configuring MSMR

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type number

      4.    ip address ip-address mask

      5.    ipv6 address ipv6-address/ipv6-prefix

      6.    router lisp

      7.    locator-set locator-set-name

      8.    ipv4-address priority priority-locator weight locator-weight

      9.    exit

      10.    Repeat Step 7 to Step 9 to specify and configure another locator set.

      11.    locator-scope name

      12.    rtr-locator-set locator-set-name

      13.    rloc-prefix ipv4-rloc-prefix

      14.    exit

      15.    Repeat Step 11 to Step 14 to specify and configure another locator scope.

      16.    site site-name

      17.    authentication-key password

      18.    eid-prefix ipv4-eid-prefix

      19.    eid-prefix ipv6-eid-prefix

      20.    exit

      21.    Repeat Step 16 to Step 20 to configure another LISP site on the map server.

      22.    ipv4 map-server

      23.    ipv6 map-server

      24.    ipv4 map-resolver

      25.    ipv6 map-resolver

      26.    exit

      27.    ip route prefix mask ip-address

      28.    ipv6 route ipv6-prefix/prefix-length ipv6-address

      29.    end


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       
      Enables privileged EXEC mode.
      • Enter your password if prompted.
       
      Step 2configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3interface type number


      Example:
      Device(config)# interface ethernet0/0
       

      Specifies the interface type and number and enters interface configuration mode.

       
      Step 4ip address ip-address mask


      Example:
      Device(config-if)# ip address 10.0.2.1 255.255.255.252
       

      Configures an IPv4 address for the interface.

       
      Step 5ipv6 address ipv6-address/ipv6-prefix


      Example:
      Device(config-if)# ipv6 address 2001:DB8:1::1/64
       

      Configures an IPv6 address for the interface.

       
      Step 6router lisp


      Example:
      Device(config-if)# router lisp
       

      Enters LISP configuration mode.

       
      Step 7locator-set locator-set-name


      Example:
      Device(config-router-lisp)# locator-set rtr-set1
       

      Specifies a locator set and enters LISP locator set configuration mode.

       
      Step 8ipv4-address priority priority-locator weight locator-weight


      Example:
      Device(config-router-lisp-locator-set)# 10.0.3.1 priority 1 weight 1
       

      Configures the LISP locator set. The LISP locator set is the set of addresses the first-hop router uses when communicating with the gateway xTR. You can configure each locator address by creating a locator entry with assigned priority and weight.

       
      Step 9exit


      Example:
      Device(config-router-lisp-locator-set)# exit
       

      Exits LISP locator set configuration mode and returns to LISP configuration mode.

       
      Step 10Repeat Step 7 to Step 9 to specify and configure another locator set.  

       
      Step 11locator-scope name


      Example:
      Device(config-router-lisp)# locator-scope s1
       

      Specifies the locator scope and enters locator scope configuration mode.

       
      Step 12rtr-locator-set locator-set-name


      Example:
      Device(config-router-lisp-locator-scope)# rtr-locator-set rtr-set1
       

      Specifies the locator set of re-encapsulating tunnel router (RTR) to use in proxy reply for disjoint/cross address family routing locator (RLOC).

       
      Step 13rloc-prefix ipv4-rloc-prefix


      Example:
      Device(config-router-lisp-locator-scope)# rloc-prefix 0.0.0.0/0
       

      Specifies the RLOC prefix to check against ingress tunnel router (ITR) RLOC and egress tunnel router (ETR) RLOC.

       
      Step 14exit


      Example:
      Device(config-router-lisp-locator-set)# exit
       

      Exits LISP locator set configuration mode and returns to LISP configuration mode.

       
      Step 15Repeat Step 11 to Step 14 to specify and configure another locator scope.  

       
      Step 16site site-name


      Example:
      Device(config-router-lisp)# site R4
       

      Configures a LISP site on a map server and enters LISP site configuration mode.

       
      Step 17authentication-key password


      Example:
      Device(config-router-lisp-site)# authentication-key R4KEY
       

      Specifies the authentication key that the LISP site uses.

       
      Step 18eid-prefix ipv4-eid-prefix


      Example:
      Device(config-router-lisp-site)# eid-prefix 10.10.10.0/24
       

      Specifies a site IPv4 EID prefix.

       
      Step 19eid-prefix ipv6-eid-prefix


      Example:
      Device(config-router-lisp-site)# eid-prefix 2001:DB8::/48
       

      Specifies a site IPv6 EID address prefix.

       
      Step 20exit


      Example:
      Device(config-router-lisp-site)# exit
       

      Exits LISP site configuration mode and returns to LISP configuration mode.

       
      Step 21Repeat Step 16 to Step 20 to configure another LISP site on the map server.  

       
      Step 22ipv4 map-server


      Example:
      Device(config-router-lisp)# ipv4 map-server
       

      Enables IPv4 map server functionality.

       
      Step 23ipv6 map-server


      Example:
      Device(config-router-lisp)# ipv6 map-server
       

      Enables IPv6 map server functionality.

       
      Step 24ipv4 map-resolver


      Example:
      Device(config-router-lisp)# ipv4 map-resolver
       

      Enables IPv4 map resolver functionality.

       
      Step 25ipv6 map-resolver


      Example:
      Device(config-router-lisp)# ipv6 map-resolver
       

      Enables IPv6 map resolver functionality.

       
      Step 26exit


      Example:
      Device(config-router-lisp)# exit
       

      Exits LISP configuration mode and returns to global configuration mode.

       
      Step 27ip route prefix mask ip-address


      Example:
      Device(config)# ip route 0.0.0.0 0.0.0.0 10.0.2.2
       

      Establishes static routes to the next hop destination.

       
      Step 28ipv6 route ipv6-prefix/prefix-length ipv6-address


      Example:
      Device(config)# ipv6 route ::/0 2001:DB8:1::ABCD
       

      Establishes static routes to the next hop destination.

       
      Step 29end


      Example:
      Device(config)# end
       

      Returns to privileged EXEC mode.

       

      Configuring RTR

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    interface type number

        4.    ip address ip-address mask

        5.    ipv6 address ipv6-address/ipv6-prefix

        6.    router lisp

        7.    locator-set locator-set-name

        8.    ipv4-address priority priority-locator weight locator-weight

        9.    ipv6-address priority priority-locator weight locator-weight

        10.    exit

        11.    map-request itr-rlocs locator-set-name

        12.    eid-table default instance-id id

        13.    map-cache ipv4-EID-prefix map-request

        14.    map-cache ipv6-EID-prefix map-request

        15.    exit

        16.    ipv4 map-request-source source-address

        17.    ipv4 map-cache-limit cache-limit

        18.    ipv4 proxy-etr

        19.    ipv4 proxy-itr ipv4-local-locator ipv6-local-locator

        20.    ipv4 itr map-resolver map-resolver-address

        21.    ipv6 map-request-source source-address

        22.    ipv6 map-cache-limit cache-limit

        23.    ipv6 proxy-etr cache-limit

        24.    ipv6 proxy-itr ipv6-local-locator ipv4-local-locator

        25.    ipv6 itr map-resolver map-resolver-address

        26.    exit

        27.    ip route prefix mask ip-address

        28.    ipv6 route ipv6-prefix/prefix-length ipv6-address

        29.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Device> enable
         
        Enables privileged EXEC mode.
        • Enter your password if prompted.
         
        Step 2configure terminal


        Example:
        Device# configure terminal
         

        Enters global configuration mode.

         
        Step 3interface type number


        Example:
        Device(config)# interface ethernet0/0
         

        Specifies the interface type and number and enters interface configuration mode.

         
        Step 4ip address ip-address mask


        Example:
        Device(config-if)# ip address 10.0.3.1 255.255.255.252
         

        Configures an IPv4 address for the interface.

         
        Step 5ipv6 address ipv6-address/ipv6-prefix


        Example:
        Device(config-if)# ipv6 address 2001:DB8:2::1/64
         

        Configures an IPv6 address for the interface.

         
        Step 6router lisp


        Example:
        Device(config-if)# router lisp
         

        Enters LISP configuration mode.

         
        Step 7locator-set locator-set-name


        Example:
        Device(config-router-lisp)# locator-set setALL
         

        Specifies a locator set and enters LISP locator set configuration mode.

         
        Step 8ipv4-address priority priority-locator weight locator-weight


        Example:
        Device(config-router-lisp-locator-set)# 10.0.3.1 priority 1 weight 1
         

        Configures an IPv4 or IPv6 address and policy for the re-encapsulation tunnel router (RTR).

         
        Step 9ipv6-address priority priority-locator weight locator-weight


        Example:
        Device(config-router-lisp-locator-set)# 2001:DB8:2::1 priority 1 weight 1
         

        Configures an IPv4 or IPv6 address and policy for the RTR.

         
        Step 10exit


        Example:
        Device(config-router-lisp-locator-set)# exit
         

        Exits LISP locator set configuration mode and returns to LISP configuration mode.

         
        Step 11map-request itr-rlocs locator-set-name


        Example:
        Device(config-router-lisp)# map-request itr-rlocs setALL
         

        Configures the locator set to be used as routing locators (RLOCs) in the ingress tunnel router (ITR) RLOC field of Map-Request messages sent from the RTR.

         
        Step 12eid-table default instance-id id


        Example:
        Device(config-router-lisp)# eid-table default instance-id 0
         

        Configures an association between the default (global) routing table and a LISP instance ID, and enters EID table configuration mode.

         
        Step 13map-cache ipv4-EID-prefix map-request


        Example:
        Device(config-router-lisp-eid-table)# map-cache 0.0.0.0/0 map-request
         

        Configures static endpoint identifier-to-routing locator (EID-to-RLOC) mappings for an ITR and enables sending of Map-Request message for a LISP destination EID.

         
        Step 14map-cache ipv6-EID-prefix map-request


        Example:
        Device(config-router-lisp-eid-table)# map-cache ::/0 map-request
         

        Configures static EID-to-RLOC mappings for an ITR and enables sending of Map-Request message for a LISP destination EID.

         
        Step 15exit


        Example:
        Device(config-router-lisp-eid-table)# exit
         

        Exits LISP EID table configuration mode and returns to LISP configuration mode.

         
        Step 16ipv4 map-request-source source-address


        Example:
        Device(config-router-lisp)# ipv4 map-request-source 10.0.3.1
         

        Specifies the IPv4 source address to be used in LISP IPv4 Map-Request messages. The ITR RLOCs configured under Steps 7 through 10, and Step 11 take precedence. However, this step (16) is still required.

         
        Step 17ipv4 map-cache-limit cache-limit


        Example:
        Device(config-router-lisp)# ipv4 map-cache-limit 100000
         

        (Optional) Specifies maximum number of IPv4 LISP map cache entries allowed to be stored on the router. The valid range is from 0 to 100000.

         
        Step 18ipv4 proxy-etr


        Example:
        Device(config-router-lisp)# ipv4 proxy-etr
         

        Configures a device to act as an IPv4 LISP proxy egress tunnel router (PETR).

         
        Step 19ipv4 proxy-itr ipv4-local-locator ipv6-local-locator


        Example:
        Device(config-router-lisp)# ipv4 proxy-itr 10.0.3.1 2001:DB8:2::1
         

        Configures this device to act as an IPv4 proxy ingress tunnel router (PITR), and configures the IPv4 and IPv6 locator addresses used as a source address for encapsulation of data packets.

         
        Step 20ipv4 itr map-resolver map-resolver-address


        Example:
        Device(config-router-lisp)# ipv4 itr map-resolver 10.0.2.1
        Device(config-router-lisp)# ipv4 itr map-resolver 2001:DB8:1::1
         

        Configures a locator address for the LISP map resolver to which this device will send Map-Request messages for IPv4 EID-to-RLOC mapping resolutions.

        • The locator address of the map resolver may be an IPv4 or IPv6 address.
        Note    You can configure up to 8 map resolvers if multiple map resolvers are available.
         
        Step 21ipv6 map-request-source source-address


        Example:
        Device(config-router-lisp)# ipv6 map-request-source 2001:DB8:2::1
         

        The ITR RLOCs configured under Steps 7 through 10, and Step 11 take precedence. However, this step (16) is still required.

         
        Step 22ipv6 map-cache-limit cache-limit


        Example:
        Device(config-router-lisp)# ipv6 map-cache-limit 100000
         

        (Optional) Specifies the maximum number of IPv6 LISP map cache entries allowed to be stored on the device. The valid range is from 0 to 100000.

         
        Step 23ipv6 proxy-etr cache-limit


        Example:
        Device(config-router-lisp)# ipv6 proxy-etr
         

        Configures a device to act as an IPv6 LISP PETR.

         
        Step 24ipv6 proxy-itr ipv6-local-locator ipv4-local-locator


        Example:
        Device(config-router-lisp)# ipv6 proxy-itr 2001:DB8:2::1 10.0.3.1
         

        Configures this device to act as an IPv6 PITR, and configures the IPv4 and IPv6 locator addresses used as a source address for encapsulation of data packets.

         
        Step 25ipv6 itr map-resolver map-resolver-address


        Example:
        Device(config-router-lisp)#  ipv6 itr map-resolver 10.0.2.1
        Device(config-router-lisp)#  ipv6 itr map-resolver 2001:DB8:1::1
         

        Configures a locator address for the LISP map resolver to which this router will send Map-Request messages for IPv6 EID-to-RLOC mapping resolutions.

        • The locator address of the map resolver may be an IPv4 or IPv6 address.
        Note    You can configure up to eight map resolvers if multiple map resolvers are available.
         
        Step 26exit


        Example:
        Device(config-router-lisp)# exit
         

        Exits LISP configuration mode and returns to global configuration mode.

         
        Step 27ip route prefix mask ip-address


        Example:
        Device(config)# ip route 0.0.0.0 0.0.0.0 10.0.3.2
         

        Establishes static routes to the next hop destination.

         
        Step 28ipv6 route ipv6-prefix/prefix-length ipv6-address


        Example:
        Device(config)# ipv6 route ::/0 2001:DB8:ABCD::1
         

        Establishes static routes to the next hop destination.

         
        Step 29end


        Example:
        Device(config)# end
         

        Returns to privileged EXEC mode.

         

        Verifying LISP Support for Disjoint RLOC Domains

        SUMMARY STEPS

          1.    enable

          2.    show ip lisp database

          3.    show ipv6 lisp database

          4.    show lisp site detail

          5.    show ip lisp map-cache

          6.    show ipv6 lisp map-cache


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Device> enable
           
          Enables privileged EXEC mode.
          • Enter your password if prompted.
           
          Step 2 show ip lisp database


          Example:
          Device# show ip lisp database
           

          Displays Locator/ID Separation Protocol (LISP) egress tunnel router (ETR) configured local IPv4 endpoint identifier (EID) prefixes and associated locator sets.

           
          Step 3 show ipv6 lisp database


          Example:
          Device# show ipv6 lisp database
           

          Displays LISP ETR configured local IPv6 EID prefixes and associated locator sets.

           
          Step 4 show lisp site detail


          Example:
          Device# show lisp site detail
           

          Displays details of LISP sites configured on a LISP map server.

           
          Step 5 show ip lisp map-cache


          Example:
          Device# show ip lisp map-cache
           

          Displays the current dynamic and static IPv4 endpoint identifier-to-routing locator (EID-to-RLOC) map cache entries.

           
          Step 6 show ipv6 lisp map-cache


          Example:
          Device# show ipv6 lisp map-cache
           

          Displays the current dynamic and static IPv6 EID-to-RLOC map cache entries.

           

          Configuration Examples for LISP Support for Disjoint RLOC Domains

          Figure 2. LISP - Disjoint RLOC Domains topology



          The examples below show the complete configuration for the LISP topology illustrated in the figure above.

          Example: Configuring xTR

          The following example shows how to configure xTR4:

          Device> enable
          Device# configure terminal
          Device(config)# interface loopback0
          Device(config-if)# ip address 10.10.10.4 255.255.255.0
          Device(config-if)# ipv6 address 2001:DB8:0:ABCD::1/64
          Device(config-if)# interface ethernet0/0
          Device(config-if)# ip address 10.0.4.1 255.255.255.252
          Device(config-if)# router lisp
          Device(config-router-lisp)# locator-set R4
          Device(config-router-lisp-locator-set)# 10.0.4.1 priority 1 weight 1
          Device(config-router-lisp-locator-set)# exit
          Device(config-router-lisp)# eid-table default instance-id 0
          Device(config-router-lisp-eid-table)# database-mapping 10.10.10.0/24 locator-set R4
          Device(config-router-lisp-eid-table)# database-mapping  2001:DB8::/48 locator-set R4
          Device(config-router-lisp-eid-table)# exit
          Device(config-router-lisp)# ipv4 itr map-resolver 10.0.2.1
          Device(config-router-lisp)# ipv4 itr
          Device(config-router-lisp)# ipv4 etr map-server 10.0.2.1 key R4KEY
          Device(config-router-lisp)# ipv4 etr
          Device(config-router-lisp)# ipv6 itr map-resolver 10.0.2.1
          Device(config-router-lisp)# ipv6 itr
          Device(config-router-lisp)# ipv6 etr map-server 10.0.2.1 key R4KEY
          Device(config-router-lisp)# ipv6 etr
          Device(config-router-lisp)# exit
          Device(config)# ip route 0.0.0.0 0.0.0.0 10.0.4.2
          

          The following example shows how to configure xTR6:

          Device> enable
          Device# configure terminal
          Device(config)# interface loopback0
          Device(config-if)# ip address 172.16.0.4 255.255.255.0
          Device(config-if)# ipv6 address 2001:DB8::4/64
          Device(config-if)# interface ethernet0/0
          Device(config-if)# ipv6 address 2001:DB8:4::2/64
          Device(config-if)# router lisp
          Device(config-router-lisp)# locator-set R6
          Device(config-router-lisp-locator-set)# 2001:DB8:4::2 priority 1 weight 1
          Device(config-router-lisp-locator-set)# exit
          Device(config-router-lisp)# eid-table default instance-id 0
          Device(config-router-lisp-eid-table)# database-mapping 172.16.0.2/24 locator-set R4
          Device(config-router-lisp-eid-table)# database-mapping 2001:DB8::1/48 locator-set R4
          Device(config-router-lisp-eid-table)# exit
          Device(config-router-lisp)# ipv4 itr map-resolver 2001:DB8:3::2
          Device(config-router-lisp)# ipv4 itr
          Device(config-router-lisp)# ipv4 etr map-server 2001:DB8:3::2 key R4KEY
          Device(config-router-lisp)# ipv4 etr
          Device(config-router-lisp)# ipv6 itr map-resolver 2001:DB8:3::2
          Device(config-router-lisp)# ipv6 itr
          Device(config-router-lisp)# ipv6 etr map-server 2001:DB8:3::2 key R4KEY
          Device(config-router-lisp)# ipv6 etr
          Device(config-router-lisp)# exit
          Device(config)# ipv6 route ::/0 2001:DB8:4::1
          

          Example: Configuring MSMR

          Device> enable
          Device# configure terminal
          Device(config)# interface ethernet0/0
          Device(config-if)# ip address 10.0.2.1 255.255.255.252
          Device(config-if)# ipv6 address 2001:DB8:1::1/64
          Device (config-if)# router lisp
          Device(config-router-lisp)# locator-set rtr-set1
          Device(config-router-lisp-locator-set)# 10.0.3.1 priority 1 weight 1
          Device(config-router-lisp-locator-set)# exit
          Device(config-router-lisp)# locator-set rtr-set2
          Device(config-router-lisp-locator-set)# 2001:DB8:2::1/64 priority 1 weight 1
          Device(config-router-lisp-locator-set)# exit
          Device(config-router-lisp)# locator-scope s1
          Device(config-router-lisp-locator-scope)# rtr-locator-set rtr-set1
          Device(config-router-lisp-locator-scope)# rloc-prefix 0.0.0.0/0
          Device(config-router-lisp-locator-scope)# exit
          Device(config-router-lisp)# locator-scope s2
          Device(config-router-lisp-locator-scope)# rtr-locator-set rtr-set2
          Device(config-router-lisp-locator-scope)# rloc-prefix ::/0
          Device(config-router-lisp-locator-scope)# exit
          Device(config-router-lisp)# site R4
          Device(config-router-lisp-site)# authentication-key R4KEY
          Device(config-router-lisp-site)# eid-prefix 10.10.10.0/24
          Device(config-router-lisp-site)# eid-prefix 2001:DB8::/48
          Device(config-router-lisp-site)# exit
          Device(config-router-lisp)# site R6
          Device(config-router-lisp-site)# authentication-key R6KEY
          Device(config-router-lisp-site)# eid-prefix 172.16.0.2/24
          Device(config-router-lisp-site)# eid-prefix 2001:DB8::1/48
          Device(config-router-lisp-site)# exit
          Device(config-router-lisp)# ipv4 map-server
          Device(config-router-lisp)# ipv4 map-resolver
          Device(config-router-lisp)# exit
          Device(config)# ip route 0.0.0.0 0.0.0.0 10.0.2.2
          Device(config)# ipv6 route ::/0 2001:DB8:1::ABCD
          

          Example: Configuring RTR

          Device> enable
          Device# configure terminal
          Device(config)# interface Ethernet0/0
          Device(config-if)# ip address 10.0.3.1 255.255.255.252
          Device(config-if)# ipv6 address 2001:DB8:2::1/64
          Device (config-if)# router lisp
          Device(config-router-lisp)# locator-set setALL
          Device(config-router-lisp-locator-set)# 10.0.3.1 priority 1 weight 1
          Device(config-router-lisp-locator-set)# 2001:DB8:2::1 priority 1 weight 1
          Device(config-router-lisp-locator-set)# exit
          Device(config-router-lisp)# map-request itr-rlocs setALL
          Device(config-router-lisp)# eid-table default instance-id 0
          Device(config-router-lisp-eid-table)# map-cache 0.0.0.0/0 map-request
          Device(config-router-lisp-eid-table)# map-cache ::/0 map-request
          Device(config-router-lisp-eid-table)# exit
          Device(config-router-lisp)# ipv4 map-request-source 10.0.3.1
          Device(config-router-lisp)# ipv4 map-cache-limit 100000
          Device(config-router-lisp)# ipv4 proxy-etr
          Device(config-router-lisp)# ipv4 proxy-itr 10.0.3.1 2001:DB8:2::1
          Device(config-router-lisp)# ipv4 itr map-resolver 10.0.2.1
          Device(config-router-lisp)# ipv4 itr map-resolver 2001:DB8:1::1
          Device(config-router-lisp)# ipv6 map-request-source 2001:DB8:2::1
          Device(config-router-lisp)# ipv6 map-cache-limit 100000
          Device(config-router-lisp)# ipv6 proxy-etr
          Device(config-router-lisp)# ipv6 proxy-itr 2001:DB8:2::1 10.0.3.1
          Device(config-router-lisp)# ipv6 itr map-resolver 10.0.2.1
          Device(config-router-lisp)# ipv6 itr map-resolver 2001:DB8:1::1
          Device(config-router-lisp)# exit
          Device(config)# ip route 0.0.0.0 0.0.0.0 10.0.3.2
          Device(config)# ipv6 route ::/0 2001:DB8:ABCD::1
          

          Example: Verifying LISP Support for Disjoint RLOC Domains

          Sample Output for the show ip lisp database Command

          To display Locator/ID Separation Protocol (LISP) egress tunnel router (ETR) configured local IPv4 endpoint identifier (EID) prefixes and associated locator sets, use the show ip lisp database command in privileged EXEC mode.

          Device# show ip lisp database
          .
          .
          .
          10.10.10.0/24, locator-set R4
          Locator Pri/Wgt Source State
          10.0.4.1 1/1 cfg-addr site-self, reachable
          

          To display LISP ETR configured local IPv6 EID prefixes and associated locator sets, use the show ip lisp database command in privileged EXEC mode.

          Device# show ipv6 lisp database
          .
          .
          .
          2001:DB8::/48, locator-set R4
          Locator Pri/Wgt Source State
          10.0.4.1 1/1 cfg-addr site-self, reachable
           mm

          To display configured LISP sites on a LISP map server, use the show lisp site detail in privileged EXEC mode.

          Device# show lisp site detail
          .
          .
          .
          Site name: R4
          .
          .
          .
          EID-prefix: 10.10.10.0/24
          .
          .
          .
          ETR 10.0.4.1, last registered 00:00:52, no proxy-reply, map-notify
          TTL 1d00h, no merge, hash-function sha1, nonce 0x28517C31-0x7B233E66
          state complete, no security-capability
          xTR-ID 0xEC52ECC2-0x006CEAFE-0x814263B3-0x89675EB6
          site-ID unspecified
          Locator Local State Pri/Wgt Scope
          10.0.4.1 yes up 1/1 s1
          EID-prefix: 2001:DB8::/48
          .
          .
          .
          .
          ETR 10.0.4.1, last registered 00:00:39, no proxy-reply, map-notify
          TTL 1d00h, no merge, hash-function sha1, nonce 0xF91CB211-0x5B00E72C
          state complete, no security-capability
          xTR-ID 0xEC52ECC2-0x006CEAFE-0x814263B3-0x89675EB6
          site-ID unspecified
          Locator Local State Pri/Wgt Scope
          10.0.4.1 yes up 1/1 s1
          .
          .
          .
          

          To display the current dynamic and static IPv4 endpoint identifier-to-routing locator (EID-to-RLOC) map cache entries, use the show ip lisp map-cache command in privileged EXEC mode.

          Device# show ip lisp map-cache
          
          LISP IPv4 Mapping Cache for EID-table default (IID 0), 2 entries
          .
          .
          .
          172.16.0.2/24, uptime: 00:01:14, expires: 00:13:44, via map-reply, complete
            Locator   Uptime    State      Pri/Wgt
            10.0.3.1  00:01:14  up           1/1
          

          To display the current dynamic and static IPv6 EID-to-RLOC map-cache entries, use the show ipv6 lisp map-cache command in privileged EXEC mode.

          Device# show ipv6 lisp map-cache
          
          LISP IPv6 Mapping Cache for EID-table default (IID 0), 2 entries
          .
          .
          .
          2001:DB8::1/48, uptime: 00:02:18, expires: 00:12:44, via map-reply, complete
            Locator   Uptime    State      Pri/Wgt
            10.0.3.1  00:02:18  up           1/1
          

          Additional References for LISP Support for Disjoint RLOC Domains

          Related Documents

          Related Topic

          Document Title

          Cisco IOS commands

          Cisco IOS Master Command List, All Releases

          Locator/ID Separation Protocol (LISP) commands

          Cisco IOS IP Routing: LISP Command Reference

          Technical Assistance

          Description

          Link

          The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

          http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

          Feature Information for LISP Support for Disjoint RLOC Domains

          The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

          Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

          Feature Name

          Release

          Feature Information

          LISP Support for Disjoint RLOC Domains

          Cisco IOS XE Release 3.11S

          The LISP Support for Disjoint RLOC domains feature enables LISP-to-LISP communications between LISP sites that are connected to different RLOC spaces but have no connectivity to each other.