IP Routing: EIGRP Configuration Guide, Cisco IOS XE Release 3S
EIGRP Prefix Limit Support
Downloads: This chapterpdf (PDF - 1.44MB) The complete bookPDF (PDF - 4.3MB) | The complete bookePub (ePub - 722.0KB) | Feedback

EIGRP Prefix Limit Support

Contents

EIGRP Prefix Limit Support

The EIGRP Prefix Limit Support feature introduces the capability to limit the number of prefixes per VPN routing/forwarding instance (VRF) that are accepted from a specific peer or to limit all prefixes that are accepted by an Enhanced Interior Gateway Routing Protocol (EIGRP) process through peering and redistribution. This feature is designed to protect the local router from external misconfiguration that can negatively impact local system resources; for example, a peer that is misconfigured to redistribute full Border Gateway Protocol (BGP) routing tables into EIGRP. This feature is enabled under the IPv4 VRF address family and can be configured to support the MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge feature.

For more information about EIGRP MPLS VPN configuration, refer to the EIGRP MPLS VPN PE-CE Site of Origin module.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for EIGRP Prefix Limit Support

  • Multiprotocol Label Switching (MPLS) Virtual Private Network (VPN) services have been configured between the Provider Edge (PE) routers and the customer edge (CE) routers at the customer sites.

Restrictions for EIGRP Prefix Limit Support

  • This feature is supported only under the IPv4 VRF address family and can be used only to limit the number of prefixes that are accepted through a VRF.
  • The EIGRP Prefix Limiting Support feature is enabled only under the IPv4 VRF address-family. A peer that is configured to send too many prefixes or a peer that rapidly advertises and then withdraws prefixes can cause instability in the network. This feature can be configured to automatically reestablish a disabled peering session at the default or user-defined time interval or when the maximum-prefix limit is not exceeded. However, the configuration of this feature alone cannot change or correct a peer that is sending an excessive number of prefixes. If the maximum-prefix limit is exceeded, you will need to reconfigure the maximum-prefix limit or reduce the number of prefixes that are sent from the peer.

Information About EIGRP Prefix Limit Support

Misconfigured VPN Peers

In MPLS VPNs, the number of routes that are permitted in the VRF is configured with the maximum routes VRF configuration command. However, limiting the number routes permitted in the VPN does not protect the local router from a misconfigured peer that sends an excessive number of routes or prefixes. This type of external misconfiguration can have a negative effect on the local router by consuming all available system resources (CPU and memory) in processing prefix updates. This type of misconfiguration can occur on a peer that is not within the control of the local administrator.

EIGRP Prefix Limit Support Overview

The EIGRP Prefix Limit Support feature provides the ability to configure a limit on the number of prefixes that are accepted from EIGRP peers or learned through redistribution. This feature can be configured on per-peer or per-process basis and can be configured for all peers and processes. This feature is designed to protect the local router from misconfigured external peers by limiting the amount of system resources that can be consumed to process prefix updates.

External Peer Router Protection

This feature can be configured to protect an individual peering session or protect all peering sessions. When this feature is enabled and the maximum-prefix limit has been exceeded, the router will tear down the peering session, clear all routes that were learned from the peer, and then place the peer in a penalty state for the default or user-defined time period. After the penalty time period expires, normal peering will be reestablished.

Redistributed Prefix Number Limiting

This feature can be configured to limit the number of prefixes that are accepted into the EIGRP topology table through redistribution from the Routing Information Base (RIB). All sources of redistribution are processed cumulatively. When the maximum-prefix limit is exceeded, all routes learned through redistribution are discarded and redistribution is suspended for the default or user-defined time period. After the penalty time period expires, normal redistribution will occur.

EIGRP Process Level Router Protection

This feature can be configured to protect the router at the EIGRP process level. When this feature is configured at the EIGRP process level, the maximum-prefix limit is applied to all peering sessions and to route redistribution. When the maximum-prefix limit is exceeded, all sessions with the remote peers are torn down, all routes learned from remote peers are removed from the topology and routing tables, all routes learned through redistribution are discarded, and redistribution and peering are suspended for the default or user-defined time period.

EIGRP Prefix Limiting Warning-Only Mode

The EIGRP Prefix Limit Support feature has two modes of operation. This feature can control peering and redistribution per default and user-defined values or this feature can operate in warning-only mode. In warning-only mode the router will monitor the number of prefixes learned through peering and/or redistribution but will not take any action when the maximum-prefix limit is exceeded. Warning-only mode is activated only when the warning-only keyword is configured for any of the maximum-prefix limit commands. Only syslog messages are generated when this mode of operation is enabled. Syslog messages can be sent to a syslog server or printed in the console. These messages can be buffered or rate limited per standard Cisco IOS XE system logging configuration options.

EIGRP Prefix Limiting Restart Reset and Dampening Timers and Counters

The EIGRP Prefix Limit Support feature provides two user-configurable timers, a restart counter, and a dampening mechanism. When the maximum-prefix limit is exceeded, peering and/or redistribution is suspended for a default or user-defined time period. If the maximum-prefix limit is exceeded too often, redistribution and/or peering will be suspended until manual intervention is taken.

Restart Timer

The restart timer determines how long the router will wait to form an adjacency or accept redistributed routes from the RIB after the maximum-prefix limit has been exceeded. The default restart-time period is 5 minutes.

Restart Counter

The restart counter determines the number of times a peering session can be automatically reestablished after the peering session has been torn down or after the redistributed routes have been cleared and relearned because the maximum-prefix limit has been exceeded. The default restart-count limit is three.


Caution


After the restart count limit has been crossed, you will need to enter the clear ip route *, clear ip eigrp neighbor, or clear eigrp address-family neighborcommand to restore normal peering and redistribution.


Reset Timer

The reset timer is used to configure the router to reset the restart count to 0 after the default or configured reset-time period has expired. This timer is designed to provide an administrator with control over long-and medium-term accumulated penalties. The default reset-time period is 15 minutes.

Dampening Mechanism

The dampening mechanism is used to apply an exponential decay penalty to the restart-time period each time the maximum-prefix limit is exceeded. The half-life for the decay penalty is 150 percent of the default or user-defined restart-time value in minutes. This mechanism is designed to identify and suppress unstable peers. It is disabled by default.

How to Configure the Maximum-Prefix Limit

Configuring the Maximum Number of Prefixes Accepted from Peering Sessions Autonomous System Configuration

The maximum-prefix limit can be configured for all peering sessions or individual peering sessions with the neighbor maximum-prefix(EIGRP) command. When the maximum-prefix limit is exceeded, the session with the remote peer is torn down and all routes learned from the remote peer are removed from the topology and routing tables. The maximum-prefix limit that can be configured is limited only by the available system resources on the router.


Note


In EIGRP, neighbor commands have been used traditionally to configure static neighbors. In the context of this feature, however, the neighbor maximum-prefix command can be used to configure the maximum-prefix limit for both statically configured and dynamically discovered neighbors.


Default or user-defined restart, restart-count, and reset-time values for the process-level configuration of this feature, configured with the maximum-prefix command, are inherited by the redistribute maximum-prefix and neighbor maximum-prefix command configurations by default. If a single peer is configured with the neighbor maximum-prefix command, a process-level configuration or a configuration that is applied to all neighbors will be inherited.

Before You Begin
  • VRFs have been created and configured.
  • EIGRP peering is established through the MPLS VPN.

Note


  • This task can be configured only in IPv4 VRF address family configuration mode.
  • When you configure the neighbor maximum-prefix command to protect a single peering session, only the maximum-prefix limit, the percentage threshold, the warning-only configuration options can be configured. Session dampening, restart, and reset timers are configured on a global basis.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    router eigrp as-number

    4.    address-family ipv4 [unicast][vrf vrf-name] autonomous-system autonomous-system-number

    5.    neighbor {ip-address | peer-group-name} description text

    6.    neighbor ip-address maximum-prefix maximum [threshold] [warning-only]

    7.    neighbor maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

    8.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 router eigrp as-number


    Example:
    Router(config)# router eigrp 1
     

    Enters router configuration mode and creates an EIGRP routing process.

    • A maximum of 30 EIGRP routing processes can be configured.
     
    Step 4 address-family ipv4 [unicast][vrf vrf-name] autonomous-system autonomous-system-number


    Example:
    Router(config-router)# address-family ipv4 vrf vrf1 autonomous-system 4453
     

    Enters address family configuration mode and creates a session for the VRF.

     
    Step 5 neighbor {ip-address | peer-group-name} description text


    Example:
    Router(config-router-af)# neighbor 172.16.2.3 description peer with example.com
     

    (Optional) Associates a description with a neighbor.

     
    Step 6 neighbor ip-address maximum-prefix maximum [threshold] [warning-only]


    Example:
    Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 10000 80 warning-only
     

    Limits the number of prefixes that are accepted from the specified EIGRP neighbor.

     
    Step 7 neighbor maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]


    Example:
    Router(config-router-af)# neighbor maximum-prefix 10000 80 warning-only 
     

    Limits the number of prefixes that are accepted from all EIGRP neighbors.

     
    Step 8 end


    Example:
    Router(config-router-af)# end 
     

    Exits address family configuration mode and enters privileged EXEC mode.

     

    Troubleshooting Tips

    If an individual peer or all peers have exceeded the maximum-prefix limit the same number of times as the default or user-defined restart-count value, the individual session or all sessions will need to be manually reset with the clear ip route* or clear ip eigrp neighbor command before normal peering can be reestablished.

    Configuring the Maximum Number of Prefixes Accepted from Peering Sessions Named Configuration

    The maximum-prefix limit can be configured for all peering sessions or individual peering sessions with the neighbor maximum-prefix (EIGRP) command. When the maximum-prefix limit is exceeded, the session with the remote peer is torn down and all routes learned from the remote peer are removed from the topology and routing tables. The maximum-prefix limit that can be configured is limited only by the available system resources on the router.


    Note


    In EIGRP, neighbor commands have been used traditionally to configure static neighbors. In the context of this feature, however, the neighbor maximum-prefix command can be used to configure the maximum-prefix limit for both statically configured and dynamically discovered neighbors.


    Default or user-defined restart, restart-count, and reset-time values for the process-level configuration of this feature, configured with the maximum-prefix command, are inherited by the redistribute maximum-prefix and neighbor maximum-prefix command configurations by default. If a single peer is configured with the neighbor maximum-prefix command, a process-level configuration or a configuration that is applied to all neighbors will be inherited.

    Before You Begin
    • VRFs have been created and configured.
    • EIGRP peering is established through the MPLS VPN.

    Note


    • This task can be configured only in IPv4 VRF address family configuration mode.
    • When you configure the neighbor maximum-prefix command to protect a single peering session, only the maximum-prefix limit, the percentage threshold, and the warning-only configuration options can be configured. Session dampening, restart, and reset timers are configured on a global basis.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    router eigrp virtual-instance-name

      4.    address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

      5.    neighbor {ip-address | peer-group-name} description text

      6.    neighbor ip-address maximum-prefix maximum [threshold] [warning-only]

      7.    neighbor maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

      8.    exit-address-family


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 router eigrp virtual-instance-name


      Example:
      Router(config)# router eigrp virtual-name1
       

      Enters router configuration mode and creates an EIGRP routing process.

      • A maximum of 30 EIGRP routing processes can be configured.
       
      Step 4 address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number


      Example:
      Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
       

      Enters address family configuration mode and creates a session for the VRF.

       
      Step 5 neighbor {ip-address | peer-group-name} description text


      Example:
      Router(config-router-af)# neighbor 172.16.2.3 description peer with example.com
       

      (Optional) Associates a description with a neighbor.

       
      Step 6 neighbor ip-address maximum-prefix maximum [threshold] [warning-only]


      Example:
      Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 10000 80 warning-only
       

      Limits the number of prefixes that are accepted from the specified EIGRP neighbor.

       
      Step 7 neighbor maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]


      Example:
      Router(config-router-af)# neighbor maximum-prefix 10000 80 warning-only 
       

      Limits the number of prefixes that are accepted from all EIGRP neighbors.

       
      Step 8 exit-address-family


      Example:
      Router(config-router-af)# exit-address-family 
       

      Exits address family configuration mode.

       

      Troubleshooting Tips

      If an individual peer or all peers have exceeded the maximum-prefix limit the same number of times as the default or user-defined restart-count value, the individual session or all sessions will need to be manually reset with the clear ip route* or clear eigrp address-family neighbors command before normal peering can be reestablished.

      Configuring the Maximum Number of Prefixes Learned Through Redistribution Autonomous System Configuration

      The maximum-prefix limit can be configured for prefixes learned through redistribution with the redistribute maximum-prefix (EIGRP) command. When the maximum-prefix limit is exceeded, all routes learned from the RIB will be discarded and redistribution will be suspended for the default or user-defined time period. The maximum-prefix limit that can be configured for redistributed prefixes is limited only by the available system resources on the router.

      Default or user-defined restart, restart-count, and reset-time values for the process-level configuration of this feature, configured with the maximum-prefix command, are inherited by the redistribute maximum-prefix and neighbor maximum-prefix command configurations by default. If a single peer is configured with the neighbor maximum-prefix command, a process-level configuration or a configuration that is applied to all neighbors will be inherited.

      Before You Begin
      • VRFs have been created and configured.
      • EIGRP peering is established through the MPLS VPN.

      Note


      This task can be configured only in IPv4 VRF address family configuration mode.


      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    router eigrp as-number

        4.    address-family ipv4 [unicast] vrf vrf-name

        5.    redistribute maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

        6.    end


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters global configuration mode.

         
        Step 3 router eigrp as-number


        Example:
        Router(config)# router eigrp 1
         

        Enters router configuration mode and creates an EIGRP routing process.

        • A maximum of 30 EIGRP routing processes can be configured.
         
        Step 4 address-family ipv4 [unicast] vrf vrf-name


        Example:
        Router(config-router)# address-family ipv4 vrf VRF1
         

        Enters address family configuration mode and creates a session for the VRF.

         
        Step 5 redistribute maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]


        Example:
        Router(config-router-af)# redistribute maximum-prefix 10000 80 reset-time 10 restart 2 
         

        Limits the number of prefixes redistributed into an EIGRP process.

         
        Step 6 end


        Example:
        Router(config-router-af)# end 
         

        Exits address family configuration mode and enters privileged EXEC mode.

         

        Troubleshooting Tips

        If the maximum-prefix limit has been exceeded for redistribution the same number of times as the default or user-defined restart-count value, the clear ip route * or clear ip eigrp neighbors command will need to be entered before normal redistribution will occur.

        Configuring the Maximum Number of Prefixes Learned Through Redistribution Named Configuration

        The maximum-prefix limit can be configured for prefixes learned through redistribution with the redistribute maximum-prefix(EIGRP) command. When the maximum-prefix limit is exceeded, all routes learned from the RIB will be discarded and redistribution will be suspended for the default or user-defined time period. The maximum-prefix limit that can be configured for redistributed prefixes is limited only by the available system resources on the router.

        Default or user-defined restart, restart-count, and reset-time values for the process-level configuration of this feature, configured with the maximum-prefix command, are inherited by the redistribute maximum-prefix and neighbor maximum-prefix command configurations by default. If a single peer is configured with the neighbor maximum-prefix command, a process-level configuration or a configuration that is applied to all neighbors will be inherited.

        Before You Begin
        • VRFs have been created and configured.
        • EIGRP peering is established through the MPLS VPN.

        Note


        This task can be configured only in IPv4 VRF address family topology configuration mode.


        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    router eigrp virtual-instance-name

          4.    address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

          5.    network ip-address [wildcard-mask]

          6.    topology base

          7.    redistribute maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

          8.    exit-af-topology


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 router eigrp virtual-instance-name


          Example:
          Router(config)# router eigrp virtual-name1
           

          Enters router configuration mode and creates an EIGRP routing process.

          • A maximum of 30 EIGRP routing processes can be configured.
           
          Step 4 address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number


          Example:
          Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
           

          Enters address family configuration mode and creates a session for the VRF.

           
          Step 5 network ip-address [wildcard-mask]


          Example:
          Router(config-router-af)# network 172.16.0.0
           

          Specifies the network for an EIGRP address family routing process.

           
          Step 6 topology base


          Example:
          Router(config-router-af)# topology base
           

          Configures an EIGRP process to route traffic under the specified topology instance and enters address family topology configuration mode.

           
          Step 7 redistribute maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]


          Example:
          Router(config-router-af-topology)# redistribute maximum-prefix 10000 80 reset-time 10 restart 2 
           

          Limits the number of prefixes redistributed into an EIGRP process.

           
          Step 8 exit-af-topology


          Example:
          Router(config-router-af-topology)# exit-af-topology
           

          Exits address family topology configuration mode.

           

          Troubleshooting Tips

          If the maximum-prefix limit has been exceeded for redistribution the same number of times as the default or user-defined restart-count value, the clear ip route * or clear eigrp address-family neighborscommand will need to be entered before normal redistribution will occur.

          Configuring the Maximum-Prefix Limit for an EIGRP Process Autonomous System Configuration

          The maximum-prefix limit can be configured for an EIGRP process to limit the number prefixes that are accepted from all sources. This task is configured with the maximum-prefixcommand. When the maximum-prefix limit is exceeded, sessions with the remote peers are brought down and all routes learned from remote peers are removed from the topology and routing tables. Also, all routes learned from the RIB are discarded and redistribution is suspended for the default or user-defined time period.

          Default or user-defined restart, restart-count, and reset-time values for the process-level configuration of this feature, configured with the maximum-prefix command, are inherited by the redistribute maximum-prefix and neighbor maximum-prefix command configurations by default. If a single peer is configured with the neighbor maximum-prefix command, a process-level configuration or a configuration that is applied to all neighbors will be inherited.

          Before You Begin
          • VRFs have been created and configured.
          • EIGRP peering is established through the MPLS VPN.

          Note


          This task can be configured only in IPv4 VRF address family configuration mode.


          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    router eigrp as-number

            4.    address-family ipv4 [unicast] vrf vrf-name[autonomous-system autonomous-system-number]

            5.    maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

            6.    end


          DETAILED STEPS
             Command or ActionPurpose
            Step 1 enable


            Example:
            Router> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.
             
            Step 2 configure terminal


            Example:
            Router# configure terminal
             

            Enters global configuration mode.

             
            Step 3 router eigrp as-number


            Example:
            Router(config)# router eigrp 1
             

            Enters router configuration mode and creates an EIGRP routing process.

            • A maximum of 30 EIGRP routing processes can be configured.
             
            Step 4 address-family ipv4 [unicast] vrf vrf-name[autonomous-system autonomous-system-number]


            Example:
            Router(config-router)# address-family ipv4 vrf VRF1
             

            Enters address family configuration mode and creates a session for the VRF.

             
            Step 5 maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]


            Example:
            Router(config-router-af)# maximum-prefix 10000 80 reset-time 10 restart 2
             

            Limits the number of prefixes that are accepted under an address family by an EIGRP process.

            • The example configures a maximum-prefix limit of 10,000 prefixes, a reset time period of 10 minutes, a warning message to be displayed at 80 percent of the maximum-prefix limit, and a restart time period of 2 minutes.
             
            Step 6 end


            Example:
            Router(config-router-af)# end 
             

            Exits address family configuration mode and enters privileged EXEC mode.

             

            Troubleshooting Tips

            If the maximum-prefix limit has been exceeded for redistribution the same number of times as the default or user-defined restart-count value, the clear ip route * or clear ip eigrp neighbors command will need to be entered before normal redistribution will occur.

            Configuring the Maximum-Prefix Limit for an EIGRP Process Named Configuration

            The maximum-prefix limit can be configured for an EIGRP process to limit the number prefixes that are accepted from all sources. This task is configured with the maximum-prefixcommand. When the maximum-prefix limit is exceeded, sessions with the remote peers are brought down and all routes learned from remote peers are removed from the topology and routing tables. Also, all routes learned from the RIB are discarded and redistribution is suspended for the default or user-defined time period.

            Default or user-defined restart, restart-count, and reset-time values for the process-level configuration of this feature, configured with the maximum-prefix command, are inherited by the redistribute maximum-prefix and neighbor maximum-prefix command configurations by default. If a single peer is configured with the neighbor maximum-prefix command, a process-level configuration or a configuration that is applied to all neighbors will be inherited.

            Before You Begin
            • VRFs have been created and configured.
            • EIGRP peering is established through the MPLS VPN.

            Note


            This task can be configured only in IPv4 VRF address family topology configuration mode.


            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    router eigrp virtual-instance-name

              4.    address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

              5.    maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

              6.    exit-address-family

              7.    show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] accounting


            DETAILED STEPS
               Command or ActionPurpose
              Step 1 enable


              Example:
              Router> enable
               

              Enables privileged EXEC mode.

              • Enter your password if prompted.
               
              Step 2 configure terminal


              Example:
              Router# configure terminal
               

              Enters global configuration mode.

               
              Step 3 router eigrp virtual-instance-name


              Example:
              Router(config)# router eigrp virtual-name1
               

              Creates an EIGRP routing process and enters router configuration mode.

              • A maximum of 30 EIGRP routing processes can be configured.
               
              Step 4 address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number


              Example:
              Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
               

              Enters address family configuration mode and creates a session for the VRF.

               
              Step 5 maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]


              Example:
              Router(config-router-af)# maximum- prefix 10000 80 reset-time 10 restart 2 warning-only
               

              Limits the number of prefixes that are accepted under an address family by an EIGRP process.

              • The example configures a maximum-prefix limit of 10,000 prefixes, a reset time period of 10 minutes, a warning message to be displayed at 80 percent of the maximum-prefix limit, and a restart time period of 2 minutes.
               
              Step 6 exit-address-family


              Example:
              Router(config-router-af)# exit-af-topology
               

              Exits address family configuration mode.

               
              Step 7 show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] accounting


              Example:
              Router# show eigrp address-family ipv4 22 accounting 
               

              (Optional) Displays prefix accounting information for EIGRP processes.

              Note   

              Connected and summary routes are not listed individually in the output from this show command but are counted in the total aggregate count per process.

               

              Example

              The following is sample output from the show eigrp address-family accounting command:

              Router# show eigrp address-family ipv4 22 accounting 
              EIGRP-IPv4 VR(saf) Accounting for AS(22)/ID(10.0.0.1) 
              Total Prefix Count: 3  States: A-Adjacency, P-Pending, D-Down 
              State Address/Source    Interface       Prefix   Restart  Restart/ 
                                                      Count     Count   Reset(s) 
               A    10.0.0.2          Et0/0               2         0        0
               P    10.0.2.4          Se2/0               0         2        114
               D    10.0.1.3          Et0/0               0         3        0 

              Troubleshooting Tips

              If the maximum-prefix limit has been exceeded for redistribution the same number of times as the default or user-defined restart-count value, the clear ip route * or clear eigrp address-family neighborscommand will need to be entered before normal redistribution will occur.

              Configuration Examples for Configuring the Maximum-Prefix Limit

              Example Configuring the Maximum-Prefix Limit for a Single Peer--Autonomous System Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for a single peer. The maximum limit is set to 1000 prefixes, and the warning threshold is set to 80 percent. When the maximum-prefix limit is exceeded, the session with this peer will be torn down, all routes learned from this peer will be removed from the topology and routing tables, and this peer will be placed in a penalty state for 5 minutes (default penalty value).

              Router(config)# router eigrp 100
              Router(config-router)# address-family ipv4 vrf VRF1
              Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 1000 80 
              Router(config-router-af)# end
              

              Example Configuring the Maximum-Prefix Limit for a Single Peer--Named Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for a single peer. The maximum limit is set to 1000 prefixes, and the warning threshold is set to 80 percent. When the maximum-prefix limit is exceeded, the session with this peer will be torn down, all routes learned from this peer will be removed from the topology and routing tables, and this peer will be placed in a penalty state for 5 minutes (default penalty value).

              Router(config)# router eigrp virtual-name1
              Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
              Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 1000 80 
              Router(config-router-af)# exit-address-family
              

              Example Configuring the Maximum-Prefix Limit for All Peers--Autonomous System Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for all peers. The maximum limit is set to 10,000 prefixes, the warning threshold is set to 90 percent, the restart timer is set to 4 minutes, a decay penalty is configured for the restart timer with the dampenedkeyword, and all timers are configured to be reset to 0 every 60 minutes. When the maximum-prefix limit is exceeded, all peering sessions will be torn down, all routes learned from all peers will be removed from the topology and routing tables, and all peers will be placed in a penalty state for 4 minutes (user-defined penalty value). A dampening exponential decay penalty will also be applied.

              Router(config)# router eigrp 100
              Router(config-router)# address-family ipv4 vrf VRF1
              Router(config-router-af)# neighbor maximum-prefix 10000 90 dampened reset-time 60
               restart 4
              Router(config-router-af)# end
              

              Example Configuring the Maximum-Prefix Limit for All Peers--Named Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for all peers. The maximum limit is set to 10,000 prefixes, the warning threshold is set to 90 percent, the restart timer is set to 4 minutes, a decay penalty is configured for the restart timer with the dampenedkeyword, and all timers are configured to be reset to 0 every 60 minutes. When the maximum-prefix limit is exceeded, all peering sessions will be torn down, all routes learned from all peers will be removed from the topology and routing tables, and all peers will be placed in a penalty state for 4 minutes (user-defined penalty value). A dampening exponential decay penalty will also be applied.

              Router(config)# router eigrp virtual-name1
              Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
              Router(config-router-af)# neighbor maximum-prefix 10000 90 dampened reset-time 60
               restart 4
              Router(config-router-af)# exit-address-family
              

              Example Configuring the Maximum-Prefix Limit for Redistributed Routes--Autonomous System Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for routes learned through redistribution. The maximum limit is set to 5000 prefixes and the warning threshold is set to 95 percent. When the number of prefixes learned through redistribution reaches 4750 (95 percent of 5000), warning messages will be displayed in the console. Because the warning-only keyword is configured, the topology and routing tables will not be cleared and route redistribution will not be placed in a penalty state.

              Router(config)# router eigrp 100
              Router(config-router)# address-family ipv4 vrf VRF1
              Router(config-router-af)# redistribute maximum-prefix 5000 95 warning-only 
              Router(config-router-af)# end
              

              Example Configuring the Maximum-Prefix Limit for Redistributed Routes--Named Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for routes learned through redistribution. The maximum limit is set to 5000 prefixes and the warning threshold is set to 95 percent. When the number of prefixes learned through redistribution reaches 4750 (95 percent of 5000), warning messages will be displayed in the console. Because the warning-only keyword is configured, the topology and routing tables will not be cleared and route redistribution will not be placed in a penalty state.

              Router(config)# router eigrp virtual-name1
              Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
              Router(config-router-af)# network 172.16.0.0
              Router(config-router-af)# topology base
              Router(config-router-af-topology)# redistribute maximum-prefix 5000 95 warning-only 
              Router(config-router-af-topology)# exit-af-topology
              

              Example Configuring the Maximum-Prefix Limit for an EIGRP Process--Autonomous System Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for an EIGRP process, which includes routes learned through redistribution and routes learned through EIGRP peering sessions. The maximum limit is set to 50,000 prefixes. When the number of prefixes learned through redistribution reaches 37,500 (75 percent of 50,000), warning messages will be displayed in the console.

              When the maximum-prefix limit is exceeded, all peering sessions will be reset, the topology and routing tables will be cleared, and redistributed routes and all peering sessions will be placed in a penalty state.

              Router(config)# router eigrp 100
              Router(config-router)# address-family ipv4 vrf RED
              Router(config-router-af)# maximum-prefix 50000 
              Router(config-router-af)# end
              

              Example Configuring the Maximum-Prefix Limit for an EIGRP Process--Named Configuration

              The following example, starting in global configuration mode, configures the maximum-prefix limit for an EIGRP process, which includes routes learned through redistribution and routes learned through EIGRP peering sessions. The maximum limit is set to 50,000 prefixes. When the number of prefixes learned through redistribution reaches 37,500 (75 percent of 50,000), warning messages will be displayed in the console.

              When the maximum-prefix limit is exceeded, all peering sessions will be reset, the topology and routing tables will be cleared, and redistributed routes and all peering sessions will be placed in a penalty state.

              Router(config)# router eigrp virtual-name
              Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
              Router(config-router-af)# maximum-prefix 50000 
              Router(config-router-af)# exit-address-family
              

              Additional References

              Related Documents

              Related Topic

              Document Title

              Cisco IOS commands

              Cisco IOS Master Commands List, All Releases

              EIGRP commands

              Cisco IOS IP Routing: EIGRP Command Reference

              EIGRP autonomous system configuration and EIGRP named configuration

              Configuring EIGRP module

              BGP cost community configuration tasks for EIGRP MPLS VPN PE-CE

              BGP Cost Community module of the Cisco IOS IP Routing: BGP Configuration Guide

              Basic EIGRP configuration tasks

              Configuring EIGRP module

              EIGRP MPLS VPN configuration tasks

              EIGRP MPLS VPN PE-CE Site of Origin (SoO) module

              MPLS VPNs configuration tasks

              Configuring MPLS Layer 3 VPNs module of the Cisco IOS Multiprotocol Label Switching Configuration Guide

              Standards

              Standards

              Title

              None

              --

              MIBs

              MIBs

              MIBs Link

              None

              To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

              http:/​/​www.cisco.com/​go/​mibs

              RFCs

              RFCs

              Title

              None

              --

              Technical Assistance

              Description

              Link

              The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

              http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

              Feature Information for EIGRP Prefix Limit Support

              The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

              Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

              Table 1 Feature Information for EIGRP Prefix Limit Support

              Feature Name

              Releases

              Feature Information

              EIGRP Prefix Limit Support

              Cisco IOS XE Release 2.6

              The EIGRP Prefix Limit Support feature introduces the capability to limit the number of prefixes per VRF that are accepted from a specific peer or to limit all prefixes that are accepted by an Enhanced Interior Gateway Routing Protocol (EIGRP) process through peering and redistribution.

              In Cisco IOS XE Release 2.6, the following commands were introduced or modified: maximum-prefix, neighbor description, neighbor maximum-prefix, redistribute maximum-prefix(EIGRP).