IP Routing EIGRP Configuration Guide, Cisco IOS Release 15S
EIGRP Stub Routing
Downloads: This chapterpdf (PDF - 1.39MB) The complete bookPDF (PDF - 4.06MB) | The complete bookePub (ePub - 703.0KB) | Feedback

EIGRP Stub Routing

Contents

EIGRP Stub Routing

The EIGRP stub routing feature improves network stability, reduces resource utilization, and simplifies the stub device configuration.

Stub routing is commonly used in hub-and-spoke network topologies. In a hub-and-spoke network, one or more end (stub) networks are connected to a remote device (the spoke) that is connected to one or more distribution devices (the hub). The remote device is adjacent to one or more distribution devices. The only route for IP traffic to reach the remote device is through a distribution device.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About EIGRP Stub Routing

EIGRP Stub Routing

The EIGRP stub routing feature improves network stability, reduces resource utilization, and simplifies the stub device configuration.

Stub routing is commonly used in hub-and-spoke network topologies. In a hub-and-spoke network, one or more end (stub) networks are connected to a remote device (the spoke) that is connected to one or more distribution devices (the hub). The remote device is adjacent to one or more distribution devices. The only route for IP traffic to reach the remote device is through a distribution device. This type of configuration is commonly used in WAN topologies, where the distribution device is directly connected to a WAN. The distribution device can be connected to many remote devices, which is often the case. In a hub-and-spoke topology, the remote device must forward all nonlocal traffic to a distribution device, so it becomes unnecessary for the remote device to have a complete routing table. Generally, the distribution device need not send anything more than a default route to the remote device.

When using the EIGRP stub routing feature, you need to configure the distribution and remote devices to use EIGRP and configure only the remote device as a stub. Only specified routes are propagated from the remote (stub) device. The stub device responds to all queries for summaries, connected routes, redistributed static routes, external routes, and internal routes with the message “inaccessible.” A device that is configured as a stub will send a special peer information packet to all neighboring devices to report its status as a stub device.

Any neighbor that receives a packet informing it of the stub status will not query the stub device for any routes, and a device that has a stub peer will not query that peer. The stub device will depend on the distribution device to send proper updates to all peers.

The figure below shows a simple hub-and-spoke network.

Figure 1. Simple Hub-and-Spoke Network

The stub routing feature by itself does not prevent routes from being advertised to the remote device. In the above example, the remote device can access the corporate network and the Internet only through the distribution device. Having a complete route table on the remote device would serve no functional purpose because the path to the corporate network and the Internet would always be through the distribution device. The large route table would only reduce the amount of memory required by the remote device. Bandwidth and memory can be conserved by summarizing and filtering routes in the distribution device. The remote device need not receive routes that have been learned from other networks because the remote device must send all nonlocal traffic, regardless of the destination, to the distribution device. If a true stub network is desired, the distribution device should be configured to send only a default route to the remote device. The EIGRP stub routing feature does not automatically enable summarization on distribution devices. In most cases, the network administrator will need to configure summarization on distribution devices.


Note


When configuring the distribution device to send only a default route to the remote device, you must use the ip classless command on the remote device. By default, the ip classless command is enabled in all Cisco images that support the EIGRP stub routing feature.


Without the EIGRP stub routing feature, even after routes that are sent from the distribution device to the remote device have been filtered or summarized, a problem might occur. If a route is lost somewhere in the corporate network, EIGRP could send a query to the distribution device, which in turn would send a query to the remote device, even if routes are being summarized. If there is a communication problem (over the WAN link) between the distribution device and the remote device, an EIGRP stuck in active (SIA) condition could occur and cause instability elsewhere in the network. The EIGRP stub routing feature allows a network administrator to prevent queries from being sent to the remote device.

Dual-Homed Remote Topology

In addition to a simple hub-and-spoke network, where a remote device is connected to a single distribution device, the remote device can be dual-homed to two or more distribution devices. This configuration adds redundancy and introduces unique issues, and the stub feature helps to address some of these issues.

A dual-homed remote device will have two or more distribution (hub) devices. However, the principles of stub routing are the same as they are with a hub-and-spoke topology. The figure below shows a common dual-homed remote topology with one remote device: however, 100 or more devices could be connected on the same interfaces on distribution router 1 and distribution router 2. The remote device will use the best route to reach its destination. If distribution router 1 experiences a failure, the remote device can still use distribution router 2 to reach the corporate network.

Figure 2. Simple Dual-Homed Remote Topology

The figure above shows a simple dual-homed remote topology with one remote device and two distribution devices. Both distribution devices maintain routes to the corporate network and stub network 10.1.1.0/24.

Dual-homed routing can introduce instability into an EIGRP network. In the figure below, distribution router 1 is directly connected to network 10.3.1.0/24. If summarization or filtering is applied on distribution router 1, the device will advertise network 10.3.1.0/24 to all of its directly connected EIGRP neighbors (distribution router 2 and the remote device).

Figure 3. Dual-Homed Remote Topology with Distribution Router 1 Connected to Two Networks

The figure above shows a simple dual-homed remote topology, where distribution router 1 is connected to both network 10.3.1.0/24 and network 10.2.1.0/24.

If the 10.2.1.0/24 link between distribution router 1 and distribution router 2 fails, the lowest cost path to network 10.3.1.0/24 from distribution router 2 will be through the remote device (see the figure below). This route is not desirable because the traffic that was previously traveling across the corporate network 10.2.1.0/24 would now be sent across a much lower bandwidth connection. The overutilization of the lower bandwidth WAN connection can cause many problems that might affect the entire corporate network. The use of the lower bandwidth route that passes through the remote device may cause WAN EIGRP distribution devices to be dropped. Serial lines on distribution and remote devices may also be dropped, and EIGRP SIA errors on the distribution and core devices can occur.

Figure 4. Dual-Homed Remote Topology with a Failed Route to a Distribution Device

It is not desirable for traffic from distribution router 2 to travel through any remote device to reach network 10.3.1.0/24. Backup routes can be used if links are sized to manage the load. However, most networks, of the type shown in the figure above, have remote devices located at remote offices with relatively slow links. To ensure that traffic from distribution devices are not routed through a remote device, you can configure route summarization on the distribution device and the remote device.

It is typically undesirable for traffic from a distribution device to use a remote device as a transit path. A typical connection from a distribution device to a remote device would have much less bandwidth than a connection at the network core. Attempting to use a remote device with a limited bandwidth connection as a transit path would generally produce excessive congestion at the remote device. The EIGRP stub routing feature can prevent this problem by preventing the remote device from advertising core routes back to the distribution devices. In the above example, routes learned by the remote device from distribution router 1 will not be advertised to distribution router 2. Therefore, distribution router 2 will not use the remote device as a transit for traffic destined to the network core.

The EIGRP stub routing feature provides network stability. If the network is not stable, this feature prevents EIGRP queries from being sent over limited bandwidth links to nontransit devices. Instead, distribution devices to which the stub device is connected answer queries on behalf of the stub device. This feature greatly reduces the chance of further network instability due to congested or problematic WAN links. The EIGRP stub routing feature also simplifies the configuration and maintenance of hub-and-spoke networks. When stub routing is enabled in dual-homed remote configurations, it is no longer necessary to configure filtering on remote devices to prevent those devices from appearing as transit paths to hub devices.


Caution


The EIGRP stub routing feature should be used only on stub devices. A stub device is defined as a device connected to the network core or distribution layer through which core transit traffic should not flow. A stub device should not have any EIGRP neighbors other than distribution devices. Ignoring this restriction will cause undesirable behavior.



Note


Multiaccess interfaces such as ATM, Gigabit Ethernet, Frame Relay, ISDN PRI, and X.25 are supported by the EIGRP stub routing feature only when all devices on that interface, except the hub, are configured as stub devices.


How to Configure EIGRP Stub Routing

Configuring the EIGRP Stub Routing Autonomous System Configuration

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    router eigrp autonomous-system-number

    4.    network ip-address [wildcard-mask]

    5.    eigrp stub [receive-only] [leak-map name] [connected] [static] [summary] [redistributed]

    6.    end

    7.    show ip eigrp neighbors [interface-type | as-number | static | detail]


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 router eigrp autonomous-system-number


    Example:
    Device(config)# router eigrp 1
     

    Configures a remote or distribution device to run an EIGRP process and enters router configuration mode.

     
    Step 4 network ip-address [wildcard-mask]


    Example:
    Device(config-router)# network 172.16.0.0
     

    Specifies the network address of the EIGRP distribution device.

     
    Step 5 eigrp stub [receive-only] [leak-map name] [connected] [static] [summary] [redistributed]


    Example:
    Device(config-router)# eigrp stub connected static
     

    Configures a remote device as an EIGRP stub device.

     
    Step 6 end


    Example:
    Device(config-router)# end
     

    Exits router configuration mode and returns to privileged EXEC mode.

     
    Step 7 show ip eigrp neighbors [interface-type | as-number | static | detail]


    Example:
    Device# show ip eigrp neighbors detail
     

    (Optional) Verifies that a remote device has been configured as a stub device with EIGRP.

    • Enter this command on the distribution device. The last line of the output displays the stub status of the remote or spoke device.

     

    Configuring the EIGRP Stub Routing Named Configuration

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    router eigrp virtual-instance-name

      4.    Enter one of the following:

      • address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number
      • address-family ipv6 [unicast] [vrf vrf-name] autonomous-system autonomous-system-number

      5.    network ip-address [wildcard-mask]

      6.    eigrp stub [receive-only] [leak-map name] [connected] [static ] [summary] [redistributed]

      7.    exit-address-family

      8.    end

      9.    show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] [neighbors] [static] [detail] [interface-type interface-number]


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.

       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 router eigrp virtual-instance-name


      Example:
      Device(config)# router eigrp virtual-name1
       

      Enables an EIGRP routing process and enters router configuration mode.

       
      Step 4Enter one of the following:
      • address-family ipv4 [multicast] [unicast] [vrf vrf-name] autonomous-system autonomous-system-number
      • address-family ipv6 [unicast] [vrf vrf-name] autonomous-system autonomous-system-number


      Example:
      Device(config-router)# address-family ipv4 autonomous-system 45000
      Device(config-router)# address-family ipv6 autonomous-system 45000
       

      Enters address family configuration mode to configure an EIGRP IPv4 or IPv6 routing instance.

       
      Step 5 network ip-address [wildcard-mask]


      Example:
      Device(config-router-af)# network 172.16.0.0
       

      Specifies the network address of the EIGRP distribution device.

       
      Step 6 eigrp stub [receive-only] [leak-map name] [connected] [static ] [summary] [redistributed]


      Example:
      Device(config-router-af) eigrp stub leak-map map1
       

      Configures a device as a stub using EIGRP.

       
      Step 7 exit-address-family


      Example:
      Device(config-router-af)# exit-address-family
       

      Exits address family configuration mode.

       
      Step 8 end


      Example:
      Device(config-router)# end
       

      Exits router configuration mode and returns to privileged EXEC mode.

       
      Step 9 show eigrp address-family {ipv4 | ipv6} [vrf vrf-name] [autonomous-system-number] [multicast] [neighbors] [static] [detail] [interface-type interface-number]


      Example:
      Device# show eigrp address-family ipv4 neighbors detail 
       

      (Optional) Displays neighbors discovered by EIGRP.

       

      Configuration Examples for EIGRP Stub Routing

      Example: EIGRP Stub Routing—Autonomous System Configuration

      A device that is configured as a stub with the eigrp stub command shares connected and summary routing information with all neighbor devices by default. The following six keywords can be used with the eigrp stub command to modify this behavior:

      • connected

      • leak-map

      • receive-only

      • redistributed

      • static

      • summary

      This section provides configuration examples for all forms of the eigrp stub command for an EIGRP autonomous system configuration.

      Example: eigrp stub Command

      In the following example, the eigrp stub command is used to configure the device as a stub that advertises connected and summary routes:

      Device(config)# router eigrp 1
      Device(config-router)# network 10.0.0.0
      Device(config-router)# eigrp stub
      

      Example: eigrp stub connected static Command

      In the following example, the eigrp stub command is used with the connected and static keywords to configure the device as a stub that advertises connected and static routes (sending summary routes will not be permitted):

      Device(config)# router eigrp 1
      Device(config-router)# network 10.0.0.0
      Device(config-router)# eigrp stub connected static
      

      Example: eigrp stub leak-map Command

      In the following example, the eigrp stub command is issued with the leak-map name keyword-argument pair to configure the device to reference a leak map that identifies routes that would have been suppressed:

      Device(config)# router eigrp 1
      Device(config-router)# network 10.0.0.0
      Device(config-router)# eigrp stub leak-map map1
      

      Example: eigrp stub receive-only Command

      In the following example, the eigrp stub command is issued with the receive-only keyword to configure the device as a receive-only neighbor (connected, summary, and static routes will not be sent):

      Device(config)# router eigrp 1
      Device(config-router)# network 10.0.0.0
      Device(config-router)# eigrp stub receive-only
      

      Example: eigrp stub redistributed Command

      In the following example, the eigrp stub command is issued with the redistributed keyword to configure the device to advertise other protocols and autonomous systems:

      Device(config)# router eigrp 1
      Device(config-router)# network 10.0.0.0
      Device(config-router)# eigrp stub redistributed
      

      Example: EIGRP Stub Routing—Named Configuration

      A device that is configured as a stub with the eigrp stub command shares connected and summary routing information with all neighbor devices by default. The following six keywords can be used with the eigrp stub command to modify this behavior:

      • connected

      • leak-map

      • receive-only

      • redistributed

      • static

      • summary

      This section provides configuration examples for all forms of the eigrp stub command for an EIGRP named configuration.

      Example: eigrp stub Command

      In the following example, the eigrp stub command is used to configure the device as a stub that advertises connected and summary routes:

      Device(config)# router eigrp virtual-name1
      Device(config-router)# address-family ipv4 autonomous-system 4453
      Device(config-router-af)# network 10.0.0.0
      Device(config-router-af) eigrp stub
      

      Example: eigrp stub connected static Command

      In the following named configuration example, the eigrp stub command is issued with the connected and static keywords to configure the device as a stub that advertises connected and static routes (sending summary routes will not be permitted):

      Device(config)# router eigrp virtual-name1
      Device(config-router)# address-family ipv4 autonomous-system 4453
      Device(config-router-af)# network 10.0.0.0
      Device(config-router-af)# eigrp stub connected static
      

      Example: eigrp stub leak-map Command

      In the following named configuration example, the eigrp stub command is issued with the leak-map name keyword-argument pair to configure the device to reference a leak map that identifies routes that would normally have been suppressed:

      Device(config)# router eigrp virtual-name1
      Device(config-router)# address-family ipv4 autonomous-system 4453
      Device(config-router-af)# network 10.0.0.0
      Device(config-router-af)# eigrp stub leak-map map1
      

      Example: eigrp stub receive-only Command

      In the following named configuration example, the eigrp stub command is issued with the receive-only keyword to configure the device as a receive-only neighbor (connected, summary, and static routes will not be sent):

      Device(config)# router eigrp virtual-name1
      Device(config-router)# address-family ipv4 autonomous-system 4453
      Device(config-router-af)# network 10.0.0.0
      Device(config-router-af)# eigrp stub receive-only
      

      Example: eigrp stub redistributed Command

      In the following named configuration example, the eigrp stub command is issued with the redistributed keyword to configure the device to advertise other protocols and autonomous systems:

      Device(config)# router eigrp virtual-name1
      Device(config-router)# address-family ipv4 autonomous-system 4453
      Device(config-router-af)# network 10.0.0.0
      Device(config-router-af) eigrp stub redistributed
      

      Additional References

      Related Documents

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for EIGRP Stub Routing

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for EIGRP Stub Routing

      Feature Name

      Releases

      Feature Information

      EIGRP Stub Routing

      The EIGRP Stub Routing feature improves network stability, reduces resource utilization, and simplifies stub router configuration. Stub routing is commonly used in a hub-and-spoke network topology. In a hub-and-spoke network, one or more end (stub) networks are connected to a remote router (the spoke) that is connected to one or more distribution routers (the hub). The remote router is adjacent only to one or more distribution routers.

      The following command was introduced or modified: eigrp stub.