IP Routing BFD Configuration Guide, Cisco IOS XE Release 3S
BFD on BDI Interfaces
Downloads: This chapterpdf (PDF - 1.16MB) The complete bookPDF (PDF - 2.93MB) | The complete bookePub (ePub - 386.0KB) | Feedback

BFD on BDI Interfaces

BFD on BDI Interfaces

The Cisco BFD on BDI Interfaces feature alleviates limitations on the maximum number of interfaces per system that switched virtual interfaces (SVI) impose. This document describes how to configure the Bidirectional Forwarding Detection (BFD) protocol on bridge domain interfaces (BDIs).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About BFD on Bridge Domain Interfaces

BFD on Bridge Domain Interfaces

Each BDI is associated with a bridge domain on which traffic is mapped using criteria defined and configured on the associated Ethernet flow points (EFPs). You can associate either single or multiple EFPs with a given bridge domain. Thus you can establish a BFD single-hop session over BDI interfaces that are defined in either a global table or a VPN routing and forwarding (VRF) table, and all existing single-hop BFD clients will be supported for BFD over BDI.

The Cisco BFD on BDI feature does not affect BFD stateful switchover (SSO) on platforms that are SSO capable.

How to Configure BFD on BDI Interfaces

Enabling BFD on a Bridge Domain Interface

Perform these steps to enable single hop BFD on an individual BDI interface.

Note


Multihop BFD is not interface specific so you do not need BDI interface-level configuration to establish multihop BFD sessions.


Before You Begin

Two or more nodes must be connected.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address ip-address mask

    5.    bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

    6.    exit


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Router(config)# interface bdi 100
     

    Configures a bridge domain interface and enters interface configuration mode.

     
    Step 4 ip address ip-address mask


    Example:
    Router(config-if)# ip address 10.201.201.1 255.255.255.0
     

    Configures an IP address for the interface.

     
    Step 5 bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier


    Example:
    Router(config-if)# bfd interval 500 min_rx 500 multiplier 5
     

    Enables BFD on the interface.

     
    Step 6 exit


    Example:
    Router(config-if)# exit
     

    Exits interface configuration mode and returns to global configuration mode.

     

    Associating an Ethernet Flow Point with a Bridge Domain

    Before You Begin

    BFD must be enabled on both nodes.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    interface type slot/subslot/port

      4.    no ip address

      5.    negotiation auto

      6.    cdp enable

      7.    service instance id service-type

      8.    encapsulation dot1q vlan-id

      9.    rewrite ingress tag pop 1 symmetric

      10.    exit

      11.    exit

      12.    bridge-domain vlan-id


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 interface type slot/subslot/port


      Example:
      Router(config)# interface GigabitEthernet0/0/3
       

      Configures an interface type and enters interface configuration mode.

       
      Step 4 no ip address


      Example:
      Router(config-if)# no ip address
       

      Disables IP processing.

       
      Step 5 negotiation auto


      Example:
      Router(config-if)# negotiation auto
       

      Enables the autonegotiation protocol to configure the speed, duplex, and automatic flow control of the interface.

       
      Step 6 cdp enable


      Example:
      Router(config-if)# cdp enable
       

      Enables Cisco Discovery Protocol on the interface.

       
      Step 7 service instance id service-type


      Example:
      Router(config-if)# service instance 2 ethernet
       

      Configures an Ethernet service instance and enters service instance configuration mode.

       
      Step 8 encapsulation dot1q vlan-id


      Example:
      Router(config-if-srv)# encapsulation dot1q 2
       

      Enables IEEE 802.1Q encapsulation of traffic on the subinterface.

       
      Step 9 rewrite ingress tag pop 1 symmetric


      Example:
      Router(config-if-srv)# rewrite ingress tag pop 1 symmetric
       

      Specifies removal of the outermost tag from the frame ingressing the service instance and the addition of a tag in the egress direction.

       
      Step 10 exit


      Example:
      Router(config-if)# exit
       

      Exits service instance configuration mode and returns to interface configuration mode.

       
      Step 11 exit


      Example:
      Router(config-if)# exit
       

      Exits interface configuration mode and returns to global configuration mode.

       
      Step 12 bridge-domain vlan-id


      Example:
      Router(config)# bridge-domain 2
       

      Associates the bridge domain with the Ethernet flow point.

       

      Example:

      What to Do Next

      Configuration Examples for BFD on BDI Interfaces

      Examples for BFD on BDI Interfaces

      The following example shows how to configure BFD on a BDI.

      Router#show bfd neighbors
      
      IPv4 Sessions
      NeighAddr                              LD/RD         RH/RS     State     Int
      10.1.1.2                             2049/1          Up        Up        BD2
      Router#
      Router#show running interface gi0/0/3
      Building configuration...
      
      Current configuration : 230 bytes
      !
      interface GigabitEthernet0/0/3
      no ip address
      ip pim passive
      ip igmp version 3
      negotiation auto
      cdp enable
      service instance 2 ethernet
        encapsulation dot1q 2
        rewrite ingress tag pop 1 symmetric
        bridge-domain 2
      !
      end
      
      Router#show running interface bdi2
      
      Building configuration...
      
      Current configuration : 127 bytes
      !
      interface BDI2
      ip address 10.1.1.3 255.255.255.0
      bfd interval 100 min_rx 100 multiplier 3
      bfd neighbor ipv4 10.1.1.2
      end
      
      
            

      And similarly for the other node:

      Router2#show running interface bdi2
      
      Building configuration...
      
      Current configuration : 127 bytes
      !
      interface BDI2
      ip address 10.1.1.2 255.255.255.0
      bfd interval 100 min_rx 100 multiplier 3
      bfd neighbor ipv4 10.1.1.3
      end
      
      ED3#show run int gig0/0/3
      Building configuration...
      
      Current configuration : 195 bytes
      !
      interface GigabitEthernet0/0/3
      no ip address
      negotiation auto
      cdp enable
      service instance 2 ethernet
        encapsulation dot1q 2
        rewrite ingress tag pop 1 symmetric
        bridge-domain 2
      !
      end
      
      Router2#show bfd neighbors
      
      IPv4 Sessions
      NeighAddr                              LD/RD         RH/RS     State     Int
      10.1.1.3                                1/2049       Up        Up        BD2
      ED3#
      
      
      	 

      Additional References

      Related Documents

      Related Topic

      Document Title

      Cisco IOS commands

      Cisco IOS Master Commands List, All Releases

      Configuring and monitoring BGP

      “Cisco BGP Overview” module of the Cisco IOS IP Routing Protocols Configuration Guide

      BFD hardware offload

      “Configuring Synchronous Ethernet on the Cisco 7600 Router with ES+ Line Card” section of the Cisco 7600 Series Ethernet Services Plus (ES+) and Ethernet Services Plus T (ES+T) Line Card Configuration Guide

      Configuring and monitoring EIGRP

      “Configuring EIGRP” module of the Cisco IOS IP Routing Protocols Configuration Guide

      Configuring and monitoring HSRP

      “Configuring HSRP” module of the Cisco IOS IP Application Services Configuration Guide

      Configuring and monitoring IS-IS

      “Configuring Integrated IS-IS” module of the Cisco IOS IP Routing Protocols Configuration Guide

      Configuring and monitoring OSPF

      “Configuring OSPF” module of the Cisco IOS IP Routing Protocols Configuration Guide

      BFD commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Routing: Protocol-Independent Command Reference

      BGP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Routing: Protocol-Independent Command Reference

      EIGRP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Routing: Protocol-Independent Command Reference

      HSRP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Application Services Command Reference

      IS-IS commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Routing: Protocol-Independent Command Reference

      OSPF commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

      Cisco IOS IP Routing: Protocol-Independent Command Reference

      BFD IPv6 Encapsulation Support

      BFD IPv6 Encapsulation Support” module

      OSPFv3 for BFD

      OSPFv3 for BFD” module

      Static Route Support for BFD over IPv6

      Static Route Support for BFD over IPv6” module

      Standards and RFCs

      Standard/RFC

      Title

      IETF Draft

      Bidirectional Forwarding Detection, February 2009

      (http://tools.ietf.org/html/draft-ietf-bfd-base-09)

      IETF Draft

      BFD for IPv4 and IPv6 (Single Hop), February 2009

      (http://tools.ietf.org/html/draft-ietf-bfd-v4v6-1hop-09

      Technical Assistance

      Description

      Link

      The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

      Feature Information for BFD on Bridge Domain Interfaces

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for BFD on Bridge Domain Interfaces

      Feature Name

      Releases

      Feature Information

      BFD on Bridge Domain Interfaces

      Cisco IOS XE Release 3.5S

      This feature supports BFD on Bridge Domain Interfaces.