Asynchronous Transfer Mode Configuration Guide, Cisco IOS Release 15S
Configuring LAN Emulation
Downloads: This chapterpdf (PDF - 367.0KB) The complete bookPDF (PDF - 2.36MB) | Feedback

Configuring LAN Emulation

Contents

Configuring LAN Emulation

Last Updated: November 29, 2012

This chapter describes how to configure LAN emulation (LANE) on the following platforms that are connected to an ATM switch or switch cloud:

  • ATM Interface Processor (AIP) on the Cisco 7500 series routers
  • ATM port adapter on the Cisco 7200 series and Cisco 7500 series routers
  • Network Processor Module (NPM) on the Cisco 4500 and Cisco 4700 routers

Note


Beginning with Cisco IOS Release 11.3, all commands supported on the Cisco 7500 series routers are also supported on the Cisco 7000 series.

For a complete description of the commands in this chapter, refer to the the Cisco IOS Switching Services Command Reference. To locate documentation of other commands that appear in this chapter, use the command reference master index or search online.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

LANE on ATM

LANE emulates an IEEE 802.3 Ethernet or IEEE 802.5 Token Ring LAN using ATM technology. LANE provides a service interface for network-layer protocols that is identical to existing MAC layers. No changes are required to existing upper layer protocols and applications. With LANE, Ethernet and Token Ring packets are encapsulated in the appropriate ATM cells and sent across the ATM network. When the packets reach the other side of the ATM network, they are deencapsulated. LANE essentially bridges LAN traffic across ATM switches.

Benefits of LANE

ATM is a cell-switching and multiplexing technology designed to combine the benefits of circuit switching (constant transmission delay and guaranteed capacity) with those of packet switching (flexibility and efficiency for intermittent traffic).

LANE allows legacy Ethernet and Token Ring LAN users to take advantage of ATM's benefits without modifying end-station hardware or software. ATM uses connection-oriented service with point-to-point signalling or multicast signalling between source and destination devices. However, LANs use connectionless service. Messages are broadcast to all devices on the network. With LANE, routers and switches emulate the connectionless service of a LAN for the endstations.

By using LANE, you can scale your networks to larger sizes while preserving your investment in LAN technology.

LANE Components

A single emulated LAN (ELAN) consists of the following entities: A LECS, a BUS, a LES, and LANE clients.

  • LANE configuration server--A server that assigns individual clients to particular emulated LANs by directing them to the LES for the ELAN. The LANE configuration server (LECS) maintains a database of LANE client and server ATM or MAC addresses and their emulated LANs. An LECS can serve multiple emulated LANs.
  • LANE broadcast and unknown server--A multicast server that floods unknown destination traffic and forwards multicast and broadcast traffic to clients within an ELAN. One broadcast and unknown server (BUS) exists per ELAN.
  • LANE server--A server that provides a registration facility for clients to join the ELAN. There is one LANE server (LES) per ELAN. The LES handles LAN Emulation Address Resolution Protocol (LE ARP) requests and maintains a list of LAN destination MAC addresses. For Token Ring LANE, the LES also maintains a list of route-descriptors that is used to support source-route bridging (SRB) over the ELAN. The route-descriptors are used to determine the ATM address of the next hop in the Routing Information Field (RIF).
  • LANE client--An entity in an endpoint, such as a router, that performs data forwarding, address resolution, and other control functions for a single endpoint in a single ELAN. The LANE client (LEC) provides standard LAN service to any higher layers that interface with it. A router can have multiple resident LANE clients, each connecting with different emulated LANs. The LANE client registers its MAC and ATM addresses with the LES.

ELAN entities coexist on one or more Cisco routers. On Cisco routers, the LES and the BUS are combined into a single entity.

Other LANE components include ATM switches--any ATM switch that supports the Interim Local Management Interface (ILMI) and signalling. Multiple emulated LANs can coexist on a single ATM network.

Simple Server Redundancy

LANE relies on three servers: the LECS, the LES, and the BUS. If any one of these servers fails, the ELAN cannot fully function.

Cisco has developed a fault tolerance mechanism known as simple server redundancy that eliminates these single points of failure. Although this scheme is proprietary, no new protocol additions have been made to the LANE subsystems.

Simple server redundancy uses multiple LECSs and multiple broadcast-and-unknown and LESs. You can configure servers as backup servers, which will become active if a master server fails. The priority levels for the servers determine which servers have precedence.

Refer to the "Configuring Fault-Tolerant Operation" section for details and notes on the Simple Server Redundancy Protocol (SSRP).

LANE Implementation Considerations

Network Support

In this release, Cisco supports the following networking features:

  • Ethernet-emulated LANs
    • Routing from one ELAN to another via IP, IPX, or AppleTalk
    • Bridging between emulated LANs and between emulated LANs and other LANs
    • DECnet, Banyan VINES, and XNS routed protocols
  • Token-Ring emulated LANs
    • IP routing (fast switched) between emulated LANs and between a Token Ring ELAN and a legacy LAN
    • IPX routing between emulated LANs and between a Token Ring ELAN and a legacy LAN
    • Two-port and multiport SRB (fast switched) between emulated LANs and between emulated LANs and a Token Ring
    • IP and IPX multiring
    • SRB, source-route translational bridging (SR/TLB), and source-route transparent bridging (SRT)
    • AppleTalk for (IOS) TR-LANE and includes Appletalk fast switched routing.
    • DECnet, Banyan VINES, and XNS protocols are not supported

Cisco's implementation of LAN Emulation over 802.5 uses existing terminology and configuration options for Token Rings, including SRB. For more information about configuring SRB, see the chapter "Configuring Source-Route Bridging" in the Cisco IOS Bridging and IBM Networking Configuration Guide. Transparent bridging and Advanced Peer-to-Peer Networking (APPN) are not supported at this time.

  • Hot Standby Router Protocol (HSRP)

For information about configuring APPN over Ethernet LANE, refer to the "Configuring APPN" chapter in the Cisco IOS Bridging and IBM Networking Configuration Guide.

Hardware Support

This release of LANE is supported on the following platforms:

  • Cisco 4500-M, Cisco 4700-M
  • Cisco 7200 series
  • Cisco 7500 series

Note


Beginning with Cisco IOS Release 11.3, all commands supported on the Cisco 7500 series routers are also supported on the Cisco 7000 series routers equipped with RSP7000. Token Ring LAN emulation on Cisco 7000 series routers requires the RSP7000 upgrade. The RSP7000 upgrade requires a minimum of 24 MB DRAM and 8 MB Flash memory.

The router must contain an ATM Interface Processor (AIP), ATM port adapter, or an NP-1A ATM Network Processor Module (NPM). These modules provide an ATM network interface for the routers. Network interfaces reside on modular interface processors, which provide a direct connection between the high-speed Cisco Extended Bus (CxBus) and the external networks. The maximum number of AIPs, ATM port adapters, or NPMs that the router supports depends on the bandwidth configured. The total bandwidth through all the AIPs, ATM port adapters, or NPMs in the system should be limited to 200 Mbps full duplex--two Transparent Asynchronous Transmitter/Receiver Interfaces (TAXIs), one Synchronous Optical Network (SONET) and one E3, or one SONET and one lightly used SONET.

This feature also requires one of the following switches:

  • Cisco LightStream 1010 (recommended)
  • Cisco LightStream 100
  • Any ATM switch with UNI 3.0/3.1 and ILMI support for communicating the LECS address

TR-LANE requires Cisco IOS Release 3.1(2) or later on the LightStream 100 switch and Cisco IOS Release 11.1(8) or later on the LightStream 1010.

For a complete description of the routers, switches, and interfaces, refer to your hardware documentation.

Addressing

On a LAN, packets are addressed by the MAC-layer address of the destination and source stations. To provide similar functionality for LANE, MAC-layer addressing must be supported. Every LANE client must have a MAC address. In addition, every LANE component (server, client, BUS, and LECS) must have an ATM address that is different from that of all the other components.

All LANE clients on the same interface have the same, automatically assigned MAC address. That MAC address is also used as the end-system identifier (ESI) part of the ATM address, as explained in the next section. Although client MAC addresses are not unique, all ATM addresses are unique.

LANE ATM Addresses

A LANE ATM address has the same syntax as an NSAP, but it is not a network-level address. It consists of the following:

  • A 13-byte prefix that includes the following fields defined by the ATM Forum:
    • AFI (Authority and Format Identifier) field (1 byte)
    • DCC (Data Country Code) or ICD (International Code Designator) field (2 bytes)
    • DFI field (Domain Specific Part Format Identifier) (1 byte)
    • Administrative Authority field (3 bytes)
    • Reserved field (2 bytes)
    • Routing Domain field (2 bytes)
    • Area field (2 bytes)
  • A 6-byte end-system identifier (ESI)
  • A 1-byte selector field

Method of Automatically Assigning ATM Addresses

We provide the following standard method of constructing and assigning ATM and MAC addresses for use in a LECS's database. A pool of MAC addresses is assigned to each ATM interface on the router. On the Cisco 7200 series routers, Cisco 7500 series routers, Cisco 4500 routers, and Cisco 4700 routers, the pool contains eight MAC addresses. For constructing ATM addresses, the following assignments are made to the LANE components:

  • The prefix fields are the same for all LANE components in the router; the prefix indicates the identity of the switch. The prefix value must be configured on the switch.
  • The ESI field value assigned to every client on the interface is the first of the pool of MAC addresses assigned to the interface.
  • The ESI field value assigned to every server on the interface is the second of the pool of MAC addresses.
  • The ESI field value assigned to the broadcast-and-unknown serve r on the interface is the third of the pool of MAC addresses.
  • The ESI field value assigned to the configuration server is the fourth of the pool of MAC addresses.
  • The selector field value is set to the subinterface number of the LANE component--except for the LECS, which has a selector field value of 0.

Because the LANE components are defined on different subinterfaces of an ATM interface, the value of the selector field in an ATM address is different for each component. The result is a unique ATM address for each LANE component, even within the same router. For more information about assigning components to subinterfaces, see the "Rules for Assigning Components to Interfaces and Subinterfaces" section later in this chapter.

For example, if the MAC addresses assigned to an interface are 0800.200C.1000 through 0800.200C.1007, the ESI part of the ATM addresses is assigned to LANE components as follows:

  • Any client gets the ESI 0800.200c.1000.
  • Any server gets the ESI 0800.200c.1001.
  • The BUS gets the ESI 0800.200c.1002.
  • The LECS gets the ESI 0800.200c.1003.

Refer to the "Multiple Token Ring ELANs with Unrestricted Membership Example" and the "Multiple Token Ring ELANs with Restricted Membership Example" sections for examples using MAC address values as ESI field values in ATM addresses and for examples using subinterface numbers as selector field values in ATM addresses.

Using ATM Address Templates

ATM address templates can be used in many LANE commands that assign ATM addresses to LANE components (thus overriding automatically assigned ATM addresses) or that link client ATM addresses to emulated LANs. The use of templates can greatly simplify the use of these commands. The syntax of address templates, the use of address templates, and the use of wildcard characters within an address template for LANE are very similar to those for address templates of ISO CLNS.


Note


E.164-format ATM addresses do not support the use of LANE ATM address templates.

LANE ATM address templates can use two types of wildcards: an asterisk (*) to match any single character, and an ellipsis (...) to match any number of leading or trailing characters.

In LANE, a prefix template explicitly matches the prefix but uses wildcards for the ESI and selector fields. An ESI template explicitly matches the ESI field but uses wildcards for the prefix and selector. The table below indicates how the values of unspecified digits are determined when an ATM address template is used:

Table 1 Values of Unspecified Digits in ATM Address Templates

Unspecified Digits In

Value Is

Prefix (first 13 bytes)

Obtained from ATM switch via Interim Local Management Interface (ILMI)

ESI (next 6 bytes)

Filled with the slot MAC address1 plus

  • 0--LANE client
  • 1--LES
  • 2--LANE BUS
  • 3--LECS

Selector field (last 1 byte)

Subinterface number, in the range 0 through 255.

1 The lowest of the pool of MAC addresses assigned to the ATM interface plus a value that indicates the LANE component. For the Cisco 7200 series routers, Cisco 7500 series routers, Cisco 4500 routers, and Cisco 4700 routers, the pool has eight MAC addresses.

Rules for Assigning Components to Interfaces and Subinterfaces

The following rules apply to assigning LANE components to the major ATM interface and its subinterfaces in a given router:

  • The LECS always runs on the major interface.

The assignment of any other component to the major interface is identical to assigning that component to the 0 subinterface.

  • The server and the client of the same ELAN can be configured on the same subinterface in a router.
  • Clients of two different emulated LANs cannot be configured on the same subinterface in a router.
  • Servers of two different emulated LANs cannot be configured on the same subinterface in a router.

LANE Configuration Task List

Before you begin to configure LANE, you must decide whether you want to set up one or multiple emulated LANs. If you set up multiple emulated LANs, you must also decide where the servers and clients will be located, and whether to restrict the clients that can belong to each ELAN. Bridged emulated LANs are configured just like any other LAN, in terms of commands and outputs. Once you have made those basic decisions, you can proceed to configure LANE.

Once LANE is configured, you can configure Multiprotocol over ATM (MPOA). For MPOA to work with LANE, a LANE client must have an ELAN ID to work properly, a LANE client must have an ELAN ID. To set up a LANE client for MPOA and give an ELAN ID perform the tasks described in the following section:

Although the sections described contain information about configuring SSRP fault tolerance, refer to the Configuring Fault-Tolerant Operation section for detailed information about requirements and implementation considerations.

Once LANE is configured, you can monitor and maintain the components in the participating routers by completing the tasks described in the Monitoring and Maintaining the LANE Components section.

For configuration examples, see the "LANE Configuration Examples" section at the end of this chapter.

Creating a LANE Plan and Worksheet

Draw up a plan and a worksheet for your own LANE scenario, showing the following information and leaving space for noting the ATM address of each of the LANE components on each subinterface of each participating router:

  • The router and interface where the LECS will be located.
  • The router, interface, and subinterface where the LES and BUS for each ELAN will be located. There can be multiple servers for each ELAN for fault-tolerant operation.
  • The routers, interfaces, and subinterfaces where the clients for each ELAN will be located.
  • The name of the default ELAN (optional).
  • The names of the emulated LANs that will have unrestricted membership.
  • The names of the emulated LANs that will have restricted membership.

The last three items in this list are very important; they determine how you set up each ELAN in the LECS's database.

Configuring the Prefix on the Switch

Before you configure LANE components on any Cisco 7200 series router, Cisco 7500 series router, Cisco 4500 router, or Cisco 4700 router, you must configure the Cisco ATM switch with the ATM address prefix to be used by all LANE components in the switch cloud. On the Cisco switch, the ATM address prefix is called the node ID. Prefixes must be 26 digits long. If you provide fewer than 26 digits, zeros are added to the right of the specified value to fill it to 26 digits.

On the switches, you can display the current prefix by using the show network EXEC command.


Note


If you do not save the configured value permanently, it will be lost when the switch is reset or powered off.

To set the ATM address prefix on the Cisco LightStream 1010 or on the Cisco LightStream 100 switch, follow these steps:

SUMMARY STEPS

1.    Router(config)# atm-address{atm-address | prefix...}

2.    Router(config)# exit

3.    Router# copy system:running-config nvram:startup-config

4.    Router(config-route-map)# set localnameip-address mask prefix

5.    Router(config-route-map)# save


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# atm-address{atm-address | prefix...} 

(Cisco LightStream 1010 Switch) Sets the local node ID (prefix of the ATM address).

 
Step 2
Router(config)# exit 

(Cisco LightStream 1010 Switch) Exits global configuration mode.

 
Step 3
Router# copy system:running-config nvram:startup-config 

(Cisco LightStream 1010 Switch) Saves the configuration values permanently.

 
Step 4
Router(config-route-map)# set localnameip-address mask prefix 

(Cisco LightStream 100) Sets the local node ID (prefix of the ATM address).

 
Step 5
Router(config-route-map)# save 

(Cisco LightStream 100) Saves the configuration values permanently.

 

Setting Up the Signalling and ILMI PVCs

You must set up the signalling permanent virtual circuit (PVC) and the PVC that will communicate with the ILMI on the major ATM interface of any router that participates in LANE.

Complete this task only once for a major interface. You do not need to repeat this task on the same interface even though you might configure LESs and clients on several of its subinterfaces.

To set up these PVCs, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1.   

2.    Router(config-if)# atm pvcvcd vpi vci qsaal

3.    Router(config-if)# atm pvcvcd vpi vci ilmi


DETAILED STEPS
  Command or Action Purpose
Step 1



Example:

Router(config-if)# interface atm slot/0



Example:

Router(config-if)# interface atm slot/port-adapter/0



Example:

Router(config-if)# interface atm number

 

Specifies the major ATM interface and enter interface configuration mode:

  • On the AIP for Cisco 7500 series routers; on the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
 
Step 2
Router(config-if)# atm pvcvcd vpi vci qsaal 

Sets up the signalling PVC that sets up and tears down switched virtual circuits (SVCs); the vpi and vci values are usually set to 0 and 5, respectively.

 
Step 3
Router(config-if)# atm pvcvcd vpi vci ilmi 

Sets up a PVC to communicate with the ILMI; the vpi and vci values are usually set to 0 and 16, respectively.

 

Displaying LANE Default Addresses

You can display the LANE default addresses to make configuration easier. Complete this task for each router that participates in LANE. This command displays default addresses for all ATM interfaces present on the router. Write down the displayed addresses on your worksheet.

To display the default LANE addresses, use the following command in EXEC mode:

Command

Purpose

Router# show lane default-atm-addresses

Displays the LANE default addresses.

Entering the LECS ATM Address on the Cisco Switch

You must enter the LECS's ATM address into the Cisco LightStream 100 or Cisco Lightstream 1010 ATM switch and save it permanently so that the value is not lost when the switch is reset or powered off.

You must specify the full 40-digit ATM address. Use the addresses on your worksheet that you obtained from the previous task.

If you are configuring SSRP or Fast Simple Server Redundancy Protocol (FSSRP), enter the multiple LECS addresses into the end ATM switches. The switches are used as central locations for the list of LECS addresses. LANE components connected to the switches obtain the global list of LECS addresses from the switches.

Entering the ATM Addresses on the LightStream 1010 ATM Switch

On the Cisco LightStream 1010 ATM switch, the LECS address can be specified for a port or for the entire switch.

To enter the LECS addresses on the Cisco LightStream 1010 ATM switch for the entire switch, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1.    Router(config)# atm lecs-address-defaultlecsaddress [sequence # ]2

2.    Router(config)# exit

3.    Router# copy system:running-config nvram:startup-config


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# atm lecs-address-defaultlecsaddress [sequence # ]2 

Specifies the LECS's ATM address for the entire switch. If you are configuring SSRP, include the ATM addresses of all the LECSs.

 
Step 2
Router(config)# exit 

Exits global configuration mode.

 
Step 3
Router# copy system:running-config nvram:startup-config 

Saves the configuration value permanently.

 
2 Refer to the LightStream 1010 ATM Switch Command Reference for further information about this command.

Entering the ATM Addresses on the LightStream 1010 ATM Switch Per Port

To enter the LECS addresses on the Cisco LightStream 1010 ATM switch per port, use the following commands beginning in interface configuration mode:

SUMMARY STEPS

1.    Router(config-if)# atm lecs-addresslecsaddress [sequence # ]3

2.    Router(config-if)# Ctrl-Z

3.    Router# copy system:running-config nvram:startup-config


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config-if)# atm lecs-addresslecsaddress [sequence # ]3 

Specifies the LECS's ATM address for a port. If you are configuring SSRP, include the ATM addresses of all the LECSs.

 
Step 2
Router(config-if)# Ctrl-Z 

Exits interface configuration mode.

 
Step 3
Router# copy system:running-config nvram:startup-config 

Saves the configuration value permanently.

 
3 Refer to the LightStream 1010 ATM Switch Command Reference for further information about this command.

Entering the ATM Addresses on the Cisco LightStream 100 ATM Switch

To enter the LECS's ATM address into the Cisco LightStream 100 ATM switch and save it permanently, use the following commands in privileged EXEC mode:

SUMMARY STEPS

1.    Router# set configserver index atm-address

2.    Router# save


DETAILED STEPS
  Command or Action Purpose
Step 1
Router# set configserver index atm-address 

Specifies the LECS's ATM address. If you are configuring SSRP, repeat this command for each LECS address. The index value determines the priority. The highest priority is 0. There can be a maximum of 4 LECSs.

 
Step 2
Router# save 

Saves the configuration value permanently.

 

Setting Up the LECS Database

The LECS's database contains information about each ELAN, including the ATM addresses of the LESs.

You can specify one default ELAN in the database. The LECS will assign any client that does not request a specific ELAN to the default ELAN.

Emulated LANs are either restricted or unrestricted. The LECS will assign a client to an unrestricted ELAN if the client specifies that particular ELAN in its configuration. However, the LECS will only assign a client to a restricted ELAN if the client is specified in the database of the LECS as belonging to that ELAN. The default ELAN must have unrestricted membership.

If you are configuring fault tolerance, you can have any number of servers per ELAN. Priority is determined by entry order; the first entry has the highest priority, unless you override it with the index option.

Setting Up the Database for the Default ELAN Only

When you configure a router as the LECS for one default ELAN, you provide a name for the database, the ATM address of the LES for the ELAN, and a default name for the ELAN. In addition, you indicate that the LECS's ATM address is to be computed automatically.

When you configure a database with only a default unrestricted ELAN, you do not have to specify where the LANE clients are located. That is, when you set up the LECS's database for a single default ELAN, you do not have to provide any database entries that link the ATM addresses of any clients with the ELAN name. All of the clients will be assigned to the default ELAN.

You can have any number of servers per ELAN for fault tolerance. Priority is determined by entry order. The first entry has the highest priority unless you override it with the index option.

If you are setting up only a default ELAN, the elan-name value in Steps 2 and 3 is the same as the default ELAN name you provide in Step 4.

To set up fault-tolerant operation, see the "Configuring Fault-Tolerant Operation" section later in this chapter.

To set up the LECS for the default ELAN, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1.    Router(config)# lane databasedatabase-name

2.    Router(lane-config-dat)# nameelan-nameserver-atm-addressatm-address [index number ]

3.    Router(lane-config-dat)# nameelan-namelocal-seg-idsegment-number

4.    Router(lane-config-dat)# default-nameelan-name

5.    Router(lane-config-dat)# exit


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# lane databasedatabase-name 

Creates a named database for the LECS.

 
Step 2
Router(lane-config-dat)# nameelan-nameserver-atm-addressatm-address [index number ]  

In the configuration database, binds the name of the ELAN to the ATM address of the LES.

If you are configuring SSRP, repeat this step for each additional server for the same ELAN. The index determines the priority. The highest priority is 0.

 
Step 3
Router(lane-config-dat)# nameelan-namelocal-seg-idsegment-number 

If you are configuring a Token Ring ELAN, assigns a segment number to the emulated Token Ring LAN in the configuration database.

 
Step 4
Router(lane-config-dat)# default-nameelan-name 

In the configuration database, provides a default name for the ELAN.

 
Step 5
Router(lane-config-dat)# exit 

Exits from database configuration mode and return to global configuration mode.

 

Setting Up the Database for Unrestricted-Membership Emulated LANs

When you set up a database for unrestricted emulated LANs, you create database entries that link the name of each ELAN to the ATM address of its server.

However, you may choose not to specify where the LANE clients are located. That is, when you set up the LECS's database, you do not have to provide any database entries that link the ATM addresses or MAC addresses of any clients with the ELAN name. The LECS will assign the clients to the emulated LANs specified in the client's configurations.

To set up fault-tolerant operation, see the "Configuring Fault-Tolerant Operation" section later in this chapter.

To configure a router as the LECS for multiple emulated LANs with unrestricted membership, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1.    Router(config)# lane databasedatabase-name

2.    Router(lane-config-dat)# nameelan-name1server-atm-addressatm-address [index number ]

3.    Router(lane-config-dat)# nameelan-name2server-atm-addressatm-address [index number ]

4.    Router(lane-config-dat)# nameelan -name1local-seg-idsegment-number

5.    Router(lane-config-dat)# nameelan -name2local-seg-idsegment-number

6.    Router(lane-config-dat)# default-nameelan-name1

7.    Router(lane-config-dat)# exit


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# lane databasedatabase-name 

Creates a named database for the LECS.

 
Step 2
Router(lane-config-dat)# nameelan-name1server-atm-addressatm-address [index number ] 

In the configuration database, binds the name of the first ELAN to the ATM address of the LES for that ELAN.

If you are configuring SSRP, repeat this step with the same ELAN name but with different server ATM addresses for each additional server for the same ELAN. The index determines the priority. The highest priority is 0.

 
Step 3
Router(lane-config-dat)# nameelan-name2server-atm-addressatm-address [index number ] 

In the configuration database, binds the name of the second ELAN to the ATM address of the LES.

If you are configuring SSRP, repeat this step with the same ELAN name but with different server ATM addresses for each additional server for the same ELAN. The index determines the priority. The highest priority is 0.

Repeat this step, providing a different ELAN name and ATM address for each additional ELAN in this switch cloud.

 
Step 4
Router(lane-config-dat)# nameelan -name1local-seg-idsegment-number 

For a Token Ring ELAN, assigns a segment number to the first emulated Token Ring LAN in the configuration database.

 
Step 5
Router(lane-config-dat)# nameelan -name2local-seg-idsegment-number 

For Token Ring emulated LANs, assigns a segment number to the second emulated Token Ring LAN in the configuration database.

Repeat this step, providing a different ELAN name and segment number for each additional source-route bridged ELAN in this switch cloud.

 
Step 6
Router(lane-config-dat)# default-nameelan-name1 

(Optional) Specifies a default ELAN for LANE clients not explicitly bound to an ELAN.

 
Step 7
Router(lane-config-dat)# exit 

Exits from database configuration mode and return to global configuration mode.

 

Setting Up the Database for Restricted-Membership LANs

When you set up the database for restricted-membership emulated LANs, you create database entries that link the name of each ELAN to the ATM address of its server.

However, you must also specify where the LANE clients are located. That is, for each restricted-membership ELAN, you provide a database entry that explicitly links the ATM address or MAC address of each client of that ELAN with the name of that ELAN.

The client database entries specify which clients are allowed to join the ELAN. When a client requests to join an ELAN, the LECS consults its database and then assigns the client to the ELAN specified in the LECS's database.

When clients for the same restricted-membership ELAN are located in multiple routers, each client's ATM address or MAC address must be linked explicitly with the name of the ELAN. As a result, you must configure as many client entries (at Steps 6 and 7, in the following procedure) as you have clients for emulated LANs in all the routers. Each client will have a different ATM address in the database entries.

To set up fault-tolerant operation, see the "Configuring Fault-Tolerant Operation" section later in this chapter.

To set up the LECS for emulated LANs with restricted membership, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1.    Router(config)# lane databasedatabase-name

2.    Router(lane-config-dat)# nameelan-name1server-atm-addressatm-address restricted [index number ]

3.    Router(lane-config-dat)# nameelan-name2server-atm-addressatm-address restricted [index number ]

4.    Router(lane-config-dat)# nameelan -name1local-seg-idsegment-number

5.    Router(lane-config-dat)# nameelan -name2local-seg-idsegment-number

6.    Router(lane-config-dat)# client-atm-addressatm-address-templatenameelan-name1

7.    Router(lane-config-dat)# client-atm-addressatm-address-templatenameelan-name2

8.    Router(lane-config-dat)# exit


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# lane databasedatabase-name 

Creates a named database for the LECS.

 
Step 2
Router(lane-config-dat)# nameelan-name1server-atm-addressatm-address restricted [index number ]  

In the configuration database, binds the name of the first ELAN to the ATM address of the LES for that ELAN.

If you are configuring SSRP, repeat this step with the same ELAN name but with different server ATM addresses for each additional server for the same ELAN. The index determines the priority. The highest priority is 0.

 
Step 3
Router(lane-config-dat)# nameelan-name2server-atm-addressatm-address restricted [index number ] 

In the configuration database, binds the name of the second ELAN to the ATM address of the LES.

If you are configuring SSRP, repeat this step with the same ELAN name but with different server ATM addresses for each additional server for the same ELAN. The index determines the priority. The highest priority is 0.

Repeat this step, providing a different name and a different ATM address, for each additional ELAN.

 
Step 4
Router(lane-config-dat)# nameelan -name1local-seg-idsegment-number 

For a Token Ring ELAN, assigns a segment number to the first emulated Token Ring LAN in the configuration database.

 
Step 5
Router(lane-config-dat)# nameelan -name2local-seg-idsegment-number 

If you are configuring Token Ring emulated LANs, assigns a segment number to the second emulated Token Ring LAN in the configuration database.

Repeat this step, providing a different ELAN name and segment number for each additional source-route bridged ELAN in this switch cloud.

 
Step 6
Router(lane-config-dat)# client-atm-addressatm-address-templatenameelan-name1 

Adds a database entry associating a specific client's ATM address with the first restricted-membership ELAN.

Repeat this step for each of the clients of the first restricted-membership ELAN.

 
Step 7
Router(lane-config-dat)# client-atm-addressatm-address-templatenameelan-name2 

Adds a database entry associating a specific client's ATM address with the second restricted-membership ELAN.

Repeat this step for each of the clients of the second restricted-membership ELAN.

Repeat this step, providing a different name and a different list of client ATM address, for each additional ELAN.

 
Step 8
Router(lane-config-dat)# exit 

Exits from database configuration mode and return to global configuration mode.

 

Enabling the LECS

Once you have created the database, you can enable the LECS on the selected ATM interface and router by using the following commands beginning in global configuration mode:

SUMMARY STEPS

1.   

2.    Router(config-if)# lane config databasedatabase-name

3.   Do one of the following:

  • Router(config-if)# lane config auto-config-atm-address
  • Router(config-if)# lane config auto-config-atm-address
  • Router(config-if)# lane config fixed-config-atm-address Router(config-if)# lane config fixed-config-atm-address

4.    exit

5.    Ctrl-Z

6.    copy system:running-config nvram:startup-config


DETAILED STEPS
  Command or Action Purpose
Step 1



Example:

Router(config)# interface atm slot/0[.subinterface-number



Example:

Router(config)# interface atm slot/port-adapter/0[.subinterface-number ]



Example:

Router(config)# interface atm number [.subinterface-number ]

 

If you are not currently configuring the interface, specifies the major ATM interface where the LECS is located.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
 
Step 2
Router(config-if)# lane config databasedatabase-name 

Link the LECS's database name to the specified major interface, and enable the LECS.

 
Step 3
Do one of the following:
  • Router(config-if)# lane config auto-config-atm-address
  • Router(config-if)# lane config auto-config-atm-address
  • Router(config-if)# lane config fixed-config-atm-address Router(config-if)# lane config fixed-config-atm-address


Example:

Router(config-if)# lane config config-atm-address atm-address-template

 

Specifies how the LECS's ATM address will be computed. You may opt to choose one of the following scenarios:

The LECS will participate in SSRP and the address is computed by the automatic method.

The LECS will participate in SSRP, and the address is computed by the automatic method. If the LECS is the master, the fixed address is also used.

The LECS will not participate in SSRP, the LECS is the master, and only the well-known address is used.

The LECS will participate in SSRP and the address is computed using an explicit, 20-byte ATM address.

 
Step 4
exit
 

Exits interface configuration mode.

 
Step 5
Ctrl-Z
 

Returns to EXEC mode.

 
Step 6
copy system:running-config nvram:startup-config
 

Saves the configuration.

 

Setting Up LESs and Clients

For each router that will participate in LANE, set up the necessary servers and clients for each ELAN; then display and record the server and client ATM addresses. Be sure to keep track of the router interface where the LECS will eventually be located.

You can set up servers for more than one ELAN on different subinterfaces or on the same interface of a router, or you can place the servers on different routers.

When you set up a server and BUS on a router, you can combine them with a client on the same subinterface, a client on a different subinterface, or no client at all on the router.

Where you put the clients is important because any router with clients for multiple emulated LANs can route frames between those emulated LANs.

Depending on where your clients and servers are located, perform one of the following tasks for each LANE subinterface.

Setting Up the Server and BUS and Client

If the ELAN in Step 3 is intended to have restrictedmembership, consider carefully whether you want to specify its name here. You will specify the name in the LECS's database when it is set up. However, if you link the client to an ELAN in this step, and through some mistake it does not match the database entry linking the client to an ELAN, this client will not be allowed to join this ELAN or any other.

If you do decide to include the name of the ELAN linked to the client in Step 3 and later want to associate that client with a different ELAN, make the change in the LECS's database before you make the change for the client on this subinterface.

Each ELAN is a separate subnetwork. In Step 4 make sure that the clients of the same ELAN are assigned protocol addresses on the same subnetwork and that clients of different emulated LANs are assigned protocol addresses on different subnetworks.

To set up the server, BUS, and (optionally) clients for an ELAN, use the following commands beginning in global configuration mode:

SUMMARY STEPS

1.    Router(config)# interface atm slot /0.subinterface-number

2.    Router(config-if)# lane server-bus{ethernet| tokenring} elan-name

3.    Router(config-if)# lane client{ethernet| tokenring} [elan-name] [elan-id id]

4.    Router(config-if)# ipaddress mask

5.    Router(config-if)# Ctrl-Z

6.    Router# copy system:running-config nvram:startup-config


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# interface atm slot /0.subinterface-number

Example:

Router(config)# interface atm slot / port-adapter /0.subinterface-number



Example:

Router(config)# interface atm number . subinterface-number

 

Specifies the subinterface for the ELAN on this router.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
 
Step 2
Router(config-if)# lane server-bus{ethernet| tokenring} elan-name  

Enables a LES and a LANE BUS for the ELAN.

 
Step 3
Router(config-if)# lane client{ethernet| tokenring} [elan-name] [elan-id id]  

(Optional) Enables a LANE client for the ELAN.

To participate in MPOA, configures the LES and a LANE BUS for the ELAN with the ELAN ID.

 
Step 4
Router(config-if)# ipaddress mask  

Provides a protocol address for the client.

  • The command or commands depend on the routing protocol used. If you are using IPX or AppleTalk, see the relevant protocol chapter (IPX or AppleTalk) in the Cisco IOS AppleTalk and Novell IPX Configuration Guide for the commands to use.
 
Step 5
Router(config-if)# Ctrl-Z  

Returns to EXEC mode.

 
Step 6
Router# copy system:running-config nvram:startup-config  

Saves the configuration.

 

Setting Up Only a Client on a Subinterface

On any given router, you can set up one client for one ELAN or multiple clients for multiple emulated LANs. You can set up a client for a given ELAN on any routers you choose to participate in that ELAN. Any router with clients for multiple emulated LANs can route packets between those emulated LANs.

You must first set up the signalling and ILMI PVCs on the major ATM interface, as described earlier in the "Setting Up the Signalling and ILMI PVCs" section, before you set up the client.

Each ELAN is a separate subnetwork. In Step 2, make sure that the clients of the same ELAN are assigned protocol addresses on the same subnetwork and that clients of different emulated LANs are assigned protocol addresses on different subnetworks.

To set up only a client for an emulated LANs, use the following commands beginning in interface configuration mode:

SUMMARY STEPS

1.    Router(config)# interface atm slot /0. subinterface-number

2.    Router(config-if)# ipaddress mask

3.    Router(config-if)# lane client{ethernet| tokenring} [elan-name]

4.    Router(config-if)# Ctrl-Z

5.    Router# copy system:running-config nvram:startup-config


DETAILED STEPS
  Command or Action Purpose
Step 1
Router(config)# interface atm slot /0. subinterface-number

Example:

Router(config)# interface atm slot / port-adapter /0. subinterface-number



Example:

Router(config)# interface atm number . subinterface-number

 

Specifies the subinterface for the ELAN on this router.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
 
Step 2
Router(config-if)# ipaddress mask  

Provides a protocol address for the client on this subinterface.

  • The command or commands depend on the routing protocol used. If you are using IPX or AppleTalk, see the relevant protocol chapter (IPX or AppleTalk) in the Cisco IOS AppleTalk and Novell IPX Configuration Guide for the commands to use.
 
Step 3
Router(config-if)# lane client{ethernet| tokenring} [elan-name]  

Enables a LANE client for the ELAN.

 
Step 4
Router(config-if)# Ctrl-Z  

Returns to EXEC mode.

 
Step 5
Router# copy system:running-config nvram:startup-config  

Saves the configuration.

 

Disabling the FLUSH Process of LAN Emulation Clients

Disable the LE_FLUSH process and make the transition from using the BUS to using a data direct virtual channel connection (VCC). Disabling the LE_FLUSH process is recommended to prevent the initial packet drops during the establishment of LANE Direct VC. With the LE_FLUSH process disabled, LAN Emulation Clients (LECs) in the node will not send a flush request and will directly use a data direct VCC for data transfer.


Note


Disabling the LE_FLUSH process affects all the LECs in a Cisco networking device.

To keep LECs from sending LE_FLUSH messages to the remote LEC, use the following command in interface configuration mode:

Command

Purpose

Router(config-if)# no lane client flush

Disables the flush mechanism of a LEC.

Setting Up LANE Clients for MPOA

For Multiprotocol over ATM (MPOA) to work properly, a LANE client must have an ELAN ID for all ELANs represented by the LANE client.


Caution


If an ELAN ID is supplied by both commands, make sure that the ELAN ID matches in both.


For more information on configuring the MPOA client, refer to the "Configuring the Multiprotocol over ATM Client " chapter.

To configure an ELAN ID, use one of the following commands in LANE database configuration mode or in interface configuration mode when starting up the LES for that ELAN:

Command

Purpose

Router(lane-config-dat)# name elan-name
 elan-id id

Configures the ELAN ID in the LAN Emulation Client Server (LECS) database to participate in MPOA.

Router(lane-config-dat)# lane server-bus {ethernet | tokenring} elan-name
 [elan-id id
]

Configures the LES and a LANE BUS for the ELAN (ELAN).

To participate in MPOA, configure the LES and a LANE BUS for the ELAN with the ELAN ID.

Configuring Fault-Tolerant Operation

The LANE simple server redundancy feature creates fault tolerance using standard LANE protocols and mechanisms. If a failure occurs on the LECS or on the LES/BUS, the ELAN can continue to operate using the services of a backup LES. This protocol is called the SSRP.

This section describes how to configure simple server redundancy for fault tolerance on an ELAN.


Note


This server redundancy does not overcome other points of failure beyond the router ports: Additional redundancy on the LAN side or in the ATM switch cloud are not a part of the LANE simple server redundancy feature.

Simple Server Redundancy Requirements

For simple LANE service replication or fault tolerance to work, the ATM switch must support multiple LES addresses. This mechanism is specified in the LANE standard. The LE servers establish and maintain a standard control circuit that enables the server redundancy to operate.

LANE simple server redundancy is supported on Cisco IOS Release 11.2 and later. Older LANE configuration files continue to work with this new software.

This redundancy feature works only with Cisco LECSs and LES/BUS combinations. Third-party LANE Clients can be used with the SSRP, but third-party configuration servers, LE servers, and BUS do not support SSRP.

For server redundancy to work correctly:

  • All the ATM switches must have identical lists of the global LECS addresses, in the identical priority order.
  • The operating LECSs must use exactly the same configuration database. Load the configuration table data using the copy rcp tftp} system:running-config command. This method minimizes errors and enables the database to be maintained centrally in one place.

The LANE protocol does not specify where any of the ELAN server entities should be located, but for the purpose of reliability and performance, Cisco implements these server components on its routers.

Fast Simple Server Redundancy Requirements

Fast Simple Server Replication Protocol (FSSRP) differs from LANE SSRP in that all configured LE servers of an ELAN are always active. FSSRP-enabled LANE clients have virtual circuits (VCs) established to a maximum of four LE servers and broadcast and unknown servers (BUSs) at one time. If a single LES goes down, the LANE client quickly switches over to the next LES and BUS resulting in no data or LE-ARP table entry loss and no extraneous signalling.

Due to the increase in LAN client connections to all LE servers in an ELAN, FSSRP increases the number of VCs in your network. On a per client basis, up to 12 additional VCs will be added. These include the additional control direct, control distribute, multicast send and multicast forward VCs (times the 3 extra LE servers and BUSs), which totals 12 additional VCs.

Users should take care to calculate whether or not the number of existing VCs in their network can be maintained with additional VC connections to the secondary LE servers and BUSs.

A LANE client may connect to up to only 4 LE servers and BUSs at a time.

Redundant Configuration Servers

To enable redundant LECSs, enter the multiple LECS addresses into the end ATM switches. LANE components can obtain the list of LECS addresses from the ATM switches through the Interim Local Management Interface (ILMI).

Refer to the "Entering the LECS ATM Address on the Cisco Switch" section for more details.

Redundant Servers and BUSs

The LECS turns on server/BUS redundancy by adjusting its database to accommodate multiple server ATM addresses for a particular ELAN. The additional servers serve as backup servers for that ELAN.

To activate the feature, you add an entry for the hierarchical list of servers that will support the given ELAN. All database modifications for the ELAN must be identical on all LECSs.

Refer to the "Setting Up the LECS Database" section for more details.

Implementation Considerations

The following is a list of LANE implementation restrictions:

  • The LightStream 1010 can handle up to 16 LECS addresses. The LightStream 100 allows a maximum of 4 LECS addresses.
  • There is no limit on the number of LE servers that can be defined per ELAN.
  • When a LECS switchover occurs, no previously joined clients are affected.
  • When a LES/BUS switches over, momentary loss of clients occurs until they are all transferred to the new LES/BUS.
  • LECSs come up as masters until a higher-level LECS tells them otherwise. This is automatic and cannot be changed.
  • If a higher-priority LES comes online, it bumps the current LES off on the same ELAN. Therefore, there may be some flapping of clients from one LES to another after a powerup, depending on the order of the LE servers coming up. Flapping should settle after the last highest-priority LES comes up.
  • If none of the specified LE servers are up or connected to the master LECS and more than one LES is defined for an ELAN, a configuration request for that specific ELAN is rejected by the LECS.
  • Changes made to the list of LECS addresses on ATM switches may take up to a minute to propagate through the network. Changes made to the configuration database regarding LES addresses take effect almost immediately.
  • If none of the designated LECSs is operational or reachable, the ATM Forum-defined well-known LECS address is used.
  • You can override the LECS address on any subinterface, by using the following commands:
    • lane auto-config-atm-address
    • lane fixed-config-atm-address
    • lane config-atm-address

Caution


When an override like this is performed, fault-tolerant operation cannot be guaranteed. To avoid affecting the fault-tolerant operation, do not override any LECS, LES or BUS addresses.


  • If an underlying ATM network failure occurs, there may be multiple master LECSs and multiple active LE servers for the same ELAN. This situation creates a "partitioned" network. The clients continue to operate normally, but transmission between different partitions of the network is not possible. When the network break is repaired, the system recovers.
  • When the LECS is already up and running, and you use the lane config fixed-config-atm-addressinterface commandto configure the well-known LECS address, be aware of the following scenarios:
    • If you configure the LECS with only the well-known address, the LECS will not participate in the SSRP, act as a "standalone" master, and only listen on the well-known LECS address. This scenario is ideal if you want a "standalone" LECS that does not participate in SSRP, and you would like to listen to only the well-known address.
    • If only the well-known address is already assigned, and you assign at least one other address to the LECS, (additional addresses are assigned using the lane config auto-config-atm-address interface command and/or the lane config config-atm-addressinterface command ) the LECS will participate in the SSRP and act as the master or slave based on the normal SSRP rules. This scenario is ideal if you would like the LECS to participate in SSRP, and you would like to make the master LECS listen on the well-known address.
    • If the LECS is participating in SSRP, has more than one address (one of which is the well-known address), and all the addresses but the well-known address is removed, the LECS will declare itself the master and stop participating in SSRP completely.
    • If the LECS is operating as an SSRP slave, and it has the well-known address configured, it will not listen on the well-known address unless it becomes the master.
    • If you want the LECS to assume the well-known address only when it becomes the master, configure the LECS with the well-known address and at least one other address.

SSRP Changes to Reduce Network Flap

SSRP was originally designed so that when a higher LES came on line, all the LECs in that ELAN flipped over to the higher LES. This caused unnecessary disruptions in large networks. Now SSRP is designed to eliminate unnecessary flapping. If the current LES is healthy, the flapping can be eliminated by changing the SSRP behavior so that the ELAN does not flip over to another LES. Obviously, if the currently active LES goes down, all the LECs will then be switched over to the first available highest LES in the list. This is now the default behavior.

If ELANs are now configured in the new way, an LECS switchover may or may not cause a network flap depending on how quickly each LES now reconnects to the new master LECS. If the old active LES connects first, the flap will not occur. However, if another LES connects first (since now the criteria is that the first connected LES is assumed the master LES, rather than the highest ranking one), then the network will still flap.

For customers who would specifically like to maintain the old SSRP behavior, they can use the new LECS name elan-name preemptLANE database configuration command.This command will force the old behavior to be maintained. This feature can be enabled/disabled on a per individual ELAN basis from the LECS database. In the older scheme (preempt), the LES switchover caused network flap.

To enable network flap and set the ELAN preempt for a LES, use the following command in LANE database configuration mode:

Command

Purpose

Router(lane-config-dat)# name elan-name preempt

Sets the ELAN LES preemption.

Monitoring and Maintaining the LANE Components

After configuring LANE components on an interface or any of its subinterfaces, on a specified subinterface, or on an ELAN, you can display their status. To show LANE information, use the following commands in EXEC mode:

Command

Purpose

Router# show lane [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief] 
                
                   
                Router# show lane [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
] [brief]
 
Router# show lane [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Displays the global and per-virtual channel connection LANE information for all the LANE components and emulated LANs configured on an interface or any of its subinterfaces.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
Router# show lane bus [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief]
                
                   
                Router# show lane bus [interface atm slot/port-adapter/ 0 [.subinterface-number
] | name elan-name
] [brief]
                
                   
                Router# show lane bus [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Displays the global and per-VCC LANE information for the BUS configured on any subinterface or ELAN.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
Router# show lane client [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief  Router# show lane client [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
] [brief]
                
                   
                Router# show lane client [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Displays the global and per-VCC LANE information for all LANE clients configured on any subinterface or ELAN.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
Router# show lane config [interface atm slot/0]
                
                   
                Router# show lane config [interface atm slot/port-adapter/0]
                
                   
                Router# show lane config [interface atm number
]

Displays the global and per-VCC LANE information for the LECS configured on any interface.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
Router# show lane database [database-name
]

Displays the LECS's database.

Router# show lane default-atm-addresses [interface atm slot/0.subinterface-number
]
                
                   
                Router# show lane default-atm-addresses [interface atm slot/port-adapter/0.subinterface-number
]
                
                   
                Router# show lane default-atm-addresses [interface atm number.subinterface-number
]

Displays the automatically assigned ATM address of each LANE component in a router or on a specified interface or subinterface.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
Router# show lane le-arp [interface atm slot/0[.subinterface-number
] | name elan-name
]
                
                   
                Router# show lane le-arp [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
]
 
Router# show lane le-arp [interface atm number
[.subinterface-number
] | name elan-name
]

Display the LANE ARP table of the LANE client configured on the specified subinterface or ELAN.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.
Router# show lane server [interface atm slot/0[.subinterface-number
] | name elan-name
] [brief
Router# show lane server [interface atm slot/port-adapter/0[.subinterface-number
] | name elan-name
] [brief]
 
Router# show lane server [interface atm number
[.subinterface-number
] | name elan-name
] [brief]

Display the global and per-VCC LANE information for the LES configured on a specified subinterface or ELAN.

  • On the AIP for Cisco 7500 series routers; On the ATM port adapter for Cisco 7200 series routers.
  • On the ATM port adapter for Cisco 7500 series routers.
  • On the NPM for Cisco 4500 and Cisco 4700 routers.

LANE Configuration Examples

All examples use the automatic ATM address assignment method described in the "Method of Automatically Assigning ATM Addresses" section earlier in this chapter. These examples show the LANE configurations, not the process of determining the ATM addresses and entering them.

Single Ethernet ELAN Example

The following example configures four Cisco 7500 series routers for one Ethernet ELAN. Router 1 contains the LECS, the server, the BUS, and a client. The remaining routers each contain a client for the ELAN. This example accepts all default settings that are provided. For example, it does not explicitly set ATM addresses for the different LANE components that are collocated on the router. Membership in this LAN is not restricted.

Router 1 Configuration

lane database example1
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 default-name eng
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example1
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus ethernet eng
 lane client ethernet 

Router 2 Configuration

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.1
 ip address 172.16.0.3 255.255.255.0
 lane client ethernet

Router 3 Configuration

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 2/0.1
 ip address 172.16.0.4 255.255.255.0
 lane client ethernet

Router 4 Configuration

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.3
 ip address 172.16.0.5 255.255.255.0
 lane client ethernet

Single Ethernet ELAN with a Backup LECS and LES Example

This example configures four Cisco 7500 series routers for one ELAN with fault tolerance. Router 1 contains the LECS, the server, the BUS, and a client. Router 2 contains the backup LECS and the backup LES for this ELAN and another client. Routers 3 and 4 contain clients only. This example accepts all default settings that are provided. For example, it does not explicitly set ATM addresses for the various LANE components collocated on the router. Membership in this LAN is not restricted.

Router 1 Configuration

lane database example1
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name eng server-atm-address 39.000001415555121101020304.0612.200c 2001.01
 default-name eng
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example1
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus ethernet eng
 lane client ethernet 

Router 2 Configuration

lane database example1_backup
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name eng server-atm-address 39.000001415555121101020304.0612.200c 2001.01 (backup LES)
 default-name eng
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database example1_backup
interface atm 1/0.1
 ip address 172.16.0.3 255.255.255.0
 lane server-bus ethernet eng
 lane client ethernet

Router 3 Configuration

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 2/0.1
 ip address 172.16.0.4 255.255.255.0
 lane client ethernet

Router 4 Configuration

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.3
 ip address 172.16.0.5 255.255.255.0
 lane client ethernet

Multiple Token Ring ELANs with Unrestricted Membership Example

The following example configures four Cisco 7500 series routers for three emulated LANS for Engineering, Manufacturing, and Marketing, as shown in the figure below. This example does not restrict membership in the emulated LANs.

Figure 1 Multiple Emulated LANs


In this example, Router 1 has the following LANE components:

  • The LECS (there is one LECS for this group of emulated LANs)
  • The LES and BUS for the ELAN for Manufacturing (man )
  • The LES and BUS for the ELAN for Engineering (eng )
  • A LANE client for the ELAN for Manufacturing (man )
  • A LANE client for the ELAN for Engineering (eng )

Router 2 has the following LANE components:

  • A LANE client for the ELAN for Manufacturing (man )
  • A LANE client for the ELAN for Engineering (eng )

Router 3 has the following LANE components:

  • A LANE client for the ELAN for Manufacturing (man )
  • A LANE client for the ELAN for Marketing (mkt )

Router 4 has the following LANE components:

  • The LES and BUS for the ELAN for Marketing (mkt )
  • A LANE client for the ELAN for Manufacturing (man )
  • A LANE client for the ELAN for Marketing (mkt )

For the purposes of this example, the four routers are assigned ATM address prefixes and end system identifiers (ESIs) as shown in the table below (the ESI part of the ATM address is derived from the first MAC address of the AIP shown in the example).

Table 2 ATM Prefixes for TR-LANE Example

Router

ATM Address Prefix

ESI Base

Router 1

39.000001415555121101020304

0800.200c.1000

Router 2

39.000001415555121101020304

0800.200c.2000

Router 3

39.000001415555121101020304

0800.200c.3000

Router 4

39.000001415555121101020304

0800.200c.4000

Router 1 Configuration

Router 1 has the LECS and its database, the server and BUS for the Manufacturing ELAN, the server and BUS for the Engineering ELAN, a client for Manufacturing, and a client for Engineering. Router 1 is configured as shown in this example:

!The following lines name and configure the configuration server's database.
lane database example2
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.02
 name eng local-seg-id 1000
 name man server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name man local-seg-id 2000
 name mkt server-atm-address 39.000001415555121101020304.0800.200c.4001.01
 name mkt local-seg-id 3000
 default-name man
!
! The following lines bring up the configuration server and associate
! it with a database name.
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example2
!
! The following lines configure the "man" server, broadcast-and-unknown server,
! and the client on atm subinterface 1/0.1. The client is assigned to the default
! emulated lan.
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus tokenring man
 lane client tokenring man
!
! The following lines configure the "eng" server, broadcast-and-unknown server,
! and the client on atm subinterface 1/0.2. The client is assigned to the 
! engineering emulated lan. Each emulated LAN is a different subnetwork, so the "eng"
! client has an IP address on a different subnetwork than the "man" client.
interface atm 1/0.2
 ip address 172.16.1.1 255.255.255.0
 lane server-bus tokenring eng
 lane client tokenring eng

Router 2 Configuration

Router 2 is configured for a client of the Manufacturing ELAN and a client of the Engineering ELAN. Because the default ELAN name is man , the first client is linked to that ELAN name by default. Router 2 is configured as follows:

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 1/0.1
 ip address 172.16.0.2 255.255.255.0
 lane client tokenring
interface atm 1/0.2
 ip address 172.16.1.2 255.255.255.0
 lane client tokenring eng

Router 3 Configuration

Router 3 is configured for a client of the Manufacturing ELAN and a client of the Marketing ELAN. Because the default ELAN name is man , the first client is linked to that ELAN name by default. Router 3 is configured as shown here:

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 2/0.1
 ip address 172.16.0.3 255.255.255.0
 lane client tokenring
interface atm 2/0.2
 ip address 172.16.2.3 255.255.255.0
 lane client tokenring mkt

Router 4 Configuration

Router 4 has the server and BUS for the Marketing ELAN, a client for Marketing, and a client for Manufacturing. Because the default ELAN name is man , the second client is linked to that ELAN name by default. Router 4 is configured as shown here:

interface atm 3/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
interface atm 3/0.1
 ip address 172.16.2.4 255.255.255.0
 lane server-bus tokenring mkt
 lane client tokenring mkt
interface atm 3/0.2
 ip address 172.16.0.4 255.255.255.0
 lane client tokenring

Multiple Token Ring ELANs with Restricted Membership Example

The following example, shown in the figure below, configures a Cisco 7500 series router for three emulated LANS for Engineering, Manufacturing, and Marketing.

The same components are assigned to the four routers as in the previous example. The ATM address prefixes and MAC addresses are also the same as in the previous example.

However, this example restricts membership for the Engineering and Marketing emulated LANs. The LECS's database has explicit entries binding the ATM addresses of LANE clients to specified, named emulated LANs. In such cases, the client requests information from the LECS about which ELAN it should join; the LECS checks its database and replies to the client. Since the Manufacturing ELAN is unrestricted, any client not in the LECS's database is allowed to join it.

Figure 2 Multiple Emulated LANs with Restricted Membership


Router 1 Configuration

Router 1 has the LECS and its database, the server and BUS for the Manufacturing ELAN, the server and BUS for the Engineering ELAN, a client for Manufacturing, and a client for Engineering. It also has explicit database entries binding the ATM addresses of LANE clients to specified, named emulated LANs. Router 1 is configured as shown here:

! The following lines name and configure the configuration server's database.
lane database example3
 name eng server-atm-address 39.000001415555121101020304.0800.200c.1001.02 restricted
 name eng local-seg-id 1000
 name man server-atm-address 39.000001415555121101020304.0800.200c.1001.01
 name man local-seg-id 2000
 name mkt server-atm-address 39.000001415555121101020304.0800.200c.4001.01 restricted
 name mkt local-seg-id 3000
! 
 ! The following lines add database entries binding specified client ATM 
 ! addresses to emulated LANs. In each case, the Selector byte corresponds
 ! to the subinterface number on the specified router. 
 ! The next command binds the client on Router 1's subinterface 2 to the eng ELAN.
 client-atm-address 39.0000014155551211.0800.200c.1000.02 name eng
 ! The next command binds the client on Router 2's subinterface 2 to the eng ELAN.
 client-atm-address 39.0000014155551211.0800.200c.2000.02 name eng
 ! The next command binds the client on Router 3's subinterface 2 to the mkt ELAN.
 client-atm-address 39.0000014155551211.0800.200c.3000.02 name mkt
 ! The next command binds the client on Router 4's subinterface 1 to the mkt ELAN.
 client-atm-address 39.0000014155551211.0800.200c.4000.01 name mkt
 default-name man
!
! The following lines bring up the configuration server and associate
! it with a database name.
interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address 
 lane config database example3
!
! The following lines configure the "man" server/broadcast-and-unknown server,
! and the client on atm subinterface 1/0.1. The client is assigned to the default
! emulated lan.
interface atm 1/0.1
 ip address 172.16.0.1 255.255.255.0
 lane server-bus tokenring man
 lane client tokenring
!
! The following lines configure the "eng" server/broadcast-and-unknown server
! and the client on atm subinterface 1/0.2. The configuration server assigns the 
! client to the engineering emulated lan. 
interface atm 1/0.2
 ip address 172.16.1.1 255.255.255.0
 lane server-bus tokenring eng
 lane client tokenring eng

Router 2 Configuration

Router 2 is configured for a client of the Manufacturing ELAN and a client of the Engineering ELAN. Because the default ELAN name is man , the first client is linked to that ELAN name by default. Router 2 is configured as shown in this example:

interface atm 1/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
! This client is not in the configuration server's database, so it will be 
! linked to the "man" ELAN by default.
interface atm 1/0.1
 ip address 172.16.0.2 255.255.255.0
 lane client tokenring
! A client for the following interface is entered in the configuration 
! server's database as linked to the "eng" ELAN.
interface atm 1/0.2
 ip address 172.16.1.2 255.255.255.0
 lane client tokenring eng

Router 3 Configuration

Router 3 is configured for a client of the Manufacturing ELAN and a client of the Marketing ELAN. Because the default ELAN name is man , the first client is linked to that ELAN name by default. The second client is listed in the database as linked to the mkt ELAN. Router 3 is configured as shown in this example:

interface atm 2/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
! The first client is not entered in the database, so it is linked to the
! "man" ELAN by default.
interface atm 2/0.1
 ip address 172.16.0.3 255.255.255.0
 lane client tokenring man
! The second client is explicitly entered in the configuration server's 
! database as linked to the "mkt" ELAN.
interface atm 2/0.2
 ip address 172.16.2.3 255.255.255.0
 lane client tokenring mkt

Router 4 Configuration

Router 4 has the server and BUS for the Marketing ELAN, a client for Marketing, and a client for Manufacturing. The first client is listed in the database as linked to the mkt emulated LANs. The second client is not listed in the database, but is linked to the man ELAN name by default. Router 4 is configured as shown here:

interface atm 3/0
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
! The first client is explicitly entered in the configuration server's 
! database as linked to the "mkt" ELAN.
interface atm 3/0.1
 ip address 172.16.2.4 255.255.255.0
 lane server-bus tokenring mkt
 lane client tokenring mkt
! The following client is not entered in the database, so it is linked to the 
! "man" ELAN by default. 
interface atm 3/0.2
 ip address 172.16.0.4 255.255.255.0
 lane client tokenring

TR-LANE with 2-Port SRB Example

The following example configures two Cisco 7500 series routers for one emulated Token-Ring LAN using SRB, as shown in the figure below. This example does not restrict membership in the emulated LANs.

Figure 3 2-Port SRB TR-LANE


Router 1 Configuration

Router 1 contains the LECS, the server and BUS, and a client. Router 1 is configured as shown in this example:

hostname Router1
!
! The following lines configure the database cisco_eng.
lane database cisco_eng
 name elan1 server-atm-address 39.020304050607080910111213.00000CA05B41.01
 name elan1 local-seg-id 2048
 default-name elan1
!
interface Ethernet0/0
 ip address 10.6.10.4 255.255.255.0
!
! The following lines configure a configuration server using the cisco_eng database on
! the interface. No IP address is needed since we are using source-route bridging.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database cisco_eng
!
! The following lines configure the server-bus and the client on the subinterface and
! specify source-route bridging information.
interface ATM2/0.1 multipoint
 lane server-bus tokenring elan1
 lane client tokenring elan1
 source-bridge 2048 1 1
 source-bridge spanning
!
! The following lines configure source-route bridging on the Token Ring interface.
interface TokenRing3/0/0
 no ip address
 ring-speed 16
 source-bridge 1 1 2048
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Router 2 Configuration

Router 2 contains only a client for the ELAN. Router 2 is configured as shown here:

hostname Router2
!
interface Ethernet0/0
 ip address 10.6.10.5 255.255.255.0
!
! The following lines configure source-route bridging on the Token Ring interface.
interface TokenRing1/0
 no ip address
 ring-speed 16
 source-bridge 2 2 2048
 source-bridge spanning
!
! The following lines set up the signalling and ILMI PVCs.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines set up a client on the subinterface and configure
! source-route bridging.
interface ATM2/0.1 multipoint
 ip address 1.1.1.2 255.0.0.0
 lane client tokenring elan1
 source-bridge 2048 2 2
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

TR-LANE with Multiport SRB Example

The following example configures two Cisco 7500 series routers for one emulated Token-Ring LAN using SRB, as shown in the figure below. Since each router connects to three rings (the two Token Rings and the ELAN "ring"), a virtual ring must be configured on the router. This example does not restrict membership in the emulated LANs.

Figure 4 Multiport SRB Token Ring ELAN


Router 1 Configuration

Router 1 contains the LECS, the server and BUS, and a client. Router 1 is configured as shown in this example:

hostname Router1
!
! The following lines configure the database with the information about the
! elan1 emulated Token Ring LAN.
lane database cisco_eng
 name elan1 server-atm-address 39.020304050607080910111213.00000CA05B41.01
 name elan1 local-seg-id 2048
 default-name elan1
!
! The following line configures virtual ring 256 on the router.
source-bridge ring-group 256
!
interface Ethernet0/0
 ip address 10.6.10.4 255.255.255.0
!
! The following lines configure the configuration server to use the cisco_eng database.
! The Signalling and ILMI PVCs are also configured.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database cisco_eng
!
! The following lines configure the server and broadcast-and-unknown server and a client
! on the interface. The lines also specify source-route bridging information.
interface ATM2/0.1 multipoint
 lane server-bus tokenring elan1
 lane client tokenring elan1
 source-bridge 2048 5 256
 source-bridge spanning
!
! The following lines configure the Token Ring interfaces.
interface TokenRing3/0
 no ip address
 ring-speed 16
 source-bridge 1 1 256
 source-bridge spanning
interface TokenRing3/1
 no ip address
 ring-speed 16
 source-bridge 2 2 256
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Router 2 Configuration

Router 2 contains only a client for the ELAN. Router 2 is configured as follows:

hostname Router2
!
! The following line configures virtual ring 512 on the router.
source-bridge ring-group 512
!
interface Ethernet0/0
 ip address 10.6.10.5 255.255.255.0
!
! The following lines configure the Token Ring interfaces.
interface TokenRing1/0
 no ip address
 ring-speed 16
 source-bridge 3 3 512
 source-bridge spanning
interface TokenRing1/1
 no ip address
 ring-speed 16
 source-bridge 4 4 512
 source-bridge spanning
!
! The following lines configure the signalling and ILMI PVCs.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines configure the client. Source-route bridging is also configured.
interface ATM2/0.1 multipoint
 ip address 1.1.1.2 255.0.0.0
 lane client tokenring elan1
 source-bridge 2048 6 512
 source-bridge spanning
!
router igrp 65529
 network 10.0.0.0

Token Ring and Ethernet Emulated LANs Example

This example, shown in the figure below, configures routing between a Token Ring ELAN (trelan ) and an Ethernet ELAN (ethelan ) on the same ATM interface. Router 1 contains the LECS, a LES and BUS for each ELAN, and a client for each ELAN. Router 2 contains a client for trelan (Token Ring); Router 3 contains a client for ethelan (Ethernet).

Figure 5 Routing Between Token Ring and Ethernet Emulated LANs


Router 1 Configuration

Router 1 contains the LECS, a LES and BUS for each ELAN, and a client for each ELAN. Router 1 is configured as shown in this example:

hostname router1
!
! The following lines name and configures the configuration server's database.
! The server addresses for trelan and ethelan and the ELAN ring number for
! trelan are entered into the database. The default ELAN is trelan.
lane database cisco_eng
 name trelan server-atm-address 39.020304050607080910111213.00000CA05B41.01
 name trelan local-seg-id 2048
 name ethelan server-atm-address 39.020304050607080910111213.00000CA05B41.02
 default-name trelan
!
! The following lines enable the configuration server and associate it
! with the cisco_eng database.
interface ATM2/0
 no ip address
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
 lane config auto-config-atm-address
 lane config database cisco_eng
!
! The following lines configure the tokenring LES/BUS and LEC for trelan
! on subinterface atm2/0.1 and assign an IP address to the subinterface. 
interface ATM2/0.1 multipoint
 ip address 10.1.1.1 255.255.255.0
 lane server-bus tokenring trelan
 lane client tokenring trelan
!
! The following lines configure the Ethernet LES/BUS and LEC for ethelan 
! on subinterface atm2/0.2 and assign an IP address to the subinterface. 
interface ATM2/0.2 multipoint
 ip address 20.2.2.1 255.255.255.0
 lane server-bus ethernet ethelan
 lane client ethernet ethelan
!
! The following lines configure the IGRP routing protocol to enable routing 
! between ELANS.
router igrp 1 
 network 10.0.0.0
 network 20.0.0.0

Router 2 Configuration

Router 2 contains a client for trelan (Token Ring). Router 2 is configured as follows:

hostname router2
!
! The following lines set up the signalling and ILMI PVCs for the interface.
interface ATM2/0
 no ip address
 no keepalive
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines configure a Token Ring LEC on atm2/0.1 and assign
! an IP address to the subinterface.
interface ATM2/0.1 multipoint
 ip address 10.1.1.2 255.255.255.0
 lane client tokenring trelan
!
! The following lines configure the IGRP routing protocol to enable routing 
! between ELANS.
router igrp 1
 network 10.0.0.0
 network 20.0.0.0

Router 3 Configuration

Router 3 contains a client for ethelan (Ethernet). Router 3 is configured as follows:

hostname router3
!
! The following lines set up the signalling and ILMI PVCs for the interface.
interface ATM2/0
 no ip address
 no ip mroute-cache
 atm pvc 1 0 5 qsaal
 atm pvc 2 0 16 ilmi
!
! The following lines configure an Ethernet LEC on atm2/0.1 and assign
! an IP address to the subinterface.
interface ATM2/0.1 multipoint
 ip address 20.2.2.2 255.255.255.0
 lane client ethernet ethelan
!
! The following lines configure the IGRP routing protocol to enable routing 
! between ELANS.
router igrp 1
 network 10.0.0.0
 network 20.0.0.0

Disabling LANE Flush Process Example

The following example shows a running configuration and the LE_FLUSH process disabled for all LECs:

more system:running-config
Building configuration... 
Current configuration :496 bytes 
! 
! Last configuration change at 11:36:21 UTC Thu Dec 20 2001 
! 
version 12.1 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname donner_b 
!
no lane client flush 
! 
interface ATM0 
 atm preferred phy A 
 atm pvc 1 0 5 qsaal 
 atm pvc 2 0 16 ilmi 
 no atm ilmi-keepalive 
! 
interface ATM0.1 multipoint 
 lane config-atm-address 47.009181000000001007385101.0050A2FEBC43.00 
 lane client ethernet 100 elan1 
! 
line con 0 
line vty 0 4 
 no login 
! 
end 

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.