Cisco 7600 Series Router SIP, SSC, and SPA Software Configuration Guide
Configuring the 1-Port Channelized OC-3/STM-1 SPA
Downloads: This chapterpdf (PDF - 722.0KB) The complete bookPDF (PDF - 13.93MB) | Feedback

Table of Contents

Configuring 1-Port ChOC-3/STM-1 and ChOC-12 / STM-4 SPAs

Configuration Tasks

Restrictions

Required Configuration Tasks

Selection of Physical Port and Controller Configuration

Interface Naming

Selection of Physical Port and Controller Configuration—SONET mode

SONET mode Configuration

SDH mode Configuration

Configure Channelized DS3 in SONET Mode

POS Interface Configuration

DS1 Configuration (Channelized T3 mode)

E1 Configuration (Channelized T3/E3 mode)

BERT Test Configuration

Unchannelized E3 Serial Interface Configuration

Optional Configurations

Configuring Encapsulation

Configuring the CRC Size for T1

Configuring FDL

Configuring Multilink Point-to-Point Protocol (Hardware-based)

Configuring APS

Verifying the APS Configuration

Configuring MLFR

FRF.12 Guidelines

LFI Guidelines

HW MLPPP LFI Guidelines

FRF.12 LFI Guidelines

Configuring QoS Features on Serial SPAs

Saving the Configuration

Verifying the Interface Configuration

Verifying Per-Port Interface Status

Configuration Tasks

Configuring CRTP

Stateful MLPPP MR-APS

MR-APS Deployment

Inter Chassis Redundancy Manager

Automatic Protection Switching

Failure Protection Scenarios

Active APS SONET controller, SPA, or Line card failure

Route Processor and Node failure

Restrictions for Stateful MLPPP with MR-APS Inter-Chassis Redundancy

Configuring Stateful MLPPP with MR-APS Inter-Chassis Redundancy

Configuring MR-APS Inter-Chassis Redundancy on the Working Router

Configuring MR-APS Inter-Chassis Redundancy on Protect Router

Removing Stateful MLPPP with MR-APS Inter-Chassis Redundancy

Verification

Troubleshooting Tips

Configuring 1-Port ChOC-3/STM-1 and ChOC-12 / STM-4 SPAs

This chapter provides information about configuring the 1-Port Channelized OC-3/STM-1 SPA on Cisco 7600 series routers and 1-Port Channelized OC-12/STM-4 SPA on SIP 400 introduced with IOS release 12.2(33) SRD 1. The new 1-Port Channelized OC-12/STM-4 SPA terminates channelized IP services on the service provider edge and maintains feature parity with 1-Port Channelized OC-3/STM-1 SPA on Cisco 7600 series router SIP-200 line cardand the Channelized OC-12 OSM line card.

This chapter includes the following sections:

For information about managing your system images and configuration files, refer to the Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.2 and Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 publications.

For more information about the commands used in this chapter, refer to the Cisco IOS Software Releases 15.0SR Command References and to the Cisco IOS Software Releases 12.2SX Command References. Also refer to the related Cisco IOS Release 12.2 software command reference and master index publications. For more information, see the Related Documentation.

Configuration Tasks

This section describes how to configure the 1-Port Channelized OC-3/STM-1 SPA and 1-Port Channelized OC-12/STM-4 SPA for the Cisco 7600 series routers and includes information about verifying the configuration.

Up to 3 STS-1 connections can be configured on the 1-Port Channelized OC-3/STM-1 SPA. Each STS-1 connection can be configured as a T3 controller or as a VT controller. A maximum of 1023 interfaces can be configured.

Up to 12 STS-1 connections can be configured on the 1-Port Channelized OC-12/STM-4 SPA. Each STS-1 connection can be configured as a T3 controller or as a VT controller. STS-1 can be clubbed together to support the concatenated POS interface. A maximum of 2000 interfaces can be configured.

Restrictions

  • SDH mode is not supported on1-Port Channelized OC-12/STM-4 SPA.
  • The 1-Port Channelized OC-12/STM-4 SPA does not support DSU mode in E3/T3 mode. For the 1-Port Channelized OC-12/STM-4 SPA, when enabled in E3/T3 mode, to work with other DSU supported cards, you must configure the remote end of this SPA in Kentrox DSU mode.

    For example, when 1-Port Channelized OC-12/STM-4 SPA is connected to 1xCHSTM1 SPA over a CEM PW (CESoP/SAToP) or ADM in E3 mode, Kentrox DSU mode must be enabled on serial interfaces of 1xCHSTM1 SPA.

This section shows how to configure the 1-Port Channelized OC-3/STM-1 SPA and 1-Port Channelized OC-12/STM-4 SPAs in either SONET or SDH framing modes.

It includes the following topics:

Required Configuration Tasks

This section lists the required steps to configure the 1-Port Channelized OC-3/STM-1 SPA and the 1-Port Channelized OC-12/STM-4 SPA. Some of the required configuration commands implement default values that might be appropriate for your network. If the default value is correct for your network, then you do not need to configure the command.


NoteTo better understand the address format used to specify the physical location of the Cisco 7600 SIP-200, SPA, and interfaces, see the:“Selection of Physical Port and Controller Configuration” section.


Selection of Physical Port and Controller Configuration

To select the physical port and controller configuration on the 1-Port Channelized STM-1/OC-3 SPA or 1-Port Channelized OC12/STM4 , use the following command:

controller sonet slot / subslot / port

If the 1-Port Channelized OC-3/STM-1 SPA sits in subslot 0 of a Cisco 7600 SIP-200 / SIP-400(releases from SRC onwards) in slot3, the 1-Port Channelized OC-3/STM-1 SPA port would be identified as controller SONET 3/0/0. Since there is only 1 port on a 1-Port Channelized OC-3/STM-1 SPA, the port number is always 0.

If the 1-Port Channelized OC12/STM4 sits in subslot 0 of a 7600-SIP-400(releases from SRD1 onwards) in slot3, the 1-Port Channelized OC12/STM4 port would be identified as controller SONET 3/0/0. Since there is only 1 port on a 1-Port Channelized OC12/STM4, the port number is always 0.


NoteThe terms slot and bay are used interchangebly in this document.


Interface Naming

Interface names are automatically generated, and the format will be dependent on the mode each particular line card is operating on. The name format of the serial interface created are listed below.

SONET mode

  • If framing is SONET and mode is vt-15 where VTG range is 1-7 and DS1(T1) range is 1-4:

interface serial [ slot / subslot / port ] . [ sts- 1#/ vtg/ ds1# ] : [ channel-group ]


NoteBased on the CLI configuration,channel-group value varies from 0 to 23 for DS1.


  • If framing is SONET and mode is CT3 where DS1 range is 1-28:

interface serial [ slot / subslot / port ] . [ sts- 1# / ds1# ] : [ channel-group ]


NoteBased on the CLI configuration,channel-group value varies from 0 to 23 for DS1.


  • If framing is SONET and mode is CT3-E1 where E1 range is 1-21:

interface serial [ slot / subslot / port ] . [ sts- 1# / e1# ] : [ channel-group ]


NoteBased on the CLI configuration,channel-group value varies from 0 to 30 for E1 and 0 to 23 for T1.


  • If framing is SONET and mode is T3:

interface serial [ slot / subslot / port.sts-1# ]

SDH mode

  • If SDH-AUG mapping is au-4 and if the tug-3 is mode t3/e3:

interface serial [ slot / subslot /< port>.<au-4>/ <tug-3> ]


NoteBased on the CLI configuration, the STS range varies from 1 to 12, the AU-4 varies from 1 to 4, the TUG-3 varies from 1 to 3, and the TUG-2 varies from 1 to 7.


  • If SDH-AUG mapping is au-3 in c-11 mode:

interface serial [ slot / subslot / port . au-3 / <tug-2> / <ds1> ] : [ channel-group ]

  • If framing is SDH with c-12 mode:

interface serial [ slot/ subslot / < port>.<au-4>/ <tug-3> / <tug-2> /< e1> ] : [ channel-group ]


NoteIf the aug mapping is au-3, then the only supported mode is c-11 ( carrying a DS1(T1)).


For POS mode

This configuration is only for 1-Port Channelized OC12/STM4 SPA and the only supported mode is SONET mode.

If framing is SONET :

interface pos [ slot / subslot / port ]:[ sts-1# ]

Here sts-1# indicates the starting sts of the POS interface.

For example, if the SPA is in 3/0/0 and the POS interface is created for the first 3 sts-1s, then the interface name is POS3/0/0:1. Also, if the the SPA is in 3/0/0 and the POS interface created for the all sts-1s, the interface name is still POS3/0/0:1, but the differentiating factor is the interface bandwidth. For OC3, the interface bandwidth is 15550 kbit and it is 622000 kbit for OC12 POS.

 

Selection of Physical Port and Controller Configuration—SONET mode

To create the interface for the 1-Port Channelized OC-3/STM-1 SPA or 1-Port Channelized OC12/STM4 SPA, complete these steps:

 

Command
Purpose

Step 1

Router(config)# controller sonet slot/subslot/port

Select the controller to configure and enter controller configuration mode.

SONET mode Configuration

To configure the SONET controller, complete these steps:

 

Command
Purpose

Step 1

For SONET controllers:

Router(config-controller)# framing sonet

Selects the framing type.

sonet—Specifies SONET as the frame type. This is the default.

Step 2

Router(config-controller)# clock source {internal | line}

Sets the clock source.

Note The clock source is set to internal if the opposite end of the connection is set to line and the clock source is set to line if the opposite end of the connection is set to internal.

  • internal—Specifies that the internal clock source is used.
  • line—Specifies that the network clock source is used. This is the default for T1 and E1.

Step 3

Router(config-controller)# [no] loopback { local | network ]

Enables or disables loopback mode on a sonet controller.

  • local loopback —loops data from the transmit path to the receive path.
  • network loopback —loops data received on the receiving path to the transmiting path and back out the external port.

Default is disabled loopback.

Step 4

In SONET framing:

Router(config-controller)# sts-1 sts-1#

sts-1 # —Specifies the SONET STS level.

Step 5

Router(config-ctrlr-sts1)# [no] mode { vt-15 | ct3 | t3 | ct3-e1 }

Specifies the mode of operation of a STS-1 path:

  • vt-15 —A STS-1 is divided into 7 VTGs. Each VTG is then divided into 4 VT1.5’s, each carrying a T1.
  • ct3 —A STS-1 carry a DS3 signal divided into 28 T1s (PDH)
  • t3— STS-1 carries a unchannelized (clear channel) T3
  • ct3-e1 —The channelized T3 is carrying E1 circuits

Note Effective from Release 15.1(1)S, the CT3-E1 mode is supported on the 1-Port Channelized OC12/STM4 SPA.


Step 6

Router(config-ctrlr-sts1)# vtg ?

<1-7> vtg number <1-7>

vtg —Specifies the VTG number.

Step 7

RouterC(config-ctrlr-sts1)# vtg 1 t1 1 { bert |channel-group |clock |description |fdl |framing |loopback |shutdown |yellow }

RouterC(config-ctrlr-sts1)# vtg 1 t1 1 channel-group 0-23 Channel group number

RouterC(config-ctrlr-sts1)# vtg 1 t1 1 channel-group 0 timeslots List of timeslots in the channel group

RouterC(config-ctrlr-sts1)# vtg 1 t1 1 channel-group 0 timeslots 1-24 List of timeslots which comprise the channel

RouterC(config-ctrlr-sts1)# vtg 1 t1 1 channel-group 0 timeslots 1 speed Specify the speed of the underlying DS0s

RouterC(config-ctrlr-sts1)# vtg 1 t1 1 channel-group 0 timeslots 1

Configures the T1s on the VTGs. For SONET framing, vtg# range is 1 to 7.

SDH mode Configuration

To configure SDH mode, complete the following steps:


NoteEffective from Release 15.1(1)S, SDH mode is supported on the1-Port Channelized OC12/STM4 SPA.


 

Command
Purpose

Step 1

For SDH controllers:

Router(config-controller)# framing sdh

Selects the framing type.

  • sonet—Specifies SONET as the frame type. This is the default.
  • sdh—Specifies SDH as the frame type.

Step 2

Router(config-controller)# aug mapping {au-3 | au-4}

Configures AUG mapping for SDH only. If the AUG mapping is configured to be au-4, then the following muxing/alignment/mapping will be used:

TUG-3 <--> VC-4 <--> AU-4 <--> AUG

If the mapping is configured to be au-3, then the following muxing/alignment/mapping will be used:

VC-3 <--> AU-3 <--> AUG

This command will be available only when sdh framing is configured.

Default is au-4 .

Step 3

Router(config-controller)# aug mapping(stm#) au-4

or

Router(config-controller)# aug mapping (stm#) au-3

Router(config-controller)# aug mapping {au-3 | au-4}

Configures AUG mappings for SDH only

Step 4

If AUG mapping is AU-4:

au-4 <au-4#> tug-3 <tug-3#>

If AUG mapping is AU-3:

au-3 <au-3#>

Enters the configuration submode for the given TUG-3.

Depending on currently configured AUG mapping setting, this command will further specify TUG-3, AU-3 or STS-1 muxing. As the result, the CLI command parser enters into config-ctrlr-tug3, config-ctrlr-au3 or config-ctrlr-sts1# parser mode, which makes only relevant commands visible.

The AU-4 number rangess from 1 to 4 for OC12 SPA and 1 for OC3.

The AU-3 number ranges from 1 to 12 for OC12 SPA and from 1 to 3 for OC3.

The STS-1 number ranges 1 to 12 for OC12 SPA and is from 1 to 3 for OC3.

Step 5

In SDH framing in AU-4 mode:

[no] mode {c-12 | t3 | e3}

C-11 and c-12 are container level-n (SDH) Channelized T3s. They are types of T3 channels that are subdivided into 28 T1 channels.

  • c-12 —Specifies a AU-4/TUG-3 is divided into 7 tug2. Each tug2 then divided into 3 TU12’s, each carrying an E1 (C-12).
  • t3 —Specifies a STS-1 or AU-4/TUG3 carries a unchannelized (clear channel) T3.
  • e3 —Specifies a AU-4/TUG3 carries a unchannelized (clear channel) E3 .

In CHOC-3/STM1 SPA, you cannot configure both T3 and E3 at the same time.


NoteOnly c-11 is supported in AU-3.


Configure Channelized DS3 in SONET Mode

To configure channelized DS3 mode, complete the following steps:

 

Command
Purpose

Step 1

Router(config)# controller sonet slot/subslot/port

Select the controller to configure and enter controller configuration mode.

Step 2

Router(config-controller)# sts-1 sts1#

The sts-1# is from 1 to y, y being the Sonet STS level, such as in OC-3.

Step 3

Router(config)# mode ct3

Sets the interface in channelized DS3 mode.

Step 4

Router(config-ctrlr-sts)# t3 framing { c-bit | m23 | auto-detect }

Specifies the framing mode.

  • c-bit —Specifies C-bit parity framing.
  • m23 —Specifies M23 framing.
  • auto-detect

Step 5

Router(config-ctrlr-sts)# clock source {internal | line}

Sets the clock source for the given T3 controller under STS.

Note The clock source is set to internal if the opposite end of the connection is set to line and the clock source is set to line if the opposite end of the connection is set to internal.

  • internal—Specifies that the internal clock source is used.
  • line—Specifies that the network clock source is used.

Step 6

Router(config-ctrlr-sts)# [no] t3 loopback { local | network [line | payload] | remote [line | payload ] }

Enables or disables loopback mode on a SONET controller.

  • local loopback —loops data from the transmit path to the receive path.
  • network loopback —loops data received on the external port to the transmit path and back out the external port.

Note Effective from Release 15.1(1)S, network loopback is supported on the 1-Port Channelized OC12/STM4 SPA.


  • Remote loopback —Applicable only to c-bit framing. When you configure locally, this mode performs the remote end network loopback.

Default is no loopback.

Step 7

Router(config-ctrlr-sts)# [no] t3 mdl string [ eic | fic | generator | lic | pfi | port | unit } string

[no] t3 mdl transmit { path | idle-signal | test-signal }

Configures MDL support.

  • eic —Specified equipment ID code
  • fic — frame ID code
  • generator —generator number in MDL test signal
  • lic —location ID code
  • pfi— facility ID code in MDL path message
  • port — port number in MDL idle string message
  • unit —unit code

Default is no mdl string and no mdl transmit.

Step 8

Router(config-ctrlr-sts)# t3 equipment { customer | network } loopback

Equipment customer loopback enables the port to honor remote loopback request. Equipment network loopback disables this functionality.

Note Remote loopbacks are only available in c-bit framing mode.

Step 9

Router(config-ctrlr-sts)# t3 bert pattern pattern interval 1-14400

Enables BERT testing.

POS Interface Configuration

To configure the OC-3 or OC 12 POS interfaces, complete the following steps:

 

Command
Purpose

Step 1

Router(config-controller)# sts-1 start-sts-1#-end-sts-1# pos

This commnad creates the POS interface.The start-sts-1 and end-sts-1 denotes the STS from which the PTS interface is created and ended.

Step 2

Router(config)# Interface pos [ slot/subslot/port ]: [ sts-1 ]

This command configures the POS interface.

Step 3

Router(config-if)#[ no ] encap ?

bstun Block Serial tunneling (BSTUN)

frame-relay Frame Relay networks

hdlc Serial HDLC synchronous

lapb LAPB (X.25 Level 2)

ppp Point-to-Point protocol

sdlc SDLC

sdlc-primary SDLC (primary)

sdlc-secondary SDLC (secondary)

smds Switched Megabit Data Service (SMDS)

stun Serial tunneling (STUN)

x25 X.25

This command configures the encapsulation on the POS interface and sets it to the required value.

Step 4

Router(config-if)# [ no ] pos ?

delay Delay POS alarm triggers

flag Specify byte value

scramble-atm Enable POS SPE scrambling

threshold Set BER threshold values

This command enables or disables scrambling on the POS interface.

Step 5

Router(config-if)#CRC { crc16 |crc32}

This command configures the CRC setting to crc16 or crc32 at both connected SPAs.

Step 6

Router(config-if)# invert data

This command configures the Invert Data setting. This should be the same for both connected SPAs.

Use the show interface pos command to verify the POS configurationand use the interface pos <slot>/<subslot>/<port>: sts-1 # command to debug the POS configuration.

Following is a sample configuration for verifying the POS configuration:

Router#show interface pos 4/1/0:1
POS4/1/0:1 is down, line protocol is down
Hardware is SPA_1xCHOC12
MTU 4470 bytes, BW 155000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Scramble disabled
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
Non-inverted data

NoteNSTS-1 is the number of the first STS-1 on the POS interface. The value of N can be 1,4,7 or 10.


DS1 Configuration (Channelized T3 mode)

To configure DS1 complete the following steps:

 

Command
Purpose

Step 1

Router(config-ctrlr-sts1)#[no] t1 t1# clock source { internal | line}

Configures the clocking source.

Step 2

Router(config-ctrlr-sts1)#[no] t1 t1# fdl ansi

Enables the one-second transmission of the remote performance reports via Facility Data Link (FDL) per ANSI T1.403.


Note FDL will run in ATT mode without this command. ATT mode is not mutually exclusive or different from ANSI mode, ANSI mode is a super-set of ATT mode.


Step 3

Router(config-ctrlr-sts1)#[no] t1 t1# framing { sf | esf }

Router(config-ctrlr-sts1)#[no] t1 t1# yellow { detection | generation }

Enables detection and generation of DS1 yellow alarms.

Step 4

Router(config-ctrlr-sts1)#[no] prefix t1 t1# shutdown

Shuts down the configured T1.

Step 5

Router(config-ctrlr-sts1)#[no] t1 t1# channel-group channel-group# timeslots list-of-timeslots speed [ 56 | 64 ]

Specifies the line speed in kilobits per second. Valid values are 56 and 64.

Step 6

Router(config-ctrlr-sts1)#[no] t1 t1# loopback { local | network line | remote {line fdl {ansi | bellcore } | payload fdl ansi }}

Note Local network payload loopback is not supported due to TEMUX-84/TEMUX-84E limitations.

Note Only 6 E1 berts can be performed concurrently due to TEMUX-84/TEMUX-84E limitations.

E1 Configuration (Channelized T3/E3 mode)

E1 configuration must be done in channelized DS3 mode. To configure E1, complete the following steps:

 

Command
Purpose

Step 1

Router(config-ctrlr-sts1)#[no] e1 e1# channel-group channel-group# timeslots list-of-timeslots speed [ 56 | 64 ]

  • E1 range is 1-4.
  • Timeslot range is 1-31.
  • Speed is 64 by default. Speed as 56 denotes that each ds0 speed will be 56kbps instead of 64 kbps to connect some legacy T1s.

Step 2

Router(config-ctrlr-sts1)#[no] e1 e1# [ unframed | framing] { crc4 | no-crc4 }

Cofiguration of crc/no-crc4 is applicable only for the framed E1configuration. Unframed E1 doesnt need the configuration.

Step 3

Router(config-ctrlr-sts1)#[no] e1 e1# clock source { internal | line }

Configures clock source.

Step 4

Router(config-ctrlr-sts1)#[no] e1 e1# national bits pattern

Sets the national reserved bits on an E1 line. Pattern is the hexadecimal value in the range 0x0 to 0x1F (hexadecimal) or 0 to 31 (decimal).

Step 5

Router(config-ctrlr-sts 1 )#[no] e1 e1# loopback [local | network]

Router(config-ctrlr-sts 1 )#[no] e1 e1# loopback [network] { line}

Local loopback is used to loop the data from the transmit path to the receive path.

Network loopback is used to loop the data received from the external port to the transmit path and back to the external port.

Step 6

Router(config-ctrlr-sts 1 )#[no] e1 e1# shutdown

Shuts the configured E1.

BERT Test Configuration

To configure BERT test, complete the following:

 

Command
Purpose

Step 1

Router(config-ctrlr- sts1 )#[no] [ [e1 | t1] [e1# | t1#] bert pattern {2^11 | 2^15 || 2^20 QRSS } interval time

Send a BERT pattern on a DS1/E1 line.

Unchannelized E3 Serial Interface Configuration

To configure an unchannelized E3 serial interface, complete the following commnads. The commands are configurable under the serial interface only and not configurable under controller.

 

Command
Purpose

Step 1

Router(config)# interface serial [slot/subslot/port ]. <au-4#>/<tug-3 #>

  • au-4 — Specifies the E3 interface under which AU-4 index. For OC3 SPA, since there is only one AU-4, this value is always 1.
  • Tug-3 — Specifies the index under which path the E3 is configured.

Step 2

Router(config-if)#[no] dsu mode { cisco | digital-link | kentrox }

  • cisco —Specifies cisco as the DSU mode.
  • digital-link —Specifies Digital link as the DSU mode. Range is from 300-34010.
  • kentrox —Specifies kentrox as the DSU mode. Range is 1000-24500, 34010.

Default is cisco .

Step 3

Router(config-if)# [no] dsu bandwidth number

Specifies the maximum allowed bandwidth in KBPS.

Step 4

Router(config-if)#[no] national bit { 0 | 1 }

Default is 0.

Step 5

Router(config-if)#[no] crc {16 | 32}

Default is 16 bit (CRC-CITT).

Step 6

Router(config-if)#[no] loopback {network | local | dte |dual}

 

Step 7

Router(config-if)#[no] shutdown

 

Use the show controllers command to verify the controller configuration.

Following is a a sample configuration to display a T1 1 with VTG 1 in SONET VT-15 mode

Router(config)# show controllers sonet3/0/0.1/1/1
SONET 3/0/0 is down.
Path mode VT15
STS-1 1, VTG 1, T1 1 (VT1.5 1/1/1) is down
timeslots: 1-24
FDL per AT&T 54016 spec.
Receiver is getting AIS.
Framing is ESF, Clock Source is Internal
Data in current interval (623 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs
623 Unavail Secs, 0 Stuffed Secs
Data in Interval 1:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs
900 Unavail Secs, 0 Stuffed Secs
 

Verifying Interface Configuration

Use the show interface serial command to verify the interface configuration:

Router(config)# show interface serial
Serial2/0/0.1/2 unassigned YES TFTP administratively down down
Serial2/1/0.1/1/1:0 unassigned YES unset down down
Serial2/1/0.1/2/4:0 unassigned YES unset down down
Serial2/1/0.1/2/4:1 unassigned YES unset down down
Serial2/1/0.2/1:0 unassigned YES unset down down
Serial2/1/0.2/2:0 unassigned YES unset down down
Serial2/1/0.2/3:0 unassigned YES unset down down
Serial2/1/0.3 unassigned YES unset down down
UUT#sh int Serial2/1/0.1/1/1:0
Serial2/1/0.1/1/1:0 is down, line protocol is down
Hardware is Channelized-T3
MTU 1500 bytes, BW 192 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 192 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions alarm present
VC 2: timeslot(s): 1-3, Transmitter delay 0, non-inverted data

Following is a sample configuration:

UUT#sh run | beg 2/1/0
controller SONET 2/1/0
ais-shut
framing sonet
clock source line
overhead j0 1
!
sts-1 1
mode vt-15
vtg 1 t1 1 channel-group 0 timeslots 1-3
vtg 2 t1 4 channel-group 0 timeslots 1-2,5-6
vtg 2 t1 4 channel-group 1 timeslots 3,7,9
!
sts-1 2
mode ct3
t1 1 channel-group 0 timeslots 1-24
t1 2 channel-group 0 timeslots 1-12
t1 3 channel-group 0 timeslots 1
!
sts-1 3
mode t3
!
controller T3 3/1/0
shutdown
cablelength 224
!
controller T3 3/1/1
shutdown
cablelength 224
!!
interface Loopback0
ip address 172.10.11.1 255.255.255.255
.

.

Configuring Encapsulation

When traffic crosses a WAN link, the connection needs a Layer 2 protocol to encapsulate traffic. To set the encapsulation method, use the following commands:

 

Command
Purpose

Step 1

Router# configure terminal

Enters global configuration mode.

Step 2

Router(config)# interface serial

For addressing information, refer to the “Interface Naming” section.

Selects the interface to configure.

  • slot/subslot/port:channel-group—Specifies the location of the interface.

Step 3

Router(config-if)# encapsulation encapsulation-type {hdlc | ppp | frame-relay}

Set the encapsulation method on the interface.

  • hdlc—High-Level Data Link Control (HDLC) protocol for serial interface. This encapsulation method provides the synchronous framing and error detection functions of HDLC without windowing or retransmission. This is the default for synchronous serial interfaces.
  • ppp—PPP (for serial interface).
  • frame-relay—Frame Relay (for serial interface).

Step 4

Router(config-if)# crc {16 | 32}

Selects the CRC size in bits.

  • 16—16-bit CRC. This is the default
  • 32—32-bit CRC.

Configuring the CRC Size for T1

The 1-Port Channelized OC-3/STM-1 SPA interface uses a 16-bit cyclic redundancy check (CRC) by default, but also support a 32-bit CRC. CRC is an error-checking technique that uses a calculated numeric value to detect errors in transmitted data. The designators 16 and 32 indicate the length (in bits) of the frame check sequence (FCS). A CRC of 32 bits provides more powerful error detection, but adds overhead. Both the sender and receiver must use the same setting.

CRC-16, the most widely used CRC throughout the United States and Europe, is used extensively with WANs. CRC-32 is specified by IEEE 802 and as an option by some point-to-point transmission standards. It is often used on Switched Multimegabit Data Service (SMDS) networks and LANs.

To set the length of the cyclic redundancy check (CRC) on a T1 interface, use these commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial

For addressing information, refer to the “Interface Naming” section.

Selects the interface to configure.

  • slot/subslot/port:channel-group—Specifies the location of the interface.

Router(config-if)# crc {16|32}

Configures the CRC based on the configuration value. If you do not set any value, the default value of 16 is assigned.

Configuring FDL

Facility Data Link (FDL) is a 4-kbps channel provided by the Extended Super Frame (ESF) T1 framing format. The FDL performs outside the payload capacity and allows you to check error statistics on terminating equipment without intrusion.

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# controller sonet slot/ subslot/port

See the “Interface Naming” section.

Selects the controller to configure.

  • slot/subslot/port—Specifies the location of the controller.

Router(config-controller)# sts-1

If the framing format was configured for esf, configures the format used for Facility Data Link (FDL).

Router(config-controller) vtg 1 t1 1 fdl ansi

  • vtg —Specifies the VTG number
  • t1 — Specifies the T1 number for which FDL need to be configured.
  • ansi—Select ANSI for FDL to use the ANSI T1.403 standard.

Verifying FDL

Use the show controllers command to verify the FDL setting:

Router(config)# show controllers sonet3/0/0.1/1/1
SONET 3/0/0 is down.
Path mode VT15
STS-1 1, VTG 1, T1 1 (VT1.5 1/1/1) is down
timeslots: 1-24
FDL per ANSI T1.403 and AT&T 54016 spec.
Receiver is getting AIS.
Framing is ESF, Clock Source is Internal
Data in current interval (805 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs
805 Unavail Secs, 0 Stuffed Secs
Data in Interval 1:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs
900 Unavail Secs, 0 Stuffed Secs

Configuring Multilink Point-to-Point Protocol (Hardware-based)

Multilink Point to Point Protocol (MLPPP) allows you to combine interfaces which correspond to an entire T1 or E1 multilink bundle. You choose the number of bundles and the number of T1 or E1 lines in each bundle.

MLPPP Configuration Guidelines

The required conditions are:

  • Only T1 or E1 links in a bundle
  • All links on the same SPA
  • Maximum of 12 links in a bundle.

NoteSome notes about hardware-based MLPPP:

Only 3 fragmentation sizes are possible 128, 256 and 512 bytes

Fragmentation is enabled by default, default size is 512 bytes

Fragmentation size is configured using the ppp multilink fragment-delay command after using the interface multilink command. The least of the fragmentation sizes (among the 3 sizes possible) satisfying the delay criteria is configured. (e.g., a 192 byte packet causes a delay of 1 millisecond on a T1 link, so the nearest fragmentation size is 128 bytes.

The show ppp multilink command will indicate the MLPPP type and the fragmentation size:

Router# show ppp multilink
Multilink1, bundle name is Patriot2
Bundle up for 00:00:13
Bundle is Distributed
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 206/255 load
0x0 received sequence, 0x0 sent sequence
Member links: 2 active, 0 inactive (max not set, min not set)
Se4/2/0.1/1/1:0, since 00:00:13, no frags rcvd
Se4/2/0.1/1/2:0, since 00:00:10, no frags rcvd
Distributed fragmentation on. Fragment size 512. Multilink in Hardware.

Fragmentation is disabled explicitly by using the no ppp multilink fragmentation command after using the interface multilink command.


Create a Multilink Bundle

To create a multilink bundle, use the following commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface multilink group-number

Creates a multilink interface and enter multilink interface mode.

  • group-number—The group number for the multilink bundle.

Router(config-if)# ip address address mask

Sets the IP address for the multilink group.

  • address—The IP address.
  • mask—The IP netmask.

Assign an Interface to a Multilink Bundle

To assign an interface to a multilink bundle, use the following commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial

For addressing information, refer to the “Interface Naming” section.

Selects the interface to configure and enters interface configuration mode.

Router(config-if)# encapsulation ppp

Enables PPP encapsulation.

Router(config-if)# multilink-group group-number

Assigns the interface to a multilink bundle.

  • group-number—The multilink group number for the T1 or E1 bundle.

Router(config-if)# ppp m ultilink

Enables multilink PPP on the interface.

Repeat these commands for each interface you want to assign to the multilink bundle.

 

Configuring Fragmentation Size on an MLPPP Bundle (optional)

To configure the fragmentation size on a multilink ppp bundle, use the following commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface multilink

For addressing information, refer to the “Interface Naming” section.

Creates a multilink interface and enters multilink interface mode.

  • group-number—The group number for the multilink bundle. Range 1-65535

Router(config-if)# ppp multilink fragment-delay delay

Sets the fragmentation size satisfying the configured delay on the multilink bundle.

  • delay—delay in milliseconds

Disabling the Fragmentation on an MLPPP Bundle (optional)

To assign an interface to a multilink bundle, use the following commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface multilink group-number

Creates a multilink interface and enters multilink interface mode.

  • group-number—The group number for the multilink bundle. Range 1-65535

Router(config-if)# no ppp multilink fragmentation

Disables the fragmentation on the multilink bundle.

Configuring APS

Automatic protection switching (APS) allows switchover of the channelized OC3/OC12 channels in the event of failure. APS refers to the mechanism of using a protect interface in the network as the backup for a working interface. When the working interface fails, the protect interface quickly assumes its traffic load. Depending on the configuration, the two circuits may be terminated in the same router, or in different routers.

MLPPP MR-APS switchover time on all serial SPAs that support PPP encapsulation and APS on the SIP 400 is enhanced in 12.2(33) SRD2 release. MLPPP APS switchover time on the Cisco 7600 platform is a combination of the time spent executing the software and the time required for LCP, IPCP negotiations by the newly forwarding MLP Bundle. In 12.2(33) SRD2, Cisco 7600 platform software is optimized to help faster MLPPP APS switchover time.

Further, to help reduce the LCP, IPCP negotiation time, the granularity of the ppp timeout retry command is also enhanced in 12.2(33)SRD2, to include millisecond values. The PPP timeout retry determines how long the PPP state machine for LCP waits for a response from the remote peer before transmitting the next configuration request packet. The first configuration request packet from the new active APS router is used by the APS unaware router to bring down the PPP sessions. The second configuration request packet from the new active APS router triggers LCP negotiation.

There is no change in the Default PPP timeout retry value (2secs). In SRD2 release, minimum supported configurable ppp timeout retry value is 255msec.


NoteConfiguring the PPP retry timeout to be 250ms increases the CPU load on the router but the faster PPP retry timeout speeds up the PPP re-negotiation to help the overall switchover time


The performance enhancement of PPP/MLPPP APS does not impact the original PPP/MLPPP scalability on Cisco 7600.

For more information about APS, refer to A Brief Overview of Packet Over SONET APS at the following URL:

http://www.cisco.com/en/US/tech/tk482/tk607/technologies_tech_note09186a0080093eb5.shtml

To configure the working interface, use the following command in interface configuration mode:

 

Command
Purpose

Router(config)# controller sonet slot/subslot/port

Selects the interface to configure and enters controller configuration mode.

slot/subslot/port—Specifies the location of the controller.

Router(config-if)# aps working

Configures a channelized OC3/OC12 interface as a working APS interface

To remove the channelized interface as a working interface, use the no form of this command.

To configure the protect channelized interface, use the following command in interface configuration mode:

Command
Purpose

Router(config)# controller sonet slot/subslot/port

Selects the interface to configure and enters controller configuration mode.

slot/subslot/port—Specifies the location of the interface.

Router(config-if)# aps protect

Configures a channelized OC3/OC12 interface as a protect APS interface

To revert the protect interfaceconfiguration on the channelized interface, use the no form of this command.

To configure the ppp timeout retry channelized interface, use the following command in interface configuration mode:

Command
Purpose

Router(config)# interface serial slot/subslot/port:channel-group

Selects the interface to configure and enters interface configuration mode.

slot/subslot/port:channel-group—Specifies the location of the interface.

Router(config-if)# ppp timeout retry <0-255> [<0-999>]

Configures the PPP Control Protocol retry timer on the channelized serial interface, in milliseconds

Note The msecs timer increases the load on the router and should not be used except for the APS retry timeout configuration.

Note This command is backward compatible with previous release trains up till12.2(33)SRC for the 1-Port Channelized OC-3/STM-1 SPA and up till 12.2(33)SRD for the 1-Port Channelized OC-12/STM-4 SPA.

To remove thetimeout retry configuration on the interface, use the no form of this command.

Verifying the APS Configuration

To verify the APS configuration or to determine if a switchover has occurred, use the show aps command.

The following is an e xample of the show aps command anda typical a configuration on the sonet controller for APS on 1-Port Channelized OC-12/STM-4 SPA and 1-Port Channelized OC-3/STM-1 SPA

 
Router#sh aps
SONET 3/0/0 APS Group 1: working channel 1 (Active)
Protect at 1.0.0.1
PGP timers (from protect): hello time=1; hold time=3
PGP timers (configured): hello time=1; hold time=3
SONET framing
Remote APS configuration: (null)
 
controller SONET 3/0/0
ais-shut
threshold sf-ber 3
framing sonet
clock source line
aps group 1
aps working 1
aps timers 1 3
 

Configuring MLFR

Multilink Frame Relay (MLFR) allows you to combine T1/E1 lines into a bundle that has the combined bandwidth of multiple T1/E1 lines. You choose the number of bundles and the number of T1/E1 lines in each bundle. This allows you to increase the bandwidth of your network links beyond that of a single T1/E1 line.

MLFR Configuration Guidelines

MLFR will function in hardware if all of the following conditions are met:

  • Only T1 or E1 member links
  • All links are on the same SPA
  • Maximum of 12 links in a bundle
  • Only supported on OC3/STM-1 SPA on SIP-200

Create a Multilink Bundle

To create a multilink bundle, use the following commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface mfr number

Configures a multilink Frame Relay bundle interface.

  • number—The number for the Frame Relay bundle.

Router(config-if)# frame-relay multilink bid name

(Optional) Assigns a bundle identification name to a multilink Frame Relay bundle.

  • name—The name for the Frame Relay bundle.

Note The bundle identification (BID) will not go into effect until the interface has gone from the down state to the up state. One way to bring the interface down and back up again is by using the shut and no shut commands in interface configuration mode.

Assign an Interface to a Multilink Bundle

To assign an interface to a multilink bundle, use the following commands:

 

Command
Purpose

Router# configure terminal

Enters global configuration mode.

Router(config)# interface serial

For addressing information, refer to the “Interface Naming” section.

Selects the interface to assign.

Router(config-if)# encapsulation frame-relay mfr number [name]

Creates a multilink Frame Relay bundle link and associates the link with a bundle.

  • number—The number for the Frame Relay bundle.
  • name—The name for the Frame Relay bundle.

Router(config-if)# frame-relay multilink lid name

(Optional) Assigns a bundle link identification name with a multilink Frame Relay bundle link.

  • name—The name for the Frame Relay bundle.

Note The bundle link identification (LID) will not go into effect until the interface has gone from the down state to the up state. One way to bring the interface down and back up again is by using the shut and no shut commands in interface configuration mode.

Router(config-if)# frame-relay multilink hello seconds

(Optional) Configures the interval at which a bundle link will send out hello messages. The default value is 10 seconds.

  • seconds—Number of seconds between hello messages sent out over the multilink bundle.

Router(config-if)# frame-relay multilink ack seconds

(Optional) Configures the number of seconds that a bundle link will wait for a hello message acknowledgment before resending the hello message. The default value is 4 seconds.

  • seconds—Number of seconds a bundle link will wait for a hello message acknowledgment before resending the hello message.

Router(config-if)# frame-relay multilink retry number

(Optional) Configures the maximum number of times a bundle link will resend a hello message while waiting for an acknowledgment. The default value is 2 tries.

  • number—Maximum number of times a bundle link will resend a hello message while waiting for an acknowledgment.

Verifying Multilink Frame Relay

Use the show frame-relay multilink detailed command to verify the Frame Relay multilinks:

router# show frame-relay multilink detailed
 
Bundle: MFR49, State = down, class = A, fragmentation disabled
BID = MFR49
No. of bundle links = 1, Peer's bundle-id =
Bundle links:
 
Serial6/0/0:0, HW state = up, link state = Add_sent, LID = test
Cause code = none, Ack timer = 4, Hello timer = 10,
Max retry count = 2, Current count = 0,
Peer LID = , RTT = 0 ms
Statistics:
Add_link sent = 21, Add_link rcv'd = 0,
Add_link ack sent = 0, Add_link ack rcv'd = 0,
Add_link rej sent = 0, Add_link rej rcv'd = 0,
Remove_link sent = 0, Remove_link rcv'd = 0,
Remove_link_ack sent = 0, Remove_link_ack rcv'd = 0,
Hello sent = 0, Hello rcv'd = 0,
Hello_ack sent = 0, Hello_ack rcv'd = 0,
outgoing pak dropped = 0, incoming pak dropped = 0

FRF.12 Guidelines

FRF.12 functions in hardware and it is supported only onOC-3/STM-1 SPA with SIP200 only. Note the following:

  • Only 3 fragmentation sizes are available - 128 bytes, 256 bytes, and 512 bytes.
    The supported fragment sizes - 128, 256 and 512 - include the FRF and NLPID headers in addition to the payload.
  • If you have a configuration where a C7600 router acts as a Provider Edge(PE) router between Customer Edge(CE) routers, you can configure C7600 in plain Frame Relay or Frame Relay Fragmentation mode. If you enable Frame Relay Fragmentation only at the CE routers and C7600 acts as a plain Frame Relay interface, the configuration works fine. In a configuration of C7600 with any of the three SPAs(8-Port Channelized T1/E1 SPA,1-Port Channelized OC-3/STM-1 SPA or 2 or 4-Port CT3 SPA), where Frame Relay is configured on the serial interface and Frame Relay Fragmentation is enabled in any of the sub interfaces, the fragmented packets may be dropped in the transparant DLCIs. If you want such a configuration to work, you should set the fragment size value on the main interface larger than any CE router fragmentation size using the command frame-relay fragment x end-to-end , where x is the fragmentation size on the main interface.

LFI Guidelines

LFI can function two ways - using FRF.12 or MLPPP. MLPPP LFI can be done in both hardware and software while FRF.12 LFI is done only in hardware.

HW MLPPP LFI Guidelines

LFI using MLPPP will function only in hardware if there is just one member link in the MLPPP bundle. The link can be a fractional T1 or full T1. Note the following:

  • The ppp multilink interleave command needs to be configured to enable interleaving.
  • Only three fragmentation sizes are supported - 128 bytes, 256 bytes, and 512 bytes.
  • Fragmentation is enabled by default, the default size being 512 bytes.
  • A policy-map having a priority class needs to applied to main interface.
  • Effective 12.2 SRB release, the bundle scale on a SIP200 is increased from 256 to 1024.

FRF.12 LFI Guidelines

LFI using FRF.12 is always done is hardware. Note the following:

  • The fragmentation is configured at the main interface
  • Only 3 fragmentation sizes are available - 128 bytes, 256 bytes, and 512 bytes.
  • A policy-map having a priority class needs to applied to main interface.

Configuring QoS Features on Serial SPAs

The SIPs and SPAs support many QoS features using modular QoS CLI (MQC) configuration. For information about the QoS features supported by the serial SPAs, see the Configuring QoS Features on Serial SPAs of Chapter5, “Configuring the SIPs and SSC”

Saving the Configuration


Caution When you swap a SPA-1XCHSTM1/OC3-V2 (Pb-free) SPA with a SPA-1XCHSTM1/OC3 (Pb) SPA or vice-versa, configuration is not retained.

To save your running configuration to nonvolatile random-access memory (NVRAM), use the following command in privileged EXEC configuration mode:

 

Command
Purpose

Router# copy running-config startup-config

Writes the new configuration to NVRAM.

For more information about managing configuration files, refer to the Cisco IOS Configuration Fundamentals Configuration Guide, Release 12.2 and Cisco IOS Configuration Fundamentals Command Reference, Release 12.2 publications.

Verifying the Interface Configuration

Besides using the show running-configuration command to display your Cisco 7600 series router configuration settings, you can use the show interface serial and the show controllers serial commands to get detailed information on a per-port basis for your1-Port Channelized OC-3/STM-1 SPA.

Verifying Per-Port Interface Status

To find detailed interface information on a per-port basis for the 1-Port Channelized OC-3/STM-1 SPA use the show interface serial command.

The following example provides sample output for interface port 0 on the SPA located in the second subslot of the Cisco 7600 SIP-200 installed in slot 2 of a Cisco 7600 series router in ct3 mode of SONET framing:

Router# show interface serial 2/1/0.2/1:0
Serial2/1/0.2/1:0 is down, line protocol is down
Hardware is Channelized-T3
MTU 1500 bytes, BW 1536 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 1536 kilobits/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions alarm present
VC 5: timeslot(s): 1-24, Transmitter delay 0, non-inverted data
UUT#sh int Serial2/1/0.3
Serial2/1/0.3 is down, line protocol is down
Hardware is CHOCx SPA
MTU 4470 bytes, BW 44210 Kbit, DLY 200 usec, rely 255/255, load 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
Available Bandwidth 44210 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 parity
(Remaining output omitted)

 

Configuration Tasks

This section describes common configurations for the 1-Port Channelized OC-3/STM-1 SPA on a Cisco 7600 series router. It contains procedures for the following configurations:

Configuring CRTP

For information on configuring cRTP, see Configuring Distributed Compressed Real-Time Protocol at the following URL:

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfdcrtp.html

Stateful MLPPP MR-APS

Multi Router-Automatic Protection Switching (MR-APS) provides Layer 1 switchover under 50 ms, across the two routers, for optical links . However, if the MLPPP/PPP sessions exist on the optical link during an MR-APS switchover, all the active Multilink Point to Point Protocol (MLPPP)/Point to Point Protocol (PPP) sessions need to renegotiate. The renegotiation process increases the switchover time and traffic loss. The Stateful MLPPP with MR-APS Inter-Chassis Redundancy feature provides the Inter Chassis-Stateful Switchover (IC-SSO) for MLPPP and PPP sessions across the two routers without the PPP/MLPPP session renegotiation.

The IC-SSO synchronizes the MLPPP sessions between the router hosting the active (working) MR-APS controllers and the router hosting the standby (protect) MR-APS controllers. Using the state information synchronized from the router hosting the active MR-APS controllers, the second router (with standby MR-APS controllers) maintains the forwarding plane in ready state to forward the traffic immediately after an MR-APS switchover occurs.

The Inter-chassis MR-APS MLPPP SSO combines existing IOS High Availability (HA) infrastructure that synchronizes PPP/MLPPPP states between the route processors on the same router chassis along with the Inter Chassis Redundancy Manager (ICRM), to provide stateful switchover of PPP/MLPPP sessions across the routers. This feature is supported on 1xCHOC3-STM1 SPA and 1xCHOC12-STM4 SPA. The 1xCHOC12-STM4 SPA is supported on SIP400 line card only and 1xCHOC3-STM1 is supported on SIP200 and SIP400 line cards for Cisco 7600 Series Routers.


NoteFor platform independent information of this feature, see the Wide-Area Networking Configuration Guide at:http://www.cisco.com/en/US/docs/ios/wan/configuration/guide/15_1s/wan_15_1s_book.html


MR-APS Deployment

The MR-APS deployment involves multiple cell sites connected to the provider network using the bundled T1/E1 connections. The T1/E1 connections are aggregated into the Optical Carrier 3 (OC3) or Optical Carrier 12 (OC12) links using the Add-Drop Multiplexers (ADMs).

Figure 21-1 shows the MR-APS deployment using the Cisco 7600 Routers.

Figure 21-1 MR-APS Deployment

 

To implement this feature, you need to configure the MR-APS IC-SSO on the two Cisco 7600 Routers, Working and Protect, as shown in this figure.

Unlike the conventional SSO model, where one router is active and the other is in standby mode, MR-APS deployment involves both the routers (Working and Protect) in active state with synchronized SONET controllers on both the routers. The controllers running on one router are in the standby mode on the other router and vice versa. When the MR-APS detects a failure in a SONNET OC3 or OC12 controller on the Working router, it activates the corresponding standby controller on the Protect router. This switchover from inactive to active state ensures minimum traffic outage and is achieved by ensuring that the MLPPP/PPP sessions per SONET controller (APS group) are stateful across the routers.

Inter Chassis Redundancy Manager

ICRM provides these capabilities for stateful MLPPP with MR-APS Inter-Chassis Redundancy implementation:

  • Node health monitoring for complete node, PE, or box failure detection. ICRM also communicates failures to the applications registered with an ICRM group.
  • Reliable data channels to transfer the state information.
  • Detects active RP failure as node failure and notifies the controllers.
  • ICRM on the standby RP re-establishes the communication channel with peer node if the active RP fails.

Automatic Protection Switching

APS allows switchover of the OC3 or OC12 controllers in the event of a network failure. APS involves a protect interface in the network as the backup for an active (working) interface. When the active interface fails, the protect interface quickly takes care of the traffic load. Depending on the configuration, the two interfaces may be terminated on the same router, or on different routers. Based on where the interfaces terminates, APS is categorized into two types: Single Router-APS (SR-APS) and Multi Router-APS (MR-APS). Additionally, the APS is responsible for managing the active and standby progression events on the APS groups. Each APS group is a logical representation of a physical SONET controller redundancy state.

For more information on APS, see Configuring APS .

Failure Protection Scenarios

The Stateful MLPPP feature provides network resiliency by protecting against:

  • Active APS SONET controller, SPA, or Line card failure
  • RP and Node failure

Active APS SONET controller, SPA, or Line card failure

Figure 21-2 shows MLPPP sessions in MR-APS configuration before an active APS group fails. On the Router A active RP, grp1 is the APS group1 and group2 is the APS group 2. All the sessions of the group1 are active and all the sessions of group2 are standby on Router A. Similarly, on the Router B, all the sessions of the group2 are active and all the sessions of group1 are in the standby state.

Figure 21-2 MLPPP Sessions Before an Active APS Group Fails

 

When an APS group on Router A fails, the APS informs the corresponding standby APS group on the Router B to take over as active APS group. The standby APS group on Router B changes state to the active and all the sessions in the group become active. The APS group on Router A is re-initialize and moved to the standby state. Figure 21-3 shows how the MLPPP sessions switchover after an active APS (group1) fails:

Figure 21-3 MLPPP Sessions After an Active APS Group Fails

 

Route Processor and Node failure

The ICRM treats an active RP failure as a complete node failure. It sends the failure notification and communicates the go-active event to the standby APS groups. The standby APS groups move to active state on receiving the go-active event message. When the failed node comes up, the ICRM establishes fresh connection with all the APS groups on the node. All the APS groups are synchronized between the two routers, and the APS groups on the second router are moved to the standby state.

Figure 21-4 shows APS groups on the two peer nodes, Router A and Router B.

Figure 21-4 APS Groups on Peer Nodes

 

When the active RP of the Router A fails, the APS groups are switched over to the Router B making all the APS groups on the Router B active. All the APS groups on the standby RP of Router A are set to the initial state after the standby RP changes to active on the Router A. The applications that are RP SSO aware (non ICRM clients) switchover to the standby RP on Router A. Figure 21-5 shows the APS groups after the active RP on the Router A fails.

Figure 21-5 APS Groups After the Active RP on Router A Fails

 

The ICRM establishes fresh connections with the new active RP on the Router A and the APS synchronizes the group states from Router B to Router A (in standby state). This event triggers all the APS groups on Router A to move to standby state and the synchronization process is initiated from the Router B. On the Router A, the failed RP reboots as the new standby RP and RP SSO aware applications are synchronized to the new standby RP.

Restrictions for Stateful MLPPP with MR-APS Inter-Chassis Redundancy

Following restrictions apply for Stateful MLPPP with MR-APS Inter-Chassis Redundancy:

  • Both the routers should have same MR-APS configuration.
  • The In-Service Software Upgrade (ISSU) functionality is not supported.
  • Applications running over MLP/PPP sessions such as the Internet Group Management Protocol (IGMP) and Transmission Control Protocol (TCP) are not synchronized across the routers. On the APS switchover, IGMP joints and TCP sessions are re-established.
  • APS session throttling for the groups is not supported.
  • Broadband sessions such as Point-to-Point Protocol over X (PPPoX) and IP are not supported.
  • Intelligent Services Gateway (ISG) features are not supported on APS groups.
  • The Authentication, Authorization and Accounting (AAA) protocol is not supported for MR-APS switchover.
  • APS revertive mode is not supported.

Configuring Stateful MLPPP with MR-APS Inter-Chassis Redundancy

To configure Stateful MLPPP with MR-APS Inter-Chassis Redundancy, you need to configure the two Cisco 7600 Series Routers with ICRM and MR-APS configuration. Figure 21-1 shows typical infrastructure for Stateful MLPPP with MR-APS Inter-Chassis Redundancy implementation.

The configuration involves these steps:

  • Configuring MR-APS Inter-Chassis Redundancy on the Working Router
  • Configuring MR-APS Inter-Chassis Redundancy on the Protect Router

Configuring MR-APS Inter-Chassis Redundancy on the Working Router

SUMMARY STEPS

1. enable

2. configure terminal

3. redundancy

4. interchassis group group-id

5. monitor peer bfd

6. member ip ip-address

7. end

8. configure terminal

9. interface gigabitethernet slot / port

10. ip address ip_address subnet_mask

11. no shutdown

12. load-interval seconds

13. negotiation { forced | auto }

14. mpls ip

15. mpls label protocol { ldp | tdp | both }

16. bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

17. end

18. configure terminal

19. interface gigabitethernet slot/port

20. ip address ip_address subnet_mask

21. no shutdown

22. negotiation { forced | auto }

23. cdp { enable | disable }

24. end

25. configure terminal

26. controller sonet slot / bay/port

27. no ais-shut

28. framing sonet

29. clock source { line [ primary | bits | independent ] | internal [ independent ] | free-running }

30. sts-1 sts1-number

31. mode vt-15

32. vtg vtg_number t1 t1_line_number channel-group channel-number timeslots list-of-timesolts

33. end

34. configure terminal

35. interface multilink1

36. ip address ip_address subnet_mask

37. carrier-delay msec msec

38. ppp multilink

39. ppp multilink group group-number

40. ppp multilink endpoint { hostname | ip ip-address | mac lan-interface | none | phone telephone-number | string char-string }

41. ppp timeout retry seconds

42. end

43. configure terminal

44. interface serial instance

45. no ip address

46. encapsulation ppp

47. ppp multilink

48. ppp multilink group group-number

49. end

50. configure terminal

51. controller sonet slot / bay / port

52. shutdown

53. aps group group_id

54. aps [ working | protect ] aps-group-number [ ip_address_of_working ]

55. aps interchassis group icrm-group-number

56. no shutdown

57. end

DETAILED STEPS

 

Command
Purpose

Step 1

enable

 
Working-Router> enable

Enables the privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Working-Router# configure terminal

Enters the global configuration mode.

Step 3

redundancy

 

Working-Router(config)# redundancy

Enters the redundancy configuration mode.

Step 4

interchassis group group-id

 

 

Working-Router(config-red)# interchassis group 50

Configures an interchassis group within the redundancy configuration mode and enters the interchassis redundancy mode.

Step 5

monitor peer bfd

 

 

Working-Router(config-r-ic)# monitor peer bfd

Configures the BFD to monitor the state of the peer routers. The default option is route-watch .

Step 6

member ip ip-address

 

 

Working-Router(config-r-ic)# member ip 60.60.60.2

Configures the IP address of the Multichassis Link Aggregation Control Protocol (mLACP) peer member group.

Step 7

end

 

Working-Router(config-r-ic)# end

 

Ends the configuration session and returns to the EXEC mode.

Step 8

configure terminal

 

Working-Router# configure terminal

Enters the global configuration mode.

Step 9

interface gigabitethernet slot/subslot/port

 

Working-Router(config)# interface GigabitEthernet3/1/0

Specifies the gigabit ethernet interface to configure ICRM connection, where:

slot/subslot/port—Specifies the location of the interface.

Step 10

ip address ip_address subnet_mask

 

Working-Router(config-if)# ip address 60.60.60.1 255.255.255.0

Configures the IP address of the interface.

Step 11

no shutdown

 

 

Working-Router(config-if)#no shutdown

 

Reverses the shutdown of an interface.

Step 12

load-interval seconds

 

Working-Router(config-if)# load-interval 30

Sets the duration to calculate the load.

Step 13

negotiation {forced | auto}

 

Working-Router(config-if)# negotiation auto

Enables the advertisement of speed, duplex mode, and flow control on a gigabit ethernet interface.

Step 14

mpls ip

 

Working-Router(config-if)# mpls ip

Enables Multi Protocol Label Switching (MPLS).

Step 15

mpls label protocol {ldp | tdp | both}

 

Working-Router(config-if)# mpls label protocol both

Specifies that both label distribution protocols are supported on the interface.

Step 16

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

 

Working-Router(config-if)# bfd interval 50 min_rx 150 multiplier 3

Enables BFD on the interface.

Step 17

end

 

Working-Router(config-if)# end

 

Ends the configuration session and returns to the EXEC mode.

Step 18

configure terminal

 

Working-Router# configure terminal

Enters the global configuration mode.

Step 19

interface gigabitethernet slot/subslot/port

 

Working-Router(config-if)# interface GigabitEthernet3/1/1

Specifies the gigabit ethernet interface to configure PGP link:

slot/subslot/port—Specifies the location of the interface.

Step 20

ip address ip_address subnet_mask

 

Working-Router(config-if)# ip address 12.2.1.2 255.255.255.0

Configures the IP address of the interface.

Step 21

no shutdown

 

 

Working-Router(config-if)#no shutdown

 

Reverses the shutdown of an interface.

Step 22

negotiation {forced | auto}

 

Working-Router(config-if)# negotiation auto

Enables the advertisement of speed, duplex mode, and flow control on a gigabit ethernet interface.

Step 23

cdp {enable|disable}

 

Working-Router(config-if)# cdp enable

Enables the Cisco Discovery Protocol on an interface

Step 24

end

 

Working-Router(config-if)# end

Ends the configuration session and returns to the EXEC mode.

Step 25

configure terminal

 

Working-Router# configure terminal

 

Enters the global configuration mode.

Step 26

controller sonet slot/bay/port

 

Working-Router(config)#controller SONET 4/2/0

Selects and configures a SONET controller and enters controller configuration mode.

slot/subslot/port—Specifies the location of the interface.

Step 27

no ais-shut

 

Working-Router(config-controller)# no ais-shut

Disables automatic insertion of a Line Alarm Indication Signal (LAIS) in the SONET signal.

Step 28

framing sonet

 

Working-Router(config-controller)# framing sonet

Configures the controller for SONET framing. SONET framing is the default option.

Step 29

clock source {line [primary | bits | independent] | internal [independent] | free-running}

 

Working-Router(config-controller)# clock source line

Sets the clocking for individual T1 or E1 links. Specifies that the phase lock loop (PLL) on this controller derives its clocking from the external source connected to the controller (generally the telephone company’s central office).

Step 30

sts-1 sts1-number

 

Working-Router(config-controller)# sts-1 1

Specifies the STS identifier.

Step 31

mode vt-15

 

Working-Router(config-ctrlr-sts1)# mode vt-15

Specifies the STS-1 mode of operation.

Step 32

vtg vtg_number t1 t1_line_number channel-group channel-number timeslots list-of-timesolts

 

Working-Router(config-ctrlr-sts1)# vtg 1 t1 1 channel-group 0 timeslots 1-24

Creates a Circuit Emulation Services over Packet Switched Network circuit emulation (CESoPSN) CEM group.

Step 33

end

 

Working-Router(config-ctrlr-sts1)#end

Ends the configuration session and returns to the EXEC mode.

Step 34

configure terminal

 

Working-Router# configure terminal

Enters the global configuration mode.

Step 35

interface multilink1

 

Working-Router(config)#interface multilink1

Enters the multilink interface configuration mode.

Step 36

ip address ip_address subnet_mask

 

Working-Router(config-if)# ip address 11.1.1.2 255.255.255.0

Configures the IP address of the interface.

Step 37

carrier-delay msec msec

 

Working-Router(config-if)# carrier-delay msec 1

Sets the duration to propagate the link status to other modules.

Step 38

ppp multilink

 

Working-Router(config-if)# ppp multilink

Enables MLPPP.

Step 39

ppp multilink group group-number

 

Working-Router(config-if)# ppp multilink group 1

Specifies the physical link to associate to a designated multilink group interface.

Step 40

ppp multilink endpoint {hostname | ip ip-address | mac lan-interface | none | phone telephone-number | string char-string}

 

Working-Router(config-if)# ppp multilink endpoint string mlp_aps_1

Overrides or changes the default endpoint discriminator that the system uses when negotiating the use of MLPPP with the peer system. The command attributes are:

  • hostname: Indicates to use the hostname configured for the router. This is useful when multiple routers are using the same username to authenticate, but have different hostnames.
  • ip: Indicates to use the supplied IP address.
  • mac: Indicates to use the specified LAN interface whose MAC address is to be used.
  • none: Causes negotiation of the Link Control Protocol (LCP) without requesting the endpoint discriminator option. This is useful when the router connects to a malfunctioning peer system that does not handle the endpoint discriminator option properly.
  • phone: Indicates to use the specified telephone number. Accepts E.164-compliant, full international telephone numbers.
  • string: Indicates to use the supplied character string.

Step 41

ppp timeout retry seconds

 

Working-Router(config-if)# ppp timeout retry 0 250

Sets the PPP timeout retry parameters.


Note Replace the seconds argument with the maximum time, in seconds, to wait for a response during PPP negotiation. Range is from 1 to 10 seconds. The default is 3 seconds.


Step 42

end

 

Working-Router(config-if)# end

Ends the configuration session and returns to the EXEC mode.

Step 43

configure terminal

 

Working-Router# configure terminal

 

Enters the global configuration mode.

Step 44

interface serial instance

 

Working-Router(config-if)# interface Serial4/2/0.1/1/1:0

Configures a serial interface and enter the interface configuration mode.

Step 45

no ip address

 

Working-Router(config-if)# no ip address

 

Removes the configured IP address from the interface.

Step 46

encapsulation ppp

 

Working-Router(config-if)# encapsulation ppp

Enables PPP encapsulation of traffic on the specified interface.

Step 47

ppp multilink

 

Working-Router(config-if)# ppp multilink

Enables MLP.

Step 48

ppp multilink group group-number

 

Working-Router(config-if)# ppp multilink group 1

Specifies the physical link to attach to the designated multilink group interface.

Step 49

end

 

Working-Router(config-if)# end

Ends the configuration session and returns to the EXEC mode..

Step 50

configure terminal

 

Working-Router# configure terminal

Enters the global configuration mode.

Step 51

controller sonet slot/bay/port

 

 

Working-Router(config)# controller sonet 4/2/0

Selects and configures a SONET controller and enters the controller configuration mode.

slot/subslot/port—Specifies the location of the interface.

Step 52

shutdown

 

 

Working-Router(config-controller)#shutdown

Shuts down the SONET controller.

Step 53

aps group group_id

 

 

Working-Router(config-controller)#aps group 1

Configures the APS group for a SONET controller.

Step 54

aps [working | protect] aps-group-number [ip_address_of_working]

 

 

Working-Router(config-controller)# aps working 1

Configures the APS group as the working interface.


Note The attribute, ip_address_of_working, is only required for configuring the Protect router configuration.


Step 55

aps interchassis group icrm-group-number

 

 

Working-Router(config-controller)# aps interchassis group 1

 

Associates the APS group to an ICRM group number.

Step 56

no shutdown

 

 

Working-Router(config-controller)#no shutdown

 

Reverses the shutdown of an interface.

Step 57

end

 

Working-Router(config-controller)#end

Ends the configuration session and returns to the EXEC mode.

Configuration Example

This example describes how to configure MR-APS Inter-Chassis Redundancy on a Working router.

Working-Router>enable
Working-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config)#redundancy
Working-Router(config-red)#interchassis group 1
Working-Router(config-r-ic)#monitor peer bfd
Working-Router(config-r-ic)#member ip 60.60.60.2
Working-Router(config-r-ic)#end
Working-Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config)#interface GigabitEthernet3/1/0 <<<<<<< ICRM link >>>>>>>>
Working-Router(config-if)#ip address 60.60.60.1 255.255.255.0
Working-Router(config-if)#no shutdown
Working-Router(config-if)#load-interval 30
Working-Router(config-if)#negotiation auto
Working-Router(config-if)#mpls ip
Working-Router(config-if)#mpls label protocol both
Working-Router(config-if)#bfd interval 50 min_rx 150 multiplier 3
Working-Router(config-if)#end
Working-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config-if)#interface GigabitEthernet3/1/1 <<<<< PGP Link>>>>>>>
Working-Router(config-if)#ip address 12.2.1.2 255.255.255.0
Working-Router(config-if)no shutdown
Working-Router(config-if)#negotiation auto
Working-Router(config-if)#cdp enable
Working-Router(config-if)#end
Working-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config)#controller SONET 4/2/0
Working-Router(config-controller)#no ais-shut
Working-Router(config-controller)#framing sonet
Working-Router(config-controller)#clock source line
Working-Router(config-controller)#sts-1 1
Working-Router(config-ctrlr-sts1)#mode vt-15
Working-Router(config-ctrlr-sts1)#vtg 1 t1 1 channel-group 0 timeslots 1-24
Working-Router(config-ctrlr-sts1)#end
Working-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config)#interface Multilink1
Working-Router(config-if)#ip address 11.1.1.2 255.255.255.0
Working-Router(config-if)#carrier-delay msec 1
Working-Router(config-if)#ppp multilink
Working-Router(config-if)#ppp multilink group 1
Working-Router(config-if)#ppp multilink endpoint string mlp_aps_1
Working-Router(config-if)#ppp timeout retry 0 250
Working-Router(config-if)#end
Working-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config)#interface Serial4/2/0.1/1/1:0
Working-Router(config-if)#no ip address
Working-Router(config-if)#encapsulation ppp
Working-Router(config-if)#ppp multilink
Working-Router(config-if)#ppp multilink group 1
Working-Router(config-if)#end
Working-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Working-Router(config)#controller sonet 4/2/0
Working-Router(config-controller)#shutdown
Working-Router(config-controller)#aps group 1
Working-Router(config-controller)#aps working 1
Working-Router(config-controller)#aps interchassis group 1
Working-Router(config-controller)#no shutdown
Working-Router(config-controller)#end

 

Configuring MR-APS Inter-Chassis Redundancy on Protect Router

SUMMARY STEPS

1. enable

2. configure terminal

3. redundancy

4. interchassis group group-id

5. monitor peer bfd

6. member ip ip-address

7. end

8. configure terminal

9. interface gigabitethernet slot / port

10. ip address ip_address subnet_mask

11. no shutdown

12. load-interval seconds

13. negotiation { forced | auto }

14. mpls ip

15. mpls label protocol { ldp | tdp | both }

16. bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

17. end

18. configure terminal

19. interface gigabitethernet slot / port

20. ip address ip_address subnet_mask

21. no shutdown

22. negotiation { forced | auto }

23. cdp { enable | disable }

24. end

25. configure terminal

26. controller sonet slot / bay / port

27. no ais-shut

28. framing sonet

29. clock source { line [ primary | bits | independent ] | internal [ independent ] | free-running }

30. sts-1 sts1-number

31. mode vt-15

32. vtg vtg_number t1 t1_line_number channel-group channel-number timeslots list-of-timesolts

33. end

34. configure terminal

35. interface multilink1

36. ip address ip_address subnet_mask

37. carrier-delay msec msec

38. ppp multilink

39. ppp multilink group group-number

40. ppp multilink endpoint { hostname | ip ip-address | mac lan-interface | none | phone telephone-number | string char-string }

41. ppp timeout retry seconds

42. end

43. configure terminal

44. interface serial instance

45. no ip address

46. encapsulation ppp

47. ppp multilink

48. ppp multilink group group-number

49. end

50. configure terminal

51. controller sonet slot / bay / port

52. shutdown

53. aps group group_id

54. aps [ working | protect ] aps-group-number [ ip_address_of_working ]

55. aps interchassis group icrm-group-number

56. no shutdown

57. end

DETAILED STEPS

 

Command
Purpose

Step 1

enable

 
Protect-Router>enable

Enables the privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 3

redundancy

 

Protect-Router(config)#redundancy

Enters the redundancy configuration mode.

Step 4

interchassis group group-id

 

 

Protect-Router(config-red)#interchassis group 1

Configures an interchassis group within the redundancy configuration mode and enters the interchassis redundancy mode.

Step 5

monitor peer bfd

 

 

Protect-Router(config-r-ic)#monitor peer bfd

Configures the BFD option to monitor the state of the peer. The default option is route-watch .

Step 6

member ip ip-address

 

 

Protect-Router(config-r-ic)#member ip 60.60.60.1

Configures the IP address of the mLACP peer member group.

Step 7

end

 

Protect-Router(config-r-ic)#end

 

Ends the configuration session and returns to the EXEC mode.

Step 8

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 9

interface gigabitethernet slot/subslot/port

 

Protect-Router(config)#interface GigabitEthernet2/1/0

Specifies the gigabit ethernet interface to configure the ICRM connection, where:

slot/subslot/port—Specifies the location of the interface.

Step 10

ip address ip_address subnet_mask

 

Protect-Router(config-if)#ip address 60.60.60.2 255.255.255.0

Configures the the IP address of the interface.

Step 11

no shutdown

 

 

Working-Router(config-if)#no shutdown

 

Reverses the shutdown of an interface.

Step 12

load-interval seconds

 

Protect-Router(config-if)#load-interval 30

Sets the duration to calculate the load.

Step 13

negotiation {forced | auto}

 

Protect-Router(config-if)#negotiation auto

Enables the advertisement of speed, duplex mode, and flow control on a the gigabit ethernet interface.

Step 14

mpls ip

 

Protect-Router(config-if)#mpls ip

Enables MPLS.

Step 15

mpls label protocol {ldp | tdp | both}

 

Protect-Router(config-if)#mpls label protocol both

Specifies that both label distribution protocols are supported on the interface.

Step 16

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

 

Protect-Router(config-if)#bfd interval 50 min_rx 150 multiplier 3

Enables BFD on the interface.

Step 17

end

 

Protect-Router(config-if)#end

 

Ends the configuration session and returns to the EXEC mode..

Step 18

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 19

interface gigabitethernet slot/subslot/port

 

Protect-Router(config-if)#interface GigabitEthernet2/1/1

Specifies the gigabit ethernet interface to configure the PGP link, where:

slot/subslot/port—Specifies the location of the interface.

Step 20

ip address ip_address subnet_mask

 

Protect-Router(config-if)#ip address 12.2.1.1 255.255.255.0

Configures the IP address of the interface.

Step 21

no shutdown

 

 

Working-Router(config-if)#no shutdown

 

Reverses the shutdown of an interface.

Step 22

negotiation {forced | auto}

 

Protect-Router(config-if)#negotiation auto

Enables the advertisement of speed, duplex mode, and flow control on a gigabit ethernet interface.

Step 23

end

 

Protect-Router(config-if)#end

Ends the configuration session and returns to the EXEC mode.

Step 24

configure terminal

 

Protect-Router#configure terminal

 

Enters the global configuration mode.

Step 25

controller sonet slot/bay/port

 

Protect-Router(config)#controller SONET 3/2/0

Selects and configures a SONET controller and enters the controller configuration mode.

slot/subslot/port—Specifies the location of the interface.

Step 26

no ais-shut

 

Protect-Router(config-controller)#no ais-shut

Disables the automatic insertion of a LAIS in the SONET signal.

Step 27

framing sonet

 

Protect-Router(config-controller)#framing sonet

Configures the controller for SONET framing. SONET framing is the default option.

Step 28

clock source {line [primary | bits | independent] | internal [independent] | free-running}

 

Protect-Router(config-controller)#clock source line

Sets clocking for individual T1 or E1 links. This command specifies that the PLL on this controller derives its clocking from the external source connected to the controller (generally the telephone company’s central office).

Step 29

sts-1 sts1-number

 

Protect-Router(config-controller)#sts-1 1

Specifies the STS identifier.

Step 30

mode vt-15

 

Protect-Router(config-ctrlr-sts1)# mode vt-15

Specifies the STS-1 mode of operation.

Step 31

vtg vtg_number t1 t1_line_number channel-group channel-number timeslots list-of-timesolts

 

Protect-Router(config-ctrlr-sts1)#vtg 1 t1 1 channel-group 0 timeslots 1-24

Creates a Circuit Emulation Services over Packet Switched Network circuit emulation (CESoPSN) CEM group.

Step 32

end

 

Protect-Router(config-ctrlr-sts1)#end

Ends the configuration session and returns to the EXEC mode.

Step 33

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 34

interface multilink1

 

Protect-Router(config)#interface multilink1

Enters multilink interface configuration mode.

Step 35

ip address ip_address subnet_mask

 

Protect-Router(config-if)#ip address 11.1.1.2 255.255.255.0

Configures the IP address for the interface.

Step 36

carrier-delay msec msec

 

Protect-Router(config-if)#carrier-delay msec 1

Sets the duration to propagate the link status to other modules.

Step 37

ppp multilink

 

Protect-Router(config-if)#ppp multilink

Enables MLPPP.

Step 38

ppp multilink group group-number

 

Protect-Router(config-if)#ppp multilink group 1

Specifies the physical link to associate to the designated multilink group interface.

Step 39

ppp multilink endpoint {hostname | ip ip-address | mac lan-interface | none | phone telephone-number | string char-string}

 

Protect-Router(config-if)#ppp multilink endpoint string mlp_aps_1

Overrides or changes the default endpoint discriminator that the system uses while negotiating the use of MLP with the peer system.

  • hostname: Indicates to use the hostname configured for the router. This is useful when multiple routers are using the same username to authenticate, but have different hostnames.
  • ip: Indicates to use the supplied IP address.
  • mac: Indicates to use the specified LAN interface whose MAC address is to be used.
  • none: Causes negotiation of the Link Control Protocol (LCP) without requesting the endpoint discriminator option. This is useful when the router connects to a malfunctioning peer system that does not handle the endpoint discriminator option properly.
  • phone: Indicates to use the specified telephone number. Accepts E.164-compliant, full international telephone numbers.
  • string: Indicates to use the supplied character string.

Step 40

ppp timeout retry seconds

 

Protect-Router(config-if)#ppp timeout retry 0 250

Sets the PPP timeout retry parameters.


Note Replace the seconds argument with the maximum time, in seconds, to wait for a response during PPP negotiation. Range is from 1 to 10 seconds. The default is 3 seconds.


Step 41

end

 

Protect-Router(config-if)#end

Ends the configuration session and returns to the EXEC mode.

Step 42

configure terminal

 

Protect-Router#configure terminal

 

Enters the global configuration mode.

Step 43

interface serial instance

 

Protect-Router(config-if)#interface Serial3/2/0.1/1/1:0

Configures the serial interface and enters the interface configuration mode.

slot/subslot/port—Specifies the location of the interface.

Step 44

no ip address

 

Protect-Router(config-if)#no ip address

 

Removes the configured IP address on the interface.

Step 45

encapsulation ppp

 

Protect-Router(config-if)#encapsulation ppp

Enables PPP encapsulation of traffic on the specified interface.

Step 46

ppp multilink

 

Protect-Router(config-if)#ppp multilink

Enables MLPPP.

Step 47

ppp multilink group group-number

 

Protect-Router(config-if)#ppp multilink group 1

Specifies the physical link to attach to the designated multilink group interface.

Step 48

end

 

Protect-Router(config-if)#end

Ends the configuration session and returns to the EXEC mode.

Step 49

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 50

controller sonet slot/bay/port

 

 

Protect-Router(config)#controller sonet 3/2/0

Selects and configures a SONET controller and enters the controller configuration mode.

slot/subslot/port—Specifies the location of the interface.

Step 51

shutdown

 

 

Protect-Router(config-controller)#shutdown

Shuts down the SONET controller.

Step 52

aps group group_id

 

 

Protect-Router(config-controller)#aps group 1

Configures the APS group for a SONET controller.

Step 53

aps [working | protect] aps-group-number [ip_address_of_working]

 

 

Protect-Router(config-controller)#aps protect 1 12.2.1.2

Configures the APS group as protect interface. The attribute, ip_address_of_working , is the ip address of the PGP link interface on the working router.

Step 54

aps interchassis group icrm-group-number

 

 

Protect-Router(config-controller)#aps interchassis group 1

 

Associates the APS group to an ICRM group number.

Step 55

no shutdown

 

 

Protect-Router(config-controller)#no shutdown

 

Reverses the shutdown of an interface.

Step 56

end

 

Protect-Router(config-controller)#end

Ends the configuration session and returns to the EXEC mode.

Example

This example displays the steps to configure MR-APS Inter-Chassis Redundancy on the Protect router.

Protect-Router>enable
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config)#redundancy
Protect-Router(config-red)#interchassis group 1
Protect-Router(config-r-ic)#monitor peer bfd
Protect-Router(config-r-ic)#member ip 60.60.60.1
Protect-Router(config-r-ic)#end
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config)#interface GigabitEthernet2/1/0
Protect-Router(config-if)#ip address 60.60.60.2 255.255.255.0
Protect-Router(config-if)#no shutdown
Protect-Router(config-if)#load-interval 30
Protect-Router(config-if)#negotiation auto
Protect-Router(config-if)#mpls ip
Protect-Router(config-if)#mpls label protocol both
Protect-Router(config-if)#bfd interval 50 min_rx 150 multiplier 3
Protect-Router(config-if)#end
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config-if)#interface GigabitEthernet2/1/1
Protect-Router(config-if)#ip address 12.2.1.1 255.255.255.0
Protect-Router(config-if)#no shutdown
Protect-Router(config-if)#negotiation auto
Protect-Router(config-if)#end
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config)#controller SONET 3/2/0
Protect-Router(config-controller)#no ais-shut
Protect-Router(config-controller)#framing sonet
Protect-Router(config-controller)#clock source line
Protect-Router(config-controller)#sts-1 1
Protect-Router(config-ctrlr-sts1)#mode vt-15
Protect-Router(config-ctrlr-sts1)#vtg 1 t1 1 channel-group 0 timeslots 1-24
Protect-Router(config-ctrlr-sts1)#end
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config)#interface Multilink1
Protect-Router(config-if)#ip address 11.1.1.2 255.255.255.0
Protect-Router(config-if)#carrier-delay msec 1
Protect-Router(config-if)#ppp multilink
Protect-Router(config-if)#ppp multilink group 1
Protect-Router(config-if)#ppp multilink endpoint string mlp_aps_1
Protect-Router(config-if)#ppp timeout retry 0 250
Protect-Router(config-if)#end
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config)#interface Serial3/2/0.1/1/1:0
Protect-Router(config-if)#no ip address
Protect-Router(config-if)#encapsulation ppp
Protect-Router(config-if)#ppp multilink
Protect-Router(config-if)#ppp multilink group 1
Protect-Router(config-if)#end
Protect-Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Protect-Router(config)#controller sonet 3/2/0
Protect-Router(config-controller)#shut
Protect-Router(config-controller)#aps group 1
Protect-Router(config-controller)#aps protect 1 12.2.1.2
Protect-Router(config-controller)#aps interchassis group 1
Protect-Router(config-controller)#no shutdown
Protect-Router(config-controller)#end

Removing Stateful MLPPP with MR-APS Inter-Chassis Redundancy

Complete these steps to remove Stateful MLPPP with MR-APS Inter-Chassis Redundancy implementation from the Working and Protect routers:

Summary Steps

1. enable

2. configure terminal

3. controller sonet slot | bay | port

4. shutdown

5. no aps interchassis group icrm-group-number

6. no aps group group_id

7. no aps [ working | protect ] aps-group-number [ ip_address_of_working ]

8. no shutdown

9. configure terminal

10. redundancy

11. no interchassis group group-id

12. end

DETAILED STEPS

 

Command
Purpose

Step 1

enable

 
Protect-Router>enable

Enables the privileged EXEC mode.

  • Enter your password if prompted.

Step 2

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 3

controller sonet slot/bay/port

 

Protect-Router(config)#controller SONET 1/2/0

Configures a SONET controller and enters the controller configuration mode.

slot/subslot/port—Specifies the location of the interface.

Step 4

shutdown

 

Protect-Router(config)#shutdown

Shuts down the SONET controller.

Step 5

no aps interchassis group icrm-group-number

 

 

Protect-Router(config-controller)#no aps interchassis group 1

Removes an APS group from an ICRM group number.

Step 6

no aps group group_id

 

 

Protect-Router(config-controller)#no aps group 1

Unconfigures the APS group for a SONET controller.

Step 7

no aps [working | protect] aps-group-number [ip_address_of_working]

 

 

Protect-Router(config-controller)#no aps working 1

Unconfigures the APS working or protect configuration.

Step 8

no shutdown

 

 

Protect-Router(config-controller)#no shutdown

 

Reverses the shutdown of an interface.

Step 9

end

 

Protect-Router(config-controller)#end

Ends the configuration session and returns to the EXEC mode.

Step 10

configure terminal

 

Protect-Router#configure terminal

Enters the global configuration mode.

Step 11

redundancy

 

Protect-Router(config)#redundancy

Enters the redundancy configuration mode.

Step 12

no interchassis group group-id

 

 

Protect-Router(config-red)#no interchassis group 1

Unconfigures an interchassis group within the redundancy configuration mode.

Step 13

end

 

Protect-Router(config-controller)#end

Ends the configuration session and returns to the EXEC mode.

Configuration Example

This example describes how to remove MR-APS Inter-Chassis Redundancy configuration from a router.

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#controller SONET 3/2/0
Router(config-controller)#shutdown
Router(config-controller)#no aps interchassis group 1
Router(config-controller)#no aps group 1
Router(config-controller)#no aps working 1
Router(config-controller)#no shutdown
Router(config-controller)#exit
Router(config)#redundancy
Router(config-red)#no interchassis group 1
Router(config-red)#end

 

Verification

Use these commands to verify Stateful MLPPP with MR-APS Inter-Chassis Redundancy implementation:

Command
Purpose

Protect-Router# show aps

SONET 3/2/0 APS Group 1: protect channel 0 (Inactive) (HA)

Working channel 1 at 60.60.60.1 (Enabled) (HA)

bidirectional, non-revertive

PGP timers (extended for HA): hello time=1; hold time=10

hello fail revert time=120

SONET framing; SONET APS signalling by default

Received K1K2: 0x00 0x05

No Request (Null)

Transmitted K1K2: 0x00 0x05

No Request (Null)

Remote APS configuration: (null)

Working-Router#show aps

SONET 1/2/0 APS Group 1: working channel 1 (Active) (HA)

Protect at 60.60.60.2

PGP timers (from protect): hello time=1; hold time=10

SONET framing

Remote APS configuration: (null)

Displays detailed information about the APS configuration. You can use this command on both the Protect and Working routers.

Protect-Router#show rgf group

 

Total RGF groups: 1

----------------------------------------------------------

STANDBY RGF GROUP

 

RGF Group ID : 1

RGF Peer Group ID: 0

ICRM Group ID : 1

APS Group ID : 1

 

RGF State information:

My State Present : Standby-hot

Previous : Standby-bulk

Peer State Present: Active-fast

Previous: Standby-cold

 

Misc:

Communication state Up

aps_bulk: 0

aps_stby: 0

peer_stby: 0

-> Driven Peer to [peer Standby Bulk] Progression

-> We sent Bulk Sync start Progression to Active

RGF GET BUF: 366 RGF RET BUF 366

Working-Router#show rgf group

 

Total RGF groups: 1

----------------------------------------------------------

ACTIVE RGF GROUP

 

RGF Group ID : 1

RGF Peer Group ID: 0

ICRM Group ID : 1

APS Group ID : 1

 

RGF State information:

My State Present : Active-fast

Previous : Standby-cold

Peer State Present: Standby-hot

Previous: Standby-bulk

 

Misc:

Communication state Up

aps_bulk: 0

aps_stby: 0

peer_stby: 0

-> Driven Peer to [Peer Standby Hot] Progression

-> Standby sent Bulk Sync start Progression

RGF GET BUF: 366 RGF RET BUF 366

Displays information about state of the router and the peer. If the value of My State Present is Standby-hot, the router is in standby state. If the value of My State Present is Active-fast, the router is in active state.

Troubleshooting Tips

Table 21-1 provides troubleshooting tips for the Stateful MLPPP with MR-APS Inter-Chassis Redundancy:

Table 21-1 Troubleshooting Stateful MLPPP with MR-APS Inter-Chassis Redundancy

Problem
Solution

Unable to configure APS.

Use the debug aps command on both the Working and Protect routers. You can use the debug aps command to debug these issues:

  • APS related issues
  • Configuration problem
  • Problem with APS state transition
  • Problem with APS events .