Cisco Service Control Application Reporter User Guide, Release 3.6.x
Working with Reports
Downloads: This chapterpdf (PDF - 847.0KB) The complete bookPDF (PDF - 4.38MB) | Feedback

Working with Reports

Table Of Contents

Working with Reports

Introduction

Report Actions

Filtering Report Templates and Instances

How to Filter Report Templates and Instances

How to Clear the Filter

Generating Reports

How to View Report Types that can be Generated in Asymmetric Routing Classification Mode

How to Generate a Report When a Report Instance is Selected

How to Generate Multiple Reports

Managing the Chart Items Hierarchy

How to Configure the Hierarchy Mode

Manipulating the Hierarchy

Viewing Reports

Adjusting the Chart Display

Configuring the Properties of a Chart Display

Changing the Appearance of the Chart

Changing the Chart Type

Modifying a Graphical Display

Changing Chart Colors

Zooming Items

Zooming In on a 2-Dimensional Chart

Dragging a Zoomed-In Chart

Zooming Out of a Chart

Zoom Reset

Managing the Chart Legend

Moving the Chart Legend

Hiding the Chart Legend

Managing Report Output

Printing Reports

Sending Reports by E-mail

Exporting Reports


Working with Reports


Revised: January 10, 2011, OL-21065-03

Introduction

After you have created and defined a report instance, you can generate reports from the report instance.

You can:

Display reports in chart or tabular form

Adjust the chart display

Export the chart display and the report data

Report Actions

Generating Reports

Viewing Reports

Adjusting the Chart Display

Exporting Reports

Report Actions

The views found on the SCA Reporter display menu items. Some commonly used actions have icons for easy navigation.

The actions and their icons are described in Table 5-1.

Table 5-1 Reporter Actions and Icons 

Action
Icon
Description
Comments

Home

210581.jpg

Opens the Welcome view.

Menu

210392.jpg

Displays all of the available actions for the view.

Common to all views.

View Filter

Filters display of template groups in the Templates view.

Display either all template groups or only groups that can be used when the service configuration that generated the data is running in asymmetric routing classification mode.

Debug

210983.jpg

Displays template code.

In the Templates view—Used to debug the structure of a report template.

Execute

210406.jpg

Generates the choose report.

In the Properties view, Templates view, and Favorites view.

New or Report (from Legend)

210388.jpg

Creates a new report instance.

In the Templates view—When you choose a report template, the icon is new.

In each report view—When you right-click a legend item, the Subset of Template Groups and Templates dialog box appears. Choose a template and click OK. The report instance is created (modified).

Refresh

210397.jpg

Collapses open nodes in the Templates view so that only the template groups are displayed.

In the Templates view and Favorites view.

Show Cmd

210404.jpg

Opens a window displaying the CLI command for the report instance.

In the Properties view, Templates view, and Favorites view —The CLI commands are placed on the clipboard. You can paste them into a vanilla text editor, edit them, and then execute them from a command file shell or a command prompt.

Delete

210389.jpg

Deletes the report instance.

In the Templates view and Favorites view.

Duplicate

210390.jpg

Creates a copy of the report instance.

In the Templates view.

Rename

158804.jpg

Highlights the report instance so that you can rename it.

In the Templates view and Favorites view.

Show Categories

210403.jpg

Toggles between displaying properties with and without categories.

In the Properties view.

Show Advanced Properties

210402.jpg

Toggles between displaying basic properties and displaying all properties.

In the Properties view.

Restore Default Value

210399.jpg

Restores property default value.

In the Properties view—Default values can be a value or (not set). Mandatory properties are not reset to (not set).

Go to report

Navigates from the choose report view to the associated report instance in the Templates view.

In each report view.

Export raw data

Opens a Browse dialog box.

In each report view.

Show List

210405.jpg

Lists generated reports that for which no report view is open.

Above the report views—To display a report, click the icon and choose from the report names in the drop-down list.

The number in the icon indicates how many reports are not in view.

Preferences

Opens a dialog box that allows you to choose whether to show system tasks or not.

Sleeping (waiting) tasks are shown in either case.

In the Progress view—The 210396.jpgicon is displayed while system tasks are running.

Remove All Finished Tasks

210398.jpg

Removes all completed tasks.

In the Progress view and Reports view.

Open Hierarchy View

Opens the Hierarchy view.

In the Templates view.

Add to Favorites

Adds the report instance to the Favorites view.

In the Templates view.

Remove From Favorites

Removes the report instance from the Favorites view.

In the Favorites view.

Export to PDF

Exports the report in view; including the table and chart, to PDF.

In the Reports view.

View Table with External Program

Exports the table in view to an external application associated with CSV file format.

In the Reports view.

Copy Chart Image to Clipboard

Copies the chart image in view to the clipboard.

In the Reports view.

Send by E-mail

Attaches the table or chart in view to an e-mail using your default e-mail application.

In the Reports view.

Print

Prints the table or chart in view.

In the Reports view.

Based on configured service tree

Configures the hierarchical tree according to the configured service tree.

In the Hierarchy view.

Based on service popularity

Configures the hierarchical tree according to service popularity.

In the Hierarchy view.

Reset Zoom

Resets the zoom on the report view

In the Reports view.


Filtering Report Templates and Instances

Report templates and instances can be filtered so that only specific templates and instances are displayed in the Templates view.

How to Filter Report Templates and Instances


Step 1 In the Templates view, enter a word, phrase, or more complex expression in the field.

The templates containing the text entered are displayed, see Figure 5-1.

Figure 5-1 Templates With Entered Text


How to Clear the Filter


Step 1 In the Templates view, click (Clear).

The filter is cleared and all templates and instances are displayed in the Templates view.


Generating Reports

You can generate a report from an existing, defined report instance. Report instances are found in the Templates view. You can duplicate, modify, rename, or delete the report instances and you can add report instances to the Favorites view (see Managing Report Instances, page 4-1). You can generate multiple reports; you can put the generate process in the background while working on other reports.

Some types of reports cannot be generated using data collected from an SCE platform running in asymmetric routing classification mode.


Note From SCA Reporter, if you launch reports that retrieve large number of records (around 800,000 and above), the processing might take a considerable amount of time. There might be a delay in launch of the reports and the system might appear to be halted. In rare instances, the console may close. To avoid such issues, use the time range for the report query.


You can define and generate reports using the SCA Reporter Command-Line Interface (CLI). You can also use the CLI to pre-schedule reports. (See The SCA Reporter Command-Line Interface, page 6-1.)

How to View Report Types that can be Generated in Asymmetric Routing Classification Mode

How to Generate a Report When a Report Instance is Selected

How to Generate Multiple Reports

How to View Report Types that can be Generated in Asymmetric Routing Classification Mode


Step 1 In the Templates view, from the drop-down menu, choose View Filter >Split-flow.

Template groups whose report instances cannot be executed for asymmetric routing classification mode data are hidden, see Figure 5-2.

Figure 5-2 Templates With Split Flow

211120.jpg


How to Generate a Report When a Report Instance is Selected


Step 1 In the Templates view, select a report instance.

The Properties view displays the report instance properties.

Step 2 Click 210406.jpg(Execute).

The report is generated and is displayed in a new report view.

The Properties view displays the chart display properties.


How to Generate Multiple Reports


Note The maximum number of reports that can be generated simultaneously is configurable. If you select more report instances than the maximum value, the generation of some of the reports are queued.



Step 1 From the Templates view window, while you hold down the CTRL key, choose the required report instances.

The selected report instances are highlighted.

Step 2 Click 210406.jpg(Execute).

A Executing report dialog box appears while reports are being generated, see Figure 5-3.

Figure 5-3 Progress Dialog

210014.jpg

Step 3 Select a further action to take.

Do one of the following:

Wait until the system task status at the bottom right corner of the SCA Reporter indicates that report generation is complete.

While the reports are being generated, the system task status shows:

210580.jpg

Click Details.

The status of all reports that are being generated is displayed, see Figure 5-4.

Figure 5-4 Report Status

210015.jpg

Click Run in Background.

Report generation continues running in the background. After it finishes, each report is displayed in a separate report view.

Click Cancel.

You can cancel a running report generation. It can take the Database Server a short time to acknowledge a cancel request, but you can move the cancelled report to the background and continue your work uninterrupted.


Managing the Chart Items Hierarchy

After reports are generated, the Hierarchy view displays a hierarchy of all the chart items included in the report.

There are two modes in which the tree structure can display the hierarchy:

Service popularity—Configures the hierarchy according to significance. The chart item creating the most significant traffic is first in the hierarchy and the chart item with the least significant traffic is last in the hierarchy.

Configured services tree—Configures the hierarchy according to the defined policy tree.


Note The Hierarchy availability depends on the report type. For example, pie charts have no hierarchy.


How to Configure the Hierarchy Mode


Step 1 Generate a report.

Step 2 To view the hierarchical tree in configured services tree mode, click (based on configured services tree).

The hierarchy is configured according to the service policy.

The chart is refreshed to reflect the hierarchy.

Step 3 To view the tree in service popularity mode, click (based on service popularity).

The hierarchy is configured according to traffic weights.

The chart is refreshed to reflect the hierarchy.


Manipulating the Hierarchy

After a report is generated, you can manipulate the chart items in the Hierarchy view in order to view a subset of the data included in the report. When the hierarchy is manipulated, the report is automatically refreshed to reflect the changes. You can perform the following actions:

Viewing only the parent chart items—You can contract the parent nodes so that the report displays only the parent chart items without identifying the specific children, see Figure 5-5.


Note When a parent node is contracted, the parent node value is an aggregation of all the values of its children nodes.


Figure 5-5 Report Displaying Only Parent Chart Items

Expanding the parent chart items—The parent nodes can be expanded in order to drill down and identify all the specific chart items included in the parent, see Figure 5-6.


Note In service tree based mode, if a parent chart item has a child that is not assigned a global usage counter, when the parent is expanded, both the parent and the child chart items appear on the chart.


Figure 5-6 Report Displaying Expand Parent Chart Items

Unchecking chart items—You can uncheck chart items in the hierarchy to remove them from the report, see Figure 5-7.

Figure 5-7 Removing Chart Items By Unchecking

Checking chart items—You can check chart items in the hierarchy to add them to the report.


Note When checking or unchecking a parent node, all the children mirror the parent. However, you can check or uncheck individual chart items to view in the report.


Viewing Reports

You can view a report as a chart or as a table.


Step 1 To select the desired display, click the appropriate tab located at the bottom-left of the report view, see Figure 5-8.

Figure 5-8 Report Chart

Select Report Display

The table is useful for locating specific information, see Figure 5-9.

Figure 5-9 Report Table

Report Table  Display


You can configure table contents and display properties:

Copying contents of a cell—To copy the contents of a cell in the table, right-click on the cell and choose Copy.

Sorting items in the table—To sort the table data in ascending or descending order, click on a column heading by which you want to sort the data.

Adjusting the Chart Display

You can change the appearance and type of any report chart by modifying chart display properties, such as three-dimensional display settings, chart rendering, and chart colors. You can also change the appearance of a report.

Drag the legend to a different spot in the report.

Hide the legend.

Hide items from the legend; the corresponding items in the graph will be removed from view.

Zoom in or out—Drag the graph so that the desired section is in focus.

Configuring the Properties of a Chart Display

Changing the Appearance of the Chart

Zooming Items

Managing the Chart Legend

Managing the Chart Legend

Configuring the Properties of a Chart Display

You configure chart display properties in the Properties view. As you make changes, the chart display is updated. There are also adjustments that are made directly in the report view (see Adjusting the Chart Display).


Note Changes to chart display properties are not saved in the report instance. When you next execute the report instance, the report is generated with default chart display properties.


Table 5-2 lists chart display properties and their descriptions:

Table 5-2 Chart Display Properties 

Property
Type
Default
Values
Comments

Look

3D

Boolean

True

True, False

Toggles between the two values.

Chart rendering

Single choice

Depends on report template

See list following this table

The chart can be displayed in many graphical formats.

Legend visibility

Boolean

True

True, False

Toggles between the two values.

Look/3D

Oblique

Boolean

True

True, False

Only displayed when 3D is True.

If True, there is always 90 degrees between the x and y axes when the chart is rotated.

Settings

Sliding scale

See table following this table

See table following this table

Only displayed when 3D is True.

Opens the 3D properties dialog box with sliding scales for eight graphical properties.


Table 5-3 shows possible values for the Chart Rendering property.

Table 5-4 lists the properties set in the 3D Properties dialog box and their possible values.

Table 5-3 Chart Display Types 

BAR

STACKED_BAR

STACKED100_BAR

SUPERIMPOSED_BAR

AREA

STACKED_AREA

STACKED100_AREA

POLYLINE

STACKED_POLYLINE

STACKED100_POLYLINE

SCATTER

STAIR

STACKED_STAIR

STACKED100_STAIR

SUMMED_STAIR

PIE


Table 5-4 3D Chart Properties 

Property
Values
Default

Rotation

-90 ... 90

35

Elevation

-90 ... 90

45

Depth

0 ... 100

20

Depth Gap

0 ... 100

0

Zoom

0 ... 200

100

Ambient Light

0 ... 100

10

Light Latitude

-90 ... 90

0

Light Longitude

-90 ... 90

0


Changing the Appearance of the Chart

You can change the chart type of the report, adjust the graphical display of the chart, and change the colors used in the chart.

Changing the Chart Type

Modifying a Graphical Display

Changing Chart Colors

Changing the Chart Type


Step 1 Generate a report. A Report view appears displaying the report, and the Properties view displays the chart display properties.

Step 2 In the Properties view, select the Chart Rendering row, and click the Browse button to open a drop-down list (Figure 5-10).

Figure 5-10 Properties Drop-Down Menu

Chart Rendering Dropdown Box

Step 3 From the drop-down list, choose the type of chart that you want to display.

When you click on another area in Properties view, the report updates.


Modifying a Graphical Display


Step 1 Generate a report. A report view appears displaying the report, and the Properties view window displays the chart display properties.

Step 2 To display the chart in two dimensions, click the 3D property.

The value of the 3D property toggles from True to False and the Look/3D category is removed from the Properties view window.

Step 3 Click the 3D property again.

The chart displays in three dimensions, and the Look/3D category reappears.

Step 4 Select the Settings property. The 3D properties dialog box appears, see Figure 5-11.

Figure 5-11 3D Properties

3D Properties Dialog Box

Step 5 Change the 3-dimensional properties using the sliding scales.

Step 6 The chart display changes as you change the properties.

Step 7 Click OK. The new values are assigned to the Settings property.


Changing Chart Colors

You can change the default color applied to a legend item in a chart. You may want to do this if, for instance, legend items that are adjacent in the chart have similar colors.


Note If legacy coloring is enabled (see the "Setting Chart Colors" section on page 2-16), this option is not available.



Note You can create and apply your own color sets globally. See the "Setting Chart Colors" section on page 2-16.



Step 1 Generate a report. A Report view appears, displaying the report.

Step 2 Right-click on an item in the legend. A popup menu appears, see Figure 5-12.

Figure 5-12 Report Legend Popup Menu

ChartPopupMenu.jpg

Step 3 From the menu, select either Edit Color (this chart only) or Edit Entity Color. The former option changes the color temporarily for this chart only, the latter makes the change persistent for all current and future charts. A color palette appears, see Figure 5-13.

Figure 5-13 Color Palette

Color.jpg

Step 4 Choose a new color from the palette.

Step 5 Close the palette. The new color is applied in the chart to the selected variable.

If you chose Edit Entity Color at Step 3, the new color is applied to all open charts, except those using temporary colors.


Zooming Items

Zooming In on a 2-Dimensional Chart

Dragging a Zoomed-In Chart

Zooming Out of a Chart

Zooming In on a 2-Dimensional Chart

You can zoom in or out of two-dimensional charts.

While you are zoomed-in, you can drag the chart to view different sections.


Step 1 Generate a Report. A report view appears displaying the report, and the Properties view displays the chart display properties.

Step 2 To display the chart in two dimensions, click the 3D property.

The value of the 3D property toggles from True to False and the Look/3D category is removed from the Properties view.

Step 3 Mark off a rectangle by dragging the mouse over the chart.

The cursor changes to a plus icon.

Step 4 Release the mouse button, and the view zooms in.


Dragging a Zoomed-In Chart


Step 1 Generate a Report and display the chart in two dimensions.

Step 2 Zoom in to the top part of the chart.

Step 3 To move the chart down, click it with the middle mouse button, while dragging the chart.

The chart moves up, and the bottom of the chart appears.


Zooming Out of a Chart


Step 1 Mark off a rectangle by right-clicking it while dragging the mouse over the chart.

The cursor changes to a minus icon.

Step 2 Release the mouse button, and the view zooms out.


Zoom Reset


Step 1 In the report view, click (Reset Zoom).

The report view is reset to its original settings.


Managing the Chart Legend

You can move the chart legend from its default position, or you can remove it from the chart display.


Note You can also globally configure how the legend is displayed. See the "Configuring the Legend in Charts" section on page 2-21.


Moving the Chart Legend

Hiding the Chart Legend

Moving the Chart Legend


Step 1 Generate a report.

A Report view appears displaying the report.

Step 2 Right-click the legend of the chart and drag it to the required position.

The legend moves to the new position.


Hiding the Chart Legend


Step 1 Generate a report.

The Properties view displays the chart display properties.

Step 2 To hide the chart legend, click the Legend visibility property.

The value of the Legend visibility property toggles from True to False and the chart legend is removed from the chart.


Managing Report Output

You can manage report output in several ways:

Print, send by e-mail, or export reports to PDF format.

Save charts to a number of graphic formats.

Save tables to CSV or Quoted CSV formats, which you can open as spreadsheets.

Print, send, or export multiple reports in one send operation.

Printing Reports


Step 1 After executing one or more report instances, choose File > Print Reports.

The Print Reports wizard appears, see Figure 5-14.

Figure 5-14 Print Reports Wizard

Step 2 Choose one or more formats for each report you are printing.

Step 3 Click Finish.

The selected reports print in the format or formats you chose.


Note For PDF and CSV formats, the print feature uses the desktop interface and only prints if the associated application can print from the desktop. If you can print from the desktop without opening the application, the print feature will work.



Note If you selected several reports to print, the application may freeze for several moments while sending the reports to the printer.



Sending Reports by E-mail


Step 1 After executing one or more report instances, select File > Send Reports.

The Send Reports wizard appears, see Figure 5-15.

Figure 5-15 Send Reports Wizard

Step 2 Choose one or more formats for each report you are sending.

Step 3 Click Finish.

An e-mail message appears from the default e-mail application installed on the desktop, with the selected reports attached.


Exporting Reports


Step 1 After executing one or more report instances, select File >Export.

The Export wizard appears, see Figure 5-16.

Figure 5-16 Export Wizard

Export Report Selection

Step 2 Choose one of the following:

Export chart to an image file

Export report to a PDF file

Export table to a CSV file

Step 3 Click Next.

The Tables and Destination page of the Export wizard appears, see Figure 5-17.

Figure 5-17 Charts and Destination

Export Report Tables and Destinations Screen

Step 4 Check one or more of the Available reports.

Step 5 (Optional) To change the Output folder, click Browse.

Step 6 Do one of the following:

If you chose Report in Step 2 continue with Step 8.

If you chose Chart, or Table in Step 2, click Next.

The Format page of the Export wizard appears (Figure 5-18 or Figure 5-19). (The display depends on whether you chose Chart or Table in Step 2.)

Step 7 Enter required information.

Do one of the following:

(For Chart)

Figure 5-18 Chart Format

Export Report Chart Format

From the File type drop-down list, choose a file type.

In the Image width and Image height fields, enter values in pixels.

(For Table)

Figure 5-19 Table Format

Export Report Table Format

From the File type drop-down list, choose a file type.

Step 8 Click Finish.

Each report selected is saved in a separate file.