Guest

Cisco 2500 Series Wireless Controllers

Cisco 2500 Series Wireless Controller Deployment Guide

Document ID: 113034

Updated: Jun 23, 2011

   Print

Introduction

This document serves as a deployment guide for the Cisco 2500 Series Wireless Controller. Cisco 2500 Series Wireless Controller is a cost-effective systems-wide wireless solution for retail, enterprise branches, and small and medium-sized businesses. The controller can scale in a network as the network grows and is feature compatible with its predecessor, Cisco 2100 Series Wireless Controller.

The Cisco 2500 Series Wireless Controller blends into the Cisco Unified Wireless Network (CUWN) and works with both Cisco lightweight access points (APs) and the Cisco Wireless Control System (WCS) to provide system-wide wireless LAN functions. The Cisco 2500 Series Wireless Controller provides real-time communication between wireless APs and other devices to deliver centralized security policies, guest access, wireless intrusion prevention system (wIPS), context-aware (location), RF management, and quality of services (QoS) for mobility services such as voice and video, and OEAP support for the teleworker solution.

Cisco 2500 Series Wireless Controller support a maximum of 50 lightweight APs in increments of 5 APs with a minimum of 5 APs, making it a cost-effective solution for retail and small and medium-sized businesses. The Cisco 2500 Series Wireless Controller offers robust coverage with 802.11 a/b/g or delivers unprecedented reliability using 802.11n and Cisco Next-Generation Wireless Solutions and Cisco Enterprise Wireless Mesh.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on the Cisco 2500 Series Wireless Controller.

Hardware Specifications

  • Data Ports – 4 x 1 Gigabit Ethernet Ports

  • Console Port – 1 x RJ45

  • External 48V Power Supply

Software Specifications

  • Feature parity with Cisco 2100 Series Wireless Controllers

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Additional Features

  • Support for Control and Provisioning of Wireless Access Points (CAPWAP) protocol

  • Encryption on CAPWAP Data Tunnel (DTLS) (optional)

  • License-based AP count. AP Counts - 50 (in steps of 5, 25, 50)

  • Supported Client Count - 500 (In all STATE)

  • Supported Tag Count - 500

  • Triple Play Ready - Supports Data, Voice and Video

2500-deploy-guide-01.gif

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Hardware Architecture of Cisco 2500 Series Wireless Controller

These sections provide a greater insight into the architecture of the new Cisco 2500 Series Wireless Controller.

The Cisco 2500 Series Wireless Controller physically has the same form factor as the Cisco 2106 controller. The CPU on a Cisco 2500 Series Wireless Controller is a multi-core CPU and can handle both data plane and wireless data traffic. The CPU can handle control plane application, which handles all the management traffic needed to “control” a wireless network.

The Cisco 2500 Series Wireless Controller has 1 GB system memory. Two types of memory devices are supported in order to store software images. The boot flash contains the boot code, and the compact flash contains the application code that can store multiple images. The front panel houses four Gigabit Ethernet ports. Two of the ports are 802.3af capable. All ports will transfer the traffic to/from the wireless network. The Power over Ethernet (PoE) ports on the Cisco 2500 Series Wireless Controller will not support directly attached APs.

The Cisco 2500 Series Wireless Controller is powered by an external 48VDC power brick. The power brick can handle power input from 110VAC to 240VAC.

2500-deploy-guide-02.gif

Basic Configuration of the Cisco 2500 Series Wireless Controller

These tools and information are needed before you can install the controller:

  • Wireless Controller hardware:

    • Controller with factory-supplied power cord and mounting hardware

    • Network, operating system service network, and AP cables as required for the command-line interface (CLI) console

    • VT-100 terminal emulator on the CLI console (PC, laptop, or palmtop)

    • Null modem serial cable to connect the CLI console and controller

  • Local TFTP server (required for downloading operating system software updates). Cisco uses an integral TFTP server. This means that third-party TFTP servers cannot run on the same workstation as the Cisco WCS because Cisco WCS and third-party TFTP servers use the same communication port.

If the controller is brought up for the first time with no prior configuration, it automatically enters into a wizard, which will ask you a series of configuration information. The wizard first will first prompt for user ID and password. This wizard cannot be bypassed and you must enter all the information it asks.

caution Caution: Do not connect a PoE cable to the console port. Doing so will damage the controller.

Controller Configuration through CLI

Before you can configure the controller for basic operations, you need to connect it to a PC that uses a VT-100 terminal emulator (such as HyperTerminal, ProComm, Minicom, or Tip). Complete these steps in order to connect the PC to the controller's console port:

  1. Plug the RJ-45 connector on a null-modem serial cable into the controller's console port and the other end of the cable into the PC's serial port.

  2. Start the PC's terminal emulation program.

  3. Configure the terminal emulation program for these parameters:

    • 9600 baud

    • 8 data bits

    • No flow control

    • 1 stop bit

    • No parity

Cisco 2500 Series Wireless Controller has 4 Gigabit Ethernet ports. Each port is, by default, an 802.1Q VLAN trunk port. The VLAN trunking characteristics of the port are not configurable.

An interface is a logical entity on the controller. An interface has multiple parameters associated with it, including IP address, default-gateway (for the IP subnet), primary physical port, secondary physical port, VLAN tag, and DHCP server. Since LAG is not used, each interface is mapped to at least one primary physical port and an optional secondary port. Multiple interfaces can be mapped to a single Wireless Controller port.

There are multiple types of interfaces on the Wireless Controller, four of which are static types that must be present and are configured at setup time:

  • Management interface (static and configured at setup time; mandatory)

  • AP-manager interface – Not required for the Cisco 2500 Series Wireless Controller

  • Virtual interface (static and configured at setup time; mandatory)

  • Dynamic interface (user-defined)

The management interface is the default interface for in-band management of the controller and connectivity to enterprise services such as AAA servers. The management interface is also used for communications between the controller and APs. The management Interface is the only consistently "pingable" in-band interface IP address on the controller. The management interface will act like an AP manager interface by default.

The dynamic interface with the “Dynamic AP Management” option enabled on it is used as the tunnel source for packets from the controller to the AP, and as the destination for CAPWAP packets from the AP to the controller. The dynamic interfaces for AP manager must have a unique IP address. Typically, this is configured on the same subnet as the management interface, but this is not necessarily a requirement. In the case of the Cisco 2500 Series Wireless Controller, a single dynamic AP manager can support any number of APs. However, as a best practice, it is suggested to have 4 separate dynamic AP manager interfaces and associate them to the 4 Gigabit interfaces. By default, the management interface acts like an AP-manager interface as well and it is associated to one Gigabit interface. As a result, if you are using the management interface, you need to create only 3 more dynamic AP manager interfaces and associate them to the remaining 3 Gigabit interfaces.

The virtual interface is used to support mobility management, DHCP relay, and embedded layer 3 security like guest web authentication and VPN termination. The virtual interface must be configured with an unassigned and unused gateway IP address. A typical virtual interface is 1.1.1.1. The virtual interface address is not pingable and should not exist in any routing table in your network.

Dynamic interfaces are created by users and are designed to be analogous to VLANs for wireless LAN client device. The Cisco 2500 Series Wireless Controller will support up to 16 dynamic interfaces. Dynamic interfaces must be configured on a unique IP network and VLAN. Each dynamic interface acts as a DHCP relay for wireless clients associated to wireless LANs (WLANs) mapped to the interface. A WLAN associates an SSID to an interface and is configured with security, QoS, radio policies, and other wireless network parameters. There can be up to 16 WLANs configured per controller.

Note: Link Aggregation (LAG) is not supported on the Cisco 2500 Series Wireless Controller.

Configure the Neighbor Switch

By default, all four ports on the Cisco 2500 Series Wireless Controller are 802.1Q trunk ports. The controller is always connected to a Gigabit Ethernet port on the neighboring switch. The neighbor switch port is configured as an 802.1Q trunk and only the appropriate VLANs are allowed on the trunk. All other VLANs are pruned. This is not necessary, but is a deployment best practice because by pruning irrelevant VLANs, the controller only processes relevant frames, optimizing performance.

This is the 802.1Q switchport configuration:

switchport 
switchport trunk encapsulation dot1q 
switchport trunk native vlan X
switchport trunk allowed vlan X
switchport mode trunk
end

Configure the Cisco 2500 Series Wireless Controller

Configure the Controller Using the Startup Wizard

(Cisco Controller)
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup

Would you like to terminate autoinstall? [yes]: yes
AUTO-INSTALL: process terminated -- no configuration loaded
System Name [Cisco_d9:24:44] (31 characters max): Szabla
Enter Administrative User Name (24 characters max): cisco
Enter Administrative Password (3 to 24 characters): ********
Re-enter Administrative Password                 : ********
Management Interface IP Address: 10.10.10.20
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 10.10.10.1
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1 to 4]: 1
Management Interface DHCP Server IP Address: 10.10.10.1

Virtual Gateway IP Address: 1.1.1.1
Mobility/RF Group Name: Jmobile

Network Name (SSID): Szabla
Configure DHCP Bridging Mode [yes][NO]: no
Allow Static IP Addresses [YES][no]: no

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter Country Code list (enter 'help' for a list of countries) [US]: US

Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes
Enable Auto-RF [YES][no]: yes

Configure a NTP server now? [YES][no]: no
Configure the system time now? [YES][no]: yes
Enter the date in MM/DD/YY format: 04/14/11
Enter the time in HH:MM:SS format: 15:52:20
Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

Configuration saved!
Resetting system with new configuration...
Restarting system.

Note: The above configuration is an example. It may differ from one install to another.

(Cisco Controller) >show sysinfo 
Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 7.0.116.0
Bootloader Version............................... 1.0.11
Field Recovery Image Version..................... 1.0.0
Firmware Version................................. PIC 14.0

Build Type....................................... DATA + WPS

System Name...................................... Szabla
System Location.................................. SJC14-Area51
System Contact................................... TME-admin
System ObjectID.................................. 1.3.6.1.4.1.9.1.1279
IP Address....................................... 10.10.10.20
Last Reset....................................... Software reset
System Up Time................................... 0 days 2 hrs 34 mins 29 secs
System Timezone Location......................... (GMT -8:00) Pacific Time (US
    and Canada)
Current Boot License Level....................... base
Current Boot License Type........................ Default. No valid license
    found.
Next Boot License Level.......................... base
Next Boot License Type........................... Default. No valid license
    found.

Configured Country............................... US - United States
Operating Environment............................ Commercial (0 to 40 C)
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +33 C
External Temperature............................. +35 C
Fan Status....................................... 3168 rpm

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 2
Number of Active Clients......................... 0
Burned-in MAC Address............................ 00:22:BD:D9:24:E0
Maximum number of APs supported.................. 50
(Cisco Controller) >

License Installation

The Cisco 2500 Series Wireless Controller does not have any licenses installed. Without any installed licenses, the APs will not be able to join the controller. It is recommended to install appropriate licenses on the Cisco 2500 Series Wireless Controller in order to work with the controller going forward. The Cisco 2500 Series Wireless Controller is shipped with an evaluation license for a period of 60 days (that is, 8 weeks 4 days). The evaluation license is a base license only.

The ordered license can be installed on the controller using either the CLI or the GUI. The license installed can be checked through both the CLI and the GUI. In both cases, there should be a TFTP server hosting the license files.

(Cisco Controller) >license install ?
<url>          tftp://<server ip>/<path>/<filename>
(Cisco Controller)

2500-deploy-guide-03.gif

The show license all command displays the installed licenses.

Note:  This license includes a data DTLS functionality.

(Cisco Controller) >show license all
(Cisco Controller) >show license all
License Store: Primary License Storage
StoreIndex:  2  Feature: base-ap-count   Version: 1.0
        License Type: Permanent
        License State: Active, In Use
        License Count: 50/50/0
        License Priority: Medium
StoreIndex:  3  Feature: data encryption   Version: 1.0
        License Type: Permanent
        License State: Active, In Use
        License Count: Non-Counted
        License Priority: Medium
License Store: Evaluation License Storage
StoreIndex:  0  Feature: base   Version: 1.0
        License Type: Evaluation
        License State: Active, Not in Use, EULA accepted
            Evaluation total period:  8 weeks  4 days
            Evaluation period left:  8 weeks  4 days
        License Count: Non-Counted
        License Priority: Low
StoreIndex:  1  Feature: base-ap-count   Version: 1.0
        License Type: Evaluation
        License State: Inactive
            Evaluation total period:  8 weeks  4 days
            Evaluation period left:  8 weeks  4 days
        License Count: 50/0/0
        License Priority: None
(Cisco Controller) >

Enable DTLS in the Cisco 2500 Series Controller

In order to enable DTLS on an AP or particularly on a group of APs, make sure that you have Data Encryption License installed in the controller. DTLS (Data Encryption) can be enabled on a per AP basis from the Advanced tab once you select the AP details.

Choose an AP, go to the Advanced tab, and choose the Data Encryption option.

2500-deploy-guide-04.gif

(Cisco Controller) >config ap link-encryption enable ? 
<Cisco AP> Enter the name of the Cisco AP. all Apply the configuration for 
    all capable Cisco AP 
(Cisco Controller) >config ap link-encryption enable J-3502E
(Cisco Controller) >show ap link-encryption all
                  Encryption  Dnstream  Upstream    Last
AP Name           State       Count     Count       Update
--------------    ---         --------  --------    ------
J-3502E           En           102  	    747 	      22:12
J-1262            Dis          0         0          22:12
J-1040            Dis          0         0          22:13
J-1140            Dis          0         0          22:10
 
(Cisco Controller) >show dtls connections 

AP Name      Local Port    Peer IP       Peer Port  Ciphersuite 
------------ ------------- ------------- ---------- ------------------ 
J-3502E      Capwap_Ctrl   10.10.10.116  41066      TLS_RSA_WITH_AES_128_CBC_SHA
J-3502E      Capwap_Data   10.10.10.116  41066      TLS_RSA_WITH_AES_128_CBC_SHA
J-1262       Capwap_Ctrl   10.10.10.120  45543      TLS_RSA_WITH_AES_128_CBC_SHA
J-1040       Capwap_Ctrl   10.10.10.122  65274      TLS_RSA_WITH_AES_128_CBC_SHA
J-1140       Capwap_Ctrl   10.10.10.123  4825       TLS_RSA_WITH_AES_128_CBC_SHA

(Cisco Controller) >

Configure the WCS and Add the Cisco 2500 Series Wireless Controller

WCS is the management software used to manage Cisco 2500 Series Wireless Controller and provide advanced management tools like wireless coverage display and location-based services. WCS uses SNMP to manage wireless controllers, access points, client devices. The Cisco 2500 Series Wireless Controller devices need to have SNMP configured correctly. Cisco 2500 Series Wireless Controller can be managed with WCS version 7.0.172.0 and later.

Complete these steps:

  1. Log in to the WCS web interface using the URL https://<wcs-ip-address>.

  2. SNMPv2 is configured on the Cisco 2500 Series Wireless Controller. In order to configure SNMPv2 through the Controller web interface, go to Management > SNMP > Communities. The Cisco 2500 Series Wireless Controller defaults are Read-Only community public and Read-Write community private. Add new communities or modify as necessary. For simplicity, the defaults are used.

    2500-deploy-guide-05.gif

  3. In the WCS Interface, go to Configure > Controllers on the WCS interface. Choose Add Controller from the drop-down box on the right-hand side, and click Go.

  4. Enter the IP Address of the Cisco 2500 Series Wireless Controller management interface, and configure the appropriate SNMP parameters. Click OK.

    2500-deploy-guide-06.gif

    The controller is added successfully, and the Cisco 2500 Series Wireless Controller is ready to be provisioned by the WCS.

In order to verify the Cisco 2500 Series Wireless Controller after it is added in WCS, go to Monitor > Controllers to see the controller details.

Cisco 2500 Series Wireless Controller Deployment Scenarios

Cisco 2500 Series Wireless Controller provides a cost effective unified wireless solution. Although the controller has multiple 10/100/1000 ports, it does not behave like switches or routers. It is not recommended to use different ports as a hub/switch implementation. Understanding this fundamental point is a key aspect of getting the best performance out of the controller.

Cisco 2500 Series Wireless Controller support multiple uplink ports where management and dynamic interfaces can be configured on different physical ports, and data traffic can switch back and forth infra network from respective physical ports.

Cisco 2500 Series Wireless Controller also support multiple AP-managers (for AP Load Balancing) where multiple AP-managers can be configured in addition to an AP-manager which is bounded with a management interface. In this case, it is recommended to have all AP-managers in the same subnet as a management interface.

<CISCO2504> >show interface summary

Interface Name        Port Vlan Id  IP Address     Type    Ap Mgr Guest
--------------------- ---- -------- -------------- ------- ------ -----
apmgr2                2    10       10.10.10.12    Dynamic Yes    No
apmgr3                3    10       10.10.10.13    Dynamic Yes    No
apmgr4                4    10       10.10.10.14    Dynamic Yes    No
management            1    10       10.10.10.10    Static  Yes    No
virtual               N/A  N/A      1.1.1.1        Static  No     No

<CISCO2504> >

2500-deploy-guide-07.gif

In the above output, the management interface and AP-manager are bounded together to port 1. Three more AP-managers are created on other physical ports (2, 3, and 4) in the same subnet as management interfaces.

APs joining the controller will load balanced such that each port on the controller will share the load of the 50 APs. Each port in the above configuration will allow 13 APs to join the controller.

It is also possible to have multiple AP-managers in a different subnet than the management interface. However, in this case, it is recommended that you disable the AP-manager from the management interface and create another AP-manager interface on different physical ports in a different subnet than the management interface. All multiple AP-managers in this scenario should be in the same subnet.

<CISCO2504> >show interface summary

Interface Name        Port Vlan Id  IP Address     Type    Ap Mgr Guest
--------------------- ---- -------- -------------- ------- ------ -----
apmgr2                2    11       10.10.11.12    Dynamic Yes    No
apmgr3                3    11       10.10.11.13    Dynamic Yes    No
apmgr4                4    11       10.10.11.14    Dynamic Yes    No
management            1    10       10.10.10.10    Static  No     No
virtual               N/A  N/A      1.1.1.1        Static  No     No

<CISCO2504> >

2500-deploy-guide-08.gif

In above output, management and AP-manager are not bounded. In this scenario, multiple AP-managers can be created in a different subnet from the management interface and mapped to different physical ports.

Note: Internal DHCP server will only work (for wireless clients) with DHCP proxy enabled.

Some of the scenarios supported by the Cisco 2500 Series Wireless Controller are described here with sample configurations.

Scenario 1

Management interface with embedded AP-Manager is configured on Port 1. Two WLANs are configured on the controller. WLAN 1 and WLAN 2 are mapped to the management interface.

A simple topology has the Cisco 2500 Series Wireless Controller connected to a Catalyst 3560 switch. Gigabit Ethernet port 1 on the controller is connected to Gigabit Ethernet port 1/0/1 on the switch.

2500-deploy-guide-09.gif

2500-deploy-guide-10.gif

Switch#sh run int gig 1/0/1
Building configuration...

Current configuration : 123 bytes
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree portfast
end

Switch#

The management interface configuration on the Cisco 2500 Series Wireless Controller is straight forward, and has dynamic AP management enabled.

2500-deploy-guide-11.gif

Two WLANs are configured. WLAN1 and WLAN2 are mapped to the management interface and are servicing clients.

<CISCO2504> >show wlan summ

Number of WLANs.................................. 2

WLAN ID  WLAN Profile Name / SSID               Status    Interface Name
-------  -------------------------------------  --------  --------------------
1        WLAN1 / WLAN1                          Enabled   management
2        WLAN2 / WLAN2                          Enabled   management

<CISCO2504> >

Internal DHCP Server with DHCP Proxy Enabled

The DHCP server TestVlan10 is configured on the controller and this scope will service APs and clients. The DHCP server configuration on the controller is simple.

<CISCO2504> >show dhcp summary

  Scope Name                   Enabled          Address Range
TestVlan10                       Yes      10.10.10.100 -> 10.10.10.200


<CISCO2504> >show dhcp detailed TestVlan10
Scope: TestVlan10

Enabled................................... Yes
Lease Time................................ 36400 <10 hours 6 minutes 40 seconds>
Pool Start................................ 10.10.10.100
Pool End.................................. 10.10.10.200
Network................................... 10.10.10.0
Netmask................................... 255.255.255.0
Default Routers........................... 10.10.10.10  0.0.0.0  0.0.0.0
DNS Domain................................
DNS....................................... 0.0.0.0  0.0.0.0  0.0.0.0
Netbios Name Servers...................... 0.0.0.0  0.0.0.0  0.0.0.0

<CISCO2504> >

This is the DHCP configuration capture using the GUI from the Cisco 2500 Series Wireless Controller:

2500-deploy-guide-12.gif

The DHCP Proxy is enabled on all Cisco controllers by default.

2500-deploy-guide-13.gif

In the all of the above configuration, VLAN10 is not tagged on the switch. All traffic from the switch is sourced to Port 1 on the controller. APs and client traffic is forwarded to the controller untagged.

APs are connected to the Catalyst switch with these switchport configurations. The switchport can either be trunked or configured to be an access port.

Switch#sh run int gig 1/0/9
Building configuration...

Current configuration : 132 bytes
!
interface GigabitEthernet1/0/9
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
end

Switch#sh run int gig 1/0/10
Building configuration...

Current configuration : 66 bytes
!
interface GigabitEthernet1/0/10
 switchport access vlan 10
end

Switch#

The AP can join the controller and the status of the AP can be verified on the controller. There are two APs that have joined the controller and can be confirmed by checking the status in this capture:

<CISCO2504> >show ap join stats summary all

Number of APs.............................................. 2

Base Mac           AP EthernetMac     AP Name            IP Address       Status
00:22:90:96:69:00  00:22:90:90:ab:d3  AP0022.9090.abd3   10.10.10.103     Joined
ec:44:76:b9:7d:c0  c4:7d:4f:3a:e3:78  APc47d.4f3a.e378   10.10.10.105     Joined


<CISCO2504> >show ap summary

Number of APs.................................... 2

Global AP User Name.............................. Not Configured
Global AP Dot1x User Name........................ Not Configured

AP Name          Slots AP Model          Ethernet MAC      Location         
---------------- ----- ----------------- ----------------- ---------------- 
AP0022.9090.abd3  2    AIR-LAP1142N-A-K9 00:22:90:90:ab:d3 default location 
APc47d.4f3a.e378  2    AIR-CAP3502E-A-K9 c4:7d:4f:3a:e3:78 default location 

Port Country Priority
---- ------- ------
1       US      1
1       US      1

The APs that have joined the controller can also be verified by verifying the AP’s summary on the controller. Configure both the AP name and the Location of the AP install.

2500-deploy-guide-14.gif

Prime the AP by configuring the controller name and IP address under High Availability.

2500-deploy-guide-15.gif

With this configuration, the AP will join the configured controller as the first preference.

External DHCP Server with DHCP Proxy Disabled

This is a general setup that has been in practice for all Cisco controllers for some deployments. The configurations are almost the same as noted in the previous, but will have the DHCP Proxy disabled.

2500-deploy-guide-16.gif

The AP-manager interfaces in this scenario point to an external DHCP server.

Note: It is recommended to enable either an internal DHCP server or an external DHCP server.

ip dhcp excluded-address 10.10.11.1 10.10.11.150
!
ip dhcp pool VLAN11
   network 10.10.11.0 255.255.255.0
   default-router 10.10.11.1
!

External DHCP Server with DHCP Proxy Enabled

This is a general setup that is one of the best practices for all Cisco controllers. The configurations are almost the same as noted in the previous with DHCP Proxy enabled.

2500-deploy-guide-17.gif

The management interface in this scenario is always directed to an external DHCP server.

ip dhcp excluded-address 10.10.11.1 10.10.11.150
!
ip dhcp pool VLAN11
   network 10.10.11.0 255.255.255.0
   default-router 10.10.11.1
!

Scenario 2

The management interface with AP-manager enabled is mapped to port 1. Dynamic interface dynamic11 is mapped to another physical interface (port 2) for data traffic. WLAN 1 is mapped to the management interface, and WLAN 2 is mapped to the dynamic interface.

2500-deploy-guide-18.gif

2500-deploy-guide-19.gif

One more DHCP scope is configured on the controller. This configured DHCP Scope TestVlan11 is mapped to the dynamic-interface configured on the controller.

<CISCO2504> >show dhcp summary

  Scope Name                   Enabled          Address Range
TestVlan10                       Yes      10.10.10.100 -> 10.10.10.200
TestVlan11                       Yes      10.10.11.100 -> 10.10.11.200


<CISCO2504> >show dhcp detailed TestVlan11
Scope: TestVlan10

Enabled................................... Yes
Lease Time................................ 36400 <10 hours 6 minutes 40 seconds>
Pool Start................................ 10.10.11.100
Pool End.................................. 10.10.11.200
Network................................... 10.10.11.0
Netmask................................... 255.255.255.0
Default Routers........................... 10.10.11.10  0.0.0.0  0.0.0.0
DNS Domain................................
DNS....................................... 0.0.0.0  0.0.0.0  0.0.0.0
Netbios Name Servers...................... 0.0.0.0  0.0.0.0  0.0.0.0

<CISCO2504> >

Internal DHCP Server with DHCP Proxy Enabled

By default, the DHCP Proxy is enabled on the controller as seen in one of the previous captures. Dynamic interface dynamic11 is configured and is mapped to VLAN11. The interface is also mapped to the configured internal DHCP server. The dynamic interface is not enabled for dynamic AP management.

2500-deploy-guide-20.gif

One of the configured WLANs is mapped to the management interface and the second WLAN is mapped to the configured dynamic interface dynamic11. The primary DHCP server is a necessity for configuration in this scenario, but should be pointed to the management interface.

2500-deploy-guide-21.gif

External DHCP Server with DHCP Proxy Disabled

2500-deploy-guide-22.gif

Clients will successfully get IP addresses from the configured external DHCP server. Verify the status of the internal DHCP server and make sure that the internal DHCP server is disabled.

2500-deploy-guide-23.gif

External DHCP Server with DHCP Proxy Enabled

2500-deploy-guide-24.gif

Clients will successfully get IP addresses from the configured external DHCP server.

Scenario 3

The management interface with AP-manager enabled is mapped to port 1. Port 2 is configured to be a backport. WLAN 1 is mapped to the management interface.

2500-deploy-guide-25.gif

2500-deploy-guide-26.gif

In this scenario the management and dynamic interfaces are configured on Port 1 with either the internal DHCP server or the external DHCP server. Ports 1 and 2 are connected to 2 different switches. This provides redundancy to the Layer 2 and Layer 3 switch network as shown in this topology and interface captures.

2500-deploy-guide-27.gif

These are just a few designs implemented by users to leverage the wireless service to their client devices using CUWN.

Guidelines for Deploying the Cisco 2500 Wireless Controller

Ethernet ports on Cisco 2500 Series Wireless Controllers do not work as Switch ports (that is, 2 machines directly connected to these ports will not be able to communicate with each other). You should not connect servers like DHCP, TFTP etc. on these ports and expect Wireless Clients and APs to receive an IP address from this DHCP server.

Ethernet ports on the Cisco 2500 Series Wireless Controller should only be used to connect/uplink to an infrastructure network configured as a data interface (management interface and dynamic interfaces) or an AP-managers interface.

If multiple Ethernet ports on a Cisco 2500 Series Wireless Controller are uplinked to an infrastructure switch, you should make sure data interfaces (management or dynamic interfaces) or AP-managers interfaces are configured for these uplinked physical ports. Physical Ethernet ports which are used as an uplink to an infra switch should not be left un-configured. This may result in unexpected behaviors.

Multicast unicast is not a supported configuration on Cisco 2500 Series Wireless Controller. As a result, HREAP APs are not able to receive multicast traffic because HREAP APs only work with multicast unicast.

Related Information

Updated: Jun 23, 2011
Document ID: 113034