Guest

Voice Quality

VoIP over PPP Links with Quality of Service (LLQ / IP RTP Priority, LFI, cRTP)

Cisco - VoIP over PPP Links with Quality of Service (LLQ / IP RTP Priority, LFI, cRTP)

Document ID: 7111

Updated: Feb 02, 2006

   Print

Introduction

This sample configuration studies a VoIP with Point to Point Protocol (PPP) over low bandwidth leased line configuration. This document includes background technical information on the configured features, design guidelines, and basic verification and troubleshooting strategies.

Note: It is important to note that in the configuration below, the two routers are connected back-to-back over a leased line. In most topologies, however, the voice enabled routers can exist anywhere. Usually, the voice routers use LAN connectivity to other routers which are connected to the WAN (in other words, a PPP leased line). This is important because if your voice routers are not directly connected via PPP over a leased line, all WAN configuration commands must be configured on those routers connected to the WAN, and not on the voice routers, as shown in the configurations below.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The configurations presented in this document were tested with this equipment:

  • Two Cisco 3640s with Cisco IOS® Software Release 12.2.6a (IP Plus)

  • IP RTP Priority was introduced in Cisco IOS Release 12.0(5)T.

  • LLQ was introduced in Cisco IOS Release 12.0(7)T.

  • LFI was introduced in Cisco IOS Release 11.3.

  • Cisco IOS releases beyond 12.0.5T contain significant performance improvements for cRTP.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

QoS Design Guidelines for VoIP Over PPP Links

This section provides design guidelines to configure VoIP over PPP leased lines (with an emphasis on low-speed links). There are two basic requirements for good voice quality:

To guarantee the above requirements, there are several important guidelines that should be followed:

Guideline Description
Strict Priority for Voice Traffic (IP RTP Priority or LLQ) Method to provide strict priority for voice traffic.
Link Fragmentation and Interleaving (LFI) May be a mandatory requirement for low-speed links.
RTP Compression Not required to provide good voice quality, but reduces call bandwidth consumption. The general advice regarding RTP compression is to apply it after having a working configuration with good voice quality (simplifies troubleshooting).
Call Admission Control (CAC) Not covered in this document. CAC is used to control the number of calls that can be established over the link. For example, if the WAN link between the two gateways has the bandwidth to carry only two VoIP calls, admitting a third call may impair the voice quality of all three calls. For more information refer to: VoIP Call Admission Control .

To summarize, for the low-speed PPP link with router/gateways as only sources of voice traffic two features are mandatory:

  1. Strict Priority for Voice Traffic

  2. Link Fragmentation and Interleaving (LFI)

Strict Priority for Voice Traffic (IP RTP Priority or LLQ)

As of Cisco IOS Software Release 12.2, there are two primary methods to provide strict priority for the voice traffic:

  • IP RTP Priority (also called PQ/WFQ: Priority Queue / Weighted Fair Queuing )

  • Low Latency Queuing (also called PQ/CBWFQ: Priority Queue / Class Based Weighted Fair Queuing).

IP RTP Priority

IP RTP Priority creates a strict priority queue for a set of RTP packet flows belonging to a range of User Datagram Protocol (UDP) destination ports. While the actual ports used are dynamically negotiated between end-devices or gateways, all Cisco VoIP products utilize the same UDP port range (16384-32767). Once the router recognizes the VoIP traffic, it places it into the strict priority queue. When the priority queue is empty, the other queues are processed according to standard Weighted Fair Queuing (WFQ). IP RTP Priority does not become active until there is congestion in the interface. This image illustrates the operation of IP RTP Priority:

pq-wfq.gif

Note: IP RTP Priority allows bursting the priority queue (PQ) when there is available bandwidth on the default queue (WFQ), but strictly polices the priority queue contents when there is congestion on the interface.

Low Latency Queuing

LLQ is a feature that provides a strict PQ to Class-Based Weighted Fair Queuing (CBWFQ). LLQ enables a single strict PQ within CBWFQ at the class level. With LLQ, delay-sensitive data (in the PQ) is dequeued and sent first. In a VoIP with LLQ implementation, voice traffic is placed in the strict PQ.

The PQ is policed to ensure that the fair queues are not starved of bandwidth. When you configure the PQ, you specify in Kbps the maximum amount of bandwidth available to the PQ. When the interface is congested, the PQ is serviced until the load reaches the configured Kbps value in the priority statement. Excess traffic is then dropped to avoid the problem with Cisco's legacy priority-group feature of starving the lower priority queues.

llq.gif

This method is more complex and flexible than IP RTP Priority. The choice between the methods should be based on the patterns of traffic in your real network and your actual needs.

LLQ vs. IP RTP Priority

This table summarizes the main differences between LLQ and IP RTP Priority and provides some guidelines of when to use each method.

Low Latency Queuing (LLQ) IP RTP Priority
Match Voice Traffic Based on:
  • Access-lists (for UDP port range, hosts addresses, IP header ToS fields: IP Precedence, DSCP, and more)
  • IP RTP port range
  • IP ToS (Type of Service) Fields: DCSP and/or IP Precedence
  • Protocols and Input Interfaces
  • All valid match criteria used in CBWFQ
Advantages:
  • More flexibility on how traffic is matched and directed to the strict PQ and CBWFQ
  • Can configure additional classes to guarantee bandwidth for other traffic such as: VoIP Signaling and Video.
Disadvantages:
  • Complex configuration
Match Voice Traffic Based on:
  • Based on RTP UDP port range: 16384-32767
Advantages:
  • Simple configuration
Disadvantages:
  • RTCP traffic (VoIP Signaling) served in WFQ queue

    Note: The RTP protocol uses RTCP (Real Time Control Protocol) to control delivery of RTP packets. While RTP ports use even numbers, RTCP ports use odd numbers in the range of 16384-32767. IP RTP Priority places RTP ports in the PQ, whereas RTCP ports are served in the default weighted fair queue.

  • Serves VoIP traffic in the PQ, but any other traffic that needs preferential treatment and bandwidth guarantee is served in WFQ. While WFQ can differentiate flows with weights (based on IP Precedence), it cannot ensure bandwidth guarantee for any flow.
Guidelines
  • The choice between them should be based on the patterns of traffic in your real network and your actual needs.
  • If you need to provide strict priority to your voice traffic, and other traffic can be treated as a single type (data), then the IP RTP Priority does a good job for your network with a simple configuration.
  • If you plan to prioritize voice traffic based on criteria other than UDP ports (for example DiffServ PHB), LLQ is necessary.

For more information on the correlation and differences of queuing methods, refer to the Congestion Management Overview.

LLQ Configuration Guidelines

Follow these guidelines to configure LLQ:

  1. Create a Class Map for VoIP Traffic and Define Match Criteria

    These commands explain how to complete this task:

    maui-voip-sj(config)#class-map ?
           WORD 		class-map name
           match-all 	Logical-AND all matching statements under this classmap
           match-any 	Logical-OR all matching statements under this classmap
    maui-voip-sj(config)#class-map match-all voice-traffic 
    
    !-- Choose a descriptive class_name. 
    
    
    maui-voip-sj(config-cmap)#match ?  
    access-group         Access group  
    any                  Any packets  
    class-map            Class map  
    cos                  IEEE 802.1Q/ISL class of service/user priority values  
    destination-address  Destination address  
    input-interface      Select an input interface to match  
    ip                   IP specific values  
    mpls                 Multi Protocol Label Switching specific values  
    not                  Negate this match result  
    protocol             Protocol 
    qos-group            Qos-group  
    source-address       Source address
    
    !-- In this example, the access-group matching option is used for its 
    !-- flexibility (it uses an access-list)
    
    
    maui-voip-sj(config-cmap)#match access-group ?
      <1-2699>  Access list index  name      Named Access List
    maui-voip-sj(config-cmap)#match access-group 102
    
    
    !-- Now, create the access-list to match the class-map access-group:
    
    maui-voip-sj(config)#access-list 102 permit udp any any range 16384 32776
    
    
    !-- Safest and easiest way is to match with UDP port range 16384-32767
    !-- This is the port range Cisco IOS H.323 products utilize to transmit 
    !-- VoIP packets.
    
    

    These access-lists can also be used to match voice traffic with the match access-group command:

    access-list 102 permit udp any any precedence critical 
    !-- This list filters traffic based on the IP packet TOS: Precedence field.  
    !-- Note: Ensure that other non-voice traffic does NOT uses the 
    !-- same precedence value.              
    
    access-list 102 permit udp any any dscp ef
    !-- In order for this list to work, ensure that VoIP packets are tagged with 
    !-- the dscp ef code before they exit on the LLQ WAN interface. 
    !-- For more information on DSCP refer to: 
    !-- Implementing Quality of Service Policies with DSCP
    !-- Note: If endpoints are not trusted on their packet marking, you can mark
    !-- incoming traffic by applying an inbound service policy on an inbound
    !-- interface. This procedure is out of the scope of this doc. 
        
    Access-list 102 permit udp host 192.10.1.1 host 192.20.1.1
    
    !-- This access-list can be used in cases where the VoIP devices cannot 
    !-- do precedence or dscp marking and you cannot determine the 
    !-- VoIP UDP port range. 
    
    

    These are other matching methods that can be used instead of access-groups:

    • Starting with Cisco IOS Release 12.1.2.T, IP RTP Priority functionality is implemented for LLQ. This feature matches the priority class contents looking at the UDP ports configured and is subject to the limitation of serving only even ports in the PQ.

      class-map voice 
        match ip rtp 16384 16383 
      
      
    • These two methods operate under the assumption that VoIP packets are marked at the originating hosts, or matched and marked in the router before applying the outbound LLQ operation.

      class-map voice 
        match ip precedence 5 
      

      or

      class-map voice 
        match ip dscp ef 
      

      Note: Starting with IOS Release 12.2.2T, VoIP dial-peers can mark voice bearer and signaling packets prior to the LLQ operation. This allows a scalable way of marking and matching VoIP packets via DSCP code values for LLQ.

  2. Create a Class Map for VoIP Signaling and Define Match Criteria (Optional)

    These commands explain how to complete this task:

     class-map voice-signaling
      match access-group 103
     !
     access-list 103 permit tcp any eq 1720 any 
     access-list 103 permit tcp any any eq 1720
    

    Note: VoIP calls can be established using H.323, SIP, MGCP or Skinny (Proprietary Protocol used by Cisco Call Manager). The above example assumed H.323 Fast Connect. This list serves as reference for the ports used by VoIP Signaling/Control Channels:

    • H.323/H.225 = TCP 1720

    • H.323/H.245 = TCP 11xxx (Standard Connect)

    • H.323/H.245 = TCP 1720 (Fast Connect)

    • H.323/H.225 RAS = TCP 1719

    • Skinny = TCP 2000-2002 (CM Encore)

    • ICCP = TCP 8001-8002 (CM Encore)

    • MGCP = UDP 2427, TCP 2428 (CM Encore)

    • SIP= UDP 5060, TCP 5060 (configurable)

  3. Create a Policy Map and Associate to the VoIP Class-Maps

    The purpose of the policy map is to define how the link resources are shared or assigned to the different map classes. These commands explain how to complete this task:

    maui-voip-sj(config)#policy-map VOICE-POLICY
    
    !-- Choose a descriptive policy_map_name.
    
    
    maui-voip-sj(config-pmap)#class voice-traffic
    maui-voip-sj(config-pmap-c)#priority ?  
    <8-2000000>  Kilo Bits per second
    
    !-- Configure the voice-traffic class to the strict priority
    !-- Queue (priority command) and assign the bandwidth.
    
    
    maui-voip-sj(config-pmap)#class voice-signaling
    maui-voip-sj(config-pmap-c)#bandwidth 8
    
    !-- Assign 8 Kbps to the voice-signaling class
    
    
    maui-voip-sj(config-pmap)#class class-default
    maui-voip-sj(config-pmap-c)#fair-queue 
    
    !-- The remaining data traffic is treated as Weighted Fair Queue
    
    

    Note: Although it is possible to queue various types of real-time traffic to the PQ, Cisco recommends that you direct only voice traffic to it. Real-time traffic, such as video, could introduce variation in delay (the PQ is a FIFO - First In First Out - queue). Voice traffic requires that delay be nonvariable in order to avoid jitter.

    Note: The sum of the values for priority and bandwidth statements needs to be less than or equal to 75 percent of the link bandwidth. Otherwise service-policy cannot be assigned to the link (to see the error messages, ensure that logging console is enabled for console access and terminal monitor is enabled for telnet access).

    Note: When configuring VoIP over a 64 Kbps link to support two voice calls, it is common to allocate more than 75 percent (48Kbps) of the link bandwidth to the PQ. In such cases, you can use the command max-reserved-bandwidth 80 to raise available bandwidth to 80 percent (51 Kbps).

    For more information on the bandwidth and priority commands, refer to Comparing the bandwidth and priority Commands of a QoS Service Policy.

  4. Enable LLQ: Apply the Policy Map to the Outbound WAN Interface

    These commands explain how to complete this task:

    maui-voip-sj(config)#interface multilink 1
    maui-voip-sj(config-if)#service-policy output VOICE-POLICY
    
    !-- In this scenario (MLPPP LFI), the service policy is applied to
    !-- the Multilink interface.
    
    
    

IP RTP Priority Configuration Guidelines

To configure IP RTP Priority use these guidelines:

  • Router(config-if)#ip rtp priority starting-rtp-port-#port-#-rangebandwidth
    
    
    Command Description
    starting-rtp-port-number
    
    Lower bound of UDP port. The lowest port number to which the packets are sent. For VoIP, set this value to 16384.
    port-number-range
    
    The range of UDP destination ports. A number, which added to the starting-rtp-port-number, yields the highest UDP port number. For VoIP, set this value to 16383 (32767 - 16384 = 16383)
    bandwidth
    
    Maximum allowed bandwidth (kbps) in the priority queue. Set this number according to the number of simultaneous calls the system supports.

    Sample Configuration:

    interface Multilink1
    
       !--- Some output omitted
    
       bandwidth 64
       ip address 172.22.130.2 255.255.255.252
       ip tcp header-compression
       fair-queue
       no cdp enable
       ppp multilink
       ppp multilink fragment-delay 10
       ppp multilink interleave
       multilink-group 1
       ip rtp header-compression iphc-format
       ip rtp priority 16384 16383 45
    

Link Fragmentation and Interleaving (LFI): Multilink PPP

While 1500 bytes is a common size for data packets, a typical VoIP packet (carrying G.729 voice frames) can be around 66 bytes (20 bytes voice payload, 6 bytes layer-2 header, 20 bytes RTP & UDP header, and 20 Bytes IP header).

Now, imagine a 56Kbps leased line link where voice and data traffic coexist. If a voice packet is ready to be serialized just when a data packet starts being transmitted over the link, then there is a problem. The delay-sensitive voice packet has to wait 214 msec before being transmitted (it takes 214 msec to serialize a 1500 bytes packet over a 56Kbps link).

As you can see, large data packets can adversely delay delivery of small voice packets, reducing speech quality. Fragmenting these large data packets into smaller ones and interleaving voice packets among the fragments reduces jitter and delay. The Cisco IOS Link Fragmentation and Interleaving (LFI) feature helps satisfy the real-time delivery requirements of VoIP. This image illustrates the operation of LFI:

lfi.gif

As shown in Table 1, the amount of serialization delay (the time it takes to actually place the bits onto an interface) introduced on low-speed WAN links can be significant, considering that the target end-to-end one-way delay should not exceed 150ms. (ITU-T G.114 recommendation specifies 150 ms maximum one-way end-to-end.)

Table 1. Serialization Delay for Various Frame Sizes on Low-Speed Links Serialization Delay = frame size (bits)/link bandwidth (bps)

1 Byte 64 Bytes 128 Bytes 256 Bytes 512 Bytes 1024 Bytes 1500 Bytes
56 kbps 143 us 9 ms 18 ms 36 ms 72 ms 144 ms 214 ms
64 kbps 125 us 8 ms 16 ms 32 ms 64 ms 126 ms 187 ms
128 kbps 62.5 us 4 ms 8 ms 16 ms 32 ms 64 ms 93 ms
256 kbps 31 us 2 ms 4 ms 8 ms 16 ms 32 ms 46 ms
512 kbps 15.5 us 1 ms 2 ms 4 ms 8 ms 16 ms 32 ms
768 kbps 10 us 640 us 1.28 ms 2.56 ms 5.12 ms 10.24 ms 15 ms
1536 kbps 5 us 320 us 640 us 1.28 ms 2.56 ms 5.12 ms 7.5 ms

Note: For voice applications, recommended serialization delay (per hop basis) is 10 ms and should not exceed 20 ms.

The link fragment size is configurable in millisecond (msec) time measurements with the command ppp multilink fragment-delay. LFI requires that ppp multilink be configured on the interface with ppp multilink interleave turned on. For more information on configuring LFI, refer to the section of this document.

Note: In cases where you have more than a dedicated half T1 connection (768 Kbps), you do not need a fragmentation feature. (You still, however, need a QoS mechanism, such as LLQ or IP RTP Priority). The half T1 offers enough bandwidth to allow voice packets to enter and leave the queue without delay issues. Also, you may not need Compression for Real-time Protocol (cRTP), which helps conserve bandwidth by compressing IP RTP headers, in the case of a half T1.

Compressed Real-time Protocol (cRTP)

Note: cRTP is not required to ensure good voice quality. It is a feature that reduces bandwidth consumption. Configure cRTP after all other conditions are met and the voice quality is good. This procedure can save troubleshooting time by isolating potential cRTP issues.

Based on RFC 2508, the RTP header compression feature compresses the IP/UDP/RTP header from 40 Bytes to 2 or 4 bytes, reducing unnecessary bandwidth consumption. It is a hop-by-hop compression scheme; therefore, cRTP must be configured on both ends of the link (unless the passive option is configured). To configure cRTP, use this command at interface level:

  • Router(config-if)#ip rtp header-compression [passive]

Since the compression process can be CPU-intensive, RTP header compression is implemented in the fast switching and CEF switching paths as the 12.0.(7)T release of IOS. Sometimes these implementations are broken, and then the only way that works will be processed switched. Cisco only recommends using cRTP with links lower than 768 Kbps, unless the router is running at a low CPU utilization rate. Monitor the router's CPU utilization and disable cRTP if it is above 75 percent.

Note: When you configure the command ip rtp header-compression, the router adds the command ip tcp header-compression to the configuration by default. This is used to compress the headers' TCP/IP packets. Header compression is particularly useful on networks with a large percentage of small packets, such as those supporting many Telnet connections. The TCP header compression technique, described fully in RFC 1144, is supported on serial lines using HDLC or PPP encapsulation.

To compress the TCP headers without enabling cRTP, use this command:

  • Router(config-if)#ip tcp header-compression [passive] 

For more information: Compressed Real-time Transport Protocol

Other Bandwidth Reduction Tips

  • Use low-bit-rate coder/decoders (codec) on the VoIP call legs; G.729 (8 Kbps) is recommended. (This is the default codec on the VoIP dial-peers). To configure different codecs use the router(config-dial-peer)#codec command under the desired voip dial-peer.

  • Although dual tone multifrequency (DTMF) is usually transported accurately when using high-bit-rate voice codecs such as G.711, low-bit-rate codecs (such as G.729 and G.723.1) are highly optimized for voice patterns and tend to distort DTMF tones. This approach can result in problems accessing interactive voice response (IVR) systems. The dtmf relay command solves the problem of DTMF distortion by transporting DTMF tones "out of band" or separate from the encoded voice stream. If low-bit-rate codecs (G.729, G.723) are used, turn on dtmf relay under the VoIP dial-peer.

  • A typical conversation may contain 35-50 percent silence. Using Voice Activity Detection (VAD), silence packets are suppressed. For VoIP bandwidth planning, assume VAD reduces bandwidth by 35 percent. VAD is configured by default under the VoIP dial-peers. To enable or disable VAD, use the router(config-dial-peer)#vad and router(config-dial-peer)# no vad commands under the desired voip dial-peers.

Network Diagram

mlppp.gif

Configurations

maui-voip-sj (Cisco 3640)
version 12.2service timestamps debug datetime msec

!-- < Some output omitted >

!
hostname maui-voip-sj
!
ip subnet-zero
!
no ip domain-lookup
!

!-- Definition of the voice signaling and traffic class maps
!-- "voice-traffic" class uses access-list 102 for its matching criteria.
!-- "voice-signaling" class uses access-list 103 for its matching criteria.


Class-map match-all voice-signaling
  match access-group 103
class-map match-all voice-traffic
  match access-group 102
!

!-- The policy-map defines how the link resources are assigned 
!-- to the different map classes. In this configuration, strict priority
!-- queue is assigned to "voice-traffic" class with (based on ACL in 
!-- class voice) with max bandwidth = 45 Kbps. 

policy-map VOICE-POLICY
  class voice-traffic
    priority 48
 class voice-signaling
   bandwidth 8

    !-- Assigns a queue for "voice-signaling" traffic that ensures 8 Kbps.
    !-- Note that this is optional and has nothing to do with good voice 
    !-- quality, but rather a way to secure signaling.

  class class-default
   fair-queue

!-- The class-default class is used to classify traffic that does 
    !-- not fall into one of the defined classes.
    !-- The fair-queue command associates the default class WFQ queueing.

!
call rsvp-sync
!

!-- Note that MLPPP is strictly an LFI mechanism. It does not
!-- bundle multiple serial interfaces to the same virtual interface as 
!-- the name stands (This bundling is done for data and NOT recommended 
!-- for voice). The end result may manifest itself as jitter and no audio.

interface Multilink1
 ip address 172.22.130.1 255.255.255.252
 ip tcp header-compression iphc-format
 service-policy output VOICE-POLICY

  !-- LLQ is an outbound operation and applied to the outbound WAN 
  !-- interface.

 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 10
  
!-- The configured value of 10 sets the fragment size such that 
  !-- all fragments have a 10 ms maximum serialization delay.

 ppp multilink interleave
 multilink-group 1
  ip rtp header-compression iphc-format
!
interface Ethernet0/0
 ip address 172.22.113.3 255.255.255.0
 no keepalive
 half-duplex
!
interface Serial0/0
 bandwidth 128

  !-- the bandwidth command needs to be set correctly for the 
  !-- right fragment size to be calculated.

 no ip address
 encapsulation ppp
 clockrate 128000
 ppp multilink
 multilink-group 1

  !-- This command links the multilink interface to the physical 
  !-- serial interface.

!
router eigrp 69 
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!

!-- access-list 102 matches VoIP traffic based on the UDP port range. 
!-- Both odd and even ports are put into the PQ.
!-- access-list 103 is used to match VoIP signaling protocol. In this
!-- case, H.323 V2 with fast start feature is used.

access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
dial-peer voice 1 pots
 destination-pattern 5000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 6000
 session target ipv4:172.22.130.2

maui-voip-austin (Cisco 3640)
version 12.2
service timestamps debug datetime msec
!
hostname maui-voip-austin
!
boot system flash slot1:c3640-is-mz.122-6a.bin
!
ip subnet-zero
!
class-map match-all voice-signaling
  match access-group 103
class-map match-all voice-traffic
  match access-group 102
!
policy-map voice-policy
  class voice-signaling
   bandwidth 8
  class voice-traffic
    priority 48
  class class-default
   fair-queue
!
interface Multilink1
 bandwidth 128
 ip address 172.22.130.2 255.255.255.252
 ip tcp header-compression iphc-format
 service-policy output voice-policy
 no cdp enable
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave
 multilink-group 1
 ip rtp header-compression iphc-format

 !-- Configure cRTP after you have a working configuration.
 !-- This helps isolate potential cRTP issues.

!
Interface Ethernet0/0
 ip address 172.22.112.3 255.255.255.0
 no keepalive
 half-duplex
!
interface Serial0/0
 bandwidth 128
 no ip address
 encapsulation ppp
 no ip mroute-cache
 ppp multilink
 multilink-group 1
!
router eigrp 69
 network 172.22.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
dial-peer voice 1 pots
 destination-pattern 6000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 5000
 session target ipv4:172.22.130.1

Verification and Troubleshooting Commands

Before attempting any debug commands, refer to Important Information on Debug Commands. For more info on the commands listed here, see the Sample show and debug Output section of this document.

Interface Commands:

  • show interface [serial | multilink]—Use this command to check that status of the serial interface. Make sure the serial and multilink interface are up and open.

  • Troubleshooting Serial Lines

LFI Commands:

  • show ppp multilink—This command displays bundle information for the Multilink PPP bundles.

  • debug ppp multilink fragments—This debug command displays information about individual multilink fragments and interleaving events. This command output also identifies the sequence number of the packet and the fragment sizes.

LLQ/IP RTP Priority Commands:

  • show policy-map interface multilink interface# —This command is very useful to see the LLQ operation and to see any drops in the PQ. For more information on the various fields of this command, refer to Understanding Packet Counters in show policy-map interface Output.

  • show policy-map policy_map_name —This command displays information about the policy-map configuration.

  • show queue interface-type interface-number —This command lists fair queueing configuration and statistics for a particular interface.

  • Debug priority—This debug command displays priority queueing events and shows if dropping occurs in this queue. Also refer to Troubleshooting Output Drops with Priority Queuing.

  • show class-map class_name —This command displays information about the class-map configuration.

  • show call active voice—This command is useful to check for lost packets at the DSP level.

Other Commands/References:

Known Issues:

  • CSCds43465: "LLQ, Policer, Shaper Should Take CRTP Compression Feedback" To view Release Notes, refer to Bug ToolKit (registered customers only) .

Guidelines:

Here are some basic troubleshooting steps, once the ppp link is up and running (MLPPP, Fragmentation, Interleaving):

  1. show call active voice—Use to check for the lost packets at the DSP level.

  2. show interface—Use to check for the general serial line or interface problems. Drops on the interface does not mean a problem yet, but it is preferable to drop the packet form the low priority queue before it reach the interface queue.

  3. show policy-map interface—Use to check for the LLQ drops and queuing configuration. Should not report any drops that violate the policy.

  4. show ip rtp header-compression—Use to check for the cRTP specific problems.

Sample show and debug Output

 

!-----------------------------------------------
 !-----------------------------------------------
 !---- To capture sections of this output, the LLQ PQ bandwidth 
 !---- was lowered and large data traffic was placed
 !---- on the link to force some packets drops.
 !-----------------------------------------------
 !-----------------------------------------------

 !---- Packet Drop Verification (During an Active Call)

 !--- Assuming your ppp link is up and running, the first step of voice 
 !--- quality problems verification is to check for lost packets 
 !--- at the DSP. Note: Use the show call active voice command 
 !--- NOT show call active voice brief


 maui-voip-austin#show call active voice
 Total call-legs: 2


 !--- Indicates that the connection is established and both legs exist


 GENERIC:
          SetupTime=155218260 ms
          Index=1
          PeerAddress=5000
          PeerSubAddress=
          PeerId=2
          PeerIfIndex=13
          LogicalIfIndex=0
          ConnectTime=155218364
          CallDuration=00:00:27
          CallState=4

 !--- indicates that it is the active call
 !--- (#define D_callActiveCallState_active 4).
          CallOrigin=2
          ChargedUnits=0
          InfoType=2
          TransmitPackets=365
          TransmitBytes=7300
          ReceivePackets=229
          ReceiveBytes=4580

 VOIP:

 !--- For this call, this was the terminating gateway.
 !--- At this gateway, the call started at the VoIP leg.

          ConnectionId[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
          IncomingConnectionId[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
          RemoteIPAddress=172.22.130.1

 !--- Indicates from which IP address the RTP stream is originating.

          RemoteUDPPort=18778
          RemoteSignallingIPAddress=172.22.130.1

 !--- Indicates from which IP address signaling messages are coming.

          RemoteSignallingPort=11010
          RemoteMediaIPAddress=172.22.130.1
          RemoteMediaPort=18778
          RoundTripDelay=50 ms
          SelectedQoS=best-effort
          tx_DtmfRelay=inband-voice
          FastConnect=TRUE

 Separate H245 Connection=FALSE

 H245 Tunneling=FALSE

 SessionProtocol=cisco
 SessionTarget=
 OnTimeRvPlayout=4570
 GapFillWithSilence=20 ms
 GapFillWithPrediction=1840 ms
 GapFillWithInterpolation=0 ms
 GapFillWithRedundancy=0 ms
 HiWaterPlayoutDelay=70 ms
 LoWaterPlayoutDelay=51 ms
 ReceiveDelay=51 ms
 LostPackets=90
 EarlyPackets=1
 LatePackets=0

 !--- Indicates the precense of jitter, lost packets, or 
 !--- corrupted packets.

 VAD = enabled
 CoderTypeRate=g729r8
 CodecBytes=20

 GENERIC:
          SetupTime=155218260 ms
          Index=2
          PeerAddress=6000
          PeerSubAddress=
          PeerId=1
          PeerIfIndex=12
          LogicalIfIndex=6
          ConnectTime=155218364
          CallDuration=00:00:34
          CallState=4
          CallOrigin=1
          ChargedUnits=0
          InfoType=2
          TransmitPackets=229
          TransmitBytes=4580
          ReceivePackets=365
          ReceiveBytes=7300
 TELE:
          ConnectionId=[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
          IncomingConnectionId=[0x18872BEB 0x1A8911CC 0x808CBE60 0x6D946FC6]
          TxDuration=35360 ms
          VoiceTxDuration=730 ms
          FaxTxDuration=0 ms
          CoderTypeRate=g729r8
          NoiseLevel=-46
          ACOMLevel=2
          OutSignalLevel=-58
          InSignalLevel=-42
          InfoActivity=2
          ERLLevel=7
          SessionTarget=
          ImgPages=0Total call-legs: 2



 !----------------------------------------------------------
 !--- Interface Verification

 !--- Make sure you see this:
 !--- LCP Open, multilink Open: Link control protocol (LCP) open statement 
 !--- indicates that the connection is establish.
 !--- Open:IPCP. Indicates that IP traffic can be transmitted via the PPP link.


 maui-voip-sj#show interface multilink 1

 Multilink1 is up, line protocol is up
   Hardware is multilink group interface
   Internet address is 172.22.130.1/30
   MTU 1500 bytes, BW 128 Kbit, DLY 100000 usec,
      reliability 255/255, txload 1/255, rxload 1/255
   Encapsulation PPP, loopback not set
   Keepalive set (10 sec)
   DTR is pulsed for 2 seconds on reset
   LCP Open, multilink Open
   Open: IPCP
   Last input 00:00:01, output never, output hang never
   Last clearing of "show interface" counters 00:25:20
   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 91
   Queueing strategy: weighted fair
   Output queue: 0/1000/64/37/383 (size/max total/threshold/drops/interleaves)
      Conversations  0/3/32 (active/max active/max total)
      Reserved Conversations 1/1 (allocated/max allocated)
      Available Bandwidth 38 kilobits/sec
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      8217 packets input, 967680 bytes, 0 no buffer
      Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      13091 packets output, 1254194 bytes, 0 underruns
      0 output errors, 0 collisions, 0 interface resets
      0 output buffer failures, 0 output buffers swapped out
      0 carrier transitions
----------------------------------------------------------------

!-- Note: There are no drops at the interface level.
!-- All traffic that is dropped due to policing, is 
!-- dropped before it gets to the interface queue.


maui-voip-austin#show interface
 serial 0/0Serial0/0 is up, line protocol is up
  Hardware is QUICC Serial
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
     reliability 255/255, txload 49/255, rxload 47/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  LCP Open, multilink Open
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 00:22:08
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair  [suspended, using FIFO]
  FIFO output queue 0/40, 0 drops
  5 minute input rate 24000 bits/sec, 20 packets/sec
  5 minute output rate 25000 bits/sec, 20 packets/sec     4851 packets input, 668983 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     4586 packets output, 657902 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up


!-----------------------------------
!--- LLQ Verification



maui-voip-austin#show policy-map int multilink 1
 Multilink1
 Service-policy output: voice-policy

 Class-map: voice-signaling (match-all)

!--- This is the class for the voice signaling traffic.

         10 packets, 744 bytes
         5 minute offered rate 0 BPS, drop rate 0 BPS
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 42
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 10/744
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: voice-traffic (match-all)

!--- This is PQ class for the voice traffic.

         458 packets, 32064 bytes
         5 minute offered rate 0 BPS, drop rate 0 BPS
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 40
         Bandwidth 15 (kbps) Burst 375 (Bytes)
!--- Notice that the PQ bandwidth was lowered to force packet drops.
         (pkts matched/bytes matched) 458/29647
         (total drops/bytes drops) 91/5890
!--- Some packets were dropped. In a well designed link,
!--- there should be no (or few) drops of the PQ class.

 Class-map: class-default (match-any)
         814 packets, 731341 bytes
         5 minute offered rate 27000 BPS, drop rate 0 BPSMatch: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 32
         (total queued/total drops/no-buffer drops) 0/0/0

!---------------------------------------------


!--- Verify the class-map configuration

maui-voip-austin#show class-map
 Class Map match-all voice-signaling (id 2)
   Match access-group  103
 Class Map match-any class-default (id 0)
         Match any
 Class Map match-all voice-traffic(id 3)
         Match access-group 102


!--- Verify the access-lists of the class-maps

maui-voip-austin#show access-lists
Extended IP access list 102
    permit udp any any range 16384 32767 (34947 matches)
Extended IP access list 103
    permit tcp any eq 1720 any (187 matches)
    permit tcp any any eq 1720 (86 matches)


!--- Verify the policy-pap configuration

maui-voip-austin#show policy-map voice-policy
  Policy Map voice-policy
    Class voice-signaling
      Weighted Fair Queueing
            Bandwidth 8 (kbps) Max Threshold 64 (packets)
    Class voice-traffic
      Weighted Fair Queueing
            Strict Priority
            Bandwidth 50 (kbps) Burst 1250 (Bytes)
    Class class-default
      Weighted Fair Queueing
            Flow based Fair Queueing Max Threshold 64 (packets)
---------------------------

!--- Debug priority command provides immediate feedback in case 
!--- of VoIP packet drops.
!--- The output below shows the error message when VoIP packets 
!--- are being dropped from the strict priority queue. 

maui-voip-sj#debug priority

priority output queueing debugging is on
maui-voip-sj#
Mar 17 19:47:09.947: WFQ: dropping a packet from the priority queue 0
Mar 17 19:47:09.967: WFQ: dropping a packet from the priority queue 0
Mar 17 19:47:09.987: WFQ: dropping a packet from the priority queue 0

-------------------------------------------------------------------



!--- Link Fragmentation and Interleaving (LFI) Verification



maui-voip-sj#show ppp multilink

!--- Verify the fragmentation size and multilink

Multilink1, bundle name is maui-voip-austin
         Bundle up for 00:08:04
         0 lost fragments, 0 reordered, 0 unassigned
         0 discarded, 0 lost received, 1/255 load
         0x6D received sequence, 0x6E sent sequence
         Member links: 1 active, 0 inactive (max not set, min not set)
         Serial0/0, since 00:08:09, last rcvd seq 00006C 160 weight

  !--- Notice the fragmentation size is 160 Bytes. The link is configured with a 
  !--- bandwidth of 128 kbps and a serialization delay of 10 msec. 
  !--- Fragment Size (in bits) = bandwidth * serialization delay.
  !--- Note: There are 8 bits in one byte.


-------------------------------------------------------


!--- Link Fragmentation and Interleaving (LFI) Verification 

!--- Testing Multilink PPP Link LFI
!--- This output displays fragmentation and interleaving information
!--- when the the 128kbps PPP link is loaded with big data and VoIP packets.

maui-voip-sj#debug ppp multilink fragments
Multilink fragments debugging is on

1w3d: Se0/0 MLP: O frag 800004CF size 160
1w3d: Se0/0 MLP: O frag 000004D0 size 160
1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
1w3d: Mu1 MLP: Packet interleaved from queue 40
1w3d: Se0/0 MLP: O ppp IP (0021) size 64
1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
1w3d: Se0/0 MLP: O frag 400004D1 size 106
1w3d: Se0/0 MLP: O ppp IP (0021) size 64
1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
1w3d: Se0/0 MLP: O ppp IP (0021) size 64 direct
1w3d: Se0/0 MLP: I frag 800004E0 size 160 direct
1w3d: Se0/0 MLP: I frag 000004E1 size 160 direct
1w3d: Se0/0 MLP: I ppp IP (0021) size 64 direct
-------------------------------------------------------------------


!--- Sample output of show ip rtp header-compression command

maui-voip-sj#show ip tcp header-compression
TCP/IP header compression statistics:  Interface Multilink1:
    Rcvd:    10 total, 6 compressed, 0 errors
             0 dropped, 0 buffer copies, 0 buffer failures
    Sent:    10 total, 7 compressed,
             230 bytes saved, 99 bytes sent
             3.32 efficiency improvement factor
    Connect: 16 rx slots, 16 tx slots,
             2 long searches, 1 misses 0 collisions, 0 negative cache hits
             90% hit ratio, five minute miss rate 0 misses/sec, 0 max

----------------------------------------------------------------------


!--- This command displays information of the voip dial-peers command.

maui-voip-sj#show dial-peer voice 2
VoiceOverIpPeer2
        information type = voice,
        tag = 2, destination-pattern = `6000',
        answer-address = `', preference=0,
        group = 2, Admin state is up, Operation state is up,
        incoming called-number = `', connections/maximum = 0/unlimited,
        application associated:
        type = voip, session-tMarget = `ipv4:172.22.130.2',
        technology prefix:
        ip precedence = 0, UDP checksum = disabled,
        session-protocol = cisco, req-qos = best-effort,
        acc-qos = best-effort,
        fax-rate = voice,   payload size =  20 bytes
        codec = g729r8,   payload size =  20 bytes,
        Expect factor = 10, Icpif = 30,signaling-type = cas,
        VAD = enabled, Poor QOV Trap = disabled,
        Connect Time = 283, Charged Units = 0,
        Successful Calls = 1, Failed Calls = 0,
        Accepted Calls = 1, Refused Calls = 0,
        Last Disconnect Cause is "10  ",
        Last Disconnect Text is "normal call clearing.",
        Last Setup Time = 93793451.

-------------------------------------------------------------------------

!---The CPU utilization of the router should not exceed the 50-60 percent
!--- during any five-minute interval.

maui-voip-austin#show processes cpu
CPU utilization for five seconds: 12%/8%; one minute: 11%; five minutes: 9%
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
   1         148    310794          0  0.00%  0.00%  0.00%   0 Load Meter
   2          76        23       3304  0.81%  0.07%  0.01%   0 Exec


Related Information

Updated: Feb 02, 2006
Document ID: 7111