CallManager 5.x/6.x/7.x/8.x : CDR/CMR Error

Document ID: 100465

Contents

Introduction
Prerequisites
   Requirements
   Components Used
   Conventions
Error Code 10011
   Unable to View the CDR Report
   Solutions
   Unable to Send the CDR Report as Email
   Solution
Error Code 10021
   Solution 1
   Solution 2
Error Code 10012
   Solution

WARN [TaskMonitor] controller.CtrNotifications − isManualPurgeRunning()
   Solution
CMR Information NULL in CAR Reports
   Solution
Warning: In some servers in this cluster the CDR Enabled Flag is false and so CDR entries may not be
   generated for all the calls made in this cluster
   Solution
CAR Scheduler Service Hangs
   Solution
Java.sql.SQLException Error
   Solution
CAR Scheduler Sending Export Files in the Incorrect Time Intervals
   Solution
Error: CDR flag is not enabled
   Solution
CAR Reports Not in Readable CSV Format
   Solution

Related Information

Introduction

This document provides information and solutions for error messages in the Call Detail Record (CDR)
Analysis and Reporting (CAR) Tool on Cisco Unified Communications Manager (CallManager) 6.x/7.x/8.x.

Also, refer to CDR Analysis and Reporting (CAR) Tool Error Message: Error Code: 10011, System Error.
Contact System Administrator.
Prerequisites

Requirements

Cisco recommends that you have knowledge of these topics:

- Cisco Unified Communications Manager (CallManager) 5.x
- Cisco Unified Communications Manager (CallManager) 6.x
- Cisco Unified Communications Manager (CallManager) 7.x
- Cisco Unified Communications Manager (CallManager) 8.x
- Cisco Call Detail Record (CDR) Analysis and Reporting (CAR) Tool

Components Used

The information in this document is based on Cisco Unified Communications Manager (CallManager) 5.x/6.x/7.x/8.x.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Error Code 10011

Unable to View the CDR Report

When an attempt is made to view the CDR report and CDR search on Cisco Unified Communications Manager (CallManager) 6.X, an error message appears 10011 System Error "Contact System Administrator".

Similarly, when an attempt is made to collect data, CAR can not collect data and an error message appears: 30061 "Data not available in Database". This issue is also documented in Cisco bug ID CSCsz99841 (registered customers only).

Solutions

Solution 1

In order to fix this issue, complete these steps:

1. Open the Cisco Unified Communications Manager Administration and choose System > Service Parameters.
2. Click the Advanced button to display the complete list of Service Parameters.
3. Disable the CDR Enabled Flag parameter on all servers in the cluster.
5. Restart these services on all the servers in your cluster:

- Cisco CDR Agent
- Cisco Database Layer Monitor
- Cisco CDR Repository Manager
- Cisco CAR Scheduler

6. Choose **Cisco CallManager Serviceability > Tools > Control Center − Feature Service** and restart these services:

- Cisco SOAP − CDRonDemand Service
- Cisco CAR Web Service

7. Enable the **CDR Enabled Flag** parameter again under the Service Parameters on all the servers in the cluster, and then run a CDR report.

**Solution 2**

If the problem remains, run these **CLI** commands in the Cisco Unified Communications Manager server.

1. run sql select param_value from car:tbl_system_preferences where param_name='MANUAL_PURGE_STATUS'
2. If this query returns a param_value of 1, run this query to update the MANUAL_PURGE_STATUS to 0:

   run sql update car:tbl_system_preferences set param_value=0 where param_name='MANUAL_PURGE_STATUS'

   After updating the MANUAL_PURGE_STATUS to 0, restart the Cisco CAR Scheduler services. The loader works fine after a restart of the Cisco CAR Scheduler services.
3. If the value is correct, run these queries:

   a. run sql select param_value from car:tbl_system_preferences where param_name='MIN_DATE'
   b. run sql select param_value from car:tbl_system_preferences where param_name='CDR_MIN_DATE'
   c. run sql select param_value from car:tbl_system_preferences where param_name='MAX_DATE'
   d. run sql select param_value from car:tbl_system_preferences where param_name='CDR_MAX_DATE'

4. Run this query:

   run sql Select max(Error_Record_Id) from car:tbl_error_id_map

5. Obtain the results of the query and run this:
run sql update car:tbl_system_preferences set param_value= <value from previous query> where param_name='MAX_ERROR_RECORD_ID'

Now try to run a CAR report and a CDR search again.

**Solution 3**

This issue can also occur when the user has not added the mail−id and domain field. In the Cisco Unified Communications Manager Administration Page, choose **System > Service Parameters > Mail Parameters** and ensure that the mail id (username) of the user and domain−name in the domain field are added.

**Solution 4**

Choose **System > Service Parameters** and click the **Advanced** button in order to display the list of Service Parameters and make sure that the **CDR Enabled** Flag is set to **True**.

**Solution 5**

1. Run the run sql Select max(Error_Record_Id) from car:tbl_error_id_map query, and add 1 to the returned result.
2. Enter the run sql update car:tbl_system_preferences set param_value="Number returned from first command +1" query.
3. Choose **System > Scheduler > CDR Load.** Select **Disable Loader,** and click the **Update** button in order to disable the CAR loader.

   **Note:** CDR data does not load into CAR until you enable CDR loading. Changes take effect at midnight. In order to force the change to take effect immediately, stop and restart the CAR Scheduler service.
4. In order to re−enable it, uncheck the **Disable Loader** check box. Check the **Continuous Loading 24/7** check box, and click the **Update** button.
5. For the changes to take effect immediately, stop and restart the CAR Scheduler service.

**Solution 6**

Complete these steps:

1. Choose **Start > Programs > Administrative Tools > Services.**
2. Right−click **Cisco Unified CallManager CAR Scheduler > Log On,** and choose **Local System Account.**

   If the error **Could not start the Cisco Unified CallManager CAR Scheduler service on Local Computer. Error 1069 also appears,** you need to synchronize the passwords.
3. In order to synchronize the passwords, choose **Start > Run > adminutility > select all > Options > Set new password.**

**Unable to Send the CDR Report as Email**

When you try to send the CDR file through email, this error message appears:

```
Error Code 10011
Error Description System Error. Contact System Administrator.
```
Note: You are able to view the report, but the error message appears when you click the Send button after you enter an email address in the To: field.

Solution

In order to resolve this issue, complete these steps:

1. Choose System > System Parameters > Mail Parameters.

   The Mail Parameters window displays.
2. In the Mail ID field, enter the E-mail ID to be used in the From field when e-mails are sent.

   Note: Make sure that the Email ID field is filled without the domain extension. For example, if the email ID is xyz.lmn@abc.com, you must fill in the field with just xyz.lmn. Also, be sure not to use the Administrator application user or a similar user, since application users do not have mail ID fields.
3. In the Password field, enter the password that is used to access the server that runs the email system.

   Note: CAR does not authenticate the user ID and password. You must disable authentication on the mail server or enter a valid user ID and password.
4. In the Confirm Password field, enter the same password from Step 3 in order to confirm.
5. In the Mail Domain field, enter the domain name for the server that runs the email system.
6. Make sure the Mail Server is set to use IP address (of the server that runs the email system) instead of host name.
7. In order to make the changes, click the Update button.

Error Code 10021

When an attempt is made to access CDR Search and CDR report from CDR Analysis and Reporting (CAR) on Cisco Unified Communications Manager (CallManager) 5.X, this error message appears: Error Code 10021 There is no matching records.

Similarly, when an attempt is made to collect data, CAR is not able to collect data and this error message appears: 30023: Data is not available for the date range selected.

Solution 1

1. This error can occur when the Disable CDR loader check box is checked in CAR. Choose System > Scheduler > CDR Load, and uncheck the Disable Loader check box in order to resolve the issue.
2. Choose System > Service Parameters, and click the Advanced button in order to display the list of Service Parameters. Make sure that the CDR Enabled Flag is set to True.

Solution 2

Complete the steps mentioned in the Solution for the Error Code 10012.

If these solutions do not solve the issue, contact the Cisco Technical Assistance Center (TAC).

Complete these steps:

1. Reset the MAX_CDR_NUMBER to a default of two million. Run this query from CLI:

   ```
   admin: run sql update car:tbl_system_preferences set param_value='2000000' where param_name='MAX_CDR_NUMBER'.
   ```
2. Choose **System > Scheduler > CDR Load**. Select **Disable Loader**, and click the **Update** button in order to disable the CAR loader.

**Note:** CDR data does not load into CAR until you enable CDR loading. Changes take effect at midnight. In order to force the change to take effect immediately, stop and restart the CAR Scheduler service.

3. Re-enable it, uncheck the **Disable Loader** check box. Check the **Continuous Loading 24/7** check box, and click the **Update** button.

4. In order for the changes to take effect immediately, stop and restart the CAR Scheduler service.

### Error Code 10012

With Cisco Unified Communications Manager 5.x, CDR reports are not generated and show an error code:

"10012.Database Error. Contact system administrator"

Also, the CAR Event Log shows that all the CDR Loader events are unsuccessful. The debug trace for the CAR Scheduler displays this error message:

```
ERROR [DailyCdrLoad] beans.EBSystemPreferences - save(): Error while saving
Sys Pref Data: MAX_DATE null.
```

**Solution**

Complete these steps in order to resolve the issue:

1. Run the query to get the maximum date.

   ```sql
   run sql select param_value from car:tbl_system_preferences where
   param_name='CDR_MAX_DATE'
   ```

2. Use the maximum date obtained in the previous query in order to insert into the `tbl_system_preferences` table. Use the date string in the `mm/dd/yyyy` format.

   ```sql
   "run sql insert into
   car:tbl_system_preferences(param_name,param_value) values ('MAX_DATE','<mm/dd/yyyy>')"
   ```

3. Stop the CAR scheduler and CAR web services.

4. Run this query to update the `MANUAL_PURGE_STATUS` to 0:

   ```sql
   run sql update car:tbl_system_preferences set param_value=0
   where param_name='MANUAL_PURGE_STATUS'
   ```

5. After you update the `MANUAL_PURGE_STATUS` to 0, restart the CAR scheduler and CAR web services.

This issue can also occur if any of these entries are missing from the `tbl_system_preferences` table:

- max_date
- min_date
- cdr_max_date
- cdr_min_date

Complete these steps in order to confirm which entry is missing:

1. `run sql select param_value from car:tbl_system_preferences where param_name='MIN_DATE'`
2. `run sql select param_value from car:tbl_system_preferences where param_name='CDR_MIN_DATE'`
3. run sql select param_value from car:tbl_system_preferences where param_name='MAX_DATE'
4. run sql select param_value from car:tbl_system_preferences where param_name='CDR_MAX_DATE'

If any of these four entries is missing, insert it back to the table with this logic:

- If MIN_DATE is missing, find CDR_MIN_DATE value and insert such value as MIN_DATE to tbl_system_preferences.
- If CDR_MIN_DATE is missing, find MIN_DATE value and insert such value as CDR_MIN_DATE to tbl_system_preferences.
- If both MIN_DATE & CDR_MIN_DATE are missing, insert '01/01/1970' to both columns to tbl_system_preferences.
- If MAX_DATE is missing, find CDR_MAX_DATE value and insert such value as MAX_DATE to tbl_system_preferences.
- If CDR_MAX_DATE is missing, find MAX_DATE value and insert such value as CDR_MAX_DATE to tbl_system_preferences.
- If both MAX_DATE and CDR_MAX_DATE are missing, insert '01/01/1970' to both columns to tbl_system_preferences.

For example, if CDR_MIN_DATE is missing, do this:

1. Get MIN_DATE value: run sql select param_value from car:tbl_system_preferences where param_name='MIN_DATE'
2. Get the value from above, eg: 01/01/2008, then run: run sql insert into car:tbl_system_preferences values('CDR_MIN_DATE', '01/01/2008');

This issue can also occur due to these known issues:

- Cisco bug ID CSCsk17300 (registered customers only)
- Cisco bug ID CSCsg01364 (registered customers only)

**WARN [TaskMonitor] controller.CtrNotifications – isManualPurgeRunning()**

No records were found in the CAR database and the CAR scheduler traces shows this message:

"WARN [TaskMonitor] controller.CtrNotifications – isManualPurgeRunning(): [Manual Purge] and [Continuous Loading 24/7] are both running, sleeps for 60 seconds ..."

The output of tbl_system_preferences shows that the Manual Purge is ON.

**Solution**

Complete these steps in order to resolve the issue:

1. Stop the CAR scheduler service.
2. Run this query:

   run sql update car:tbl_system_preferences set param_value='0' where param_name='MANUAL_PURGE_STATUS'

3. Start the CAR scheduler service.
4. Set the loader properties to default.
5. Restart the CAR scheduler service.
CMR Information NULL in CAR Reports

CMR information shows NULL in CAR reports.

Solution

In order to resolve the issue, verify this:

1. Make sure the call diagnostics parameters are enabled in the Cisco CallManager service parameters:
   - CDR Enable Parameter - Enabled
   - Call Diagnostics Parameters - Enabled
2. Determine if Load CDR only is checked. If it is, uncheck it.

Warning: In some servers in this cluster the CDR Enabled Flag is false and so CDR entries may not be generated for all the calls made in this cluster

You are unable to collect CDR data, and this error message appears:

Warning: In some servers in this cluster the CDR Enabled Flag is false and so CDR entries may not be generated for all the calls made in this cluster.

Solution

In order to resolve the issue, make sure that the CDR Enabled Flag is set to True on the Cisco Unified Communications Manager server.

CAR Scheduler Service Hangs

The CAR scheduler service hangs and leaves a large number of unprocessed CDR/CMR files. There is a high memory usage on the CAR scheduler when partitions are auto-purged.

This issue is documented in Cisco bug ID CSCta71863 (registered customers only).

Solution

In order to resolve this issue, increase the MAX_CAR_DATABASE_AGE setting, which is configurable on the CAR automatic-purge page, to either the default of 60 days or a value greater than 34.

Java.sql.SQLException Error

The CDR loading in the CAR fails intermittently with this SQL error: java.sql.SQLException: Table (informix.xxx) has been dropped, altered or renamed., error code -710.

This issue is documented in Cisco bug ID CSCsr05092 (registered customers only).
Solution

These are the workarounds for this issue:

1. Restart the CAR scheduler service whenever such an SQL error is caught.
2. Configure a more frequent loader schedule. For example, load 13 mins for every 15 mins.

**CAR Scheduler Sending Export Files in the Incorrect Time Intervals**

The CAR scheduler is sending export files twice per minute instead of once per hour as defined in the scheduler.

**Solution**

In order to resolve the issue, change the **CDR File Time Interval** from 1 to 60 in the **System Parameters**.

**Error: CDR flag is not enabled**

When trying to get to the CDR option, the **CDR flag is not enabled** error message is received.

**Solution**

Perform these steps in the CallManager server to resolve this issue:

1. Go to **Enterprise Parameters** and configure these:

   ♦ **CDR File Time Interval** = 1
   ♦ **Cluster ID** = StandAloneCluster

2. Go to **Service Parameters**, select **Cisco CallManager** as the service and configure these:

   ♦ **CDR Enabled Flag** = True
   ♦ **CDR Log Calls with Zero Duration Flag** = True
   ♦ **Call Diagnostics Enabled** = Enabled Regardless of CDR Enabled Flag

**CAR Reports Not in Readable CSV Format**

For Cisco Unified Communications Manager 5.x and later, the CAR CSV View Report output is not properly formatted and not readable.

**Solution**

This behavior is because the underlying platform is Linux for Cisco Unified Communications Manager 5.x and later. You can get the reports formatted to some level using the workaround provided in this section. It is because of the way the Linux platform works.

This issue is documented in Cisco bug ID CSCtb75858 (registered customers only).

Perform this procedure as a possible workaround:

1. Open Microsoft Excel.
2. Go to File > Open.
3. Choose Text Files (*.pm; *.txt, *.csv) for Files of type.
4. Find and open the report.txt file.
5. From the Text Import Wizard – Step 1 of 3 window, choose Fixed width as file type under the Original Data Type. Then, click Next.

Note: If you choose Delimited as the file type, this can result in truncation of data.
6. In the Text Import Wizard – Step 2 of 3 window, use the horizontal scroll bar to go over the entire row and complete these steps:
   a. Delete any unwanted column break with a double click.
   b. Add any missing column break with a single click at the desired position.
   c. Click Next.
7. From the Text Import Wizard – Step 3 of 3 window, click Finish.
8. The data will be displayed in the Excel cells. You can perform these items for better readability:
   ♦ adjust the alignment
   ♦ select the whole table by clicking the table's upper-left corner
   ♦ click the left-alignment button on the tool bar

In order to make cell width fit data length automatically, double click between any two columns.

Related Information

• Understanding CDR (Call Detail Records)
• After Cisco CallManager 4.1 is upgraded to Cisco CallManager 4.2, CMR files are not inserted into the CDR database, which results in high CPU usage on the server
• Voice Technology Support
• Voice and Unified Communications Product Support
• Technical Support & Documentation – Cisco Systems