Guest

Cisco 800 Series Routers

Configuring a Cisco 827 Router Terminating on a Cisco 6400 in RBE Mode Using RFC1483 Bridging

Cisco - Configuring a Cisco 827 Router Terminating on a Cisco 6400 in RBE Mode Using RFC1483 Bridging

Document ID: 12897

Updated: Nov 23, 2007

   Print

Introduction

This sample configuration shows a Cisco 827 Digital Subscriber Line (DSL) Router connected to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM), terminating on a Cisco 6400 Universal Access Concentrator (UAC).

The Cisco 827 router is configured with RFC1483 Bridging; the Cisco 6400 is configured with routed bridge encapsulation (RBE).

The ATM RBE feature in the Cisco 6400 node route processor (NRP) routes IP over bridged RFC1483 Ethernet traffic from a stub-bridged LAN.

Bridged IP packets received on an ATM interface configured in route-bridge mode are routed via an IP header. The interface takes advantage of the characteristics of a stub LAN topology commonly used for DSL access and offers increased performance and flexibility over integrated routing and bridging (IRB).

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco 827-4V Customer Premises Equipment (CPE) IOS® Software Release 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS Software Release 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

827rfc_6400rbe.gif

Configurations

To be able to Telnet to (or ping) the Cisco 827 from the Internet, you must configure an IP address and a MAC address on the ATM interface. For the IP address, configure the same IP address on the ATM interface that you configured on the Ethernet interface. For the MAC address, issue the show interface eth0 command. Note the MAC address and configure this same MAC address on the ATM interface.

When the Cisco 827 is bridging IP on the Ethernet and ATM interfaces, both interfaces can have the same IP address.

Note the no ip routing command in the configuration.

Cisco 827 (R1)
Current configuration: 
! 
version 12.1 
service timestamps debug datetime msec 
service timestamps log datetime msec
! 
hostname R1 
! 
ip subnet-zero 
no ip routing 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 

!--- When the router is in bridge mode, the Ethernet 
!--- and ATM interfaces can have the same IP address.

 no ip directed-broadcast
 bridge-group 1 
! 
interface ATM0 
 mac-address 0030.96f8.45bd

!--- This is the MAC address of interface ethernet0.
!--- Use the IOS command show interface ethernet 0
!--- to get the MAC address.
 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 4/100 
  encapsulation aal5snap 
 ! 
 bundle-enable 
 bridge-group 1 
 hold-queue 224 in 
!
ip classless 
no ip http server 
! 
bridge 1 protocol ieee 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 
! 
end

Cisco 6400 NRP
Current configuration:
! 
version 12.0 
no service pad 
service timestamps debug datetime msec
service timestamps log datetime msec 
! 
hostname NRP
! 
redundancy 
 main-cpu 
  no auto-sync standard 
 no secondary console enable 
ip subnet-zero 
! 
interface Loopback1 
 ip address 10.0.0.2 255.0.0.0  
 no ip directed-broadcast 
! 
interface ATM0/0/0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
! 
interface ATM0/0/0.4 point-to-point 
 ip unnumbered Loopback1
 no ip directed-broadcast
 atm route-bridged ip 
 pvc 4/100
  encapsulation aal5snap 
! 
! 
interface Ethernet0/0/1 
 no ip address 
 no ip directed-broadcast 
! 
interface Ethernet0/0/0
 no ip directed-broadcast 
! 
interface FastEthernet0/0/0 
 no ip address 
 no ip directed-broadcast 
 full-duplex 
! 
ip classless 
ip route 10.0.0.1 255.255.255.255 ATM0/0/0.4 
! 
end 

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 23, 2007
Document ID: 12897