Guest

Cisco Unified MeetingPlace

Field Notice: FN - 60323 - MeetingPlace Web Incorrect NT Authentication Configuration Causes Internal Start -1 Error and Meeting Room Stuck at 1% Error


Revised July 07, 2005

May 12, 2004


Products Affected

Product

Comments

MeetingPlace Web

Versions: 4.3.0.x, 5.3.x

Problem Description

Note: This Field Notice is a legacy Latitude Field Notice that has been converted to the Cisco format so the information would remain available to their customers.

Cisco MeetingPlace Web Conferencing consists of multiple components, one of which is the Data Conferencing that provides DC (data conferencing) meetings and functionalities.

When the Cisco MeetingPlace Web machine is powered on, the MeetingPlace Web services come up and a special test DC meeting is created internally. If, for whatever reason, this special test DC meeting cannot be created, the Data Conferencing component will not work and no one will be able to join data conferences on this machine.

In the GWSIM eventlog, you will see:

Mon Mar 08 16:53:50 2004 mpagent (0x9dc) Warning:Error in internal start -1

Mon Mar 08 16:53:50 2004 mpagent (0x9dc) Information:Web API response : (null)

In the IIS log you will see the 401 error, which is "Access Denied" as defined by IIS.

CAUSE:

Cisco MeetingPlace Web makes an internal call to JengaX.dll to create the special DC test meeting.

With NT Authentication, if JengaX.dll access is set incorrectly, it will prevent MeetingPlace Web from creating the special DC test meeting. The file jengax.dll needs to be configured for Anonymous Access in the IIS Admin User Interface.

Problem Symptoms

There will be a Cisco MeetingPlace Web outage because people will be unable to attend data conferences on this machine.

Workaround/Solution

For MPWeb 4.3.x or below:

  1. Open IIS by going to Start\Programs\Administrative Tools\Internet Services Manager

  2. Expand the computer icon to view the Default Web Site (or the site that represents the MeetingPlace Web website)

  3. Under the Default Web Site, navigate to \MPWEB\Scripts\Jengax.dll.

  4. Right-click on Jengax.dll and select Properties.

  5. Select the File Security tab and under the Anonymous Access and Authentication Control section, click the Edit button.

    1. Ensure Anonymous Access is checked.

    2. Click the Edit button. Make sure the Account Used for Anonymous Access is set to the IUSR_hostname internet guest account.

    3. Check Allow IIS to control password.

    4. Click OK to close the Anonymous User Account window.

    5. In the Authenticated access section, Basic Authentication should be unchecked.

    6. Integrated Windows Authentication should be checked.

    7. Click OK, Apply, and then Ok to close the jengax.dll Properties window.

  6. Restart the MeetingPlace Web Conferencing service.

For MPWeb 5.3.x or above:

  1. Open IIS by going to Start\Programs\Administrative Tools\Internet Services Manager.

  2. Expand the computer icon to view the Default Web Site or the site that represents the MeetingPlace Web website.

  3. Under the Default Web Site, navigate to \MPWEB\Extensions.

  4. Right-click on \Extensions and select Properties.

  5. Select the Directory Security tab and under the Anonymous Access and Authentication Control section, click the Edit button.

    1. Ensure Anonymous Access is checked.

    2. Click the Edit button. Make sure the Account Used for Anonymous Access is set to the IUSR_hostname internet guest account.

    3. Check Allow IIS to control password.

    4. Click OK to close the Anonymous User Account window.

    5. If prompted by a pop-up window asking you whether you want to apply the change to a list of files inside this \Extensions folder, click Select All so that the change you have made are applied to all the files inside the \Extensions folder.

    6. In the Authenticated access section, Basic Authentication should be unchecked.

    7. Integrated Windows Authentication should be checked.

    8. Click OK, Apply, and then Ok to close the folder Properties window.

  6. Restart the MeetingPlace Web Conferencing service.

For More Information

If you require further assistance, or if you have any further questions regarding this field notice, please contact the Cisco Systems Technical Assistance Center (TAC) by one of the following methods:

Receive Email Notification For New Field Notices

Product Alert Tool - Set up a profile to receive email updates about reliability, safety, network security, and end-of-sale issues for the Cisco products you specify.