Introdução
Este documento descreve como resolver o erro do Cisco Umbrella Dashboard, "Insira um IP válido."
Pré-requisitos
Requisitos
Não existem requisitos específicos para este documento.
Componentes Utilizados
As informações neste documento são baseadas no Cisco Umbrella.
As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a rede estiver ativa, certifique-se de que você entenda o impacto potencial de qualquer comando.
Problema
Este artigo descreve como resolver o erro "Insira um IP válido" ao registrar uma rede no Umbrella Dashboard:
valid_IP.png
Solução
O Painel do Umbrella neste momento pode aceitar somente blocos de notação CIDR válidos. Isso não inclui suporte para intervalos semelhantes a CIDR (por exemplo, /30 é 4 IPs, portanto, endereço inicial +4) e pode retornar esse erro. Apenas correspondências de blocos CIDR exatos e válidos são aceitos no Painel no momento. Qualquer entrada que não seja uma correspondência exata pode gerar esse erro.
Para adicionar a rede desejada que seja um bloco CIDR parcial, você deve usar o bloco CIDR que descreve o bloco IP total da rede (utilizável mais broadcast) ou vários blocos que formam o intervalo de IP (como /31 e dois /32). Você pode usar qualquer site de terceiros para verificar se a notação CIDR que você está usando está correta. Um exemplo é esse site de terceiros que pode fornecer a notação CIDR correta com base no intervalo de rede. Você pode aplicar todos os registros à mesma política para garantir a aplicação consistente da política em todos os IPs.
Por exemplo:
- 10.0.0.1/30 (CIDR inválido, erro de IP válido)
Em vez disso, registre estes:
- 10.0.0.1/32
- 10.0.0.2/31
- 10.0.0.4/32
- 10.0.0.0/30 (CIDR válido, aceito)
Causa
O erro pode aparecer quando o intervalo de endereços IP que está sendo registrado tem uma notação CIDR inválida.