Introdução
Este documento descreve como solucionar problemas de um dispositivo virtual (VA) que não é exibido no Umbrella Dashboard após a implantação.
Pré-requisitos
Requisitos
Não existem requisitos específicos para este documento.
Componentes Utilizados
As informações neste documento são baseadas no Cisco Umbrella.
As informações neste documento foram criadas a partir de dispositivos em um ambiente de laboratório específico. Todos os dispositivos utilizados neste documento foram iniciados com uma configuração (padrão) inicial. Se a rede estiver ativa, certifique-se de que você entenda o impacto potencial de qualquer comando.
Problema
Você implantou um Virtual Appliance (VA), mas ele não aparece no Umbrella Dashboard em Implantação > Configuração > Sites e Ative Diretory. Além disso, o console do dispositivo virtual exibe o processo de sincronização como desabilitado e que o teste Atualizações falhou, como mostrado aqui:
115008641668
Alternando para as Atualizações: GET falhou no teste e pressionar Enter revela esta informação:
GET failed: GET from http://shared.opendns.com:80/enterprise/upgrade/va/mainline/MANIFEST failed: HTTP/1.1 404 Not Found
115008641688
Solução
Se você estiver implantando seus dispositivos virtuais no VMWare e testemunhar o comportamento descrito anteriormente, não faça alterações no arquivo OVA ou no modelo OVF incluído nesse arquivo. Implante o modelo OVF exatamente como mostrado na documentação do Cisco Umbrella.
Se você estiver implantando os dispositivos virtuais no Hyper-V, preste atenção especial na seção sobre importação de ambos os discos rígidos, conforme mostrado na documentação do Cisco Umbrella.
Causa
O comportamento descrito anteriormente indica que os dispositivos virtuais não foram implantados de acordo com a documentação existente.
Os dispositivos virtuais são baixados do Umbrella Dashboard como arquivos compactados (.ova para VMWare, .zip para Hyper-V). A extração desses arquivos revela os seguintes arquivos:
VMWare:
-
forwarder-va.vmdk (disco rígido)
-
dynamic.vmdk (disco rígido)
-
forwarder-va.ovf (arquivo de descrição)
-
forwarder-va.mf (arquivo de manifesto)
Hyper-V:
- Discos Rígidos Virtuais\forwarder-va.vhd (disco rígido)
- Discos Rígidos Virtuais\dynamic.vhd (disco rígido)
- config.xml (arquivo de configuração)
- Máquinas virtuais\[ALPHANUMERIC STRING].exp (arquivo de exportação)
O primeiro disco rígido listado para cada plataforma, forwarder-va.vmdk e forwarder-va.vhd, contém o software de encaminhador de DNS que aceita consultas de DNS de clientes e as encaminha para os resolvedores Umbrella Anycast. Este disco também contém o processo de sincronização que se conecta periodicamente com a API Umbrella.
O segundo disco rígido listado para cada plataforma, dynamic.vmdk e dynamic.vhd, contém informações específicas da organização que são exigidas pelo processo de sincronização do dispositivo virtual. Se o processo de sincronização do dispositivo virtual localizado no disco rígido do encaminhador-va não tiver as informações disponíveis no disco dinâmico, ele não poderá ser sincronizado com a API Umbrella e o processo permanecerá desabilitado. Além disso, o dispositivo virtual nunca se registra no Umbrella Dashboard e pode continuar a falhar no teste Updates mostrado nas capturas de tela anteriores.