De maximale transmissie-eenheid (MTU) definieert de grootste omvang van pakketten die een interface kan verzenden zonder dat het nodig is om te fragmenteren. IP-pakketten die groter zijn dan de MTU moeten IP-fragmentatieprocedures doorlopen.
Cisco ATM-routerinterfaces ondersteunen een MTU tussen 64 en 17966 bytes. Elke interface ondersteunt een standaard maximale pakketgrootte. De maximale waarde is bijvoorbeeld 9288 bytes op zowel de ATM-interfaceprocessor (AIP) als de netwerkprocessormodule (NP) en 4470 bytes op de PA-A3- en PA-A2-poortadapters.
In dit document worden de standaard MTU-waarden voor ATM-interfaces beoordeeld en wordt verduidelijkt wanneer een router de AAL5-oversized SDU's en de AAL5-lengteovertredingstellers verhoogt.
Er zijn geen specifieke vereisten van toepassing op dit document.
Dit document is niet beperkt tot specifieke software- en hardware-versies.
Raadpleeg Cisco Technical Tips Conventions (Conventies voor technische tips van Cisco) voor meer informatie over documentconventies.
De meeste Cisco ATM-routerinterfaces gebruiken een standaard MTU-grootte van 4470 bytes. Dit nummer is gekozen om exact overeen te komen met Fibre Distributed Data Interface (FDDI) en High-Speed Serial Interface (HSSI) interfaces voor autonome switching.
Gebruik de mtu-opdracht in de configuratiemodus van de interface om een niet-standaardwaarde te configureren. Merk op dat subinterfaces een waarde ondersteunen die verschilt van de hoofdinterface zolang de waarde van de hoofdinterface zo groot is als, of groter dan de grootste subinterface MTU.
7200#show interface atm 3/0
ATM3/0 is up, line protocol is up
Hardware is ENHANCED ATM PA
Internet address is 1.1.1.1/8
MTU 4470 bytes, sub MTU 1500, BW 149760 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Gebruik de opdracht ATM-interface tonen om de momenteel geconfigureerde waarde weer te geven.
7200#show atm interface atm 3/0 Interface ATM3/0: AAL enabled: AAL5 , Maximum VCs: 4096, Current VCCs: 2 Maximum Transmit Channels: 0 Max. Datagram Size: 4528 PLIM Type: SONET - 155000Kbps, TX clocking: LINE Cell-payload scrambling: ON sts-stream scrambling: ON 8359 input, 8495 output, 0 IN fast, 0 OUT fast, 0 out drop Avail bw = 155000 Config. is ACTIVE
Het commando show interface atm rapporteert twee tellers die vetgedrukt en relevant zijn voor een discussie over de pakketgrootte.
7200#show interface atm1/ima0
ATM1/IMA0.1 is up, line protocol is up
Hardware is ATM IMA
MTU 4470 bytes, BW 6000 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 2/255
Encapsulation ATM
1382 packets input, 399282 bytes
1558 packets output,205883 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 280
AAL5 SAR Timeouts : 0
AAL5 Oversized SDUs : 0
AAL5 length violation : 210285
AAL5 CPI Error : 302
Beide tellers verwijzen naar ATM-adaptatielaag 5 (AAL5). Ze omvatten gerouteerde of overbrugde protocolgegevenseenheden (PDU's) op de Common Part Convergence Sublayer (CPCS) van de ATM-stack. RFC 1483 definieert
het formaat van de AAL5-trailer, zoals in dit diagram wordt geïllustreerd.
Het veld met twee bytes in de AAL5-trailer geeft de grootte van het CPCS-PDU-laadveld aan. Twee bytes is 16 bits of een maximale lengtewaarde van 65.535 (216) octetten.
MTU definieert de grootte van het Layer 3-datagram. Een AAL5 service data unit (SDU) wordt gedefinieerd als het Layer 3 datagram plus de optionele Logical Link Control/Subnetwork Access Protocol (LLC/SNAP) header. Een AAL5-PDU wordt gedefinieerd als de gecombineerde AAL5-SDU plus de Acht-byte AAL5-trailer. Daarom kan een MTU van 9180 een AAL5-SDU van 9180 bytes en een AAL5-PDU van 9188 bytes produceren met de Acht-byte AAL5-trailer.
Wanneer een ATM-interface een pakket ontvangt dat groter is dan de MTU, verhoogt de router de Oversized SDU's-teller. De bovenmaatse SDU-teller is gedefinieerd in RFC 1695
.
aal5VccOverSizedSDUs OBJECT-TYPE
SYNTAX Counter32
MAX-ACCESS read-only
STATUS current
DESCRIPTION
"The number of AAL5 CPCS PDUs discarded
on this AAL5 VCC at the interface
associated with an AAL5 entity because the
AAL5 SDUs were too large."
::= { aal5VccEntry 5 }
RFC 1695 ondersteunt ook de mogelijkheid om afzonderlijke SDU-formaten voor verzending en ontvangst in te stellen met behulp van deze object-ID's:
atmVccAal5CpcsTransmitSduSize OBJECT-TYPE
SYNTAX INTEGER (1..65535)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"An instance of this object only exists when the
local VCL end-point is also the VCC end-point,
and AAL5 is in use.
The maximum AAL5 CPCS SDU size in octets that is
supported on the transmit direction of this VCC."
DEFVAL { 9188 }
:= { atmVclEntry 9 }
atmVccAal5CpcsReceiveSduSize OBJECT-TYPE
SYNTAX INTEGER (1..65535)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"An instance of this object only exists when the
local VCL end-point is also the VCC end-point,
and AAL5 is in use.
The maximum AAL5 CPCS SDU size in octets that is
supported on the receive direction of this VCC."
DEFVAL { 9188 }
::= { atmVclEntry 10 }
ATM-interfaces die RFC 1695 volgen, verhogen ook de ifInErrors-teller bij het detecteren van te grote SDU-fouten. Dit komt bovenop CRC-32 en SAR time-out fouten, die twee tellers ook gedefinieerd in de RFC zijn.
Een router verhoogt de AAL5-lengteovertredingsteller wanneer de berekende grootte van een opnieuw samengesteld pakket niet overeenkomt met de ontvangen waarde van het AAL5-lengteveld, ongeacht de MTU. Om te begrijpen hoe deze schendingen kunnen optreden, moet u begrijpen hoe een ontvangende ATM-interface de laatste cel van een frame herkent.
Een koptekst van een cel bevat een drie-bit payload type identifier (PTI) veld. Deze drie bits betekenen:
Bit 1—Geeft aan of de cel gebruikersgegevens of beheergegevens bevat.
Bit 2 - Geeft aan of de cel congestie ervaart tijdens de overdracht.
Bit 3 — Geeft aan of de cel de laatste cel is van een dataframe met een hogere laag. Wanneer dit item op 1 wordt ingesteld, wordt dit bit het einde van de markering (EOM) genoemd.
PTI-waarden van 001 of 011 markeren de laatste cel van een AAL5-PDU en geven aan dat de ontvangende ATM-interface moet worden gemonteerd. Tijdens periodes van congestie of foutcondities kan een ATM-link de laatste cel laten vallen. Als gevolg hiervan begint de ontvangende interface niet opnieuw te monteren totdat het einde van de markeercel van het tweede AAL5-pakket is ontvangen, wat een lengteovertreding oplevert.
In sommige gevallen rapporteert uw router een grote waarde voor de AAL5-lengteovertredingsteller en een veel kleinere waarde voor de AAL5 CRC-foutteller. Deze voorwaarde treedt op wanneer de ATM-interface een lengteoverschrijding declareert en een opnieuw samengesteld pakket laat vallen zonder de moeite te nemen om de CRC te controleren. Een ATM-interface controleert de CRC pas nadat deze bevestigt dat de pakketgrootte overeenkomt met het AAL5-lengteveld.
Het gebruik van een consistente en maximale MTU op meerdere interfaces in uw netwerk biedt de volgende voordelen:
Vermindert of elimineert fragmentatie. Grotere MTU's kunnen de TCP-prestaties verbeteren door fragmentatie te elimineren. Daarom kunnen toepassingen zoals Network File System (NFS) meer profiteren van hun grote native MTU's van ongeveer 8 kB.
Optimaliseert de grootte van de pakketbufferpools die zijn uitgehouwen in Packet Memory (MEMD) op de routegeheugenprocessor (RSP) op een switch uit de Cisco 7500-reeks. Op dit platform speelt MTU een belangrijke rol in buffersnijwerk. Concreet maakt dit platform gebruik van een buffersnijalgoritme dat vier bufferpools maakt op basis van MTU. Als alle interfaces dezelfde MTU gebruiken, creëert de router een grote pool van buffers van dezelfde grootte. Het gebruik van grote en sterk variërende MTU's op dit platform dwingt de Cisco IOS®-software om een klein aantal grote buffers te kerven, mogelijk met invloed op andere interfaces. Op het platform uit de 7500-reeks kan het aanpassen van de MTU leiden tot een kleiner aantal genegeerde invoerfouten. Raadpleeg Wat veroorzaakt een "%RSP-3-RESTART: cbus complex"?
Opmerking: Oorspronkelijk ondersteunde de AIP een MTU zo groot als 9180. De reden hiervoor is een goed begrip van architectuur. Het vermogen van ATM-interfaces om het geadverteerde maximale aantal actieve gelijktijdige virtuele circuits (VC's) te ondersteunen, is gebaseerd op statistische multiplexing en op het hebben van voldoende pakketbuffers om een aantal gelijktijdige herassemblages uit te voeren. Cisco beperkt de MTU-grootte tot ongeveer 9000 bytes op de AIP om de geadverteerde maximale actieve VC's-waarde van 2000 te ondersteunen.
Verhoogt de prestaties van de router door het aantal verwerkte pakketten te minimaliseren. De meeste prestatiekosten in routers hebben betrekking op "behandelde pakketten" in plaats van "overgedragen bytes". Een router verwerkt transitpakketten meestal in de interrupt-modus. Een grote MTU kan resulteren in hogere prestaties, omdat snellere CPU's niet noodzakelijkerwijs resulteren in snelle interrupt-intensieve bewerkingen.
In deze tabel staan verzoeken om commentaar (RFC's) met betrekking tot de grootte van een datagram.
Opmerking: Alle links in de tabel zijn RFC 1483
.
| verzoek om commentaar | Beschrijving |
|---|---|
| RFC 791 |
Definieert IP-fragmentatieprocedures. |
| RFC 1191 |
Definieer Path MTU discovery, een belangrijk mechanisme voor het verminderen van IP-fragmentatie in het internet. Dit mechanisme is belangrijk omdat ATM standaard MTU-groottes gebruikt die aanzienlijk verschillen van andere technologieën zoals Ethernet en FDDI. |
| RFC 1209 |
Specificeert een IP MTU boven SMDS van 9180 octetten. De Internet Engineering Task Force (IETF) gebruikte deze waarde en RFC om een MTU van 9180 octetten voor IP over ATM AAL5 in te stellen, zoals gedefinieerd in RFC 2225 |
| RFC 1626 |
Geef onder andere op dat ATM-interfaces moeten proberen te onderhandelen over de AAL CPCS-SDU-grootte met behulp van het ATM-signaleringsprotocol voor geschakelde virtuele circuits (SVC's). |
RFC 791 definieert
IP-fragmentatie en beschrijft de procedure als "Als de totale lengte kleiner is dan of gelijk is aan de maximale transmissie-eenheid, dient u dit datagram in bij de volgende stap in de dataverwerking; anders knipt u het datagram in twee fragmenten, het eerste fragment is de maximale grootte en het tweede fragment is de rest van het datagram."
Het debug-ip-pakket {host access-list} commando-uitvoer legt een ping vast tussen de twee hosts 192.168.1.51 en 192.168.1.254. Voor elk pakket meldt de router dat het twee fragmenten ontvangt: één 1500 bytes lang en één 48 bytes lang.
Let op: voordat u foutopsporingsopdrachten geeft, raadpleegt u Belangrijke informatie over foutopsporingsopdrachten.
*Mar 28 09:59:27.002: IP: s=192.168.1.51 (ATM4/0.3), d=192.168.1.254, len 1500, rcvd 4 *Mar 28 09:59:27.002: IP: recv fragment from 192.168.1.51 offset 0 bytes *Mar 28 09:59:27.002: IP: s=192.168.1.51 (ATM4/0.3), d=192.168.1.254, len 48, rcvd 4 *Mar 28 09:59:27.002: IP: recv fragment from 192.168.1.51 offset 1480 bytes
De router reageert met een echo-antwoord en meldt dat het twee fragmenten verzendt.
*Mar 28 09:59:27.002: ICMP: echo reply sent, src 192.168.1.254, dst 192.168.1.51 *Mar 28 09:59:27.002: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 1528, sending *Mar 28 09:59:27.002: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 1500, sending fragment *Mar 28 09:59:27.006: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 48, sending last fragment
Gigabit Ethernet-interfaces op Cisco Catalyst 5000 en 6000 switches ondersteunen jumboframes, die een MTU van 9.216 bytes hebben. Ondersteuning voor jumboframes voor de Catalyst 6000 ATM-module (WS-X6101) is beschikbaar vanaf Cisco IOS Software Release 12.1(10)E, volgens de Release Notes.
Het configureren van de MTU-grootte op de subinterface heeft geen invloed op de maximale framegrootte die kan worden overgedragen op een ATM-module van de Catalyst 6000-familie. De maximale framegrootte (9218 bytes) wordt geïnitialiseerd wanneer de module verschijnt en verandert niet wanneer de MTU-grootte verandert met behulp van de CLI.
Om de jumboframes te overbruggen, moet de functie voor de ATM-module op de supervisor-engine worden ingeschakeld met behulp van de opdracht jumbomod/poort instellen.
In Cisco IOS Software Releases eerder dan 12.1(10)E accepteren Catalyst ATM-modules de MTU-opdracht op de opdrachtregel en een maximale waarde van 9218 bytes. Zonder jumboframeondersteuning is deze configuratiewijziging echter misleidend. Het oorspronkelijke gebrek aan ondersteuning voor jumboframes komt voort uit het maximale aantal buffers dat voor elke VC wordt ondersteund.
ATM#show interface atm0
ATM0 is down, line protocol is down
Hardware is Catalyst 5000 ATM
MTU 1584 bytes, sub MTU 0, BW 156250 Kbit, DLY 80 usec, rely 255/255,
load 1/255
Encapsulation ATM, loopback not set, keepalive not supported
Encapsulation(s): AAL5, PVC mode
4096 maximum active VCs, 1024 VCs per VP, 0 current VCCs
VC idle disconnect time: 300 seconds
Signaling vc = 1, vpi = 0, vci = 5
UNI Version = 3.1, Link Side = user
PHY Type : SINGLE PHY; Link Status: DOWN
[snip]
De specificaties voor LANE versie 1 vereisen dat een SETUP-bericht het AAL-parameters-informatie-element (IE) bevat. In dit IE moet de oproepende partij of de ATM-interface van de bron de maximale CPCS-SDU-grootte doorsturen en de maximale CPCS-SDU-grootte achterwaarts opgeven. De ondersteunde AAL5 SDU Max octet waarden zijn 1516, 4544, 9234 en 18190. Vanaf Cisco IOS Software Release 12.1(10)E kunnen LEC's frames overdragen tot 9218 bytes.
Ondersteuning voor jumboframes staat al op de routekaart voor de verbeterde Gigabit Ethernet-lijnkaarten van 8540. Dergelijke ondersteuning wordt onderzocht voor de Gigabit Ethernet-kaarten voor de 8510. De ATM-routermodule 2 (ARM2) voor de 8540 ondersteunt nu een configureerbare MTU-grootte.
Voer deze stappen uit om de probleemoplossing te beperken als uw symptomen wijzen op een probleem met de grootte van de datagrammen.
Bevestig dat de juiste MTU zich op de hoofdinterface en op de subinterface bevindt.
Als pings boven een bepaalde pakketgrootte falen, kan het probleem gerelateerd zijn aan het vormgeven van het verkeer. Raadpleeg Inzicht in de VBR-nrt-servicecategorie en verkeersvorming voor geldautomaten. Bevestig dat de pakketten de bronrouter verlaten en/of voer de bestemmingsrouter in met de volgende opdrachten:
IP-foutopsporingspakket (alleen hosttoegangslijst)
Let op: Deze debug kan een grote hoeveelheid output op een productie-output produceren. Neem extra voorzorgsmaatregelen wanneer u deze foutopsporing inschakelt.
Foutopsporing ATM Packet Interface ATM Mod/Port VPI VCI
Fouten bij debuggen ATM
Controleer op een niet-nulwaarde voor de reuzenteller in de uitvoer van de show interface-geldautomaat. Telleren de reuzen de toename met je pings?
Voer de opdracht showbuffers uit en zoek naar waarden die niet gelijk zijn aan nul voor de tellers voor missen en mislukkingen. Bepaal of de tellers toenemen, vooral wanneer u de router pingt en de systeembuffers gebruikt. Raadpleeg Buffer Tuning voor meer informatie.
7500#show buffers
Buffer elements:
499 in free list (500 max allowed)
913677 hits, 0 misses, 0 created
Public buffer pools:
Small buffers, 104 bytes (total 480, permanent 480):
474 in free list (20 min, 1000 max allowed)
1036212 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Middle buffers, 600 bytes (total 360, permanent 360):
358 in free list (20 min, 800 max allowed)
635809 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Big buffers, 1524 bytes (total 360, permanent 360):
360 in free list (10 min, 1200 max allowed)
23457 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 40, permanent 40):
40 in free list (5 min, 1200 max allowed)
8969 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Large buffers, 5024 bytes (total 40, permanent 40):
40 in free list (3 min, 120 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Huge buffers, 18024 bytes (total 4, permanent 0):
3 in free list (3 min, 52 max allowed)
0 hits, 1 misses, 427 trims, 431 created
0 failures (0 no memory)
Voer de opdracht show ip interface atm uit en bepaal of Cisco Express Forwarding (CEF) is ingeschakeld. Zo ja, controleer dan de MTU-grootte waarnaar wordt verwezen in de aangrenzende vermelding van de bestemming.
router#show adj atm 5/0.1 interface
Protocol Interface Address
IP ATM5/0.1 point2point(6)
0 packets, 0 bytes
00040000
AAAA030000000800
CEF expires: 00:02:49
refresh: 00:00:49
ATM-PVC never
Fast adjacency enabled
IP redirect enabled
IP mtu 4470 (0x0)
Fixup disabled
Cisco bug ID CSCdv42095 (alleen geregistreerde klanten) lost een probleem op met falende pings voor pakketten groter dan 1498 bytes wanneer de MTU is geconfigureerd voor minder dan 1502 bytes op een overbrugde interface. De wijzigingen maken het mogelijk dat de maximale pakketgrootte gelijk is aan de MTU plus de maximale ATM-inkapseling in bytes. Stel de MTU in op 1502 als een tijdelijke oplossing.