Introduzione
In questo documento viene descritto come risolvere il problema relativo a "Non tutti i DNS funzionano correttamente" durante la configurazione di appliance virtuali (VA) in Cisco Umbrella.
Prerequisiti
Requisiti
Nessun requisito specifico previsto per questo documento.
Componenti usati
Le informazioni fornite in questo documento si basano su Cisco Umbrella.
Le informazioni discusse in questo documento fanno riferimento a dispositivi usati in uno specifico ambiente di emulazione. Su tutti i dispositivi menzionati nel documento la configurazione è stata ripristinata ai valori predefiniti. Se la rete è operativa, valutare attentamente eventuali conseguenze derivanti dall'uso dei comandi.
Problema
La configurazione delle appliance virtuali e la disposizione dei resolver DNS locali sono state completate correttamente e tutto sembra operativo. Tuttavia, nella console dell'appliance virtuale viene visualizzato un avviso giallo "Not All DNS ok" o rosso "All DNS Fail" (Tutti i DNS non riusciti):
360002644046
Soluzione
1. Verificare quali dei quattro sistemi di risoluzione Umbrella non sono raggiunti. Controllare il firewall per verificare se l'indirizzo IP è stato autorizzato.
- Se mancano dei messaggi, aggiungerli e verificare se il messaggio di errore non viene visualizzato. Se il problema persiste, contatta l'Assistenza Umbrella.
2. Controllare i prerequisiti dell'appliance virtuale e verificare che siano tutti soddisfatti.
Se sono stati verificati tutti i prerequisiti elencati nella documentazione di Umbrella, sono stati aggiunti gli indirizzi IP mancanti (se presenti) e il problema persiste, aprire il tunnel di supporto su richiesta sulla VSA in questione e contattare il supporto Umbrella.
Causa
"Not All DNS ok" è solitamente causato da qualcosa che blocca la comunicazione che va da VA a Umbrella. Il blocco è spesso causato da un firewall o da un dispositivo di sicurezza che impedisce alla query DNS sulla porta 53 di raggiungere uno dei quattro indirizzi IP richiesti dei resolver Umbrella:
- 208.67.220.220
- 208.67.222.222
- 208.67.220.222
- 208.67.222.220
Per visualizzare il messaggio di errore che viene bloccato, premere TAB. Verrà aperto il messaggio espanso con ulteriori dettagli:
360002644066
In questo caso, la connessione della ricerca UDP sulla porta 53 a 208.67.220.222 e 208.67.222.220 non è riuscita.