Introduzione
Questo documento descrive come risolvere i problemi relativi alle informazioni utente di Active Directory che non vengono passate dal modulo CSC al proxy SWG.
Prerequisiti
Requisiti
Nessun requisito specifico previsto per questo documento.
Componenti usati
Le informazioni fornite in questo documento si basano su Cisco Secure Client e Secure Web Gateway.
Le informazioni discusse in questo documento fanno riferimento a dispositivi usati in uno specifico ambiente di emulazione. Su tutti i dispositivi menzionati nel documento la configurazione è stata ripristinata ai valori predefiniti. Se la rete è operativa, valutare attentamente eventuali conseguenze derivanti dall'uso dei comandi.
Problema
Si stanno verificando problemi in cui le informazioni utente di Active Directory non vengono passate dal modulo Cisco Secure Client (CSC) (in precedenza AnyConnect) al proxy Secure Web Gateway (SWG). Di conseguenza, l'identità utente non viene segnalata a Cisco Umbrella Dashboard.
Soluzione
Per evitare questo comportamento, assicurarsi che solo un utente alla volta sia connesso.
Causa
Quando più utenti sono collegati al modulo CSC SWG, il modulo non è in grado di determinare quale utente ha la precedenza sull'altro, quindi nessuno degli utenti viene segnalato. Il file acumbrellaplugin.log genera un errore simile al seguente:
"Sembra che vi siano due utenti connessi."

Nota: Cisco ha annunciato la fine del ciclo di vita di Cisco AnyConnect nel 2023 e del client di roaming Umbrella nel 2024. Molti clienti Cisco Umbrella stanno già beneficiando della migrazione a Cisco Secure Client e si è incoraggiati ad avviare la migrazione il prima possibile per ottenere un'esperienza di roaming migliore. Ulteriori informazioni in questo articolo della Knowledge Base: Come installare Cisco Secure Client con il modulo Umbrella?