Le Maximum Transmission Unit (MTU) définit la plus grande taille des paquets qu’une interface peut transmettre sans avoir besoin de fragmenter. Les paquets IP plus grands que le MTU doivent passer par des procédures de fragmentation IP.
Les interfaces de routeur ATM Cisco prennent en charge une MTU comprise entre 64 et 17966 octets. Chaque interface prend en charge une taille de paquet maximale par défaut. Par exemple, la valeur maximale est de 9 288 octets sur le processeur d'interface ATM (AIP) et le module de processeur réseau (NP), et de 4 470 octets sur les cartes de ports PA-A3 et PA-A2.
Ce document examine les valeurs MTU par défaut pour les interfaces ATM et clarifie quand un routeur incrémente les SDU surdimensionnées AAL5 et les compteurs de violation de longueur AAL5.
Aucune exigence spécifique n'est associée à ce document.
Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.
Pour plus d'informations sur les conventions des documents, référez-vous à Conventions des conseils techniques Cisco.
La plupart des interfaces de routeur ATM Cisco utilisent une taille de MTU par défaut de 4 470 octets. Ce nombre a été choisi pour correspondre exactement aux interfaces FDDI (Fiber Distributed Data Interface) et HSSI (High-Speed Serial Interface) pour la commutation autonome.
Utilisez la commande mtu en mode de configuration d'interface pour configurer une valeur autre que la valeur par défaut. Notez que les sous-interfaces prennent en charge une valeur qui est différente de l'interface principale tant que la valeur de l'interface principale est aussi grande que, ou plus grande que le MTU de la plus grande sous-interface.
7200#show interface atm 3/0
ATM3/0 is up, line protocol is up
Hardware is ENHANCED ATM PA
Internet address is 1.1.1.1/8
MTU 4470 bytes, sub MTU 1500, BW 149760 Kbit, DLY 80 usec,
reliability 255/255, txload 1/255, rxload 1/255
Utilisez la commande show atm interface atm pour afficher la valeur actuellement configurée.
7200#show atm interface atm 3/0 Interface ATM3/0: AAL enabled: AAL5 , Maximum VCs: 4096, Current VCCs: 2 Maximum Transmit Channels: 0 Max. Datagram Size: 4528 PLIM Type: SONET - 155000Kbps, TX clocking: LINE Cell-payload scrambling: ON sts-stream scrambling: ON 8359 input, 8495 output, 0 IN fast, 0 OUT fast, 0 out drop Avail bw = 155000 Config. is ACTIVE
La commande show interface atm signale deux compteurs mis en évidence en gras et pertinents pour une discussion sur la taille de paquet.
7200#show interface atm1/ima0
ATM1/IMA0.1 is up, line protocol is up
Hardware is ATM IMA
MTU 4470 bytes, BW 6000 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 2/255
Encapsulation ATM
1382 packets input, 399282 bytes
1558 packets output,205883 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 280
AAL5 SAR Timeouts : 0
AAL5 Oversized SDUs : 0
AAL5 length violation : 210285
AAL5 CPI Error : 302
Les deux compteurs font référence à la couche d’adaptation ATM 5 (AAL5). Ils encapsulent des unités de données de protocole (PDU) routées ou pontées au niveau de la sous-couche de convergence de la partie commune (CPCS) de la pile ATM. Le document RFC 1483
définit le format de la queue de bande AAL5, comme illustré dans ce schéma.
Le champ de longueur de deux octets de la queue de bande AAL5 indique la taille du champ de données utiles CPCS-PDU. Deux octets représentent 16 bits ou une longueur maximale de 65 535 (216) octets.
MTU définit la taille du datagramme de couche 3. Une unité de données de service (SDU) AAL5 est définie comme le datagramme de couche 3 plus l'en-tête LLC/SNAP (Logical Link Control/Subnetwork Access Protocol) facultatif. Une unité de données de protocole AAL5 est définie comme l’unité de données de protocole AAL5 combinée avec la queue de bande AAL5 de huit octets. Par conséquent, une MTU de 9180 peut produire une SDU AAL5 de 9180 octets et une PDU AAL5 de 9188 octets avec la queue de bande AAL5 de huit octets.
Lorsqu’une interface ATM reçoit un paquet plus volumineux que le MTU, le routeur incrémente le compteur des unités SDU surdimensionnées. Le compteur de SDU de surdimensionnement est défini dans la RFC 1695
.
aal5VccOverSizedSDUs OBJECT-TYPE
SYNTAX Counter32
MAX-ACCESS read-only
STATUS current
DESCRIPTION
"The number of AAL5 CPCS PDUs discarded
on this AAL5 VCC at the interface
associated with an AAL5 entity because the
AAL5 SDUs were too large."
::= { aal5VccEntry 5 }
RFC 1695 prend également en charge la possibilité de définir des tailles de SDU de transmission et de réception distinctes à l'aide des ID d'objet suivants :
atmVccAal5CpcsTransmitSduSize OBJECT-TYPE
SYNTAX INTEGER (1..65535)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"An instance of this object only exists when the
local VCL end-point is also the VCC end-point,
and AAL5 is in use.
The maximum AAL5 CPCS SDU size in octets that is
supported on the transmit direction of this VCC."
DEFVAL { 9188 }
:= { atmVclEntry 9 }
atmVccAal5CpcsReceiveSduSize OBJECT-TYPE
SYNTAX INTEGER (1..65535)
MAX-ACCESS read-create
STATUS current
DESCRIPTION
"An instance of this object only exists when the
local VCL end-point is also the VCC end-point,
and AAL5 is in use.
The maximum AAL5 CPCS SDU size in octets that is
supported on the receive direction of this VCC."
DEFVAL { 9188 }
::= { atmVclEntry 10 }
Les interfaces ATM qui suivent la RFC 1695 incrémentent également le compteur ifInErrors lors de la détection d'erreurs SDU surdimensionnées. Cela s'ajoute aux erreurs CRC-32 et SAR timeout, qui sont deux compteurs également définis dans la RFC.
Un routeur incrémente le compteur de violation de longueur AAL5 lorsque la taille calculée d’un paquet réassemblé ne correspond pas à la valeur reçue du champ de longueur AAL5, quel que soit le MTU. Pour comprendre comment ces violations peuvent se produire, vous devez comprendre comment une interface ATM réceptrice reconnaît la dernière cellule d’une trame.
Un en-tête de cellule comprend un champ d'identificateur de type de charge utile (PTI) à trois bits. Ces trois bits signifient :
Bit 1 : indique si la cellule contient des données utilisateur ou des données de gestion.
Bit 2 : indique si la cellule subit un encombrement lors de la transmission.
Bit 3 : indique si la cellule est la dernière cellule d'une trame de données de couche supérieure. Lorsqu'il est défini sur 1, ce bit est appelé fin de marqueur (EOM).
Les valeurs PTI 001 ou 011 marquent la dernière cellule d’une unité de données de protocole AAL5 et indiquent à l’interface ATM réceptrice de commencer le réassemblage. Pendant les périodes d’encombrement ou d’erreur, une liaison ATM peut abandonner la dernière cellule. Par conséquent, l'interface de réception ne commence pas le réassemblage avant de recevoir la fin de la cellule de marqueur du second paquet AAL5, ce qui produit une violation de longueur.
Dans certains cas, votre routeur signale une valeur élevée pour le compteur de violations de longueur AAL5 et une valeur beaucoup plus petite pour le compteur d'erreurs CRC AAL5. Cette condition se produit lorsque l’interface ATM déclare une violation de longueur et abandonne un paquet réassemblé sans prendre la peine de vérifier le CRC. Une interface ATM vérifie le CRC uniquement après avoir confirmé que la taille du paquet correspond au champ de longueur AAL5.
L'utilisation d'une MTU cohérente et de taille maximale sur plusieurs interfaces de votre réseau offre les avantages suivants :
Réduit ou élimine la fragmentation. Des MTU plus importants peuvent améliorer les performances TCP en éliminant la fragmentation. Par conséquent, les applications telles que NFS (Network File System) peuvent tirer le meilleur parti de leurs grandes unités de transmission maximale (MTU) natives d'environ 8 Ko.
Optimise la taille des pools de tampons de paquets gravés dans la mémoire de paquets (MEMD) sur le processeur de commutation de routage (RSP) d’une plate-forme de la gamme Cisco 7500. Sur cette plate-forme, MTU joue un rôle important dans la découpe de tampon. Plus précisément, cette plate-forme utilise un algorithme de découpage de tampon qui crée quatre pools de tampons basés sur MTU. Si toutes les interfaces utilisent le même MTU, le routeur crée un grand pool de mémoires tampon de même taille. L'utilisation de MTU de grande taille et très variables sur cette plate-forme force le logiciel Cisco IOS® à graver un petit nombre de mémoires tampons de grande taille, ce qui peut avoir un impact sur d'autres interfaces. Sur la plate-forme de la gamme 7500, le réglage de la MTU peut entraîner un plus petit nombre d'erreurs d'entrée ignorées. Reportez-vous à Causes d'un « %RSP-3-RESTART : complexe cbus" ?
Remarque : à l'origine, l'AIP prenait en charge un MTU pouvant atteindre 9 180. La raison nécessite une compréhension de l'architecture. La capacité des interfaces ATM à prendre en charge le nombre maximal annoncé de circuits virtuels simultanés (VC) actifs est basée sur le multiplexage statistique et sur le fait d'avoir suffisamment de tampons de paquets pour effectuer un certain nombre de réassemblages simultanés. Cisco limite la taille MTU à environ 9 000 octets sur l'AIP pour prendre en charge la valeur maximale annoncée des circuits virtuels actifs de 2 000.
Augmente les performances du routeur en réduisant le nombre de paquets traités. La plupart des coûts liés aux performances des routeurs concernent les « paquets traités » plutôt que les « octets transférés ». Un routeur traite généralement les paquets de transit en mode d’interruption. Un MTU important peut entraîner des performances plus élevées, car des processeurs plus rapides n'entraînent pas nécessairement des opérations d'interruption rapides.
Ce tableau répertorie les demandes de commentaires (RFC) liées aux tailles de datagramme.
Remarque : tous les liens de la table sont RFC1483
.
| appel à commentaires | Description |
|---|---|
| RFC 791 |
Définit les procédures de fragmentation IP. |
| RFC 1191 |
Définissez la détection de MTU de chemin, un mécanisme clé pour réduire la fragmentation IP sur Internet. Ce mécanisme est important, car ATM utilise des tailles de MTU par défaut qui sont sensiblement différentes des autres technologies telles qu’Ethernet et FDDI. |
| RFC 1209 |
Spécifie un MTU IP sur SMDS de 9 180 octets. L'IETF (Internet Engineering Task Force) a utilisé cette valeur et la RFC pour définir une MTU de 9180 octets pour IP sur ATM AAL5, comme défini dans la RFC 2225 |
| RFC 1626 |
Spécifiez entre autres éléments que les interfaces ATM doivent tenter de négocier la taille CPCS-SDU AAL à l’aide du protocole de signalisation ATM pour les circuits virtuels commutés (SVC). |
Le document RFC 791
définit la fragmentation IP et décrit la procédure comme suit : « Si la longueur totale est inférieure ou égale à l'unité de transmission maximale, alors soumettre ce datagramme à l'étape suivante du traitement du datagramme ; sinon, découpez le datagramme en deux fragments, le premier étant la taille maximale et le second étant le reste du datagramme."
Le résultat de la commande debug ip packet {host access-list} capture une requête ping entre les deux hôtes 192.168.1.51 et 192.168.1.254. Pour chaque paquet, le routeur signale qu’il reçoit deux fragments : un de 1 500 octets et un de 48 octets.
Attention : avant d'émettre des commandes de débogage, consultez Informations importantes sur les commandes de débogage.
*Mar 28 09:59:27.002: IP: s=192.168.1.51 (ATM4/0.3), d=192.168.1.254, len 1500, rcvd 4 *Mar 28 09:59:27.002: IP: recv fragment from 192.168.1.51 offset 0 bytes *Mar 28 09:59:27.002: IP: s=192.168.1.51 (ATM4/0.3), d=192.168.1.254, len 48, rcvd 4 *Mar 28 09:59:27.002: IP: recv fragment from 192.168.1.51 offset 1480 bytes
Le routeur répond par une réponse d’écho et signale qu’il envoie deux fragments.
*Mar 28 09:59:27.002: ICMP: echo reply sent, src 192.168.1.254, dst 192.168.1.51 *Mar 28 09:59:27.002: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 1528, sending *Mar 28 09:59:27.002: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 1500, sending fragment *Mar 28 09:59:27.006: IP: s=192.168.1.254 (local), d=192.168.1.51 (ATM4/0.3), len 48, sending last fragment
Les interfaces Gigabit Ethernet sur les commutateurs Cisco Catalyst 5000 et 6000 prennent en charge les trames jumbo, qui ont une MTU de 9 216 octets. La prise en charge des trames jumbo pour le module ATM de la gamme Catalyst 6000 (WS-X6101) est disponible à partir de la version 12.1(10)E du logiciel Cisco IOS, conformément aux notes de version.
La configuration de la taille MTU sur la sous-interface n’affecte pas la taille de trame maximale pouvant être transférée sur un module ATM de la gamme Catalyst 6000. La taille de trame maximale (9 218 octets) est initialisée lorsque le module est activé et ne change pas lorsque la taille de MTU change à l'aide de l'interface de ligne de commande.
Pour relier les trames jumbo, la fonction doit être activée pour le module ATM sur le moteur de supervision à l'aide de la commande set port jumbo mod/port.
Dans les versions du logiciel Cisco IOS antérieures à 12.1(10)E, les modules ATM Catalyst acceptent la commande MTU au niveau de la ligne de commande et une valeur maximale de 9 218 octets. Cependant, sans la prise en charge des trames jumbo, cette modification de configuration est trompeuse. L'absence de prise en charge des trames jumbo à l'origine provient du nombre maximal de tampons pris en charge pour tout circuit virtuel.
ATM#show interface atm0
ATM0 is down, line protocol is down
Hardware is Catalyst 5000 ATM
MTU 1584 bytes, sub MTU 0, BW 156250 Kbit, DLY 80 usec, rely 255/255,
load 1/255
Encapsulation ATM, loopback not set, keepalive not supported
Encapsulation(s): AAL5, PVC mode
4096 maximum active VCs, 1024 VCs per VP, 0 current VCCs
VC idle disconnect time: 300 seconds
Signaling vc = 1, vpi = 0, vci = 5
UNI Version = 3.1, Link Side = user
PHY Type : SINGLE PHY; Link Status: DOWN
[snip]
La spécification LANE version 1 exige qu'un message SETUP inclue l'élément d'information (IE) des paramètres AAL. Dans cet IE, l'appelant ou l'interface ATM source doit spécifier la taille maximale CPCS-SDU en aval et la taille maximale CPCS-SDU en amont. Les valeurs d’octet AAL5 SDU Max prises en charge sont 1516, 4544, 9234 et 18190. Depuis la version 12.1(10)E du logiciel Cisco IOS, les LEC peuvent transférer des trames jusqu’à 9 218 octets.
La prise en charge des trames jumbo est déjà prévue pour les cartes de ligne Gigabit Ethernet améliorées 8540. Une telle prise en charge est en cours d'étude pour les cartes Gigabit Ethernet du 8510. Le module de routeur ATM 2 (ARM2) du 8540 prend désormais en charge une taille de MTU configurable.
Effectuez ces étapes pour affiner votre dépannage si vos symptômes indiquent un problème lié à la taille des datagrammes.
Vérifiez que le MTU correct se trouve sur l'interface principale et sur la sous-interface.
Si les requêtes ping au-dessus d'une certaine taille de paquet échouent, le problème peut être lié au formatage du trafic. Référez-vous à Présentation de la catégorie de service VBR-nrt et du formatage du trafic pour les circuits virtuels ATM. Vérifiez que les paquets quittent le routeur source et/ou entrez le routeur de destination à l’aide des commandes suivantes :
debug ip packet (liste d'accès hôte uniquement)
Attention : ce débogage peut produire une grande quantité de sortie sur une sortie de production. Prenez des précautions supplémentaires lorsque vous activez ce débogage.
debug atm packet interface atm mod/port vpi vci
debug atm errors
Recherchez une valeur non nulle pour le compteur de géants dans la sortie de show interface atm. Le compteur géant s'incrémente-t-il avec vos requêtes ping ?
Exécutez la commande show buffers et recherchez des valeurs non nulles pour les compteurs d'échecs et d'échecs. Déterminez si les compteurs s'incrémentent, en particulier lorsque vous envoyez une requête ping au routeur et que vous utilisez les tampons système. Référez-vous à Réglage de tampon pour plus d'informations.
7500#show buffers
Buffer elements:
499 in free list (500 max allowed)
913677 hits, 0 misses, 0 created
Public buffer pools:
Small buffers, 104 bytes (total 480, permanent 480):
474 in free list (20 min, 1000 max allowed)
1036212 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Middle buffers, 600 bytes (total 360, permanent 360):
358 in free list (20 min, 800 max allowed)
635809 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Big buffers, 1524 bytes (total 360, permanent 360):
360 in free list (10 min, 1200 max allowed)
23457 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
VeryBig buffers, 4520 bytes (total 40, permanent 40):
40 in free list (5 min, 1200 max allowed)
8969 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Large buffers, 5024 bytes (total 40, permanent 40):
40 in free list (3 min, 120 max allowed)
0 hits, 0 misses, 0 trims, 0 created
0 failures (0 no memory)
Huge buffers, 18024 bytes (total 4, permanent 0):
3 in free list (3 min, 52 max allowed)
0 hits, 1 misses, 427 trims, 431 created
0 failures (0 no memory)
Exécutez la commande show ip interface atm et déterminez si Cisco Express Forwarding (CEF) est activé. Si c'est le cas, vérifiez la taille MTU référencée dans l'entrée de contiguïté vers la destination.
router#show adj atm 5/0.1 interface
Protocol Interface Address
IP ATM5/0.1 point2point(6)
0 packets, 0 bytes
00040000
AAAA030000000800
CEF expires: 00:02:49
refresh: 00:00:49
ATM-PVC never
Fast adjacency enabled
IP redirect enabled
IP mtu 4470 (0x0)
Fixup disabled
L'ID de bogue Cisco CSCdv42095 (clients enregistrés uniquement) résout un problème d'échec des requêtes ping pour les paquets supérieurs à 1498 octets lorsque la MTU est configurée pour être inférieure à 1502 octets sur une interface pontée. Les modifications permettent d’obtenir une taille de paquet maximale égale à la MTU plus l’encapsulation ATM maximale en octets. Définissez le MTU sur 1502 comme solution de contournement.