Einleitung
In diesem Dokument wird die Behebung des Cisco Umbrella Dashboard-Fehlers "Geben Sie eine gültige IP-Adresse ein" beschrieben.
Voraussetzungen
Anforderungen
Es gibt keine spezifischen Anforderungen für dieses Dokument.
Verwendete Komponenten
Die Informationen in diesem Dokument basieren auf Cisco Umbrella.
Die Informationen in diesem Dokument beziehen sich auf Geräte in einer speziell eingerichteten Testumgebung. Alle Geräte, die in diesem Dokument benutzt wurden, begannen mit einer gelöschten (Nichterfüllungs) Konfiguration. Wenn Ihr Netzwerk in Betrieb ist, stellen Sie sicher, dass Sie die möglichen Auswirkungen aller Befehle kennen.
Problem
In diesem Artikel wird beschrieben, wie Sie den Fehler "Geben Sie eine gültige IP-Adresse ein" beheben, wenn Sie ein Netzwerk auf dem Umbrella Dashboard registrieren:
valid_IP.png
Lösung
Das Umbrella Dashboard kann zu diesem Zeitpunkt nur gültige CIDR-Notationsblöcke akzeptieren. Dies beinhaltet keine Unterstützung für CIDR-ähnliche Bereiche (z. B. /30 ist 4 IPs, also Startadresse +4) und kann diesen Fehler zurückgeben. Nur gültige, exakte CIDR-Blockübereinstimmungen werden zu diesem Zeitpunkt in das Dashboard übernommen. Jede Eingabe, die nicht exakt übereinstimmt, kann diesen Fehler verursachen.
Um Ihr gewünschtes Netzwerk, das ein Teil-CIDR-Block ist, hinzuzufügen, müssen Sie den CIDR-Block verwenden, der den gesamten IP-Block Ihres Netzwerks beschreibt (verwendbar plus Broadcast), oder mehrere Blöcke, die Ihren IP-Bereich bilden (wie ein /31 und zwei /32). Sie können auf jeder beliebigen Drittanbieter-Website überprüfen, ob die verwendete CIDR-Notation korrekt ist. Ein Beispiel ist diese Website eines Drittanbieters, die Ihnen die richtige CIDR-Notation basierend auf Ihrem Netzwerkbereich bereitstellen kann. Sie können alle Registrierungen auf dieselbe Richtlinie anwenden, um eine konsistente Anwendung von Richtlinien über alle IPs hinweg zu gewährleisten.
Beispiele:
- 10.0.0.1/30 (ungültiger CIDR, gültiger IP-Fehler)
Stattdessen sollten Sie diese registrieren:
- 10.0.0.1/32
- 10.0.0.2/31
- 10.0.0.4/32
- 10.0.0.0/30 (gültiger CIDR, akzeptiert)
Ursache
Der Fehler kann auftreten, wenn der registrierte IP-Adressbereich eine ungültige CIDR-Notation aufweist.