Einleitung
In diesem Dokument wird beschrieben, wie Sie "Nicht alle DNS in Ordnung" auflösen, wenn Sie virtuelle Appliances (VA) in Cisco Umbrella konfigurieren.
Voraussetzungen
Anforderungen
Es gibt keine spezifischen Anforderungen für dieses Dokument.
Verwendete Komponenten
Die Informationen in diesem Dokument basieren auf Cisco Umbrella.
Die Informationen in diesem Dokument beziehen sich auf Geräte in einer speziell eingerichteten Testumgebung. Alle Geräte, die in diesem Dokument benutzt wurden, begannen mit einer gelöschten (Nichterfüllungs) Konfiguration. Wenn Ihr Netzwerk in Betrieb ist, stellen Sie sicher, dass Sie die möglichen Auswirkungen aller Befehle kennen.
Problem
Sie haben Ihre virtuellen Appliances erfolgreich eingerichtet und Ihre lokalen DNS-Resolver angeordnet. Alles scheint betriebsbereit. In der Konsole der virtuellen Appliance wird dann jedoch eine gelbe Warnung "Nicht alle DNS-Einträge sind in Ordnung" oder eine rote Warnung "Alle DNS-Fehler" angezeigt:
360002644046
Lösung
1. Überprüfen Sie, welcher der vier Umbrella Resolver nicht erreicht wird. Überprüfen Sie Ihre Firewall, um festzustellen, ob diese IP-Adresse zulässig ist.
2. Überprüfen Sie die Voraussetzungen für die virtuelle Appliance, und stellen Sie sicher, dass alle Voraussetzungen erfüllt sind.
Wenn Sie alle in der Umbrella-Dokumentation aufgeführten Voraussetzungen überprüft haben, die fehlenden IP-Adressen (falls vorhanden) hinzugefügt haben und dieses Problem weiterhin besteht, öffnen Sie den On Demand Support Tunnel auf der betreffenden VA, und wenden Sie sich an den Umbrella Support.
Ursache
"Not All DNS ok" (Nicht alle DNS in Ordnung) wird normalerweise dadurch verursacht, dass die Kommunikation zwischen VA und Umbrella blockiert wird. Die Blockierung wird häufig durch eine Firewall oder eine Sicherheits-Appliance verursacht, die verhindert, dass die DNS-Abfrage auf Port 53 zu einer der vier erforderlichen IP-Adressen der Umbrella-Resolver gelangt:
- 208.67.220.220
- 208.67.222.222
- 208.67.220.222
- 208.67.222.220
Um zu sehen, welche davon blockiert werden, ziehen Sie die Tabulatortaste über die Fehlermeldung. Daraufhin wird die erweiterte Nachricht mit weiteren Details geöffnet:
360002644066
In diesem Fall konnte die UDP-Suche an Port 53 keine Verbindung mit den Ports 208.67.220.222 und 208.67.222.220 herstellen.