‘셀프 터널’로 장애관리 OK!

Troubleshooting

Static Routing

'셀프 터널'로 장애관리 OK!

IOS 초기 버전은 정적 라우팅 사용 … 순환 룩업도 적용 가능


중복 경로가 있는 네트워크 토폴로지에서 정적 경로(static route)를 사용함으로써 원격 사이트의 활성 라우터에서 생기는 LAN 인터페이스 오류는 두 개의 LAN 사이를 고립시킬 수 있다. 비록 라우터에 HSRP(Hot Standby Router Rpotocol)가 구성돼 있다고 해도 말이다. 시스코 IOS 소프트웨어 릴리즈 12.3 이후 버전에 있는 오브젝트 트랙킹 포 릴라이어블 스태틱 라우팅 백업(Object Tracking for Reliable Static Routing Backup)이나, ISP와 원격 사이트간의 터널링과 같은 기능들로 이런 문제를 극복할 수도 있다. 하지만 이런 기능을 사용할 수 없는 초기 버전의 IOS를 돌리고 있을 때는 순수 정적 라우팅(pure static routing) 전략을 사용하면 된다.


앗! 오류가 발생했다
그림 1. CUST1 이더넷 인터페이스 오류가 나면 고객 사이트가 서로 분리 된다.
<그림 1>에서 보면 ISP1과 ISP2가 ISP라우터며, 여기서 ISP1은 HSRP 활성 라우터로서 HSRP 트랙 명령어(track command)가 그 WAN 인터페이스(시리얼0/0)에 구성돼 있다. ISP 정책에 따르면, 원격 고객의 사이트로 가는 정적 경로만이 이러한 장비에 구성될 수 있다(터널도 또한 전혀 허용되지 않는다). CUST1과 CUST2는 고객 원격 사이트에 있는 라우터들로, CUST1은 활성 디바이스로 구성돼 있다. 만약 오류가 CUST의 이더넷 인터페이스에서 발생한다면, 다음과 같은 정적 경로가 ISP1에서 구성이 된다 : ip route 10.26.248.0 255.255.255.0 ser0/0 정상적인 상황이라면 10.26.248.0/24로 향하는 모든 트래픽은 ISP1을 통과해 흐른다. CUST1 인터페이스 오류가 발생할 때는 오류를 인식하지 못하는 ISP1이 여전히 활성 ISP 라우터로서 자신의 WAN 링크를 통해 CUST1으로 패킷을 계속 전송하며, 이때 WAN 링크 역시 활성 상태를 유지하고 있다. 10.26/248.0/24로 향하는 트래픽을 ISP1에서 ISP2로 리라우팅할 수 있는 메커니즘은 전혀 존재하지 않기 때문에, 두 개의 사이트는 분리가 된다. ISP의 개입 없이 제대로 된 라우팅 작동으로 복구하기 위해서는 예를 들어 CUST1을 꺼야만 한다. 이렇게 하면 ISP1으로 연결된 WAN 링크가 다운이 되고, HSRP 트랙 명령어에 따라 ISP2가 새로운 활성 라우터가 된다.


셀프 터널을 이용한 장애관리
수동 개입이 없이 이러한 문제를 해결하기 위해 '셀프 터널(self-tunnel)'이라는 개념이 도입되었다(그림 2).
셀프 터널은 같은 라우터가 출발지이자 목적지가 되는 터널이다. CUST1에 다음과 같은 구성 라인을 추가하라 :

interface Loopback6000
ip address 10.26.247.1 255.255.255.252
! see note
!
interface Tunnel1000
ip address 10.26.247.9 255.255.255.252
backup interface ser0/0
tunnel source 10.26.247.2
tunnel destination 10.26.247.2
no keep-alive
!
interface Tunnel2000
ip address 10.26.247.13 255.255.255.252
backup interface Loopback6000
tunnel source 192.168.60.61
no keep-alive
!
Interface FastEthernet0/0
IP address 10.26.248.202 255.255.255.0
Standby 1 ip 10.26.248.201
Standby 1 preempt
Standby 1 priority 105
Standby 1 track Serial0/0

Interface Serial0/0
IP address 172.16.1.2 255.255.255.252(omitted)

ip route 192.168.60.60 255.255.255.252
FastEthernet0/0 ! This subnet is used only to change Tunnel2000 interface status.

ip route 10.26.249.0 255.255.255.0
172.16.1.1

그림 2. 셀프 터널은 같은 라우터에 출발지와 목적지가 있는 터널이다.
이 메커니즘이 제대로 돌아가게 하기 위해서는 루프백6000(Loopback6000)이 CUST1이 라우팅할 수 있는 주요 네트워크들 가운데 속해 있지 않아야 한다(즉 디폴트 경로든 서브넷 마스크 < 30이 있는 10.26.247.0과 같은 정적 경로든 제시되지 않아야 한다. 예를 들어 10.26.0.0/16 경로가 라우팅 테이블에 나와 있다면 터널1000은 언제나 활성이기 때문에 메커니즘이 작동하지 못하게 된다). 정상적인 상황이라면 192.168.60.60/30으로 가는 정적 경로가 라우팅 테이블에 있을 때 터널2000은 활성이며(Fa0/0이 활성임을 감안할 때 사실이다), T2000의 백업 인터페이스 명령어는 루프백6000이 계속 다운돼 있도록 만든다. 루프백6000이 다운되면 터널1000 또한 다운되며(왜냐하면 루프백은 터널의 출발지이자 목적지기 때문에), 시리얼0/0은 활성이다(이것은 터널1000의 백업 인터페이스기 때문에).

패스트이더넷0/0이 오류가 날 때는 정적 경로가 라우팅 테이블에서 사라지며, T2000이 다운되기 때문에 루프백6000이 활성이 된다. 하지만 T1000도 활성이기 때문에 결국 백업 인터페이스 명령어 덕분에 시리얼0/0은 다운이 된다. 이런 메커니즘을 이행하고 나면 ISP1의 시리얼 인터페이스도 다운이 되기 때문에, 그 시리얼에 구성된 트랙 명령어에 의해 HSRP 상태 변화(활성>대기)가 트리거링된다. 따라서 인바운드(inbound) 트래픽은 결국 활성이 된 ISP2를 통해 전달이 된다. 이것은 기본적으로 연출되는 상황이다. 보다 복잡한 환경에서는 셀프 터널과 함께 더 많은 네트워킹 전략을 이행해야 할 것이다. 예를 들어 CUST1~2 아래서 역동적 프로토콜을 이용하는 네트워크 토폴로지로 순환 룩업(recursive lookup)을 사용해 비슷한 문제를 예방할 수 있다.


[readertips] 라우터 인스톨된 모듈 파악하기
라우터에 인스톨된 모듈을 알고 싶을 때 아래와 같은 명령어를 사용하면 빠르게 결과를 파악할 수 있다 :

router#show diag | include IC|NM-|Serial|FRU

PCB Serial Number : FOC09162SSN
Chassis Serial Number : FTX0926A00R
Product (FRU) Number : CISCO3845
PCB Seria Number : FOC09182ET4
Product (FRU) Number : CISCO3845-MB
Chassis Serial Number : FTX0926A00R
WIC Slot 0 :
VIC2 - BRI-NT/TE Voice daughter card (2 port)
PCB Serial Number : FOC0910103x
product (FRU) Number :VIC2-2BRI-NT/TE=

WIC Slot 1 :
VIC2 - BRI-NT/TE Voice daughter card (2 port)
PCB Serial Number : FOC0910103x
Product (FRU) Number : VIC2-2BRI-NT/TE=
WIC Slot 2:
PCB Serial Number :FOC092150QX
Product (FRU) Number :HWIC-4ESW
NM-IT3/E3 (clear/subrate) Port adapter, 1 port
PCB Serial Number FOC09140Y4S
Product (FRU) Number : NM-1T3/E3=


MICHAEL KUNZE 미카엘 쿤제, 독일

FRANCO CONT
필자 프랑코 콘트(FRANCO CONT)와 루카 피오리코 피오르고(LUCA PIORICO PIORGO)는 모두 이탈리아 로마의 텔레 시스테미 페로비아리(Tele Sistemi Ferroviari)사의 네트워크 엔지니어이다. 두 사람 모두 네트워크 업계에 10년 이상 몸담고 있다. 이메일 주소는 f.conti@tsf.itl.piorico@tsf.it이다.

추가자료


■ 시스코 애플리케이션 네트워킹 서비스/ 애플리케이션 가속화
    cisco.com/packet/182_5a1
■ '컨텐츠 네트워킹의 기초' 실바노 다 로스(시스코 프레스, ISBN: 1587052407)
    cisco.com/packet/182_5a2



Cisco에 문의하세요



Packet 지난 호 보기