[an error occurred while processing this directive]

Support

S Commands

Hierarchical Navigation

Downloads

 Feedback

Table Of Contents

S Commands

set as-path

set comm-list delete

set community

set dampening

set etxcommunity

set extcomm-list delete

set forwarding-address

set ip default next-hop

set ip next-hop

set ipv6 default next-hop

set ipv6 next-hop

set level

set local-preference

set metric

set metric-type

set origin

set tag

set vrf

set weight

set-attached-bit

set-overload-bit

shutdown (BGP)

shutdown (EIGRP)

shutdown (IS-IS)

shutdown (OSPF)

shutdown (OSPFv3)

shutdown (VRRP)

spf-interval

stub

summary-address

summary-address (OSPF)

summary-address (OSPFv3)

suppress-inactive


S Commands


This chapter describes the Cisco NX-OS unicast routing commands that begin with the letter S, except for the show commands.

set as-path

To modify an autonomous system path (as-path) for BGP routes, use the set as-path command in route-map configuration mode. To not modify the autonomous system (AS) path, use the no form of this command.

set as-path {tag | {prepend as-num[...as-num] | last-as num}}

no as-path {tag | {prepend as-num[...as-num] | last-as num}}

Syntax Description

tag

Converts the tag of a route into an autonomous system path. Applies only when redistributing routes into BGP.

prepend as-num

Appends the specified AS number to the autonomous system path of the route that is matched by the route map. Applies to both inbound and outbound BGP route maps. Range: 1 to 65535. You can configure more than on AS number.

last-as num

Prepends the last AS numbers to the as-path. Range: 1 to 10.


Defaults

Autonomous system path is not modified.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

You must enter the feature pbr global configuration mode command to enable PBR before entering the route-map command.

Use the route-map command to enter route-map configuration mode. Once you enter the route-map command, the prompt changes to the following:

switch(config-route-map)#

Once you enter route-map configuration mode, you can enter the set command.

The only global BGP metric available to influence the best path selection is the autonomous system path length. By varying the length of the autonomous system path, a BGP speaker can influence the best path selection by a peer further away.

By allowing you to convert the tag into an autonomous system path, the set as-path tag variation of this command modifies the autonomous system length. The set as-path prepend variation allows you to "prepend" an arbitrary autonomous system path string to BGP routes. Usually the local autonomous system number is prepended multiple times, increasing the autonomous system path length.

Examples

The following example converts the tag of a redistributed route into an autonomous system path:

switch(config)# route-map test1
switch(config-route-map)# set as-path tag

The following example prepends 100 to all the routes advertised to 10.108.1.1:

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set as-path prepend 100
!

switch(config)# router bgp 64496
switch(config-router)# neighbor 10.108.1.1 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor-af)# route-map set-as-path test1 out

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.


set comm-list delete

To remove communities from the community attribute of an inbound or outbound update, use the set comm-list delete command in route-map configuration mode. To remove a previous set comm-list delete command, use the no form of this command.

set comm-list community-list-name delete

no set comm-list

Syntax Description

community-list-name

A standard or expanded community list name. The name is any alphanumeric string up to 63 characters.


Command Default

No communities are removed.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

This set route-map configuration command removes communities from the community attribute of an inbound or outbound update using a route map to filter and determine the communities to be deleted. Depending upon whether the route map is applied to the inbound or outbound update for a neighbor, each community that passes the route map permit clause and matches the given community list will be removed from the community attribute being received from or sent to the Border Gateway Protocol (BGP) neighbor.

Each entry of a standard community list should list only one community when used with the set comm-list delete command. For example, in order to be able to delete communities 10:10 and 10:20, you must use the following format to create the entries:

switch(config)# ip community-list 500 permit 10:10
switch(config)# ip community-list 500 permit 10:20

The following format for a community list entry, while acceptable otherwise, does not work with the set comm-list delete command:

switch(config)# ip community-list 500 permit 10:10 10:20

When both the set community community-number and set comm-list delete commands are configured in the same sequence of a route map attribute, the deletion operation (set comm-list delete) is performed before the set operation (set community community-number).

This command does not require a license.

Examples

The following example shows how to remove communities from the community attribute of an inbound or outbound update:

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set comm-list list1 delete

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.


set community

To set the BGP communities attribute, use the set community route map configuration command. To delete the entry, use the no form of this command.

set community {none | {aa:nn [...aa:nn] | additive | local-as | no-advertise | no-export}}

no set community {none | {aa:nn | additive | local-as | no-advertise | no-export}}

Syntax Description

aa:nn

(Optional) Autonomous system (AS) number and network number entered in the 4-byte new community format. This value is configured with two 2-byte numbers separated by a colon. A number from 1 to 65535 can be entered each 2-byte number. A single community can be entered or multiple communities can be entered, each separated by a space.

You can configure one ore more AS numbers.

You can configure one or more keywords.

additive

(Optional) Adds to existing community.

You can configure one or more keywords.

local-AS

(Optional) Specifies the local-as community (well-known community). Routes with community are advertised to only peers that are part of the local autonomous system or to only peers within a subautonomous system of a confederation. These routes are not advertised external peers or to other subautonomous systems within a confederation.

You can configure one or more keywords.

no-advertise

(Optional) Specifies the no-advertise community (well-known community). Routes with this community are not advertised to any peer (internal or external).

You can configure one or more keywords.

no-export

(Optional) Specifies the no-export community (well-known community). Routes with this community are advertised to only peers in the same autonomous system or to only other subautonomous systems within a confederation. These routes are not advertised to external peers.

You can configure one or more keywords.

none

(Optional) Specifies the no community attribute.

You cannot configure any other keyword if you configure the none keyword.


Command Default

No BGP communities attributes exist.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

You must have a match clause (even if it points to a "permit everything" list) if you want to set tags.

Use the route-map global configuration command, and the match and set route map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route map configuration commands specify the redistribution set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

In the following example, routes that pass the autonomous system path access list 1 have the community set to 109:02 and 33:40. Routes that pass the autonomous system path access list 2 have the community set to no-export (these routes will not be advertised to any external BGP [eBGP] peers).

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:02 33:40
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community no-export

In the following similar example, routes that pass the autonomous system path access list 1 have the community set to 109:30. Routes that pass the autonomous system path access list 2 have the community set to local-as (the router will not advertise this route to peers outside the local autonomous system.

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set community 109:30 additive
switch(config-route-map)# exit
switch(config)# route-map test1 20 permit
switch(config-route-map)# match as-path 2
switch(config-route-map)# set community local-as

Related Commands

Command
Description

ip community-list

Creates a community list for BGP and control access to it.

match community

Matches a BGP community.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set comm-list delete

Removes communities from the community attribute of an inbound or outbound update.

show ip bgp community

Displays routes that belong to specified BGP communities.


set dampening

To set the BGP route dampening factors, use the set dampening route map configuration command. To disable this function, use the no form of this command.

set dampening half-life reuse suppress max-suppress-time

no set dampening

Syntax Description

half-life

Time (in minutes) after which a penalty is decreased. Once the route has been assigned a penalty, the penalty is decreased by half after the half life period (which is 15 minutes by default). The process of reducing the penalty happens every 5 seconds. Range: 1 to 45. Default: 15.

reuse

Unsuppresses the route if the penalty for a flapping route decreases enough to fall below this value. The process of unsuppressing routes occurs at 10-second increments. Range: 1 to 20000. Default: 750.

suppress

Suppresses a route when its penalty exceeds this limit. Range: 1 to 20000. Default: 2000.

max-suppress-time

Maximum time (in minutes) a route can be suppressed. Range: 1 to 255. Default: Four times the half-life value. If the half-life value is allowed to default, the maximum suppress time defaults to 60 minutes.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

When a BGP peer is reset, the route is withdrawn and the flap statistics cleared. In this instance, the withdrawal does not incur a penalty even though route flap dampening is enabled.

This command does not require a license.

Examples

The following example sets the half life to 30 minutes, the reuse value to 1500, the suppress value to 10000; and the maximum suppress time to 120 minutes:

switch(config)# route-map test1 10 permit
switch(config-route-map)# set dampening 30 1500 10000 120

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.


set etxcommunity

To set the Border Gateway Protocol (BGP) extended communities attribute, use the set extcommunity command. To delete the entry, use the no form of this command.

set extcommunity {none | {generic {transitive | nontransitive} aa4:nn [...aa4:nn] } | additive}

no set extcommunity {none | {generic {transitive | nontransitive} aa4:nn [...aa4:nn] } | additive}

Syntax Description

none

(Optional) Specifies the no community attribute.

generic

Specifies the generic specific extended community type.

transitive

Configures BGP to propagate the extended community attributes to other autonomous systems.

nontransitive

Configures BGP to propagate the extended community attributes to other autonomous systems.

aa4:nn

(Optional) Autonomous system number and network number. This value is configured with a 4-byte AS number and a 2-byte network number separated by a colon. The 4-byte AS number range is from 1 to 4294967295 in plaintext notation, or from 1.0 to 56636.65535 in AS.dot notation. You can enter a single community or multiple communities, each separated by a space.

additive

(Optional) Adds to existing community.


Command Default

No BGP communities attributes exist.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.2(1)

This command was introduced.


Usage Guidelines

Use the set extcommunity command in a route map to set the extended community attribute in a BGP route.

You must have a match clause in a route map (even if it points to a "permit everything" list) if you want to use set commands.

The set commands specify the set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

The following example shows how to configure a route map that sets the extended community to 1.5:

switch(config)# route-map test1 10 permit
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcommunity generic transitive 1.5
switch(config-route-map)# exit

Related Commands

Command
Description

ip extcommunity-list

Creates a community list for BGP and controls access to it.

route-map

Defines the conditions for redistributing routes from one routing protocol into another.

send-community

Configures BGP to propagate community attributes to BGP peers.

match extcommunity

Matches an extended community in a route map.

ip extcommunity-list

Creates a community list for BGP and controls access to it.


set extcomm-list delete

To remove extended communities from the extended community attribute of an inbound or outbound Border Gateway Protocol (BGP) update, use the set extcomm-list delete command. To remove a previous set extcomm-list delete command, use the no form of this command.

set extcomm-list community-list-name delete

no set extcomm-list

Syntax Description

community-list-name

Standard or expanded extended community list name. The name is any alphanumeric string up to 63 characters.


Command Default

No communities are removed.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.2(1)

This command was introduced.


Usage Guidelines

Use the set extcomm-list command in a route map to delete the extended community attribute in a BGP route.

You must have a match clause in a route map (even if it points to a "permit everything" list) if you want to use set commands.

The set commands specify the set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

When you configure both the set extcommunity community-number and set ext comm-list delete commands in the same sequence of a route map attribute, the deletion operation (set extcomm-list delete) is performed before the set operation (set extcommunity community-number).

This command does not require a license.

Examples

The following example shows how to remove extended communities from the extended community attribute of an inbound or outbound update:

switch(config)# route-map test1
switch(config-route-map)# match as-path 1
switch(config-route-map)# set extcomm-list list1 delete

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match extcommunity

Matches a BGP extended community.

set extcommunity

Sets the BGP extended communities attribute.


set forwarding-address

To set the OSPF forwarding address for redistributed type-5 LSAs, use the set forwarding-address route-map configuration mode command. To remove the address, use the no form of this command.

set forwarding-address

no forwarding-address

Syntax Description

This command has no arguments or keywords.

Command Default

No forwarding address is set as a default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

This command is used by the Open Shortest Path First (OSPF) to set the forwarding address in the for the redistributed type-5 LSAs. The value of the forwarding address specified by the autonomous system boundary router (ASBR) can be either 0.0.0.0 or non-zero. The 0.0.0.0 address indicates that the originating router (the ASBR) is the next hop. The forwarding address is determined by these conditions:

The forwarding address is set to 0.0.0.0 if the ASBR redistributes routes and OSPF is not enabled on the next hop interface for those routes. This is true in the figure if Router 1 does not have OSPF enabled on the Ethernet interface.

All of the following conditions must be met to set the forwarding address field to a non-zero address:

OSPF is enabled on the ASBR's next hop interface.

ASBR's next hop interface is non-passive under OSPF.

ASBR's next hop interface is not point-to-point.

ASBR's next hop interface is not point-to-multipoint.

Any other conditions besides those listed previously, set the forwarding address to 0.0.0.0.

This command does not require a license.

Examples

The following example shows how to set the forwarding address:

switch(config)# route-map test1 10 permit
switch(config-route-map)# set forwarding-address

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.


set ip default next-hop

To indicate where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination, use the set ip default next-hop command in route-map configuration mode. To delete an entry, use the no form of this command.

set ip default next-hop ip-address [...ip-address] [load-share]

no set ip default next-hop ip-address [...ip-address]

Syntax Description

ip-address

IP address of the next hop to which packets are output.The next hop must be an adjacent router. You can configure up to 32 IP addresses.

load-share

(Optional) Enables load sharing.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ip-address argument.

Use this command to provide certain users a different default route. If the software has no explicit route for the destination in the packet, then it routes the packet to this next hop. The first next hop specified with the set ip default next-hop command needs to be adjacent to the router. The optional specified IP addresses are tried in turn.

Use the ip policy route-map interface configuration command, the route-map global configuration command, and the match and set route-map configuration commands to define the conditions for policy routing packets. The ip policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which policy routing occurs. The set commands specify the set actions—the particular routing actions to perform if the criteria enforced by the match commands are met.

The set clauses can be used in conjunction with one another. They are evaluated in the following order:

1. set ip next-hop

2. set ip default next-hop


Note The set ip next-hop and set ip default next-hop are similar commands but have a different order of operations. Configuring the set ip next-hop command causes the system to use policy routing first and then use the routing table. Configuring the set ip default next-hop command causes the system to use the routing table first and then policy route the specified next hop.


This command does not require a license.

Examples

The following example shows how to configure a route map that sets the IPv6 default next-hop address.

switch(config)# ip access-list test
switch(config-ip-acl)# permit ip 192.0.2.0/24 any 
switch(config-ip-acl)# exit
switch(config)# route-map equal-access 
switch(config-route-map)# match ip address test
switch(config-route-map)# set ip default next-hop ip 192.0.2.3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ip policy route-map equal-access


Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.


set ip next-hop

To indicate where to output packets that pass a match clause of a route map for policy routing, use the set ip next-hop command in route-map configuration mode. To delete an entry, use the no form of this command.

set ip next-hop {ip-address [... ip-address] [load-share] | peer-address}

no set ip next-hop {ip-address [... ip-address] [load-share] | peer-address}

Syntax Description

ip-address

IP address of the next hop to which packets are output. It need not be an adjacent router. You can configure one or more IP addresses.

load-share

(Optional) Enables load sharing.

peer-address

Sets the next hop to be the BGP peering address.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ip-address argument.

Use the ip policy route-map interface configuration command, the route-map global configuration command, and the match and set route-map configuration commands to define the conditions for policy routing packets. The ip policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which policy routing occurs. The set commands specify the set actions—the particular routing actions to perform if the criteria enforced by the match commands are met.

If the first next hop specified with the set ip next-hop command is down, the optionally specified IP addresses are tried in turn.

When the set ip next-hop command is used with the peer-address keyword in an inbound route map of a BGP peer, the next hop of the received matching routes will be set to be the neighbor peering address, overriding any third-party next hops. So the same route map can be applied to multiple BGP peers to override third-party next hops.

When the set ip next-hop command is used with the peer-address keyword in an outbound route map of a BGP peer, the next hop of the advertised matching routes will be set to be the peering address of the local router, thus disabling the next hop calculation. The set ip next-hop command has finer granularity than the (per-neighbor) neighbor next-hop-self command, because you can set the next hop for some routes, but not others. The neighbor next-hop-self command sets the next hop for all routes sent to that neighbor.

The set clauses can be used in conjunction with one another. They are evaluated in the following order:

1. set ip next-hop

2. set ip default next-hop

This command does not require a license.

Examples

In the following example, three routers are on the same LAN (with IP addresses 10.1.1.1, 10.1.1.2, and 10.1.1.3). Each is in a different autonomous system. The set ip next-hop peer-address command specifies that traffic from the router (10.1.1.3) in remote autonomous system 64496 for the router (10.1.1.1) in remote autonomous system 64497 that matches the route map is passed through the router bgp 64498, rather than sent directly to the router (10.1.1.1) in autonomous system 100 over their mutual connection to the LAN.

switch(config)# router bgp 64498
switch(config-router)# neighbor 10.1.1.3 remote-as 64496
switch(config-router)# neighbor 10.1.1.3 route-map set-peer-address out
switch(config-router)# neighbor 10.1.1.1 remote-as 64497
!
switch(config)# route-map set-peer-address permit 10
switch(config-route-map)# set ip next-hop peer-address

Related Commands

Command
Description

ip policy route-map

Identifies a route map to use for policy routing on an interface.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match length

Bases policy routing on the Level 3 length of a packet.

route-map

Defines the conditions for redistributing routes from one routing protocol to another, or enables policy routing.

set ip default next-hop

Indicates where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination.


set ipv6 default next-hop

To indicate where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination, use the set ipv6 default next-hop command in route-map configuration mode. To delete an entry, use the no form of this command.

set ipv6 default next-hop ipv6-address [...ipv6-address] [load-share]

no set ipv6 default next-hop ipv6-address [...ipv6-address]

Syntax Description

ipv6-address

IPv6 address of the next hop to which packets are output.The next hop must be an adjacent router. You can configure up to 32 IPv6 addresses.

load-share

(Optional) Enables load sharing.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.2(1)

This command was introduced.


Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ipv6-address argument.

Use this command to provide certain users a different default route. If the software has no explicit route for the destination in the packet, then it routes the packet to this next hop. The first next hop specified with the set ipv6 default next-hop command needs to be adjacent to the router. The optional specified IP addresses are tried in turn.

Use the ipv6 policy route-map interface configuration command, the route-map global configuration command, and the match and set route-map configuration commands to define the conditions for policy routing packets. The ipv6 policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which policy routing occurs. The set commands specify the set actions—the particular routing actions to perform if the criteria enforced by the match commands are met.

The set clauses can be used in conjunction with one another. They are evaluated in the following order:

1. set ipv6 next-hop

2. set ipv6 default next-hop


Note The set ipv6 next-hop and set ipv6 default next-hop are similar commands but have a different order of operations. Configuring the set ipv6 next-hop command causes the system to use policy routing first and then use the routing table. Configuring the set ipv6 default next-hop command causes the system to use the routing table first and then policy route the specified next hop.


This command does not require a license.

Examples

The following example shows how to configure a route map that sets the IPv6 default next-hop address.

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any 
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access 
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 default next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ipv6 address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ipv6 next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ipv6 route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric

Redistributes routes with the metric specified.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Modifies an autonomous system path for BGP routes.

set community

Sets the BGP communities attribute.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set next-hop

Specifies the address of the next hop.

set tag

Sets a tag value of the destination routing protocol.

set weight

Specifies the BGP weight for the routing table.


set ipv6 next-hop

To indicate where to output packets that pass a match clause of a route map for policy routing, use the set ipv6 next-hop command in route-map configuration mode. To delete an entry, use the no form of this command.

sset ipv6 next-hop {ipv6-address [... ipv6-address] [load-share] | peer-address}

no set ipv6 next-hop {ipv6-address [... ipv6-address] [load-share] | peer-address}

Syntax Description

ipv6-address

IPv6 address of the next hop to which packets are output. It need not be an adjacent router. You can configure one or more IP addresses.

load-share

(Optional) Enables load sharing.

peer-address

Sets the next hop to be the BGP peering address.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.2(1)

This command was introduced.


Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the ipv6-address argument.

Use this command to provide certain users a different default route. If the software has no explicit route for the destination in the packet, then it routes the packet to this next hop. The first next hop specified with the set ipv6 default next-hop command needs to be adjacent to the router. The optional specified IP addresses are tried in turn.

Use the ipv6 policy route-map interface configuration command, the route-map global configuration command, and the match and set route-map configuration commands to define the conditions for policy routing packets. The ipv6 policy route-map command identifies a route map by name. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which policy routing occurs. The set commands specify the set actions—the particular routing actions to perform if the criteria enforced by the match commands are met.

The set clauses can be used in conjunction with one another. They are evaluated in the following order:

1. set ipv6 next-hop

2. set ipv6 default next-hop


Note The set ipv6 next-hop and set ipv6 default next-hop are similar commands but have a different order of operations. Configuring the set ipv6 next-hop command causes the system to use policy routing first and then use the routing table. Configuring the set ipv6 default next-hop command causes the system to use the routing table first and then policy route the specified next hop.


This command does not require a license.

Examples

The following example shows how to configure a route map that sets the IPv6 next-hop address.

switch(config)# ipv6 access-list test
switch(config-ipv6-acl)# permit ipv6 2001:0DB8::/48 any 
switch(config-ipv6-acl)# exit
switch(config)# route-map equal-access 
switch(config-route-map)# match ipv6 address test
switch(config-route-map)# set ipv6 next-hop 2001:0DB8::3
switch(config-route-map))# exit
switch(config)# interface externet 2/1
switch(config-if)# ipv6 policy route-map equal-access

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ipv6 address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ipv6 next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ipv6 route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set ipv6 default next-hop

Specifies the address of the next hop.


set level

To indicate where to import routes, use the set level command in route-map configuration mode. To delete an entry, use the no form of this command.

set level {level-1 | level-2 | level-1-2}

no set level {level-1 | level-2 | level-1-2}

Syntax Description

level-1

Imports routes into a Level 1 area.

level-2

Imports routes into a Level 2 subdomain.

level-1-2

Imports routes into Level 1 and Level 2.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

In the following example, routes will be imported into the Level 1 area:

switch(config-router)# route-map testcase
switch(config-route-map)# set level level-l

Related Commands

Command
Description

ip policy route-map

Identifies a route map to use for policy routing on an interface.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match length

Bases policy routing on the Level 3 length of a packet.

neighbor next-hop-self

Disables next hop processing of BGP updates on the router.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol to another, or enables policy routing.

set ip default next-hop

Indicates where to output packets that pass a match clause of a route map for policy routing and for which the Cisco NX-OS software has no explicit route to a destination.


set local-preference

To specify a preference value for the autonomous system path, use the set local-preference command in route-map configuration mode. To delete an entry, use the no form of this command.

set local-preference number-value

no set local-preference number-value

Syntax Description

number-value

Preference value. Range: 0 to 4294967295. Default: 100.


Command Default

Preference value of 100 by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

The preference is sent only to all routers in the local autonomous system.

You must have a match clause (even if it points to a "permit everything" list) if you want to set tags.

Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

You can change the default preference value with the bgp default local-preference command.

This command does not require a license.

Examples

The following example sets the local preference to 100 for all routes that are included in access list 1:

switch(config-router)# route-map map-preference
switch(config-route-map)# match as-path 1
switch(config-route-map)#  set local-preference 100

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match interface (IP)

Distributes routes that have their next hop out one of the interfaces specified.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (IP)

Redistributes routes with the metric specified.

match route-type (IP)

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map (IP)

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set automatic-tag

Automatically computes the tag value.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level (IP)

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric (BGP, OSPF, RIP)

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin (BGP)

Sets the BGP origin code.

set tag (IP)

Sets the value of the destination routing protocol.


set metric

To set the metric value for a routing protocol, use the set metric command in route-map configuration mode. To return to the default metric value, use the no form of this command.

set metric [+ | -] bandwidth-metric

set metric bandwidth-metric [delay-metric reliability-metric load-metric mtu]

no set metric

Syntax Description

+

(Optional) Adds to the existing delay metric value.

-

(Optional) Subtracts from the existing delay metric value.

bandwidth-metric

Interior Gateway Routing Protocol (IGRP) bandwith metric, in Kb/s. The range is from 0 to 4294967295..

delay-metric

(Optional) Interior Gateway Routing Protocol (IGRP) delay metric, in 10 microsecond units. The range is from 1 to 4294967295.

reliability-metric

(Optional) IGRP reliability metric. The range is from 0 to 255.

load-metric

(Optional) IGRP load metric. The range is from 1 to 255.

mtu

(Optional) IGRP maximum transmission unit (MTU) of the path. The range is from 1 to 4294967295.


Command Default

None

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.

4.1(2)

Added the + and - keywords.


Usage Guidelines

Use the set metric command to modify the IGRP metric values.


Note We recommend that you consult your Cisco technical support representative before changing the default value.


When you confiture the reliability-metric and the load-metric arguments, 255 means 100 percent reliability.

Use the + or - keywords to modify the existing delay metric value. You can modify only the delay metric with these keywords.

Use the route-map global configuration command and the match and set route-map configuration command to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

The following example shows how to set the bandwith metric value for the routing protocol to 100:

switch(config)# route-map set-metric
switch(config-route-map)# set metric 100

The following example shows how to increase the bandwith metric value for the routing protocol by 100:

switch(config)# route-map set-metric
switch(config-route-map)# set metric +100

Related Commands

Command
Description

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.


set metric-type

To set the metric type for the destination routing protocol, use the set metric-type command in route-map configuration mode. To return to the default, use the no form of this command.

set metric-type {internal | external | type-1 | type-2}

no set metric-type {internal | external | type-1 | type-2}

Syntax Description

internal

Specifies the Intermediate System-to-Intermediate System (IS-IS) internal metric, or the Interior Gateway Protocol (IGP) metric as the multi-exit discriminator (MED) for BGP.

external

Specifies the IS-IS external metric.

type-1

Specifies the Open Shortest Path First (OSPF) external Type 1 metric.

type-2

Specifies the OSPF external Type 2 metric.


Command Default

This command is disabled by default.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the route-map global configuration command with match and set route-map configuration commands to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.


Note This command is not supported for redistributing routes into Border Gateway Protocol (BGP).


This command does not require a license.

Examples

The following example sets the metric type of the destination protocol to OSPF external Type 1:

switch(config)# route-map map-type
switch(config-route-map)# set metric-type type-1

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.


set origin

To set the BGP origin code, use the set origin route-map configuration mode command. To delete the entry, use the no form of this command.

set origin {egp as-num [:as-num] | igp | incomplete}

no set origin

Syntax Description

egp as-num [:as-num]

Specifies the AS number for a remote exterior gateway protocol (EGP) system. You can specify the AS number as a 2-byte integer, or a 4-byte integer in aa:nn format. Range is from 1 to 65535.

igp

Specifies a local interior gateway protocol (IGP) system.

incomplete

Specifies an unknown heritage.


Command Default

Default origin, based on route in main IP routing table.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

You must have a match clause (even if it points to a "permit everything" list) if you want to set tags.

Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all of the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

The following example sets the origin of routes that pass the route map to IGP:

switch(config)# route-map set_origin
switch(config-route-map)# match as-path 10
switch(config-route-map)# set origin igp

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.



set tag

To set a tag value of the destination routing protocol, use the set tag command in route-map configuration mode. To delete the entry, use the no form of this command.

set tag tag-value

no set tag tag-value

Syntax Description

tag-value

Name for the tag. Integer from 0 to 4294967295.


Command Default

If not specified, the default action is to forward the tag in the source routing protocol onto the new destination protocol.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.

The set route-map configuration commands specify the redistribution set actions to be performed when all the match criteria of a route map are met. When all match criteria are met, all set actions are performed.

This command does not require a license.

Examples

The following example sets the tag value of the destination routing protocol to 5:

switch(config)# route-map test
switch(config-route-map)# set tag 5

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.


set vrf

To enable virtual routing/forwarding instance (VRF) selection within a route map for policy-based routing VRF selection, use the set vrf command in route-map configuration mode. To disable VRF selection within a route map, use the no form of this command.

set vrf {vrf-name | default | management}

no set vrf [vrf-name | default | management]

Syntax Description

vrf-name

Name assigned to the VRF.

default

Sets the VRF to the default VRF.

management

Sets the VRF to the management VRF.


Command Default

No default behavior or values

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

The set vrf route-map configuration command was introduced with the MPLS VPN—VRF Selection using Policy Based Routing feature to provide a PBR mechanism for VRF selection. This command is used to enable VRF selection by policy routing packets through a route map. The route map is attached to the incoming interface. Match criteria is defined in an IP access list or in an IP prefix list. Match criteria can also be defined based on packet length with the match length route map command. The VRF must be defined prior to the configuration of this command, and the ip policy route-map interface configuration command must be configured to enable policy routing under the interface or subinterface. If the VRF is not defined or if policy routing is not enabled, an error message will be printed in the console when you attempt to configure the set vrf command.


Note The set vrf command cannot be configured with the set ip default next-hop, and set ip next-hop policy routing commands because a packet cannot be set to an interface and the next hop cannot be changed when the VRF is specified. This is designed behavior. An error message will be printed in the console if you attempt to configure the set vrf command with any of the four above set clauses.


This command does not require a license.

Examples

The following example shows a route-map sequence that selects and sets a VRF based on match criteria defined in three different access lists. (The access list configuration is not shown in this example.) If the route map falls through and a match does not occur, the packet will be dropped if the destination is local.

switch(config)# route-map PBR-VRF-Selection permit 10
switch(config-route-map)# match ip address 40
switch(config-route-map)# set vrf VRF_1
!
switch(config)# route-map PBR-VRF-Selection permit 20
switch(config-route-map)# match ip address 50
switch(config-route-map)# set vrf VRF_2
!
switch(config)# route-map PBR-VRF-Selection permit 30
switch(config-route-map)# match ip address 60
switch(config-route-map)# set vrf VRF_3

Related Commands

Command
Description

access-list (IP standard)

Defines a standard IP access list.

debug ip policy

Displays IP policy routing packet activity.

ip policy route-map

Identifies a route map to use for policy routing on an interface.

ip vrf

Configures a VRF routing table.

ip vrf receive

Inserts the IP address of an interface as a connected route entry in a VRF routing table.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, or performs policy routing on packets.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.


set weight

To specify the BGP weight for the routing table, use the set weight command in route-map configuration mode. To delete an entry, use the no form of this command.

set weight number

no set weight [number]

Syntax Description

number

Weight value. Range: 0 to 65535.


Defaults

The weight is not changed by the specified route map.

Command Modes

Route-map configuration (config-route-map)

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

The implemented weight is based on the first matched autonomous system path. Weights indicated when an autonomous system path is matched override the weights assigned by global neighbor commands. In other words, the weights assigned with the set weight route-map configuration command override the weights assigned using the neighbor weight command.

This command does not require a license.

Examples

The following example sets the BGP weight for the routes matching the autonomous system path access list to 200:

switch(config)# route-map set-weight
switch(config-route-map)# match as-path 10
switch(config-route-map)# set weight 200

Related Commands

Command
Description

match as-path

Matches a BGP autonomous system path access list.

match community

Matches a BGP community.

match ip address

Distributes any routes that have a destination network number address that is permitted by a standard or expanded access list, and performs policy routing on packets.

match ip next-hop

Redistributes any routes that have a next hop router address passed by one of the access lists specified.

match ip route-source

Redistributes routes that have been advertised by routers and access servers at the address specified by the access lists.

match metric (

Redistributes routes with the metric specified.

match route-type

Redistributes routes of the specified type.

match tag

Redistributes routes in the routing table that match the specified tags.

route-map

Defines the conditions for redistributing routes from one routing protocol into another, or enables policy routing.

set as-path

Sets a BGP autonomous system path access list.

set community

Sets the BGP communities attribute.

set ip next-hop

Specifies the address of the next hop.

set level

Indicates where to import routes.

set local-preference

Specifies a preference value for the autonomous system path.

set metric

Sets the metric value for a routing protocol.

set metric-type

Sets the metric type for the destination routing protocol.

set origin

Sets the BGP origin code.

set tag

Sets the value of the destination routing protocol.


set-attached-bit

To set the attached (ATT) bit for Intermediate-System-to-Intermediate System (IS-IS), use the set-attached-bit command. To disable this function, use the no form of this command.

set-attached-bit

no set-attached-bit

Syntax Description

This command has no keywords or arguments.

Defaults

Enabled

Command Modes

Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.1(2)

This command was introduced.


Usage Guidelines

Use set-attached-bit command to configure whether to use a Level 1/Level 2 IS-IS router as the default router for Level 1 routers in the same area. If the set-attached-bit command is disabled, the "attached-bit" will not be advertised by the router in its Level 1 LSP, and other Level 1 routers in the area will not use this router as the default router outside the area.

This command requires the Enterprise Services license.

Examples

The following example shows how to unset the attached bit:

switch(config)# router isis Border1
switch(config-router)# no set-attached-bit

Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.


set-overload-bit

To configure the router to signal other routers not to use this router as an intermediate hop in their shortest path first (SPF) calculations, use the set-overload-bit command. To remove the designation, use the no form of this command.

set-overload-bit {always | {on-startup {seconds | wait-for bgp as-num[.as-num]}} [suppress [[interlevel] [external]]]

no set-overload-bit

Syntax Description

always

Sets the overload bit unconditionally.

on-startup seconds

Sets the overload bit at system startup. The overload bit remains set for the number of seconds configured. Range: 5 to 86400.

on-startup wait-for bgp

Causes the overload bit to be set upon system startup and remains set until BGP has converged.

as-num

AS number. Range: 1 to 65535

.as-num

(Optional) AS number. Range: 0 to 65535

suppress

(Optional) Causes the type of prefix identified by the subsequent keyword or keywords to be suppressed.

interlevel

(Optional) Prevents the IP prefixes that are learned from another IS-IS level from being advertised.

external

(Optional) Prevents the IP prefixes that are learned from other protocols from being advertised.


Command Default

The overload bit is not set by default.

Command Modes

Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

The set-overload-bit command forces the router to set the overload bit in its nonpseudonode link-state packets (LSPs). Normally, the setting of the overload bit is allowed only when a router runs into problems. For example, when a router is experiencing a memory shortage, it might be that the link-state database is not complete, resulting in an incomplete or inaccurate routing table. By setting the overload bit in its LSPs, other routers can ignore the unreliable router in their SPF calculations until the router has recovered from its problems.

The results are that no paths through this router are seen by other routers in the IS-IS area. However, IP and Connectionless Network Service (CLNS) prefixes directly connected to this router are reachable.

This command can be useful when you want to connect a router to an IS-IS network but do not want real traffic flowing through it under any circumstances. Examples situations are as follows:

A test router in the lab, connected to a production network.

A router configured as an LSP flooding server, for example, on a nonbroadcast multiaccess (NBMA) network, in combination with the mesh group feature.

A router that is aggregating virtual circuits (VCs) used only for network management. In this case, the network management stations must be on a network directly connected to the router with the set-overload-bit command configured.

Unless you specify the on-startup keyword, this command sets the overload bit immediately.

In addition to setting the overload bit, you might want to suppress certain types of IP prefix advertisements from LSPs. For example, allowing IP prefix propagation between level 1 and level 2 effectively makes a node a transit node for IP traffic, which might be undesirable. The suppress keyword used with the interlevel or external keyword (or both) accomplishes that suppression while the overload bit is set.

This command does not require a license.

Examples

The following example sets the overload bit upon startup and until BGP has converged:

switch(config)# router isis firstcompany

switch(config-router)# set-overload-bit on-startup wait for-bgp suppress interlevel external

Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.


shutdown (BGP)

To shut down an instance of the Border Gateway Protocol (BGP), use the shutdown command. To disable this function, use the no form of this command.

shutdown

no shutdown

Syntax Description

This command has no keywords or arguments.

Defaults

Enabled

Command Modes

Router configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.1(2)

This command was introduced.


Usage Guidelines

Use the shutdown command to disable an instance of BGP without removing the configuration.

This command requires the Enterprise Services license.

Examples

The following example shows how to disable BGP 64496:

switch(config)# router BGP 64496
switch(config-router)# shutdown

shutdown (EIGRP)

To shut down an instance of Enhanced Interior Gateway Routing Protocol (EIGRP), use the shutdown command. To disable this function, use the no form of this command.

shutdown

no shutdown

Syntax Description

This command has no keywords or arguments.

Defaults

Enabled

Command Modes

Address family configuration
Router configuration
Router VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the shutdown command to disable an instance of EIGRP without removing the configuration.

This command requires the Enterprise Services license.

Examples

The following example shows how to disable eigrp 209:

switch(config)# router eigrp 209
switch(config-router)# shutdown

shutdown (IS-IS)

To stop an IS-IS router process without removing the process configuration, use the shutdown command. To start a stopped IS-IS process, use the no form of this command.

shutdown

no shutdown

Syntax Description

This command has no arguments or keywords.

Command Default

No process is stopped.

Command Modes

Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Entering the shutdown command stops a router process but does not remove any configuration parameters. The shutdown command is displayed in the running configuration file when enabled.

This command requires the Enterprise Services license.

Examples

The following example stops an active IS-IS process:

switch(config)# router isis firstcompany
switch(config-router)# shutdown

The following example starts a stopped a IS-IS process:

switch(config)# router isis firstcompany
switch(config-router)# no shutdown

Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.


shutdown (OSPF)

To stop an Open Shortest Path First (OSPF) instance without removing the configuration, use the shutdown command. To start a stopped OSPF instance, use the no form of this command.

shutdown

no shutdown

Syntax Description

This command has no arguments or keywords.

Command Default

No process is stopped.

Command Modes

Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Entering the shutdown command stops a router process but does not remove any configuration parameters. The shutdown command is displayed in the running configuration file when enabled.

This command requires the Enterprise Services license.

Examples

This example stops an active OSPF instance:

switch(config)# router ospf firstcompany
switch(config-router)# shutdown

Related Commands

Command
Description

feature ospf

Enables OSPF on the router.

router ospf

Configures an OSPF instance.


shutdown (OSPFv3)

To stop an Open Shortest Path First (OSPFv3) instance without removing the configuration, use the shutdown command. To start a stopped OSPF instance, use the no form of this command.

shutdown

no shutdown

Syntax Description

This command has no arguments or keywords.

Command Default

No process is stopped.

Command Modes

Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Entering the shutdown command stops a router process but does not remove any configuration parameters. The shutdown command is displayed in the running configuration file when enabled.

This command requires the Enterprise Services license.

Examples

This example stops an active OSPFv3 instance:

switch(config)# router ospfv3 firstcompany
switch(config-router)# shutdown

Related Commands

Command
Description

feature ospfv3

Enables OSPFv3 on the router.

router ospv3f

Configures an OSPF v3 instance.


shutdown (VRRP)

To disable a Virtual Router Redundancy Protocol (VRRP) configuration, use the shutdown command. To enable a VRRP configuration, use the no form of this command.

shutdown

no shutdown

Syntax Description

This command has no arguments or keywords.

Defaults

Disabled

Command Modes

VRRP configuration mode

Supported User Roles

network-admin
VDC administrator

Command History

Release
Modified

4.0(1)

This command was introduced.


Usage Guidelines

Shut down the virtual router before configuring the virtual router parameters; you can only configure the virtual router after it is in administrative shut down state. Enter the no shutdown command to update the virtual router state after completing configuration.

This command does not require a license.

Examples

This example shows how to shut down a VRRP group:

switch(config-if)# vrrp 45
switch(config-if-vrrp)# shutdown
switch(config-if-vrrp)# address 6.6.6.45
switch(config-if-vrrp)# no shutdown

Related Commands

Command
Description

feature vrrp

Enables VRRP.

show vrrp

Displays VRRP configuration information.

clear vrrp

Clears all the software counters for the specified virtual router.


spf-interval

To configure the minimum interval between arrivals of a link-state advertisement (LSA), use the spf-interval command. To return to the default setting, use the no form of this command.

spf-interval [level-1 | level-2] spf-max-wait [spf-initial-wait spf-second-wait]

no spf-interval

Syntax Description

level-1

Specifies the shortest path first (SPF) level-1 interval.

level-2

Specifies the SPF level-2 interval.

spf-max-wait

Maximum interval (in milliseconds) between two consecutive SPF calculations. Range: 500 to 65535.

spf-initial-wait

Initial SPF calculation delay (in milliseconds) after a topology change. Range: 50 to 65535.

spf-second-wait

Hold time between the first and second SPF calculation (in milliseconds). Range: 50 to 65535.


Command Default

None

Command Modes

Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

An LSA is used to advertise connected networks.

This command requires the Enterprise Services license.

Examples

The following example shows how to set the minimum interval time between arrivals of a LSA:

switch(config)# router isis firstcompany
switch(config-router)# spf-interval level-1 500 500 500

Related Commands

Command
Description

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.



stub

To configure a router as a stub using the Enhanced Interior Gateway Routing Protocol (EIGRP), use the stub command. To disable the EIGRP stub routing feature, use the no form of this command.

stub [direct | leak-map map-name| receive-only | redistributed]

no stub [direct | leak-map map-name| receive-only | redistributed]]

Syntax Description

direct

(Optional) Advertises directly connected routes.

leak-map map-name

(Optional) Allows dynamic prefixes based on the leak map.

receive-only

(Optional) Sets the router as a receive-only neighbor.

redistributed

(Optional) Advertises redistributed routes from other protocols and autonomous systems.


Command Default

Disabled

Command Modes

Address-family configuration
Router configuration
Router VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the stub command to configure a router as a stub where the router directs all IP traffic to a distribution router.

The direct keyword permits EIGRP stub routing to advertise connected routes. This option is enabled by default.

The receive-only keyword restricts the router from sharing any of its routes with any other router in that EIGRP autonomous system, and the receive-only keyword does not permit any other option to be specified because it prevents any type of route from being sent.

The redistributed keyword permits the EIGRP Stub Routing feature to send other routing protocols and autonomous systems. Without the configuration of this option, EIGRP will not advertise redistributed routes.

If you use any of these four keywords (direct, leak-map, receive-only, redistributed) with the stub command, only the route types specified by the particular keyword(s) are advertised.

This command requires the Enterprise Services license.

Usage Guidelines

The following example shows how to configure the router as a receive-only neighbor:

switch(config)# router eigrp 1
switch(config-router)# stub receive-only

summary-address

To create the IS-IS aggregate addresses, use the summary-address command. To remove the aggregate address, use the no form of this command.

summary-address {ip-addr | ip-prefix/length | ipv6-addr | ipv6-prefix/length} level

Syntax Description

ip-addr

IP address of the neighbor in this format: A.B.C.D.

ip-prefix/length

IP prefix and the length of the IP prefix. The length of the IPv6 prefix is a decimal value that indicates how many of the high-order contiguous bits of the address comprise the prefix (the network portion of the address). A slash mark must precede the decimal value. Use this format: A.B.C.D/length.

ipv6-addr

IPv6 address of the neighbor in this format: A:B::C:D.

ipv6-prefix/length

IPv6 prefix and the length of the IPv6 prefix for neighbors in this format: A:B::C:D/length.

level

Level number. Default: All routes are advertised individually. Valid values are as follows:

level-1—Summarizes the IP address into the level-1 area. Only routes redistributed into level 1 are summarized with the configured address and mask value.

level-1-2—Summarizes the IP address into the level-1 and level-2 areas. Summary routes are applied when redistributing routes into level-1 and level-2 IS-IS, and when level-2 IS-IS advertises level-1 routes as reachable in its area.

level-2—Summarizes the IP address into the level-2 area. Routes learned by level-1 routing are summarized into the level-2 backbone with the configured address and mask value. Redistributed routes into level-2 IS-IS will be summarized also.


Command Default

None

Command Modes

Address-family configuration
Router configuration
VRF configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Multiple groups of addresses can be summarized for a given level. Routes learned from other routing protocols can also be summarized. The metric used to advertise the summary is the smallest metric of all the more specific routes. This command helps reduce the size of the routing table.

This command also reduces the size of the link-state packets (LSPs) and thus the link-state database (LSDB). It also helps network stability because a summary advertisement is depending on many more specific routes. A single route flap does not cause the summary advertisement to flap in most cases.

Note that when using summary addresses, other routes might have less information to calculate the most optimal routing table for all individual destinations are used.

This command requires the Enterprise Services license.

Examples

The following example redistributes directly connected routes into IS-IS. This example advertises only 10.1.0.0 into the IS-IS level-1 link-state protocol data unit (PDU). The summary address is tagged with 100.

switch(config)# router isis 100
switch(config-router)# address-family ipv4 unicast
switch(config-router-af)# redistribute direct route-map CORE1
switch(config-router-af)# summary-address 10.1.0.0 255.255.0.0

Related Commands

Command
Description

address-family

Enters the address family mode or a VRF address-family mode.

feature isis

Enables IS-IS on the router.

router isis

Enables IS-IS.


summary-address (OSPF)

To create aggregate addresses for the Open Shortest Path First (OSPF) protocol, use the summary-address command. To return to the default, use the no form of this command.

summary-address ip-prefix/length [not-advertise] [tag tag]

no summary-address ip-prefix/length [not-advertise] [tag tag]

Syntax Description

ip-prefix/length

IP prefix designated for a range of addresses, including the prefix length. Specify ip-prefix as an IP address. Specify length as a number from 1 to 31.

not-advertise

(Optional) Suppress routes that match the specified prefix/length pair.

tag tag

(Optional) Tag value that can be used as a "match" value for controlling redistribution using route maps. The range is from 1 to 65535.


Defaults

None

Command Modes

Router configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the summary-address command to create an aggregate address to replace a series of more-specific addresses. The metric used to advertise the summary is the smallest metric of all the more specific routes.

Use this command to help reduce the size of the routing table and allow an OSPF Autonomous System Boundary Router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address.

This command requires the Enterprise Services license.

Examples

The following example shows how to configure the summary address 192.0.0.0 to include address 192.0.1.0, 192.0.2.0, 192.0.3.0, and so on. Only the address 192.0.0.0 is advertised in an external link-state advertisement.

switch(config)# router ospf 201
switch(config-router)# summary-address 192.0.0.0/16

Related Commands

Command
Description

redistribute (OSPF

Redistributes external routing protocol routes into OSPF.


summary-address (OSPFv3)

To create aggregate addresses for the Open Shortest Path First version 3 (OSPFv3) protocol, use the summary-address command. To return to the default, use the no form of this command.

summary-address ipv6-prefix/length [not-advertise] [tag tag]

no summary-address ipv6-prefix/length [not-advertise] [tag tag]

Syntax Description

ipv6-prefix/length

IP prefix designated for a range of addresses, including the prefix length. Specify ip-prefix as an IPv6 address. Specify length as a number from 1 to 128.

not-advertise

(Optional) Suppress routes that match the specified prefix/length pair.

tag tag

(Optional) Tag value that can be used as a "match" value for controlling redistribution using route maps. The range is from 1 to 65535.


Defaults

None

Command Modes

Address-family configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the summary-address command to create an aggregate address to replace a series of more-specific addresses. The metric used to advertise the summary is the smallest metric of all the more specific routes.

Use this command to help reduce the size of the routing table and allow an OSPFv3 Autonomous System Boundary Router (ASBR) to advertise one external route as an aggregate for all redistributed routes that are covered by the address.

This command requires the Enterprise Services license.

Examples

This example shows how to configure the summary address 192.0.0.0 to include address 192.0.1.0, 192.0.2.0, 192.0.3.0, and so on. Only the address 192.0.0.0 is advertised in an external link-state advertisement.

switch(config)# router ospfv3 201
switch(config-router)# address-family ipv6 unicast
switch(config-router)# summary-address 2001:0DB8::0/16

Related Commands

Command
Description

redistribute (OSPFv3

Redistributes external routing protocol routes into OSPFv3.


suppress-inactive

To advertise the active routes to a Border Gateway Protocol (BGP) peer only, use the suppress-inactive command. To remove the restriction, use the no form of this command. To return to the default setting, use the default form of this command.

suppress-inactive

no | default suppress-inactive

Syntax Description

This command has no keywords or arguments.

Command Default

BGP advertises routes to a peer as soon as they are installed in the local routing table, even if the routes are not the active routes in the table.

Command Modes

Neighbor address-family configuration

Supported User Roles

network-admin
vdc-admin

Command History

Release
Modification

4.0(1)

This command was introduced.


Usage Guidelines

Use the suppress-inactive command to advertise only active routes to a BGP peer.

This command requires the Enterprise Services license.

Examples

This example shows how to create a summary address. The path advertised for this route is an autonomous system set consisting of all elements contained in all paths that are being summarized.

switch(config)# router bgp 64496
switch(config-router)# neighbor 192.0.2.1/8 remote-as 64497
switch(config-router-neighbor)# address-family ipv4 unicast
switch(config-router-neighbor af)# suppress-inactive

Related Commands

Command
Description

route-map map-name

Creates a route map.



[an error occurred while processing this directive]