Guest

Support

Configuring Dial Backup and Remote Management

 Feedback

Table Of Contents

Configuring Dial Backup and Remote Management

Dial Backup Feature Activation Methods

Backup Interfaces

Configuring Backup Interfaces

Floating Static Routes

Configuring Floating Static Routes

Dialer Watch

Configuring Dialer Watch

Dial Backup Feature Limitations

Configuration Example

Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port

Configuration Tasks

Configuration Example

Configuring Dial Backup and Remote Management Through the ISDN S/T Port

Configuration Tasks

Configure ISDN Settings

Configure the Aggregator and ISDN Peer Router


Configuring Dial Backup and Remote Management


The Cisco 800 series access routers support dial-in (for remote management) and dial-out (for dial backup) capabilities. By allowing you to configure a backup modem line connection, the Cisco 800 series access routers provide protection against WAN downtime. Dial backup is inactive by default, and must be configured to be active.

Dial backup functions can be configured as follows:

Through the auxiliary port on any Cisco 870 series router

Through the ISDN S/T port on a Cisco 876 with an advanced enterprise (c870-adventerprisek9-mz) image

Remote management functions can be configured as follows:

Through the auxiliary port on any Cisco 850 or Cisco 870 series router

Through the ISDN S/T port on the Cisco 876 and Cisco 878 routers


Note The console port and the auxiliary port in the Cisco IOS software configuration are on the same physical RJ-45 port; therefore, both ports cannot be activated simultaneously, and the command-line interface (CLI) must be used to enable the desired function.


This chapter contains the following topics:

Dial Backup Feature Activation Methods

Dial Backup Feature Limitations

Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port

Configuring Dial Backup and Remote Management Through the ISDN S/T Port

Dial Backup Feature Activation Methods

Three methods are available to activate the dial backup feature:

Backup Interfaces

Floating Static Routes

Dialer Watch

Backup Interfaces

When the router receives an indication that the primary line is down, a backup interface is brought up. You can configure the backup interface to go down once the primary connection has been restored for a specified period.

This is accomplished using dial-on-demand routing (DDR). When this is configured, a backup call is triggered by specified traffic.


Note Even if the backup interface comes out of standby mode (is brought up), the router does not trigger the backup call unless it receives the specified traffic for that backup interface.


Configuring Backup Interfaces

Perform these steps to configure your router with a backup interface, beginning in global configuration mode:

 
Command
Purpose

Step 1 

interface type number

Example:

Router(config)# interface atm 0
Router(config-if)#

Enters interface configuration mode for the interface for which you want to configure backup.

This can be a serial interface, ISDN interface, or asynchronous interface.

The example shows the configuration of a backup interface for an ATM WAN connection.

Step 2 

backup interface interface-type interface-number

Example:

Router(config-if)# backup interface bri 0
Router(config-if)#

Assigns an interface as the secondary, or backup interface.

This can be a serial interface or asynchronous interface. For example, a serial 1 interface could be configured to back up a serial 0 interface.

The example shows a Basic Rate Interface configured as the backup interface for the ATM 0 interface.

Step 3 

exit

Example:

Router(config-if)# exit
Router(config)#

Enters global configuration mode.

Floating Static Routes

Floating static routes provide alternative routes for traffic. Floating static routes are not activated unless a DDR backup call has been triggered by specified traffic for a backup interface.

Floating static routes are independent of line protocol status. This is an important consideration for Frame Relay circuits because the line protocol may not go down if the data-link connection identifier (DLCI) is inactive. Floating static routes are also encapsulation independent.


Note When static routes are configured, the primary interface protocol must go down in order to activate the floating static route.


Configuring Floating Static Routes

Static and dynamic routes are the two components of floating static routes. Perform these steps to configure the static and dynamic routes on your router, beginning in global configuration mode:

 
Command
Purpose

Step 1 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 
22.0.0.2
Router(config)#

Assigns the primary static route.

Step 2 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 
192.168.2.2 150
Router(config)#

Assigns the lower routing administrative distance value for the backup interface route. 192.168.2.2 is the peer IP address of the backup interface.

Step 3 

router rip

Example:

Router(config)# router rip
Router(config)#

Enables RIP routing.

Step 4 

network ip-address

Example:

Router(config)# network 22.0.0.0
Router(config)#

Defines the primary interface network. 22.0.0.0 is the network value of the primary interface.

Step 5 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 
192.168.2.2 150
Router(config)#

Assigns the lower routing administrative distance value for the backup interface route. 192.168.2.2 is the peer IP address of the backup interface.


Note When dynamic routes are being used, the time it takes to activate a floating static route depends on the routing protocol convergence times.


Dialer Watch

The dialer watch method only supports the Extended Interior Gateway Routing Protocol (EIGRP) link-state dynamic routing protocols.

Configuring Dialer Watch

Perform these steps to configure a dialer watch on your router, beginning in global configuration mode:

 
Command
Purpose

Step 1 

interface type number

Example:

Router(config)# interface dialer 2
Router(config-if)#

Enters configuration mode for the dial backup interface.

Step 2 

dialerwatch-group group-number

Example:

Router(config-if)# dialer watch-group 2
Router(config-if)#

Specifies the group number for the watch list.

Step 3 

exit

Example:

Router(config-if)# exit
Router(config)#

Enters global configuration mode.

Step 4 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 
22.0.0.2
Router(config)#

Assigns the primary route. 22.0.0.2 is the peer IP address of the primary interface.

Step 5 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance]

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 
192.168.2.2 150
Router(config)#

Assigns the lower routing administrative distance value for the backup interface route. 192.168.2.2 is the peer IP address of the backup interface.

Step 6 

dialerwatch-list group-number {ip ip-address address-mask | delay route-check initial seconds}

Example:

Router(config)# dialer watch-list 2 ip 
22.0.0.2 255.255.255.255
Router(config)#

Assigns an IP address to the watch list.

If the connection on the primary interface is lost and the IP address is unavailable on the router, the dial-out feature on the backup interface is triggered. 22.0.0.2 is the peer IP address of the primary interface.

Dial Backup Feature Limitations

The following limitations exist for the dial backup feature:

Bridging is not supported over console or auxiliary port backup interfaces.

For the Cisco 851 router, only dial-in capability is supported.

Dial backup support on the Cisco 871 router is limited because the Ethernet WAN interface is always up, even when ISP connectivity is down on the other side of the modem connected to the Cisco 871 router. The router must be in a PPPoE environment with the dialer watch feature running. The IP addresses of the peer must be specified in the dialer watch and the static route commands to enable dial backup when the primary line goes down.

Table 13-1 summarizes dial backup support and limitations for the Cisco 800 series access routers.

Table 13-1 Dial Backup Feature Support and Limitations Summary 

WAN Encapsulation Type
Dial Backup Possible?
Dial Backup Method
Limitations
Cisco 851 or 871

PPPoE

Yes

Dialer watch

Bridging is not supported across a slow interface, for example, an auxiliary port. The peer IP address of the ISP is needed to configure the dialerwatch command and the IP static route.

Normal IP in cable modem scenario

No

Dialer watch

The IP addresses of the peers are needed for dialer watch to work properly. If a lease time obtained by DHCP is not set short enough (1 or 2 minutes), dial backup will not be supported.

Cisco 876, 877, or 878

PPP over ATM

PPP over Ethernet

Yes

Backup interfaces

Floating static routes

Dialer watch

Floating static route and dialer watch need a routing protocol to run in the router. The dialer watch method brings up the backup interface as soon as the primary link goes down. The backup interface is brought down as soon as the dialer timeout is reached and the primary interface is up. The router checks the primary interface only when the dialer timeout expires. The backup interface remains up until the dialer timeout is reached, even though the primary interface is up.

For the dialer watch method, a routing protocol does not need to be running in the router, if the IP address of the peer is known.

RFC 1483 (AAL5, SNAP, and MUX)

Yes

Backup interfaces

Floating static routes

Dialer watch

If bridging is done through the WAN interface, it is not supported across the auxiliary port.


Configuration Example

The following three examples show sample configurations for the three dial backup methods.

Example 13-1 Configuring Dial Backup Using Backup Interfaces

!
vpdn enable
!
vpdn-group 1
 accept-dialin
 protocol pppoe
!
! Specifies the ISDN switch type
isdn switch-type basic-net3
!
interface vlan 1
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
! ISDN interface to be used as a backup interface
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
!
interface ATM0
 backup interface BRI0
 no ip address
 no atm ilmi-keepalive
 pvc 1/40
 encapsulation aal5snap
 pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. 
! Dialer pool 1 associates it with BRI0's dialer pool member 1.
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 30
 dialer string 384040
 dialer-group 1
!
! Primary interface associated with physical ATM0's interface. 
! Dialer pool 2 associates it with ATM0's dial-pool-number2.
interface Dialer2
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 2
 dialer-group 2
 no cdp enable
!
ip classless
! Primary and backup interface are given route metric
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
! Specifies interesting traffic to trigger backup ISDN traffic.
dialer-list 1 protocol ip permit

Example 13-2 Configuring Dial Backup Using Floating Static Routes

!
vpdn enable
!
vpdn-group 1
 accept-dialin
 protocol pppoe
!
! Specifies the ISDN switch type.
isdn switch-type basic-net3
!
interface vlan 1
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
! ISDN interface to be used as a backup interface.
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 1/40
 encapsulation aal5snap
 pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. 
! Dialer pool 1 associates it with BRI0's dialer pool member 1
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 30
 dialer string 384040
 dialer-group 1
!
! Primary interface associated with physical ATM0's interface. 
! Dialer pool 2 associates it with ATM0's dial-pool-number2.
interface Dialer2
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 2
 dialer-group 2
!
ip classless
no cdp enable
! Primary and backup interface are given route metric. (This example uses static routes, 
! thus atm0 line protocol must be brought down for backup interface to function.)
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 150
ip http server
!
! Specifies interesting traffic to trigger backup ISDN traffic.
dialer-list 1 protocol ip permit

Example 13-3 Configuring Dial Backup Using Dialer Watch

!
vpdn enable
!
vpdn-group 1
 accept-dialin
 protocol pppoe
!
! Specifies the ISDN switch type.
isdn switch-type basic-net3
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
! ISDN interface to be used as a backup interface.
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 1/40
 encapsulation aal5snap
 pppoe-client dial-pool-number 2
!
dsl operating-mode auto
!
! Dial backup interface, associated with physical BRI0 interface. 
! Dialer pool 1 associates it with BRI0's dialer pool member 1. 
! Note "dialer watch-group 1" associates a watch list with corresponding 
! "dialer watch-list" command.
interface Dialer0
 ip address negotiated
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 30
 dialer string 384040
 dialer watch-group 1
 dialer-group 1
!
! Primary interface associated with physical ATM0 interface. 
! Dialer pool 2 associates it with ATM0's dial-pool-number2.
interface Dialer2
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 2
 dialer-group 2
 no cdp enable
!
ip classless
!
! Primary and backup interface are given route metric.
ip route 0.0.0.0 0.0.0.0 22.0.0.2
ip route 0.0.0.0 0.0.0.0 192.168.2.2 80
ip http server
!
! Watch for interesting traffic.
dialer watch-list 1 ip 22.0.0.2 255.255.255.255
! Specifies interesting traffic to trigger backup ISDN traffic.
dialer-list 1 protocol ip permit
!

Configuring Dial Backup and Remote Management Through the Console or Auxiliary Port

When customer premises equipment, such as a Cisco 850 or Cisco 870 series router is connected to an ISP, an IP address is dynamically assigned to the router, or the IP address may be assigned by the router peer through the centrally managed function. The dial backup feature can be added to provide a failover route in case the primary line fails. Cisco 850 and Cisco 870 routers can use the auxiliary port for dial backup and remote management.


Note The cable modem environment is currently not supported.


Figure 13-1 shows the network configuration used for remote management access and for providing backup to the primary WAN line.

Figure 13-1 Dial Backup and Remote Management Through the Auxiliary Port

1

Cisco 850 or Cisco 870 series router

A

Main WAN link; primary connection to Internet service provider

2

Modem

B

Dial backup; serves as a failover link for Cisco 870 routers when primary line goes down

3

PC

C

Remote management; serves as dial-in access to allow changes or updates to Cisco IOS configurations


Configuration Tasks

Perform these steps to configure dial backup and remote management for these routers, beginning in global configuration mode:

 
Command
Purpose

Step 1 

ip name-server server-address

Example:

Router(config)# ip name-server 
192.168.28.12
Router(config)#

Enters your ISP DNS IP address.

Tip You may add multiple server addresses if available.

Step 2 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool 1
Router(config-dhcp)#

Creates a DHCP address pool on the router and enters DHCP pool configuration mode. The name argument can be a string or an integer.

Configure the DHCP address pool. For sample commands you can use in DHCP pool configuration mode, see the "Configuration Example" section.

Step 3 

exit

Example:

Router(config-dhcp)# exit
Router(config)#

Enters global configuration mode.

Step 4 

chat-script script-name expect-send

Example:

Router(config)# chat-script Dialout ABORT 
ERROR ABORT BUSY "" "AT" OK "ATDT 5555102 
T" TIMEOUT 45 CONNECT \c
Router(config)#

Configures a chat script used in dial-on-demand routing (DDR) to give commands to dial a modem and to log in to remote systems. The defined script is used to place a call over a modem.

Step 5 

interface type number

Example:

Router(config)# interface Async 1
Router(config-if)#

Creates and enters configuration mode for the asynchronous interface.

Configure the asynchronous interface. For sample commands you can use in async interface configuration mode, see the "Configuration Example" section.

Step 6 

exit

Example:

Router(config-if)# exit
Router(config)#

Enters global configuration mode.

Step 7 

interface type number

Example:

Router(config)# interface Dialer 3
Router(config-if)#

Enters interface configuration mode.

Step 8 

dialer watch-group group-number

Example:

Router(config-if)# dialer watch-group 1
Router(config-if)#

Specifies the group number for watch list.

Step 9 

exit

Example:

Router(config-if)# exit
Router(config)#

Enters global configuration mode.

Step 10 

ip nat inside source {list access-list-number} {interface type number | pool name} [overload]

Example:

Router(config)# ip nat inside source list 
101 interface Dialer 3 overload

Enables dynamic translation of addresses on the inside interface.

Step 11 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 
22.0.0.2
Router(config)#

Sets the IP route to point to the dialer interface as a default gateway.

Step 12 

access-list access-list-number {deny | permit} source [source-wildcard]

Example:

Router(config)# access-list 1 permit 
192.168.0.0 0.0.255.255 any

Defines an extended access list that indicates which addresses need translation.

Step 13 

dialerwatch-list group-number {ip ip-address address-mask | delay route-check initial seconds}

Example:

Router(config)# dialer watch-list 1 ip 
22.0.0.2 255.255.255.255
Router(config)#

Evaluates the status of the primary link, based on the existence of routes to the peer. 22.0.0.2 is the peer IP address of the ISP.

Step 14 

line [aux | console | tty | vty] line-number [ending-line-number]

Example:

Router(config)# line console 0
Router(config-line)#

Enters configuration mode for the line interface.

Step 15 

modem enable

Example:

Router(config-line)# modem enable
Router(config-line)#

Switches the port from console to auxiliary port function.

Step 16 

exit

Example:

Router(config-line)# exit
Router(config)#

Enters global configuration mode.

Step 17 

line [aux | console | tty | vty] line-number [ending-line-number]

Example:

Router(config)# line aux 0
Router(config)#

Enters configuration mode for the auxiliary interface.

Step 18 

flowcontrol {none | software [lock] [in | out] | hardware [in | out]}

Example:

Router(config)# flowcontrol hardware
Router(config)#

Enables hardware signal flow control.

Configuration Example

The following configuration example specifies an IP address for the ATM interface through PPP/IPCP address negotiation and dial backup over the console port.

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT 5555102\T"
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer pool-member 3
 async default routing
 async dynamic routing
 async mode dedicated
 ppp authentication pap callin
!
interface ATM0
 mtu 1492
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
 pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
! Primary WAN link.
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication pap callin
 ppp pap sent-username account password 7 pass
 ppp ipcp dns request
 ppp ipcp wins request
 ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
 ip address negotiated
 ip nat outside
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool 3
 dialer idle-timeout 60
 dialer string 5555102 modem-script Dialout
 dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup 
! has not timed out. Use multiple routes because peer IP addresses are alternated 
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated 
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available 
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
 match ip address 101
 match interface Dialer1
!
route-map secondary permit 10
 match ip address 103
 match interface Dialer3
!
! Change console to aux function.
line con 0
 exec-timedout 0 0
 modem enable
 stopbits 1
line aux 0
 exec-timeout 0 0
 ! To enable and communicate with the external modem properly.
 script dialer Dialout
 modem InOut
 modem autoconfigure discovery
 transport input all 
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
scheduler max-task-time 5000
end

Configuring Dial Backup and Remote Management Through the ISDN S/T Port

Cisco 876 and Cisco 878 routers can use the ISDN S/T port for remote management. With an advanced enterprise (c870-adventerprisek9-mz) image, a Cisco 876 router can also use the ISDN S/T port for dial backup.

Figure 13-2 and Figure 13-3 show two typical network configurations used to provide remote management access and backup for the primary WAN line. In Figure 13-2, the dial backup link goes through a customer premises equipment (CPE) splitter, a digital subscriber line access multiplexer (DSLAM), and a central office (CO) splitter before connecting to the ISDN switch. In Figure 13-3, the dial backup link goes directly from the Cisco router to the ISDN switch.

Figure 13-2 Dial Backup Through CPE Splitter, DSLAM, and CO Splitter

1

Cisco 876 or Cisco 878 router

A

Primary DSL interface

2

DSLAM

B

Dial backup and remote management through the ISDN interface (ISDN S/T port); serves as a failover link when the primary line goes down

3

ATM aggregator

4

ISDN switch

5

ISDN

C

Administrator remote management through the ISDN interface when the primary DSL link is down; serves as dial-in access to allow changes or updates to Cisco IOS configuration

6

ISDN peer router

7

Web server

8

Administrator


Figure 13-3 Dial Backup Directly from Router to ISDN Switch

1

PC

A

Primary DSL interface

2

Cisco 876 router

B

Dial backup and remote management through the ISDN interface (ISDN S/T port); serves as a failover link when the primary line goes down

3

DSLAM

4

Aggregator

5

ISDN switch

C

Administrator remote management through the ISDN interface when the primary DSL link is down; serves as dial-in access to allow changes or updates to Cisco IOS configuration

6

Web server

7

Administrator


Configuration Tasks

Perform the following tasks to configure dial backup and remote management through the ISDN S/T port of your router:

Configure ISDN Settings

Configure the Aggregator and ISDN Peer Router

Configure ISDN Settings


Note Traffic of interest must be present to activate the backup ISDN line by means of the backup interface and floating static routes methods. Traffic of interest is not needed for the dialer watch to activate the backup ISDN line.


Perform these steps to configure your router ISDN interface for use as a backup interface, beginning in global configuration mode:

 
Command
Purpose

Step 1 

isdn switch-type switch-type

Example:

Router(config)# isdn switch-type basic-net3
Router(config)#

Specifies the ISDN switch type.

The example specifies a switch type used in Australia, Europe, and the United Kingdom. For details on other switch types supported, see the Cisco IOS Dial Technologies Command Reference.

Step 2 

interface type number

Example:

Router(config)# interface bri 0
Router(config-if)#

Enters configuration mode for the ISDN Basic Rate Interface (BRI).

Step 3 

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp
Router(config-if)#

Sets the BRI0 interface encapsulation type.

Step 4 

dialer pool-member number

Example:

Router(config-if)# dialer pool-member 1
Router(config-if)#

Specifies the dialer pool membership.

Step 5 

isdn switch-type switch-type

Example:

Router(config-if)# isdn switch-type 
basic-net3
Router(config-if)#

Specifies the ISDN switch type.

Step 6 

exit

Example:

Router(config-if)# exit
Router(config)#

Enters global configuration mode.

Step 7 

interface dialer dialer-rotary-group-number

Example:

Router(config)# interface dialer 0
Router(config-if)#

Creates a dialer interface (numbered 0-255) and enters interface configuration mode.

Step 8 

ip address negotiated

Example:

Router(config-if)# ip address negotiated
Router(config-if)#

Specifies that the IP address for the interface is obtained through PPP/IPCP (IP Control Protocol) address negotiation. The IP address is obtained from the peer.

Step 9 

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp
Router(config-if)#

Sets the encapsulation type to PPP for the interface.

Step 10 

dialer pool number

Example:

Router(config-if)# dialer pool 1
Router(config-if)#

Specifies the dialer pool to be used.

In the example, the dialer pool 1 setting associates the dialer 0 interface with the BRI0 interface because the BRI0 dialer pool-member value is 1.

Step 11 

dialer string dial-string[:isdn-subaddress]

Example:

Router(config-if)# dialer string 384040
Router(config-if)#

Specifies the telephone number to be dialed.

Step 12 

dialer-group group-number

Example:

Router(config-if)# dialer group 1
Router(config-if)#

Assigns the dialer interface to a dialer group (1-10).

Step 13 

exit

Example:

Router(config-if)# exit
Router(config)#

Exits dialer 0 interface configuration mode, and enters global configuration mode.

Step 14 

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

Example:

Router(config)# dialer-list 1 protocol ip 
permit
Router(config)#

Creates a dialer list for packets of interest to be forwarded through the specified interface dialer group.

In the example, dialer-list 1 corresponds to dialer-group 1.

For details about this command and additional parameters that can be set, see the Cisco IOS Dial Technologies Command Reference.

Configure the Aggregator and ISDN Peer Router

The aggregator is typically a concentrator router where your Cisco router ATM PVC terminates. In the configuration example shown below, the aggregator is configured as a PPPoE server to correspond with the Cisco 876 router configuration example that is given in this chapter.

The ISDN peer router is any router that has an ISDN interface and can communicate through a public ISDN network to reach your Cisco router ISDN interface. The ISDN peer router provides Internet access for your Cisco router during the ATM network downtime.

! This portion of the example configures the aggregator.
vpdn enable
no vpdn logging
!
vpdn-group 1
 accept-dialin
 protocol pppoe
 virtual-template 1
!
interface Ethernet3
 description "4700ref-1"
 ip address 40.1.1.1 255.255.255.0
 media-type 10BaseT
!
interface Ethernet4
 ip address 30.1.1.1 255.255.255.0
 media-type 10BaseT
!
interface Virtual-Template1
 ip address 22.0.0.2 255.255.255.0
 ip mtu 1492
 peer default ip address pool adsl
!
interface ATM0
 no ip address
 pvc 1/40
 encapsulation aal5snap
 protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
! This portion of the example configures the ISDN peer.
isdn switch-type basic-net3
!
interface Ethernet0
 ip address 30.1.1.2 255.0.0.0 
!
interface BRI0
 description "to 836-dialbackup"
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
!
interface Dialer0
 ip address 192.168.2.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer string 384020
 dialer-group 1
 peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
!
dialer-list 1 protocol ip permit
!