Cisco Packaged Contact Center Enterprise Installation and Upgrade Guide, Release 10.0(x)
Network Design Considerations
Downloads: This chapterpdf (PDF - 1.41MB) The complete bookPDF (PDF - 4.0MB) | The complete bookePub (ePub - 806.0KB) | Feedback

Network Design Considerations

Network Design Considerations

This chapter provides guidance on performing the network configuration needed to deploy Packaged CCE on UCS servers. It includes information on fault tolerance and redundancy.

Network Requirements for Cisco UCS C-Series Servers

The illustration below shows the reference design for all Packaged CCE deployments on UCS C-series servers and the network implementation of the vSphere vSwitch design.

This design calls for using the VMware NIC Teaming (without load balancing) of virtual machine network interface controller (vmnic) interfaces in an Active/Standby configuration through alternate and redundant hardware paths to the network.

The network side implementation does not have to exactly match this illustration, but it must allow for redundancy and must not allow for single points of failure affecting both Visible and Private network communications.


Note


The customer also has the option, at their discretion, to configure VMware NIC Teaming on the Management vSwitch on the same or separate switch infrastructure in the data center.


Requirements:

  • Ethernet interfaces must be Gigabit speed and connected to Gigabit Ethernet switches. 10/100 Ethernet is not supported.
  • No single point of failure is allowed for visible and private networks.
  • Network switch infrastructure cannot use Cisco Stacking technology to combine all switches to which the UCS C-Series server is connected into a single virtual switch.
  • Network switches must be configured properly for connection to VMware. Refer to the VMware Knowledge Base for details on ensuring proper switch configuration to prevent Spanning Tree Protocol (STP) delay in failover/fallback scenarios.

Bandwidth Provisioning and Network QoS Considerations

Your Wide Area Network must support QoS. For details, refer to the Bandwidth Provisioning and QoS considerations section in the Cisco Unified Contact Center Enterprise Design Guide: http:/​/​www.cisco.com/​en/​US/​partner/​products/​sw/​custcosw/​ps1844/​products_​implementation_​design_​guides_​list.html.

Data Center Switch Configuration for UCS C-Series Server Ethernet Uplinks

Reference and required design for UCS C-Series server Packaged CCE Visible and Private networks Ethernet uplinks uses the VMware default of IEEE 802.1Q (dot1q) trunking, which is referred to as the Virtual Switch VLAN Tagging (VST) mode. This design requires that specific settings be used on the uplink data center switch, as described in the example below.

Improper configuration of up-link ports can directly and negatively impact system performance, operation, and fault handling.


Note


All VLAN settings are given for example purposes. Customer VLANs may vary according to their specific network requirements.


Example: Virtual Switch VLAN Tagging

    C3750-A1

    interface GigabitEthernet1/0/1
      description PCCE_Visible_A_Active
      switchport trunk encapsulation dot1q
      switchport trunk allowed vlan 10
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk

    interface GigabitEthernet1/0/2
      description PCCE_Private_A_Standby
      switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 100
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk

    C3750-A2

    interface GigabitEthernet1/0/1
      description PCCE_Visible_A_Standby
      switchport trunk encapsulation dot1q
      switchport trunk allowed vlan 10
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk

    interface GigabitEthernet1/0/2
      description PCCE_Private_A_Active
      switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 100
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk


    C3750-B1

    interface GigabitEthernet1/0/1
      description PCCE_Visible_B_Active
      switchport trunk encapsulation dot1q
      switchport trunk allowed vlan 20
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk

    interface GigabitEthernet1/0/2
      description PCCE_Private_A_Standby
      switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 200
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk

    C3750-B2

    interface GigabitEthernet1/0/1
      description PCCE_Visible_B_Standby
      switchport trunk encapsulation dot1q
      switchport trunk allowed vlan 20
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk

    interface GigabitEthernet1/0/2
      description PCCE_Private_B_Active
      switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 200
      switchport mode trunk
      switchport nonegotiate
      spanning-tree portfast trunk 

Note


  • ESXi supports dotlq only.
  • DTP is not supported.

VMware vSwitch Design for Cisco UCS C-Series Servers

This figure illustrates a configuration for the vSwitches and vmnic adapters on a UCS C-Series server using the redundant Active/Standby vSwitch NIC Teaming design. The configuration is the same for the Side A server and the Side B server.

Configure the ESXi Host Network for the Virtual Machines

To configure the network for VMs, you create a virtual switch connected to an Ethernet port on the server, and then associate the virtual machine's network adapter to this virtual switch. Perform the following procedure to create vSwitches for the public and private networks on the Side A and B servers, referring to the illustration above as an example.

Procedure
    Step 1   Add a vSwitch as follows:
    1. Login to the ESXi host using VMware Infrastructure Client.
    2. Select the ESXi host.
    3. Click the Configuration tab.
    4. Under Hardware, click Networking.
    5. Click Add Networking...
    6. Select Connection Type >Virtual Machine. Then click Next.
    7. Select Create a vSphere standard switch and select an associated a VM nic. Be sure to reference the figures in this section to ensure you are aware of which physical VM NIC you're associating with the vSwitch.
    8. Under Port Group Properties, enter Network Label: VM X, where X describes the network. For example, the UCCE Public or UCCE Private network as illustrated in the figure above.
    9. Click Next. Then click Finish.
    Step 2   Associate a VM Network Adapter to Network Connection as follows:
    1. Click Edit virtual machine settings.
    2. Select the Network Adapter.
    3. Select a virtual switch from the Network Connection/network label (must be "UCCE Public" or "UCCE Private").

      If your switchports are using VLANs, enter the VLAN id in the VLAN ID field.

    4. Click OK.

    Link Speed Considerations

    Configuring the speed and duplex of a network link is essential for reliable network operation.

    While VMware allows for fixed 1000/Full to be set on the Host and the Switch, use Auto/Auto on both ends. Manually configuring 1000/Full on the Host requires Host configuration steps that are not detailed here and are not exposed in VMware.


    Note


    Refer to this article on the VMware Knowledge Base: Configuring the speed and duplex of an ESXi/​ESX host network adapter.