Cisco Nexus 6000 Series NX-OS Layer 2 Interfaces Command Reference
I Commands
Downloads: This chapterpdf (PDF - 243.0KB) The complete bookPDF (PDF - 2.99MB) | Feedback

I Commands

Table Of Contents

I Commands

install certificate

install feature-set virtualization

instance vlan

interface ethernet

interface ethernet (Layer 3)

interface loopback

interface mgmt

interface port-channel

interface vethernet

interface vlan

ip igmp snooping (EXEC)

ip igmp snooping (VLAN)


I Commands


This chapter describes the Cisco NX-OS Ethernet and virtual Ethernet commands that begin with I.

install certificate

To install a certificate that is used to connect to a vCenter Server, use the install certificate command. To remove a certificate, use the no form of this command.

install certificate {bootflash:[//server/] | default}

no install certificate

Syntax Description

bootflash:[//server/]

Specifies the source or destination URL for boot flash memory to install the certificate. The server argument value is module-1, sup-1, sup-active, or sup-local.

default

Specifies the default path.


Command Default

None

Command Modes

SVS connection configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

This command does not require a license.

Examples

This example shows how to install a certificate to the boot flash memory:

switch# configure terminal
switch(config)# svs connection SVSConn
switch(config-svs-conn)# install certificate bootflash:///
switch(config-svs-conn)#
 
   

This example shows how to remove a certificate:

switch# configure terminal
switch(config)# svs connection SVSConn
switch(config-svs-conn)# no install certificate
switch(config-svs-conn)#
 
   

Related Commands

Command
Description

show svs connections

Displays SVS connection information.

svs connection

Enables an SVS connection.


install feature-set virtualization

To install the Cisco virtual machine feature set on the switch, use the install feature-set virtualization command. To remove the Cisco virtual machine feature set, use the no form of this command.

install feature-set virtualization

no install feature-set virtualization

Syntax Description

This command has no arguments or keywords.

Command Default

Disabled

Command Modes

Global configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines


Note The Cisco virtual machine feature is supported only on the Cisco Nexus 5500 Series switches.


This command requires an Enhanced Layer 2 license.

Examples

This example shows how to install the Cisco virtual machine feature set on the switch:

switch# configure terminal
switch(config)# install feature-set virtualization
switch(config)# 
 
   

Related Commands

Command
Description

feature vmfex

Enables or disables Cisco Virtual Machine Fabric Extender (VM-FEX) on the switch.

feature-set virtualization

Enables the Cisco virtual machine feature set on the switch.

show feature-set

Displays the status of the virtualization feature set.

show running-config

Displays the running system configuration information.


instance vlan

To map a VLAN or a set of VLANs to a Multiple Spanning Tree instance (MSTI), use the instance vlan command. To delete the instance and return the VLANs to the default instance (Common and Internal Spanning Tree [CIST]), use the no form of this command.

instance instance-id vlan vlan-id

no instance instance-id [vlan vlan-id]

Syntax Description

instance-id

Instances to which the specified VLANs are mapped. The range is from 0 to 4094.

vlan vlan-id

Specifies the number of the VLANs that you are mapping to the specified MSTI. The VLAN ID range is from 1 to 4094.


Command Default

No VLANs are mapped to any MST instance (all VLANs are mapped to the CIST instance).

Command Modes

MST configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

The VLAN identifier is entered as a single value or a range.

The mapping is incremental, not absolute. When you enter a range of VLANs, this range is added to or removed from the existing instances.

Any unmapped VLAN is mapped to the CIST instance.


Caution When you change the VLAN-to-MSTI mapping, the system restarts MST.

Examples

This example shows how to map a range of VLANs to MSTI 4:

switch(config)# spanning-tree mst configuration 
switch(config-mst)# instance 4 vlan 100-200 
 
   

Related Commands

Command
Description

show spanning-tree mst configuration

Displays information about the MST protocol.

spanning-tree mst configuration

Enters MST configuration mode.


interface ethernet

To enter interface configuration mode for an Ethernet IEEE 802.3 interface, use the interface ethernet command.

interface ethernet [chassis_ID/] slot/[QSFP-module/]port

Syntax Description

chassis_ID

(Optional) Specifies the Fabric Extender chassis ID. The chassis ID is from 100 to 199.

Note This argument is not optional when addressing the host interfaces of a Cisco Nexus 2000 Series Fabric Extender.

slot

Slot from 1 to 8. The following list defines the slots available:

Slot 1 to 4 are fixed Linecard Expansion Modules (LEMs).

Slot 5 to 8 are hot-swappable LEMs.

QSFP-module

The Linecard Expansion Module that has been set to 10G mode. The

QSFP-module number is 1 to 199.

port

Port number within a particular slot. The port number is from 1 to 128.


Command Default

None

Command Modes

Global configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Examples

This example shows how to enter configuration mode for Ethernet interface 1/4:

switch(config)# interface ethernet 1/4 
switch(config-if)# 
 
   

This example shows how to enter configuration mode for a host interface on a Fabric Extender:

switch(config)# interface ethernet 101/1/1 
switch(config-if)# 
 
   

Related Commands

Command
Description

interface vethernet

Configures a virtual Ethernet interface.

show fex

Displays all configured Fabric Extender chassis connected to the switch.

show interface ethernet

Displays various parameters of an Ethernet IEEE 802.3 interface.

speed

Sets the speed on the interface.

vtp (interface)

Enables VLAN Trunking Protocol (VTP) on an interface.


interface ethernet (Layer 3)

To configure a Layer 3 Ethernet IEEE 802.3 routed interface, use the interface ethernet command.

interface ethernet [chassis_ID/] {slot/[QSFP-module/]port[.subintf-port-no]}

Syntax Description

chassis_ID

(Optional) Specifies the Fabric Extender chassis ID. The chassis ID is from 100 to 199.

Note This argument is not optional when addressing the host interfaces of a Cisco Nexus 2000 Series Fabric Extender.

slot

Slots from 1 to 8. The following list defines the slots available:

Slots 1 to 4 are fixed Linecard Expansion Modules (LEMs).

Slots 5 to 8 are hot-swappable LEMs.

QSFP-module

Specifies the Linecard Expansion Module (LEM) that has been set to 10G

mode.

port

Port number within a particular slot. The port number is from 1 to 128.

.

(Optional) Specifies the subinterface separator.

subintf-port-no

(Optional) Port number for the subinterface. The range is from 1 to 48.


Command Default

None

Command Modes

Global configuration mode
Interface configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

You must use the no switchport command in the interface configuration mode to configure the interface as a Layer 3 routed interface. When you configure the interface as a Layer 3 interface, all Layer 2 specific configurations on this interface are deleted.

Use the switchport command to convert a Layer 3 interface into a Layer 2 interface. When you configure the interface as a Layer 2 interface, all Layer 3 specific configurations on this interface are deleted.

Examples

This example shows how to enter configuration mode for a Layer 3 Ethernet interface 1/5:

switch(config)# interface ethernet 1/5 
switch(config-if)# no switchport 
switch(config-if)# ip address 10.1.1.1/24 
switch(config-if)# 
 
   

This example shows how to configure a Layer 3 subinterface for Ethernet interface 1/5 in the global configuration mode:

switch(config)# interface ethernet 1/5.2 
switch(config-if)# no switchport 
switch(config-subif)# ip address 10.1.1.1/24 
switch(config-subif)# 
 
   

This example shows how to configure a Layer 3 subinterface in interface configuration mode:

switch(config)# interface ethernet 1/5 
switch(config-if)# no switchport 
switch(config-if)# interface ethernet 1/5.1 
switch(config-subif)# ip address 10.1.1.1/24 
switch(config-subif)# 
 
   

This example shows how to convert a Layer 3 interface to a Layer 2 interface:

switch(config)# interface ethernet 1/5 
switch(config-if)# no switchport 
switch(config-if)# ip address 10.1.1.1/24 
switch(config-if)# switchport
switch(config-if)# 
 
   

Related Commands

Command
Description

bandwidth

Sets the bandwidth parameters for an interface.

delay

Configures the interface throughput delay value.

encapsulation

Sets the encapsulation type for an interface.

ip address

Sets a primary or secondary IP address for an interface.

inherit

Assigns a port profile to an interface.

interface vethernet

Configures a virtual Ethernet interface.

no switchport

Configures an interface as a Layer 3 interface.

service-policy

Configures a service policy for an interface.

show fex

Displays all configured Fabric Extender chassis connected to the switch.

show interface ethernet

Displays various parameters of an Ethernet IEEE 802.3 interface.


interface loopback

To create a loopback interface and enter interface configuration mode, use the interface loopback command. To remove a loopback interface, use the no form of this command.

interface loopback number

no interface loopback number

Syntax Description

number

Interface number; valid values are from 0 to 1023.


Command Default

None

Command Modes

Global configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

Use the interface loopback command to create or modify loopback interfaces.

From the loopback interface configuration mode, the following parameters are available:

description—Provides a description of the purpose of the interface.

ip—Configures IP features, such as the IP address for the interface, Address Resolution Protocol (ARP) attributes, load balancing, Unicast Reverse Path Forwarding (RPF) or IP Source Guard.

logging—Configure logging of events.

shutdown—Shut down traffic on the interface.

This command does not require a license.

Examples

This example shows how to create a loopback interface:

switch(config)# interface loopback 50 
switch(config-if)# ip address 10.1.1.1/24
switch(config-if)# 
 
   

Related Commands

Command
Description

show interface loopback

Displays information about the traffic on the specified loopback interface.


interface mgmt

To enter the management interface configuration mode, use the interface mgmt command.

interface mgmt mgmt-intf-num

Syntax Description

mgmt-intf-num

Management interface number. The interface number is 0.


Command Default

None

Command Modes

Global configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Examples

This example shows how to enter the management interface configuration mode:

switch# configure terminal
switch(config)# interface mgmt 0
switch(config-if)# 
 
   

Related Commands

Command
Description

show interface mgmt

Displays information about the management interface.

cdp enable

Enables the Cisco Discovery Protocol (CDP) on an interface.

description (interface)

Adds a description to an interface configuration.

duplex

Configures the duplex mode for an interface.

lldp (interface)

Enables the reception or transmission of Link Layer Discovery Protocol (LLDP) packets on an interface.

rate-limit cpu direction

Configures the packet per second (PPS) rate limit for an interface.

snmp trap link-status

Enables Simple Network Management Protocol (SNMP) link trap generation on an interface.

speed

Configures the transmit and receive speed for an interface.

vrf member

Adds an interface to a virtual routing and forwarding (VRF) instance.


interface port-channel

To create an EtherChannel interface and enter interface configuration mode, use the interface port-channel command. To remove an EtherChannel interface, use the no form of this command.

interface port-channel channel-number[.subintf-channel-no]

no interface port-channel channel-number[.subintf-channel-no]

Syntax Description

channel-number

Channel number that is assigned to this EtherChannel logical interface. The range is from 1 to 4096.

.

(Optional) Specifies the subinterface separator.

Note Applies to Layer 3 interfaces.

subintf-channel-no

(Optional) Port number of the EtherChannel subinterface. The range is from 1 to 4093.

Note Applies to Layer 3 interfaces.


Command Default

None

Command Modes

Global configuration mode
Interface configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

A port can belong to only one channel group.

When you use the interface port-channel command for Layer 2 interfaces, follow these guidelines:

If you are using CDP, you must configure it only on the physical interface and not on the EtherChannel interface.

If you do not assign a static MAC address on the EtherChannel interface, a MAC address is automatically assigned. If you assign a static MAC address and then later remove it, the MAC address is automatically assigned.

The MAC address of the EtherChannel is the address of the first operational port added to the channel group. If this first-added port is removed from the channel, the MAC address comes from the next operational port added, if there is one.

You must use the no switchport command in the interface configuration mode to configure the EtherChannel interface as a Layer 3 interface. When you configure the interface as a Layer 3 interface, all Layer 2 specific configurations on this interface are deleted.

Use the switchport command to convert a Layer 3 EtherChannel interface into a Layer 2 interface. When you configure the interface as a Layer 2 interface, all Layer 3 specific configurations on this interface are deleted.

You can configure one or more subinterfaces on a port channel made from routed interfaces.

Examples

This example shows how to create an EtherChannel group interface with channel-group number 50:

switch(config)# interface port-channel 50 
switch(config-if)# 
 
   

This example shows how to create a Layer 3 EtherChannel group interface with channel-group number 10:

switch(config)# interface port-channel 10 
switch(config-if)# no switchport 
switch(config-if)# ip address 192.0.2.1/24 
switch(config-if)#
 
   

This example shows how to configure a Layer 3 EtherChannel subinterface with channel-group number 1 in interface configuration mode:

switch(config)# interface port-channel 10 
switch(config-if)# no switchport 
switch(config-if)# interface port-channel 10.1 
switch(config-subif)# ip address 192.0.2.2/24 
switch(config-subif)#
 
   

This example shows how to configure a Layer 3 EtherChannel subinterface with channel-group number 20.1 in global configuration mode:

switch(config)# interface port-channel 20.1 
switch(config-subif)# ip address 192.0.2.3/24 
switch(config-subif)#
 
   

Related Commands

Command
Description

encapsulation

(Layer 3 interfaces) Sets the encapsulation type for an interface.

ip address

(Layer 3 interfaces) Sets a primary or secondary IP address for an interface.

no switchport

(Layer 3 interfaces) Configures an interface as a Layer 3 interface.

show interface

Displays configuration information about interfaces.

show lacp

Displays LACP information.

show port-channel summary

Displays information on the EtherChannels.

vtp (interface)

Enables VLAN Trunking Protocol (VTP) on an interface.


interface vethernet

To enter interface configuration mode for a virtual Ethernet (vEth) interface, use the interface vethernet command. To remove a virtual Ethernet interface, use the no form of this command.

interface vethernet veth-id[, vethernet veth-id, ...]

no interface vethernet veth-id[, vethernet veth-id, ...]

Syntax Description

veth-id

Virtual Ethernet interface number. The range is from 1 to 1,048,575.

You can specify more than one virtual Ethernet interface. Make sure you use the comma (,) separator.


Command Default

None

Command Modes

Global configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

Before you use a virtual Ethernet interface, you must enable the Cisco Virtual Machine Fabric Extender (VM-FEX) on the switch by using the feature vmfex command.

You must configure a virtual Ethernet interface on each switch. The configuration in the secondary switch must be identical to that of the primary switch.

You can create a maximum of 1000 virtual Ethernet interfaces on a Cisco Nexus 5548 switch. Before you disable Adapter-FEX on the switch, make sure that you delete these interfaces. After you delete a virtual Ethernet interface, make sure that you save the running configuration of the switch to the startup configuration file.

Examples

This example shows how to enter configuration mode for virtual Ethernet interface 10:

switch# configure terminal
switch(config)# interface vethernet 10
switch(config-if)# 
 
   

This example shows how to enter configuration mode for multiple virtual Ethernet interfaces:

switch# configure terminal
switch(config)# interface vethernet 10, vethernet 2
switch(config-if-range)# 
 
   

This example shows how to bind an interface, configure a vEthernet access interface, assign the access VLAN for that interface, and then assign a port profile named ppVEth, and a class of service (CoS) value 3 to a virtual Ethernet interface:

switch# configure terminal
switch(config)# port-profile type vethernet ppVEth
switch(config-port-prof)# switchport mode access
switch(config-port-prof)# service-policy type qos input my_policy1
switch(config-port-prof)# exit
switch(config)# interface vethernet 10
switch(config-if)# bind interface ethernet 1/5 channel 10
switch(config-if)# inherit port-profile ppVEth
switch(config-if)# untagged cos 3
switch(config-if)#
 
   

This example shows how to remove a virtual Ethernet interface:

switch# configure terminal
switch(config)# no interface vethernet 2
switch(config)# 
 
   

Related Commands

Command
Description

bind

Binds an interface to a virtual Ethernet interface.

feature vmfex

enables VM-FEX on the switch.

port-profile

Configures a port profile.

show interface ethernet

Displays information about Ethernet interfaces.

show interface vethernet

Displays various parameters of a virtual Ethernet interface.

show running-config interface

Displays the running configuration of an interface.

vethernet auto-create

Sets the default policy to enable auto creation of virtual Ethernet interfaces.


interface vlan

To create a VLAN interface and enter interface configuration mode, use the interface vlan command. To remove a VLAN interface, use the no form of this command.

interface vlan vlan-id

no interface vlan vlan-id

Syntax Description

vlan-id

VLAN to set when the interface is in access mode; valid values are from 1 to 4094, except for the VLANs reserved for the internal switch use.


Command Default

None

Command Modes

Global configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

Before you use this command, enable the interface-vlan feature by using the feature interface-vlan command.

Use the interface vlan command to create or modify VLAN interfaces.

The VLAN interface is created the first time that you enter the interface vlan command for a particular VLAN. The vlan-id argument corresponds to the VLAN tag that is associated with the data frames on an IEEE 802.1Q-encapsulated trunk, or the VLAN ID that is configured for an access port.

This command does not require a license.

Examples

This example shows how to create a VLAN interface for VLAN 50:

switch(config)# interface vlan 50
switch(config-if)#
 
   

Related Commands

Command
Description

feature interface-vlan

Enables the ability to create VLAN interfaces.

show interface vlan

Displays information about the traffic on the specified VLAN interface.


ip igmp snooping (EXEC)

To enable Internet Group Management Protocol (IGMP), use the ip igmp snooping command. To disable IGMP snooping, use the no form of this command.

ip igmp snooping

no ip igmp snooping

Syntax Description

This command has no arguments or keywords.

Command Default

IGMP snooping is enabled.


Note If the global setting is disabled, then all VLANs are treated as disabled, whether they are enabled or not.


Command Modes

EXEC mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Examples

This example shows how to enable IGMP snooping:

switch# ip igmp snooping 
 
   

Related Commands

Command
Description

show ip igmp snooping

Displays IGMP snooping information and configuration.


ip igmp snooping (VLAN)

To configure Internet Group Management Protocol (IGMP) on a VLAN, use the ip igmp snooping command. To negate the command or return to the default settings, use the no form of this command

ip igmp snooping parameter

no ip igmp snooping parameter

Syntax Description

parameter

Parameter to configure. See the "Usage Guidelines" section for additional information.


Command Default

The default settings are as follows:

explicit-tracking—enabled

fast-leave—disabled for all VLANs

last-member-query-interval seconds—1

querier IP-address—disabled

report-suppression—enabled

Command Modes

VLAN configuration mode

Command History

Release
Modification

6.0(2)N1(1)

This command we introduced.


Usage Guidelines

Table 1 lists the valid values for parameter.

Table 1 IGMP Snooping Parameters 

Keyword and Argument
Description

explicit-tracking

Enables tracking IGMPv3 membership reports for each port on a per-VLAN basis. The default is enabled on all VLANs.

fast-leave

Enables IGMPv3 snooping fast-leave processing. The default is disabled for all VLANs.

last-member-query-interval seconds

Removes the group if no hosts respond to an IGMP query message. Valid value is from 1 to 25 seconds. The default is 1 second.

mrouter interface interface

Configures a static connection to a multicast router. The specified interface is Ethernet or EtherChannel.

querier IP-address

Configures a snooping querier. The IP address is used as the source in messages. The default is disabled.

report-suppression

Limits the membership report traffic sent to multicast-capable routers. When you disable report suppression, all IGMP reports are sent as is to multicast-capable routers. The default is enabled.

static-group group-ip-addr [source source-ip-addr] interface interface

Configures an interface belonging to a VLAN as a static member of a multicast group. The specified interface is Ethernet or EtherChannel, or virtual Ethernet.


Examples

This example shows how to configure IGMP snooping parameters for VLAN 5:

switch# configure terminal
switch(config)# vlan 5
switch(config-vlan)# ip igmp snooping last-member-query-interval 3
switch(config-vlan)# ip igmp snooping querier 192.168.2.106
switch(config-vlan)# ip igmp snooping explicit-tracking
switch(config-vlan)# ip igmp snooping fast-leave
switch(config-vlan)# ip igmp snooping report-suppression
switch(config-vlan)# ip igmp snooping mrouter interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 192.0.2.1 interface ethernet 1/10
switch(config-vlan)# ip igmp snooping static-group 192.0.2.12 interface vethernet 4/1
switch(config-vlan)#
 
   

Related Commands

Command
Description

show ip igmp snooping

Displays the IGMP snooping information and configuration.